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Introduction
This chapter contains the following topics:
•
•
•
•
•
•
•

Getting the Most Out of SlickEdit®
New Features and Enhancements
Documentation
Supported Languages and Environments
Installation
Startup and Exit
Product Support
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Getting the Most Out of SlickEdit®
At SlickEdit, our belief is that it’s the code that really matters. We are a company of power programmers
working to develop the tools that power programmers demand—tools that provide the best editing
capabilities to help you write your code the way you want.
We take great pride in delivering unparalleled power, speed, and flexibility to our customers. Our goal is to
remove the tedious tasks involved with programming, allowing you to focus on the reason you first got into
programming: the thrill of writing great code.

Learn About Our Cool Features
SlickEdit® contains the most powerful and comprehensive set of features available in any editor. Many are
unique to SlickEdit. To see a list of features we think are particularly cool, click Help > Cool Features from
the SlickEdit main menu. Each feature is described and you can watch a short demo of the feature in
action.

Write More Code, Faster
The keys to programming efficiency are the same in SlickEdit® as any other editor. These strategies will
help you write more code, faster than you ever have before:
•

Keep your hands on the keyboard - Time is wasted each time you reach for the mouse.
SlickEdit contains 13 editor emulations with predefined key bindings that are ready for use in
performing common tasks. Define your own key bindings or invoke editor operations from the
SlickEdit command line. For more information, see Using the Mouse and Keyboard.

•

Type as little as possible - SlickEdit contains many features that reduce the number of
keystrokes you type, including: completions, syntax expansion, aliases, macros, code templates,
and code generators. For information about these features, see the topics in the Editing Features
chapter.

•

Rapidly navigate code - Instantly jump from a symbol to its definition or view a list of references.
Preview definitions for the current symbol without having to open the file. Use bookmarks to mark
important locations in the code. SlickEdit includes powerful browsers and search capabilities,
allowing you to quickly find the code you want. See Navigation for more information.

•

Access information quickly - SlickEdit uses visual indicators to provide you with information
about your code, including syntax highlighting and color coding. Special tool windows are also
available for viewing information about files, classes, symbols, definitions, and more. To learn
more, see Toolbars and Tool Windows, Symbol Browsing and the Editing Features chapter.

•

Let SlickEdit do the formatting - Syntax indenting, SmartPaste®, and code beautifiers are just a
few of the automatic formatting features in SlickEdit. For more information, see the topics in the
Editing Features chapter.

•

Utilize utilities - SlickEdit provides many utilities for working with your code, such as DIFFzilla®,
3-Way Merge, Spell Check, FTP, a RegEx Evaluator, math commands, and even a calculator. See
the topics in the Tools and Utilities chapter for more information.

•

Integrate to other tools - SlickEdit integrates with other tools to make your world complete,
including source control systems, compilers, debuggers, profilers, and analyzers. See Tools and
Utilities for more information.
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Use the Quick Start to Get Started
Be sure to check out the Quick Start guide. It contains a short list of common user preference settings and
describes how to quickly create a workspace and project, so you can get up and running in no time.

Register Your Product
Registering your product allows SlickEdit to provide you with automatic notification of free updates and
new releases, and enters your name into a weekly drawing for a SlickEdit gift pack. To register your
product from within SlickEdit®, from the main menu, click Help > Register Product, then follow the steps
indicated.

Get Maintenance & Support
Subscribe to Maintenance and Support Service to receive the following benefits:
•

Unlimited technical support via telephone or e-mail for 12 months.

•

Access to new releases, upgrades, and fixes at no additional charge.

•

The ability to participate in SlickEdit® beta programs and receive a free copy of SlickEdit beta
software as a preview of the next release.

To check the status of your Maintenance and Support Service from within SlickEdit, click the menu item
Help > Check Maintenance. This will launch the SlickEdit Maintenance and Support Web page in a
browser, showing the status of your service.
To subscribe to Maintenance and Support Service or learn more, contact SlickEdit Sales
(sales@slickedit.com).
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New Features and Enhancements
This section describes the new features and enhancements in SlickEdit® 2008.

Message List
Message List is a feature that shows output messages from processes running in SlickEdit®, such as build
warnings and errors. Messages are automatically displayed in the Message List tool window, docked in the
bottom tab group of the editor by default. The tool window shows messages in tabular format, with columns
for the message type (warning, error, etc.), source file and line number associated with the message, a
description, the creator of the message (Build, Java Live Errors, XML validation, etc.), and the date.
Messages can be filtered and sorted. You can clear the tool window of all messages, or clear only
messages with a certain creator or type.
Messages are associated with a location in the code. When the cursor is on a line with an error or warning,
the corresponding message in the Message List is highlighted. You can also navigate to the message in
the source code from within the Message List by double-clicking on it (or right-click on a selected message
and click Go to code location).
See Message List for more information on this feature.

New Options Dialog
One of the main advantages of SlickEdit® is its vast configurability. To make options and settings more
accessible, a new Options dialog is available. The Options dialog combines all of the individual options
dialogs formerly used to configure SlickEdit, including dialogs previously on the Tools > Options menu.
The options have been sorted into new categories which are presented as nodes in a tree. Click on the
nodes to view individual options, which are displayed in embedded forms or in tabular format.
The new Options dialog provides the following features:
•
•
•
•

Navigation buttons to jump to previously viewed options pages.
An incremental search function to find options that contain specific text.
A way to mark frequently used options pages as “favorites” for quicker access.
An Options History feature to see which options have been changed and when.

To access the Options dialog, from the main menu, click Tools > Options, or use the config command on
the SlickEdit command line. See Options Dialog for more information.

Enhancements to Installed Language Support
Language-specific options are now accessed from the Languages node of the new Options dialog (Tools
> Options > Languages). The options are categorized by language type and language. For example, to
access C/C++ or Java options, expand the Application Languages node. Under each language, the
options are further categorized by type (General, Indent, View, etc.).
TIP A shortcut method to access language-specific options for the current buffer is to use the
Document > [Language] Options menu item (or the setupext command).
The option categories are the same for each language while the particular settings are unique to each
language. Some languages do not support all option categories or options, and some include additional
options that are not available in other languages. See Language Options for more information.
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Installed language support has also been enhanced to add a layer of indirection between physical file
extensions and language associations, providing more flexibility with extension mapping. Previously, file
extensions could only be mapped to their native language, for example, the “m” extension could not mean
anything other than Objective-C. Now you can remap extensions to a completely different language very
easily, without hiding or removing support for the native language.
Languages and file extensions are now managed through the Language Manager and File Extension
Manager screens of the Options dialog (Tools > Options > Languages). See Managing Languages and
Managing File Extensions for more information.

Adaptive Formatting
Many development teams set standards for code formatting styles. These standards often vary from
project to project or between languages. In this environment, you can lose valuable time in having to
change configurations, set/unset options, or run beautifiers from file to file just so you can meet the team’s
requirements.
Adaptive Formatting addresses these situations by scanning a file for the formatting styles in use, and
automatically matching those settings for the current editing session. This provides seamless integration of
new code with existing code, making it easier to read—not only for you, but for the next person who needs
to edit the file.
Adaptive Formatting is enabled by default and recognizes indentation and tab style settings, parentheses
padding, and begin/end style settings. It also recognizes case settings, such as keyword casing for caseinsensitive languages, and tag, attribute, and value casing for HTML-based languages. To configure what
settings are recognized or to disable the feature, use the language-specific Adaptive Formatting options
page (Tools > Options > Languages > [LanguageCategory] > [Language] > Adaptive Formatting).
See Adaptive Formatting to learn more about this feature.

Quick Brace/Unbrace
Quick Brace makes it easy to convert single line statements into a brace-enclosed blocks so you can add
new lines without having to manually position the cursor and type extra keystrokes. Quick Brace attempts
to honor your brace style and indent settings.
To use Quick Brace, position the cursor where you would normally type the open brace, and type the open
brace. SlickEdit® automatically moves the child statement to the next line (if the statement was contained
on one line), indents it according to your indent preferences, and inserts the closing brace according to
your brace style preferences.
Unbrace does the opposite of Quick Brace, removing the braces from a brace-enclosed block that contains
a single line statement and moving the statement to the preceding line that contains the parent statement
(unless it is just too long). To use Unbrace, simply delete the opening brace.
This feature set is on by default and can be enabled/disabled on a language-specific basis through the
Formatting Options screen (Tools > Options > Languages > [LanguageCategory] > [Language] >
[Language] Formatting Options). See Quick Brace/Unbrace for more information.

Perl Regular Expressions
SlickEdit® now supports the Perl regular expression syntax and has enhanced the Brief, SlickEdit, and
UNIX syntaxes to support various features found in the Perl syntax. New capabilities include:
•
•

34

Word anchor matching - Match a word boundary or anything except at a word boundary.
Extended escape sequence - Match all characters as literals until reaching a specified point.
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•
•

Case-sensitive matching - Match the casing of text or ignore case.
Character case modification on replace - Convert matched characters to upper- or lowercase.

See Regular Expressions for more information.

Makefile Import
You can now create a project by importing a makefile. This feature is a time-saver when you have a project
that was not created in SlickEdit® that contains a makefile. Simply import the makefile, and SlickEdit
automatically parses the targets, finds all referenced source files, and adds them to a new SlickEdit
project.
To import a makefile, from the main menu, click Project > Open Other Workspace > Makefile. When you
import a makefile, SlickEdit creates a new workspace and adds the project to it.
The new project automatically imports all files that are referenced by the makefile. All of the make targets
are also added and made available for execution from the main menu under Build > Execute Makefile
Target. For makefiles that contain invocations of other makefiles, the other makefiles can be optionally
added to the workspace as separate projects, or all their files added into one project.
See Importing Makefiles for more information about this feature.

Cursor on Symbol Shows All Uses in File
SlickEdit® can highlight all occurrences of the current symbol under the cursor. This makes it easy to see,
at a glance, all uses of a symbol in a file. This option can be set on a language-specific basis. To enable it,
from the main menu, click Tools > Options > Languages, expand your language category and language,
then select Context Tagging®. On the options screen, select Highlight matching symbols under
cursor. See Cursor on Symbol Shows All Uses in File for more information.

Enhanced Auto-Generation of Doc Comments
By default, SlickEdit® automatically expands doc comment skeletons when you type the start characters.
Now, using aliases, you can modify the template that gets expanded.
To modify a doc comment template, from the main menu, click Tools > Options > Languages, expand
your language category and language, and select Comments. In the Doc comments section, select the
type of skeleton you want to modify from the For start characters drop-down list, then click the Edit
expansion button. The Doc Comment Editor dialog opens with the specified start characters are already
selected in the alias list, so you can start editing the comment template in the edit window. See Doc
Comments for more information.
In addition to Comment enhancements, SlickEdit has added several new escape sequences that you can
use in your doc comment templates by using the Insert Escape Sequence list on the Doc Comment
Editor. These include the ability to insert local function param names, types, and return types. See Alias
Escape Sequences for more information.

Full SCIM Support
SlickEdit now provides full SCIM support for Linux users. First, set the VSLICK_XIM environment variable
to scim and set the XMODIFIERS environment variable to @scim (Macro > Set Macro Variable). Then,
from the main menu, click Tools > Options > Keyboard > Redefine Common Keys, and set the Use
Ctrl+Space for input method editor option to True. Now, you can press Ctrl+Space at any time to
activate the SCIM input method editor.
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Slick-C® Debugger
The Slick-C Debugger helps you locate bugs and resolve issues in your Slick-C code. When the debugger
is activated (Macro > Start Slick-C® Debugger or slickc_debug_start command), a debugger instance
of SlickEdit® opens and attaches to the running instance. Use the Debug menu items to perform debug
operations. For more information about the debugger, see “Slick-C Debugger” in the Help system (Help >
Index). For more information about debugging in SlickEdit, see Debugging.

URLs Treated as Links
SlickEdit® now treats URLs in editor windows as hyperlinks, making them easy to identify and open from
within your code. A configuration variable lets you specify the recognized URL types. By default, a string is
interpreted as a URL if it begins with one of the following URI schemes, or, URL types (including the colon
and slashes):
•
•
•
•

file://
ftp://
http://
https://

URLs are underlined. You can navigate to a link by hovering over it with the mouse and using Ctrl+Click
(or Cmd+Click on the Mac). To configure recognized URI schemes, from the main menu, click Tools >
Options, then expand Network & Internet Options in the tree and select URI Schemes. See Navigating
to URLs for more information about this feature.

Enhanced URL Mapping
SlickEdit® lets you map URLs to different locations. You can now specify a default lookup directory that
contains all of your DTDs and namespace schema files. Every mapping doesn't need to be explicitly
configured. You can also create mappings for namespace URIs as well as DTD files. To configure URL
Mapping, from the main menu, click Tools > Options, then expand Network & Internet Options in the
tree and select URL Mappings. See URL Mapping for more information.

Auto Symbol Translation
Auto Symbol Translation automatically converts a character or sequence of characters to the appropriate
entity reference, saving you from having to repeatedly guess at the correct entity or look up reference
charts. This feature works automatically as you type, so you don’t need to press a special key or key
sequence to trigger the translation. For example, type >>, and SlickEdit® automatically converts the >>
sequence to &gt;, which is the entity reference for the right angle bracket (>). Typing && translates to
&amp;, the entity reference for the ampersand symbol (&).
Auto Symbol Translation uses the Alias mechanism in SlickEdit—the character or character sequence that
you type to trigger translation is actually a special kind of alias, henceforth called a “symbol alias”. SlickEdit
comes with some predefined symbol aliases. You can view these, customize them, and create your own by
using the Symbol Translation Editor dialog. The first time Auto Symbol Translation is triggered, a prompt
appears that describes the feature and lets you open the Symbol Translation Editor.
See Auto Symbol Translation for more information about this feature.
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New Clipboards Tool Window
A new Clipboards tool window is available for previewing and managing your clipboards in SlickEdit®. The
tool window shows a list of your recently used clipboards (up to 50 by default), and displays the same
information presented by the Select Text to Paste dialog, used to view and insert a clipboard
(list_clipboards command or Ctrl+Shift+V). The new tool window has a Preview area that lets you see
the entire contents of a clipboard including color-coding based on the source of the clipboard text.
Display of the Clipboards tool window can be toggled on/off by clicking View > Toolbars > Clipboards or
by using the toggle_clipboards command. To display the tool window on demand, use the
activate_clipboards command. See Clipboards for more information.

New Language-Specific File Options
Most of the options regarding loading and saving files in SlickEdit® are global, such as Expand tabs to
spaces. But sometimes you may need to work with files that have different file load and save options from
the defaults. For example, when working with makefiles, tabs should never be expanded to spaces. Now,
load and save file options such as this are available on a language-specific basis. To access them, from
the main menu, click Tools > Options. Expand Languages in the tree, then select your language category
and language, and click File Options. New language-specific file options also include Load as Binary,
Save as Binary, and Strip trailing spaces. See Language-Specific File Options for more information.

Additional Enhancements
Along with the new features listed above, we have made many other enhancements to SlickEdit® 2008.
The following are particularly noteworthy:
•

Tagging operations run off current identifier - Previously, Context Tagging® relied on word
characters to find identifiers in the code being analyzed. Now, Context Tagging operations are
based on the current identifier. If you are creating color coding support for a new language, you
can adjust ID start and follow characters by using the Identifiers options on the Tokens tab of the
Language-Specific Color Coding Options (Tools > Options > Languages > [LanguageCategory]
> [Language] > Color Coding).

•

Organize Imports now supports Annotations and Enums, properly screens out package-private
classes, and allows for static imports.

•

The Save Macro dialog (which appears automatically when you stop macro recording) has been
enhanced. Now, when you attempt to save a macro with a name that is already taken, SlickEdit
displays a message asking if you want to overwrite the existing macro. The Save Macro dialog
also has a new button: Save and Bind to Key. This saves the new macro and allows you to
quickly create a key binding for it with the Key Bindings dialog. You can also create/change key
bindings for recorded macros by clicking Bind to Key on the List Macros dialog (Macro > List
Macros or list_macros command).

•

SlickEdit now supports DocBook and XHTML. DocBook a DTD set that includes both SGML and
XML versions which are used to create technical documentation.
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Documentation
Documentation for SlickEdit® consists of:
•

A fully integrated Help system, including context-sensitive Help, a searchable index, and
categorized lists of C and Slick-C® macro functions. See The Help System for more information.

•

The SlickEdit® User Guide, which provides the same information as the Help system in PDF
format for viewing and printing as a manual.

•

Emulation charts in PDF format for the following editors: BBEdit, Brief, CodeWarrior™,
CodeWright®, CUA (SlickEdit’s default emulation), Epsilon, GNU Emacs, ISPF, SlickEdit (Text
Mode edition), Vim, Visual C++® 6, Visual Studio® default, and Xcode®.

•

Slick-C® reference material in PDF format, which includes the Slick-C Macro Programming Guide
and Slick-C Macro Conventions and Best Practices for End Users.

PDF documents are located in the docs directory on the root of the product CD. After SlickEdit is installed
on your computer, these documents are located in the docs subdirectory of the installation directory.
Documentation for the current and previous versions of SlickEdit is also available on the SlickEdit Web site
at www.slickedit.com/docs.

Documentation Updates/Feedback
In-product documentation is current as of the build date of the product. Revisions to the product
documentation are made regularly with the most current version being made available on the SlickEdit
Web site (www.slickedit.com).
We welcome your comments and suggestions regarding the documentation. Please send feedback to
docs@slickedit.com.

Other Resources
The following additional resources are available:
•

The SlickEdit Community Forums - Learn more about SlickEdit products and interact with other
users at http://community.slickedit.com.

•

“Hello World”–the SlickEdit Developer Blog - Read thoughts, tips, and tricks from the
developers at SlickEdit at http://blog.slickedit.com.

•

The SlickEdit® book - After years of developing code with SlickEdit, expert John Hurst brings his
wealth of knowledge to readers in Professional SlickEdit (Indianapolis, Wiley Publishing, 2005,
ISBN - 978-0470122150).

Documentation Conventions
The conventions listed below are used in SlickEdit® documentation.

Default Emulation/Key Binding Mode
CUA is the default editor emulation mode. Therefore, key bindings and shortcuts listed in the
documentation follow the CUA emulation.
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Platform-Specific Notes
Platform-specific notes appear throughout the documentation and are included for Microsoft Windows,
UNIX® (which includes Linux®), and Mac OS® X.

Mac OS X Notes
SlickEdit® can be used on a Mac OS X operating system, displayed as an X11 application. The X11
application can be customized to accommodate your preferences.
Throughout the user documentation, information that is available for Linux and UNIX operating systems
will be the same or similar when using SlickEdit on a Mac OS X operating system. The documentation
contains specific information for the Mac OS X operating system where relevant. Mouse and keyboard
shortcuts in the documentation are written for Microsoft Windows, but can be adapted for Mac OS X using
the information below.
TIP In SlickEdit, a key or key sequence that is bound to an operation is called a key binding. See
Using the Mouse and Keyboard and Key and Mouse Bindings for more information.
Mouse and keyboard shortcuts on Windows and Mac OS X have the following similarities:
•

The Command (Cmd) key on the Mac keyboard functions the same as the Windows Control
(Ctrl) key.

•

The Cmd key plus a mouse click on the Mac keyboard functions the same as right-clicking the
mouse on Windows.

•

Single-button mouse support (available through the preferences menu for the X11 application).

The following table shows some of the differences between mouse and keyboard shortcuts on a Windows
operating system and the Mac OS X operating system:
Microsoft Windows

Mac OS X

Right-click with the mouse

Cmd+Click

Left-click with the mouse

Single mouse click

Ctrl+F (Find)

Cmd+F (Find)

Ctrl+G (Find again)

Cmd+G (Find again)

Print Screen

Cmd+P (Print)

NOTE Until they are disabled, X11 keyboard shortcuts override SlickEdit shortcuts. For example, in
SlickEdit, Cmd+Q quits the SlickEdit application, but in X11, Cmd+Q quits the X11 application. To
disable X11 keyboard shortcuts:
1. With SlickEdit in the foreground, go to the X11 menu.
2. Select Preferences (Cmd+Comma).
3. On the Preferences dialog, under the Input category, uncheck the option Enable key
equivalents under X11.

Menus and Dialogs
Instructions for navigating to items accessed from the main menu are written in the form:
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[MainMenuItem] > [SubMenuItem]
For example, the text “click Search > Find” indicates that you should first select Search from the main
menu, then select Find from the Search submenu. Brackets are used to indicate that the menu item is a
variable. Some menu paths include tree nodes in dialogs. For example, Tools > Options > Languages >
[LanguageCategory] > [Language] > Indent is a quick way to write “select Tools > Options from the
main menu, then in the Options tree, expand the Languages node, the category for the language you want
and the language you’re using, then select the Indent node”.
Instructions for using the product make up the bulk of our documentation, while listings of dialog boxes and
options can be found in the Menus, Dialogs, and Tool Windows chapter. Buttons on dialogs, such as OK,
Close, and Help, are not usually documented since the meaning is obvious.

Code Syntax Conventions
•

Commands, switches, keywords, properties, operators, options, variables, and text to be typed by
the user are shown in bold type.

•

User-input variables and placeholders are shown in bold italic type.

•

Code samples and file names are displayed in a monospaced font.

•

File extensions and environment variables are written with an UPPERCASE font.

•

SlickEdit® commands that contain two or more words are written with underscore separators: for
example, cursor_down. Note that in the user interface, however, these commands are displayed
with hyphen separators: for example, cursor-down. Both of these forms work in SlickEdit, so you
can use whichever style you prefer.

The Help System
The searchable Help system is installed with the product. In addition to information about the SlickEdit
application, it provides categorized lists of C and Slick-C® macro functions.
The Help system can be accessed in several ways:
•

To view a list of all topics in the Help system, from the main menu, click Help > Contents. This is
useful for browsing topics depending on your needs.

•

To look up specific keyword(s) in the Index, click Help > Index. Use the Index to find specific
information, for example, “changing emulations” or “toolbars”. You can also use the index to find
information about a specific option in SlickEdit by looking up the label, for example, “One file per
window”. When you type in the Index, the list of terms is searched incrementally.

•

To search the entire Help system for every instance of a word used, click Help > Search. This can
be particularly useful to discover information about API functions or more obscure topics. Use
quotation marks around the term if it contains spaces.

•

To invoke the Help entry for toolbars, tool windows, menus, and dialog boxes, press F1.

You can also configure SlickEdit to display Word Help for the item at the cursor in files. See Advanced Help
Configuration for information.
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Help Key Shortcuts
The table below lists keyboard shortcuts that can be used when working in the Help system.
Shortcut

Description

Tab

Next hypertext item

Shift+Tab

Previous hypertext item

Enter

Go to hypertext item

Alt+I

Displays Help index

Ctrl+S or Alt+S

Display Help Find dialog box

Ctrl+C or Ctrl+Ins

Copy selection to clipboard

Home

Start of topic

End

End of topic

Up arrow

Scroll up

Down arrow

Scroll down

PgUp

Page up

PgDn

Page down

Click+Drag

Selects text

Shift+Click+Drag

Extends a selection

Supported Help Web Browsers
The Help system runs on many browsers. If you are using Microsoft Windows, you must have Microsoft
Internet Explorer® installed for the Help system to function. Based on our testing on other operating
systems, we recommend the following:
•

If you are using a UNIX, Linux, or another UNIX-based operating system, use the Firefox®
browser.

•

If you are using Macintosh®, use the Safari™ browser.

NOTE SlickEdit® provides a way to configure what Web browser to use when SlickEdit needs to
launch a browser (such as when you click Help > SlickEdit Support Web Site). This configuration
does not apply to the Help system. For more information, see Web Browser Setup Options.
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Supported Languages and Environments
This section outlines the languages and file types supported by each SlickEdit® feature, including special
features for the Mac®, as well as supported emulations, project types, and version control systems.

Supported Languages and File Types
The table below indicates the languages and file types that support key SlickEdit® features. Features that
are not language-specific, such as DIFFzilla®, are not listed here.
Feature

Languages

Automatic Syntax Expansion

ActionScript, Ada, AWK, C, C#, C++, CFML, CFScript, Ch,
COBOL, DocBook, DTD, Fortran, HTML, IDL, InstallScript,
J#, Java, JavaScript™, JSP™, Objective-C, Pascal, Perl,
PHP, PL/SQL, PV-WAVE®, Python™, REXX, Ruby, SAS®,
Slick-C®, Tcl, Transact-SQL®, VBScript, Verilog®, VHDL,
Visual Basic®, Visual Basic .NET™, XHTML, XML, XSD

Code Beautifier

ActionScript, Ada, C, C#, C++, CFML, DocBook, HTML,
Java, JavaScript, JSP, Slick-C, XHTML, XML, XSD

Color Coding

ActionScript, Ada, ANTLR, AppleScript®, Assembly
Language, AWK, Bourne shell scripts, C, C Shell, C#, C++,
CFML, CFScript, Ch, CICS®, COBOL, DB2®, DocBook,
DTD, Fortran, High Level Assembler, HTML, IDL,
InstallScript, J#, Java, JavaScript, JCL, JSP, Lex, Modula-2,
Objective-C, Pascal, Perl, PHP, PL/I, PL/SQL, PowerNP™
Assembler, Progress® 4GL, PV-WAVE, Python, REXX,
Ruby, SAS, Slick-C, Tcl, Transact-SQL, VBScript, Verilog,
VHDL, Visual Basic, Visual Basic .NET, Windows batch files,
x86 Assembly, XHTML, XML, XSD, Yacc

Context Tagging®: Auto List
Members, Auto Parameter Info

ActionScript, Ada, C, C#, C++, CFML, CFScript, Ch, CICS,
COBOL, DocBook, DTD, High Level Assembler, HTML, IDL,
InstallScript, J#, Java, JavaScript, JSP, Objective-C, Pascal,
Perl, PHP, PL/I, PV-WAVE, Python, Ruby, Slick-C, VBScript,
Verilog, VHDL, Visual Basic .NET, XHTML, XML, XSD

Context Tagging: Auto List
Parameters

ActionScript, C, C++, Ch, J#, Java, Slick-C

Javadoc™ Editor

ActionScript, C, C#, C++, J#, Java, JavaScript, Slick-C

Select/Hide Code Block

ActionScript, Ada, C, C#, C++, CFML, Ch, COBOL, DB2,
DocBook, Fortran, High Level Assembler, HTML, IDL,
InstallScript, J#, Java, JavaScript, Modula-2, Objective-C,
Pascal, Perl, PHP, PL/SQL, Slick-C, Tcl, Visual Basic, Visual
Basic .NET, XHTML, XML, XSD
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Feature

Languages

Selective Display
Collapsible code block and
function bodies.

ActionScript, Ada, ANTLR, C, C#, C++, CFML, CFScript,
Ch, CICS, COBOL, DB2, DocBook, DTD, Fortran, High
Level Assembler, HTML, IDL, InstallScript, J#, Java,
JavaScript, JCL, JSP, Lex, Modula-2, Objective-C, Pascal,
Perl, PHP, PL/I, PL/SQL, PowerNP Assembler, PV-WAVE,
Python, REXX, Ruby, SAS, Slick-C, Tcl, Transact-SQL,
VBScript, Verilog, VHDL, Visual Basic, Visual Basic .NET,
x86 Assembly, XHTML, XML, XSD, Yacc

SmartPaste®
Pasted code re-indents to correct
level.

ActionScript, AWK, C, C#, C++, DocBook, HTML, IDL,
InstallScript, J#, Java, JavaScript, JSP, Objective-C, Pascal,
Perl, PHP, PL/I, PV-WAVE, Python, Ruby, Slick-C, Tcl,
XHTML, XML

Source Code Navigation and
Lookup
Includes Class, Defs, Preview,
References, and Symbols tool
windows, as well as symbol
navigation.

ActionScript, Ada, ANTLR, Assembly Language, AWK,
Bourne shell scripts, C, C Shell, C#, C++, CFML, CFScript,
Ch, CICS, COBOL, DB2, DocBook, DTD, Fortran, High
Level Assembler, HTML, IDL, InstallScript, J#, Java,
JavaScript, JCL, JSP, Lex, Makefile, Modula-2, Objective-C,
Pascal, Perl, PHP, PL/I, PL/SQL, PowerNP Assembler,
Progress 4GL, PV-WAVE, Python, REXX, Ruby, SAS, SlickC, Tcl, Transact-SQL, VBScript, Verilog, VHDL, Visual
Basic, Visual Basic .NET, Windows batch files, x86
Assembly, XHTML, XML, XSD, Yacc

Syntax Indenting
Cursor is placed at correct indent
level.

ActionScript, Ada, AWK, C, C#, C++, CFML, CFScript, Ch,
COBOL, DocBook, Fortran, HTML, IDL, InstallScript, J#,
Java, JavaScript, JSP, Objective-C, Pascal, Perl, PHP, PL/
SQL, PV-WAVE, Python, REXX, Ruby, SAS, Slick-C, Tcl,
Transact-SQL, VBScript, Verilog, VHDL, Visual Basic,
Visual Basic .NET, XHTML, XML, XSD

Special Features for Mac OS X
The following features are available for programmers using Mac OS X:
•
•
•
•

Xcode project support
Objective-C language support
Emulations for CodeWarrior, BBEdit, and Xcode
Mac OS X default line endings are the same as UNIX

See Platform-Specific Notes for information on Mac OS X documentation conventions and keyboard and
mouse commands.

Embedded Languages
SlickEdit® recognizes languages embedded in HTML, COBOL, Perl scripts, and UNIX shell scripts. When
editing embedded languages, all language-sensitive features are supported, including Context Tagging®,
SmartPaste®, Syntax Expansion, Syntax Indenting, and Color Coding. In fact, Context Tagging picks up
embedded tags. For example, the Defs tool window displays function names if any exist. Embedded
language colors are user-defined.
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Embedded Languages in HTML
SlickEdit® supports any embedded language in HTML. However, Web browsers usually only support
VBScript, JavaScript, and/or Java, while Web servers typically support VBScript, Java, or PHP. The
following screen is an example of VBScript, JavaScript, and Java embedded in HTML:

Embedded Languages in Perl and Other Scripting Languages
To allow SlickEdit® to recognize embedded source in a Perl script or UNIX shell, prefix the HERE
document terminator with the color coding lexer name. The following Perl example shows HTML
embedded in a Perl script. Unknown languages are color-coded in string color.

Supported Editor Emulations
SlickEdit® provides keyboard emulations for the following editors:
•
•

BBEdit
Brief
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•
•
•
•
•
•
•
•
•
•
•

CodeWarrior
CodeWright
CUA (SlickEdit’s default)
Epsilon
GNU Emacs
ISPF
SlickEdit (Text Mode edition)
Vim
Visual C++ 6
Visual Studio default
Xcode

See Emulations for more information.

Supported Project Types
SlickEdit® supports the creation of projects that use the Microsoft Visual C++ Toolkit and Microsoft .NET
Framework Software Development Kit. Many other project types are supported, including many for Java.
For a list of all supported types, see the list box on the Project > New dialog. For information about
working with projects, see Workspaces and Projects.

Supported Version Control Systems
SlickEdit® provides support for the version control systems listed below. To learn more about working with
version control in SlickEdit, see Version Control.
•
•
•
•
•
•
•
•
•
•
•
•
•
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CCC/Harvest
ClearCase®
ComponentSoftware RCS
CVS
MKS Source Integrity®
Perforce
PVCS®
RCS
SCC
StarTeam®
Subversion
TLIB
Visual SourceSafe®
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System Requirements
SlickEdit® is supported for many operating systems. The table below shows the available platforms and
space requirements for each. Each installation requires a minimum of 256 MB of memory.
Platform/Version

Requirements

Microsoft® Windows® Vista™, XP, 2000

170 MB disk space

Linux®, 32-bit or compatible, kernel 2.6 or later, and
LSB compliant

200 MB disk space

AIX 5.3 and later

250 MB disk space

HP-UX® 11 and later

270 MB disk space

Solaris™ SPARC® 7 and later

240 MB disk space

Solaris x86 10 and later

240 MB disk space

Mac OS® X v10.4 and later (X11 required)
Note that the Mac OS X version of SlickEdit supports
universal binaries to run on Intel® and Power PC®
Macs.

240 MB disk space

Installing SlickEdit®
Use the information below to install SlickEdit® on your Windows, Linux, UNIX, or Mac OS X platform.
NOTE When you start SlickEdit for the first time after an installation, several dialog boxes
automatically appear that require action. See Running SlickEdit® for the First Time for more
information.

Windows
When you place the CD in the drive, the setup program starts automatically. Use the setup wizard to
complete the installation. To start setup if it does not start automatically, or if you are installing a
downloaded product, double-click the .msi file to start the setup.
NOTE The Windows installer will not allow you to install more than one copy of SlickEdit® with the
same version number on the same machine. For example, you can have SlickEdit v12.0.3 and
SlickEdit 2008 installed, but you cannot install two copies of SlickEdit 2008. To create a second
installation, copy the installation directory to another location.

Linux/UNIX
Complete the following steps to install SlickEdit® on a computer running Linux or UNIX:
1. Mount the CD-ROM block device to a local directory. To prevent file name casing issues on HPUX®, use the -o cdcase option when mounting.
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2. At an xterm or full-screen prompt, change to the applicable UNIX platform directory on the CDROM (where <cdrom> is your CD-ROM mount point):
o

AIX - <CD-ROM>/aix/rs6000

o

HP-UX - <CD-ROM>/hpux/hp9000

o

Linux x86 - <CD-ROM>/linux/x86

o

Solaris™ Sparc® - <CD-ROM>/solaris/sparc

o

Solaris x86 - <CD-ROM>/solaris/x86

3. Start the installation at the prompt: # ./vsinst

Mac
Complete the following steps to install SlickEdit® on a computer running Mac OS X:
1. Ensure that X11 is fully installed on your system (see the Note below).
2. Browse to the mac folder on the product CD.
3. Double-click slickedit.dmg. A disk image is mounted, with Finder™ displaying the contents.
4. Double-click slickedit.pkg, and the installation process begins.
The default installation path is /Applications.
After installing SlickEdit, if you want to use SlickEdit keyboard shortcuts instead of X11 shortcuts, you will
need to disable X11 keyboard shortcuts. See Mac OS X Notes for instructions.
NOTE SlickEdit runs as an X11 application, so X11 must be installed prior to installing SlickEdit. To
check if X11 is installed, click Finder > Applications > Utilities. A file named X11.app should exist
at this location. Otherwise, you will need to install X11 from your OS X installation CD:
1. Using installation disk 1, run the Optional Installs.mpkg utility.
2. At the Install Type phase, expand the Applications tree and select X11.
3. Continue with the X11 installation.

Unattended Installation
Using command line switches and arguments, SlickEdit® can be installed in an unattended manner. This is
useful for network administrators to deploy SlickEdit on multiple client machines with standardized
settings. Instructions can be downloaded in PDF format from www.slickedit.com/docs/unattended.
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Licensing
NOTE To provide more consistent functionality on all supported platforms, the Activations licensing
option has been removed from SlickEdit® 2008 in the v13.0.1 release. If you have previously used
Activation to authenticate your license you will need to download a license file, which is available on
your registered products Web page. If you were using a license file for v13.0, that license file will still
work with v13.0.1. We have made some changes to where the license files are stored, which may
cause SlickEdit to think your product is not licensed. If the License Manager is displayed when you
first run v13.0.1, you can use it to browse for the location of your existing license file.
SlickEdit® 2008 uses FLEXnet™ Publisher from Macrovision to manage licenses for both Named User
and Concurrent User licenses. Named User licenses are stored on the local machine. Concurrent User
licenses use a FLEXnet server to access a license.

Concurrent User Licenses
Concurrent License users will find complete instructions for setting up a license server at
www.slickedit.com/flexnet. This also contains information on how to configure an installation of SlickEdit®
to find the server.
When you run SlickEdit, if a license is not found, the SlickEdit License Manager wizard is run. This wizard
is only for configuring Named User licenses. Please exit the wizard and contact your FLEXnet
administrator for assistance in configuring your installation to correctly locate the FLEXnet server.

Named User Licenses
SlickEdit® uses a license file to authenticate your license. A Full License file is not bound to a particular
machine and may be used on as many machines as allowed by the End User License Agreement. A Trial
License file is bound to a single machine.
In most cases, the location of the license file is managed by SlickEdit and depends on your platform.
However, if you are setting up a portable installation of SlickEdit, to run on a USB drive for example, you
should manually copy the license file to the win subdirectory of your SlickEdit installation on Windows or
the bin subdirectory on all other platforms.
NOTE SlickEdit 2008 v13.0 also allowed Activation to authenticate a license. Because the support
for activations has been removed from the product, you will still need to download and install a
license file even if you have previously activated this computer.
When SlickEdit is run, it checks for a license. If one can't be found, the SlickEdit License Manager wizard is
run. You can also manually run the SlickEdit License Manager by selecting Help > License Manager. The
SlickEdit License Manager provides the following options:
•

Request a Trial License - To try out SlickEdit, click the option to obtain a Trial License. This will
take you to a Web page where you can register for a trial. A license key will be e-mailed to you. A
trial can be converted to a Full License by entering a Full License key at any time in the SlickEdit
License Manager, or by downloading a Full License file.

•

Purchase a license - To buy a Full License, visit the SlickEdit Web site at www.slickedit.com or
select this option, which will take you directly to the product page for SlickEdit.

•

Use a license server (concurrent licenses) - Use this to configure concurrent licenses using a
FLEXnet server.
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•

Request a license for a purchased product - If you have already purchased a license for
SlickEdit, you can download a license file to this computer from the SlickEdit Web site.

•

Install a license file - Copies a downloaded license file to the location SlickEdit uses to store the
file.

Upgrading SlickEdit®
We recommend keeping up with SlickEdit releases and updates to get the latest features and bug fixes.
Major versions contain many new features and enhancements to SlickEdit. Minor versions are usually
released subsequently to a major version and contain additional enhancements. Hot fixes are published
frequently and contain a smaller set of changes to address a specific problem with the previous release.

Upgrading to a New Version
Checking for Updates
SlickEdit® automatically checks and notifies you when a new major or minor version is available. When an
update is available, the Update Manager displays a dialog showing a list of available updates and
descriptions, and provides a link to download the update.
You can set the frequency of how often SlickEdit checks for these updates and change proxy settings
through the Update Manager Options dialog. To access these options, from the main menu, click Help >
Product Updates > Options (or click the Options button on the Update Manager dialog).
You can also check for updates manually. From the SlickEdit main menu, click Help > Product Updates >
New Updates. Or, visit the Support Web site at www.slickedit.com/support and click Updates.

Migrating Settings
SlickEdit® creates a versioned subdirectory in your configuration directory corresponding to each version
of SlickEdit you have installed. SlickEdit migrates your settings to a new subdirectory corresponding to the
new version the first time the new version is run. However, as a precaution, we recommend that prior to
installing an update, exit SlickEdit and make a backup of your user configuration directory. For information
about the user config directory’s location and the files it contains, see User Configuration Directory.
Certain customizations that you have made to the editor are not preserved. These are:
•
•

Modifications to menus and toolbars
Custom forms

If you have added your own toolbar, you can reload the macros that contain these customizations. Most of
these changes are saved in vusrobjs.e (Windows) or vunxobjs.e (UNIX/Linux/Mac). To reload these
macros, first, copy the vusrobjs.e or vunxobjs.e file from the previous configuration directory to your
new configuration directory. Then, to load these files, simply activate the SlickEdit command line (by
pressing Esc in most emulations), and enter the file’s full path and file name. If the path contains spaces,
be sure to surround it with double quotes.
See Creating and Distributing Custom Toolbars for more information about backing up user-created
toolbars and toolbar buttons.
NOTE All customizations or additions to the main SlickEdit toolbar (known as the Standard toolbar)
are lost after an upgrade, because SlickEdit rebuilds the toolbar for each new version.
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Keeping the Previous Version
You can continue to run a previous version of SlickEdit® by installing the new version into a new directory.
Because the config directories are versioned, each version of SlickEdit will locate the matching settings.

Applying Hot Fixes
Hot fixes are small, localized changes to address a specific problem with the previous release. They can
consist of Slick-C® modules, configuration files, installation files, or DLL files. Hot fixes are distributed as
ZIP files and made available on the SlickEdit Support Web site at www.slickedit.com/support. For
convenience, a number of hot fixes may be aggregated into a single ZIP file.
NOTE If a user loads a hot fix on a multi-user installation of SlickEdit®, only that user will be
updated. To apply a fix to a multi-user installation, please contact Product Support for assistance.

Installing Hot Fixes
To install a hot fix, complete the following steps:
1. Save the ZIP file to any location on your computer.
2. From the SlickEdit® menu, click Help > Product Updates > Load Hot Fix (or use the command
load_hotfix). The Apply Hot Fix dialog appears.
3. Browse to and select the hot fix ZIP file, then click OK.
4. A confirmation prompt appears describing the hot fix. Click Yes. The installation starts.
Details about the installed fix will be sent to the Output tool window.

Listing Installed Hot Fixes
To see the list of hot fixes installed, from the SlickEdit® menu, click Help > Product Updates > List
Installed Fixes (or use the command list_hotfixes). A summary sheet appears with the location of the hot
fix ZIP file, its revision number, the date it was published, and its description.

Unloading Hot Fixes
To unload a hot fix, use the unload_hotfix command from the SlickEdit® command line. At the prompt,
select the hot fix to unload and click OK.
CAUTION Unloading a hot fix will reload the original files distributed with the previously installed
release of SlickEdit. If other hot fixes include the same file or are dependent on the unloaded files,
SlickEdit may behave unpredictably. If more than one hot fix has been installed, you may need to
reinstall the other hot fixes after removing one of them.

Uninstalling SlickEdit®
To remove SlickEdit from your computer, use the information below specific to your platform.
NOTE Uninstalling SlickEdit does not automatically remove the user configuration directory. See
User Configuration Directory for more information.
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Windows
If your computer is running Windows, complete the following steps to uninstall SlickEdit®:
1. From the Windows Control Panel, open Add or Remove Programs.
2. Click Change or Remove Programs.
3. Select the SlickEdit installation that you want to remove.
4. Click Change/Remove or Remove. This will delete the installation directory as well as any registry
settings. You may be prompted to reboot for the changes to take effect.
Alternatively, double-click on the original .msi installation file, located on the product CD or in your product
installation download, and select Remove.

Linux/UNIX
To uninstall SlickEdit® on a computer running Linux or UNIX, simply delete the installation directory.

Mac
To uninstall SlickEdit® on a computer running Mac OS X, open the Application folder, and drag the
SlickEdit icon to the Trash, then empty the Trash.

52

SlickEdit® User Guide

STARTUP AND EXIT

Startup and Exit
Starting the Program
To manually run SlickEdit® on a computer that is using a Microsoft Windows or Mac OS X operating
system, use the SlickEdit icon displayed on your desktop or launch it from the Start menu (or equivalent).
On Linux or UNIX, run SlickEdit using the vs binary located in ...slickedit/bin. For a complete list of
options that can be used with the vs command, see Invocation Options.
TIPS
•

You can make settings so that certain items such as files, clipboards, and Selective Display
are restored each time SlickEdit is started. See Restoring Settings on Startup for more
information.

•

You can also set a macro to be run upon startup. See the section “Hooking Exit and Other
Events” in the Slick-C® Macro Programming Guide for more information.

Running Multiple Instances
You can have two instances of SlickEdit® running at the same time. On Windows or Mac OS X, right-click
on the SlickEdit icon displayed on the desktop. In the Target field, append the text +new to the end of the
existing text.
On UNIX or Linux, append +new to the invocation command (for example, vs +new).
CAUTION SlickEdit cannot save configuration changes when another instance is running. If you
attempt to close an instance that contains configuration changes, while another instance is running,
a save-failed message is displayed, then a prompt asks whether or not to exit anyway.

Running SlickEdit® for the First Time
The first time SlickEdit is started after an installation, several dialog boxes may be automatically launched
that require action:
NOTE For Mac OS X, SlickEdit requires a one-time background caching of the font list. This will take
a few minutes, after which SlickEdit will start normally.
•

Release Notes - The SlickEdit dialog displays the Release Notes for this version. The Program
Information tab contains the serial number, version, and other details about your product. This
information is used by Product Support should a problem arise (the Copy to Clipboard button is
useful in this case). The License Agreement tab displays the “End User License Agreement”
(EULA). Information about contacting SlickEdit is shown on the Contact Information tab. The
SlickEdit dialog can be displayed at any time by clicking Help > About SlickEdit, or by using the
version command.

•

Emulation - The process of imitating another program is called emulation. SlickEdit provides
emulations of key bindings for 13 editors, so that you can use the style to which you are
accustomed. See Emulations for more information. You can use the default (CUA) emulation or
select another. If you are upgrading, your emulation is remembered and this dialog does not
appear.
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•

Create Tag Files for Run-Time Libraries - This dialog prompts for tag generation. Context
Tagging® is required so that the most powerful features in SlickEdit will work, such as Code
Navigation and Symbol Browsing. To use the default code base directories and tag file destination
paths for C, C++, Java, and .NET, click Create tag file(s). To tag source files for other languages,
some configuration is required. For more information, see Building and Managing Tag Files.

NOTE In order for SlickEdit to help you work more quickly and efficiently (such as using Code
Navigation and Symbol Browsing mentioned above), it is important to create these tag files. This
may take several minutes, depending on the size of your code base. You can create tag files at any
time by clicking the Auto Tag button on the Context Tagging® - Tag Files dialog (Tools > Tag Files).
•

Cool Features - The Cool Features dialog displays information about some of the best SlickEdit
features and contains options for viewing feature settings, getting help on a feature, and viewing a
demo of the feature. There is also an option labeled Show on startup. Clear this option if you do
not want to see the Cool Features dialog each time SlickEdit is launched. See Cool Features
Dialog for more details.

Exiting the Program
To safely exit SlickEdit®, from the menu, click File > Exit (Alt+F4). You can also use the SlickEdit
command line to exit. Activate the command line by pressing the Escape key or by clicking on the
message line with the mouse, then type safe_exit. If files have not been saved or closed upon exit, you
will be prompted with a dialog to save or discard any changes.
TIPS
•

You can make settings so that certain items such as files, clipboards, and Selective Display
are restored each time SlickEdit is started. See Restoring Settings on Startup for more
information.

•

You can also set a macro to be run upon exit. See the section “Hooking Exit and Other
Events” in the Slick-C® Macro Programming Guide for more information.

Exiting with Modified Buffers
If files have not been saved or closed upon exit, you will be prompted with a dialog to save or discard any
changes. The buffer names in the list box are buffers which have not been saved. See Exiting with
Modified Buffers Dialog for option descriptions. See also Saving Files.

Default Exit Options
To access default options for saving configuration changes, click Tools > Options > Application Options
> Exit. See Exit Options for descriptions of these options.
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Product Support
The Product Support Web site provides a list of frequently asked questions and answers as well as
information about upgrades and hot fixes. You can launch this site in a browser by clicking the menu item
Help > SlickEdit Support Web Site or by going directly to www.slickedit.com/support. You can also
access the FAQ page directly by clicking the menu item Help > Frequently Asked Questions.
See Documentation for more help resources.

Contacting Product Support
To contact Product Support, use the menu item Help > Contact Product Support. This will automatically
gather your program information, such as the current version and serial number, that helps us to better
answer your questions.
You can also send e-mail to support@slickedit.com. For problem reports, please provide the following
information:
•

A description of the problem.

•

The language you are working in (C/C++, Java, etc.).

•

SlickEdit program information. Select Help > About SlickEdit, then select the Program
Information tab, click Copy To Clipboard and paste the information in the problem report.

•

A code snippet to help us reproduce it (if possible).

To speak to a member of our Product Support team, call the Support line at 1.919.473.0100. Telephone
support is only available during business hours for customers with a valid Maintenance and Support
Service Agreement.
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Quick Start
SlickEdit® is one of the most powerful programming editors available today, and one of the most flexible.
SlickEdit contains hundreds of options to let you work your way. Most people don't have time to read the
whole user guide. Take a few minutes to go through the Quick Start, and you’ll be up and running with
SlickEdit in no time.
The information is divided into the following steps:
1. Set Your Preferences
2. Set Up a Workspace and Project
3. Start Coding

Set Your Preferences
After installation, you may want to change some default options to match your own coding preferences.
This section contains a list of settings that are common in many code editors. This list is not
comprehensive, so we encourage you to browse all of the options screens to set preferences for
something that may not be mentioned here.
Options are changed using the Options dialog, which is displayed when you click Tools > Options from
the main menu.
Option settings are divided into two categories: General Options and Language-Specific Options.

General Options
General options affect all languages. All menu paths are relative to the Options dialog (Tools > Options).
•

Changing the emulation - During the product installation, you are prompted to choose the editor
emulation. The default is CUA. To change the emulation at any time, in the Options dialog, select
Keyboard > Emulation.

•

Maximizing the first window - By default, when an editor window is opened, it is displayed as
floating. To have editor windows maximized when they are first opened, select Editing > Editor
Windows, then set the option Maximize first window to True.

•

Expanding/collapsing with a single click - Selective Display Plus and Minus bitmaps can be
expanded or collapsed with a single click rather than a double-click. To specify this option, select
Appearance > Advanced, then set the value of Expand/collapse to Expand on single click.

•

Clicking past the end of a line - To have the ability to place the cursor past the end of a line,
select Editing > General, then set the option Click past end of line to True.

•

Specifying cursor up/down behavior - By default, cursor_up and cursor_down commands go
to the same column of the next or previous line, unless that line is shorter than the current column,
in which case the cursor is placed at the end of the line. To have the cursor placed in virtual space
at the end of the line, click Keyboard > Redefine Common Keys, then set the option Cursor up/
down places cursor in virtual space to True.

•

Changing the line insert style - In code, a line of text is a meaningful unit of functionality.
SlickEdit® treats line selections differently than character selections. Line selections are pasted
either above or below the current line, saving you from tediously positioning the cursor at the
beginning or end of a line prior to pasting. To specify where line selections are pasted, click
Editing > General, then set the Line insert style option to Before or After.
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•

Setting color schemes and fonts - Predefined color schemes, as well as individual settings, are
available for changing the colors of screen elements. To use a different color scheme, click
Appearance > Colors, then select a scheme that you like from the Color scheme drop-down list.
To change the fonts used for screen elements, click Appearance > Fonts.

•

Associating file types - Files with certain extensions can be associated with SlickEdit, so that
when those files are opened from Windows Explorer or the file manager, they run in the SlickEdit
application. To set up these associations, click File Options > Associate File Types.

Language-Specific Options
Language-specific options can be configured for each language that you need to work with in SlickEdit®.
These options are accessed from the Options dialog (Tools > Options) under Languages >
[LanguageCategory] > [Language]. All menu instructions below are relative to this path.
TIP A shortcut method to access language-specific options for the current buffer is to use the
Document > [Language] Options menu item (or the setupext command).
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•

Changing the brace style - To change the brace style used for C, C++, C#, Java, and other
languages that use braces, select the [Language] Formatting Options category, then specify the
Begin-end style that you want to use.

•

Changing the tab and indent styles:
o

Indenting with spaces - By default, when you press the Tab key to indent, literal spaces are
inserted. This is a feature called Syntax Indent. To change the amount of spaces, select the
language-specific Indent category, make sure the Indent style is set to Auto, then specify the
amount of spaces in the Syntax indent text box.

o

Indenting with tabs - If you plan to indent your code using tabs, or if you will be editing files
that already contain tabs, select the language-specific Indent category, then select the option
Indent with tabs and specify the amount of spaces tab characters should have in the Tabs
text box.

•

Enabling/disabling Syntax Expansion - When you type a keyword, such as if or for, press the
spacebar to expand that syntax element, inserting the rest of the if or for statement. This feature is
called Syntax Expansion. To turn it off, select the language-specific Indent category, then clear the
option Syntax expansion.

•

Setting symbol navigation - For C and C++, by default, with each attempt to navigate to a
definition (Ctrl+Dot or Search > Go to Definition), you will be prompted for whether you wish to
navigate to the definition (proc) or the declaration (proto). To specify that Go to Definition always
navigates to one or the other, select the language-specific Context Tagging® category, then
select one of the Go to Definition options.

•

Showing the info for a symbol under the mouse - By default, as the mouse cursor floats over a
symbol, the information and comments for that symbol are displayed. To turn this behavior off,
select the language-specific Context Tagging® category, then clear the option Show info for
symbol under mouse.

•

Configuring C/C++ preprocessing - For C and C++, your source code base will typically include
preprocessor macros that you use in your code for portability or convenience. For performance
considerations, Context Tagging® does not do full preprocessing, so preprocessing that interferes
with normal C++ syntax can cause the parser to miss certain symbols. To configure your
preprocessing to avoid these omissions, see C/C++ Preprocessing.
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Set Up a Workspace and Project
After configuring settings, you are ready to set up your workspaces and projects, unleashing the powerful
file-leveraging capabilities of SlickEdit®.
A workspace defines a set of projects and retains the settings for an editing session. A project defines a set
of related files that build and execute as a unit. For each project you can specify the set of files it contains,
a working directory, a set of commands to build and execute the project, compiler options, and
dependencies between other projects. A tag file for each project’s source files is automatically created and
maintained, enabling SlickEdit’s advanced navigation and unique Context Tagging® lookup features.
For more detailed information than is provided here, see the following sections:
•
•
•

Workspaces and Projects
Building and Compiling
Running and Debugging

Create a New Workspace
To create a new workspace, complete the following steps:
1. From the main menu, click Project > New.
2. Select the Workspaces tab.
3. In the Workspace name text box, give a name to your workspace.
4. In the Location text box, type a path or use the Browse button to pick a location.

Create a New Project
To create a new project, complete the following steps:
1. From the main menu, click Project > New.
2. It is important that you select the correct project type. From the list box on the left side of the
dialog, select the type of project that you want to use.
3. In the Project name text box, give the project a name.
4. In the Location text box, type a path or use the Browse button to pick a location. If the directory
does not exist, a prompt appears to create it when you click OK.
5. In the Executable name text box, type the name of the executable file or output file.
6. Select Add to current workspace.
7. Specify whether this project depends on another project in this workspace by checking the
Dependency of check box and selecting the depended on project from the drop-down list.
8. Click OK.

Add Files to the Project
To add files to your new project, complete the following steps:
1. From the main menu, click Project > Project Properties.
2. Select the Files tab.
3. To add individual files, click Add Files, and select the files that you want to add.
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4. To add the source files in a directory, click Add Tree. Then select the directory and the file filter
that you want to use.
5. When you are finished adding files, click OK.

Start Coding
After settings have been configured and a workspace and project are set up, you are ready to start coding.
See the Editing Features chapter to learn more about how SlickEdit® can help in your everyday work.
Tutorials are available for C/C++ and Java that describe how to create, build, and run a sample Hello
World program. See Hello World Tutorial (C/C++) or Hello World Tutorial (Java).
If you’re not ready to get to work just yet, you may want to configure even more preference options. For
information, see the User Preferences chapter.
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User Interface
This chapter contains the following topics:
•
•
•
•
•
•
•
•

Screen Layout
Toolbars and Tool Windows
Buffers and Editor Windows
Accessing Menus
The SlickEdit® Command Line
Screen Management
Using the Mouse and Keyboard
Printing
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Screen Layout
The SlickEdit® Interface
SlickEdit® uses a Multiple Document Interface (MDI), common to Windows applications that support
editing multiple documents. The outer window is called the MDI frame or window. For a non-clipped MDI
child window, start a new instance of SlickEdit.

SlickEdit contains the following screen elements:
•

Title bar - The title bar shows the product name and the name and path of the file currently in
focus.

•

Main menu - The main menu is displayed under the title bar (File, Edit, Search, etc.).

•

Standard toolbar - Toolbars are groups of buttons (called toolbar controls) that allow you to
perform specific operations. The Standard toolbar is displayed and docked under the main menu
by default. Toolbars can be moved by clicking and dragging the grab bars (or title bar if floating).
See Toolbars and Tool Windows for more information.

•

Editor pane - The editor pane is the viewing area within SlickEdit inside of which editor windows
(files or buffers that are being editing) are floating or docked.

•

Editor windows - Editor windows are files or buffers that are open for editing and are docked or
floating inside of the editor pane. See Buffers and Editor Windows for more information.
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•

File tabs - File tabs are displayed for open buffers and files. Right-click on file tabs to display a
menu of save, close, and window splitting options. Display of file tabs can be toggled from the
main menu by clicking View > Toolbars > File Tabs.

•

Tool windows - Tool windows are similar to toolbars except they may also contain settings and/or
allow the viewing of information, and they can be docked. You can auto-hide a tool window by
clicking on the Pin button in the top right corner. See Toolbars and Tool Windows for more
information.

•

Size bars - Size bars indicate the parts of SlickEdit that can be resized. When the pointer
becomes a double-headed arrow, click and drag to adjust the size in the direction indicated.

•

Message line and SlickEdit command line - The message line appears at the bottom of the
SlickEdit application window. It displays a single line of information, providing feedback from
various operations in SlickEdit. The message line and the command line share the same screen
space. As a result, when clicking the message line or invoking an editor command that requires
the command line, the message line is hidden and the command line is displayed. See The
SlickEdit® Command Line for more information.

•

Status line - The status line holds the following indicators:
o

Line and column indicators - To the right of the message/command line are the line and
column indicators for the current cursor position. Click on these indicators to move the cursor
position.

o

Line/character count indicator - This displays the number of lines or characters in the
current selection. This is useful to measure the length of a word or string, or the number of
lines in a function. Click on the indicator or use the select_toggle command to create
successively larger common selections. For example, if you have a character selection, you
can click on the indicator or use select_toggle to extend the selection to include the entire
word. See Selection Indicator for more information.

o

Permissions toggle - This area indicates the read/write permission setting of the file or buffer
in focus. The letters RW indicate that the current file or buffer is read-write. The letters RO
indicate that the file or buffer is read-only. Click on the letters to toggle between modes.
You can configure the editor to prevent modification of read-only files. To access this setting,
click Tools > Options > Editing > General, then set the option Protect read-only mode to
True. Now the editor will not let you modify a file that is in read-only mode. The save
command will always prompt for a different output file name if the file is in read-only mode.

o

Macro recording indicator - When a macro is being recorded, the recording indicator REC is
active (not dimmed). Click on the indicator or use the record_macro_toggle command to
toggle recording on and off. See Recorded Macros for more information.

o

Insert or Replace toggle - The Insert/Replace toggle is located to the right of the recording
indicator. The letters Ins indicate that the editor is in Insert mode (default). In Insert mode,
typing a character pushes characters at and after the cursor to the right. The letters Rep
indicate that the editor is in Replace mode. In Replace mode, typing a character replaces the
character under the cursor. Click on the letters to toggle between modes.
To start in Replace mode instead of the default Insert mode each time the editor is invoked,
from the main menu, click Tools > Options > Editing > General, then set the Start mode
option.

o
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Current character indicator - When editing an SBCS/DBCS mode file or non-Unicode file,
the current character is displayed in hexadecimal format. If the current character is a double
byte character (DBCS), then two bytes and its Unicode equivalent are displayed in
hexadecimal (95 74 U+4ED8). When editing a Unicode file, the current composite character is
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displayed in hexadecimal. The indicator field is blank when the cursor is past the end of the
line. See Encoding for more information about Unicode.

Tabular Lists
Several dialogs and tool windows in SlickEdit®, such as the Bookmarks Tool Window and the Key Binding
Options screen, present data in a tabular list.

To sort the data, click on a column header to sort in ascending order, or click again to sort in descending
order. An arrow in a column header indicates that the data is sorted by this column, and the direction of the
arrow indicates the ascending (up arrow) or descending (down arrow) sort order.
You can resize columns by clicking and dragging the column separators. If a file path column is not large
enough, the text is elided so that you can always see the file name. If a text column is not large enough,
the contents are abbreviated. You can always hover over a row with the mouse to see a tooltip that shows
the entire contents of each cell.
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Toolbars and Tool Windows
Toolbars are groups of buttons (called toolbar controls) that allow you to perform specific operations. Tool
windows are similar to toolbars except they may also contain settings and/or allow the viewing of
information. Both toolbars and tool windows can be docked. For documentation purposes, the terms
“toolbars” and “tool windows” are sometimes used interchangeably.

Displaying Toolbars and Tool Windows
By default, the Build, Output, Preview, References, and Search Results tool windows are docked into a tab
group on the bottom of the editor, while the Defs, FTP, Open, Projects, and Symbols tool windows are
docked into a tab group on the left side of the editor.
There are many more toolbars and tool windows that are not displayed by default. You can view and toggle
the display of these by clicking View > Toolbars, then selecting the toolbar or tool window to display or
hide.
NOTE Some tool windows that are used for debugging are only available when the editor is in debug
mode. See Debug Toolbars and Tool Windows for a list.

Docking and Grouping Toolbars and Tool Windows
Toolbars and tool windows have display and docking options, which are accessed by right-clicking on the
tool window’s title bar on Windows or the tool window’s background on UNIX/Mac:
•

Dockable - Toolbars and tool windows can be docked, or locked into, any edge within the editor
pane. When this setting is on, you can click on the toolbar or tool window’s title bar and drag and
drop the window into position. When multiple tool windows are docked to the same location, they
are automatically organized into tab groups.

•

Floating - This is the default setting when a toolbar or tool window is first displayed. It allows you
to click on the toolbar or tool window’s title bar and drag it around within the editor pane. When this
option is selected, the toolbar or tool window always appears on top of any open editor windows.

•

Auto-hide - This setting is only available for tool windows when they are docked. When the tool
window is not being used, it “slides” out of view and is replaced with a tab showing the name of the
tool window. Click on the tab to “slide” the tool window back into view. Click the Pin button on the
right of a tool window’s title bar to pin a tool window in place or unpin it to let it slide.

•

Hide - This setting hides the toolbar or tool window. To view it again, from the main menu, click
View > Toolbars.

CAUTION If you un-dock a tool window that has been docked, the tool window may be destroyed
and re-created, so you may lose any data that has been entered.

Customizing Toolbars
Toolbars can be customized by using the Toolbar Options. To display these options, from the main menu,
click Tools > Options > Appearance > Toolbars. Or, right-click on any toolbar’s title bar and select
Customize.
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Changing Toolbar Button Command Properties
To change a toolbar button’s command binding, on the actual toolbar, right-click on any control and select
Properties. This will display the Toolbar Control Properties Dialog. You can change the command, the
description, and the button image, as well as the command key binding and auto-enable properties.

Available Toolbars and Tool Windows
The display of toolbars and tool windows can be toggled on and off by clicking the items in the View >
Toolbars menu, which are grouped as follows:
•
•
•

Tool Windows - grouped at the top of the menu
Toolbars - grouped at the bottom of the menu
Debug Toolbars and Tool Windows - grouped at the top of the menu when in debug mode

Tool Windows
The tool windows listed below are used for various operations, allow the viewing of information, and/or
provide option settings. They are grouped together at the top of the View > Toolbars menu.

Backup History
Creates a backup version of a file each time it is saved, creating a detailed version history for this file. This
is useful to track changes between check-ins. Use this tool window to compare previous versions to the
current version or restore a previous version of the file. For more information, see Backup History.

Bookmarks
Displays a list of bookmarks and provides operations to add, delete, and navigate to a selected bookmark.
This window can also be accessed by clicking Search > Bookmarks. For more details, see Bookmarks.

Breakpoints
Lists breakpoints (and exception breakpoints for Java) and allows you to modify them. You must use this
tool window to set breakpoint properties. It can be used when you are not in debug mode. Right-click within
the tool window to display a context menu which allows you to jump to the location of a breakpoint or
modify breakpoints. The Breakpoints tool window can also be accessed from the Debug > Windows
menu. For more details on this topic, see Setting Breakpoints.

Build
Docked as a tab along the bottom of the editor by default, the Build tool window, sometimes called the
“concurrent process buffer,” is a shell window that allows you to type operating system commands and see
the results. It displays output from a build, compile, or any other Build menu command which sends output
to the concurrent process buffer. Double-click on an error message to navigate to the error.
Right-click in the Build window to access build, search, and clipboard options. There are two options
settings that apply to the Build tool window:
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•

Auto exit process - To have the Build tool window automatically exited when the buffer is closed
or when exiting the editor, from the main menu, click Tools > Options > Editing > General, then
set the option Auto exit build window to True.

•

CR w/o LF erases line in build window - It is possible that output sent to the Build window may
contain carriage return (CR) characters without subsequent line feed (LF) characters. This causes
the line to be erased in the Build window. To prevent SlickEdit from erasing lines in this situation,
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from the main menu, click Tools > Options > Editing > General, then set the option CR w/o LF
erases line in build window to False.
For more details on this topic, see Building and Compiling.

Class
Docked as a tab on the left side of the editor by default, the Class tool window provides an outline view of
both the members of the current class as well as any visible inherited members. This tool window also
shows the inheritance hierarchy of the current class. This is useful for object-oriented programming
languages such as Java. In addition to the menu item, you can activate or toggle this window by using the
activate_tbclass or toggle_tbclass commands. See Class Tool Window for more information.

Clipboards
Allows you to preview and manage clipboards. Shows a list of recently used clipboards and lets you insert
a clipboard into the current buffer. The tool window contains a Preview area that lets you see the entire
contents of a clipboard with color coding. In addition to the View > Toolbars > Clipboards menu item,
there are several other ways to display the tool window:
•
•
•

Using the menu item Edit > List Clipboards (Ctrl+Shift+V or list_clipboards command)
Using the activate_clipboards command
Toggle the window with the toggle_clipboards command

See Clipboards for more information.

Code Annotations
Code Annotations allow you to store information about code–such as task notes, personal comments, and
review comments–without actually modifying the code. This tool window provides a detailed view of
annotations that you have created as well as operations for adding, modifying, and removing annotations.
You can also use the tool window to create your own annotation types. See Code Annotations for more
information.

Current Context
Docked in the top upper-right section of the editor by default, Current Context displays the logical location
of the cursor within your code. If it is within a class, it displays the class name. If it is within a function, it
displays the function name. If the function is within a class, it displays the class and the function name. See
Current Context Tool Window for more information.

Defs
Docked as a tab on the left side of the editor by default, the Defs (Definitions) tool window contains the defs
browser, which provides an outline view of symbols in the current workspace. In addition to the menu item,
you can activate or toggle this window by using the activate_defs or toggle_defs commands. See Defs
Tool Window for more information.

Exceptions
Allows you to add, edit, disable, and delete breakpoints. For more information, see Setting Breakpoints.

File Tabs
Toggles visibility of the tabs for the open buffers in the editor. By default, these tabs are visible and the
maximum number that can be displayed is 255. Right-click on the file tabs to display a menu of save,
close, and window splitting options. For more information, see Buffers and Editor Windows.

SlickEdit® User Guide

69

TOOLBARS AND TOOL WINDOWS

Files
Allows you to view open files, project files, and workspace files, sortable by file name or path. Contains a
filter to narrow the list of files incrementally, as well as shortcuts for basic file operations (Open, Save, etc.).
This tool window can also be displayed by clicking Document > List Open Files (Ctrl+Shift+B), or by
using the list_buffers command. For more information, see Files Tool Window.

Find and Replace
Used to perform search and replace operations. This tool window can also be displayed by using the key
binding Ctrl+F or by clicking Search > Find. See Find and Replace and Find and Replace Tool Window for
more information.

Find Symbol
Used to locate symbols which are declared or defined in your code. It allows you to search for symbols by
name using a regular expression, substring, or fast prefix match. See Symbol Browsing and Find Symbol
Tool Window for more information.

FTP Client
Used to connect to FTP servers and transfer files. As with most FTP clients, local directories and files are
displayed in the left section of the tool window and the FTP server directories and files are on the right.
Right-click on files to display a menu of FTP operations. See Working with FTP for more information.

FTP
Used to connect to FTP servers and open files. Right-click on files to display a menu of FTP operations.
See Working with FTP for more information.

Message List
Automatically displays output messages from processes running in SlickEdit®, such as build warnings and
errors. This tool window is docked into the bottom tab group of the editor by default. In addition to the menu
item, you can activate or toggle this window by using the activate_messages or the toggle_messages
command, respectively. See Message List for more information.

Open
Docked as a tab on the left side of the editor by default, the Open tool window can be used to browse
directories and open files on disk. Right-click in the Files list to display a menu of options. For more
information about opening files, see Opening Files.

Output
Docked as a tab on the bottom of the editor by default, the Output tool window displays output from various
operations within the editor, such as errors.

Preview
Docked as a tab on the bottom of the editor by default, the Preview tool window provides a portal for
viewing information in other files without having to open them in the editor. It automatically shows this
information when you are working with certain features. In addition to the menu item, you can activate or
toggle this window by using the activate_preview or toggle_preview commands. See Preview Tool
Window for more information.
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Projects
Contains the project browser, which allows you to browse the files in your open workspaces. It is docked as
a tab on the left side of the editor by default. See Workspaces and Projects for more information.

References
Docked as a tab on the bottom of the editor by default, the References tool window displays the list of
symbol references (uses) found the last time that you used the Go to Reference feature (Ctrl+/ or
push_ref command—see Symbol Navigation for more information). In addition to the menu item, you can
activate or toggle this window by using the activate_refs or toggle_refs commands. See References Tool
Window for more information.

Regex Evaluator
Provides the capability to interactively create and test regular expressions. You can also access this
window by clicking Tools > Regex Evaluator. See The Regex Evaluator for more details.

Search Results
Docked as a tab on the bottom of the editor by default, this window displays the results of multi-file
searches, or when the option List all occurrences is selected on the Find and Replace Tool Window. See
Find and Replace for more information about searching and replacing.

Slick-C® Stack
Displays errors that occur within the editor. If errors occur during normal use, you can send this information
to Product Support as a reference (see Contacting Product Support). If an error occurs in one of your
macros, you can use this information to help debug it. Double-clicking on a line of code in this window will
open the file and go to the line in the file that contains the error.

Symbols
Docked as a tab on the left side of the editor by default, the Symbols tool window contains the symbol
browser, which lists the symbols from all of the tag files. In addition to the menu item, you can activate or
toggle this window by using the activate_symbols or toggle_symbols commands. See Symbols Tool
Window for more information.

Symbol Properties
Displays detailed information about the symbol at the cursor location. Note that you cannot use this
window to change the properties. See Symbol Properties Tool Window for more information.

Unit Testing
Provides an interface to run JUnit unit tests and view the results. See JUnit Testing for more details.

Toolbars
Toolbars are listed below, and are grouped together at the bottom of the View > Toolbars menu.

Debug
Provides buttons for commonly used debugger commands including start, restart, step, toggle breakpoint,
and add watch. It is also very useful when you are not in debug mode. For more information about
debugging within SlickEdit®, see Debugging.
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Edit
Contains operations to edit text, such as convert to uppercase, indent lines, etc. These are the same
options found under the main menu item Edit. For more information, see Text Editing.

HTML
Used to insert tags and values into an HTML file, spell check from the cursor or on selected text, beautify
the document, open an FTP connection for transferring files, and more. For more information about these
operations, see the topics HTML, Spell Checking, and FTP.

Project Tools
Contains options for the current project to process compiler error messages, run the build and compile
commands, and check files in or out of version control. See Building and Compiling and Version Control for
more details on these operations.

Selective Display
Allows you to collapse unwanted lines of code so you can better see the structure of your code. Buttons
allow you to outline a file with function headings, hide selected lines or lines inside code blocks, display the
Selective Display dialog box, and end selective display. See Selective Display for more information about
this feature.

Standard
Toggles display of the Standard toolbar, which contains buttons for commands common to most
applications, including Open File, Save, Cut, Copy, Paste, Undo, Redo, etc. By default, this toolbar is
docked along the top of the editor just under the main menu.

Context Tagging®
Contains several buttons for manipulating tags and navigating. For information about these operations,
see the following topics: Building and Managing Tag Files, Find and Replace, Bookmarks, and Navigation.

Tools
Contains shortcut buttons for commonly used tools and operations within SlickEdit®, such as
beautification, DIFFzilla®, merging, spell checking, and more. For more information about these
operations, see the following topics: Beautifying Code, Comparing and Merging, Find File Dialog, Using
the Calculator and Math Commands, Spell Checking, and Hex Mode Editing.

XML
Contains options to beautify and validate XML documents. See XML for more information about these
operations.

Debug Toolbars and Tool Windows
The toolbars and tool windows listed below are used for debugging. In debugging mode, the View >
Toolbars menu displays a group of these items at the top, and they are also accessible from the Debug >
Windows menu. See Debugging for more information about working with these features.

Debug
This toolbar is available when not in debug mode. See Debug tool window described previously.
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Autos
Displays the contents of auto, local, and member variables used before and after the current execution
line. Right-click within the tool window to display a context menu which allows you to jump to the definition
of a variable or add a variable to the watches.

Breakpoints
This tool window is also available when not in debug mode. See Breakpoints tool window described
previously.

Call Stack
Displays the stack for the thread selected in the Thread combo box. Double-click on a method to navigate
to any stack execution point.

Loaded Classes
(Java only) Displays the currently loaded classes. Double-click on a class to display class properties.
Double-click on a member to go to the definition of the member. Right-click on a method and select Set
breakpoint to add a breakpoint to a method. Right-click on a member variable and select Add Watch to
add a watch on a static class member. Use the Show system classes check box to display classes
outside the scope of your workspace, like classes in the JFC.

Debug Sessions
Lists the open debugging sessions.

Exceptions
The Exceptions tool window is also available when not in debug mode. See Exceptions tool window
described previously.

Locals
Displays the locals variables for the method selected in the Stack combo box. You can modify the values
of variables by double-clicking in the Value column of simple types.

Members
Displays the value of static and non-static members for any method context. You can modify the contents
of a member variable by specifying a valid Java expression. Right-click within the tool window to display a
context menu which allows you to jump to the definition of a variable or add a variable to the watches. You
cannot add or remove entries from an array.

Memory
(GNU C/C++ only) Displays the contents of the specified memory address. Enter the memory location in a
hexadecimal, decimal, or any valid C expression. In addition, you may specify the number of bytes to
display.

Registers
(GNU C/C++ only) Displays the contents of hardware registers.

Threads
Allows you to view the threads currently running and choose a thread context, so you can view the stack
for a particular thread. It displays the thread, group, status, and state.
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Watch
Contains watch tabs that are used to display the value variables or expressions you specify for the context
method. There are several ways to add a new watch variable or expression:
•
•
•

Double-click on the <add> text in the Name column of the tool window.
Right-click on a variable or selected expression and select Add Watch.
Select a variable or expression, then from the main menu, click Debug > Add Watch.

To display a context menu which allows you to jump to the definition of a variable or delete a watch
expression, right-click within the Watch tool window.
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Buffers and Editor Windows
When you edit a file, it is loaded into a buffer. A buffer is the in-memory representation of the file. Your edits
are made to the buffer, but the file is not updated until you save it. Buffers are displayed in editor windows
in the editor pane. An editor window can be maximized to fill the entire pane, or you can organize the
windows within the editor pane. Each buffer has an associated tab in the File Tabs tool window, which
displays the name of the file. In general, you will have a one-to-one relationship between files and buffers.
If you open a file that is already open, the existing buffer is displayed. Therefore, the terms “file” and
“buffer” are sometimes used interchangeably.
When a buffer is modified (changed and not yet saved), there are two visual indicators:
•

An asterisk will be displayed to the right of the file name in the title bar.

•

The file name on the file tab turns red.

TIP For a list of Slick-C® buffer and window functions and commands, see “Macro Functions by
Category” in the Help system.
SlickEdit® provides two main approaches to managing buffers and editor windows, controlled through the
Files per window option (Tools > Options > Editing > Editor Windows). The value for this option affects
the behavior of the window and buffer switching commands, described later in this section.
1. One file per window - This maintains a one-to-one correspondence between a buffer and an
editor window. Each buffer is displayed in its own editor window. This is the default behavior for
SlickEdit. This approach is preferred by many for its simplicity.
2. Multiple files share window - With this approach, you determine how many editor windows you
want and you select the buffer to display in each. You have to manually create a new editor
window (typically by splitting or duplicating an existing window). All buffers are available to all
windows. You can use the file tabs to select the buffer to edit, which will place the buffer in the
currently active editor window. You can also use Document > List Buffers (list_buffers
command) to view a list of the buffers and select one. This approach appeals to users who like a
particular arrangement of windows and use editor windows for specific tasks.

Managing Windows
File Tabs
When you open buffer or file in SlickEdit®, by default, an associated file tab is displayed at the bottom of
the editor window to indicate the name of the file. You can click on a file tab to select the buffer you want to
edit, placing the selected buffer into the currently active editor window.

The area where file tabs are displayed is called the File Tabs tool window. You can toggle display of this
area, turning file tabs on and off, by selecting View > Toolbars > File Tabs from the main menu, or by
using the toggle_filetabs command. The maximum number of file tabs that can be displayed is 255.
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By default, file tabs do not show the complete name of the file when adjacent files differ only by file
extension. This saves space and provides better visibility for associated files. For file names to be
abbreviated in this style, their paths and base file name must match exactly. For example,
C:\rectangles\BorderRectangle.cpp would not abbreviate with
C:\src\include\BorderRectangle.h. You can turn this feature on and off for all file tabs by right-clicking
in the File Tabs tool window and selecting Abbreviate similar files from the context menu.
When a buffer is modified (changed and not yet saved), the text of the file tab turns red by default. You can
change the color of modified file tabs with the Modified file tab(s) screen element (Tools > Options >
Appearance > Colors).
Some file tabs, like those for search results buffers, build output, and File Manager operations, display a
picture by default. You can further save space in the file tabs area by turning pictures off. To turn pictures
on and off for all file tabs, right-click in the File Tabs tool window and select Show pictures from the
context menu.
When you create a new, unnamed “scratchpad” buffer, it is indicated by the text “Untitled” in the file tab
along with a number that indicates the internal ID. You can create a scratchpad buffer by using the menu
item File > New and not naming the file.
If you prefer to keep your hands on the keyboard for buffer/file navigation, two commands are available:
next_buff_tab and prev_buff_tab. Use these commands to navigate through the file tabs in the order
they are displayed. Both circle around to the other end when you are on the last item. These commands
are not bound to keys by default. To create key bindings for these commands, see Creating Bindings.
The right-click context menu in the File Tabs tool window provides more operations such as Save, Close,
Close All, Close Others, etc., as well as window splitting options. These are described throughout the
documentation where applicable.

Changing the Window Left Margin Width
The left margin of an editor window is used to give visual indicators for certain operations (such as when
diffing files). Increasing the size of the window left margin can make it easier to create line selections with
the mouse. It also prevents window contents from jumping to the right when a bookmark, breakpoint, or
error is first displayed.
To specify the space between the left edge of the window and the editor text, click Tools > Options >
Appearance > General, then set the value of the option Window left margin to the amount of space
desired in inches. This value has no effect when there are bitmaps displayed in the left margin, since more
space is necessary.

Splitting Windows
To split the current editor window into two parts so you can view/edit different parts of the same buffer at
the same time, click Window > Split Horizontally (Ctrl+H or hsplit_window command) or Window >
Split Vertically (vsplit_window command). You can also right-click on the file tab of the current window to
perform the same operations.
To view two different editor windows side-by-side, while the focus is on the current editor window, rightclick on the file tab of the window you want to compare it with and choose one of the Split...with
operations.

Duplicating Windows
To create a duplicate of the current editor window, use the duplicate_window command (Window >
Duplicate). This will create a new window linked to the current buffer.
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Cascading and Tiling Windows
To resize and arrange the open editor windows in a cascading display, click Window > Cascade
(cascade_windows command).
To resize and rearrange the open editor windows so they don’t overlap, click Window > Tile
(tile_windows command). If there are three or fewer open editor windows, they will be tiled vertically. To
tile three or fewer windows horizontally, click Window > Tile Horizontal (tile_windows h).

Manipulating Tiled Windows
There are several SlickEdit® commands that can be used when the windows are tiled:
•

window_below - Switches to the window tile below the current window, if one exists.

•

window_left - Switches to the window tile to the left of the current window, if one exists.

•

window_right - Switches to the window tile to the right of the current window, if one exists.

•

move_edge - Moves the adjoining edge of a tiled window. This command is bound to Alt+F2.
Press Alt+F2, then use the arrow keys to move the cursor to point to the window edge and move it
to the new edge position, then press Enter.

•

delete_tile - Deletes an adjacent tiled window. Use the arrow keys to point to the edge of the
window you wish to delete.

Maximizing and Minimizing Windows
By default, editor windows are floating when they are first opened. To specify that all editor windows should
be maximized when they are first opened, from the main menu, choose Tools > Options > Editing >
Editor Windows, set the option Maximize first window to True.
To maximize an editor window, click the Maximize button on the window’s title bar, or use the
maximize_window command. You can also toggle the existing state with a maximized state by using the
zoom_window command (Window > Zoom Toggle or Ctrl+Shift+Z).
To minimize an editor window to an iconized state, click the Minimize button on the window’s title bar, or
use the iconize_window command. To iconize all open editor windows, use the iconize_all command.
When a window is iconized, you can click on the title bar for a menu of operations such as Restore, Move,
Close, and Next. Use the mouse to drag the iconized windows around the editor pane. Use the
arrange_icons command (Window > Arrange Icons) to re-dock the iconized windows along the bottom
edge of the editor pane.
To restore an iconized window to its previous state, click the Restore Up button on the window’s title bar,
or use the restore_window command. To restore all iconized windows, use the restore_all command.

Setting the New Window Size
You can specify a custom width and height for new floating editor windows through options on the Options
dialog. To access them, from the main menu, click Tools > Options, then expand Editing and click Editor
Windows. Alternately, use the new_window_size command as a shortcut to open the Options dialog to
the correct option screen.
To specify a custom width and height, complete the following steps:
1. Set the value of both options New window width and New window height to be Custom value.
2. In the Custom window width and Custom window height boxes, type the size, in pixels.
See Editor Window Options for more information about all of the available options.
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Switching Between Buffers or Windows
The method for switching the buffer or window with which you are working depends on whether you are
using a one-to-one relationship between buffers and files (see the introduction to Buffers and Editor
Windows). If you have selected One file per window, switching buffers and switching windows is the
same thing. If you have Multiple files share a window selected, then these are two very different
operations and you manipulate windows and buffers separately.
There are many styles and commands for switching between buffers and windows within the editor, and
we encourage you to try them out and pick the method that works best for you.
Using the mouse, you can switch between editor windows by clicking on the file tabs or by using the
Window menu items. By default, the active window will change when you switch to a specific file or buffer,
unless the active window is already displaying the buffer you select (see Linking to a Window below).
TIP For information about navigating within files, see Cursor Navigation.

Next Window Style
The default next window style is Smart Next Window. This style allows you to press Ctrl+Tab
(next_window command) to switch the focus between the two most frequently used open editor windows,
rather than always going to the next window. Press Ctrl+Shift+Tab (prev_window command) to switch
between all open editor windows. This style is similar to how Ctrl+Tab and Ctrl+Shift+Tab work in other
Windows MDI applications, like Visual Studio.
Smart Next Window is on by default (Tools > Options > Editing > Editor Windows > Smart next
window style). There are two alternatives to this behavior (note that all three options are mutually
exclusive):
•

Reorder windows - If this option is selected, activating an existing window reinserts the window
after the current window. Neither Ctrl+Tab nor Ctrl+Shift+Tab reorders the windows. This option
is very good for switching between more than two files, but it is not the Windows standard (which
means you’re probably not used to it). It's similar to the way SlickEdit® reorders buffers.

•

No window reordering - If this option is selected, newly opened windows are inserted after the
current window. Activating an existing window, pressing Ctrl+Tab, or pressing Ctrl+Shift+Tab
does not reorder windows. This option is best if you like to memorize the hot key numbers on the
Window menu (for example, Alt+W 1) because it attempts to keep the hot key numbers the same.

Buffer and Window Switching Commands
The following is a list of SlickEdit® commands that you can use to switch between buffers and windows:
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•

next_buff_tab/prev_buff_tab - Navigates through the buffer tabs (also called file tabs) in the
order they are displayed. next_buff_tab moves to the right and prev_buff_tab moves to the left.
Both circle around to the other end when you are on the last item. These commands are not bound
to keys by default.

•

next_buffer/prev_buffer - Navigates through the buffers in the order they were last used. If you
are using multiple files per window, then you need to use this to cycle through the buffers
associated with a particular window. These commands are bound respectively to the menu items
Document > Next Buffer (Ctrl+N) and Document > Previous Buffer (Ctrl+P).

•

forward/back - Same as next_buffer/prev_buffer. These commands are bound to the green
arrows on the Standard toolbar and the forward/back mouse buttons.

•

next_window/prev_window - Moves between editor windows. If you are using the option One
file per window (on by default), then this is the same as next_buffer/prev_buffer. If you are
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using multiple files per window, you can use this to navigate between editor windows, but you will
need to use next_buffer/prev_buffer to cycle through the buffers within a particular window. The
next_window and prev_window commands are bound respectively to the menu items Window >
Next (Ctrl+Tab or Ctrl+F6) and Window > Previous (Ctrl+Shift+Tab or Ctrl+Shift+F6).

Listing Open Files
To view and work with a list of open files in SlickEdit®, click Document > List Open Files (Ctrl+Shift+B),
or use the list_buffers command. This will display the Files tool window, which contains an alphabetized
list of the files and buffers currently open in the editor.
NOTE For documentation purposes, the word “files” generally includes both files and buffers.

TIPS
•

By docking this tool window, you have quick access for switching between files or opening
other files. Right-click on the title bar and select Dockable, then drag and drop the window
to your desired location.

•

When the Files tool window is not docked, it can be dismissed by opening a file for editing or
by pressing Esc. To make this dialog behave like other tool windows, right-click inside the
Files list area and uncheck Dismiss on select.

•

The Files tool window can also show a list of files in the active project or workspace. Use the
View buttons or the view settings on the right-click menu to change the display.

Using the buttons on the Files tool window (or the right-click menu), you can perform the following
operations:
•

Open - Opens and brings that file into focus, ready for editing. The active file is listed in the tool
window in a bold font. You can also open files by double-clicking on them, or by pressing Enter or
Alt+E.

•

Save - Saves the selected file(s). Modified files have a Disk bitmap in the left margin of the tool
window, and are listed in a red font; when selected, they have a red highlight. You can also click
the Disk bitmap to quickly save a modified file, or press Ctrl+S, Alt+S, or Alt+W.
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•

Close - Closes the selected file(s) in the editor. You can also press Delete, Alt+C, or Alt+D to
close a selected file. Upon close, you are prompted to save modified buffers. If you are using the
option One file per window (Tools > Options > Editing > Editor Windows > Files per window),
which is on by default, all windows displaying the buffer are closed as well.

Sort any column by clicking on the column header. When you click to sort, an arrow on the right side of the
column header shows the ascending or descending order.
Use the Filter text box to display matching file names. Right-click inside the Files list area to enable Prefix
match inside the Filter text box. When the focus is not in the Filter text box, you can incrementally search
the list of file names by typing the first few characters of the name. See Working with the Files List for more
details about filtering and searching the Files list.
TIP You can collapse display of the buttons and the Filter text box by clicking the Minus button in the
top-left corner of the tool window. The collapsed area is replaced with a message that states your
current view and filter settings. To view the buttons and Filter text box again, click the Plus button.
Collapsing the buttons and filter gives your window a cleaner look and more room for file listings.
For more detailed information about using the Files tool window, see Files Tool Window.

Linking to a Window
You can change the buffer that is displayed in the current window by using the Link Window dialog
(Window > Link Window or link_window command), pictured below. This is especially useful if you like
to work with split windows, for quickly bringing the buffers you want to view into focus.

Select the buffer that you want, then click Link to Window. To start a process buffer in the current editor
window, click Start Process. If a process buffer has already been started, it is linked to in the current
window. See also Link Window Dialog for more descriptions of the available options.
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Closing Buffers and Windows
To close an editor window, click Window > Close (Ctrl+F4 or close_window command), or File > Close
All (close_all command) to close all open editor windows. You will be prompted to save any modified
buffers.
You can also access these items from the right-click context menu on the File Tabs tool window, as well as
an additional operation, Close Others, which closes all open files except for the one selected.
See Closing Files for more information about closing buffers and files.
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Accessing Menus
By default, the SlickEdit® main menu appears under the title bar of the editor (File, Edit, Search, etc.) and
provides a way to access most of the editing features within SlickEdit. For listings of all the menus and
associated dialogs and tool windows, see the Menus, Dialogs, and Tool Windows chapter.
Menu items are mapped to commands, so all of the items that you can access through a menu have
command line counterparts. For example, to cut selected text, you could use the menu item Edit > Cut, or
you could use the cut command. You can edit and customize menus with the use of macros. See Creating
and Editing Menus for more information.

Right-Click Context Menus
Click the right mouse button to access submenus or context-sensitive menus that list commonly used
editing functions. Context-sensitive menus are supported in edit windows, all toolbars, and in many dialog
boxes, including the DIFFzilla® Dialog, the Multi-File Diff Output Dialog, and the Context Tagging® - Tag
Files Dialog.

Context Menu Settings
Language-specific settings are available for specifying which context menu to display in the editor window,
based on whether text is selected.
To access these options, from the main menu, click Tools > Options > Languages, expand your language
category and language, then select General. Choose from the following options in the Context menus
group box:
•

Menu if no selection - This specifies that the context menu is displayed when right-clicking in an
editor window that does not have a selection.

•

Menu if selection - This specifies that the context menu is displayed when right-clicking in an
editor window that does have a selection.

•

Select first (affects all extensions) - When checked (default), a selection can be made with the
right mouse button instead of displaying the language-specific menu. When this is not checked,
select menu items by clicking and dragging the mouse.

Menu Hotkeys
A menu hotkey allows you to choose items from the main menu using the keyboard. This is done using the
Alt key and a letter in the menu item. This works independently from key bindings, which bind arbitrary key
sequences to commands. If a menu item has a key binding, it is shown to the right of the menu entry. See
Key and Mouse Bindings for more information about key bindings.
SlickEdit provides two options for menu hotkeys:
•

Alt Menu - When selected, pressing the Alt key switches focus to the menu bar and underlines the
hotkeys. Now, when you type a letter, it selects an the corresponding item on the menu.

•

Alt Menu Hotkeys - For emulations other than CUA, selecting this option gives priority to the menu
hotkeys, overriding any key bindings using the same Alt key combination.

Alt Menu
When you press the Alt key in SlickEdit without following it with another key, focus shifts to the menu bar,
and the hotkeys in the menu names are underlined. Pressing one of the underlined letters will activate the
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corresponding menu or menu item. For example, press Alt,V,A to invoke the View > Show All command.
Pressing Alt again toggles the focus back to the cursor location. This is controlled by the Alt menu option
(Tools > Options > Keyboard > Advanced), which is on by default.
TIP On Microsoft Windows, to force menu names to be underlined all the time instead of just when
you press Alt:
1. Right-click on the desktop and select Properties.
2. Select the Appearance tab.
3. Click on Effects.
4. Uncheck Hide underlined letters for keyboard navigation until I press the Alt key.
5. Click OK.

Alt Menu Hotkeys
This option applies only to non-CUA emulations. You can make Alt-prefixed key bindings display the
corresponding drop-down menu. For example, when you press Alt+F (where F corresponds to the
underlined letter on the File menu), the File menu drop-down is displayed. Thus, pressing Alt+F,D will
invoke the File > Change Directory command. To enable this option, set the Alt menu hotkeys option
(Tools > Options > Keyboard > Advanced) to True.
CAUTION When this option is enabled, the Alt menu hotkeys may override your normal key
bindings.

Short Key Names in Menus
The SlickEdit® main menu displays the key bindings for commands associated with each menu entry.
These bindings can be condensed for non-CUA emulations. For example, Ctrl+O becomes C-O. To
enable this behavior, set the option Short key names (Tools > Options > Appearance > Advanced) to
Condensed.
See Key and Mouse Bindings for more information about working with bindings in SlickEdit.
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The SlickEdit® Command Line
SlickEdit provides a command line as a means to execute most SlickEdit operations without taking your
hands off of the keyboard. This is useful for less frequently used operations that may not warrant a key
binding, or complex commands that require arguments.
TIP SlickEdit® commands that contain two or more words are written throughout our documentation
with underscore separators: for example, cursor_down. Note that in the user interface, however,
these commands are displayed with hyphen separators: for example, cursor-down. Both of these
forms work in SlickEdit, so you can use whichever style you prefer.

Activating the Command Line
To activate or toggle the SlickEdit® command line in any emulation, click on the message line with the
mouse. Key bindings are also provided for toggling the cursor to the command line, based on your
emulation:
•
•
•
•
•
•
•
•
•
•
•
•
•

BBEdit - Esc
Brief - Esc
CodeWarrior - Esc
CodeWright - F9
CUA (SlickEdit’s default emulation) - Esc
Epsilon - Alt+X or F2
GNU Emacs - Alt+X or F2
ISPF - Esc
SlickEdit (Text Mode edition) - Esc
Vim - Ctrl+A
Visual C++ - Esc
Visual Studio default - Esc
Xcode - Esc

See Emulations for more information.

Command Line History
The SlickEdit® command line maintains a command history, allowing you to quickly reuse previously
entered commands. Once the command line is open, use the arrow keys to scroll up and down in the
command history.

Command Line Completion
As you type a command on the SlickEdit® command line, a list of matching completions is displayed,
including any command line arguments used in a previous command. Use Tab or the Down arrow to move
to the next command in the list, and Shift+Tab or the Up arrow to move to the previous command. Press
the Enter key to select the current command.

SlickEdit® User Guide

85

THE SLICKEDIT® COMMAND LINE

Some commands, like set_var, prompt for arguments. SlickEdit maintains a history of arguments used for
each command. Use the same completion and history mechanism as described above for commands to
complete arguments. Typically, the most recent argument you typed is automatically displayed.
TIP Command completions are useful for discovering operations in SlickEdit. For instance, to find all
operations that begin with “find”, type find in the command line, and SlickEdit will display a list of
those commands. Some search commands do not begin with “find”, like gui_find, so you may not
discover all related commands this way. To find all commands containing the word “find,” use the
Key Bindings options page (Tools > Options > Keyboard > Key Bindings or gui_keybindings
command). See Key and Mouse Bindings for more information.
For information about other items that can be automatically completed, see Completions.

Disabling Command Line Completions
To disable command line completions, from the main menu, click Tools > Options > Appearance >
General and set the option List command line completions to False. Note that this option does not
apply to the Vim command line.

Using Shortcuts Inside the Command Line
The SlickEdit® command line is a text box control just like the text boxes that appear in various dialog
boxes. For a list of key shortcuts that can be used inside the command line and other text boxes within
SlickEdit, see Key Shortcuts in Text Boxes.

Using the Command Line to View Key Binding
Associations
You can use the SlickEdit® command line to determine what keys are associated with what commands,
and vice-versa.
TIP Alternatively, you can use the Key Bindings options page (Tools > Options > Keyboard > Key
Bindings or gui_keybindings command) to see a list of command/key binding associations. See
Key Binding Options for more information.

Determining the Command of a Key Binding
To determine the function of a key or key binding, use the what_is command (Help > What Is Key). For
example:
1. Click Help > What Is Key, or activate the SlickEdit® command line (by pressing Esc) and type
what_is (or type what and press the spacebar for auto-completion), then press Enter.
2. The command line will prompt with the text What is key. Enter the key sequence in question. A
message box will be displayed with the information. If the key or key sequence is not bound to a
command, no message will appear.

Determining the Key Binding of a Command
To determine the key to which a command is bound, use the where_is command (Help > Where Is
Command). For example:
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1. Click Help > Where Is Command, or activate the command line and type where_is, then press
Enter.
2. The command line will prompt with the text Where is command. Enter the command in question.
The status line will display the key binding or state that the command is not bound to a key.

Command Line Switches
In addition to setting options through the graphical interface, you can specify or override some options on
the SlickEdit® command line for immediate, one-time use. This way, you don’t need to constantly open the
Options dialog to change an option every time you want to enable or disable it. For example, when using
the save or save_as command, you can specify many of the Save File Options, such as Expand tabs to
spaces, for just this one operation.
Switches are described in the documentation when the switch is helpful or applicable. To use a switch, type
it between the command and file name. Depending on whether you want to enable or disable the option,
type a plus (+) or minus (-) sign before the switch character. No matter the default setting, the specified
switch will be used.
For example, perhaps you have the Save File Option Expand tabs to spaces set to False. This means
that when you save a file, tabs are not expanded to spaces. However, you may want to quickly save a file
with tabs expanded. To enable the option just this once, use the save command with the E switch, as
follows:
save +E

Starting a Program from the Command Line (Shelling)
You can use the SlickEdit® command line to start a program. Click on the command line or press Esc to
toggle the cursor to the command line. Type the program name and arguments and press Enter. When
entering a command that the editor does not recognize as an internal command, a path search is
performed to find an external program to execute. To use a program whose name contains space
characters, enclose the name in double quotes. For example, “this is” will start a program named this
is.exe if it exists.
Executing the command dir (or ls) from the command line will invoke the SlickEdit File Manager. To
bypass an internal command, prefix the command with “dos”. To execute the dos dir command, type
dos -w dir and press Enter.
To get an operating system prompt, type the command dos with no arguments or from the main menu,
click Tools > OS Shell.

Command Line Prompting
Many commands that display dialog boxes have equivalent commands that prompt for arguments on the
SlickEdit® command line. For example, the gui_open command (File > Open or Ctrl+O), which displays
the Open file dialog, corresponds to the edit command, which is used to open files via the SlickEdit
command line. If you frequently use key bindings to open dialogs, a faster method of entering arguments is
to use Command Line Prompting. When this feature is enabled, you are prompted on the command line for
arguments that you would otherwise select as options on a dialog. For example, instead of displaying the
Open file dialog when you press Ctrl+O, the SlickEdit command line is invoked, so you can type the name
of the file to open and any other desired arguments. To enable Command Line Prompting, from the main
menu, select Tools > Options > Keyboard > Advanced and set the Command line prompting option to
True.
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The following table contains a partial list of user interface commands and their command line counterparts.
Graphical Command

Command Line Version

gui_open

edit

gui_find

find

gui_replace

replace

gui_write_selection

put

gui_append_selection

append

gui_margins

margins

gui_tabs

tabs

gui_find_proc

find_proc

Common SlickEdit® Commands
Commands are essentially the names of functions. The Help system contains a list of macro functions,
organized into categories (see Help > Contents > Macro Functions by Category). The following is a list
of twenty commands that we use frequently in our own work, which you may also find useful.
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1.

e file

Edit a file

2.

sa file

Save file as

3.

number

Go to line number

4.

f symbol

Find a symbol

5.

/search_string/options

Search for a string

6.

c/search/replace/options

Replace a string

7.

gt/search/options

Substring search for a symbol

8.

sb name

Set a bookmark

9.

gb name

Jump to a bookmark

10.

help topic

View Help on topic

11.

man command

Show UNIX man page

12.

cd directory

Change directory

13.

dir directory

Show directory in the File Manager

14.

list wildcards

Show directory tree in the File Manager

15.

del filename

Delete file

16.

pushd directory

Push directory

17.

popd

Pop directory
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18.

set env=value

Set environment variable

19.

dos command

Execute command outside of editor

20.

math expr

Evaluate expression
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Screen Management
There are several features regarding the handling of the monitor screen, as described below.

Multiple Monitor Support
SlickEdit® supports the use of multiple monitors on Windows, UNIX, and Mac OS X platforms. When the
application, or any dialog or tool window, is moved to a particular monitor, the location is remembered. If
you are running UNIX or Mac OS X and using multiple monitors that have different width and height values,
you will need to set the invocation option -summ. See Invocation Options for more information.

JAWS Screen Reader Software
JAWS®, the widely used Windows-based screen reading software developed by Freedom Scientific,
allows applications to be accessible by vision-impaired software developers. All toolbars, menus, tab
controls, and tree controls are accessible, along with all labels, controls, and contents of dialog boxes.
Additionally, JAWS accurately reads the contents of the editor pane, Output tool window, and Projects tool
window. Key bindings allow fast and accurate code navigation and control of other functionality.
The Context Tagging® features Color Coding, Go to Definition, and Go to Reference are not supported.
Access is provided to third-party integrated development environments and version control systems.
However, each third-party product is responsible for its own accessibility functionality.

Configuring JAWS
The installation program auto-detects if JAWS is installed. If detected, you are prompted to configure
JAWS. To manually configure JAWS, type the following text in the environment section of the
win\vslick.ini file (located in your SlickEdit® installation directory):
VSLICKJAWS=1
This is the only configuration needed.
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Using the Mouse and Keyboard
SlickEdit® provides four ways to launch operations: commands, menu items, key bindings, and buttons.
For example, to launch the Open dialog box in order to open a file, you could use any of the following
methods:
•
•
•
•

Type the gui_open command on the SlickEdit command line.
Click File > Open.
Press the key binding F7 or Ctrl+O.
Click the Open button on the Standard toolbar.

The command forms the basis of each method. As you can see, commands are often bound to more than
one key sequence. They can also be bound to mouse events, including the spin wheel. Key bindings are
the fastest and most efficient means of executing operations.
See The SlickEdit® Command Line for more information about commands, and Key and Mouse Bindings
for more information about bindings.

Key Shortcuts in Text Boxes
Most keyboard shortcuts for basic text operations can be used inside any text box in SlickEdit®, including
the SlickEdit command line, which is also a text box. The table below shows a list of these shortcuts, based
on the CUA emulation.
Note that even if you are not using the CUA emulation, by default, you can still use the common Cut/Copy/
Paste keyboard shortcuts inside text boxes (Ctrl+X/Ctrl+C/Ctrl+V, respectively). To disable this capability,
so that you can use your emulation’s Cut/Copy/Paste shortcuts, from the main menu, click Tools >
Options > Editing > General, then set the option CUA text box to False.
Text Box Editing Operation

Key Shortcut

Append Cut

Ctrl+Shift+X

Append to Clipboard

Ctrl+Shift+C

Copy Word to Clipboard

Ctrl+K

Copy

Ctrl+C

Cut Line

Ctrl+Backspace

Cut to End of Line

Ctrl+E

Cut Word

Ctrl+Shift+K

Cut

Ctrl+X

Delete Character Under Cursor or Selection

Delete

Delete Previous Character or Selection

Backspace

Expand Alias

Ctrl+Shift+O

Expand Partially Typed Parameter or Insert Space

Spacebar

Extend Selection to Mouse Position

Shift+Click

Insert Mode Toggle

Insert
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Text Box Editing Operation

Key Shortcut

List Clipboards

Ctrl+Shift+V

List Matches to Partially Typed Parameter

?

Lowercase Word

Ctrl+Shift+L

Move Cursor Left

Left arrow

Move Cursor Right

Right arrow

Move Cursor to Beginning of Line

Home

Move Cursor to End of Line

End

Next Word

Ctrl+Right arrow

Paste

Ctrl+V

Previous Word

Ctrl+Left arrow

Select Line

Triple-click

Select Text Between Cursor and Beginning of Line

Shift+Home

Select Text Between Cursor and End of Line

Shift+End

Select Word

Double-click

Redefining Common Keys
Many users have a preference for the functions of the keys Backspace, Delete, Enter, Tab, and Home.
Options are available for changing the function of these keys. To access these options, from the main
menu, click Tools > Options > Keyboard > Redefine Common Keys.
For a description of each option, see Redefine Common Key Options. For more information on changing
Tab key functions, see Indenting with Tabs.
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Printing
Printing within SlickEdit® varies slightly between Windows and UNIX (which includes Mac OS X)
platforms.

Printing on Windows
To print, from the main menu, click File > Print (or use the gui_print command). The Print dialog is
displayed, which allows you to specify the printer to use and set configuration options. After the printer is
specified and options configured, click Print to print the selection or active buffer.
Alternately, you can use the print command to immediately print the active buffer, or the print_selection
command to immediately print the selection, both based on the current configuration.

Windows Printer Configuration
To configure printing options, from the main menu, click File > Print (or use the gui_print command). The
Print dialog is displayed, as pictured below.

To print immediately using the current settings, click Print. To select the font used for printing, click Font.
For printer setup, click Setup.
For a complete list of the options on this dialog, see Print Dialog for Windows. The sections below describe
a few of the features.
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Header/Footer Print Settings
To define the contents of printed headers and footers, use the Header/Footer Tab of the Print dialog. Type
directly into the text boxes to specify text for the top left, center, and right headers and bottom left, center,
and right footers. Click the arrow to the right of each text box pick from a list of escape sequences to be
inserted. Escape sequences are values that are replaced with real data, such as %f (which will be replaced
with the file name) and %d (which will be replaced with the date).

Print Margin Settings
To define margin spacing, use the Margins Tab of the Print dialog. In the After header and Before footer
fields, enter the amount of spacing to come between the header and the first line on a page, and the
amount of spacing to come between the last line on a page and the footer.
In the top, bottom, left, and right margin fields, enter the amount of spacing in inches to come between the
outer edge of the paper and the printed text.
To print the maximum amount of text, specify “0” for all margins.

Print Schemes
Print schemes are a way to manage different printing configurations. For example, you might want to
define one scheme that prints two up, landscape, and uses a small font, and another scheme that prints
the same configuration with a different font. To define or select a print schemes, use the Schemes Tab of
the Print dialog, which is pictured below.

The default scheme is named “SlickEdit”. When you change the configuration options on the other tabs in
the Print dialog, the scheme name changes to append the text “(Modified)” to the end. Click Save to give a
name to the modified scheme. Click Delete and Rename to delete and rename schemes, respectively.
System schemes are stored in the print.ini file located in the product installation directory. User-defined
schemes or modified system schemes are stored in the uprint.ini file.
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Printing on UNIX, Linux, and Mac OS X
To print, from the main menu, click File > Print (or use the command gui_print). The Text Mode Print
dialog is displayed, which allows you to specify the device to use and set configuration options. After the
device is specified and options configured, click OK to print the active file or buffer.
Alternately, you can use the print command to immediately print the active buffer, or the print_selection
command to immediately print the selection, both based on the current configuration. Mac OS X users can
use the keyboard shortcut Cmd+P to immediately print the active buffer.
NOTE Graphical printing options (such as print preview) are not supported for UNIX.

UNIX, Linux, and Mac OS X Printer Configuration
To configure printing options, from the main menu, click File > Print (or use the command gui_print). The
Text Mode Print dialog, pictured below, is displayed.

This dialog contains some of the same options as the Windows Print dialog. See Print Dialog for Mac,
Linux, and UNIX for a complete list of the available options.

Inserting a Formfeed
The printing facility supports embedded formfeed characters. The formfeed character must be the only
character on the line. To insert a formfeed into the current buffer, press Ctrl+Q (quote_key command),
and Ctrl+L. Alternatively, you can use the Insert Literal dialog box (Edit > Insert Literal or insert_literal
command) to insert a formfeed or any other character (see Inserting Literal Characters).
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User Preferences
This chapter contains the following topics:
•
•
•
•
•
•
•

Introduction to User Preferences
Emulations
Key and Mouse Bindings
Cursor, Mouse, and Scroll Settings
Setting Fonts and Colors
Restoring Settings on Startup
Setting File Associations
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Introduction to User Preferences
SlickEdit® can be customized to accommodate your own individual preferences. Customization options
are located on the Options dialog, which can be displayed from the main menu by clicking Tools >
Options.
User preferences are broken into two categories: options that apply to all languages (global options), and
preferences that apply to specific languages (language-specific options).
TIP If you are using SlickEdit in a multiple user environment, each user must define a
SLICKEDITCONFIG environment variable that refers to a local directory. This allows each user to
have their own configuration. If making modifications to vslick.ini, make a local copy of this file
and place it in the SLICKEDITCONFIG directory file. See Environment Variables for more
information.

Global Options
Global options that can be set include:
•
•
•
•

Emulation modes (see Emulations)
Fonts and colors (see Setting Fonts and Colors)
Auto Restore settings (see Restoring Settings on Startup)
File associations (see Setting File Associations)

Other global preferences, such as default search options and selection styles are also available for setting
through the Options dialog (Tools > Options). These options are described in the documentation on a
contextual basis. For a listing of option categories, see Option Categories.

Language-Specific Options
The behavior of the editor can be customized for files based on specific languages. indent, word wrap,
comment, auto-complete, Context Tagging®, and other code-style settings are all language-specific.
These settings are located on the Options dialog (Tools > Options or config command) under
Languages > [LanguageCategory] > [Language]. The options are described in the documentation on a
contextual basis. For a flat listing of the language-specific options, see Language Options.
TIP A shortcut method to access language options for the current buffer is to use the Document >
[Language] Options menu item (or the setupext command). This will open the Options dialog to
the General language-specific option screen for that language.
For more information about working with languages and language extensions, see Language-Specific
Editing.
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Emulations
Emulation is the process of imitating another program. SlickEdit® provides emulations of key bindings for
13 editors so that you can use the style to which you are accustomed, making your coding experience as
efficient as possible.
The Key Bindings option screen allows you see what keys or key sequences are bound to what
commands. Emulation charts are also available in the Help system and as printable PDF documents in the
docs subdirectory of your SlickEdit installation directory. See Key and Mouse Bindings for more
information.

Supported Emulations
This section describes each emulation mode and any special notes. For a list of key bindings that open the
SlickEdit® command line in each emulation, see Activating the Command Line.
•

BBEdit

•

Brief - This emulation relies heavily on Alt key bindings. In addition to Brief emulation support,
SlickEdit also supports Brief regular expressions. See Brief Regular Expressions for more
information.

•

CodeWarrior

•

CodeWright

•

CUA - CUA is an acronym for Common User Interface, a standard set of user interface guidelines
similar to those used in Microsoft products. This is the default emulation mode used by
SlickEdit.

•

Epsilon - This emulation relies heavily on Ctrl+X and Escape (meta) key bindings.

•

GNU Emacs - This emulation relies heavily on Ctrl+X and Escape (meta) key bindings. It does
not include an Emacs Lisp emulator.

•

ISPF - Support is included for ISPF prefix line commands, the ISPF command line, rulers, line
numbering, and some XEDIT extensions. In addition to the ISPF emulation charts, additional
documentation about using this emulation is available—see Using the ISPF and XEDIT
Emulations.

•

SlickEdit® (Text Mode edition)

•

Vim - The Vim emulation contains special keys and key sequences that are case-sensitive. A plus
(+) sign separates the simultaneous key presses and a comma (,) indicates sequential key
presses. For example, the key binding Ctrl+w,W, which moves the cursor to the window above,
indicates to press at the same time, the Ctrl key and lowercase w, release, then immediately press
Shift plus w to enter the uppercase W. Another example is the key binding gP, which pastes the
text before the cursor. Press the G key (to enter a lowercase g), release, then press Shift plus p at
the same time (to enter the uppercase P).

TIP SlickEdit supports the vimtutor command. This opens a practice file in the editor that you can
actually edit as you learn Vim commands. See Vim Tutorial for more information.
•

Visual C++ 6

•

Visual Studio default - The key bindings provided for the Visual Studio default emulation are not
the same as the key bindings used in Visual C++, but there might be some overlap. If Microsoft
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Visual Studio does not provide a default key binding for a particular SlickEdit command, the
corresponding Visual C++ key binding is used.
•

Xcode

Changing Emulations
After SlickEdit® is installed, you are prompted to choose an emulation. CUA is the default emulation mode
for SlickEdit. Key bindings and shortcuts mentioned in our documentation are based on this emulation. You
can change emulation modes at any time by using the Emulation Options. To access these options, from
the main menu, click Tools > Options, expand Keyboard in the tree, and select Emulation.

You should save custom key/mouse bindings for the current emulation before switching emulations. You
can do this by exporting your custom bindings (see Exporting and Importing Bindings), or you can save
using the prompt that appears when you click Apply or OK on the Options dialog when switching
emulations.

By saving your custom key bindings when you switch emulations, when you return to the original emulation
those bindings are automatically available. For example, if you have created and saved custom bindings in
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the CUA emulation, and then switch to Vim, switching back to CUA will make your custom bindings for
CUA available again.
To remove custom key bindings for an emulation, resetting to the defaults, select the Restore to default
key bindings option on the Emulation options page.
See Managing Bindings for more information on working with custom bindings.

Determining Keys/Functions
When/if you switch emulations, the key bindings that are assigned to commands change according to the
emulation chosen. You can use the Key Bindings option screen to look up what command is bound to what
key or key sequence (or vice-versa), or you can use the SlickEdit® menu and command line to determine
these items. See Key and Mouse Bindings and Using the Command Line to View Key Binding
Associations for more information.
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Key and Mouse Bindings
Key and mouse bindings are quick ways to execute operations in SlickEdit®. Key bindings are the most
efficient. Time is wasted each time you lift your hand from the keyboard to grab the mouse, and more time
is wasted when you move your hand back to the keyboard in preparation for more typing. Therefore, if you
learn the key bindings associated with operations that you use most frequently, you will save time coding.
If an operation you use frequently isn’t already bound by default, create your own easy-to-remember
binding.

What is a Binding?
A key or mouse binding is a key sequence or mouse event associated with a command. Key terms are
defined as follows:
•

Mouse event - The clicking of any button or motion of the mouse wheel.

•

Key - Any single key on the keyboard.

•

Key combination - Two or more keys pressed simultaneously, for example, Ctrl+O (in CUA
emulation, associated with the gui_open command, File > Open, and the Open button on the
Standard toolbar). The plus (+) sign between the keys indicates that these keys must be pressed
simultaneously: press the Ctrl and O keys at the same time. Note that the last key is caseinsensitive. You do not need to press Shift.

•

Key sequence - A series of one or more keys or key combinations, for example, Ctrl+X,R (in Vim
emulation, this binding is associated with the redo command, Edit > Redo, and the Redo button
on the Standard toolbar). The comma (,) indicates that each key must be pressed consecutively:
press Ctrl and X at the same time, release, then press the R key.

•

Key binding range - A command bound to a range of keys. For example, the alt_bookmark
command is bound by default to the key combination range of Ctrl+0 through Ctrl+9. Press Ctrl+0
to create a bookmark named “0”, Ctrl+1 to create a bookmark named “1”, etc.

To view or change bindings, create new bindings, and export/import custom bindings, see Key and Mouse
Bindings.
The available key bindings change depending on the selected emulation. While SlickEdit® provides
emulations for 13 editors, CUA is the default emulation, so key bindings listed throughout the
documentation are for the CUA emulation. To change the emulation mode, click Tools > Options >
Emulation. For more information, see Emulations.
NOTE
•

For documentation purposes, both mouse events and keys that are bound to commands are
often referred to collectively as key bindings.

•

The SlickEdit main menu displays the key bindings for commands associated with each
menu entry. See Accessing Menus and Creating and Editing Menus for more information.

•

A menu hotkey is a key sequence that corresponds to an underlined letter on a menu name.
See Menu Hotkeys for more information about these items.

Managing Bindings
Create and manage key bindings using the Key Bindings option screen. This displays a list of all
SlickEdit® commands, including macros that you have recorded, their associated key sequences, and the
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language editing mode in which the key binding can be used. Documentation for the selected command, if
available, is also displayed. The Key Bindings screen provides capabilities to incrementally search by
command or by key sequence, export and import custom bindings, save an HTML chart of your bindings,
and run a selected command or user-recorded macro.
To access the Key Bindings option screen, from the main menu, click Tools > Options > Keyboard > Key
Bindings, or use the gui_keybindings command.
The first time the Key Bindings screen is invoked, the Building Tag File progress bar may be displayed
while Slick-C® macro code is tagged.

Bindings are based on the editor emulation mode (CUA is the default). To change the emulation mode,
click Tools > Options > Keyboard > Emulation. For more information, see Emulations.
The Search by command and Search by key sequence boxes are used to filter the data. See Viewing
and Filtering Bindings.
The Command column shows all of the SlickEdit commands including macros that you have recorded.
The Key Sequence column shows the key sequence or mouse event to which the command/macro is
bound. If there is no binding, this field is empty. The Mode column shows the language editing mode to
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which the binding is assigned. The Recorded column indicates if the item is a command (No) or userrecorded macro (Yes).
TIP What is a language editing mode? SlickEdit uses the extension of the current file to determine
what language you are using, thereby only making available the options and features that are
possible or useful in that language. You can also manually set the language editing mode. See
Language Editing Mode for more information.
The bottom of the screen contains documentation (if available) for the selected command.
Columns can be sorted by clicking on the column headers. An up or down arrow in the column header
indicates ascending or descending sort order. All of the columns as well as the documentation pane can be
resized by dragging the separator bars.
The following sections describe different ways to use the Key Bindings option screen:
•
•
•
•
•
•
•
•
•

Viewing and Filtering Bindings
Creating Bindings
Editing Bindings
Removing Bindings
Exporting and Importing Bindings
Saving a Bindings Chart
Running a Command/Macro using the Key Bindings Dialog
Resetting Default Bindings
Working with Key Binding Ranges

Viewing and Filtering Bindings
You can filter the data on the Key Bindings screen by using the Search by command and Search by key
sequence boxes at the top. This is useful for finding a command/macro for creating, editing, or removing a
binding, and for determining what key sequences are associated with a command/macro and vice-versa.
•

To find a command/macro, search for it by entering a string in the Search by command box. The
column of commands is filtered incrementally as you type, to show only commands that contain
the specified string. Commands that have more than one key sequence associated with them are
listed on separate rows. For example, in CUA emulation, the command gui_open is bound to F7,
Command+O (on the Mac), and Ctrl+O. Therefore, gui_open appears in the Command column
three times–one row per key sequence.

•

To find a key sequence, place the focus in the Search by key sequence box (by tabbing or using
the mouse) and then press the actual key or key sequence. The column of key sequences is
filtered to show only bound sequences that contain the specified key(s). For example, to see all
commands/macros that are bound to Ctrl+O, with the focus in the search box, simply press
Ctrl+O.

•

To find a mouse event, place the focus in the Search by key sequence box (by tabbing or using
the mouse) and click the mouse event you want to find. If the mouse event involves the scroll
wheel, click the Mouse Event button (
) to the right of the field. This displays the Select Mouse
Event dialog containing a list of all mouse events. If the event involves pressing a modifier key or
keys, such as Ctrl, Alt, Shift, Cmd, Ctrl+Alt, etc., in conjunction with a mouse click, for example,
Ctrl+RButtonDn, press the modifier key(s) when clicking the Mouse Event button. Then the
Select Mouse Event dialog shows a list of modifier-prefixed mouse events. After selecting the
mouse event you want to look up, click OK. The option screen updates to show only those
commands that are bound to that mouse event.
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To clear either field, click the red X button to the right of each box. This is especially handy for the key
sequence search, due to the fact that the field recognizes any keyboard/mouse input including
Backspace.
Alternatively, you can use the what_is and where_is commands (Help > What Is Key and Help > Where
Is Command) on the SlickEdit® command line to determine binding associations. See Using the
Command Line to View Key Binding Associations for more information.

Creating Bindings
You can work more efficiently if you create key/mouse bindings for commands or user-recorded macros
that you use frequently. To create a new key or mouse binding:
1. Using the Key Bindings options screen (Tools > Options > Keyboard > Key Bindings), find the
command or user macro you want to bind. You can search for a command/macro by entering a
string in the Search by command box (see Viewing and Filtering Bindings).
2. Initiate the binding by using one of the following methods:
o

Select the row, then click the Add button.

o

Select the row, then press Enter.

o

Double-click on the row.

3. When you initiate a binding, the Bind Key dialog is displayed with focus in the Key Sequence box.
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o

For a key binding, press the key sequence just as you would to use it. For example, to bind
surround_with to Ctrl+W, simply press Ctrl+W. The key sequence you pressed is displayed
in the box.

o

For a mouse binding, click the Mouse button next to the Key Sequence field, and select the
mouse event you want to use from the Select Mouse Event dialog. For example, to bind
surround_with to the right-click mouse event, select RButtonDn and click OK.
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Use the red X button to clear the input field if you make a mistake. If you enter a key sequence or
mouse event that is already assigned to another command/macro, a warning prompt is displayed.
If you continue, the previous binding is unbound and reassigned.
TIPS
•

SlickEdit® allows key sequences that are very long, but shorter sequences are easier to
remember and more practical to use.

•

Do not begin key sequences with keys that are normally used in typing. Otherwise, these
keys will launch the operation and not appear when you type. For example, binding a
command to the A key will prevent you from using that letter in your code. It is best to always
begin your key sequences with a Ctrl or Alt key combination.

4. The default language editing mode is the default language editing mode for new bindings, which
means the binding will work in all language editing modes. If you want the binding to work only in a
specific language editing mode, you can change it now by clicking the Advanced button on the
Bind Key dialog. Click Bind to mode, then from the drop-down list, select the mode for which the
binding should apply. Bindings assigned to a specific language editing mode override those
assigned to default.
TIP You can create multiple bindings for the same command/macro and have one binding set to
default and the others set to specific modes. In this case, when you are editing in a specified mode,
that binding is in effect, and when editing in any other language editing mode not specified, the
default binding will be in effect. For example, in CUA emulation, Ctrl+L is bound to select_line by
default, but when in HTML mode, you may want to use Ctrl+L to insert an HTML link instead
(insert_html_link command). Therefore, you can bind Ctrl+L to insert_html_link and specify the
HTML mode for use only when editing HTML files.
5. When finished, click Bind. The key sequence or mouse event now appears in the Key Sequence
column.

Editing Bindings
To change the binding or language editing mode for a command/macro that is already bound, you will need
to first unbind the command/macro, then recreate it. See Removing Bindings and Creating Bindings. If you
have advanced knowledge of SlickEdit®, you can edit the Slick-C® key binding source directly. See
Editing the Key Binding Source for more information.

Removing Bindings
To remove a binding:
1. Using the Key Bindings options screen, find the command/user macro or key sequence that you
want to unbind. You can search by using the search boxes at the top (see Viewing and Filtering
Bindings).
2. With the command/macro row selected, click Remove, or press Delete. You are prompted to
confirm the unbind operation.
If a command is bound to a range (see Working with Key Binding Ranges), for example, Ctrl+0 through
Ctrl+9, the entire range is unbound.
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Exporting and Importing Bindings
Key and mouse bindings can be exported out of SlickEdit® and imported in, useful for creating backups,
sharing with other team members, or taking with you should you switch computers.

Exporting Bindings
When exporting, custom bindings for all language editing modes in the current emulation are exported into
an XML file with a name and location that you can specify.
To export your bindings:
1. Click the Export button on the Key Bindings option screen. The Save As dialog is displayed.
2. If you want, change the directory location and change the file name to something more meaningful
to you, such as myname_cua.xml.
3. Click Save.

Importing Bindings
Imported bindings override any existing bindings for the selected emulation. For example, if you have the
surround_with command bound to Ctrl+W, and import surround_with bound to Ctrl+Q, then Ctrl+Q is
now the binding for that command in the selected emulation. When you import for the selected emulation,
SlickEdit® resets the key bindings to the default, then loads the user key bindings.
If you import a key bindings file from a different emulation than the one currently selected, SlickEdit
displays a warning and prompts whether or not you want to continue. If you continue, the emulation mode
is changed and the key bindings are loaded for that emulation.
To import bindings into SlickEdit:
1. Click the Import button on the Key Bindings option screen. The Open dialog is displayed.
2. Find and select a bindings file that was previously exported, then click Open.

Saving a Bindings Chart
Click the Save Chart button on the Key Bindings option screen to save an HTML reference chart of all
current bindings for all language editing modes in the selected emulation. Commands and user macros
that are not bound are not included.

Running a Command/Macro using the Key Bindings Dialog
If you have the Key Bindings option screen open, you can conveniently run a selected command or userrecorded macro by clicking the Run button.

Resetting Default Bindings
To reset bindings for the selected emulation to the SlickEdit® defaults, from the main menu, click Tools >
Options > Keyboard > Emulation, then select the Restore to default key bindings option on the
Emulation options screen. See Emulations for more information.

Working with Key Binding Ranges
A key binding range is a command that is bound to a range of keys. For example, the alt_bookmark
command is bound by default in CUA emulation to the key combination range of Ctrl+0 through Ctrl+9.
Press Ctrl+0 to create a bookmark named “0”, Ctrl+1 to create a bookmark named “1”, etc. Key binding
ranges are displayed in the Key Sequence column on the Key Bindings option screen. For example, the
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range for alt_bookmark is displayed as Ctrl+0 -> Ctrl+9 in CUA emulation. Key binding ranges are also
shown when using the Export and Save Chart features.
You cannot remove a single key combination from within a range, but you can rebind the key range to a
different command. If you unbind a command that is bound to a range, the entire range is unbound.

Key Binding Settings
The following are settings that you can make pertaining to key bindings.

Key Message Delay
For key bindings that contain multiple key combinations, like Ctrl+X,Ctrl+C, you can specify the maximum
delay between the two combinations. If that time limit is exceeded, this key sequence will be interpreted as
two separate bindings, executing the command bound to Ctrl+X followed by the command bound to
Ctrl+C, rather than the command bound to Ctrl+X,Ctrl+C.
To change this option, click Tools > Options > Keyboard > Advanced, then set the Key message delay
for the amount, in tenths of a second, to delay before a prefix key. The prefix key is not displayed if the next
key is pressed before the delay specified in this text box.

Using Shorter Key Names in Menus
The SlickEdit® main menu displays the key bindings for commands associated with each menu entry.
These bindings can be condensed for non-CUA emulations. See Short Key Names in Menus for more
information.
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Cursor, Mouse, and Scroll Settings
This section describes settings for the cursor, mouse, and scroll style. For cursor navigation information,
see Cursor Navigation.

Setting the Cursor Style
You can use a text mode style cursor instead of a vertical cursor. To set this option, from the main menu,
click Tools > Options > Appearance > General, then select Use block cursor from the Cursor style
drop-down list.

Hiding the Mouse Pointer
To hide the mouse pointer when typing, from the main menu, click Tools > Options > Appearance >
General, then set the option Hide mouse pointer to True. The mouse pointer is then only displayed when
moving the mouse or when a dialog box is displayed.

Displaying Tool Tips
By default, hovering the mouse pointer over a button displays a tool tip about the item. To turn tool tips off,
from the main menu, click Tools > Options > Appearance > Advanced, then set the option Show tool
tips to False. To change the amount of time before tool tips are displayed, change the value of the option
Tool tip delay. The delay value is in tenths of a second.

Scroll Bar and Scroll Style Settings
The scroll bars on the right and bottom edges of the editor windows are optional in SlickEdit. To turn these
on or off, from the main menu, click Tools > Options > Appearance > General, then set the options
Horizontal scroll bar and/or Vertical scroll bar. When these options are set to True, the scroll bars are
displayed. These options do not affect edit window controls on dialog boxes.
To set the scroll style, from the main menu, click Tools > Options > Appearance > General, then set the
Scroll style settings that you want to use. Commands that move the cursor more than one page of text,
such as searching, always center scroll text into view. The following scroll settings are available:
•

Smooth horizontal scroll - When set to True, editor windows scroll column-by-column when the
cursor moves out of view. When set to False, the cursor is centered and the text is scrolled onefourth the width of the window when the cursor moves out of view.

•

Smooth vertical scroll - When set to True, editor windows scroll line-by-line when the cursor
moves out of view. When set to False, the cursor is centered and the text is scrolled half the height
of the window when the cursor moves out of view.

•

Scroll when - Specifies how close (in number of lines) the cursor may get to the top or bottom of
the window before scrolling occurs.
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Setting Fonts and Colors
This section describes how to set fonts and colors for screen elements and editor windows. For information
about changing the colors of code, such as colors used for keywords, see Color Coding.

Fonts
SlickEdit® provides the capability to change the fonts used by edit windows, the command line, status text,
and other screen elements. Recommended fonts are listed. You can also set fonts for editor windows.
TIP Xft fonts are supported on Linux.

Setting Fonts for Screen Elements
To configure font settings for screen elements, use the Fonts options screen (Tools > Options >
Appearance > Fonts). For a description of each option, see Font Options.

Recommended Fonts for Elements
Font recommendations are given for the best screen display. The information below contains
recommended fonts for some of the screen elements.
NOTE Some font names are portable font names which are translated into other fonts. This allows
Slick-C® macros and dialog boxes to be portable across Windows and UNIX.
Command Line Fonts
The following table contains recommendations, based on the operating system, for the Command Line font
element:
Platform

Font Recommendation

Windows

Choose Courier, Courier New, OEM Fixed Font, or Terminal
fonts for the most visually appealing character displays.

Linux

Choose Courier, Lucida Sans Typewriter or a console font for
the most visually appealing character displays. If these fonts
are not visible, look for the UNIX fonts below.

UNIX

Choose Adobe Courier, B&H Lucida Typewriter, or Width x
Height family fonts for the most visually appealing fixed fonts.

Selection List Fonts
Choose Courier for best display of selection lists that need a fixed font.
Dialog Box Fonts
Choose MS Sans Serif as an attractive font for dialogs.
Text Box Fonts
Choose System or MS Sans Serif for fonts used in text boxes.
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SBCS/DBCS Source Window Fonts
This is the element used for all non-Unicode source windows. Choose Terminal for the most attractive
visual display.
Unicode Source Window Fonts
Default Unicode Font is the default font for the Unicode Source Windows element. When this font is
selected, the Arial Unicode MS font is used if it is installed. Otherwise, the ANSI Fixed Font is used,
which only supports the English character set. Arial Unicode MS is a fairly complete font which is included
with Microsoft Office. Currently, no version of Windows ships with a complete Unicode font. For more
information on Unicode support, see Using Unicode.

Setting Editor Window Fonts
In addition to setting the fonts for screen elements, you can specify the fonts and font styles for editor
windows. To change editor window fonts, from the main menu, click Window > Font, or use the wfont
command. The Window Font dialog will be displayed. Font, size, and style options are the same as those
on the Font Options screen.
From the Window Font dialog, choose the Scope that you wish to affect. Select the Current window
option if you only want to change the current window’s font. Select the All windows and Default option to
set the font for all editor windows that are open as well as newly-created windows.
For a complete list of the options on the Window Font dialog, see Window Font Dialog.

Colors
Use the Colors option screen (Tools > Options > Appearance > Colors or color command) to set the
color for different screen elements in SlickEdit®. This includes syntactic elements in the editor window, like
keywords, comments, strings, etc. as well as other user interface elements like the message area or the
status line. Window colors and backgrounds are set using the facilities provided by the operating system.
Color and Color Coding are different. Color Coding is a feature that combines current line coloring,
modified line coloring, and language-specific coloring. SlickEdit recognizes and automatically displays
color support for many languages. See Color Coding for more information.

Setting Colors for Screen Elements
Colors can be customized in the user interface. Colors can be set either individually or by editing a
scheme. To change the default colors, complete the following steps:
1. From the main menu, click Tools > Options > Appearance > Colors (or use the color
command). The Colors option screen is displayed.
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2. Select the element you want to change from the Screen element list box (for descriptions of some
of these elements, see Color Options).
3. Set the Foreground and Background colors by clicking on the color squares. The Color Picker
dialog is displayed, allowing you to pick a color from the palette, or set your own custom color
using RGB values.
NOTE If you have chosen the Selection screen element, note that SlickEdit will attempt to render
selections using your normal color settings for the Foreground color. The selected foreground color
will only be used if there is not enough contrast between the font colors to be readable. It is best to
specify a Background color for selections that is as close as possible to your normal background
color, ensuring that the color-coded fonts are still easy to read.
4. If you change the background color for an element in the editor window, you can use the Sync
Backgrounds button to propagate the background color for the currently selected element to
other related elements. For example, if you change the background color for Keywords you will
probably want that same color used for Strings, Comments, Numbers, etc. The Sync
Backgrounds button prevents you from having to manually make all these changes.
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5. If you want, choose a Font Style for the text.
For a complete list of all of the options available, see Color Options.

Using Color Schemes
Color schemes store the settings for all screen elements, allowing you to quickly change the look of your
editing environment. Several predefined color schemes are provided, and you can create your own.
To use a color scheme, from the Color scheme drop-down, select a color scheme and click Apply. To use
this color scheme, click OK.
To define a new color scheme, set your colors for the various screen elements and click Save Scheme.
User-defined color schemes are stored in the uscheme.ini file located in your configuration directory. You
can change the name of a scheme by clicking Rename Scheme.

Setting an Embedded Language Color
The option Set embedded language color allows you to specify the colors used for embedded
languages. These occur when a file of one type embeds a language of another type within it, like HTML
files containing JavaScript. For HTML, the syntax color coding recognizes the <script language="???">
tag and uses embedded language colors for the new language. In addition, for Perl and UNIX shell scripts,
you can prefix your HERE document terminator with one of the color coding lexer names to get embedded
language color coding. The following is an example for Perl:
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Restoring Settings on Startup
By default, the files, current directory, and more from the previous edit session are automatically restored
when you switch workspaces or close and re-open SlickEdit®.
To control which elements of your SlickEdit environment that are automatically restored, from the main
menu, click Tools > Options > Application Options > Auto Restore. See Auto Restore Options for more
information.
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Setting File Associations
Files of certain types can be associated with SlickEdit®, so that when those files are opened from
Windows Explorer, they run in the SlickEdit application. To set up these associations, use the Associate
File Types Options. To access these, from the main menu, click Tools > Options, expand File Options,
then select Associate File Types (or use the assocft command).

Select the file types you wish to associate in the Unassociated File Types list box. Click the Associate
button to move them to the Associated File Types list box. Use the Disassociate button to remove
associations from the list.
NOTE If you are associating workspace files (.vpw extension) to SlickEdit, SlickEdit restores the edit
session and the project when opening the .vpw file. See Workspaces and Projects for more
information about working with projects and workspaces.
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Workspaces, Projects, and Files
This chapter contains the following topics:
•
•

Workspaces and Projects
Working with Files
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Workspaces and Projects
Overview of Workspaces and Projects
Workspaces and projects provide a way to organize your work. Much of the power provided by SlickEdit®
derives from the information in your projects. So, it’s important to set them up correctly.
A workspace defines a set of projects and retains the settings for an editing session. Opening a
workspace returns a session to the same state as when you last worked on it, including which files are
open, the working directory, and more. To see the auto restore options, click Tools > Options >
Application Options > Auto Restore. The data for each workspace is stored in a text file with the
extension .vpw.
A project defines a set of related files that build and execute as a unit. For each project you can specify
the set of files it contains, a working directory, a set of commands to build and execute the project, compiler
options, and dependencies between other projects. Files can only be added to projects, not directly to a
workspace. A file may belong to multiple projects, and a project may belong to multiple workspaces. The
data for each project is stored in a text file with the extension .vpj.
When you create a project, you select the project type based on the language and tool chain you are
using. A tool chain is the combination of compiler and debugger used. Selecting the right project type is
essential to configure SlickEdit to build, run, and debug your program. Once a project type is selected, it is
not possible to change it. For more information on this topic, see the section on Project Types.
The number of projects you create in a given workspace depends on the type of program you are creating.
Typically, you create a separate project for each build target in your program. In C/C++ you would create a
separate project for each DLL or SO and one for each executable. In Java, you might only create a single
project.
If you have a workspace with multiple projects, you can use project dependencies to ensure that projects
are built in the correct order (see Defining Project Dependencies). You may find it useful to define an
umbrella project that depends on all other projects. This provides an easy way to rebuild all of your
projects. Even if you have no project that meets this criterion, you can create an empty project for that
purpose.
Files in a workspace are processed by the Context Tagging® feature, building a database of the symbols
they contain. This information is used for completions, providing parameter information, navigating from a
symbol to its definition or references, and more. The Context Tagging database provides nearinstantaneous access to information for which you would otherwise have to search, saving you a great
deal of time.
You can define as many workspaces as you like. For large systems that decompose into multiple
subsystems and programs, you can create a separate workspace for each program or subsystem. This
helps you manage the complexity by limiting the number of files in your workspace. It also prevents
irrelevant information from being presented by Context Tagging when doing symbol lookups.
SlickEdit has a default workspace that is active before you define a workspace or after you close a
workspace. However you can not add projects or files to this workspace. You can open files and edit them,
and state will be saved, but using SlickEdit in this way is like using a basic editor and will not provide the
full benefit of SlickEdit’s symbol analysis. For more information on these features, see Context Tagging®.

Organizing Files
SlickEdit® places no restrictions on the location of your files. Your source files do not have to be located in
the same directory as your project (.vpj) or workspace (.vpw) files. Adding files to a project does not copy
the files to a new location. It simply associates those files with the project. Likewise, adding an existing
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project to a workspace does not copy the project. This gives you a great deal of flexibility to organize your
files.
In general, there are two approaches to organizing your files:
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•

Single Root Approach - All files are stored under a single root directory. In this approach, the
workspace .vpw file is typically located in the root folder and there is a subfolder for each project.
Each project folder contains the project .vpj file and the source files.

•

Multiple Root Approach - No single folder contains all of the workspace files exclusively. Each
project may be created in a different directory unrelated to each other, and the workspace .vpw file
may be placed in yet another directory.
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The single root approach is common when all team members are working with SlickEdit. This organization
provides a simple approach to storing your files and facilitates interaction with source control systems. The
multiple root approach may be used on complex programs that share framework code with other
programs. In this case, you may not want to duplicate the shared code to place it under the root directory
for this program.
A hybrid approach may be used if you have a single root source hierarchy but the whole team is not using
SlickEdit. In that situation, they may not want to have the SlickEdit project (.vpj) and workspace (.vpw)
files checked into the same location as the source files. You can still check out the source tree into a single
directory. Then define a separate subdirectory for your workspace and project files. If other team members
are using SlickEdit, you can check these files into a different area in source control, allowing you to share
them with other SlickEdit users but not interfere with non-SlickEdit users.
Storing files remotely will have a definite impact on performance since network latency is added to disk
latency. If your standards require you to work with remote files, you should still try to set up your workspace
locally. SlickEdit reads and writes workspace files frequently, so storing them remotely will reduce
performance. Workspaces are just a list of projects, so setting up a local workspace is quick and easy.

Version Control
If the whole team is using SlickEdit®, then project (.vpj) and workspace (.vpw) files should be checked in
any time they are updated by SlickEdit. That way, all team members will see any new files or projects you
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add to the workspace. Even if you are the only person using SlickEdit, it’s a good idea to check in your
project and workspace files. This protects you from loss and allows you to fall back to earlier versions of
the program.
Do not check in the .vpwhist file. It contains breakpoints, bookmarks, file positions, list of open files—
information that is unique to an editing session.
For more information about using version control with SlickEdit, see Version Control.

Add Wildcard
If all team members are using SlickEdit® for their development, you will pick up newly added files by
getting the latest version of the .vpj files. If some of your teammates are not using SlickEdit, then you
need to use Add Wildcard when adding files to your projects in order to pick up added files. Each time you
start SlickEdit, the wildcards are evaluated and the file list is updated (see Managing Source Files for more
information).

Working with Libraries
A typical program also makes calls to library routines. A library is a pre-built unit of code providing
application-independent functionality. Standard libraries are provided by the compiler, and many programs
use third-party libraries. Some development projects have their own libraries.
Libraries should not be added to your workspace as a project. The key distinction is that libraries are prebuilt and will not be edited as part of the development effort. If you have library routines that you plan to
edit and build as part of your development, these should be added to your workspace as a project.
SlickEdit® automatically tags the standard libraries for C/C++, Java, .NET, and COBOL as part of normal
installation. This adds the same type of symbolic information for these libraries to the symbol database that
is created for your source code. If you skipped auto-tagging or you switch compilers and need to tag those
libraries, you can re-run auto-tagging by clicking Tools > Tag Files and then clicking the Auto Tag button.
If you use third-party libraries or your own internal libraries, you will want to tag them as well. See Creating
Language-Specific Tag Files for instructions on how to tag libraries.

Managing Workspaces
Workspaces are just a means to aggregate projects and store values from an editing session. They are
easy to create, and you can quickly switch from one workspace to another. The Projects tool window
allows you to browse the projects within a workspace and the files contained in those projects. It is docked
as a tab on the left side of the editor by default and display can be toggled by clicking View > Toolbars >
Projects.

Opening and Closing Workspaces
To open an existing workspace, click Project > Open Workspace (Ctrl+Shift+O or workspace_open
command). Locate the workspace file (.vpw) and click Open.
To close a workspace, click Project > Close Workspace (workspace_close command). Only one
workspace can be open at any given time. If you open another workspace when one is already open, the
existing workspace will be automatically closed first.

Creating Workspaces
Workspaces are typically created by creating a new project. At that time you have the option to create a
new workspace for this project or add it to the current workspace. If no workspace is open, you can only
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elect to create a new workspace. If you choose to create a new workspace, your current workspace will be
closed and the new one opened. For more information on creating projects, see Creating Projects.
Creating a workspace without creating a project is useful when you plan to import existing projects or if you
want a workspace for editing files that aren’t part of a project, like shell script files.
To create a workspace without creating a project, complete the following steps:
1. From the main menu, click Project > New and select the Workspaces Tab.
2. Type a value in the Workspace name field.
3. Type the location (or use the Browse button to the right of this field to pick a location) for the new
workspace.

Managing Projects within a Workspace
To list projects in the current workspace, add or remove projects from the current workspace, or to set the
active project, use the Workspace Properties dialog box. The dialog, pictured below, can be accessed from
the main menu by clicking Project > Workspace Properties.

For more information on using this dialog, see Workspace Properties Dialog.

Sharing Projects between Workspaces
A project can be used in more than one workspace. Adding an existing project to a workspace does not
copy the project or its source files—it simply creates an association between the two. If you want a local
copy of the project, you will need to copy it before you add it to the workspace.
To share an existing workspace, complete the following steps:
1. From the main menu, click Project > Workspace Properties.
2. Click Add.

SlickEdit® User Guide

131

WORKSPACES AND PROJECTS

3. Locate the file and click Open.

Working with Third-Party Workspaces
SlickEdit® provides compatibility with the following third-party workspaces. Use Project > Open
Workspace to open these project types.
•

Visual Studio .NET - SlickEdit can directly open .sln and .vpw files. Visual Studio 2005 has
added many new project types, and not all of these are supported. If you have difficulty opening a
Visual Studio 2005 solution or workspace, please contact Product Support. SlickEdit cannot create
Visual Studio workspaces. You need to create the workspace in Visual Studio and define the
project structure there. Once created, SlickEdit can add files to existing projects.

•

Tornado

•

Xcode

Managing Projects
The most important thing to remember when working with SlickEdit® projects is to use the correct project
type. When you create a project, you are presented with a list of project types. These determine the build
options and other behaviors for the project. Once created, the project type cannot be changed.
Once a project has been created, you need to add the source files to it. See Managing Source Files for
more information.

Project Types
SlickEdit® provides a variety of project types that match commonly available languages, tool chains
(defined by the compiler and debugger you are using), and types of programs. Some project types create
main programs, starting you off with a fully compilable program.
The (Generic) project type is provided for use when a specific project type does not match the language or
tool chain you are using. When you use this project type, you are responsible for configuring all build, run,
and debug commands.
NOTE it is not possible to configure the Generic project type to work with supported tool chains. For
example, if you are using the GNU compiler or debugger, you need to use the GNU C/C++ Wizard.
The Generic C/C++ project type supports the GNU debugger but does not contain the configuration
options for the GNU compiler.
You can create a custom project type if none of the existing project types match your development. By
doing this you avoid having to redefine the build, run, and debug commands or other project properties
each time you set up a new project. You can customize the (Generic) project type to create a completely
new project type or customize one of the language-specific project types, like Java, to tailor it to your
needs. See Creating Custom Project Types for more information.
The sections below describe the most commonly used project types.

GNU C/C++
SlickEdit® provides a GNU C/C++ Wizard that leads you through the configuration options for setting up a
new GNU C/C++ project. Using this wizard, you can quickly configure a new project that will build, run, and
debug.
SlickEdit prompts you whether this project will build an executable, a shared library, or a static library. You
can specify whether this project will use C++, C, or ANSI C. Further, you can select whether to create an
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empty project, an application with a main() function, or a “Hello World” application. Finally, you are
prompted whether to use SlickEdit’s build system or to use a makefile.
SlickEdit detects the presence of GNU tools on your system and configures the new project
correspondingly. You can make changes to these settings by clicking Project > Project Properties.
See C and C++ for more information about SlickEdit’s C/C++ features.

Microsoft Visual Studio
SlickEdit® cannot create Visual Studio solutions or projects. Visual Studio users should create a
workspace, which is the equivalent to a solution in Visual Studio, and define the projects it contains using
Visual Studio.
Solutions can be opened in SlickEdit by clicking Project > Open Workspace. Navigate to the directory
containing the solution and select the .sln file to be opened. SlickEdit reads the .sln file and configures
the build, run, and debug operations to be performed just as they would in Visual Studio.
NOTE You can add files to projects using SlickEdit, but any modifications to the workspace or project
settings must be performed using Visual Studio. This includes adding any new projects to the
workspace.
SlickEdit lists a number of Visual Studio project types on the New Project dialog, but most of them will
simply warn you that SlickEdit cannot create a project of that type and that you need to do that in Visual
Studio. The project types for the Microsoft SDKs, however, can be used. These create SlickEdit projects
that are not compatible with Visual Studio. This provides a low-cost way to use the Microsoft SDK
compilers and still have a rich editing environment.
For C#, a tutorial is available that describes how to build a simple C# console application with SlickEdit—
no Visual Studio required. See Hello World Tutorial (C#).

Other C/C++ Compiler Compatible with GDB (UNIX only)
Some compilers, like the Sun™ compiler, are compatible with the GNU tool chain. For these, you should
start with the GNU C/C++ project and customize it to use the compiler, debugger, and do builds the way
you want. Doing this allows you to launch the integrated debugger using Debug > Step Into rather than
Debug > Attach > Debug Other Executable. (See C and C++ for more information about C/C++ features
in SlickEdit®.)

Other C/C++ Compiler
SlickEdit® provides a project type for Borland® C++, both 16- and 32-bit for Windows and for Symantec™
C++. These were created for older versions of these products and may not work with the most recent
versions. In that case, or when using any other C/C++ compiler, you should select the Generic C/C++
project type. You will then have to configure the build, compile, link, run, and debug commands for both the
Release and the Debug configurations. (See C and C++ for more information about C/C++ features in
SlickEdit.)

Java
SlickEdit® provides a broad selection of Java project types. Select the appropriate choice based on
whether you are creating an applet or application and the type of program. SlickEdit detects the installed
JDK on your system and configures the build, run, and debug commands. (See Java for more information
about SlickEdit’s Java features.)
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Dynamic Languages: Perl, Python, PHP, Ruby
Dynamic languages do not get compiled. Most of the settings in the project types provided in SlickEdit®
are related to compiling and debugging your program. Therefore, SlickEdit has no project types that are
specific to these languages. Use the (Generic) project type and add your files there. You can configure run
and debug commands by clicking Project > Project Properties and selecting the Tools Tab. Create a
custom project type for this language to avoid having to redundantly configure projects each time you
create them (see Creating Custom Project Types).

Creating Projects
To create a project, complete the steps below.
1. From the main menu, click Project > New.
2. Select the type of project that you want. It is critical that you select the correct project type. Please
see Project Types above for a full discussion of project types.
3. Type the project name.
4. Select a directory location. If the directory does not exist, a prompt appears to create it when you
click OK.
5. Type the name of the executable file or output file.
6. Select either Create new workspace or Add to current workspace. If adding this project to the
existing workspace, specify whether this project depends on another project in this workspace by
checking the Dependency of check box and selecting the depended-on project from the dropdown list.
7. Click OK.
TIP You can also create a project by importing a makefile. To do this, from the main menu, click
Project > Open Other Workspace > Makefile (or use the workspace_open_makefile command).
See Importing Makefiles for more information.

Creating Custom Project Types
If an existing project type does not meet your needs, you can define a new project type or customize an
existing one.
To create a custom project type, complete the following steps:
1. Click Project > New, then click the Customize button.
2. On the Customize Project Types dialog, click the New button.
3. Enter a name for the new custom project type.
4. Select the project type to use as the starting point for your custom project. Use the (Generic)
project if you are defining a project type for a completely new language/compiler or select one of
the existing project types to make modifications.
5. Click OK to bring up the Project Properties dialog.
6. Configure the project settings for this project type. This is similar to the process of configuring a
single project, except that you cannot add files to a project type.
7. Click OK when done to save your changes and return to the Customize Project Types dialog. Click
OK to return to the New Project dialog. Click Cancel in these dialogs to discard your changes.
To customize an existing project type, complete the following steps:
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1. Click Project > New, then click the Customize button.
2. On the Customize Project Types dialog, select the project type to customize and click the Edit
button.
3. Make the changes needed for this project type.
4. Click OK when done to save your changes and return to the Customize Project Types dialog. Click
OK to return to the New Project dialog. Click Cancel in these dialogs to discard your changes.
Creating or customizing a project type creates a new project template stored in the
userprjtemplates.vpt file located in your configuration directory. Other team members can use this
template by copying the template file into their own configuration directories. If they have also created
custom project types, they can use DIFFzilla® to compare and merge the two versions of the file.

Setting the Active Project
Each workspace contains one project that is the active project. The active project is the one that is built
when you click Build > Build. If the active project depends on other projects, those projects will be built
first.
To make a project active, click Project > Set Active Project, and pick the project to make active.
Alternately, you can use the Workspace Properties dialog box to set the active project (see Managing
Projects within a Workspace).

Defining Project Dependencies
Dependencies define a relationship between two projects, causing the dependent project to be built after
the projects it depends on. This ensures that elements in a depended-on project are up-to-date prior to
building the dependent project. Project dependencies can be defined when a project is created.
To specify dependencies, complete the following steps:
1. Click Project > Workspace Properties.
2. Select the project you want to have depend on other projects.
3. Click the Dependencies button. The Project Properties dialog box opens with the Dependencies
Tab displayed.
4. Mark the check box next to the projects upon which the selected project should depend. These
dependencies will be built before the project is built when a build or rebuild is performed.
5. Click OK.

Project Configurations
Projects can have multiple configurations, each with different values for project settings. The most
common use of project configurations is for creating a debug or release version of a project without having
to define a new project. The Project Configuration Settings dialog box (Build > Configurations) is
available for viewing, adding, and deleting project configurations. You can change the active configuration
by selecting Build > Set Active Configuration from the main menu.
SlickEdit creates a “Debug” and “Release” configuration for each new project. These configurations are
identical, until you change the project settings associated with them. When you select Project > Project
Properties, the drop-down list at the top lets you select the project configuration you are modifying. The
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“All configurations” value is selected by default. By selecting a configuration you can change things that
are specific to that configuration, like setting compiler flags or changing the list of source files.
NOTES
•

Visual C++ - If you open a Visual C++ v5.0 or later workspace, the configurations are
automatically retrieved from the Visual C++ project. Some typical configurations for Visual
C++ v5.0 or later are “CFG=MyApp - Win32 Debug” and “CFG=MyApp - Win32 Release.”
Use Visual C++ to change the configurations.

•

Mac OS X - Opening an Xcode project imports styles that you cannot change using
SlickEdit®. You will need to change the styles using Xcode. You can work with the project in
SlickEdit, but you cannot change the project settings.

For information on using Project Configurations in builds, see Project Configurations in Builds.

Configuring Project Directories
The Directories tab of the Project Properties dialog box (Project > Project Properties) allows you to set
the working directory, references file, and include file search directories for the current project. See
Directories Tab for a list of the options.
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Configuring Project Tools
The Tools tab of the Project Properties dialog box (Project > Project Properties) is used to change
project commands and their properties.

The options on the Tools tab vary, depending on the tool name that is selected in the Tool name text box.
This text box contains a list of the tools/commands that can be used for projects. You can have different
tools for different projects, and you can choose whether or not each tool should appear on the Build menu.
Use the up and down arrows to move the tools up and down in the list. This order corresponds to the order
in which the tool appears on the Build menu. Click the red X button to remove a user-defined tool (default
tools cannot be deleted). Click the New button to add a tool. Click the Advanced button to change
environment variables (see Environment Variables).

Setting Language-Specific Options
The Options button on the Project Properties Tools tab is only available for selected tools that support
language-specific options. Click the Options button to display options specific to the language with which
you are currently working. From there you can make settings for the command that gets executed for the
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tool specified in the Tool name combo box. For more information on changing language options, see the
topic for your language in the Language-Specific Editing chapter.
TIP (Java only) You can easily change Java tool options including the class path. Click the Options
button here to display the Java Options dialog box, which allows you to customize options supported
by Javac, Javadoc, and JAR. To change the compiler from Javac to another compiler (such as SJ or
Jikes™), from the Java Options dialog, select the Compiler tab, then select the Other tab, and type
the compiler name.

Command Line Execution
The Command line text box on the Project Properties Tools tab is only available (and visible) for selected
tools that support a command line execution. It defines the command line that is set to be executed for the
selected tool in the Tool name combo box. This field is initially blank when you modify settings for “All
Configurations”, and the settings differ for different configurations. Click the buttons to the right of this text
box to insert files and escape sequences (such as %f which inserts the current buffer name) that you can
use to build your command line.

Specifying a Command Directory
For each tool listed on the Project Properties Tools tab, you can specify the directory from which to run the
command in the Run from dir text box. By default, all of the tools are run from the working directory that is
specified using the %rw or %rp escape sequences, which indicate the working directory or project
directory, respectively. When running programs like ant or make, this is typically set to the directory
containing the makefile.

Other Options
The remaining options on the Project Properties Tools tab allow you to specify output, save, display, and
other settings.
NOTE (UNIX only) Output of text mode programs that are executed using xterm cannot be
captured. To see the output, uncheck the Output options Capture output and Output to build
window, then prefix the program name in the Command line field with xterm -e or dos -w (this
waits for a key press).
All of the options and settings on the Project Properties Tools tab are outlined in the section Tools Tab.

Configuring Build Settings
The commands project_compile (Shift+F10 or Build > Compile) and project_build (Ctrl+M or Build >
Build) start the compile and build commands respectively for the current project.
The commands next_error (Ctrl+Shift+Down or Build > Next Error) and prev_error (Ctrl+Shift+Up or
Build > Previous Error) allow for quick navigation of compiler errors. For information about building and
compiling projects, see Building and Compiling.
To change the build and compile commands for projects as well as other project options, use the Build tab
of the Project Properties dialog (Project > Project Properties). The Build tab allows you to run programs
and/or execute commands before or after a build. You can run different programs and commands for
different projects as the information is stored per-configuration. The contents of this tab are unavailable for
extension-based projects.
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Each line in the Pre and Post Build Commands text boxes can contain a program to execute a
command. For example, the set command could be used to set environment variables. Double-click on the
text as indicated in the text boxes to add commands. Use the Up and Down arrows to the right of the text
boxes to move the commands up and down in the list. The order corresponds to the order in which the
command will be run.
When the Stop on error option is checked and the current project depends on other projects, the vsbuild
utility (see Using VSBUILD to Compile) will be used to build the projects and check for error codes. When
the vsbuild program detects an error, it does not continue building other dependencies.
NOTE (Windows only) Under Windows 95 or later, vsbuild cannot detect error codes returned from
a batch program.

Build System Options
The build method options on the Build tab apply to GNU C/C++ projects only and affect all configurations.
With these options, you will not need to convert the current build methods to use the GNU debugger; you
can select one of these methods when you create a new GNU C/C++ Wizard project.
•

Build without a makefile (dependencies automatically checked) - Automatically checks
dependencies and does not generate a makefile. Instead, the vsbuild utility (see Using VSBUILD
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to Compile) determines what should be compiled dynamically. This option is useful when you are
not concerned with how the build gets done. Make sure the project include directories are set up
correctly (Project > Project Properties, Directories Tab) so include files may be found (see
Configuring Project Directories).
•

Build with a user-maintained makefile or custom build command - Sets the build command to
make and does not generate a makefile. The build command can be changed from the Tools tab
of the Project Properties dialog box (see Configuring Project Tools). Select this option when you
already have your own method for building the source.

•

Build with an auto-generated, auto-maintained makefile - Automatically generates a makefile
and updates when files are added to the project. This option is useful when you need a makefile
and do not want to use the built-in vsbuild utility (see Using VSBUILD to Compile). Specify the
path to the makefile in the Makefile field. Make sure the project include directories are set up
correctly (Project > Project Properties, Directories Tab) so include files may be found (see
Configuring Project Directories).

To start a build from outside the application, execute the following command where make is the name of
the make program, Makefile is the name of the makefile, and ConfigName is the name of the
configuration:
make -f Makefile CFG=ConfigName

Defining Language-Specific Projects
If you are building something that only contains one source file and no project, you can define a languagespecific project. Language-specific projects are based on the language of the current file. However, the
working directory is ignored for these projects. All language-specific projects are stored in the file
project.vpe (UNIX: uproject.vpe).
To define a language-specific project, complete the following steps:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select General.
2. Click Language-Specific Project.

Managing Source Files
Adding and Removing Files
Files can be added to new and existing projects.
The Files tab of the Project Properties dialog (Project > Project Properties), shown below, displays a list
of the files in the current project and also allows you to remove files from projects. See Files Tab for a list of
the options.
SlickEdit® provides a number of ways to add files to a project. How you add files to the project depends on
whether all team members are using SlickEdit and updating the project files. If so, you can use Add Files,
Add Tree, or Import to perform the initial setup of existing files. All subsequent files will be added as they
are created through SlickEdit. If some members of the team are not using SlickEdit, then you should use
Add Wildcard to add files. The wildcard is evaluated each time SlickEdit is run and any new files are
automatically added to your project.
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To add files to a project, complete the following steps:
1. From the main menu, click Project > Project Properties. The Project Properties dialog is
displayed.
2. Click to display the Files tab.
3. Perform the file operation:
o

Add Files - Use for adding individual files.

o

Add Tree - Use for adding files in a directory or directory tree. Click Add Tree, then select the
directory and the file filter to use.

o

Add Wildcard - Use for adding files from a directory or directory tree matching the specified
wildcard. This expression is evaluated each time SlickEdit is loaded, adding new files from the
specified directory.

o

Remove - To remove the selected files.

o

Remove All - To remove all files from this project.

o

Refresh - To update the list of files, re-evaluating any wildcards that have been specified.
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o

Import - Loads files and directories specified in an import file. See Importing Files for more
details.

Creating New Files
There are two different approaches to adding a new file to a project:
•

Create a buffer with the correct name and then do a File > Save As to store the file in the correct
location and, optionally, add it to the project.

•

Use File > New or Project > Add New Item from Template to create the file and put it in the
correct place in the project.

Many developers prefer the first approach because it is faster and allows you to keep your hands on the
keyboard. A new buffer named foo.cpp can be created from the command line by typing e foo.cpp.
To create a new source file using the second approach, complete the following steps:
1. From the main menu, click Project > New and select the File tab.
2. Select the document mode from the list on the left.
3. To add the new file to an existing project, mark the Add to project check box and select the
project from the drop-down list.
4. Type a file name, including the extension, in the Filename field.
5. Verify that the Location is correct.
6. Change the Encoding as needed.
7. Click OK.
This same approach can be used with the SlickEdit® Code Templates by clicking Project > New Item
From Template. See Code Templates for more information.

Importing Files
The Import File dialog (Project > Project Properties, select the Files tab, then click the Import button)
allows you to load files and directories specified in an import file into your project.

Importing Makefiles
You can create a project by importing a makefile. SlickEdit® parses the targets, finds all referenced source
files, and adds them to the project. When you import a makefile, SlickEdit creates a new workspace and
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adds the project to it. If the same makefile is ever imported again, the corresponding workspace can be
opened without creating a new redundant workspace.
The new project automatically imports all files that are referenced by the makefile. All of the make targets
are also added and made available for execution from the main menu under Build > Execute Makefile
Target. For makefiles that contain invocations of other makefiles, the other makefiles can be optionally
added to the workspace as separate projects, or all their files added into one project.
The Build option for the makefile project is set to Build with a user-maintained makefile or custom build
command (Project > Project Properties, Build tab) and the build command is set to make. See Build
System Options for more information.
To create a new project by importing a makefile, from the main menu, click Project > Open Other
Workspace > Makefile (or use the workspace_open_makefile command). The Open Makefile as
Workspace dialog is displayed.

In the Makefile field, specify the makefile to import. Use the Browse button to browse for the makefile.
Check Scan for recursive makefile calls if you want to also scan for invocations of make on other
makefiles and to include them in the project. In this case, you can also check Make recursive makefile
calls separate projects if you want a new, separate project created for each of the referenced makefiles.
Then, specify any file types to include or exclude by using the drop-down lists or by typing the file
extensions separated with semicolons. The “*” wildcard is permitted. For example,
*.ch;*.chf;*.chs;*.cpp;*.h can be used to include or exclude all referenced files with those extensions.

Loading Project Files for Editing
The Files tool window can be used to open one or more files from the current project or the current
workspace. To display the tool window, from the main menu, click Project, then select Open Files from
Project or Open Files from Workspace (project_load command). The files that are shown in the tool
window depend on the menu item selected. A button on the tool window also lets you toggle between
viewing current project files and current workspace files.
To open a selected file, press Enter. Use Ctrl+Click to select more than one file. See Files Tool Window
for more information about operations in this window.
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Working with Files
Overview
SlickEdit® provides familiar operations for creating, opening, and working with files. There are many ways
to perform these tasks and many options available for specifying your preferences.
Topics in this section are:
•
•
•
•
•
•
•

The Working Directory
Creating Files
Opening Files
Saving Files
Closing Files
The SlickEdit® File Manager
File History and Backups

Here are a few tips to keep in mind as you read through this section and work with files:
•

SlickEdit supports file names up to 200 characters long.

•

If you’re using the command line and need to edit a file whose name contains space characters,
place double quotation marks around the name.

•

Options are available for specifying actions that automatically occur when a file is opened or
saved, including adjustments for the line format. When you specify a file to edit, the format is
automatically recognized and necessary adjustments are made, based on whether the file type is
DOS, Linux, UNIX, or Mac (classic Mac line endings are a single carriage return, ASCII 13). An
EOF character will not be appended to Linux, UNIX, or Mac text file formats when saved,
regardless of the Save options.

•

When the text in one text file is copied to a buffer that has a different type of text file format, the line
separation characters are reformatted to conform to the format of the destination buffer.

A Word of Caution for Binary Files
The default Load and Save options are safe for editing binary files since all reformatting is turned off. As an
extra precaution to ensure that no reformatting takes place when opening and saving binary files, set the
encoding to Binary when opening the file.
While the default options are safe, it is NOT safe to edit binary files with the following non-default settings,
due to the risk of damaging or losing the files. These options are located on the Load and Save option
screens (Tools > Options > File Options):
•
•
•
•
•

Show EOF character - False
Expand tabs to spaces - True
Append EOF character - True
Remove EOF character - True
Strip trailing spaces - True

The Working Directory
SlickEdit® uses the current working directory for various operations that involve file navigation, and to save
you from tediously browsing and typing long path names when navigating files. For example, when you
use the e command to open a file for editing (see Using the e Command), you don’t need to specify the
complete path if the file is in the current working directory.
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To see the current working directory at any time, use the pwd command on the SlickEdit command line.
SlickEdit automatically changes the working directory to save you time in various situations. You can also
manually set the working directory at any time. Note that the working directory in SlickEdit is different from
the working directory used by the Build tool window. See the following topics:
•
•
•

Automatic Changes to the Working Directory
Manually Changing the Working Directory
Working Directory in the Build Window

Automatic Changes to the Working Directory
SlickEdit® automatically sets or changes the working directory in the following situations:
•

By default, when you start SlickEdit, the working directory is automatically set to the directory from
the previous editing session. You can turn this behavior off with the option Auto restore working
directory (Tools > Options > Application Options > Auto Restore).

•

The working directory is automatically set or changed when you switch projects, according to the
specified project directory or the directory specified in the Working directory field on the
Directories tab of the Project Properties dialog (Project > Project Properties).

•

By default, the working directory is automatically set or changed if you specify a directory with the
open or save_as commands or specify a directory location in the Open and Save As dialogs (File
> Open and File > Save As). You can change this behavior by setting the Change directory
option (Tools > Options > Appearance > General) to False.

•

The working directory changes to match directories you select in the Open tool window. This
window is docked to the left tab group of the editor by default, and can also be displayed by
clicking View > Toolbars > Open from the main menu.

•

The working directory can be automatically set to the corresponding directory when you navigate
to a file, if the configuration variable def_switchbuf_cd is modified (see Configuration Variables).
This is similar to the Change directory option mentioned in the preceding bullet, except it also
works for any file navigation operation (such as e or edit or when SlickEdit opens a file
automatically, such as with Symbol Navigation). This feature is on by default in GNU Emacs
emulation and off in all other emulations.

Manually Changing the Working Directory
You can change the working directory at any time with the Change Directory dialog (from the main menu,
click File > Change Directory or use the gui_cd command). If you want to also change the directory in the
Build window, select the option Process chdir. To use an alias for the directory name, select Expand
alias. Click Save Settings to preserve your preferences. The settings here are also used when you use
the command line version of this feature.

Changing Directories From the SlickEdit® Command Line
To change the directory from the SlickEdit command line, use the cd command as follows, where the p
option corresponds to the Process chdir option on the Change Directory dialog, and a corresponds to
Expand alias:
cd {+p|-p} {+a|-a} drive/and/path/to/directory
You can also change the working directory with the pushd and popd commands. The pushd command
adds the current working directory to the top of the directory stack, and makes the specified directory the
new working directory. For example:
pushd drive/and/path/to/directory
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If no arguments are given, the current working directory is swapped with the directory at the top of the
directory stack. After using pushd, you can use the popd command to remove the top directory from the
directory stack and make it the new working directory.

Working Directory in the Build Window
The working directory in the editor is different from the working directory in the Build tool window. The Build
window is a shell that displays build and compile output, and also allows you to type operating system
commands and see the results. It is docked to the bottom tab group of the editor by default. It can also be
displayed by clicking View > Toolbars > Build from the main menu.
The working directory is shown in the prompt inside the Build window. When you first launch SlickEdit®,
the window is blank. Type a command in the window for the prompt to be displayed.
By default, when the directory is changed in the editor, it is also changed in the Build window. However, the
reverse is not true: changing the directory in the Build window does not change the directory in the editor.
To make the working directory completely independent so that a change directory does not affect the Build
window, make sure the Process chdir option on the Change Directory dialog is off (not selected) and save
the settings (see Manually Changing the Working Directory).

Creating Files
SlickEdit® provides four methods for creating new files:
•
•
•
•

Using the e Command
Using the New File Dialog
Using Code Templates
Using Write Selection

Using the e Command
One of the quickest ways to both create and open files in SlickEdit® is to use the e command on the
SlickEdit command line, using the syntax e file, where file is the name of the file. If the specified file does
not exist, a new buffer by that name will be created. If it already exists, the file will be loaded in a new
buffer. The e command is just a shortcut for the edit command, so you can use edit instead, if you prefer.
If you’re opening a file and the file is not in the current working directory, use the full path. Command Line
Completion will help entering file names and paths.

Using the New File Dialog
If you prefer working with an interface, use the menu item File > New to create a new file. This displays the
New dialog open to the File tab. First select the Document Mode for the new file (recently chosen modes
are listed at the top). If a project is open, the Add to Project box is checked automatically. Specify a
Filename, the Location, and Encoding, then click OK. See the section on the New dialog’s File Tab for
more information about these fields.
You can create a new, untitled buffer by unchecking Add to Project, then double-clicking on a language in
the Document Mode list.

Using Code Templates
Code templates are pre-defined units of code that you can use to automate the creation of common code
elements, like a standard class implementation or design patterns. See Code Templates for more
information and details about this feature.
To instantiate a predefined Code Template, complete the following steps:
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1. From the main menu, click File > New Item from Template (or use the add_item command). The
Add New Item dialog is displayed.
2. In the Categories list, expand Installed Templates, then click through the tree to select the
language and category of the file you want to create.
3. In the Templates box, select the template you want to use.
4. In the Name field, type the name of the new file.
5. In the Location field, type the directory path where you want to store the new file, or click Browse.
This field is prepopulated with the active directory.
6. Optionally, select Add to current project.
7. The type of template you selected may generate more than one file. If you want to view a
confirmation list of the files that will be created after you click Add, select Confirm files before
adding.
8. Click Add.

Using Write Selection
SlickEdit also lets you create a file from a selection. Select the text you want to write, then from the main
menu, click File > Write Selection (or use the gui_write_selection command). The Write Selection dialog
is displayed, with fields for specifying the file name and location (similar to the Save As Dialog). The
selected text is written to the specified file.

Opening Files
SlickEdit® provides many ways to open files:
•

One of the quickest ways to open a file is to use the e command (in the syntax e file), which can
also be used to create files. See Using the e Command for more information.

•

Alternately, from the main menu, click File > Open (or use the gui_open command). On Windows,
the standard Open dialog is displayed. On Linux, UNIX, or Mac, a Windows 3.1-style Open dialog
is displayed. This dialog is generally faster than the dialog that appears on Windows platforms and
it contains additional options. See Standard Open Dialog and Windows 3.1-Style Open Dialog for
more information about the fields on these dialogs.

•

To quickly open the header or source file that is associated with the current file, from the main
menu, click Document > Edit Associated File (or use the edit_associated_file command).

•

For Windows platforms, another way to open files is to set up file associations. When you open an
associated file from Windows Explorer, it runs in the SlickEdit application. See Setting File
Associations for more information.

TIP The Files tool window is available for viewing files that are open in the editor. It can show a list of
open files, project files, and workspace files, all sortable by file name or path. The tool window also
includes a filter to narrow the list of files displayed and shortcuts for basic file operations. To display
the Files tool window, from the main menu, click Document > List Open Files (or press
Ctrl+Shift+B or use the list_buffers command). See Files Tool Window for more information.
More topics in this section:
•
•
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•
•
•

Inserting Files
Invoke and Edit
Options for Opening Files

Finding Files
SlickEdit® provides a Find File feature so you can search for one or more files to open. To access this
feature, from the main menu, click Search > Find File (or use the find_file command). The Find File
dialog is displayed. You can also access the dialog by clicking the Find File button on the Open dialog
(File > Open). See Find File Dialog for information about using this dialog.

Opening URLs
In addition to opening files on your computer, SlickEdit® lets you open files on the Web for editing. To open
a file located at a particular Web address, from the main menu, click File > Open URL. The Open URL
dialog is displayed. In the URL text box, enter a URL to open. You can use forward or backward slashes,
and the prefix “http://” is not required. The URL will be opened in a new editor window. For a description of
this dialog, see Open URL Dialog.
TIP URLs in SlickEdit editor windows are treated as links. You can open these links in a Web
browser by hovering over the link with your mouse pointer and using the binding Ctrl+Click (or
Cmd+Click on the Mac). See Navigating to URLs for more information.

Inserting Files
The Insert File feature can be used to insert a file at the cursor location in the current buffer. To access this
feature, from the main menu, click File > Insert a File (or use the gui_insert_file command). The Insert
File dialog is displayed (similar to the standard Open dialog), which lets you specify the file to insert.

Invoke and Edit
Using your operating system command line, you can invoke SlickEdit® with a file(s) loaded for editing. The
syntax is:
vs {options} file1 {options} file2
If the file that you want to edit is not found, an empty buffer is created with that name.
The table below shows some invocation examples. See Invocation Options in the Appendix for more
options and information.
Invocation Example

Description

vs project1.vpw

Auto Restore from workspace file. If you specify
.vpj, SlickEdit Auto Restores the project.

vs project1.dsw

Auto Restore from a Visual C++ workspace file.

vs autoexec.bat config.sys

Edit two files.

vs “this is.c”

Edit a file with a space character.

vs test.c -#1000

Edit test.c and go to line 1000.

vs orders -#bottom-of-buffer -#/invoice/-

Edit orders file, go to bottom of buffer, and search
backward for “invoice”.
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Invocation Example

Description

vs +70 test.exe

Edit binary file test.exe in record width 70.

vs *.c

Edit all C source files in the current directory.

vs -r list \

Start the Windows file manager and list the entire
drive contents.

vs -x rich.sta autoexec.bat

Specify a different state file (rich.sta) and edit
the file autoexec.bat.

Options for Opening Files
SlickEdit® provides several options related to opening files:
•
•
•

•

Using the Windows 3.1-Style Dialog
Activating Change Directory
Setting Global Load Options
o Working with Large Files
o Different Options for Different Drives
Setting Language-Specific Load Options

Using the Windows 3.1-Style Dialog
If you are running Windows, you can choose to use a Windows 3.1-style dialog instead of the standard
Open and Save As dialogs. To do this, from the main menu click Tools > Options, expand Appearance
and select Advanced, then set the option Windows 3.1 style open dialog to True.

Activating Change Directory
You can specify that the current directory is changed in the editor when the directory is changed in the
Open, Save As, and Change Directory dialogs. From the main menu, click Tools > Options, expand
Appearance and select General, then set the option Change directory to True.

Setting Global Load Options
SlickEdit® provides many global Load options, such as specifying which file is active after multiple files are
loaded at once, expanding tabs to spaces, size limits for files to be loaded, and Auto Reload preferences.
These options affect the Open dialog box and any other command that uses the e or edit commands to
open a file. In fact, you can override many of these global Load options by selecting the corresponding
option on the Open dialog. To access global Load options, from the main menu, click Tools > Options,
then expand File Options and select Load. See Load File Options for information about each option.
Working with Large Files
The editor reads the entire file for files that are color-coded. However, the Load partial option enhances
system performance because the original file is used as a read-only spill file. To determine when the entire
file is read, go to the bottom of the file. If the line number is displayed at the bottom of the file, the entire file
has been read; however, this does not mean the entire file is in memory. When the entire file is not loaded,
it will be locked, and other applications will not be able to write to it.
By default, 2 MB is used for the buffer cache. When the cache is full, modified blocks are written to the spill
file. Blocks that are not modified and that can be reread from the original file are discarded. Scrolling
through a 2 GB file requires no more than 2 MB of memory (default). A search and replace operation that
hits every block requires that almost all blocks be spilled. Saving a 2 GB file requires 4 GB of disk space.
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The file data must first be spilled before saving the file. Turn backups off before saving a large file since
this requires additional disk space, equal to the size of the file. The block size is 16 K.
Different Options for Different Drives
If you want to specify different global Load options for different disk drives, define an environment variable
called VSLICKLOAD and specify each drive followed by the appropriate switch. For example, the following
command specifies preloading files from jump drives M and N:
set VSLICKLOAD= m: +L n: +L
TIP See Command Line Switches for information about enabling and disabling switches on the
SlickEdit® command line.

Setting Language-Specific Load Options
Some options for loading files, such as loading as binary and expanding tabs to spaces, can be set on a
language-specific basis. Language-specific File options override all global File options as well as any other
options set for that language. To access these, from the main menu, click Tools > Options. Expand
Languages, the language category and language, then select File Options. See Language-Specific File
Options for more information.

Saving Files
You can use the following methods to save files in SlickEdit®:
•

To save the current file or buffer: From the main menu, click File > Save (Ctrl+S or save
command). Alternately, right-right click on a file tab and select Save [file] from the context menu.

•

To save the current file or buffer with another name: From the main menu, click File > Save As
(gui_save_as command). On Windows, the standard Save As dialog is displayed. On Linux,
UNIX, or Mac, a Windows 3.1-style Save As dialog is displayed. Both dialogs provide similar fields
and options. Select the Keep old file option if you do not want the buffer name to be changed. See
Save As Dialog for more information.

•

To save all open buffers: Click File > Save All (save_all command). Alternately, right-click on
any file tab and select Save All from the context menu.

If a Save operation fails, for example, because the file does not have write permissions, the Save Failed
dialog box is displayed, presenting some alternate choices. See Save Failed Dialog for a description of this
dialog.

Options for Saving Files
SlickEdit® provides many options regarding the saving of files:
•
•
•
•
•
•

Using the Windows 3.1-Style Dialog
Setting Global Save Options
Setting Language-Specific Save Options
Setting Backup Options
Setting AutoSave Options
Setting File Filter Options

Setting Global Save Options
Global Save options are available to specify actions that automatically occur when a file is saved, such as
appending/removing EOF characters, expanding tabs to spaces, and setting the line format. You can
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override some of these global Save options by selecting the corresponding option on the Save As dialog.
To access global Save options, from the main menu, click Tools > Options, then expand File Options and
select Save. See Save File Options for information about each option.

Setting Language-Specific Save Options
Some options for saving files, such as saving as binary and expanding tabs to spaces, can be set on a
language-specific basis. Language-specific Save options override all global Save options as well as any
other options set for that language. To access these, from the main menu, click Tools > Options. Expand
Languages, the language category and language, then select File Options. See Language-Specific File
Options for more information.

Setting Backup Options
When a file is saved, SlickEdit can automatically create a backup of the file. To enable Backup and
configure Backup options, from the main menu, click Tools > Options, then expand File Options and
select Backup. See Backup File Options for more information.

Setting AutoSave Options
SlickEdit® can save temporary versions of files, in the event of power failure or other unforeseen
circumstances. To enable AutoSave and set your AutoSave preferences, from the main menu, click Tools
> Options, then expand File Options and select AutoSave. When AutoSave is enabled, SlickEdit creates
temporary files in the autosave directory of your user config. These files are deleted the next time
AutoSave occurs. AutoSave does not save buffers that are not named. See AutoSave File Options for
more information.

Setting File Filter Options
You can change the file specifications that appear as choices in the drop-down lists for the Files of type
and Save as type fields on the Open and Save As dialogs, respectively. By default, all files are listed;
however, you might want a smaller list that displays only the source files you typically edit. To edit these file
filters, from the main menu, click Tools > Options, then expand File Options and select File Filters. See
File Filter Options for more information.

Closing Files
Files can be closed in SlickEdit® with the methods below. Prior to closing, you will be prompted to save
any changes.
•

To close the current file: Click File > Close (F3 or q command), or right-click on the file tab and
select Close [file] from the context menu. You can also use Shift+LeftClick or the middle mouse
button on a file tab to close a file, even if the focus is not on the file to be closed. Note that the
middle mouse button must be configured to send a Middle Button event.

TIP The q command is a shortcut for the quit command. Use q (or quit) in the syntax q [file], where
[file] is a file or list of files to close. Wildcards are permitted. For example, q c:\temp\*.* closes all
files in the temp directory that you had open.
•

To close all open files: Click File > Close All (close_all command) or right-click on the file tab
and select Close All from the context menu.

•

To close all open files except for the one currently in focus: Right-click on the file tab and
select Close Others from the context menu.

See Opening and Closing Workspaces for information about closing workspaces and projects.
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Automatically Closing Visited Files
Some features and operations in SlickEdit® automatically open files for “visiting”, such as Go to Definition
and Pop Bookmark (see Symbol Navigation). A file is considered visited if it is opened as a result of a
symbol navigation or search operation, not modified, and subsequently navigated away from. An option is
available to automatically close these visited files. To access the Automatically close visited files option,
from the main menu, click Tools > Options, then expand Appearance and select General. You can
enable the option or you can choose to be prompted to close each time you navigate away from a visited
file.

The SlickEdit® File Manager
The SlickEdit File Manager offers a rich set of file listing, selecting, and operating capabilities. You can
select, deselect, list, and unlist files by extension, attribute, and search pattern. Once you have listed and
selected the files to be operated on, you can change file attributes, copy, move, delete, or back up the
selected files.
File Manager operations and options can be accessed from the main menu by clicking File > File
Manager.
Topics in this section:
•
•
•

Creating a New File List
Selecting Files in the File List
Operating on Selected Files

Creating a New File List
Before managing files in the File Manager, you must first create a list of files to be managed. To create a
new file list, use the fileman command, or from the main menu, click File > File Manager > New File List.
The List Files dialog is displayed, with the following options:
•

File name - Specify in this text box one or more files separated by spaces. Each file specification
may contain wildcard characters. For example, “*.c *.h” will list all C and H files.

•

Include system files - When checked, files with the system attribute set are included in the list.
This option is ignored on UNIX. This option is always turned on under Windows if the Show all
files option is set on the Open dialog box (see Standard Open Dialog).

•

Include hidden files - When checked, files with the hidden attribute set are included in the list.
This option is ignored on UNIX. This option is always turned on under Windows if the Show all
files option is set on the Open dialog box (see Standard Open Dialog).

•

Subdirectories - When checked, all subdirectories below each file specified in the File name text
box are searched.

The listing of files will appear in a new buffer window.
You can append files to your current file list. From the main menu, click File > File Manager > Append
File List or use the fileman command. The Append File List dialog contains the same fields and options
as the List Files dialog described above.
TIP To modify and close a file list without being prompted to save each time, from the main menu,
click Tools > Options > Editing > General, then set the Throw away file lists option to True.
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Selecting Files in the File List
To select files in the file list, use the File Manager selection functions. To access these functions, from the
main menu, click File > File Manager > Select, then choose one of the following sub-menu items:
•

All - Selects all files in the list.

•

Deselect All - Deselects all files that were previously selected.

•

InvertSelect - Invert the selection.

•

Attribute - Selects files that contain a specific attribute search string that you specify.

•

Extension - Selects all files with the specified extension. Enter the extension without the Dot
character.

•

Highlight - Selects all files within a marked area.

•

Deselect Highlight - Deselects highlighted files.

Operating on Selected Files
The following operations are available on the File Manager menu (File > File Manager):
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•

Sort - (fsort command) Sorts the files listed in File Manager on a primary and optionally a
secondary key. Check the Secondary Sort check box if you want to sort on a secondary key.

•

Backup - (fileman_backup command) Copies the selected files (lines with “>” character as first
character of line) to a directory you choose. The directory structure on the source file is preserved.
Typically only a drive letter is specified for the destination directory. However, you may specify a
path if you wish to further nest the directory structure.

•

Copy - (fileman_copy command) Copies the selected files (lines with “>” character as first
character of line) to a directory you choose.

•

Move - (fileman_move command) Moves the selected files (lines with “>” character as first
character of line) to a directory you choose. The destination drive does not have to be the same as
the source drive.

•

Delete - (fileman_delete command) Prompts whether to delete the selected files.

•

Edit - (fileman_edit command) Opens the selected files for editing.

•

Select - Displays a menu of selection commands. See Selecting Files in the File List.

•

Files - Displays a menu of the following file commands:
o

Unlist All - (unlist_all command) Removes all files from the list.

o

Unlist Selected - (unlist_select command) Removes selected files from the list.

o

Unlist Extension - (gui_unlist_ext command) Removes files with a specific extension from
the list.

o

Unlist Attribute - (unlist_attr command) Removes files with a specific attribute from the list.

o

Unlist Search - (unlist_search command) Deletes lines which contain a search pattern you
specify.

o

Read List - (read_list command) This dialog box is similar to the Append List dialog box
which adds files to the current list. The difference is that the Read List dialog box prompts you
for a file name which contains the names of files to append to the current list. The file may be
a list of file names or may be a file in the same format as a file manager list. You may use the
Write List dialog box to write a list containing the selected file names.
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o

Write List - (write_list command) Writes a list of the currently selected file names to a file you
choose. The Open dialog box is displayed to prompt you for a file.

•

Attribute - (fileman_attr command) Sets the Read Only, Hidden, System, and Archive
attributes of the selected files.

•

Repeat Command - (for_select command) Runs internal or external commands on selected files.

•

Global Replace - (fileman_replace command, or Alt+Shift+G) The Global Replace dialog box
performs a search and replace on the selected files in the File Manager. The following options are
available:

•

o

Search for - Enter the string you want to search for here.

o

Replace with - Search string is replaced with this string.

o

Match case - When checked, a case sensitive search is performed.

o

Match whole word - When checked, a word search is performed. Before a search is
considered successful, the characters to the left and right of the occurrence of the search
string found are checked to be non-word characters. To change the word characters for a
specific language, use the Word chars box on the language-specific General options screen
(Tools > Options > Languages > [LanguageCategory] > [Language] > General). See
General Language-Specific Options.

o

Regular expression - When checked, a regular expression search is performed. See Find
and Replace with Regular Expressions for more information.

o

Place cursor at end - When checked, the cursor is placed at the end of the occurrence found.

Global Find - (fileman_find command) Performs a search on selected files.

File History and Backups
This section includes the following topics:
•
•
•
•

Backup History
Backing Up Network Files
Viewing the History of Opened Items
Setting Backup Options

Backup History
Backup History maintains a version history for a file, creating a new version each time you save. This
creates a more fine-grained version history that bridges the gap between checkins with your source control
system. With Backup History you can compare the current version to previous versions, compare two
previous versions, or open a previous version for editing. To activate Backup History, from the main menu
click Tools > Options, expand File Options and select Backup, then set the Make backup files option to
True. Make sure that the Backup directory option is set to Create backup history on save.
To access Backup History for the current file, from the main menu click File > Backup history for. The
Backup History tool window is displayed (View > Toolbars > Backup History), as shown below.
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SlickEdit® creates and stores deltas to conserve disk space. The Run Diff on Selected Backups button
allows the comparison by using DIFFzilla® dialog, and the Open Selected Backup button allows you to
open the version that is highlighted in the list of files. The Save Selected Backup As button can be used
to save a file from the history with a different file name.
For more information on diffing files and using the DIFFzilla dialog, see DIFFzilla®. See Setting Backup
Options below for more information on Backup History options.

Backing Up Network Files
Windows Backups
Sometimes the default backup style does not work correctly when a network file is saved. By default,
backups are placed in a subdirectory named backup under the SlickEdit® installation directory. For this
backup style to work, make sure the application has access rights to this directory and that this directory
exists. Specify the backup directory in the Backup directory path field on the Backup File Options screen
(Tools > Options > File Options > Backup).

Linux, UNIX, and Mac Backups
The default backup style will work properly under Linux, UNIX, and Mac platforms because backup files
are placed in the $HOME/.vslick directory, which should always have read-write permissions.
A backup file is created the first time a file is saved in a given edit session. Therefore, the backup file may
not represent the last save.

Viewing the History of Opened Items
To see the names of files and projects that have been recently opened, from the main menu, click Tools >
Options, expand Appearance and select History. You can see the history of items recently opened from
the File or Project menu. See History Appearance Options for more information.

Setting Backup Options
To activate backups of files and backup history and to set backup preferences, from the main menu, click
Tools > Options, expand File Options and select Backup. See Backup File Options for more information.
A backup of a file is made the first time you save your file in a given edit session. Your backup file may not
represent your last save. To maintain a complete history of your saves, use the Backup History feature.
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For more up-to-date backups, use the AutoSave feature (see Setting AutoSave Options).
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Context Tagging®
This chapter contains the following topics:
•
•

Context Tagging®
Building and Managing Tag Files
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Context Tagging®
Context Tagging is a feature set that performs expression type, scope, and inheritance analysis as well as
symbol look-up within the current context to help you navigate and write code. Context Tagging uses an
engine that parses your code and builds a database of symbol definitions and declarations—commonly
referred to as tags. Context Tagging features work with your source code, not just standard APIs
(application program interfaces), and the features are dynamic, in the sense that symbols are updated
immediately or in the background as you edit your source code.
The Context Tagging feature set includes:
•
•
•
•
•
•
•

Tag-Driven Navigation
List Members
Parameter Information
Auto List Compatible Parameters
Completions
Symbol Browsing
Statement Level Tagging

Before you begin working with these features, some configuration is required. See Building Tag Files.

Tag-Driven Navigation
The Context Tagging® database allows you to navigate your code, jumping from a symbol to its definition
or its references. For more information, see Symbol Navigation.

List Members
When typing a member access operator (Dot, Comma, “->”, and “:” for C++; Dot for Java; IN and OF for
COBOL), members are automatically listed. You can access this feature on demand by pressing Alt+Dot,
finding identifiers when there is no member operator (list locals, global variables, current class members,
etc.). For example, for the C language, to find a string function, type the string on the command line and
press Alt+Dot. If you want to disable automatic listing and only list members on demand, turn List
Members off, as follows:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Context Tagging®.
2. Clear the Auto-list members check box.
The following example shows the results of what is displayed after typing a Dot when entering Java
source. Notice that the Javadoc comments are displayed in a mini-HTML browser. To view documentation
for Java APIs, you must install the source files as part of the JDK. If clicking on a URL, the default HTML
browser starts. Clicking on other hypertext links navigates within the comment window. The equals method
in the example below has two occurrences, one in the String class and one in the Object class. Press
Ctrl+PgDn or Ctrl+PgUp to select the next or previous occurrence.
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The example below shows the display after typing a Dot when entering C++ source code. The stack class
is one of the C++ standard template library classes.

Parameter Information
The prototype for a function is automatically displayed when typing a function operator such as the open
parenthesis. This also highlights the current argument within the displayed prototype. When working with
C++, parameter info is also automatically displayed when typing a template argument operator such as <.
The following example shows the result of pressing Alt+Comma inside the argument list of the Java API
String method startsWith. The Javadoc comments are displayed in a mini-HTML browser. To view
documentation for Java APIs, you must install the source files as part of the JDK. If clicking on a URL, the
default HTML browser starts. Clicking on other hypertext links will navigate within the comment window.
The startsWith method has two overloads that accept different arguments. Press Ctrl+PgDn or
Ctrl+PgUp to select the next or previous occurrence.

The example below shows the result of pressing Alt+Comma inside the argument list of the WIN32 API
function CreateWindowEx.
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Auto List Compatible Parameters
When typing a function operator such as the open parenthesis, “(”, a list of compatible variables and
expressions for the current argument is displayed. Auto List Compatible Parameters can also be used
instead of List Members, in assignment statements (x=<Alt+Comma>) and when listing members of a
class or struct. Keep in mind, not all possible variables and expressions are listed. Press Alt+Dot if the
symbol that you want is not listed. To access Auto List Compatible Parameters on demand, press
Alt+Comma. If you want to disable automatic listing and only list parameters on demand, turn Auto List
Compatible Parameters off, as follows:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Context Tagging®.
2. Clear the Auto-list compatible parameters check box.
The following example displays the results of pressing Alt+Comma after an assignment operator. The
Rect, pRect, and argv are not listed because their types do not match.

Completions
Completions save keystrokes as you are typing code by providing a way to automatically complete
partially-typed text. Press Ctrl+Space for SlickEdit® to automatically complete the rest of the symbol
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you’re currently typing. If a unique match is not found, a list is displayed allowing the selection of the exact
match. See Completions for more information.

Symbol Browsing
SlickEdit® gives you the ability to browse and view symbols in your files or workspaces. There are several
tool windows that display information as you work to help you find what you need exactly when you need it:
•

Class - This tool window provides an outline view of both the members of the current class as well
as any visible inherited members. It also shows the inheritance hierarchy of the current class. The
Class tool window is docked as a tab on the left side of the editor by default.

•

Current Context - Current Context displays the logical location of the cursor within your code. If it
is within a class, it displays the class name. If it is within a function, it displays the function name. If
the function is within a class, it displays the class and the function name. The tool window is
docked in the top upper-right section of the editor by default.

•

Defs - The Defs (Definitions) tool window contains the defs (definitions) browser, which provides
an outline view of symbols in the current workspace. It is docked as a tab on the left side of the
editor by default.

•

Find Symbol - This tool window is used to locate symbols (tags) in your code. It allows you to
search for symbols by name using either a regular expression, substring, or fast prefix match. This
window can be displayed by clicking Search > Find Symbol or by using the gui_search
command.

•

Preview - The Preview tool window provides a portal for viewing information in other files without
having to open them in the editor. It automatically shows this information when you are working
with certain features. This window is docked as a tab on the bottom of the editor by default.

•

References - This window displays the list of symbol references (uses) found the last time that
you used the Go to Reference feature (Ctrl+/ or push_ref command—see Symbol Navigation for
more information).

•

Symbols - The Symbols tool window contains the symbol browser, which lists symbols from all of
the tag files. It is docked as a tab on the left side of the editor by default.

•

Symbol Properties - This window displays detailed information about the symbol at the cursor
location. It can be displayed by clicking View > Toolbars > Symbol Properties or by using the
activate_tag_properties_toolbar command.

For more detailed information about these tool windows and how SlickEdit can help you browse symbols,
see Symbol Browsing. For information about how to navigate between symbols in files, see Symbol
Navigation.

Statement Level Tagging
Statement Level Tagging is a feature of Context Tagging® that provides a more detailed view of items in
the Defs tool window for C/C++, Java, Python, and Visual Basic .NET. Along with definitions, view
constructs like if, while, and for statements. It also displays every non-comment line of code. To see this
feature in action, from the Defs Tool Window, right-click and select Show Statements.
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Building and Managing Tag Files
Context Tagging® creates tag files to store information about symbols and, optionally, cross-reference
information from your source code. Many of the most powerful features of SlickEdit® use this information
to speed your coding.

Building Tag Files
Tag files are automatically created and maintained for files in the workspace (see Creating Tag Files for
Run-Time Libraries). You may need to create language-specific tag files for compiler includes or other
libraries that you have (see Tagging Run-Time Libraries).
After a tag file is created, it is updated in the background when you make modifications. If you modify some
source files using an application other than SlickEdit, you will need to rebuild the tag file. Tag file names
have the extension .vtg. By separating tag files for different languages, the Context Tagging features can
identify symbol information for the file that you are currently editing.

Creating Tag Files for Run-Time Libraries
The Create Tag Files for Run-Time Libraries dialog appears when SlickEdit® is run for the first time. It
allows you to build tag files for commonly used languages and their libraries, including C, C++, Java, and
.NET. You can access this dialog at any time in order to create tag files, from the Context Tagging® - Tag
Files Dialog (click Tools > Tag Files, then click Auto Tag).

To create tag files for the languages listed, enter the base directory for your package (if it is not already
filled in), as well as the destination of your tag file. Click Create tag file(s) and the Building Tag Files dialog
box opens showing the progress as the tag file is built.
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For source files other than these languages, use the Add Tag File dialog, which allows you to choose from
a list of languages the source type for which to insert the tag file. See Creating Language-Specific Tag
Files below.

Creating Language-Specific Tag Files
Language-specific tag files provide the same symbolic information for libraries that is provided for code in
your projects. A library is a pre-built unit of code that is not edited as part of this development effort. These
tag files are accessible from any project written in the same language.
You need to create an language-specific tag file if your project uses a compiler whose standard libraries
are not tagged by the Create Tag Files for Run-Time Libraries dialog (see Creating Tag Files for Run-Time
Libraries) or if you are using a third-party library. Additionally, you may have local libraries that are reused
from project to project.
To create an language-specific tag file, complete the following steps:
1. From the main menu, click Tools > Tag Files. The Context Tagging® - Tag Files Dialog is
displayed.
2. Click Add Tag File to open the Add Tag File dialog.

3. Select the source type into which you want the tag file inserted. Select Generate References only
if you want library functions to be shown when you list references.
NOTE Generate References creates an inverted file index so that you can quickly find which files
contain which symbols. Workspace tag files create this index by default. This information is used to
build a list of references (using the push_ref command, bound to Ctrl+/ in the CUA emulation). In
general, it’s better to have the reference list contain functions that are part of this workspace and not
in libraries. If Generate References is not checked, you will still be able to jump from a symbol to its
definition in a library using Ctrl+Dot (push_tag).
This option is off by default since most programmers do not want to see library functions shown in
the reference list.
4. Click OK. The Add Tags Database dialog opens.
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5. Select an existing tag file or enter the name for the new tag file. Tag files have the extension .vtg.
6. Click Open to display the Add Tree dialog. Navigate to the root of the library source code and click
the OK button.
7. The Building Tag File dialog opens showing the progress as the tag file is built. When finished, the
contents are displayed in the Context Tagging® - Tag Files dialog.
See Managing Tag Files for more information.

Tagging Run-Time Libraries
Create language-specific tag files for include files of compiler packages or utility libraries or both. This
allows the Context Tagging® feature set to work for all symbols, not just those symbols in the project.
Context Tagging needs all symbol information to work properly.
A tag file is automatically built for the run-time libraries of C#, InstallShield, JavaScript, Perl, PV-WAVE,
Slick-C®, Tornado, TCL, and Visual Basic .NET, and usually it is not necessary to build tag files for the
run-times of these languages. If you already built a tag file for run-times during installation, you can skip
this section. If you are using Perl, Python, or TCL, and the compiler cannot be found in PATH (or registry
for Windows), you need to build tag files for these run-time libraries.
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Configuring Context Tagging® for COBOL
All of the Context Tagging features for COBOL, except Parameter Information, are provided by scanning
COBOL source file and the copy books that are included. This information is used by List Members,
completions, tag-driven navigation, symbol preview, and in the Outline view. Parameter Information for
COBOL commands and intrinsic functions are provided by the COBOL built-ins file created during product
installation. To provide Parameter Information for subroutines, you must build a tag file that will hold
linkage information from the subroutine’s point of view.

Managing Tag Files
The Context Tagging® - Tag Files Dialog (Tools > Tag Files) is used to manage your tag files.

The left pane of the dialog lists all of your tag files, separated into categories (see Tag File Categories
below). A tag file having a File bitmap with blue arrows indicates the tag file is built with support for crossreferencing. The right pane of the dialog lists all the source files indexed by the currently selected tag file.
For information about the buttons available, see Context Tagging® - Tag Files Dialog.

Tag File Categories
The Tag File categories, described below, are listed on the left side of the Context Tagging® - Tag Files
dialog (Tools > Tag Files).
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•

Workspace Tag File - The tag file for the current active workspace. Visible only if a workspace is
open.

•

Auto-Updated Tag Files - These tag files are designed to be shared by multiple users of
SlickEdit® on a network. You can use the vsmktags utility to rebuild these tag files as part of your
nightly build process. When SlickEdit detects that a newer version of an auto-updated tag file is
available, it will automatically copy in the newer version and begin using it.
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•

“C” Compiler Configuration Tag Files - These tag files correspond to one of the C/C++ compiler
configurations. These may be configured by using the C/C++ Compiler Properties dialog box
(Tools > Options > Languages > Application Languages > C/C++ > C/C++ Compiler
Options). See C/C++ Compiler Settings for more information.

•

Language-Specific Tag Files - The tag files listed under each of the language-specific categories
apply to that language only. Use these categories to add tag files for third-party libraries.

Tag File Search Order
When doing tag lookups, the tag files are searched in a specific order, which affects the tags found. The
following are examples of the order in which tag files are searched.

Example: Java Tag File Search Order
If a Java source file is open, when a tagging-related operation is performed, the tag files are searched in
the following order:
1. Workspace tag file, providing it contains other Java source files.
2. Auto-updated tag files, containing other Java source files.
3. Language-specific Java tag files, in the order that they are listed in the Context Tagging® - Tag
Files Dialog.

Example: C/C++ Tag File Search Order
If a C/C++ source file is open, when a tagging-related operation is performed, the tag files are searched in
the following order:
1. Workspace tag file, providing it contains other C/C++ source files.
2. Auto-updated tag files containing other C/C++ source files.
3. The “C” Compiler Configuration tag file corresponding to your default C compiler configuration as
specified in your project (see C/C++ Compiler Settings), or global default.
4. Language-specific C tag files, in the order that they are listed in the Context Tagging® - Tag Files
Dialog. Note that if you have a “C” Compiler Configuration tag file, cpp.vtg will be excluded from
this list.

Rebuilding Tag Files
The Rebuild Tag File dialog box contains options for rebuilding the selected file. To display the Rebuild
Tag File dialog, click Tools > Tag Files. When the Context Tagging® - Tag Files Dialog is displayed, select
a file to rebuild, then click Rebuild Tag File.
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The following settings are available:
•

Retag modified files only - If checked, SlickEdit® will incrementally rebuild the tag file, only
retagging files that have been modified since the last time they were tagged. If not checked,
SlickEdit will rebuild the entire tag file from scratch.

•

Generate References - If checked, the tag file will be built with support for cross-referencing. Tag
files with support for references are slightly larger and take slightly more time to build. They will
also be included in all symbol references searches, which may not be necessary, especially for
third-party libraries.

•

Remove all deleted files without prompting - If checked and the tag file contains a source file
which no longer exists on disk, the source file will be removed from the tag file without prompting
for confirmation.

•

Keep all deleted files without prompting - If checked and the tag file contains a source file
which no longer exists on disk, the source file will not be removed from the tag file without
prompting for confirmation.

NOTE The options Remove all deleted files without prompting and Keep all deleted files
without prompting are mutually exclusive—selecting one will clear the other.

Context Tagging® Options
General Context Tagging® Options
Options are available for setting general parameters for the Context Tagging feature set. You can
designate how tagging is done, how references function within the application, and tune the application to
maximize performance. To display the options, from the main menu, click Tools > Options, expand
Editing, and select Context Tagging® Options. See Context Tagging® Options for descriptions of the
options.
TIP To improve tagging performance, you may need to adjust the tag file cache size (Tools >
Options > Application Options > Virtual Memory). See Virtual Memory Options for more
information.
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Language-Specific Context Tagging® Options
You can activate and deactivate various Context Tagging features on a per-language basis. To access
these options, from the main menu, click Tools > Options > Languages, expand your language category
and language, then select Context Tagging®. See Language-Specific Context Tagging® Options for more
information.
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Building, Running, and Debugging
This chapter contains the following topics:
•
•

Building and Compiling
Running and Debugging
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Building and Compiling
Project Configurations in Builds
Each project may have a number of configurations defined. See Project Configurations for more
information on creating and managing Project Configurations. The active configuration is used during the
build process to determine the project settings to use. The manner in which the configuration affects a
build depends on which build system you are using.
The build system is specified by selecting Project > Project Properties from the main menu and then
selecting the Build tab. The first and third options, Build without a makefile and Build with an autogenerated, auto-maintained makefile, use the SlickEdit® build system. The second option, Build with a
user-maintained makefile or custom build command, allows you to use a custom makefile or configure
build commands on the Tools tab.
•

If you use the SlickEdit build system, SlickEdit will use the project properties associated with the
currently active configuration. It will direct the build output to a directory with the same name as the
project configuration. For example, if Debug is active, SlickEdit will direct the build output to a
directory, named “Debug”, inside the project directory. You can specify an output directory for a
configuration by selecting Build > Configurations from the main menu, and then enter a directory
in the Object directory field.

•

If you are using custom build commands on the Tools tab, you can use the %b (current
configuration) or %bd (object directory) escape sequences to implement configuration-specific
build behaviors.

•

If you are using a custom makefile, you can define a macro, such as CFG, which represents the
configuration you want to build. Add code to the makefile to check for this macro and perform
different statements, like choosing different compile options or a different directory for object files.
The makefiles exported from Visual C++ already define a CFG macro. For a standard make
program you will need to use the name=value syntax when passing a macro to the make
program. For example:
make CFG=Debug

Using Build and Compile Operations
SlickEdit® provides the capability to build a project or compile single files.
•

To build the active project, click Build > Build from the main menu, press Ctrl+M, or use the
project_build command.

•

To build a different project, open the Projects view, right-click on a project and select Build.

•

To compile the file in the active editor window, click Build > Compile from the main menu, press
Shift+F10, or use the project_compile command.

•

To compile a different file, display the Projects tool window, right-click on a file, and select
Compile.

If your workspace contains multiple projects, sometimes one or more projects must be compiled before a
particular project can be compiled. Click Project > Project Properties and then select the Dependencies
Tab to view or set dependencies for the active project. Alternatively, you can right-click on a project in the
Projects view and select Dependencies, allowing you to set dependencies for a project that is not active.
Before you can execute the Build or Compile commands you must set the current project or define an
extension-based project. To define an extension-based project command, use the language-specific
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General options screen (see Defining Language-Specific Projects). You will probably want the Build
command to be based on the current project and not the current extension. Use the workspace_new
command (Project > New) to create a workspace or project. If the current project has a Compile command
defined, the language-specific project Compile command will be ignored.
By default, the Build or Compile command is executed in the Build window. This allows you to continue
editing while the compiler runs. You can process the error messages as they appear in the Build window
instead of waiting until the compile process finishes. Use the stop_process command or click Build >
Stop Build to stop the compiler running. To send the compile output to an editor window (named
.process), right-click in the Build window and select Send Compile Output to Editor Window.
To customize the Build and Compile commands, click Project > Project Properties. Select the Tools Tab,
then select an operation from the list: Build, Compile, or Rebuild. Depending on the language and your
other project settings, either a command line or an Options button will be displayed allowing you to
configure the operation.

Compiling a Project
The Build menu items Compile and Build start the compile and build commands respectively for the
current project. If you selected a compiler package, you can try these commands now. To change these
commands and a few other project options, use the Tools Tab of the Project Properties dialog box (Project
> Project Properties). The Build > Next Error and Build > Previous Error menu items allow quick
navigation of compiler errors.

Using VSBUILD to Compile
Use the utility program vsbuild to compile files in a project and process dependencies between projects.
This tool is intended to help implement project support. It has a built-in make facility for Java and C++,
performs project dependencies, and processes pre- and post-build commands. For example, if
file1.java references file2.java which references file3.java and file3.java is modified, then
when you invoke the Build command, file1.java, file2.java, file3.java will be recompiled. Invoking
vsbuild with no parameters displays invocation options.

Compiling a Visual C++ Project
For Visual C++ v5.x and v6.x, the default compile command uses the nmake program which requires a
makefile (.mak extension). Visual C++ v5.x and v6.x do not automatically create a makefile for you. Use
Project > Export Makefile in Visual C++ to create or update the makefile. For Visual C++ v5.x or higher,
the default build and rebuild commands do not need a makefile.
You can customize the compile, build, and rebuild commands from the Tools Tab of the Project Properties
dialog box (Project > Properties).
If you get an error when you run nmake, you need to run the VCVARS32.BAT file (shipped with Visual C++)
in a DOS box that you start the editor from. This will set the environment so that the editor can run these
compiles.

Specifying Build on Save
A build can be automatically launched upon saving the file or files within a project. To specify this option
and to toggle it on/off, from the main menu click Build > Build Automatically on Save. By default this
option is not selected.
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Specifying Open Commands
The Open Tab of the Project Properties dialog (Project > Project Properties) lets you enter commands
that are executed when the project is activated. This information is stored per project, not per
configuration. This tab is unavailable for extension-based projects.
To enter a new command to be opened for a project, simply type the command(s) in the editor control
window. Each line should contain a command just as you would type it on the command line. You can set
environment variables in the concurrent build window with the set command. For example, the command
set xxx=yyy sets the environment variable xxx to the value yyy. This automatically supports different
UNIX shells. Use concur_command to send a command string to the concurrent build window, for
example: concur_command export name=value.

Language-Specific Build Methods
Build Methods for GNU C/C++
There are three build methods available for GNU C/C++. With these build options you will not need to
convert the current build methods to use the GNU debugger. You can select one of these build methods
when you create a new GNU C/C++ Wizard project:
•

Build without a makefile (dependencies automatically checked) - When you use the GNU C/
C++ Wizard and select this build option, no makefile is ever generated. Instead, our vsbuild utility
program determines what needs to be compiled dynamically. We recommend using this option
when you are not worried about how the build gets done. Make sure the project include directories
(Project > Project Properties, select the Directories Tab) are set up correctly so include files may
be found.

•

Build with a user-maintained makefile or custom build command - When you use the GNU C/
C++ Wizard and select this build option, no makefile is ever generated and by default the build
command is set to make. You can change the build command to anything you want using the
Project Properties dialog (Project > Project Properties, select the Tools Tab, select Build for the
tool name). Choose this option when you already have your own method for building the source.

•

Build with an auto-generated, auto-maintained makefile - When you use the GNU C/C++
Wizard and select this build option, a makefile is automatically generated and updated when files
are added to the project. We recommend using this option when you need a makefile and do not
want to use the built-in vsbuild utility. Make sure the project include directories (Project > Project
Properties, select the Directories Tab) are set up correctly so include files may be found. To start
a build from outside the application, execute the following command where make is the name of
the make program, Makefile is the name of the makefile, and ConfigName is the name of the
configuration: make -f Makefile CFG=ConfigName.

Build Methods for Xcode
When SlickEdit® opens an Xcode project, it creates a view of the project that is consistent with other
SlickEdit workspaces. This creates a few discrepancies between from the view of the project that Xcode
provides. The most noticeable difference is that the files in the project cannot be viewed in a single tree,
rather the files are always separated by the target that uses the file.
There are build methods available when using Xcode. To open an Xcode project, complete the following
steps:
1. From the user interface, click Project > Open Other Workspace > Xcode Project.
2. In the Directory window, select the .Xcode directory. This directory appears as a file inside the
Finder.
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3. From the File window, select the project.pbxproj file.
4. From the main menu, click Project > Set Active Project.
5. Select the project that you want to use.
6. Click Build > Set Active Configuration.
7. Select the style that you want.
8. Click Build > Build.
9. The project is then built, and you can work with your project.

Build Methods for Ant and NAnt
SlickEdit® supports Apache Ant XML build files and NAnt build files. Apache Ant is a popular make facility
used to build Java components. NAnt is a .NET build tool that is similar to Ant.
NOTE Ant build files must end with the .xml extension in order to be recognized as build files. NAnt
build files must end with the .build extension.
You must use SlickEdit projects for your Ant/NAnt files in order to access the commands that invoke build
file targets.
When you open an Ant XML or NAnt build file, SlickEdit automatically either opens the project if it already
exists, or creates a new project and adds the file to it.
•

To open an Ant XML file - From the main menu, click Project > Open Other Workspace > Ant
XML Build File, or use the workspace_open_ant command.

•

To open an NAnt build file - From the main menu, click Project > Open Other Workspace >
NAnt .build file, or use the workspace_open_nant command.

Alternately, you can manually create a project and add the build files or add the files to an existing project.
When adding build files to a project, they are scanned for callable targets. If any targets are found in the
file, the icon in the project tree is changed to the “bull’s eye” icon.
See Creating Projects and Adding and Removing Files for more information about creating projects and
adding files to them.

Invoking Ant or NAnt Targets
Once you have a project that contains Ant or NAnt files, you can execute Ant or NAnt targets. The SlickEdit
commands that invoke the build file targets are only available from the Build menu and the right-click
context menu of the tree in the Projects tool window.
To execute a single target, pick the target menu item. For example, for Ant, from the main menu, click
Build > Execute Ant Target, then navigate to the target. To specify arguments or execute multiple targets,
use the Select Multiple Targets menu item. For example, for Ant, from the main menu, click Build >
Execute Ant Target > Select Multiple Targets. Alternately, you can right-click on an Ant or NAnt project in
the Projects tool window and execute one target or multiple targets.

Setting Shortcuts for Build and Rebuild
To set up the Build menu items or Rebuild menu items or both to invoke a specific set of targets, first
select one of the target menu items:
•

178

For Ant XML files, from the main menu, click Build > Execute Ant Target > Select Multiple
Targets, and choose Ant XML File.
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•

For NAnt build files, click Build > Execute NAnt target > Select Multiple Targets, and choose
NAnt .build file.

Then, complete the following steps:
1. Check one or more targets and provide any additional arguments.
2. Check the Remember and use these settings for check box.
3. Select Build or Rebuild in the adjacent combo box.
4. Click OK.

Working with Build Errors
Viewing and Navigating Errors
Error markers (displayed as red X bitmaps) are placed on the lines of the errors in the editor windows after
a build or compile is completed. To clear these markers, fix the errors and rebuild. You can also clear the
markers by clicking Build > Clear All Error Markers or by using the clear_all_error_markers command.
Execute the next_error command (Ctrl+Shift+Down, or Build > Next Error) to place the cursor on the
line of the file containing the next error. Open the build window by clicking on the Build tab to view the
compiler’s error messages. You can use the cursor_error command (Alt+1, double-click, or Build > Go
to Error or Include) to set the next error starting search position and go to a specific error.
You can also use the cursor_error and next_error commands to process messages from the sgrep
program provided. For example:
1. Activate the concurrent build window (Project > Activate Build).
2. Type sgrep main *.c and press Enter.
3. Press Ctrl+Shift+Down to cursor through the located occurrences.
4. Press PgUp to move the cursor off the concurrent build window command prompt so you can use
the cursor_error command (Alt+1 or double-click) on a specific occurrence.

Listing Errors
To see a list of errors that have occurred during the current editing session, use the list_errors command.
The Error File dialog box will be displayed.
Move the cursor in the editor control to the error message you want to go to and click Go To Cursor Error
to view the source code.

Parsing Errors with Regular Expressions
SlickEdit® provides the capability to scan the Build window for errors and warnings (using Build > Next
Error and Build > Previous Error). You can also navigate from an error or warning to the corresponding
location in the source code (using Build > Go to Error or Include or by double-clicking on the error in the
Build window).
SlickEdit uses regular expressions to parse the contents of the Build window and retrieve the file name or
path, line number, column number, and error message. A set of default regular expressions are included
that can parse error messages from supported compilers like Visual Studio, GCC, and Java. For other
tools, you may have to write additional regular expressions.
Error parsing regular expressions are written using the SlickEdit regular expression syntax (see SlickEdit®
Regular Expressions). They are stored in the ErrorRE.xml file located in your configuration directory. If the
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file is deleted, SlickEdit will create a new one with the default values. Rather than modifying the XML by
hand, you can use the Options dialog to configure error parsing, creating new regular expressions or
managing the list of existing ones. See the following sections for more information:
•
•
•
•
•
•
•
•
•

Configuring Error Parsing
Enabling Expressions
Setting Priority
Adding New Categories
Adding New Expressions
Editing Expressions
Error Expression Groups
Sample: Creating a New Error Parsing Expression
Testing Expressions

Configuring Error Parsing
To configure error parsing, use the Configure Error Parsing option screen. It can be accessed from the
main menu by clicking Build > Configure Error Parsing, or by opening the Options dialog (Tools >
Options) and selecting Configure Error Parsing from the Tools category. You can also display the
screen with the configure_error_regex command.

The Categories list displays all the expression categories that are defined in the ErrorRE.xml
configuration file. Highlighting a category will show the individual expressions for that category.

Enabling Expressions
To enable or disable an expression, or a whole category of expressions, simply click the check box to the
left of the expression or category. If a category is unchecked (disabled), then the expressions are not used
to parse build output, regardless of their checked or unchecked status.
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Setting Priority
To optimize performance for your development needs, you may re-prioritize either expressions or whole
categories by using the blue Up and Down arrow buttons. The default category cannot be re-prioritized.

Adding New Categories
Click the green Plus button next to the category listing. The following prompt is shown.

Enter the name for your new category and click OK. Category names must be unique and the dialog will
prevent you from adding duplicate entries.

Adding New Expressions
You can add new expressions to any category. Highlight the category you want the new expression to be
under, then click the green Plus button to the right of the Expressions listing. The following dialog is
displayed.

Enter a name for your new expression. The regular expression must be authored using SlickEdit® Regular
Expression syntax. The arrow to the right of the entry field will display a menu of common regular
expression syntax constructs to assist you. A “starter” expression is provided for you, as well as some
sample error output lines. See the following sections on how to author and test your expression.
Once you have created and tested your new expression, click OK to save the expression. You must also
click OK when quitting the main configuration dialog to save your changes.
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Exclusions
Some of the error parsing expressions may match lines that you do not want recognized as errors. To
eliminate these “false positive” matches, define a new expression in the Exclusions category. The default
configuration file contains an expression to match the “Total Time” build output line that is generated by
SlickEdit®'s internal build system, vsbuild. Any new exclusion expressions you write should be very strict
to prevent real error lines from being skipped. You do not have to define match groups in the exclusion
expressions since they will not be used to extract file name and line number information.

Editing Expressions
To edit an existing expression, double-click the expression in the expression listing, or highlight the
expression and click the small Edit button to the right of the listing. This launches the same dialog that is
used to create a new expression.

Error Expression Groups
In order to navigate to the file that caused the build error or warning, the regular expression needs to be
able to identify the file name, and optionally the line and column number, as well as the error message.
This is accomplished by using four Tagged Expressions, also known as match groups. The following table
documents the match groups used to identify specific portions of an error message.
Group Number

Group Syntax

Purpose

0

{#0:p}

Retrieves the file name or file path.

1

{#1:i}

Retrieves the error line number.

2

{#2:i}

Retrieves the error column.

3

{#3}

Retrieves the error message text.

The expression for Group #3 can match any portion of the error message you like. The sample expression
{#3?+}$ is just matching all remaining characters up to the end of the line. The groups can occur in any
order in your expression. For example, if the build tool output places the file name, line, and column after
the error message, like the following hypothetical example:
Error E509: Bad format: found in /usr/tmp/file.x, line 23, column 13

then your expression might look something like the following:
^Error {#3?+} found in {#0:p},:bline:b{#1:i},:bcolumn:b{#2:i}$

Sample: Creating a New Error Parsing Expression
The steps below demonstrate creating a new regular expression to support error output from a Lint tool.
Below are some samples of the tool’s output.
Sample 1:
file.cpp (5) : Warning 200: Possible dereferencing of null pointer

Sample 2:
includes\file.h (17) : Warning 003: Macro not parenthesized

1. Create a new expression category, and name it “Lint”.
2. Highlight the newly created Lint category. The Expressions listing is empty.

182

SlickEdit® User Guide

BUILDING AND COMPILING

3. Create a new expression by clicking the New Expression (green Plus) button to the right of the
expression listing. Copy and paste the sample output lines into the Test Case area.
4. The first thing to match is the file name at the beginning of the line. The group number reserved for
the file is {#0}. SlickEdit® syntax for matching a file path is :p, and ^ represents the beginning of a
line. Therefore, enter the following in the Expression entry field: ^{#0:p}.
5. There is now one space, :b, followed by an integer, :i, enclosed in parentheses, \(\). The group
number reserved for the error line number is {#1}. Edit the expression to be: ^{#0:p}:b\({#1:i}\).
6. After the line number, there is a space, :b, a colon, \:, another space, and then the informative
message on the remainder of the line. To match any number of characters you can use ?+, and to
match the end of the line is $. The group number reserved for the output message is {#3}. Edit the
expression to be: ^{#0:p}:b\({#1:i}\):b\::b{#3?+}$
7. Now test the expression. Click the Validate button. You should see a pop-up message for each
line of sample output.
8. Click OK to save the new expression, and click OK on the main dialog to save your changes to the
configuration file.

Testing Expressions
Copy some sample error or warning output lines from your compiler or build tool, and enter them into the
Test Case area. Click the Validate button to validate the regular expression against the Test Case text
lines. If the regular expression syntax is invalid, then the expression text is colored red, and an error
message is displayed on the status line. If any of the lines in the Test Case area match the expression, a
message box displays the details of the match, like the following sample.

This pop-up displays the line of the matched test case and value for each of the four tagged expression
groups.
You may also want to use the Regex Evaluator tool window to test your expressions. From the main menu
click Tools > Regex Evaluator. Be sure to select the SlickEdit® syntax option when authoring expressions
for error parsing. For more information on the Regex Evaluator tool window, see The Regex Evaluator.
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Running and Debugging
SlickEdit® provides debugging capabilities when working in GNU C/C++, Java, and CLR programs, using
GDB version 6.7.1. You can download this version from www.slickedit.com/gdb. Other programs will result
in SlickEdit launching an external debugger.
NOTE The GDB shipped with SlickEdit on Windows is based on Cygwin. If you don’t want to use
Cygwin for GDB, you can download and install the MinGW-based version of GDB from
www.mingw.org/download.shtml. This version of GDB is known to work with SlickEdit and does not
depend on cygwin1.dll. Use the Configurations tab on the Debugger Options dialog (Debug >
Debugger Options or debug_props command) to make it the default native GDB debugger
configuration.

Running a Program
To run a program, complete the following steps:
1. From the main menu, click Build > Execute.
2. If there is more than one main program you are prompted to select the one to run.

Debugging
Use one of the following methods for debugging your code. From the main menu, select Debug and then
one of the following options:
•

Start executes the program and will stop when a breakpoint is reached.

•

Step Into places you on the first executable line of the program.

•

Restart stops the current debugger session if necessary and then places you on the first
executable line of the program (like Step Into).

•

Run to Cursor will execute the program and will stop when the line under the cursor is reached.

Additional debug operations can be accessed through the Debug toolbar (View > Toolbars > Debug).

Mixed Mode View in Debugger
When debugging, you can view your source code with the disassembled code displayed between each
line of source. In this mode you can step execution at the assembly language level for greater control over
debugging. The buffer is changed to read-only so that the SlickEdit® product can maintain synchronization
between source and disassembled code. To view mixed mode, use the Debug toolbar (View > Toolbars >
Debug) and click the button Toggle Display of Disassembly.

Debug Key Bindings
The table below shows the key bindings that are available for Debug functions.
Key

Function

F5

Start/continue debugging

Shift+F5

Stop debugging
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Ctrl+Shift+F5

Restart debugging

F9

Toggle breakpoint

Ctrl+F9

Toggle breakpoint enable

Ctrl+Shift+F9

Clear all breakpoints

F10

Step over

F11

Step into

Ctrl+F10

Run to cursor

Alt+* (on the numeric keypad)

Show next statement

Ctrl+Alt+B or Alt+F9

Activate breakpoints window

Alt+3 or Ctrl+Alt+W

Activate watch window

Alt+4 or Ctrl+Alt+V

Activate variables window

Alt+7 or Ctrl+Alt+C

Activate call stack

Ctrl+Alt+H

Activate threads window

Multiple Session Debugging
Multiple session debugging provides the ability to start more than one debugging session within a single
instance of SlickEdit®. You can have one session debugging using GDB, and one using Java at the same
time.
To create an additional debugger session, use the command debug_create_new_session, or complete
the following steps:
1. From the main menu, click Build > Debug.
2. From the Debug toolbar, select Add a new Debug selection.
NOTE If you are using Java, you can only attach to remote JVM.

Named Sessions
The main debugging session always acquires the name of the current project. (Additional sessions can be
created by typing debug_new_create_session.) This name is to be numeric or derived from the
executable name. The setup information and invocation information for each named session are stored in
the workspace history file (.vpwhist). When you create a new session, you can reuse a named session to
save time setting up a remote session. You must also confirm the process ID with each session.
A named session can be associated with a project in such a way that it will always be started when the
project is debugged. The named session can be debugged using the Create New dialog.
If you detach from the main session, all sessions are stopped and you exit the debugging mode. If you
detach from any other session, it simply detaches and control is assumed by another session.

Attaching to a Running Process (GNU C++ only)
To attach to a running process, complete the following steps:
1. Click Debug > Attach Debugger > Attach to Running Process, then select a process to debug.
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2. Enter the path to the executable (to pick up debug symbols).
3. Click OK.
To detach from a running process, click Debug > Attach Debugger > Detach from Process.

Attaching to a Remote Process (GNU C++ only)
To attach to a remote GDB server or GDB stub process, complete the following steps:
1. Click Debug > Attach Debugger > Attach to Remote Process.
2. Enter the path to the executable (to pick up debug symbols).
3. Choose the attach method (socket or device).
4. Select the Remote Options tab to adjust remote debugging options.
5. Click OK.
To detach from a remote debugging session, click Debug > Attach Debugger > Detach from Process.

Attaching to a Core File (GNU C++, UNIX only)
To attach to a core file, complete the following steps:
1. Click Debug > Attach Debugger > Analyze Core File.
2. Type the path to the core file.
3. Type the path to the executable (to pick up debug symbols).
4. Click OK.

Attaching to a Remote VM (Java only)
To attach to a remote VM, complete the following steps:
1. Start the remote VM with command arguments similar to the following example:
Java -Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,
suspend=y,address=8000 MainClass Arg1 Arg2

2. From the main menu, click Debug > Choose Attach to Remote VM.
To detach from a remote debugging session, click Debug > Detach from VM.

Setting Breakpoints
The quickest way to set or clear a breakpoint is to press F9. This toggles the breakpoint for the current line.
You can also set a breakpoint using the appropriate button on the Debug toolbar (View > Toolbars >
Debug).
A Breakpoints toolbar (Debug > Windows > Breakpoints) is also available that displays all of the
breakpoints and lets you easily add, remove, and activate breakpoints.

Setting Conditional Breakpoints
To set a conditional breakpoint, complete the following steps:
1. Set a breakpoint.
2. Select the Breakpoints tab on the Breakpoints toolbar.
3. Double-click on the breakpoint for which you want to set a conditional breakpoint.
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4. Set the Expression to be evaluated or the Number of times to skip before stopping.
5. Click OK.
6. Click Close.

Setting Java Exception Breakpoints
To set a breakpoint when an exception occurs, complete the following steps:
1. Select the Exceptions tab on the Breakpoint toolbar.
2. Click Add and select one or more exceptions from the list.
3. Click OK.
Once an exception breakpoint is added, double-click on it to display the exception properties dialog. This
dialog allows you to specify an expression, number of times to skip before stopping, and a specific thread.

Generate Debug
This feature supports C#, C++, Java, and Slick-C®. Place the cursor on a function name, then click Tools
> Generate Debug to generate a statement that dumps the name of the current function and the value of
the parameter(s) passed in. Place the cursor on a variable name, then click Tools > Generate Debug to
generate a statement that dumps the contents of that variable. The results are as follows:
•

In C#, this will generate a System.Diagnostics.Trace.WriteLine() statement.

•

In C++, this will generate a printf statement.

•

In Java, this will generate a System.out.println statement.

•

In Slick-C, this will generate a say statement.

Viewing Debugger Info and Setting Options
To view the properties of the underlying debugger system, including a general description retrieved from
the debugger, version number, run-time version, and debugger name, make sure you’re in debug mode,
then from the main menu, click Debug > Debugger Information (or use the debug_props command).
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Click the Options button to tune the run-time performance of the integrated debugger, examine the
properties of the underlying debugger system, set class filters, and/or control the directories searched for
source files. See Debugger Options for more information.

Debugger Tool Windows
The toolbars and tool windows that can be used during debugging are listed in the section Available
Toolbars and Tool Windows. These can be accessed from the menu items View > Toolbars or Debug >
Windows when the editor is in debug mode.
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Editing Features
This chapter contains the following topics:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Navigation
Symbol Browsing
Text Editing
Code Templates
Color Coding
Syntax Indent and SmartPaste®
Adaptive Formatting
Completions
Aliases
Syntax Expansion
Quick Brace/Unbrace
Dynamic Surround and Surround With
Bookmarks
Code Annotations
Message List
Commenting
Beautifying Code
Quick Refactoring
Viewing and Displaying
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Navigation
There are two types of navigation in SlickEdit®: Code Navigation, which provides in-depth symbol
navigation and structure matching, and Cursor Navigation, which pertains to more simple movements
within text and files.

Code Navigation
Some of the most powerful features in SlickEdit® are its code navigation methods, particularly Symbol
Navigation. These features allow you to navigate your code the way you think about it, rather than just as a
set of files. If you aren’t using SlickEdit’s code navigation features, you aren’t getting the most out of the
editor.

Symbol Navigation
Symbol Navigation allows you to jump from a symbol to its definition or to a reference with a single
keystroke. A pushed bookmark is set, allowing you to return to the symbol with another keystroke. You can
chain a series of these navigation operations together, creating a stack of locations. Then pop your way
back to the starting location.
To navigate between symbols use the following operations:
•

Go to Definition - To quickly move the cursor from a symbol to its definition, pushing a bookmark
in the process, press Ctrl+Dot. Alternatively, click Search > Go to Definition or use the push_tag
command.

•

Go to Reference - To create a list of references and optionally jump to the first one, pushing a
bookmark in the process, press Ctrl+/. Alternatively, click Search > Go to Reference or use the
push_ref command.

•

Pop Bookmark - To pop the bookmark and return to the previous location, press Ctrl+Comma.
Alternatively, click Search > Pop Bookmark or use the pop_bookmark command. See Pushed
Bookmarks for more information about working with bookmarks.

When you first call these operations, if a tag file does not exist for the current file, it will be built (see
Building Tag Files).
TIPS
•

Procs and prototypes - In C and C++, navigating from a symbol to its definition will prompt
you to select whether you want to go to the prototype or the function. You can tell SlickEdit®
to always go to one or the other by setting one of the options Go to Definition navigates to
symbol definition (proc) or Go to Definition navigates to symbol declaration (proto).
To set these options, from the main menu, click Tools > Options > Languages, expand
your language category and language, then select Context Tagging®. When the cursor is
in the prototype, pressing Ctrl+Dot will navigate to the function and vice versa. If you do not
set one of these options, you will be prompted with the Select Symbol Dialog the first time
you navigate from a symbol to its definition.

•

Auto-close visited files - SlickEdit can automatically close a visited file, one that was
opened through symbol navigation but not edited. See Automatically Closing Visited Files
for more information.
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Navigating Between Multiple Instances
If more than one instance of the definition or reference is found, the Select Symbol Dialog is displayed,
from which you can select the instance to navigate to. To go to the next occurrence, press Ctrl+G (Search
> Next Occurrence or find_next command). To go to the previous occurrence, press Ctrl+Shift+G
(Search > Previous Occurrence or find_prev command).
Alternatively, press Ctrl+Down (next_tag command) or Ctrl+Up (prev_tag command) to place the cursor
on the next or previous symbol definition.

Using the Find Symbol Tool Window
The Find Symbol Tool Window (Search > Find Symbol or gui_push_tag command) is used to locate
symbols (tags) which are declared or defined in your code. It allows you to search for symbols by name
using either a regular expression, substring, or fast prefix match. See Find Symbol Tool Window for
descriptions of the options that are available.

More Symbol Navigation Methods
There are several other methods for navigating to symbols:
•

The Symbols Tool Window shows the symbols for all tag files. Right-click in the tool window and
select Find Tag to search for a specific symbol. You can also use the cb_find command to find the
symbol under the cursor and display it in the Symbols tool window.

•

At the SlickEdit® command line, use the f command and completion keys (Space and ?) to enter
a tag name. For example, if tagging the C run-time library, type f str? on the command line for a
list of tag names starting with “str” (such as strcpy, strcmp, etc.).

•

To navigate to a Slick-C® symbol, you can use the fp command (a shortcut for find_proc). If
editing a Slick-C macro, then enter the push_tag command (Ctrl+Dot) to find the symbol at the
cursor. The push_tag command actually calls the find_proc command with the symbol name at
the cursor to perform the task.

Begin/End Structure Matching
Begin/End Structure Matching moves the cursor from the beginning of a code structure to the end, or vice
versa. This works for languages using curly braces “{ }”, “begin” and “end”, or any other defined begin/end
pairs.
To place the cursor on the opposite end of the structure when the cursor is on a begin or end keyword pair,
press Ctrl+] (find_matching_paren command or from the menu click Search > Go to Matching
Parenthesis). The find_matching_paren command supports matching parenthesis pairs { },[ ] and ( ).
TIP For Python, SlickEdit® supports the matching of the colon (:) token and the end of context. See
Begin/End Structure Matching for Python for more information.

Viewing and Defining Begin/End Pairs
Use the language-specific General options screen to view or define the begin/end pairs for any language.
To access this dialog, from the main menu, click Tools > Options > Languages, expand your language
category and language, then select General.
In the Begin/end pairs text field, specify the pairs in a format similar to a regular expression.
NOTE This text box is unavailable (dimmed) for languages that have special begin/end matching
built-in.
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The examples below illustrate the syntax for defining the begin/end pairs. The begin and end pair matching
option is case-sensitive by default. Append “;I” to ignore case.
Example 1
(begin),(case)|(end);|

The above begin/end pairs are for the Pascal language. The Pascal language requires a more
sophisticated expression. This expression indicates the keywords begin or case start a block and the
keyword end terminates the block. The , (comma) is used to specify multiple begins or multiple ends. The
| operator is used to separate begins from ends.
Example 2
(#ifdef),(#ifndef),(#if)|(#endif)

The above pairs are for the C language. The C language has the added complication that #if is a substring of #ifdef. Due to the implementation of begin/end matching, #ifdef must appear before #if.
More settings for begin/end pairs can be found on the [Language] Formatting Options screen (Tools >
Options > Languages > [LanguageCategory] > [Language]). See Language-Specific Formatting
Options for more information.

Setting the Paren Match Style
As you type a closing parenthesis, highlight and matching options are available. To specify these options,
from the main menu, click Tools > Options, expand Editing, then click General and set the value of the
Parenthesis matching style option.
The Highlight style option temporarily block-selects the text within the parenthesis pair. The Cursor to
Begin Pair style option temporarily places the cursor on the matching begin parenthesis.
Select Highlight matching blocks to automatically highlight the corresponding parenthesis, brace,
bracket, or begin/end word pairs under the cursor. To customize the highlighting color, from the main
menu, click Tools > Options > Appearance > Colors, and select the Block Matching screen element. To
adjust the delay in milliseconds before the highlighting is updated, go to Macro > Set Macro Variable and
modify the variable def_match_paren_idle. See Setting Colors for Screen Elements and Setting/
Changing Configuration Variables for more information.

Navigating in Statements and Tags
The following navigation commands are available for languages that support statement tagging:
•

next_tag/prev_tag - Places the cursor on the next/previous tag definition, skipping any tags
filtered out by the Defs tool window.

•

next_proc/prev_proc - Places the cursor on the next/previous function heading.

•

find_tag - Displays a list of tags in the Select Symbol Dialog, allowing you to pick the tag to which
you want to navigate.

•

goto_tag - Prompts for a procedure tag name and places the cursor on the definition of the
procedure name specified. This command is available in GNU Emacs emulation mode only.

•

end_tag - Places the cursor at the end of the current symbol definition. This is useful if you are in
the middle of a large function or class definition and you want to jump to the end of it. In a class
definition in C++, the end is where inline function definitions are usually stored.

•

end_proc - Moves the cursor to the end of the current procedure.

•

next_statement/prev_statement - Moves the cursor to the beginning of the next/previous
statement.
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•

begin_statement/end_statement - Places the cursor at the beginning/end of the current
statement.

•

next_sibling/prev_sibling - Moves the cursor to the beginning of the next/previous sibling. These
are similar to the next_statement/prev_statement commands except they stay at one level of
nesting.

•

goto_parent - Moves the cursor to the beginning of the enclosing statement or symbol scope
relative to the current cursor position.

•

begin_statement_block/end_statement_block - Moves the cursor to the beginning/end of the
current statement block.

Cursor Navigation
These cursor navigation methods pertain to simple cursor movement within files. We recommend creating
key bindings for commands that you use frequently (if a key binding doesn’t already exist by default). See
also Switching Between Buffers or Windows for information about navigating between buffers and editor
windows.

Navigating in Pages and Files
The following commands control cursor navigation in pages and files:
•

top_of_window/bottom_of_window (Ctrl+PgUp/Ctrl+PgDn) - Places the cursor at the top/
bottom of the current editor window.

•

top_of_buffer/bottom_of_buffer (Ctrl+Home/Ctrl+End) - The top_of_buffer command places
the cursor at the first line and first column of the current buffer. The bottom_of_buffer command
places the cursor at the end of the last line of the current buffer. If the option Preserve column on
top/bottom is enabled (Tools > Options > Editing > General), the cursor is placed at the first
line/last line of the buffer and the column position is unchanged.

TIP There is an option to make top_of_buffer/bottom_of_buffer push a bookmark, providing quick
navigation between the top/bottom of the buffer and the previous location. See Pushed Bookmark
Options for more information.
•

top_left_of_window/bottom_left_of_window - Places the cursor at the top left/bottom right of
the current editor window.

•

page_up/page_down (PgUp/PgDn) - Moves the cursor to the previous/next page of text.

•

page_left/page_right - Changes the left edge scroll position by half the window width to the left/
right. The cursor is moved half the window width to the left/right as well.

Navigating Between Words
To navigate between words, use the next_word (Ctrl+Right) and prev_word (Ctrl+Left) commands. The
next_word command moves the cursor to the beginning of the next word. The prev_word command
moves the cursor to the beginning of the previous word.
You can specify whether the cursor moves to the beginning or the end of the next/previous word. Click
Tools > Options > Editing > General, then set the Next word style to Begin or End. This affects both
next_word and prev_word commands.
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Navigating to a Specific Line
To view and place the cursor on a specific line number, from the main menu, click Search > Go to Line.
Enter the line number and click OK. Alternatively, you can use the goto_line command in the syntax
goto_line linenumber.

Navigating to an Offset
To seek to a byte offset in the current buffer, from the main menu click Search > Go to Offset, or use the
gui_seek command. This function is the same as the C lseek function. However, if you have opened the
file with tab expansion, the seek position on disk may be different.
When the Seek dialog appears, enter the position to seek for. You may specify a C syntax expression. In
addition, you may prefix the expression with a plus or minus sign (+ or -) to specify a relative seek position.
Some examples are:
•

0x10+10 - Seek to offset 26

•

+8+4 - Seek to current offset + 12

•

-8+4 - Seek to current offset - 12

Select the Decimal option to enter the seek position in decimal number format. Select the Hex option to
enter the seek position in hexadecimal number format. You can type an “x” as the first character in the
Position to seek for text box and this option will automatically be selected.

Navigating to URLs
SlickEdit® treats URLs in editor windows as hyperlinks, making them easy to identify and open in a Web
browser from within your code. By default, a string is interpreted as a URL if it begins with one of the
following URI schemes, or, URL types (including the colon and slashes):
•
•
•
•

file://
ftp://
http://
https://

URLs are underlined. You can navigate to a link by hovering over it with the mouse and using Ctrl+Click
(or Command+Click on the Mac). The link opens in a new Web browser window, or the current browser
window if one is already open. The file:// URI scheme is handled differently—see Handling File URLS
below.
When using the mouse to hover over an http:// link, click the green arrow to open the source code in
SlickEdit.

The URI Schemes node of the Options dialog lets you specify the recognized URI schemes, and makes it
easy to extend this feature. For example, you may want to add a mailto URI scheme so that e-mail URLs
are recognized. To access these options, from the main menu, click Tools > Options, expand Network &
Internet Options, then select URI Schemes. See URI Scheme Options for more information.
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Handling File URLS
Files can be designated using the file:// URI scheme. Depending on the file type, a file can be opened
in a browser, passed to an application for opening, or executed. How the file is handled depends on the
operating system and the settings in Tools > Options > Languages > File Extension Manager.
The File Extension Manager provides two settings to control this behavior:
•

Open Application - Specifies an application to open files with the selected extension.

•

Use file association - Overrides the application specified in Open Application and uses the
operating system to determine what application to use. This is only applicable to Microsoft
Windows operating systems.

If an application is specified in the Open Application field, the file will be passed to that application for
opening.
If Use file association is checked, the operating system is used to determine what application to use. This
is only applicable on Windows.
If both fields are left blank, SlickEdit® will use the operating system to determine what application to use.
This is the same as if you checked Use file association and is only applicable on Windows.
Runnable Files
A file:// URI scheme can be used to specify a runnable file, like a batch file, script file, or executable.
On Windows, the operating system is used to automatically identify runnable files and run them, unless
you have specified a value for Open Application.
On Linux, UNIX, or Mac you have to specify how to run a runnable file by specifying an application or
system command in the Open Application field. For example, on Linux you can run a Perl file by
specifying the path to the Perl interpreter in Open Application. You also need to include the escape
sequence denoting the file name, for example, /usr/bin/perl %f. The %f inserts the full path for the file
portion of the URL. If you want to run a binary file you would just specify put %f in the Open Application
field.

Other URI Schemes
You can add additional URI schemes to be treated as links (see URI Scheme Options). On Windows, the
operating system will determine how to handle the URL. For example, using ms-help:// will open the
associated link in MSDN Help. On all other platforms, the link will be sent to the browser.
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Symbol Browsing
SlickEdit® gives you the ability to browse and view symbols in your files or workspaces. Symbol browsing
relies on Context Tagging®, so symbols are updated immediately or in the background as you edit. There
are several tool windows that display information as you work to help you find what you need at exactly the
time you need it:
•
•
•
•
•
•
•
•

Class Tool Window
Current Context Tool Window
Defs Tool Window
Find Symbol Tool Window
Preview Tool Window
References Tool Window
Symbols Tool Window
Symbol Properties Tool Window

See also Symbol Navigation for information about how to navigate between symbols in files.

Class Tool Window
The Class tool window, docked as a tab on the left side of the editor by default, provides an outline view of
both the members of the current class as well as any visible inherited members. This tool window also
shows the inheritance hierarchy of the current class. This is useful for object-oriented programming
languages such as Java.
Display of the Class tool window can be toggled on/off by clicking View > Toolbars > Class or by using the
toggle_tbclass command. To display the tool window on demand, use the activate_tbclass command.
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If you are coding within a class, the top pane (hierarchy pane) of the tool window shows the base class
hierarchy for the current class. The bottom pane (members pane) shows all members of the current class,
as well as all members visible from inherited superclass(es) and implemented interface(s). The name of
the current class is displayed at the top of the tool window.
If you are not currently in a class (or enum or interface), the hierarchy pane is blank and the members pane
shows the symbols in the current file. The name of the current file is displayed at the top of the tool window.
Hover the mouse over the bitmap of any item in the hierarchy or members panes to see a tool tip that
shows the symbol’s signature and scope.
To show or hide the hierarchy pane, use the two buttons located at the top-right of the tool window. If the
hierarchy pane is hidden, the members pane is resized to take up the entire space of the window. Use the
size bar to resize either pane.
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Use the Up/Down buttons located to the left of the pane buttons to navigate up or down the class
hierarchy. The Up arrow button will allow you to navigate to a child class (derived class or subclass) of the
current class. The Down arrow allows you to navigate to a parent class (superclass or interface) of the
current class. When using these buttons to navigate through code, the active buffer will switch to the
destination class, and the hierarchy and members panes will update.
To jump to the definition of a class in the code, pushing a bookmark in the process, double-click on any
member or class. Left-click or press Ctrl+Comma to go back.

Filtering in the Hierarchy Pane
Right-click on a class in the hierarchy pane to display a list of filtering options. You can exclude entire
namespaces or packages, anything above a certain level in the hierarchy, and anything outside of the
current workspace. You can always include any class(es) you have excluded via the “Include” options.
By excluding a class or interface in the hierarchy view, the members of this class or interface are no longer
displayed in the members pane, but they are still visible in the hierarchy as gray text.
Select Show in Symbol Browser to jump to the class in the symbol browser.

Class Exclusion Manager
The Class Exclusion Manager, accessed by right-clicking on a class in the hierarchy pane, displays a list of
any currently excluded classes, interfaces, namespaces, and packages. Exclusions are kept on a perworkspace basis.

To add an item to the list, type the name in the Add Item To List text box, then press Enter. Click the
buttons to remove selected items or to clear the list.

Filtering and Sorting in the Members Pane
Right-click on a member in the members pane to access a list of filtering and sorting options as well as
options for code navigation and modification. The following options are available:
•

Quick Refactoring - Offers two Quick Refactorings: Rename and Modify Parameter List. See
Quick Refactoring for more information.
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•

Add Member Function, Add Member Variable, and Add Virtual Function - (C/C++ only) When
these options are selected for a class, you are prompted with a dialog to type a member function,
member variable, or virtual function to be added into the source code at the top of the current
class.

•

Organize imports - (Java only) Organizes import statements in Java files. See Organize Imports
for more information.

•

Go to Tag - Moves the cursor to the selected tag. See Symbol Navigation for more information.

•

References - Brings the References tool window into focus, displaying the references for the
symbol. See References Tool Window for more information.

•

Set Breakpoint - Sets a debugging breakpoint. See Setting Breakpoints for more information.

•

Show in Symbol Browser - Jumps to the member in the symbol browser. See Symbols Tool
Window for more information.

•

Increase/Decrease Listed Members Limit - Controls the number of members displayed in the
members pane. When this option is selected, the command line will prompt you for a variable
value. The default is 400.

•

Sort Classes By Hierarchy and Sort Classes By Name - These options toggle the display of
classes sorted either by hierarchy or alphabetically by name.

•

Sort Members By Line Number and Sort Members By Name - These options toggle the display
of members sorted either by line number or alphabetically by name.

•

Organize Members By Class - Groups the members in the members pane by their class (or
interface). When this option is selected, all “Sort” options are available. When this option is not
selected, visible members in this pane will not be grouped at all. They will instead be displayed in
one list, sorted by name.

•

Auto Expand All Top Level Classes - Expands all top level class nodes in the members pane
whenever the current class changes. The default behavior is to only auto-expand the node of the
current class.

•

Auto Expand All Structs/Enums/Inner Classes - Expands all struct, enum, and inner class
nodes displayed in the members pane whenever the content is refreshed. By default this option is
turned off, and these nodes are collapsed.

•

Quick Filters and Scope Filters - Quick filters allow you to display only certain items in the
members pane, such as functions, prototypes, etc. Scope filters allow you to display members
only in certain scopes, such as public or global, private, protected, etc.

Current Context Tool Window
Current Context displays the logical location of the cursor within your code. If it is within a class, it displays
the class name. If it is within a function, it displays the function name. If the function is within a class, it
displays the class and the function name.
By default, the tool window is docked in the top upper-right section of the editor. Display can be toggled on/
off by clicking View > Toolbars > Current Context or by using the toggle_context command. To display
the tool window on demand, use the activate_context command.
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Defs Tool Window
The Defs (Definitions) tool window contains the defs (definitions) browser, which provides an outline view
of symbols in the current file.
By default, the Defs tool window is docked as a tab on the left side of the editor. Display can be toggled on/
off by clicking View > Toolbars > Defs or by using the toggle_defs command. To display the tool window
on demand, use the activate_defs command.

The name of the file is displayed at the top of the tool window. Hover the mouse over the bitmap of any
symbol in the window to see a tool tip that shows the symbol’s signature and scope.
To jump to the definition of the symbol in the code, pushing a bookmark in the process, double-click on any
symbol. Press Ctrl+Comma to go back.

Defs Tool Window Options
Right-click on any symbol in the Defs tool window to access the following options:
•

Quick Refactoring - Offers two Quick Refactorings: Rename and Modify Parameter List. See
Quick Refactoring for more information.

•

Set Breakpoint - Sets a debugging breakpoint. See Setting Breakpoints for more information.

•

Sort by Function Name and Sort by Line Number - These options toggle the display of symbols
sorted either alphabetically by function name or by line number.
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•

Show Hierarchy - Organizes symbols by their scope within the current file. Clear this option to
display all of the symbols in one flat list.

•

Show Statements - (C/C++, Java, Visual Basic only) This option controls the Statement Level
Tagging feature. When selected, the tool window shows an outline of all statements in each
function within the current file. This allows you to see a primitive function flowchart or to navigate to
a specific statement within a function.

•

Display Files - Displays the names of the files that are open in the editor. Clear this option to only
show symbols in the current file, allowing you to use the window as a true outline view.

•

Auto Expand - Automatically expands all levels within the current file. If this option is cleared, you
will need to click to expand items manually.

•

Expand All - Expands all symbols or levels in the current file.

•

Expand 1 Level - Expands everything one level below the current symbol.

•

Expand 2 Levels - Expands everything two levels below the current symbol.

•

Display Non-taggable Files - Displays files that are open in the editor that are not taggable, such
as text files.

•

Properties - Displays the Symbol Properties Tool Window, showing the properties of the selected
item, such as visibility, whether it's static or final, etc. Note that you cannot use this window to
change the properties.

•

Arguments - Displays the return type and arguments for functions/methods in the Symbol
Properties Tool Window.

•

References - Displays the list of references for the selected symbol, just as if you pressed Ctrl+/
in the editor window. See Symbol Navigation for more information.

•

Show Call Tree - Displays a tree of symbols used by the selected symbol, for example, other
functions called by the current function. See Viewing Symbol Uses with the Calling Tree for more
information.

•

Contents - Displays the following menu of save and print operations for the defs browser tree:

•

o

Save - Writes the items displayed in the defs browser to a text file, prompting you for a file
name and directory location. The text file will then be displayed in the editor.

o

Print - Displays the Print dialog, where you can configure options for printing the tree.

o

Save Subtree and Print Subtree - These options function similarly to the above except they
apply to the selected subtree.

Quick filters, Scope, Functions, Variables, Data Types, Statements, and Others - All of these
items are for filtering the data displayed in the Defs tool window.

Find Symbol Tool Window
The Find Symbol tool window (Search > Find Symbol or gui_push_tag command) is used to locate
symbols in your code. It allows you to search for symbols by name using either a regular expression,
Substring, or fast prefix match.
Searching for a symbol is faster than a normal text search because it is executed against the Context
Tagging® database, rather than searching through your source files. Find Symbol also avoids false hits in
comments or string literals. Though Syntax-Driven Searching in the regular Find and Replace Tool Window
provides this same capability, it cannot match the speed of Find Symbol.
See Find Symbol Tool Window for information about the options that are available on the tool window.
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Preview Tool Window
The Preview tool window provides a portal for viewing information in other files without having to open
them in the editor. It automatically shows this information when you are working with certain features. See
Information Displayed in the Preview Window for more information.
By default, the Preview window is docked as a tab at the bottom of the editor. Display can be toggled on/off
by clicking View > Toolbars > Preview or by using the toggle_preview command. To display the tool
window on demand, use the activate_preview command.

The Preview tool window contains the following components:
•

•

Symbol list - This is the list of all symbols which are currently being previewed. In most cases, this
is a single symbol. In some cases, such as for the symbol under the cursor, multiple matches are
shown, such as the definition and declaration of a symbol. You can do a few things with the symbol
list:
o

Hover the mouse over the bitmap of any item to see a tool tip that shows the symbol’s
signature and scope.

o

Click on any symbol to preview that specific symbol or it's comments.

o

Right-click to adjust symbol search filtering options.

o

Double-click to jump to a symbol. Press Ctrl+Comma to go back.

o

You can create key bindings for the preview_next and/or preview_prev commands in order
to scroll through the items in the symbol list without using your mouse. See Creating Bindings
for more information.

File and line label - Shows the file name and line number of the selected symbol.
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•

Documentation comments pane - This pane displays any existing comments for the symbol that
is selected in the symbol list. If the comments are in Javadoc or XMLdoc format, they will be
formatted in HTML. You can single-click on hypertext links within the comments to follow the links,
such as “See also” sections.

•

Editor preview window - Shows the contents of the actual source file at the line number of the
selected symbol. Double-click to open the code in the editor. Right-click to adjust symbol search
filtering options.

•

Size bars - Use the size bars to adjust the width of the symbol list and/or the height of the
documentation comments area.

•

Buttons - The following buttons are found along the right edge of the Preview window:
o

Back and Forward - Allow you to navigate among the hypertext links that you have traversed
in the documentation comments.

o

Go to definition - Opens the selected symbol in the editor.

o

Go to reference - Finds references to the selected symbol.

o

Show in symbol browser - Locates the selected symbol in the Symbols Tool Window.

o

Manage Tag Files - Opens the Context Tagging® - Tag Files Dialog for building and
maintaining tag files for indexing symbol information.

Information Displayed in the Preview Window
The table below describes what the Preview window displays under different circumstances.
Editor Element in Use
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Preview Window Display

Any source file open in the editor

The Preview window shows the definition or
declaration of the symbol under the cursor, along
with the symbol’s documentation comments, if
any exist.

The Defs, Symbols, Class, Current Context,
and Find Symbol tool windows

Single-click on a symbol and the Preview window
displays the selected symbol and its
documentation comments, if any exist. See Defs
Tool Window, Symbols Tool Window, Class Tool
Window, Current Context Tool Window, and Find
Symbol Tool Window for more information.

Call Tree dialog and References tool window

The Preview window shows the location of the
symbol references or use.

The Base Classes and Derived Classes
symbol browser dialogs

Single-click on a symbol and the Preview window
displays the selected symbol and its
documentation comments, if any exist. See
Symbols Tool Window for more information.

The Bookmarks tool window

Single-click on a bookmark and the Preview
window displays the location of the bookmark.
See Bookmarks Tool Window for more
information.

SlickEdit® User Guide

SYMBOL BROWSING

Editor Element in Use

Preview Window Display

The Breakpoints tool window

Single-click on a breakpoint and the Preview
window displays the location of the breakpoint.
See Setting Breakpoints for more information.

The Message List tool window

Single-click on a message and the Preview
window displays the message type, and the
location of the message in the source code. See
Message List Tool Window for more information.

The Search Results tool window

Single-click on a line in the Search Results
window and the Preview window displays the
location of the selected search result. See Search
Results Output for more information.

List Members and Auto-Complete results

Cursor up or down through the list of items in
auto-complete or list-members results and the
Preview window displays the location of the
selected symbol and its documentation
comments, if any exist. See List Members and
Auto-Complete for more information.

References Tool Window
The References tool window displays the list of symbol references (uses) found the last time that you used
the Go to Reference feature (Ctrl+/ or push_ref command—see Symbol Navigation for more information).
By default, the References window is docked as a tab at the bottom of the editor. Display can be toggled
on/off by clicking View > Toolbars > References or by using the toggle_refs command. To display the
tool window on demand, use the activate_refs command.

SlickEdit® User Guide

207

SYMBOL BROWSING

The References tool window automatically comes into focus when you use the Go to Reference feature or
when you select References from the right-click menu of the Class, Defs, or Symbols tool window.
NOTE Typically, you only want to view references that occur in project files, and not run-time
libraries, which can be very large. For this reason, references are not generated automatically for
run-time library tag files. If you want to view references that occur in a run-time library tag file, you
need to generate references for the tag file. To do this, display the Context Tagging® - Tag Files
Dialog (Tools > Tag Files or gui_make_tags command), choose the tag file, right-click to display
the context menu, and select Generate References. See Tagging Run-Time Libraries for more
information.
The left pane displays a tree view of the files and locations that contain the symbol references. Hover the
mouse over the bitmap of a symbol to see a tool tip that shows the symbol’s signature and scope. To jump
to the location of a symbol reference in the code, pushing a bookmark in the process, double-click on it.
Press Ctrl+Comma to go back.
The right pane displays a preview of that location in the source. The number of instances found and the file
name and line number are displayed at the top. Use the size bar to resize either pane.
Use the buttons located at the top right corner of the tool window to toggle the preview pane on and off.
Because source can also be previewed in the Preview Tool Window, you may find it more efficient to use
the References window with the preview pane off.

References Tool Window Options
Right-click on a symbol or file in the left pane of the References window to display the following options:
•

•

Contents - Displays the following menu of save and print operations for the references browser
tree:
o

Save - Writes the items displayed in the references browser to a text file, prompting you for a
file name and directory location. The text file will then be displayed in the editor.

o

Print - Displays the Print dialog, where you can configure options for printing the tree.

o

Save Subtree and Print Subtree - These options function similarly to the above except they
apply to the selected subtree.

Quick filters, Scope, Functions, Variables, Data Types, Statements, and Others - All of these
items are for filtering the data displayed in the References tool window.

Symbols Tool Window
The Symbols tool window contains the symbol browser, which lists symbols from all of the tag files.
By default, the Symbols tool window is docked as a tab on the left side of the editor. Display can be toggled
on/off by clicking View > Toolbars > Symbols or by using the toggle_symbols command. To display the
tool window on demand, use the activate_symbols command.
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The top part of the window contains an option and combo boxes that are used for filtering. The bottom part
of the window lists the symbols grouped by category. Symbols in your workspace are listed in the top group
labeled “Workspace.” The rest of the symbols are grouped by language or compiler.
Hover the mouse over the bitmap of a symbol to see a tool tip that shows the symbol’s signature and
scope. To jump to the definition of a symbol in the code, pushing a bookmark in the process, double-click
on any symbol. Press Ctrl+Comma to go back.

Filtering Symbols in the Symbols Tool Window
The symbols listed in the symbol browser can be filtered using the Class and Member combo boxes. The
Class combo box filters the items listed under the Classes folder. The Member combo box filters the items
listed under any displayed classes or under any of the other folders, like Global Variables, Static Variables,
Defines, etc. Enter multiple words in either combo box to search for items containing either word.
For example:
•

Enter person into the Class combo box to find all classes containing the word “person”.

•

Enter person manager into the Member combo box to find all members, variables, etc. containing
the word “person” or “manager”.

NOTES
• The filters are case-sensitive, so be sure to type the values in the same case.
• The items listed under the Classes folder are global classes that are not part of a
namespace or package.
To clear the filters and see all items again, select the Show all tags option.
For non-object-oriented languages, use the Member combo box to search, since there are no classes. You
can hide the combo boxes to save space by right-clicking and selecting Filters, then unchecking the
corresponding check box.
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Symbols Tool Window Options
Right-click on a symbol in the Symbols tool window to access the following additional filtering options as
well as code management options:
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•

Go to Definition - Moves the cursor to the symbol’s definition (proc). See Symbol Navigation for
more information.

•

Go to Declaration - Moves the cursor to the symbol’s declaration (proto). See Symbol Navigation
for more information.

•

Quick Refactoring - Offers two Quick Refactorings: Rename and Modify Parameter List. See
Quick Refactoring for more information.

•

Organize imports - (Java only) Organizes import statements in Java files. See Organize Imports
for more information.

•

Set Breakpoint - Sets a debugging breakpoint. See Setting Breakpoints for more information.

•

Find Tag - Searches for symbols and displays them in the symbol browser. Note that the Find
Symbol tool window also provides this functionality.

•

Manage Tag Files - Displays the Context Tagging® - Tag Files Dialog for use in managing your
tag files.

•

Expand and Collapse options - Expands/collapses symbols as specified.

•

Sort by - Sorts symbols displayed by tag name, line number, or containers to top, which puts
classes, structs, etc. at the top of the list.

•

Filters - Filter by class or member, or select Filtering Options to display the Symbol Browser
Filter Options dialog. See Symbol Browser Filter Options for information on the available options.

•

Contents - Displays the following menu of save and print operations for the symbol browser tree:
o

Save - Writes the items displayed in the symbol browser to a text file, prompting you for a file
name and directory location. The text file will then be displayed in the editor.

o

Print - Displays the Print dialog, where you can configure options for printing the tree.

o

Save Subtree and Print Subtree - These options function similarly to the above except they
apply to the selected subtree.

•

Base Classes - Displays the Base Classes dialog, which shows a list of base classes for the
selected class on the left with the list of that class’s members on the right. Base classes are
displayed in a tree view, allowing you to explore up the inheritance hierarchy. See Viewing Base
and Derived Classes for more information. Note that the Class Tool Window provides this same
functionality.

•

Derived Classes - Displays the Derived Classes dialog, which works the same as above but for
derived classes. See Viewing Base and Derived Classes for more information.

•

Properties - Displays the Symbol Properties Tool Window, showing the properties of the selected
item, such as visibility, whether it's static or final, etc. Note that this window is read-only, so you
can’t use it to change the properties.

•

Arguments - Displays the return type and arguments for functions/methods in the Symbol
Properties Tool Window.

•

References - Displays the list of references for the selected symbol in the References Tool
Window, just as if you pressed Ctrl+/ in the editor window. See Symbol Navigation for more
information.
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•

Calls/Uses - Displays a tree of symbols that are used by this symbol or called by this function. See
Viewing Symbol Uses with the Calling Tree for more information.

Viewing Symbol Uses with the Calling Tree
View symbol uses to see what symbols (variables, functions, methods, classes, etc.) are used by a specific
function or method.
To view the symbols that a particular function or method uses, first create a project or open an existing
project. Then from the Symbols tool window, right-click on the desired function or method and select Calls
or uses. The Symbol Uses/Calling Tree dialog will be displayed.
TIP You can also access the Symbol Uses/Calling Tree from within the Defs Tool Window by rightclicking on a symbol and selecting Show Call Tree.

Right-click in this tree to display/modify the symbol filters. Items in the tree can be expanded to view uses
recursively. Double-click or press the spacebar on an item in the tree list to go to an item. Double-click and
Space are the same except when the item is a prototype that has a corresponding code section. Doubleclicking will then go to the prototype’s corresponding code section.
If the focus is in the Symbol Uses/Calling Tree dialog, the selected item will be shown in the Preview Tool
Window tool window, just as it is in the Symbols Tool Window.
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Viewing Base and Derived Classes
To see what classes are inherited by a particular class, right-click on the class in the Symbols tool window
and select Base Classes. To see what classes are derived from a particular class, right-click on the class
in the Symbols tool window and select Derived Classes. Both dialogs have the same interface.

The left pane of each dialog contains a tree showing the class inheritance hierarchy (the class list). The
right pane shows a list of the members of the selected class (the member list).
If the focus is in the class list, the selected class will be displayed in the member list, if it can be resolved. If
the focus is in the member list, the selected item will be shown in the Preview window, and is the name as
it appears within the class definition.
To jump to the symbol in the code, pushing a bookmark in the process, double-click on a symbol in either
pane. Press Ctrl+Comma to go back. Right-click on a symbol for filtering options.

Symbol Browser Filter Options
To access symbol browser filter options, right-click in the Symbols tool window and click Filters > Filtering
Options.
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Each option has three states: If the option is selected, only the specified items will be displayed. If the
option is cleared, the specified item will not be displayed. If the option is in a neutral state, the item will not
be considered in the filter.
The following options are available:
•

•

Class Members
o

Public - When selected, public members are displayed.

o

Protected - When selected, protected members are displayed.

o

Private - When selected, private members are displayed.

o

Package - (Java only) When selected, package members are displayed. Java members have
package scope if they do not specify public, protected, or private.

o

Inherited - When selected, only inherited members that this class can access are displayed.
When cleared, only members of this class are displayed.

o

Preprocessed - When selected, only members expanded by pre-processing are displayed.
This is specifically useful for MFC classes. When cleared, only non-preprocess members
displayed.

Declarations
o

Template - (C++ only) When selected, only template classes are displayed. When cleared,
only non-template classes are displayed.
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o

Const - (C++ only) When selected, only methods which do not modify members (method1()
const) are displayed. When cleared, only non-const methods are displayed.
Use the Symbol Properties Tool Window (right-click in the Symbols tool window and choose
Arguments, or from the main menu click View > Toolbars > Symbol Properties) to view
other const information for declarations (for example, int const * const *pcpcvariable;).

•

•

•
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o

Final - (Java only) When selected, only final members are displayed. When cleared, only nonfinal members are displayed.

o

Volatile - (C++ only) When selected, only volatile method members (method1() volatile) are
displayed. When cleared, only non-volatile members are displayed.

o

Synchronized - (Java only) When selected, only synchronized members are displayed. When
cleared, only non-synchronized members are displayed.

o

Extern - When selected, only identifiers defined explicitly using the extern keyword are
displayed. When cleared, only identifiers defined which do not explicitly use the extern
keyword are displayed.

o

Anonymous - When selected, only class names which are automatically generated by
Context Tagging® are displayed. When cleared, only explicitly named classes are displayed.

Functions/Methods
o

Inline - When selected, inline functions or methods are displayed.

o

Constructors - When selected, constructors are displayed.

o

Operators - When selected, overloaded operators are displayed.

o

Abstract - When selected, only abstract methods are displayed. When cleared, only nonabstract methods are displayed.

o

Virtual - When selected, only virtual methods are displayed. When cleared, only non-virtual
methods are displayed. All non-static Java methods are implicitly virtual.

o

Static (class methods) - When selected, only static methods are displayed. When cleared,
only non-static methods are displayed.

o

Native - When selected, only methods explicitly defined with the native keyword are
displayed. When cleared, only non-native methods are displayed.

Data Members
o

Show data only - When selected, only data members are displayed. When cleared, only
methods are displayed.

o

Static (class data) - When selected, only static data members are displayed. When cleared,
only non-static data members are displayed.

o

Transient - (Java only) When selected, only transient data members are displayed. When
cleared, only non-transient data members are displayed.

Display or Hide
o

Class Filter - When selected, the class filter is displayed in the Symbols tool window.

o

Member Filter - When selected, the member filter is displayed in the Symbols tool window.
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Symbol Properties Tool Window
The Symbol Properties tool window displays detailed information (properties and arguments) for the
symbol at the cursor location. Note that this window is read-only, so you can’t use it to change the
properties.
Display can be toggled on/off by clicking View > Toolbars > Symbol Properties. To display the tool
window on demand, right-click on a symbol in the Symbols tool window and select Properties or
Arguments, or use the activate_tag_properties_toolbar command.
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Text Editing
This section includes the following topics:
•
•
•
•
•

Overview
Selections
Basic Editing
Clipboards
Advanced Editing

Overview
SlickEdit® provides familiar operations for selecting, copying, moving, and operating on text, with
enhanced capabilities to meet the needs of developers.
The available editing features depend on the current emulation. Different editors provide different
capabilities, and SlickEdit attempts to match these features in each emulation. For example, the Brief
emulation provides a brief_iselect_char command that will start an inclusive character selection. This is
an operation familiar to Brief users that the other emulations don’t necessarily provide. However, CUA is
the default emulation mode for SlickEdit, so the operations described in this section are based on that
mode. See Emulations for more information about emulation modes.
In addition to the basic and advanced editing features described in this section, SlickEdit provides many
more text editing-related features that can be managed on a per-language basis. See topics in the Editing
Features chapter for information.

SlickEdit® and Text Selections
Many editing operations are performed on selected text, so you need to know how selections work in
SlickEdit in order to gain the power of its editing features. There are several types of selections, and some
are handled differently than others regarding operations and features. In particular, SlickEdit handles line
selections differently than most other editors. See Selections for more information.

SlickEdit® Clipboards
Most text editing operations involve clipboards. Clipboards in SlickEdit are internal to the editor and separate from the system clipboard provided by the operating system. While most operating systems only allow
one clipboard at a time, SlickEdit, by default, keeps a stack of the 50 most recently used clipboards. You
can see a list of your clipboards by using the Clipboards tool window (Ctrl+Shift+V, Edit > List Clipboards or list_clipboards command). See Clipboards for more information.

Insert/Replace Editing Mode
By default, SlickEdit® starts in Insert mode, which means text that you type is inserted at the cursor. When
the editor is in Replace mode, text is typed over the subsequent characters, essentially replacing text as
you type. The Insert or Replace editing mode is indicated in the status line of the editor (Ins or Rep). To
toggle the editing mode between Insert and Replace, click on the indicator, press the Insert key, or use the
insert_toggle command. To change the default start mode, from the main menu, click Tools > Options,
expand Editing and click General, then change the value of the Start mode option.
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Improve Your Editing Efficiency
The subsequent sections describe many editing commands. If a command you like to use isn’t bound to a
key or key sequence already, it’s a good practice to give it a key binding for quicker keyboard access. See
Creating Bindings for more information.
If you frequently use multiple text editing operations in succession, record the steps as a macro and bind it
to a key to save time in the future. See Recording a Macro for more information.
All editing features are not necessarily documented here, nor are all commands documented for each
feature. For example, in a subsequent section, common Cut operations are described, but more
commands are also available. Usually these are emulation-specific. A good way to discover related
commands is to type a portion of the command into the Search by command box on the Key Bindings
option screen (Tools > Options > Key Bindings). For example, type “cut” in this box, and the list of
Commands is filtered to show only those with that contain the text “cut”. Now you can see that some
additional Cut commands are append_next_cut and cut_level, two features of the GNU Emacs
emulation.

Selections
Most applications let you select text and perform operations on the selected text, such as Cut, Copy, and
Move. SlickEdit® offers three types of selections: character, line, and block. Each selection type provides
different capabilities for different editing situations—and easy access.
Selected text is rendered with a shaded background. You can change the color of the shading by
modifying the Background color of the Selection screen element (Tools > Options > Appearance >
Color). See Setting Colors for Screen Elements for more information.
The following topics are described below:
•
•
•
•
•

Selection Types
Selection Styles
Selection Indicator
Cycling Through Selections
Operating on Selected Text

Selection Types
There are three selection types in SlickEdit®: character, line, and block. The following table shows a
summary of each type and some methods for creating the selection. Each type is explained in more detail
below.
Selection Type
Character selection
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Description

Creation Methods

This is created when one or
more individual characters are
selected. This is also known
as a “char” selection.

Use the mouse to drag or use
the select_char command
(F8 or Edit > Select > Char).
See also Character
Selections.
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Selection Type

Description

Creation Methods

Line selection

This is created when one or
more whole lines are selected
as lines. You can select all of
the characters on a line and
still have a character
selection. The selection type
depends on how the selection
was created.

Triple-click within a line or use
the select_line command
(Ctrl+L or Edit > Select >
Line). For multiple lines, drag
in the left margin area of the
edit window (when the mouse
pointer changes to point right).
See also Line Selections.

Block selection

This is created when columns
of text are selected, also
known as a “column
selection”.

Right-click and drag or use the
select_block command
(Ctrl+B or Edit > Select >
Block). See also Block
Selections.

Character Selections
Character selections (also called “char” selections) are used to select words, parts of a line, or a range of
text between a starting location and an ending location. To create a character selection, use any of the
following methods:
•

Use the mouse to click and drag.

•

Use the select_char command (F8 or Edit > Select > Char), then use the arrow keys to extend
the selection, or use the mouse to click at the end of the selection.

•

Press and hold the Shift key with any navigation key. See Starting/Extending a Character
Selection below for examples.

You can also create character selections on words:
•

To select the whole word under the cursor, double-click on the word or use the
select_whole_word command (Edit > Select > Word).

•

To select from the cursor to the end of the current word or the next word, use the select_word
command.

When viewing a list of clipboards, character selection types are indicated with the text “CHAR” (see
Viewing and Inserting Clipboards for more information).
Starting/Extending a Character Selection
You can start or extend a character selection with Shift key shortcuts, described in the table below. For
example, press Shift+Home to create a character selection from the cursor to the beginning of the line.
Press Shift+End to create a selection from the cursor to the end of the line. You can also use
Ctrl+Shift+Home to create a character selection from the cursor to the top of the file, or Ctrl+Shift+End to
create a selection from the cursor to the end of the file.
Note that these shortcuts are based on the default CUA emulation.
Shortcut for Extending a Char
Selection

Description

Shift+Right

Start or extend selection to right.

Shift+Left

Start or extend selection to left.
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Shortcut for Extending a Char
Selection

Description

Shift+Up

Start or extend selection up one line.

Shift+Down

Start or extend selection down one line.

Shift+PgUp

Start or extend selection up one page.

Shift+PgDn

Start or extend selection down one page.

Ctrl+Shift+Home

Start or extend selection to top of buffer.

Ctrl+Shift+End

Start or extend selection to bottom of buffer.

Line Selections
A line selection is created when one or more complete lines are selected (partially selected lines are
treated as character selections).
SlickEdit® treats line selections very differently from character selections. A line selection can only be
inserted before or after another line of code. That's because a line of code is a meaningful unit of
functionality in most languages, and it would never be inserted inside another line of code. Handling line
selections in this manner makes it faster to copy and paste lines of code.
Line selections are pasted before or after the current line, depending on your Line insert style setting
(Tools > Options > Editing > General). Furthermore, line selections work with SmartPaste®, which
reindents inserted lines according to the surrounding code. See Inserting Lines for more information.
To select a line, use one of the following methods:
•

Use the mouse to triple-click within a line, or to select multiple lines, drag in the left margin area of
the edit window (when the mouse pointer changes to point right).

•

Use the select_line command (Ctrl+L or Edit > Select > Line). This selects the current line, or,
you can use the arrow keys to extend the selection to include more lines (or click with the mouse
on the last line of the selection).

The following operations are also treated as line selections:
•

To select the current code block (an entire block statement such as if, loop, switch, etc.), use the
select_code_block command (Edit > Select > Code Block).

•

To select the current procedure/function, including the function heading, use the select_proc
command (Edit > Select > Procedure).

•

To select the entire buffer, use the select_all command (Ctrl+A or Edit > Select > All).

When viewing a list of clipboards, line selection types are indicated with the text “LINE” (see Viewing and
Inserting Clipboards for more information).

Block Selections
Block selections, also known as column selections, are used to process columns of text. To create a block
selection, use any of the following methods:
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•

Use the mouse to right-click and drag.

•

Use the select_block command (Ctrl+B or Edit > Select > Block), then use the arrow keys to
extend the selection, or use the mouse to click at the end of the selection.
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When viewing a list of clipboards, block selection types are indicated with the text “BLOCK” (see Viewing
and Inserting Clipboards for more information).

Selection Styles
Selections styles determine key behaviors for selections, like whether to extend the selection as the cursor
moves or to deselect after a copy or paste operation. Selection features in SlickEdit® depend on the
current selection style, which is set to match your emulation mode by default. However, note that the key
bindings described in this section are based on the default emulation mode, CUA. If you are using a
different emulation, see the emulation charts (located in the docs subdirectory of your installation directory)
for a listing of selection keys.
To change the selection style, use the Selections option screen (Tools > Options > Editing > Selections).
See Selection Options for more information.

Selection Indicator
SlickEdit® provides a selection indicator, located in the status area of the editor, to indicate the type of
selection and the number of characters or lines in a selection. This is useful to quickly determine the
selection type you have made, and to measure the length of a word or string, or the number of lines in a
function.
The selection indicator displays the following information based on your current selection:
•

When nothing is selected, the indicator is dimmed and displays the text “No Selection”.

•

When the current selection is a character selection:
o

If the character selection is contained on one line, the indicator displays the number of
columns selected. For example, if three characters are selected, the indicator displays “3
Cols”.

NOTE Because columns are “virtual”, the number of columns displayed by the indicator is not
necessarily the actual number of characters or bytes in the selection, if the selection includes tab
characters, Unicode characters, or extends beyond the end of the line.
o

If the character selection spans more than one line, the indicator shows the number of lines,
with a plus sign (+) to indicate if there are “extra” characters selected, or a minus sign (-) to
indicate if there are fewer characters selected, depending on the start and end columns of the
selection. For example, if the selection spans one entire line and part of the subsequent line,
the indicator displays “1 Line+”.

•

When the current selection is a line selection, the indicator displays the number of lines. For
example, if two lines are selected, the indicator displays “2 Lines”.

•

When the current selection is a block selection, the indicator displays the size of the block in the
format Lines x Columns. For example, if the selected block is two lines long and three columns
wide, the indicator displays “2x3 Block”.

TIP The selection indicator can be used to count the number of characters in any text block. This can
be useful for database work or any type of task that involves checking the number of characters.
Simply paste the text into SlickEdit and select it with one of the character selection methods, then
look at the selection indicator to see the number of characters.
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Cycling Through Selections
You can quickly cycle through the three selection types (character, line, and block) with the mouse. To do
this, press and hold the left button while clicking with the right button to change the selection type. For
example, if you have a character selection, click once to start a block selection, or twice to make a line
selection.
You can also cycle through successively larger selections by using the select_toggle command or by
clicking on the Selection Indicator in the editor’s status area. For example, if you have a character
selection, you can use select_toggle to extend the selection to include the entire word. Selections are
cycled in the following order, starting with no selection:
1. Create empty character selection
2. Select current word
3. Select current line
4. Select current code block
5. Select larger code block
6. Select current function
7. Select entire file
8. Deselect
Except for empty character selections and line selections, the selections are locked so that the cursor
remains stationary.

Operating on Selected Text
SlickEdit® provides many methods for manipulating selected text. The table below describes some of the
most common selection operations. See Basic Editing for more.
Selection Operation
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Description

Usage

Add Numbers in Selection

Adds selected numbers and
inserts result below the last
line of the selection. Addition
is performed for each adjacent
line. If no operator exists
between two adjacent
numbers, addition is
assumed. Works with
character, line, and block
selections.

Use the add command.

Add Numbers to Selection
(Enumeration)

Automatically adds
incrementing numbers to a
selection of code.

Use the enumerate command
to auto-add numbers or use
the gui_enumerate command
(Edit > Other > Enumerate)
to display the Enumerate
Dialog, where you can specify
options.
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Selection Operation

Description

Usage

Align Block Selection Center

Centers text in a block
selection within the selected
area.

Use the
align_selection_center
command.

Align Block Selection Left

Aligns text in a block selection
so that the first non-blank
character of each line is flush
against the left edge of the
selection.

Use the align_selection_left
command.

Align Block Selection Right

Aligns text in a block selection
so that the last non-blank
character of each line is flush
against the right edge of the
selection.

Use the
align_selection_right
command.

Append Selection to Clipboard

Appends selected text to the
clipboard.

Use the
append_to_clipboard
command (Ctrl+Shift+C or
Edit > Append to Clipboard)

Beautify Selection

Beautifies the selected text
according to the beautification
settings for the current
language. See Beautifying
Code for more information.

Use the beautify_selection
command, or check the
Restrict to selection box on
the Beautifier dialog (Tools >
Beautify).

Cancel Selection

Cancels the selection.

Use the deselect command
or press Ctrl+U.

Casing: Lowercase Selection

Translates characters within a
selection to lowercase letters.
See Case and Capitalization
of Text for more casing
options.

Use the lowcase_selection
command (Ctrl+Shift+L or
Edit > Other > Lowcase).

Casing: Toggle Selection
Casing

Toggles the characters within
a selection between
lowercase and uppercase.

Use the
togglecase_selection
command.

Casing: Uppercase Selection

Translates characters within a
selection to lowercase letters.
See Case and Capitalization
of Text for more casing
options.

Use the upcase_selection
command (Ctrl+Shift+U or
Edit > Other > Upcase).

Copy Selection by Dragging

Drag/copies selected text.

Press and hold Ctrl while
clicking inside a selection and
then dragging with the mouse
to the desired location
(Ctrl+LButtonDn).
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Selection Operation

224

Description

Usage

Copy Selection to Clipboard

Copies selected text (or the
entire line, if no selection) to
the clipboard. You can also
create a named clipboard with
this operation—see Named
Clipboards.

Use the copy_to_clipboard
command (Ctrl+C or Edit >
Copy).

Copy Selection to Cursor

Copies selected text to the
cursor location. Char and
block selections are inserted
before the character at the
cursor, while lines are inserted
at the location specified by the
Line insert style setting
(Tools > Options > Editing >
General).

Use the copy_to_cursor
command or press Ctrl+Shift
while holding the right mouse
button
(Ctrl+Shift+RbuttonDn).

Cut Selection

Deletes a selection and
copies it to the clipboard.

Use the cut command (Ctrl+X
or Edit > Cut).

Delete and Append to
Clipboard

Deletes a selection and
appends it to the clipboard.

Use the append_cut
command (Ctrl+Shift+X or
Edit > Append Cut).

Execute Selection

Executes each line or sub-line
of a selection as if entered on
the command line.

Use the execute_selection
command or press Alt+=.

Files: Append Selection to File

Appends selected text to the
specified file.

Specify a file name with the
append command, or use the
gui_append_selection
command to display a dialog
where you can browse to pick
the file.

Files: Write Selection to File

Writes selected text to the
specified file.

Specify a file name with the
put command, or use the
gui_write_selection
command (File > Write
Selection) to display a dialog
where you can browse to pick
the file.

Fill Selection

Fills a selection with the
specified key character.

Use the fill_selection
command to be prompted on
the command line for the key,
or use the gui_fill_selection
command (Edit > Fill) to
display a dialog prompt.

SlickEdit® User Guide

TEXT EDITING

Selection Operation

Description

Usage

Hide Selection

Hides all lines in a selection
by collapsing as a Selective
Display unit.

Use the hide_selection
command (View > Hide
Selection). Use the show_all
command (View > Show All)
to redisplay lines.

Indenting: Indent Selection

Indents the selected text
according to the Syntax Indent
settings or by one tab stop,
depending on the Indent with
tabs setting on the LanguageSpecific Indent Options
screen. One indent level is
added for char and line
selections, while one indent
level starting from the left
edge of the selection is used
for block selections.

Use the indent_selection
command (Tab or Edit >
Indent).

Indenting: Unindent Selection

Unindents the selected text
according to the Syntax Indent
settings or by one tab stop,
depending on the Indent with
tabs setting on the LanguageSpecific Indent Options
screen. One indent level is
removed from each line of
char and line selections, while
one indent level starting from
the left edge of the selection is
removed for block selections.

Use the unindent_selection
command (Shift+Tab or Edit
> Unindent).

List Clipboards

Allows you to view and insert
a clipboard. See Clipboards
for more information.

Use the list_clipboards
command (Ctrl+Shift+V or
Edit > List Clipboards.

Move Selection by Dragging

Drag/moves selected text.

Press and hold the left mouse
button while clicking on a
selection and then dragging
with the mouse to the new
location.

Overlay Block Selection

Overlays a block selection at
the current cursor location.

Use the
overlay_block_selection
command (Edit > Other >
Overlay Block).

Overlay/Adjust Block
Selection

Overlays a block selection at
the current cursor location,
and fills the source selection
with blanks.

Use the
adjust_block_selection
command (Edit > Other >
Adjust Block).
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Description

Usage

Paste

Inserts the most recent
clipboard at the current cursor
location. To insert another
clipboard, see the List
Clipboards operation or
Clipboards.

Use the paste command
(Ctrl+V or Edit > Paste).

Reflow Selection

Reflows text within a selection
according to the margin
settings specified on the Word
Wrap option screen (see
Language-Specific Word
Wrap Options). Block
selections are wrapped within
the columns of the block. Char
selections are not supported
for this operation.

Use the reflow_selection
command (Document >
Format Selection).

Reverse Selection

Reverses the characters in a
selection.

Use the reverse_selection
command.

Shift Text in Selection Left

Shifts text within a selection to
the left by one column,
maintaining relative
indentation. This operation
supports line and block
selections. If a character
selection is used, it is
converted to a line selection.

Use the shift_selection_left
command (Shift+F7 or Edit >
Other > Shift Left).

Shift Text in Selection Right

Shifts text within a selection to
the right by one column,
maintaining relative
indentation. This operation
supports line and block
selections. If a character
selection is used, it is
converted to a line selection.

Use the shift_selection_right
command (Shift+F8 or Edit >
Other > Shift Right).

Sort Lines Within Selection

Sorts lines in a selected area
in ascending order.

Use the
sort_within_selection
command or select the Sort
within selection option on
the Sort dialog (Tools > Sort).

Sort Selected Lines

Sorts lines in a selected area
in ascending order, by
comparing only the first
columns.

Use the sort_on_selection
command or select the Sort
on selection option on the
Sort dialog (Tools > Sort).
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Selection Operation
Spell Check Selection

Description
Checks the spelling of
selected text according to the
Spell Option settings. See
Spell Checking for more
information.

Usage
Use the
spell_check_selection
command (Tools > Spell
Check > Check Selection).

Basic Editing
The main menu item Edit provides access to commonly used editing features. Each menu item and its
associated command are described in the Edit Menu section. Keyboard shortcuts for each menu item (if
available) are displayed by default on the menu itself, based on the current emulation.
This section describes the following basic editing operations:
•
•
•
•
•
•
•

Cutting and Deleting Text
Copying Text
Pasting Text
Moving Text
Undoing Text Operations
Case and Capitalization of Text
Inserting Literal Characters

TIP Several editing operations affect words. You can change the characters that SlickEdit® uses to
recognize words, on a per-language basis. To do this, use the Word chars option on the General
Language-Specific Options screen (Tools > Options > Language > [LanguageCategory] >
[Language] > General).

Cutting and Deleting Text
You can cut or delete any selected text, or individual words, lines, or entire code blocks. Cut operations
copy the text to the clipboard before deleting. To remove selected text without copying it to the clipboard,
press the Delete key.
The table below shows some common Cut operations.
Cut Operation

Description

Usage

Cut

Deletes the selection and
copies it to the clipboard.

Use the cut command (Ctrl+X
or Edit > Cut).

Append Cut

Deletes the selection and
appends it to the clipboard.

Use the append_cut
command (Ctrl+Shift+X or
Edit > Append Cut).
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Cut Operation

Description

Usage

Cut Word

Deletes text starting from the
cursor to the end of the
current word or next word, and
copies it to the clipboard.
Invoking this operation from
the keyboard multiple times in
succession creates one
clipboard. See the Tip at the
beginning of this section to
change word recognition
characters.

Use the cut_word command
(Ctrl+Shift+K or Edit >
Delete > Word).

Cut Line

Deletes the current line and
copies it to the clipboard.
Invoking this operation from
the keyboard multiple times in
succession creates one
clipboard.

Use the cut_line command
(Ctrl+Backspace or Edit >
Delete > Line).

Cut to End of Line

Deletes text starting from the
cursor to the end of the line,
and copies it to the clipboard.
Invoking this operation from
the keyboard multiple times in
succession creates one
clipboard.

Use the cut_end_line
command (Ctrl+E or Edit >
Delete > To End of Line).

Cut Code Block

Prompts to delete the current
code block statement and
copies the lines to the
clipboard.

Use the cut_code_block
command or press Ctrl+Del.

Copying Text
The table below shows some common Copy operations.
Copy Operation
Copy to Clipboard
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Description
Copies the selected text (or
the entire line, if no selection)
to the clipboard. You can also
create a named clipboard with
this operation—see Named
Clipboards.

Usage
Use the copy_to_clipboard
command (Ctrl+C or Edit >
Copy).
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Copy Operation

Description

Usage

Copy Word

Copies the word at the cursor
to the clipboard. Invoking this
operation from the keyboard
multiple times in succession
creates one clipboard. See
the Tip at the beginning of this
section to change word
recognition characters.

Use the copy_word
command (Ctrl+K or Edit >
Copy Word).

Copy to Cursor

Copies the selected text to the
cursor location. Char and
block selections are inserted
before the character at the
cursor, while lines are inserted
at the location specified by the
Line insert style setting
(Tools > Options > Editing >
General).

Use the copy_to_cursor
command or press Ctrl+Shift
while holding the right mouse
button
(Ctrl+Shift+RbuttonDn).

Copy to System Clipboard

Passes the selected text to
the operating systems
clipboard.

Use the copy command.

Copy Visible

Copies the currently visible
lines to the clipboard. Ignores
lines hidden by Selective
Display.

Use the
copy_selective_display
command (View > Copy
Visible).

Pasting Text
When pasting text created from a character or block selection, the text is inserted before the character at
the cursor. Line selections are inserted at the location specified by the Line insert style setting (Tools >
Options > Editing > General), and by default, indented according to your indent level settings. See
Inserting Lines for more information.
The most recent clipboard item can be inserted at the cursor location with the paste command (Ctrl+V or
Edit > Paste).
To insert another clipboard, use the Clipboards tool window (View > Toolbars > Clipboards), or use the
list_clipboards command to display the Select Text to Paste dialog. Both the tool window and dialog show
a list of your clipboards and let you select the clipboard to insert. The only difference is that the tool window
can be docked and contains a Preview area that shows the entire color-coded contents of the clipboard.
See Clipboards for more information about these features.
You can also cycle through and paste clipboards with the paste_next_clipboard and
paste_prev_clipboard commands. These commands cycle through the clipboard ring and paste the top
item, while leaving the pasted text selected, so you can use the command again to see the next (or
previous) clipboard text, if that wasn’t the clipboard you wanted. For example, if you have three clipboards
named 1, 2, and 3, invoking the paste_next_clipboard command inserts (yet leaves selected) clipboard 2
and moves it to the top of the ring. Invoke the command again to see/paste the next clipboard instead, and
so on.
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Moving Text
To move a text selection from one location to another, use the mouse to drag and drop it where you want.
SlickEdit® allows this capability by default. To disable it, from the main menu, click Tools > Options,
expand Editing and click General, then set the Allow drag drop text option to False.

Undoing Text Operations
To undo a text operation, use the undo command (Edit > Undo or Ctrl+Z). To redo the operation after
using Undo, use the redo command (Edit > Redo or Ctrl+Y). To cancel a text selection, use the deselect
command or press Ctrl+U.

Case and Capitalization of Text
The table below shows some of the operations you can use to change the case and capitalization of
characters and words.
Casing Operation
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Description

Usage

Lowercase Selection

Translates characters within a
selection to lowercase letters.

Use the lowcase_selection
command (Ctrl+Shift+L or
Edit > Other > Lowcase).

Lowercase Word

Translates the current word to
lowercase letters and places
the cursor after it. See the Tip
at the beginning of this section
to change word recognition
characters.

Use the lowcase_word
command.

Uppercase Selection

Translates characters within a
selection to lowercase letters.

Use the upcase_selection
command (Ctrl+Shift+U or
Edit > Other > Upcase).

Uppercase Word

Translates the current word to
uppercase letters and places
the cursor after it. See the Tip
at the beginning of this section
to change word recognition
characters.

Use the upcase_word
command.

Toggle Casing

Toggles the case of letters
within a selection.

Use the
togglecase_selection
command.
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Casing Operation

Description

Usage

Uppercase Mode

Toggles Uppercase mode on
and off. Uppercase mode
means that letters you type
are automatically uppercased,
so you don’t need to press
and hold Shift. Note that you
can enable auto-caps on a
language-specific basis with
the Auto CAPS option—see
General Language-Specific
Options.

Use the caps command.

Capitalize Selection

Capitalizes the first letter of
each word in a selection.

Use the cap_selection
command (Ctrl+Shift+A or
Edit > Other > Capitalize).

Capitalize Word

Capitalizes the first letter of
the current word and places
the cursor after the word. See
the Tip at the beginning of this
section to change word
recognition characters.

Use the cap_word command.

Inserting Literal Characters
Characters can be inserted at the cursor location in the current buffer. This is useful if you wish to insert
non-ASCII characters (keys not on the keyboard). To insert a literal character, from the main menu, click
Edit > Insert Literal, or use the insert_literal command. The Insert Literal dialog is displayed.
The text box to the right of the Character Code label displays the character. The spin box displays the
decimal character code, hex character code, or ASCII character depending on which of those options is
selected.

Clipboards
Use SlickEdit® clipboards to copy and move text in files, the SlickEdit command line, dialog text boxes, or
any other application that supports text clipboards, such as a word processor. Clipboards in SlickEdit are
internal to the editor and separate from the system clipboard provided by the operating system.
Common clipboard-related operations (cut, copy, paste, etc.) are available on the main Edit drop-down
menu. The corresponding key binding for each item is also shown by default. See Basic Editing for more
information about basic editing operations.
When using a cut or copy operation, a clipboard is created. Pressing the same cut key multiple times in
succession creates one clipboard. For example, the shortcut Ctrl+Shift+K is used to cut words (the
binding for the cut_word command). If you press Ctrl+Shift+K three times to cut three words, one
clipboard is created that you can insert with Ctrl+V (the paste command). This is true for Ctrl+Backspace
(cut_line command) and Ctrl+E (cut_end_line command) as well.
TIP If you are using the Brief emulation and want to place cut text on a clipboard, bind the
commands cut_word, cut_end_line, and cut_line to the appropriate keys.
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This section includes the following topics:
•
•
•
•

Viewing and Inserting Clipboards
Named Clipboards
Clipboards in the Command Line and Text Boxes
Setting the Max Number of Clipboards

Viewing and Inserting Clipboards
To insert the current clipboard into the buffer, from the main menu, select Edit > Paste, press Ctrl+V, or
use the paste command.
In the case of multiple clipboards, there are two ways to view and insert: by using the Clipboards tool
window, or by using the modal Select Text to Paste dialog. Both provide the same information, except the
Clipboards tool window is dockable and contains a color-coded Preview area for previewing clipboard
contents.
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•

To display the Clipboards tool window, from the main menu, select Edit > List Clipboards, press
Ctrl+Shift+V, or use the list_clipboards command.

•

To display the Select Text to Paste dialog, you can use either the old_list_clipboards command
or the list_clipboards_modal command. These commands are identical.
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With either method, double-click on a clipboard to insert it at the cursor location, or, select the clipboard to
insert and press Enter or click OK.
Both the dialog and the tool window provide the same information:
•

Clipboard name/number - This is the number of the clipboard or the name, if using Named
Clipboards. Clipboards are numbered with the most recent clipboard first, which always appears at
the top of the list. You can use this value with the paste command to insert the specified clipboard.
For example, type paste 2 on the command line to insert clipboard 2 at the cursor location.

•

Clipboard type - The clipboard type can be CHAR, LINE, or BLOCK. A CHAR type clipboard is
inserted before the current character. A LINE type clipboard is inserted after the current line by
default. If you want LINE type clipboards inserted before the current line, change the line insert
style (Tools > Options > Editing > General). A BLOCK type clipboard is inserted before the
current character and pushes over all text intersecting with the block. No lines are inserted.

•

Line count - The number following the clipboard type indicates the number of complete or partial
lines of text in the clipboard.

•

Clipboard contents/summary - This area shows all or a portion of the clipboard contents. If the
contents exceed the viewing area, they are condensed.

The Clipboards tool window contains a Preview area that shows the selected clipboard’s color-coded
contents. You can copy text in the Preview to create a new clipboard. To see the entire contents of a
condensed clipboard using the Select Text to Paste dialog, click the View button. The View Clipboard
dialog opens showing the color-coded contents in an edit window. From here, you can copy all or part of
the contents to the operating system clipboard.
The Clipboards tool window contains additional functionality:
•

To delete the selected clipboard item in the tool window, press Delete, or, right-click and select
Delete from the context-menu. To delete all clipboards, select Clear All from the right-click context
menu.

•

To make the selected clipboard active, select Set as Current Clipboard from the right-click
context menu.

•

To save the clipboard to a file, select Save clipboard to file from the right-click context menu.
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•

To change the view of the tool window, the View menu item on the right-click context menu:
o

Auto - When this is selected, the Clipboards tool window switches between Horizontal and
Vertical views automatically as you resize it.

o

Horizontal - When this is selected, the clipboard list is displayed above the Preview area.

o

Vertical - When this is selected, the clipboard list and Preview area are displayed side-byside.

Named Clipboards
You can create a named clipboard by simply typing the name after the copy_to_clipboard command. For
example, create a selection, then, on the SlickEdit® command line, type: copy_to_clipboard a. A
clipboard named “a” is created. Now, you can use the name with the paste command to insert the named
clipboard without using the Select Text to Paste dialog or Clipboards tool window (for example, paste a).
Note that named clipboards are limited to two characters, and that the cut command is not supported for
this feature.

Clipboards in the Command Line and Text Boxes
Only clipboards of one line can be inserted into the SlickEdit® command line or a text box. Both Ctrl+V
and Ctrl+Shift+V key sequences can be used to insert clipboard text into these fields. The result of
inserting a clipboard into a text box varies depending on the clipboard type.

Setting the Max Number of Clipboards
By default, a stack of the 50 most recently used clipboards is kept. To change the maximum number of
clipboards saved, from the main menu, click Tools > Options, expand Editing and click General, then
enter a value in the Maximum clipboards box.

Advanced Editing
This section describes the following advanced editing features:
•
•
•

Inserting Lines
Block Insert Mode
Hex Mode Editing

Inserting Lines
When pasting lines, they are inserted at the location specified by the Line insert style setting (Tools >
Options > Editing > General)—either Before or After the current line. SmartPaste® is on by default, and
indents the pasted lines according to your language-specific indent settings. See SmartPaste® and
Language-Specific Indent Options for more information.
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SlickEdit® provides several ways to start a new line or split a line, as described in the table below.
Line Operation

Description

Usage

Split Line at Cursor

Splits the line at the cursor
and appends enough blanks
at the beginning of the new
line to align it with the first
non-blank character of the
original line.

Use the split_insert_line
command or press Enter.

No Split Insert Line (After)

Inserts a blank line after the
current line, aligning the
cursor with the first non-blank
character of the current line.
The current line is not split.

Use the nosplit_insert_line
command or press
Ctrl+Enter.

No Split Insert Line (Before)

Inserts a blank line before the
current line, aligning the
cursor with the first non-blank
character of the current line.
The current line is not split.

Use the
nosplit_insert_line_above
command or press
Ctrl+Shift+Enter.

Block Insert Mode
Block insert mode is useful when you need to edit a block of text instead of just copying or deleting it.
Additionally, when in this mode, characters you type, as well as other edits (such as backspacing and
deleting), apply to the entire block/column selection.
After a block selection is created, you can enter block insert mode by simply typing some characters to
insert, or by entering the block_insert_mode command (Edit > Other > Block Insert Mode). If the block
selection is more than one column wide, then the initial block selection will be deleted when you type the
first character. This mode also supports use of the keys Tab, Shift+Tab, and Backspace.
To cancel out of block insert mode, press the Esc key.
The figure below shows an example of a block selection created by right-clicking and dragging to select a
block. Notice the cursor position.

The figure below shows how the above example changes when you type “i” at the cursor while the block is
selected.
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The figure below shows how the original example changes when you type “int” at the cursor while the block
is selected.

Hex Mode Editing
You can enable Hex view/edit mode on a per-document or language-specific basis:
•

To view the current binary or text file in a Hex mode, click View > Hex or View > Line Hex (or use
the commands hex or linehex, respectively).

•

To enable Hex or Line Hex view on a language-specific basis, so that each file opened in that
language is displayed in Hex mode, use the Language-Specific View Options.

If you close a file in Hex mode, the file will be displayed in Hex mode the next time it is opened. When the
cursor is in hex data, the data can be overwritten or hex nibbles (characters 0 through F) can be inserted.
When the cursor is in the text data, overwrite it if you want, or insert text characters the same as if editing a
text file. All of the search and replace commands work while SlickEdit® is in Hex mode. Only character
selections are displayed when in Hex mode.
See also Hex/Line Hex View for more information.

Hex/Text View Key Bindings
Hex mode key bindings override normal key bindings for the emulation. Most of the other emulation keys
will perform the same operation. However, keys that are bound to the following commands perform hex
cursor motion: top_of_buffer, bottom_of_buffer, page_up, page_down, begin_line, end_line,
begin_line_text_toggle, cursor_left, and cursor_right.
Hex/Text View Operation
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Key Shortcut

Delete Byte to Left of Cursor and Move Cursor Left

Backspace

Delete Byte Under Cursor

Delete

Move Cursor to Beginning of Hex Line

Home

Move Cursor to Last Character of Hex Line

End
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Hex/Text View Operation
Toggle Cursor Between Hex Data on Left, Text Data on
Right
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Key Shortcut
Tab and Shift+Tab
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Code Templates
Code templates are pre-defined units of code that you can use to automate the creation of common code
elements, like a standard class implementation or design patterns. You can create templates for a whole
file or multiple files. Templates can contain substitution parameters that are replaced when the template is
instantiated—when a new element is created from that template. Some parameters are replaced with
calculated or pre-defined values, like date or author. If a value is not known, you will be prompted for a
value when the template is instantiated.
Code templates are composed of one or more template source files and a metadata file providing
additional information, like the name of the template, a description of the template, prompts for substitution
parameters, and default values for substitution parameters. The following is an example of a single file
source template. The items surrounded by dollar signs, “$”, are the substitution parameters.
/*
* $copyright$
*/
package $package$;
/**
* @author $author$
* @version $version$
*/
public class $safeitemname$ {
/**
* Default constructor.
*/
public $safeitemname$(){
}
}

Templates can be organized into Categories to make them easier to manage. The templates shipped with
SlickEdit® are organized into categories by language and then by purpose. Use the Template Manager
dialog to add, edit, and delete user templates. The Template Manager dialog is accessed by clicking File >
Template Manager.

Instantiating a Template
You can add an item to your current project by clicking Project > Add New Item from Template. If you
want to create a new item from a template without adding it to your current project, then click File > New
Item from Template. The Add New Item dialog box is shown below.
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We call the process of creating new files from a template “instantiating a template”. When a template is
instantiated, you are prompted for the name of the new item. This name is often used heavily in the
template. For a class template, the name will likely be the class name or a part of the class name. In the
sample template, $safeitemname$ is a form of this name that strips out any spaces, making it safe to use
as part of an identifier. This value can even be used as part of the file name when the template is
instantiated.
If any of the values in the template are not known at instantiation time, the Parameter Entry dialog box,
shown below, will prompt you for values.
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Creating Templates
Creating templates is very much like writing code. To create a new code template, complete the following
steps:
1. Create the template source files.
2. Insert substitution parameters into the template files.
3. Use the Template Manager to create a new template.
4. Add the template files to the newly-defined template.

Create the Template Source Files
This is the same process as writing any source file. Use SlickEdit® to write a file from scratch or to modify
an existing file. Make sure your file is syntactically correct to minimize compile errors after it is instantiated.
In many languages, the $name$ syntax used by SlickEdit Code Templates is legal for identifiers, so you
will be able to compile and run your template source files prior to instantiating them. In other languages,
you will have to use temporary identifier names while writing the templates, and then put in the substitution
parameters once you are sure the source is correct.
You can store these source files in any directory and copy them to the templates directory during Step 4.

Insert Substitution Parameters into the Template Files
Use substitution parameters for any part of the source code that can differ from instantiation to
instantiation. This includes class names, author names (if several people are sharing the same template
files), or creation dates.
In our sample, we put in a substitution for copyright statement. See Substitution Parameters for more
details.

Use the Template Manager to Create a New Template
Click File > Template Manager to bring up the Template Manager. Select the User Template folder in the
tree, and right-click in either the Categories pane or the Templates pane to create a new template.
There are different operations based on whether you want to create a new category or not. You will be
prompted for the name of the new template. Fill in a name and click OK. Now you can use the Template
Manager to enter a description, add files, or set values for Custom Parameters.
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Add the Template Files to the Newly-Defined Template
Select the Files tab on the Code Template Manager dialog and click the Plus (+) button to add the files you
created in Step 1 to this template. You will have the option to link to the source in its current location or
copy it to the template directory. You will also be prompted for a target file name. If you want the name of
the instantiated template to appear in the file name, you should use a substitution variable in the name, like
“My$safeitemname$Class.java”.

Substitution Parameters
Substitution parameters provide the real power in Code Templates. Without them, you would simply be
making copies of static files. You can use substitution parameters to replace any text in the template's
source code. You can also use substitution parameters in file names, which is useful in Java where a class
must be defined in a file by the same name.
Substitution parameters are written as identifiers surrounded by a delimiter. The default delimiter is $. Use
a double delimiter to represent the delimiter character in a template source file, $$. You can specify a
different character to use as the delimiter. Click File > Template Manager and click on the Custom
Parameters tab to change the value for the Delimiter field.
We provide a set of predefined substitution parameters for items related to item name, project name,
directories, date, and time. We can determine the value for these items rather than having to prompt for
them. See the list at the end of this section for all the predefined substitution parameters.
You can define substitution parameters that are common to all templates. For example, you might want to
define an “author” parameter where the parameter value is your name. You could then create code
templates that fill in a header comment with the author's (your) name. You would only have to define the
substitution parameter once. To define these parameters, open the Template Manager and select the
Custom Parameters tab.
If no value is provided for a substitution parameter, you will be prompted for one when the template is
instantiated. This is useful for things like class name or other values that are different each time the
template is instantiated.

Predefined Substitution Parameters
The following substitution parameter names and values are pre-defined for use in an item template. The
default delimiter “$” is used:
Parameter Name
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Description

$itemname$

Name of item entered, as on the Add New Item dialog.

$fileinputname$

Name of item entered, as on the Add New Item dialog, without
file extension.

$safeitemname$

Name of item entered, as on the Add New Item dialog, with all
unsafe characters replaced with safe characters. For example,
if the item name was My Custom Class, then the
$safeitemname$ would evaluate to My_Custom_Class for a
C++ source code file.

$upcasesafeitemname$

Same as $safeitemname$ with all characters uppercased.

$lowcasesafeitemname$

Same as $safeitemname$ with all characters lowercased.
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Parameter Name

Description

$tempdir$

Location of operating system temp directory. No trailing file
separator.

$rootnamespace$

Root namespace or package for the current project. This is
typically used for C# and Java projects to find the namespace
containing Main() (or main() in the case of Java).

$ampmtime$

Time of day in the form hh:mm[am|pm]. Example: 11:34pm

$localtime$

Time of day in locale-specific format.

$time$

Time of day in the form hh:mm:ss.

$localdate$

Current date in locale-specific format.

$date$

Current date in the form mm/dd/yyyy.

$projectname$

Current project name (no path, no extension).

$safeprojectname$

Current project name (no path, no extension), with all unsafe
characters replaced with safe characters. For example, if the
project name was: My Project.vpj, then $safeprojectname$
would evaluate to My_Project for a C++ source code file.

$workspacename$

Current workspace name (no path, no extension).

$safeworkspacename$

Current workspace name (no path, no extension), with all
unsafe characters replaced with safe characters. For example,
if the workspace name was: My Workspace.vpw, then
$safeworkspacename$ would evaluate to My_Workspace
for a C++ source code file.

$projectworkingdir$

Current project working directory. No trailing file separator.

$projectbuilddir$

Current project build (output) directory. No trailing file
separator.

$projectconfigname$

Current project configuration name.

$workspaceconfigname$

Current workspace configuration name. This will be the same
as $projectconfigname$ except for MS Visual Studio
workspace which will have a separate workspace/solution
configuration name.

$projectdir$

Location of current project file. No trailing file separator.

$workspacedir$

Location of current workspace file. No trailing file separator.

$username$

Operating system login name.

Organizing Templates
Templates are organized into category hierarchies as shown on the Add New Item dialog. These category
hierarchies map exactly to the directory structure under the locations for installed and user templates.
To create a new template item category:
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1. Create a new folder under the user templates directory. For example, if you wanted to create a
Dialogs category for Java project items, you would create the following directory:
[ConfigDir]/templates/ItemTemplates/Java/Dialogs/
2. Place all templates for the category under this directory.
3. Create a new project or open an existing one.
4. From the main menu click Project > Add New Item.
5. Verify that your new category appears in the Categories list on the Add New Item dialog box.
CAUTION We do not recommend creating new categories or re-organizing categories under
installed templates since the next patch or upgrade would overwrite any customizations you have
made. If you want to customize an installed template, then we suggest you copy it to the user
templates directory and perform your customization on the copy.

Template Manager Operations
Use the Template Manager dialog to add, edit, and delete templates. You can show this dialog by clicking
File > Template Manager. Use the Categories list to select a category. Selecting a category populates the
Templates list with templates for that category.

Creating a New Category
To create a new category under the selected category, right-click in the Categories tree and select New
Category. You will be prompted for a category name. After clicking OK, you can add templates in the new
category.

Creating a New Template
To create a new template, select the category in which to create the template, then right-click in the
Templates list and select New Template. You will be prompted for a template name which is used to
create the new template file. After clicking OK, you can edit the new template the lower half of the dialog.

Editing an Existing Template
To edit an existing template, select a template from the Templates list, and edit its properties in the lower
half of the dialog.

Deleting a Template
To delete a template, select the template you want to delete from the Templates list, right-click and select
Delete Template from the context menu.

Template Manager Dialog
The Template Manager dialog is made up of the following elements:
•

Categories - Lists a hierarchy of item categories for installed and user template items.

NOTE Installed templates can be viewed but not modified.
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•

Templates - Lists the templates for the currently selected category. When you select a template,
you are able to edit its properties in the lower half of the dialog.

•

Template file - File name of the currently selected template.

Details Tab
The Details tab of the Template Manager dialog contains the following:
•

Name - Specifies the name for the template item. The name is used in the Templates list of the
Add New Item dialog.

•

Description - Specifies the description for the template item. The description is displayed on the
Add New Item dialog when the template is selected.

•

Default name - Specifies the default item name when using the Add New Item dialog box.

•

Sort order - Specifies an order number that is used to sort the template item in relation to other
template items in a list. Used to sort template items in a category on the Add New Item dialog box.
Lower sort orders are placed ahead of higher sort order values in a sorted list.

Files Tab
Use the Files tab of the Template Manager dialog to add, edit, order, and delete files in a template. Files
are created from a template when using the Add New Item dialog, as when adding an item template to a
project.
Add, Edit, Order, and Delete operations are accessible from the buttons on the right side or from the
context menu inside the list of files.

Custom Parameters Tab
Use the Custom Parameters tab of the Template Manager dialog to add, edit, and delete substitution
parameters in a template. Substitution parameters are used to replace parameter names in the content of
files created from a template with a pre-defined value. Substitution parameters can also be used to form
target file names (Files tab).
Add, Edit, and Delete operations are accessible from the buttons on the right side or from the context
menu inside the list of parameters.

Template Options Dialog
Use this dialog to edit options that are common to all templates. You can launch this dialog from the
Template Manager dialog by clicking the Options button.

Global Substitution Parameters
The Global substitution parameters area on the Template Options dialog lists the substitution
parameters that are common to all templates. A common substitution parameter, for example, could be
“author” where the parameter value is your name. You could then create code templates that automatically
fill in a header comment with the author's (your) name.
Add, Edit, and Delete operations are accessible from the buttons on the right side or from the context
menu inside the list of parameters.
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Add File Dialog
Used to add a file to a template. To launch this dialog, right-click on a file in the Files tab of the Template
Manager dialog, and select Add File, or use the Add File button. The dialog contains the following:
•

Source file name - When a file is created from a template, as when adding an item template from
the Add New Item dialog, it is created from the source file with this file name.

•

Copy source file to template directory - Check this option to place a copy of the file in the
current template's directory and change the source file name to point to the new file in the
template. The file is not copied until you click OK.

•

Target file name - When a file is created from a template, as when adding an item template from
the Add New Item dialog, the file name of the file that is created on disk is formed from the target
file name in the location you specify. Use the menu button to the right of this field to insert common
pre-defined substitution parameters. For example, $fileinputname$ is the item name provided on
the Add New Item dialog when adding an item template to your project.

•

Replace parameters in target file content - Check this option if you want substitution parameters
embedded in the content of the target file to be replaced when the file is created from the template,
as when adding an item template to your project from the Add New Item dialog.

•

Preview - Previews how the file would be copied when creating the file from a template as if the
source file name and target file name were fully resolved.

Add Parameter Dialog
Used to add a custom substitution parameter to a template. This dialog is launched when performing an
Add operation from the Custom Parameters tab of the Template Manager Dialog. When files are created
from a template, as when adding an item template to your project from the Add New Item dialog box, you
can configure your template to replace all substitution parameters with values. For a list of pre-defined
substitution parameters, see Predefined Substitution Parameters.
The Add Parameter dialog contains the following:
•

Name - This is the name of the substitution parameter WITHOUT delimiters. For example, if the
delimiter is “$” (the default), then a substitution parameter that inserts a copyright string would
have a name of “copyright” and NOT “$copyright$”. Do not use quotes in the name. Valid
characters for a parameter name are: A-Za-z0-9_

•

Value - This is the value that the substitution parameter evaluates to when a string or file is
created from the template and has its substitution parameters replaced with values.

•

Prompt for value - Check this option if you always want to be prompted for the value of a
substitution parameter. When set, the Value field becomes a default value field and is used to prepopulate the value when you are prompted.

•

Prompt string - Specifies the prompt string to display when being prompted for a substitution
parameter value.

Add New Item Dialog
Used to add an item to your current project, the Add New Item dialog is displayed when you click Project >
Add New Item or File > New Item from Template.
Use the Categories list to select a category. Selecting a category populates the Templates list with
template items for that category. You can then select an item from the Templates list, enter a unique Name
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for the item, and enter a Location. Click Add to instantiate the template with the name and location you
provided.
You can manage your templates from the Template Manager dialog box by choosing File > Template
Manager.
The Add New Item dialog contains the following:
•

Categories - Lists a hierarchy of item categories for installed and user template items.

•

Templates - Lists the template items for the currently selected category. When you select a
template item, a brief description for that item is displayed just above the Name field.

•

Name - Enter the name of the file you want to create.

NOTE For single file templates (templates that create a single file) this is the name of the file. Multifile templates use the name of the item entered to form names of files in the template. For more
information about creating multi-file templates, see Creating a Multi-file Template.
•

Location - Enter the location to which to save the item.

•

Add to current project - When selected, the new item is added to the current project.

•

Add - After you have selected a template item, provided a name and a location, click Add to
instantiate the template item.

Locating Templates
Installed Templates
Templates that are installed with the product are located at:
[SlickEditInstallDir]/sysconfig/templates/ItemTemplates/
For example, the following directory under Windows contains item templates for the C++ language:
c:\SlickEdit\sysconfig\templates\ItemTemplates\C++\

User Templates
User templates are templates that the user creates and are located at:
[ConfigDir]/templates/ItemTemplates/
TIP You can locate your Configuration Directory from the main menu by clicking Help > About
SlickEdit.

Manually Creating a Template
SlickEdit® Code Templates are represented as files stored in specific directories. A template is composed
of the source file or files for the template and a metadata template file that provides additional information.
Since these are just files, you can write them using SlickEdit.
To manually create an item template:
1. Choose a category folder under the user templates directory. Your user templates directory is at:
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[ConfigDir]/templates/ItemTemplates/
TIP You can locate your Configuration Directory from the main menu by clicking Help > About
SlickEdit.
All files will be created relative to the folder you choose. For more information about how templates
are organized, see Organizing Templates.
2. Create or edit a code file (e.g. *.cpp, *.java, etc.). Replace occurrences of substitutable text with
substitution parameter names. For example, you might want to make the name of a C++ or Java
class into a substitution parameter, in which case you could use the $safeitemname$ substitution
parameter. For more information on substitution parameters, see Substitution Parameters.
3. Create an XML file and give it an extension of .setemplate.
4. Insert template metadata into the .setemplate file. See the example below. For more information
on template metadata elements, see Code Template Metadata File Reference.
5. Create a new project or open an existing one.
6. From the main menu, click Project > Add New Item.
7. Verify that your new template item appears in the Templates list on the Add New Item dialog box.

Example
The following example illustrates the metadata for an item template for a custom Java class, along with the
content of the Java source code file.
From the Add New Item dialog box, if the user entered Foo.java for the item name, then $fileinputname$
would be replaced with “Foo” in the file name of the file created, and $safeitemname$ would be replaced
with “Foo” in the Java source code file.
MyClass.setemplate:
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File TargetFilename="$fileinputname$.java">MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>
MyClass.java:
class $safeitemname$ {
};

Creating a Multi-file Template
A multi-file template is a template item that creates more than one file.
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Multi-file templates require the use of substitution parameters to ensure that file name and extension parts
are used when creating each file of the template item. For example, a C++ class typically consists of:
•

A .h file that contains the class definition.

•

A .cpp file that contains the class implementation.

Since you can only enter one name into the Name field on the Add New Item dialog box, you need a way
to specify the target file name for each file created by the multi-file template. In the C++ class example
below, the .h and .cpp files are created with the name you provide, while their extensions are preserved.
To create a multi-file item template from the Template Manager dialog, click File > Template Manager.
To manually create a multi-file item template:
1. Create the item template the same way a single file template would be created. For more
information on manually creating a template item, see Manually Creating a Template.
2. Add TargetFilename attributes to each of the File elements in your template metadata file
(.setemplate). Set the value of each TargetFilename attribute to $fileinputname$.[extension],
where [extension] is the file extension of the target file name being created. When the files are
created, their names will be based on the name you entered in the Name field of the Add New Item
dialog box. See the example below.

Example
The following example demonstrates a multi-file item template .setemplate file. The item creates C++
class header (.h) and implementation (.cpp) files.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My C++ Class</Name>
<Description>My complete C++ class header and implementation</Description>
<DefaultName>MyClass.cpp</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File TargetFilename="$fileinputname$.cpp">MyClass.cpp</File>
<File TargetFilename="$fileinputname$.h">MyClass.h</File>
</Files>
</TemplateContent>
</SETemplate>

Code Template Metadata File Reference
Template metadata describes the template item, its files, and how to create the template. Template
metadata files have a .setemplate extension.
The SETemplate element is the root element of a template file.
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Summary of metadata elements:
Element

Child Elements

Attributes

DefaultName

-

-

Description

-

-

File

-

ReplaceParameters,
TargetFilename

Files

File

-

Name

-

-

Parameter

-

Name,Value

Parameters

Parameter

-

SETemplate

TemplateContent,
TemplateDetails

Type,Version

SortOrder

-

-

TemplateContent

Files,Parameters

Delimiter

TemplateDetails

DefaultName,
Description,Name,
SortOrder

-

Elements
DefaultName
DefaultName is an optional child element of TemplateDetails. Specifies the default item name when using
the Add New Item dialog box. This element becomes more important in multi-file templates where you
need to specify a DefaultName element in order to create file names from parts of the input item name.
See the example below.
•

Attributes - None.

•

Child elements - None.

•

Parent elements - TemplateDetails.

•

Value - Text value is required. The text value specifies the default name of the template item. Used
to populate the name field with an initial value on the Add New Item dialog box.

Example
The following example illustrates the metadata for an item template for a C++ class that creates a header
file (.h) and implementation file (.cpp).
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My C++ Class</Name>
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<Description>My complete C++ class header and implementation</Description>
<DefaultName>MyClass.cpp</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File TargetFilename="$fileinputname$.cpp">MyClass.cpp</File>
<File TargetFilename="$fileinputname$.h">MyClass.h</File>
</Files>
</TemplateContent>
</SETemplate>

Description
Description is a required child element of TemplateDetails. Specifies the description for the template
item. See the example below.
•

Attributes - None.

•

Child elements - None.

•

Parent elements - TemplateDetails.

•

Value - Text value is required. The text value specifies the description of the template item. The
description is shown on the Add New Item dialog box.

Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>

File
File is an optional child element of Files. Specifies a file for the template item. See the example below.
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•

Attributes
Attribute

Description

ReplaceParameters

Optional.
Specifies whether parameter substitution takes place on
the file contents when the file is created from the template.
Note that parameter substitution always takes place on the
TargetFilename attribute value (example:
TargetFilename="$fileinputname$.cpp").
Possible values are “1” (true) or “0” (false).
Defaults to “1” (true).

TargetFilename

Optional.
Specifies the actual name of the item that is created from
the template.
This attribute is especially useful when creating a multi-file
template where file names of files created from the
template are assembled by parameter substitution.

•

Child elements - None.

•

Parent elements - TemplateContent.

•

Value - Text value is required. Value is the path of a file in the template item.

Example
The following example illustrates the metadata for an item template for a C++ class that creates a header
file (.h) and implementation file (.cpp).
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My C++ Class</Name>
<Description>My complete C++ class header and implementation</Description>
<DefaultName>MyClass.cpp</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File TargetFilename="$fileinputname$.cpp">MyClass.cpp</File>
<File TargetFilename="$fileinputname$.h">MyClass.h</File>
</Files>
</TemplateContent>
</SETemplate>

Files
Files is a required child element of TemplateContent. Specifies files for the template item. See the
example below.
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•

Attributes - None.

•

Child elements - File.
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•

Parent elements - TemplateContent.

•

Value - N/A

Example
The following example illustrates the metadata for an item template for a C++ class that creates a header
file (.h) and implementation file (.cpp).
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My C++ Class</Name>
<Description>My complete C++ class header and implementation</Description>
<DefaultName>MyClass.cpp</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File TargetFilename="$fileinputname$.cpp">MyClass.cpp</File>
<File TargetFilename="$fileinputname$.h">MyClass.h</File>
</Files>
</TemplateContent>
</SETemplate>

Name
Name is a required child element of TemplateDetails. Specifies the name for the template item. See the
example below.
•

Attributes - None.

•

Child elements - None.

•

Parent elements - TemplateDetails.

•

Value - Text value is required. The text value specifies the name of the template item. The name is
shown in the Templates list on the Add New Item dialog box.

Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>

SlickEdit® User Guide

253

CODE TEMPLATES

</SETemplate>

Parameter
Parameter is an optional child element of Parameters. Specifies a custom substitution parameter for the
template item. For a list of pre-defined substitution parameters, see Predefined Substitution Parameters.
See the example below.
•

Attributes
Attribute

Description

Name

Parameter name. This is the name of the substitution
parameter WITHOUT delimiters. For example, if the delimiter
is “$” (the default), then a substitution parameter that inserts a
copyright string would be defined as “copyright” and NOT as
“$copyright$”.

Value

Parameter value. This is the value that the substitution
parameter evaluates to when a string or File is created from
the template.

•

Child elements - None.

•

Parent elements - Parameters.

•

Value - N/A

Example
The following example illustrates the metadata for an item template for a custom Java class.
When MyClass.java is used to create the file from the template, all occurrences of $copyright$ in the
created file will be replaced with “(c)2005-2006”.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Parameters>
<Parameter Name="copyright" Value="(c)2005-2006" />
<Parameters>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>
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Parameters
Parameters is a required child element of TemplateContent. Specifies custom substitution parameters for
the template item. For a list of pre-defined substitution parameters, see Predefined Substitution
Parameters.
See the example below.
•

Attributes - None.

•

Child elements - Parameter.

•

Parent elements - TemplateContent.

•

Value - N/A

Example
The following example illustrates the metadata for an item template for a custom Java class.
When MyClass.java is used to create the file from the template, all occurrences of $copyright$ in the
created file will be replaced with “(c)2005-2006”.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Parameters>
<Parameter Name="copyright" Value="(c)2005-2006" />
<Parameters>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>

SETemplate
Root element. Contains all metadata about template item.
•

Attributes
Attribute

Description

Version

Template version number. The current version is “1.0”.

Type

Template type. Valid types are: “Item”.

•

Child elements - TemplateDetails, TemplateContent.

•

Parent elements - None.

•

Value - N/A
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Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>

SortOrder
SortOrder is an optional child element of TemplateDetails. Specifies an order number that is used to sort
the template item in relation to other template items in a list. Used to sort template items in a category on
the Add New Item dialog box.
If no SortOrder is specified for a template item, then the SortOrder value defaults to “0”.
•

Attributes - None.

•

Child elements - None.

•

Parent elements - TemplateDetails.

•

Value - Text value is required. An integer that is greater than or equal to “0”. When sorting in
relation to other template items, low SortOrder values are placed ahead of higher values in a
sorted list.

Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
<SortOrder>100</SortOrder>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>
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TemplateContent
TemplateContent is a required child element of SETemplate. Specifies the contents of a template item.
•

Attributes
Attribute
Delimiter

Description
Optional.
Delimiter used when replacing substitution parameters in
content.
Defaults to “$”.

•

Child elements - Files, Parameters.

•

Parent elements - SETemplate.

•

Value - N/A

Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>

TemplateDetails
TemplateDetails is a required child element of SETemplate. Describes the template item. Details are
used to display the template item on the Add New Item dialog box.
•

Attributes - None.

•

Child elements - DefaultName, Description, Name, SortOrder.

•

Parent elements - SETemplate.

•

Value - N/A

Example
The following example illustrates the metadata for an item template for a custom Java class.
<?xml version="1.0" ?>
<!DOCTYPE SETemplate SYSTEM "http://www.slickedit.com/dtd/vse/setemplate/1.0/
setemplate.dtd">
<SETemplate Version="1.0" Type="Item">
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<TemplateDetails>
<Name>My Java Class</Name>
<Description>My custom Java class</Description>
<DefaultName>MyClass.java</DefaultName>
</TemplateDetails>
<TemplateContent>
<Files>
<File>MyClass.java</File>
</Files>
</TemplateContent>
</SETemplate>
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Color Coding
This feature is designed to combine current line coloring, modified line coloring, and language-specific
coloring. By default, Plain Text mode colors the current line. Languages with specific support already
defined (i.e. keywords, comments, etc.) use language-specific coloring.
If modified line coloring is active, the left edge of the window displays a different color depending on
whether the line was inserted or modified. To change the colors, use the Colors options screen (Tools >
Options > Appearance > Colors). For more information see, Colors.
When current line color coding is active, language-specific color coding for the current line is not viewable.
If you want to know what lines have been modified, bind the command color_modified_toggle to a key. It
will toggle display of modified lines in a different color on/off. You can bind the color_toggle command to a
key as well. This command toggles between current line, modified line, and language specific coloring
individually.

Resetting Modified Lines on Save
SlickEdit® can clear the modified and inserted line color when you save a file. To activate this feature, from
the main menu, click Tools > Options, expand File Options and click Save, then set the Reset line
modify option to True.

Adding Color-Coded Keywords to Supported
Languages
You can add color-coded keywords to a supported language. To add color-coded keywords to a supported
language, complete the following steps.
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Color Coding.
2. Click New.
3. Enter the new keywords separated with a space character.
4. Click OK.
5. Click OK on the Color Coding options screen.
For more information, see Color Coding Configuration.

Creating Color Coding for a New Language
To create color coding support for your language, complete the following steps:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Color Coding.
2. Select the Color Coding Tokens Tab, then click New. The Enter New Keywords dialog box is
displayed.
3. Enter the new lexer name. Usually this is a language name such as C or Java. Click OK.
4. On the Tokens tab, make sure the new keyword is selected, then correct the ID start characters.
These are valid characters which can be the start of an identifier.
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5. Correct the ID follow characters. These are additional characters which are valid after the start ID
character. For example, digits are usually allowed in identifiers, but not as the first character of an
identifier.
6. Select the Color Coding Comments Tab. This lists the comments currently defined and allows you
to define new multi-line and line comments. For each comment, click New to add a line or multiline comment.
7. Select the Color Coding Numbers Tab to display various numeric style options.
8. Select the Color Coding Strings Tab to display various string literal options.
9. If you have not found all the options you need, click the Color Coding Language Tab. This displays
even more advanced language-specific options.
10. Click OK on the Color Coding options screen.

Color Coding Line Options
To enable color coding for modified lines or the current line, from the main menu, click Tools > Options >
Languages, expand your language category and language, then select General. When Modified lines is
selected, changed lines are indicated in color. When Current line is selected, the current line is indicated
in color. See General Language-Specific Options for more information.

Color Coding Configuration
To configure color coding, from the main menu, click Tools > Options > Languages, expand your
language category and language, then select Color Coding.
Click New to prompt for a lexer name to start a new language-specific color coding definition (see Creating
Color Coding for a New Language). Click Colors at the bottom of the dialog to display the Color Settings
dialog, which allows you to specify the color for color coding elements and other editor elements (see
Setting Colors for Screen Elements).
The options on each tab are described in the section Language-Specific Color Coding Options.

Advanced Color Coding Configuration
The vslick.vlx file defines language-specific coloring support. For information about modifying this file,
and how to create a new lexer name, see VLX File and Color Coding.

260

SlickEdit® User Guide

SYNTAX INDENT AND SMARTPASTE®

Syntax Indent and SmartPaste®
Syntax Indent and SmartPaste® are two of the many SlickEdit® features designed to decrease typing,
improving your coding efficiency. Syntax Indent automatically indents code to the correct levels. There are
two ways that code can be indented: by using the automatic Syntax Indent feature, and/or by using tabs.
SmartPaste reindents pasted text to the correct level based on surrounding code.

Syntax Indent
By default, if you press Enter while you are editing a source file, Syntax Indent automatically indents the
cursor to the next level if it is moved inside a structure block. For example, if you edit a C file and the cursor
is on a line containing the text for (:){ and you press Enter, a new line is inserted and the cursor is
indented four spaces in from the letter “f” in the word “for”.
To change the Syntax Indent spacing, complete the following steps:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Indent.
2. Change the value in the Syntax indent text box.

Indenting with Tabs
By default, when you press the Tab key to indent, literal spaces are inserted. If you plan to indent your
code using tab characters, or if you will be editing files that already contain tabs, you will need to specify
these preferences.
To activate tab indenting, from the main menu, click Tools > Options > Languages, expand your
language category and language, then click Indent. Select the Indent with tabs option.

Setting Tab Spacing
The default value of the Tab key is eight spaces. You can change this value in the Tabs text box. In
general, the Tabs setting should match the Syntax indent value. For example, by default for the C
language extension, the Syntax indent value is set to 4, and the Tabs setting is set to +4. The plus sign
(+) indicates that the editor will automatically expand the stops by four. By default, the Tabs setting is “+4”,
which indicates that the default tab setting is eight spaces.
To work properly with the Sun Java API source code, the tab stops need to be in increments of eight, but
the syntax indent must be set to four. The Syntax Indent affects not only the Tab key, but also the number
of spaces to indent for each code block level.
NOTES
•

When you change the tab stops and indent for all languages except COBOL, change the
Tabs text box to +value where value is the same value used for the Syntax indent text box.
The Tabs text box only affects how tab characters are expanded on the screen. This does
not affect the indent when pressing Tab, or the amount of indent for statements inside a
code block.

•

For COBOL files, the Tabs text box also affects the Tab key. Syntax Indent still affects the
indent for each code block level.
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Setting Tab to Indent Selections
For the Tab key to indent the selection when text is selected, select the option Indent selection when text
selected.

Setting Tabs for the Current File
To set tabs for the current buffer only, use the Tabs dialog box (Document > Tabs or gui_tabs command).
You can set tabs in increments or at specific column positions. For example, to specify an increment of
three, enter +3 in the text box. To specify columns, you could enter 1 8 27 44 to specify tab stops that have
absolute locations.
By default, the Tab key inserts enough spaces to move the text to the next tab stop. The Shift+Tab key
combination deletes enough spaces to move the text to the previous tab stop. See Redefining Common
Keys for information on other Tab and Shift+Tab key bindings. Regardless of the Tab key binding, if the
language-specific setting Indent with tabs is on, a physical tab character is inserted (see Indenting with
Tabs).

Setting the Backspace Unindent Style
By default, pressing the Backspace key when the previous character is a tab, causes the rest of the line to
be moved to the previous tab stop. If you want your Backspace key to delete through tab characters one
column at a time, from the main menu, click Tools > Options, expand Keyboard and select Redefine
Common Keys, then set the Backspace over tab option. See Redefining Common Keys for more
information.

SmartPaste®
When pasting lines of text into a source file, SmartPaste reindents the added lines according to the
surrounding code. For example, if editing a C or C++ file, select some lines with a line selection (Ctrl+L),
copy them to the clipboard (Ctrl+C), then paste them inside a for loop block (Ctrl+V). The added lines are
correctly indented according to the for loop's indent level. SmartPaste will work for character/stream
selections; however, the last line of the selection must include the end-of-line character. Use the mouse to
copy and move lines and still take advantage of SmartPaste.
SmartPaste is enabled by default, and can be turned on and off from the language-specific Indent option
screen. To access these options, from the main menu, click Tools > Options. Expand Languages in the
tree, select the language category and language, then click Indent. Select or clear the Use SmartPaste®
option.
NOTE SmartPaste only works with line selections. For information about creating a line selection,
see Line Selections.
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Adaptive Formatting
Many development teams set standards for code formatting styles. These standards often vary from
project to project or between languages. In this environment, you can lose valuable time in having to
change configurations, set/unset options, or run beautifiers from file to file just so you can meet the team’s
requirements.
Adaptive Formatting addresses these situations by scanning a file for the formatting styles in use, and
automatically matching those settings for the current editing session. This provides seamless integration of
new code with existing code, making it easier to read—not only for you, but for the next person who needs
to edit the file.
Adaptive Formatting is enabled by default and recognizes indentation and tab style settings, parentheses
padding, and begin/end style settings. It also recognizes case settings, such as keyword casing for caseinsensitive languages, and tag, attribute, and value casing for HTML-based languages.

Enabling/Disabling Adaptive Formatting
Adaptive Formatting is enabled by default. You can toggle it on and off on a language-specific basis, and
you can also enable/disable each of the individual formatting settings on a language-specific basis as well.
To access these options, from the main menu, click Tools > Options, expand your language category and
select the language, then select Adaptive Formatting. As an example, the C/C++ Adaptive Formatting
options are shown below.

The specific Adaptive Formatting settings available for that language are shown on the options screen.
Select or clear the Use Adaptive Formatting check box to enable or disable the feature. When Adaptive
Formatting is enabled, use the subsequent check boxes to select the settings for which SlickEdit® should
scan.
You can also toggle Adaptive Formatting on and off for a language by using the menu item Document >
Adaptive Formatting (or the adaptive_format_toggle command). This turns the feature on and off for
the current language without affecting the individual style settings.
The individual formatting style settings are located on various screens in the language-specific section of
the Options dialog. A label, linked to the Adaptive Formatting options screen, appears next to each setting
to indicate if Adaptive Formatting is on or off for that setting. Adaptive Formatting does not change the
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value set in these options; rather, it overrides the value on a document-by-document basis. For example,
notice how Adaptive Formatting is enabled for settings on the C/C++ Indent options screen:

The values specified by Adaptive Formatting will be used instead of the values shown on the options
screen. Click on the Adaptive Formatting hyperlinks to jump to the Adaptive Formatting options screen for
that language.

Recognized Settings
The table below shows each option recognized by Adaptive Formatting, the path to the option in
SlickEdit®, and a description, along with a link for more information. Because these options are languagespecific, the option paths are relative to the language-specific portion of the Options dialog: click Tools >
Options > Languages, expand your language category and then select your language.
Formatting Option
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Path to Option in SlickEdit

Description

Syntax indent

[Language] > Indent
(Language-Specific Indent
Options)

When enabled, the Enter key
indents according to the
language syntax, and you can
specify the amount to indent
for each level. See Syntax
Indent for information.

Tabs

[Language] > Indent
(Language-Specific Indent
Options)

Specifies tab stops, which can
be in increments of a specific
value or at specific column
positions. See Indenting with
Tabs for information.
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Path to Option in SlickEdit

Description

Indent with tabs

[Language] > Indent
(Language-Specific Indent
Options)

Determines whether the Tab
key, Enter key, and paragraph
reformat commands indent
with spaces or tabs. See
Indenting with Tabs for
information.

Begin/End style

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

The is the brace style used for
Syntax Expansion and smart
indenting. See the section for
your language in the
Language-Specific Editing
chapter. For example, C/C++
Formatting Options.

Indent CASE from SWITCH
and Indent constant from
case

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies Syntax Expansion
indentation. See the section
for your language in the
Language-Specific Editing
chapter. For example, C/C++
Formatting Options.

No space before
parenthesis

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

When enabled, no space is
placed between keywords
(such as if, for, or while) and
the open paren when Syntax
Expansion occurs. See the
section for your language in
the Language-Specific Editing
chapter. For example, C/C++
Formatting Options.

Insert padding between
parenthesis

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

When enabled, a space is
placed after the open
parenthesis and before the
close parenthesis, providing
padding for the enclosed text.
See the section for your
language in the LanguageSpecific Editing chapter. For
example, C/C++ Formatting
Options.

Keyword case

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies the case of
keywords used by Syntax
Expansion. See the section for
your language in the
Language-Specific Editing
chapter. For example, Ada
Formatting Options.
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Path to Option in SlickEdit

Description

Case for inserted tags

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies the case for tags
that are automatically
inserted. See HTML
Formatting Options for more
information.

Case for inserted attributes

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies the case for tag
attributes that are
automatically inserted. See
HTML Formatting Options for
more information.

Case for inserted single
word values

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies the case of word
values that are automatically
inserted inside a tag. See
HTML Formatting Options for
more information.

Case for hex values

[Language] > [Language]
Formatting Options
(Language-Specific
Formatting Options)

Specifies the case for hex
values that are automatically
inserted inside a tag. See
HTML Formatting Options for
more information.

Scanning for Styles in Use
Adaptive Formatting has two modes of scanning: automatic, which is the default behavior, and manual,
which lets you run a scan at any time to determine a file’s formatting styles in order to quickly save them as
the default settings.
By default, when you open a file for editing, Adaptive Formatting initially scans for the indent-related
settings that are in effect (Syntax indent, Indent with tabs, and Tabs), starting at the beginning of the file.
Thereafter, Adaptive Formatting scans as you type to determine brace settings, parentheses padding, and
other formatting styles. If Adaptive Formatting determines that the file is using a different formatting style
than the current language-specific setting, a dialog is displayed that shows the settings in effect. You can
then choose to use the settings or use the settings set for the language. Once the formatting style is
determined, the options for those styles are used as long as the buffer is open for editing.
For example, when you type a keyword such as if in a C/C++ file that uses formatting styles different from
the current settings, the C/C++ Adaptive Formatting Results dialog is displayed.
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On this dialog, the selected settings are used only for the current buffer. You can access the Adaptive
Formatting options screen to enable/disable Adaptive Formatting for that language by clicking the
hyperlink to Configure or disable Adaptive Formatting.
If you always want to accept the Adaptive Formatting results, select Don’t show me this again to
suppress the dialog from appearing in the future.
A similar dialog is shown when you run Adaptive Formatting manually. This mode lets you run Adaptive
Formatting on the entire file at once, in order to quickly save the settings as the defaults for that language.
To run a manual scan, use the adaptive_format_stats command. The Adaptive Formatting Results dialog
for that language is displayed, showing all of the recognized style settings that are in use in the current file.
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This dialog lets you enable/disable the settings just for the current buffer, or select Use these settings for
all files of this language to quickly set these values as the default.

Confidence Level and Statistics
Both Adaptive Formatting Results dialogs show a confidence level and provide a link to a statistics screen.
The Confidence Level is a statistical percentage, based on the frequency of use of that style in the file, that
indicates the editor’s confidence in this being a “correct” setting. To be considered the “correct” setting, the
option must meet a confidence level of 66%. SlickEdit® ignores setting results with a confidence level of
less than 66% and they do not appear on the results dialogs. For these options, the current language
settings are used.
For example, if the dialog shows Indent with tabs enabled and a Confidence Level of 85%, this means
that out of all of the examined instances of this style in the file, 85% of them were indented with tabs, and
15% were indented with spaces.
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Click the Statistics button, and the Adaptive Formatting Statistics dialog shows each style that was found
and the total number of times it occurred in the examined instances. Each individual setting is categorized
in the tree according to type. Click on the plus/minus bitmaps to expand/collapse the tree categories.

Rescanning
Certain events require the file to be rescanned in case any formatting changes have occurred. These
events include beautification, auto-reload, and version control update. After one of these processes,
Adaptive Formatting is placed again in automatic mode, just as when you first opened the file, scanning
the entire file once for indent-type settings, then as you type for all of the other settings.
You can also rescan a file manually with the adaptive_format_update command. This clears the Adaptive
Formatting results from memory, then scans the entire file for all Adaptive Formatting settings available for
that language. This is useful if you want to create a new file and use different settings for it than what you
currently have configured.
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Completions
Completions save keystrokes as you are typing code by providing a way to automatically complete
partially-typed text. There are four types of completions in SlickEdit®:
•
•
•
•

Auto-Complete - A feature set that includes syntax, keyword, and symbol completions.
Word Completion - Completions that work for any text in an editor window.
Completion in Dialogs - Completions that work in dialog text box fields.
Command Line Completion - Completions for command line entries.

Auto-Complete
Auto-Complete offers suggestions for how syntax, keywords, symbols, and lines of code may be
completed by the editor. It works by looking at the word prefix under the cursor and using several different
queries to find and suggest completion options. Each of these types of suggestions can be individually
turned on or off, allowing you to customize auto-completion to your liking.

Using Auto-Complete
Auto-Complete is activated when the editor is idle for a short period of time and there is a partially-typed
word under the cursor. When Auto-Complete is active, the available completions are indicated in several
ways:
•
•
•

A light bulb appears on the left edge of the editor.
A list of completions appears under the word being typed.
The rest of the completed word or statement appears to the right of the cursor.

These visual hints can also be individually turned on or off through the Auto-Complete options. See
Language-Specific Auto-Complete Options.
TIP Auto-Complete can be activated manually by using the autocomplete command. Bind this
command to a key sequence if you use it frequently. See Creating Bindings for more information.
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To cancel out of Auto-Complete mode, use the Escape key.
To scroll through the items in the completion list, use the Up, Down, PgUp, and PgDn keys. Optionally,
you can use Tab and Shift+Tab to cycle through the choices.
If a completion is selected, you can press Space, Enter, or any non-identifier key to cause the selected
completion to be inserted along with the character typed (except for Enter).
Use Shift+Space to insert a real space rather than the completion. Use Ctrl+Shift+Space to insert the
next character of the currently selected completion. This can be useful if you only want part of the word
being completed and you do not want to type it yourself. Optionally, pressing Tab will cause autocompletion to attempt to insert the longest unique prefix match of all its completions.
If the completion has comments, you can use Shift+PageDown, Shift+PageUp, Shift+Home, or
Shift+End to page through the comments. Use Ctrl+C to copy the comments for the current item to the
clipboard.
Auto-Complete options can be configured on a language-specific basis. See Language-Specific AutoComplete Options for information.

Word Completion
Word Completions search the current editor window for text matching the prefix at the current cursor
position. Most completions are driven by Context Tagging®, matching symbols such as function names
and variables. Word Completions can match any text in the current editor window, including comments.
Auto-Complete also lists word completions, but it is often faster to use key bindings to search for and insert
Word Completions. The following is a list of commands for these operations and the key bindings in the
CUA emulation. See Creating Bindings to change them.
•

complete_prev (Ctrl+Shift+Comma) – Searches backwards through the current editor window to
find a match.

•

complete_next (Ctrl+Shift+Dot) – Searches forwards through the current editor window to find a
match.

•

complete_more (Ctrl+Shift+Space) – Adds subsequently more text from the matched line to the
cursor position, allowing you to extend the amount of text inserted.

The following example of code shows how word completion is used:
if (pWindowView->pBuffer->LineNum>100) {
pW<Cursor is Here>
}

Press Ctrl+Shift+Comma,Ctrl+Shift+Space,Ctrl+Shift+Space to obtain the following result:
if (pWindowView->pBuffer->LineNum >100) {
pWindowView->pBuffer->LineNum <Cursor is Here>
}

Pressing Ctrl+Shift+Comma matched “pWindowView” in the previous line. If you wanted to match an
earlier occurrence beginning with “pW”, press Ctrl+Shift+Comma to find the next previous match. This
also changed “pW” on the second line to the matching text, “pWindowView”. Pressing Ctrl+Shift+Space
extends that selection, matching “pWindow->pBuffer”. Pressing Ctrl+Shift+Space, again, extends the
selection to include “pWindow->pBuffer->LineNum”.
You can easily see how this would save time typing in multiple lines that access structs, class members,
arrays, etc.
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Completion in Dialogs
Many SlickEdit® dialogs contain fields that offer completions. Dialogs such as the Open dialog box (File >
Open) and the New Project dialog box (Project > New) contain text fields for file names or directory paths.
SlickEdit uses completions to help you enter values for these fields. When you type a character, SlickEdit
pops up a list of matching values.
When this list is displayed, the following keys have different behaviors:
Key

Behavior

Esc

Closes the list.

Enter

Uses the current value selected.

Tab, Down, or Ctrl+K

Moves to the next item in the list.

Shift+Tab, Up, or Ctrl+I

Moves up one item in the list.

Home or End

If an item is selected in the list, the cursor moves to the top or
bottom of the list, otherwise the cursor moves to the beginning
or end of the text box, respectively.

PgUp or PgDn

Moves up or down a page of items in the list.

Space

If an item is selected in the list, that item is used and you are
advanced to the next argument.

For a demonstration of how completions in dialogs work, complete the following steps:
1. From the main menu, click Project > New.
2. Press Tab to jump to the Location field.
3. Start typing a directory path. Notice the completion options.
4. Press Esc to cancel.

Argument Completion
For a larger list of possible matches, type “?” to list the matches. For a demonstration of how this works,
complete the following steps:
1. From the main menu, click Macro > Open Form.
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2. Type _open and the _open_form command is highlighted.
3. Press the question mark key (?) to display the Select a Command Parameter dialog. A selection
list of possible matches to an argument that is partially-typed is displayed.

Configuring Completion Settings
To configure Auto-Complete settings, from the main menu, click Tools > Options > Languages, expand
your language category and language, then select Auto-Complete. See Language-Specific AutoComplete Options for more information.
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Aliases
Aliases are identifiers that you can quickly type which are then expanded into snippets of text. You can use
aliases for any text that you frequently type, including directory paths, function names, statements, and
comment headers.
There are two types of aliases in SlickEdit®:
•

Global Aliases - These aliases can be used across multiple languages. They are also very useful
as directory aliases, because they save you from having to type long paths in file name or directory
fields within the editor.

•

Language-Specific Aliases - These aliases are set up on a per-language basis. For example, if you
work in multiple languages, you could have one alias identifier for the same function but with
different expansions applicable to each language.

Global Aliases
Global aliases work across all languages. One way to use global aliases is to save time in entering long
directory paths. See Directory Aliases below.

Directory Aliases
Directory aliases take advantage of the fact that most users are constantly opening files from a small
number of directories throughout the day. By using a directory alias when opening a file or changing
directories, you do not have to type in long paths or click the mouse repeatedly in directory and file name
fields within the editor.
After typing the alias identifier, directory aliases can be expanded by pressing Ctrl+Space. Global aliases
are stored in the file alias.slk, located in the SlickEdit® root installation directory.

Defining a New Directory Alias
Directory aliases typically consist of a short abbreviation of the last name in a long directory path. For
example, if you had a directory called c:\version20\src\project2\, a good alias name might be p2. For
compiler include files, define an alias called inc (vinc in Microsoft Visual C++, binc in C++ Builder®, or
ginc for GCC) if you have multiple compilers.
To define a new directory alias, complete the following steps:
1. From the main menu, click Tools > Options, then in the Options dialog tree, click Editing >
Global Aliases.
2. Click New, then type the characters you wish to use for an identifier in the Alias Name text box.
3. Click OK. The identifier you entered is now displayed in the alias list box on the options page.
4. Make sure your new identifier is selected, then in the large text box to the right, enter the alias
value by typing in the directory path that you want the identifier substituted with.
5. Click OK.

Using Directory Aliases
After the directory aliases are defined, you can use them in any text box or buffer, including the Build tool
window and the Open and Change Directory dialogs. For example, to use a directory alias in the Open
dialog, complete the following steps:
1. From the main menu, click File > Open (Ctrl+O).
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2. In the File name field, type the alias name (identifier) for the directory you wish to go open.
3. Press Ctrl+Space to expand the alias.

Embedding Environment Variables in Directory Aliases
If you keep source code in a version directory tree, you might want to set an environment variable and
embed the environment variable in the alias value. For example, if you have a directory named
c:\version20\src\project2\, define a p2 alias and give it a value such as %VERSION%\src\project2\.
Type the following command on the command line to set or create the VERSION environment variable:
set VERSION=c:\version20
For more information about setting environment variables, see Environment Variables.

Language-Specific Aliases
You can set up language-specific aliases for any frequently used text, such as comment headers. Each
language can have one alias file, allowing aliases to be defined that do not affect other languages.
Language-specific aliases are stored in files with the extension .als located in the user configuration
directory.
After typing the alias identifier, language-specific aliases can be expanded by pressing Ctrl+Space
(codehelp_complete command).
TIPS
•

If the alias is a Syntax Expansion modification, you can simply press Space to expand the
alias. See Syntax Expansion for more information.

•

An option is available to show a tool tip of the matching alias for the word under the cursor.
Click Tools > Options > Languages > [LanguageCategory] > [Language] > AutoComplete and check the option Alias expansion. See Completions for more information.

The aliases that you create in a language are made available each time you open or create a file in that
language. To manage language-specific aliases, from the main menu, click Tools > Options >
Languages, expand your language category and language, then select Aliases. As an example, the Java
Aliases screen is shown below.
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Alias names are displayed in the list box on the left. The value for the selected alias name is displayed in
the large text box to the right. Click Delete to remove a selected alias and its value.

Creating a Language-Specific Alias
To create a new alias, complete the following steps:
1. Click New, then type the characters you wish to use for an identifier in the Alias Name text box.
2. Click OK. The identifier you entered is now displayed in the list box in the Alias options page.
3. Make sure your new identifier is selected, then in the large text box to the right, enter the alias
value by typing in the text that you want the identifier substituted with.
4. Click OK.
TIPS
•

You can use special escape sequences in your aliases, which will be substituted upon
expansion with certain values. See Alias Escape Sequences for more information.

•

You can also specify parameters in alias values. When the alias is expanded, you are
prompted with a dialog to input the values. See Parameter Prompting for more information.
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Alias Escape Sequences
Alias escape sequences can be used in alias values. When the aliases are expanded, the sequences are
replaced with their values. The following table contains a list of the escape sequences that can be used for
aliases. For examples, see Escape Sequence Examples below.
Escape Sequence
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Description

%\c

Places the cursor. This sequence can be used multiple times
in the same alias value in order to create a series of “hot spots”
within the alias. After the alias is expanded, press Ctrl+[
(next_hotspot command) to jump to the next cursor stop.

%\d

Inserts the date (locale-dependent).

%\e

Inserts the date in MMDDYY format.

%\t

Inserts the time (locale-dependent).

%%

Inserts a percent character.

%\f

Inserts the current file name.

%\g

Inserts a file separator character. This is the backslash on
Windows (\) platforms and slash (/) on UNIX/Mac.

%\n

Inserts the current function name.

%\o

Inserts the current function name with signature.

%\i

Indents.

%\b

Unindents.

%\s

Preserves trailing spaces. This should be placed at the end of
a line.

%\l

Preserves leading spaces. This should be placed at the
beginning of the first alias line.

%\xColumnNumber

Moves the cursor to the specified column number.

%\x+ddd

Increments column by ddd.

%\x-ddd

Decrements column by ddd.

%\m MacroName
ArgumentList%

Calls the specified Slick-C® macro with a specified optional
argument.

%EnvironmentVariable%

Inserts the value of the environment variable specified.

%(ParameterName)

Parameter Prompting replacement. See Parameter Prompting
for more information.

%\m sur_text%

Indicates where the text to be surrounded is placed. See
Dynamic Surround and Surround With for more information.

%\p

Inserts parameters from the function that is located beneath it.
See Doc Comments for more information.
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Description

%\q

Insert the type for the parameters (double, integer, string, etc.)
from the function that is located beneath it. Typically used in
conjunction with the %\p escape sequence. See Doc
Comments for more information.

%\r

Inserts the return type from the function that is located beneath
it. See Doc Comments for more information.

%\u

Includes this line in the expansion, if there are any function
parameters that are expanded. If there are no function
parameters expanded, this line is not included in the full
expansion. See Doc Comments for more information.

%\v

Includes this line in the expansion, if there are any return types
that are expanded. If there are no return types expanded, this
line is not included in the full expansion. See Doc Comments
for more information.

%\un

If there are any function parameters that are expanded, this
line is not included in the full expansion. If there are no function
parameters expanded, this line is included in the full
expansion. See Doc Comments for more information.

%\vn

If there are any return types that are expanded, this line is not
included in the full expansion. If there are no return types
expanded, this line is included in the full expansion. See Doc
Comments for more information.

%()

Used to separate identifier characters. For example, %\u%()n
has the effect of the %\u option followed by a literal “n”. It is
recommended that %() be used to separate alias escape
sequences ending with a letter from other identifier characters
so that new aliases escape sequences won't break existing
aliases you have. Don't write %\dx. Write %\d%()x instead.

Escape Sequence Examples
The following table contains some examples of using escape sequences in alias values:
Alias Name and Description

Value

comment - A header comment to
have the date and time inserted.

**********************************************
**/
/* Date: %\d Time: %\t */
/
**********************************************
*/

if - A simple if statement, with
indenting, support for surround,
and a cursor position.

if(%\c){
%\i// Comment goes here
%\i%\m sur_text%
}
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Alias Name and Description

Value

ifelse - An if/else statement with
indenting and several cursor hot
spots.

if(%\c){
%\i%\c
} else {
%\i%\c
}

wm - A WinMain function
template with indenting and a
cursor position.

int APIENTRY WinMain(HANDLE hInstance,
HANDLE hPrevInstance,
LPSTR lpszCmdParam,
int nCmdShow)
{
%\i%\c
}

/** - A Javadoc comment.

/**
*
* %\c
*
* @author %\a (%\d)
* %\u
* @param %\p %\c
* %\v
* @return %\c%\v
*/

Parameter Prompting
Parameters can be set up for aliases, so that when the alias is expanded, you are prompted with a dialog
to input the values. This is useful for reducing even more key strokes for repetitive tasks when using
aliases that may require different values each time they are used.
To use parameter prompting, first define the parameters, then use them in your alias values by typing
%(ParamName) where ParamName is the name of the parameter that you have defined (see Creating an
Alias for Parameter Prompting below). When the alias is used and expanded, the Parameter Entry dialog
will appear, prompting you for the parameter values, which will then be inserted into your text.

Creating an Alias for Parameter Prompting
To create an alias for parameter prompting, complete the following steps:
1. Click New, then enter the new alias name. In the aliases list box (on the left side of the Alias page),
make sure the new alias is selected.
2. Click the Add button below the Parameters group box. The Enter Alias Parameter dialog is
displayed.
3. Enter the following values:
o

Parameter Name - Enter the name that you wish to use in the alias value.

o

Prompt - Enter the text that you wish to be prompted with. This is the label that will appear on
the Parameter Entry dialog that prompts for values after the alias is expanded.

o

Initial Value - (Optional) Enter the initial value of the parameter. This text will appear in the text
field of the Parameter Entry dialog that prompts for values after the alias is expanded.

4. Click OK.
5. If you wish to add more parameters, repeat Steps 2 through 4.
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6. On the Alias options page, the Parameters group box will now display a list of the parameters that
you have added.
7. In the large text field on the right side of the Alias options page, you can now type the alias value.
In the places where you want parameter prompting to occur, type %(ParamName), where
ParamName is the parameter name that you entered in Step 3.
8. Click OK when you are finished.
Example: Instantiating a Variable in Java with Parameter Prompting
In Java, instantiating variables can be a repetitive task. The following code shows a common Java code
snippet:
public class {
public static void main (String args[]) {
String x = new String( arg[0] );
}
}

You could define an alias for entering new class names with variables and arguments. That way, when you
press Enter after the third line and type and expand the alias, you will be prompted for the values.
For this alias, use the Parameters section of the Alias options page to first define three parameters:
class_name, var_name, and arg_list. Then, enter the following text for the alias value:
%(class_name) %(var_name) = new %(class_name)( %(arg_list) );

Creating a Language-Specific Alias from a Selection
You can create a language-specific alias from a selection by following the steps below.
1. Select some code.
2. Right-click and select Create Alias.
3. Give the alias a name and click OK.
4. The language-specific Alias options page appears, from which you can edit the code to fine-tune
or add parameters.
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Syntax Expansion
Syntax Expansion is a feature designed to minimize keystrokes, increasing your code editing efficiency.
When you type certain keywords and then press the spacebar, Syntax Expansion inserts a default
template that is specifically designed for this statement. For example, if you are using the C language and
type “for”, press Space and the following text expansion is inserted, with the cursor location between the
parentheses:
for() {
}

Additionally, for C, C#, C++, J#, Java, and Slick-C®, after the statement is expanded, you can use the
next_hotspot command (Ctrl+[) to jump the cursor to the next part of the statement. In the case of the for
loop above, Ctrl+[ would move the cursor from the group in parentheses to the code block.
The structures loop, if, and switch or case are also expanded. You do not have to type the entire keyword
for Syntax Expansion to occur. If there is more than one keyword that matches what you type, a list of
possible keyword matches is displayed. To get the C template displayed above, type “f” followed by
pressing Space.
To override the insertion of braces immediately for one line if, for, or while statements, type a semicolon
immediately after the keyword. For example:
if;

=>

if ( <cursor here> ) <next hotspot>;

To override non-insertion of braces immediately for if, for, while, foreach, with, lock, fixed, and switch
statements, type an open brace immediately after the keyword. For example:
if{

=>

if ( <cursor here> ) { <next hotspot> }

If the default behavior of Syntax Expansion does not match your coding style, for most languages, it can be
customized. From the main menu, click Tools > Options > Languages, expand your language category
and language, then select [Language] Formatting Options. See Language-Specific Formatting Options
for more information.
For further customization, for most languages, you can override the default keyword expansion by defining
an alias for that keyword. See Language-Specific Aliases for more information.

Syntax Expansion Settings
To access Syntax Expansion settings, from the main menu, click Tools > Options > Languages, expand
your language category and language, then select Indent.
To turn Syntax Expansion on or off, select or clear the option Syntax expansion. To change the minimum
expandable keyword length, enter the value by using the Minimum expandable keyword length spin
box.
To set options such as brace style, from the main menu, use the [Language] Formatting Options screen.
TIP SlickEdit® can display Syntax Expansion choices for the word prefix under the cursor. To turn
this option on/off, select the Auto-Complete language-specific options screen and select/clear the
Syntax expansion option. See Completions for more information.

Modifying Syntax Expansion Templates
Syntax Expansion templates are essentially language-specific aliases that have been pre-defined. You can
modify these templates by replacing them with your own.
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For example, to add a comment to the end of C for, while, if, and switch statements:
1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select Aliases.
2. Click New and then type for as the alias name.
3. Type the following lines in the text box to the right of the alias name:
for (%\c;;) {
} /* for */

The %\c escape sequence above specifies the cursor placement after expansion is performed.
4. Repeat Steps 5 and 6 for the while, if, and switch keywords.
5. Click OK to save new aliases.
The above steps replace the default Syntax Expansion templates for these keywords. The C brace style
options will not affect defined aliases.
For more information on working with aliases, using the Alias options page, or using alias escape
sequences, see Language-Specific Aliases.

Adding Syntax Expansion for Other Languages
To add syntax expansion and indenting for other languages, complete the following steps:
1. Use the prg.e macro as a template. This file is located in the macros subdirectory of your
installation directory. Make a copy of it and give it another name.
2. Change the #define constants EXTENSION and MODE_NAME near the top of the file to reflect
the new extension and mode name respectively. Do not use any spaces in these constants.
3. Change the name of the first five characters of the _command functions dbase_mode,
dbase_enter, and dbase_space to use the value given to the MODE_NAME constant in Step 2.
4. Modify the prg_expand_enter function to provide the Enter key the desired support.
5. Modify the prg_expand_space function to provide the spacebar key the desired support. If you
can rely on language-specific aliases, follow the comment in this function.
6. Use the load command Macro > Load Module to load new macro modules.
Steps 4 and 5 require a good understanding of the Slick-C® language and what this specific macro is
doing. See the Slick-C® Macro Programming Guide for more information.
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Quick Brace/Unbrace
Quick Brace makes it easy to convert single line statements into a brace-enclosed blocks, so you can add
new lines without having to manually position the cursor and type extra keystrokes. Unbrace removes the
braces from a block that contains a single line statement.
TIPS
•

As you write new code, SlickEdit® automatically expands statement templates for common
block structures (such as if, for, or while) when you type the initial keyword. See Syntax
Expansion for more information.

•

Quick Brace and Unbrace do not support code blocks containing multiple statements, but
you can use Dynamic Surround and Unsurround instead.

A single line statement is defined as a single line child statement that is not enclosed in braces, for
example:
if ( cond ) doSomething();

Hanging single line statements are often broken across two lines in the editor:
if ( cond )
doSomething();

Using Quick Brace/Unbrace
When you use Quick Brace, SlickEdit attempts to honor your brace style and indent settings. To use Quick
Brace, position the cursor where you would normally type the open brace, and type it. Using the preceding
code samples, you could position the cursor as follows:
if ( cond ) <cursor here>doSomething();

or
if ( cond )
<cursor here>doSomething();

After typing the opening brace, the child statement is moved to the next line if necessary, indented
according to your indent settings, and the closing brace is inserted automatically. The result on the
preceding code sample is:
if ( cond ) {
doSomething();
}

TIP Indentation and brace style settings are specified on the Formatting Options screen specific to
your language (Tools > Options > Languages > [LanguageCategory] > [Language] >
[Language] Formatting Options). For C-like languages, use the C/C++ Formatting Options screen.
Unbrace does the opposite of Quick Brace, removing the braces from a brace-enclosed block that contains
a single line statement and moving the statement to the preceding line that contains the parent statement
(unless it is just too long). To use Unbrace, simply delete the opening brace. Using the preceding code
example, the result is as follows:
if ( cond ) doSomething();
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You can use Unbrace on any brace-enclosed block that contains a single line statement, not just a block
that was created with Quick Brace. Unbrace works on any brace style.
Depending on the original brace style and the column location of the open brace, Unbrace either pulls the
statement up to the same line or leaves it hanging. The default column threshold is 40, which can be
modified by setting the configuration variable def_hanging_statements_after_col (Macro > Set Macro
Variable). Set the value to 1 for statements to always remain on the second line. Set the value to a very
large number to always pull up statements to the original line. See Setting/Changing Configuration
Variables for more information on setting variables.
Quick Brace and Unbrace work for C/C++ and similar languages that support brace blocks. Statements
such as if, while, and for are supported, as well as the handling of else clauses for if statements and the
splicing of the close brace with a trailing else.

Disabling Quick Brace/Unbrace
Quick Brace/Unbrace is on by default, and can be enabled/disabled on an language-specific basis. To
access this option, from the main menu, click Tools > Options > Languages, expand your language
category and language, then click [Language] Formatting Options and select or clear the option Quick
brace/unbrace one line statements.
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Dynamic Surround and Surround With
Two SlickEdit® features that allow you to surround text with text are Dynamic Surround, which lets you
surround existing statements with block statements, and Surround With, which lets you surround any
selected text with predefined language structures, or any text that you specify. Unsurround is also available
to remove outer code block structures from statements.

Dynamic Surround
Dynamic Surround provides a convenient way to surround a group of statements with a block statement,
indented to the correct levels according to your preferences. This feature works in conjunction with the
syntax and alias expansion features (see Syntax Expansion and Language-Specific Aliases), and is
designed to help you keep your hands on the keyboard, thereby improving your speed and efficiency.
Dynamic Surround is supported for any language that uses block statements. Note that this feature is lineoriented and will not work for character or block selections.
SlickEdit® enters Dynamic Surround mode automatically, immediately after you expand a block statement
(for instance, by typing if then pressing Space). After expanding the statement, a box is drawn around it as
a visual guide, and you can pull the subsequent lines of code or whole statements into the block by using
the Up, Down, PgUp, or PgDn keys. Pressing any other key or clicking with the mouse will exit Dynamic
Surround mode.
The following screen shot shows the Syntax Expansion menu that appears after typing “if” in a C++ file:

After pressing Space to expand the template, Dynamic Surround is activated, with a blue rectangle drawn
around the expanded statement, as shown below:
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Pressing the Down arrow key pulls the code block into the statement, indented to the correct levels, as
shown below:
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The finished code is shown as follows:
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Statements that are pulled into the block are indented according to your indent settings (see Syntax
Indent). The color of the rectangle box guide is controlled by the Block Matching screen element (see
Colors).
Syntax Expansion must be on for Dynamic Surround to work. Both options are on by default. To turn off
either of these options, from the main menu, click Tools > Options > Languages, expand your language
category and language, then select Indent. Clear the option(s) Use Dynamic Surround and/or Syntax
expansion.
If you need to move or modify existing text, you can manually enter Dynamic Surround mode by using the
dynamic_surround command. This will cause the code block under the cursor to be selected, and you
can use the navigation keys as described above to pull in statements. By default, this command is not
associated with a key binding. See Creating Bindings for information on creating your own.

Surround With
Surround With makes it fast and easy to wrap existing lines of code in a new block structure. Surround
With is supported for the languages C, C++, C#, HTML, Java, JavaScript, and XML. Highlight the lines to
surround, right-click, and select Surround Selection With, or use the surround_with command. The
Surround With dialog appears, with a pre-defined list of structures based on the current file extension.
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Select the structure you wish to surround with, then click OK.
If there is no selection and you activate Surround With, the current line or code block will be automatically
highlighted for surrounding (the same function performed by the select_code_block command).
TIP The surround_with command has a button available for toolbar customization. See
Customizing Toolbars for more information about creating your own custom toolbars.

Modifying Surround With Templates
Surround With templates are created and modified the same way as other aliases, with the addition of the
%\m sur_text% escape sequence. This sequence indicates where the selected text should be placed, and
can be used multiple times within a single Surround With template. See Surround With Commands for
more information on sur_text.
To view or modify the Surround With templates, use the surround_with command to display the Surround
With dialog, then click the Customize button. This will display the language-specific Alias options page
with the Surround With option selected. As an example, the C Alias options page is shown below.
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The list of Surround With structures for the chosen language is shown in the list box on the left. To modify
one of the Surround With structures, complete the following steps:
1. Select the structure that you wish to modify. Notice the template for the structure that appears in
the text box on the right.
2. Modify the template to suit your needs. For a list of escape sequences and template examples,
see Alias Escape Sequences. For more information about using the Alias options page, see
Creating a Language-Specific Alias.
3. When you are finished, click OK on the Alias options page.
4. Click OK on the Surround With dialog.

Surround With Commands
There are three commands available for working with Surround With:
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•

surround_with - This command is used to display the Surround With dialog, allowing you to pick
a structure to surround selected text with. This command can be bound to a key—see Creating
Bindings for more information.

•

sur_text - This is a Slick-C® function that can only be used inside of a Surround With template. It
is used to indicate where the selected text should be placed and can be used multiple times within
a single Surround With template. sur_text can take several parameters, which can appear in any
order. The available parameters are:
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•

o

-beautify - This is the default for C, Java, and others. It beautifies the results of the template
expansion.

o

-begin text - Prefixes each line of the selection with text.

o

-deselect - This is the default parameter. It specifies to leave the text deselected.

o

-end text - Suffixes each line of the selection with text.

o

-ignore chars - The -begin, -indent, and -stripbegin options will ignore any chars when
finding the beginning of the selected line.

o

-indent - Indents each line of the selection.

o

-nobeautify - This is the default for HTML, XML, and others. It specifies that the editor should
not attempt to beautify the results of the template expansion.

o

-notext - Specifies that no text should be pasted.

o

-select - Leaves the text selected.

o

-stripbegin text - If any line begins with text, text is removed from the line. This option is
applied before -begin.

o

-stripend text - If any line ends with text, text is removed from the line. This option is applied
before -end.

surround_with_if - This is a wrapper command that expands the if template for the selected text.
This command can be bound to a key—see Creating Bindings for more information.

The use of Surround With can be streamlined by using wrapper commands and key bindings. You can
create your own wrapper commands. The following example is the definition of surround_with_if
_command void surround_with_if() name_info(',':
VSARG2_REQUIRES_EDITORCTL | VSARG2_MARK | VSARG2_REQUIRES_AB_SELECTION)
{
surround_with('if');
}

You must change the name of the command and the argument passed to surround_with. The argument
does not have to be an exact match with the template name. For instance, calling surround_with('i') will
prompt you to select the if, if...else, or include once template. If there is an exact match, that template will
be used. In the case of surround_with_if, “if” matches the beginning of both the if and if...else templates,
but the if template is used because it is an exact match.
After you create your wrapper command, you can bind it a key or invoke it from the command line.
For more information on working with commands, see the Slick-C® Macro Programming Guide.

Unsurround
Unsurround is a feature that lets you remove the surrounding text from a code block. This is particularly
effective when used with Dynamic Surround. Unsurround is supported for the following languages:
ActionScript, AWK, C#, C++, CFML, HTML, Java, JavaScript, Perl, PHP, Slick-C®, Tcl, and XML.
To use Unsurround, right-click on a selected code block and select Unsurround, or use the unsurround
command.
For example, to remove the if statement structure from a code block, select the code block or part of the
code block, then right-click and select Unsurround (or use the unsurround command). The entire code
block under the cursor is automatically highlighted and a dialog prompt appears to confirm the unsurround
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operation. Click OK, and the if line of the code block as well as the line containing the closing brace are
removed. The remaining code is unindented to the correct level.
TIP The unsurround command has a button available for toolbar customization. See Customizing
Toolbars for more information about creating your own custom toolbars.

Deleting Code Blocks
Unsurround is also associated with the cut_line (Ctrl+Backspace) and delete_line (Ctrl+Del)
commands. When one of these commands is invoked while the cursor is on the first line of a block
statement, the Delete Code Block dialog appears, from which you can choose to delete the line, delete the
entire block, or unsurround the block.

Each of these operations copies the removed text to the clipboard. This is useful if you want to paste the
structure into a different location, because as soon as the text is pasted, SlickEdit® enters Dynamic
Surround mode, allowing you to pull statements into the pasted block.
The Delete Code Block dialog also contains an option to Always just delete line when cut_line or
delete_line operations are invoked. Selecting this option will prevent the dialog from appearing when
these operations are used. To see the dialog again, use the cut_code_block command.

294

SlickEdit® User Guide

BOOKMARKS

Bookmarks
Bookmarks are used to save the current edit location, so you can quickly return to it later. There are two
types of bookmarks:
•

Named Bookmarks - Used to mark long-term, meaningful locations in the code, or to quickly set a
temporary, named bookmark on the current line.

•

Pushed Bookmarks - Used to set temporary “breadcrumbs” as you explore the code. Pushed
bookmarks are manipulated separately from named bookmarks.

Bookmark options for named and pushed bookmarks can be found under the Bookmarks category on the
Search Options screen of the Options dialog (Tools > Options > Editing > Search).
A set of bookmark controls for named and pushed bookmarks is available for adding to your custom
toolbars. See Customizing Toolbars for more information.

Named Bookmarks
Named bookmarks are great for marking long-term, meaningful locations in your code. For example, if you
have a project with a lot of include files, you might want to bookmark the top of the main header file. Or you
could bookmark a file with instructional comments about a particular project you’re working on.
In addition to menu items and command line operations, a Bookmarks tool window (View > Toolbars >
Bookmarks) is available for creating and managing named bookmarks. See Bookmarks Tool Window for
more information.
See the following sections for more information about working with named bookmarks:
•
•
•
•

Setting Named Bookmarks
Navigating Named Bookmarks
Deleting Named Bookmarks
Using Workspace Bookmarks

Setting Named Bookmarks
There are various ways to use named bookmarks, and the way you set them depends on which way you
want to use them:
•

Give them a specific name - Creating a bookmark and naming it yourself is one of the best ways
to mark a location in your code. For example, you could set a bookmark named “main” to save the
location of the main function. See Setting a Bookmark With a Specific Name.

•

Allow automatic naming - This is a quicker way to set named bookmarks. This method could be
useful to mark locations that you temporarily need to reference, perhaps only in the current editing
session. See Setting a Bookmark With an Automatic Name.

•

Use a key binding shortcut for the name - The quickest way to set and navigate named
bookmarks is to name according to a specific key binding. This method lets you create a bookmark
with one key binding, and navigate back to the bookmark with a similar key binding. See Setting a
Bookmark With a Key Binding.

After setting a named bookmark, a green bitmap is displayed in the left margin of the editor window,
indicating the location of the bookmark. Use the Show set bookmarks option to enable or disable the
display of the indicator (Tools > Options > Editing > Search).
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Setting a Bookmark With a Specific Name
There are several different ways to set a bookmark on the current line and give it a name:
•

Using the Bookmarks Tool Window, click the Create a New Bookmark button.

•

From the main menu, click Search > Set Bookmark. The Bookmarks Dialog is displayed. Type
the name of the bookmark in the combo box, then click Add.

•

On the SlickEdit® command line, use the set_bookmark or sb command. The sb command is a
shortcut for set_bookmark, so you can use whichever you prefer. If you use the command without
arguments, the Bookmarks Dialog is displayed. Or, you can append sb or set_bookmark with any
character or text string, and a bookmark will be instantly set using that value for the name. This
works best in conjuction with the goto_bookmark (or gb) command, because you can use sb 1
on the command line to create an instant bookmark named “1”, and then navigate back to that
bookmark at any time by using gb 1. See Navigating Named Bookmarks for more information.

Setting a Bookmark With an Automatic Name
Most of the methods described in the section for Setting a Bookmark With a Specific Name display a dialog
that prompts for the name of the new bookmark. In each case, SlickEdit® prepopulates the name field with
an automatic name that you can use if you don’t want to specify your own name.
The automatic name will be in one of two formats: SymbolName:LineNumber, or
FileName:LineNumber. The symbol name is used if the bookmark is inside of a symbol. The file name is
used if there is no symbol on the line or if the file does not support Context Tagging®.
While you can use the methods described in Setting a Bookmark With a Specific Name, the quickest
method of setting a named bookmark with an automatic name is to use the Toggle Bookmark feature,
which instantly sets an automatically named bookmark and lets you toggle it on and off. To use this feature,
from the main menu, click Search > Toggle Bookmark, press Ctrl+Shift+J, or use the toggle_bookmark
command.

Setting a Bookmark With a Key Binding
You can set a bookmark that takes its name from the key used to set it. There are two commands that can
be used: alt_bookmark, for setting a bookmark, and alt_gtbookmark, for navigating to the bookmark.The
purpose of these commands is so that you can bind them to keys, providing a way for you to have one type
of keyboard shortcut for setting the bookmarks, naming them in the process, and another for navigating to
the bookmarks.
These commands can be bound to any of the following keys/ranges:
•

Ctrl+[0-9], Ctrl+[A-Z], Ctrl+[F1-F12]

•

Alt+[0-9], Alt+[A-Z], Alt+[F1-F12]

•

Ctrl+Alt+[0-9], Ctrl+Alt+[A-Z], Ctrl+Alt+[F1-F12]

•

Shift+[F1-F12]

For example, you could bind alt_bookmark to Ctrl+[0-9] and alt_gtbookmark to Alt+[0-9], for a more
efficient means of setting bookmarks named “0” through “9”, and navigating back to them. See Working
with Key Binding Ranges for more information.
NOTE Different emulations have different default assignments for alt_bookmark and
alt_gtbookmark. Use the menu item Help > Where Is Command to see what keys are set up by
default in your emulation. See Using the Command Line to View Key Binding Associations for more
information.
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Navigating Named Bookmarks
To jump to and navigate between your named bookmarks, use one of the following methods:
•

From the main menu, click Search > Previous Bookmark or Search > Next Bookmark (or use
the prev_bookmark and next_bookmark commands, respectively). The order of navigation
matches the order in which the bookmarks were created. These operations are also available on
the Bookmarks Tool Window.

•

Use the Go to Bookmark feature: From the main menu, click Search > Go to Bookmark, or, use
the goto_bookmark command or the gb command. The gb command is a shortcut for
goto_bookmark, so you can use whichever command you prefer. This displays the Go to
Bookmark Dialog, from which you can select a bookmark to navigate to.

TIP When you use the Go to Bookmark dialog to jump to a named bookmark, SlickEdit® pushes a
bookmark in the process. To get back to where you were, press Ctrl+Comma. See Pushing and
Popping Bookmarks.
•

You can also append goto_bookmark or gb with the name of the bookmark to go directly to that
bookmark’s location in the code. This works best in conjuction with the set_bookmark (or sb)
command. For example, you can set a bookmark named “1” by using sb 1 on the SlickEdit
command line, then use gb 1 to navigate back to that location. Command Line Completion is
supported to assist you with typing the name of the bookmark. See also Setting a Bookmark With
a Specific Name.

Deleting Named Bookmarks
To remove a named bookmark, use one of the following methods:
•

Using the Bookmarks Tool Window, select the bookmark to delete and click the Delete Selected
Bookmark button or press the Delete key.

•

When the cursor is on the bookmark line, use the Toggle Bookmark feature to toggle that
bookmark off (in effect, deleting it): From the main menu, click Search > Toggle Bookmark, or,
press Ctrl+Shift+J or use the toggle_bookmark command. Use the feature again to toggle the
bookmark back on.

•

On the SlickEdit® command line, use the delete_bookmark command with the name of the
bookmark to delete. For example, if the bookmark to delete is named “1”, type
delete_bookmark 1 on the command line. Command Line Completion is supported to assist you
with typing the name of the bookmark.

•

On the Bookmarks Dialog or Go to Bookmark Dialog, select the bookmark to remove and click
Delete.

To remove all named bookmarks at once:
•

Using the Bookmarks Tool Window, click the Delete All Bookmarks button.

•

On the SlickEdit® command line, use the clear_bookmarks command.

Using Workspace Bookmarks
By default, named bookmarks are global and are not associated with a specific workspace (see Managing
Workspaces). However, you can choose to associate your bookmarks with a workspace instead. When
you use workspace bookmarks, the Bookmarks Tool Window (and other dialogs that show bookmarks)
only displays bookmarks that are associated with the current workspace. You can set bookmarks for files
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that are not in the current workspace. To enable workspace bookmarks, set the Use workspace
bookmarks option to True (Tools > Options > Editing > Search).

Pushed Bookmarks
Pushed bookmarks are used to set temporary “breadcrumbs” as you move throughout your code. For
example, you may have multiple spots in your code that you want to examine. You can push a bookmark
(drop a breadcrumb) at each location, one right after the other. When you’re done examining the code and
pushing bookmarks, you can backtrack to where you first started by popping the bookmarks (picking up
the breadcrumbs).
Pushed bookmarks are stored on the bookmark stack, which is simply an internal list of pushed
bookmarks. When you push a bookmark, the current line is placed on top of the bookmark stack. Popping
a bookmark removes the top bookmark from the stack, and navigates the cursor to the location of the
previous bookmark.
Pushed bookmarks are deleted when you close SlickEdit®.
See the following sections for more information:
•
•
•

Pushing and Popping Bookmarks
Viewing Pushed Bookmarks
Pushed Bookmark Options

Pushing and Popping Bookmarks
To push a bookmark for the current line, placing it on top of the bookmark stack, use one of the following
methods:
•

From the main menu, click Search > Push Bookmark (or use the push_bookmark command).

•

Use the Go to Definition or Go to Reference feature: Press Ctrl+Dot (bound to the push_tag
command) to move the cursor from a symbol to its definition, or Ctrl+/ (bound to the push_ref
command) to navigate from a symbol to its reference, pushing a bookmark in the process. See
Symbol Navigation for more information.

To pop a bookmark, from the main menu, click Search > Pop Bookmark, press Ctrl+Comma, or use the
pop_bookmark command. The top bookmark on the stack is removed and the cursor jumps to the
location of the previous bookmark.
To pop all pushed bookmarks at once, use the pop_all_bookmarks command.
TIP When you use the Go to Bookmark dialog to jump to a named bookmark (see Navigating Named
Bookmarks), SlickEdit pushes a bookmark in the process. This way you can quickly go back to your
previous location.

Viewing Pushed Bookmarks
In most use cases, you will never need to see pushed bookmark locations or a list of pushed bookmarks,
because they are intended to act as temporary “breadcrumbs” as you explore your way through code.
However, there are two ways to see visual representations of pushed bookmarks:
•
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Enable the visual indicator - SlickEdit® can display a blue bitmap in the left margin of editor
windows at the location of each pushed bookmark. To enable display of the indicator, set the
Show pushed bookmarks option to True (Tools > Options > Editing > Search).
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•

Use the Bookmark Stack dialog - SlickEdit provides a Bookmark Stack dialog that shows a list of
all pushed bookmarks that are currently set. To display it, from the main menu, click Search >
Bookmark Stack, or use the bookmark_stack command. The Bookmark Stack dialog can also
be used to navigate between and delete pushed bookmarks. See Bookmark Stack Dialog for more
information.

Pushed Bookmark Options
There are several options for pushed bookmarks:
•

When using Symbol Navigation (Go to Definition or Go to Reference), if SlickEdit® opens a file
that was not previously open and you navigate away from it, SlickEdit prompts to close the visited,
unmodified file. To remove the prompt and specify the default action, set the option Automatically
close visited files (Tools > Options > Appearance > General). See Automatically Closing
Visited Files for more information.

•

To delete pushed bookmarks automatically when a file is closed, set the Close deletes pushed
bookmarks option to True (Tools > Options > Editing > Search). SlickEdit automatically deletes
pushed bookmarks when the editor is closed.

•

SlickEdit can automatically push a bookmark whenever you jump to the top or bottom of the buffer
(Ctrl+Home/Ctrl+End, or top_of_buffer/bottom_of_buffer commands, respectively). This is
convenient, for example, in C++: if you jump to the top of the buffer to add a #include statement, a
bookmark is pushed, so you can use Ctrl+Comma (pop_bookmark command) to get back to
your previous position. To enable this behavior, set the Top/bottom buffer pushes bookmark
option to True (Tools > Options > Editing > Search). Note that this option corresponds to the
def_top_bottom_push_bookmark configuration variable.
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Code Annotations
Code Annotations Overview
Code Annotations provide a mechanism to store information about the code without actually modifying the
code. Unlike code comments, code annotations are not stored in the source file but in an external file. The
information you record is associated with a specific location in the code and can be viewed while you work
on a source file.
You can use Code Annotations for recording various information, like comments about something that
needs to be changed, tasks that need to be performed (see Using Code Annotations to Record Tasks), or
comments in preparation for a code review (see Using Code Annotations for Code Reviews). Anything you
can record in a code comment can be stored in a Code Annotation.
Because code annotations are not stored in the source code, you can use them to record private
information you don’t want to share with the rest of the team. Or you can use code annotations to record
information that is shared with the team but should never be visible in the source code.

Annotation Types
Each annotation contains a set of data fields specific to that type of annotation. All annotations contain a
set of default fields, including the author who created or last edited this annotation, and the date this
annotation was last changed. Code annotations used for different purposes also include specific fields
related to that purpose. For example, a task annotation will also have a due date and a field to record the
person who has been assigned this task. A code review annotation will include a text field for the proposed
resolution and a status field indicating whether this change was accepted or rejected.
SlickEdit® provides some predefined annotation types, but you can create your own by specifying the set
of fields contained. For each field, you specify the name of the field, the type of the field, and the default
value. When an annotation of that type is created, you are prompted for these values. See Managing
Annotation Types for more information.

Purpose-Based Locations
When you create a code annotation, you specify where it is to be stored. You select the location based on
the purpose of the annotation. The location can be one of these values:
•

Personal - These annotations are for your own use and not intended to be shared with others.
Personal annotations are stored in your configuration directory. They are not specific to any
workspace.

•

Workspace - Used to record information about files in the current workspace. The annotation file
is stored in the same directory as your workspace file (.vpw) and uses the same base file name
but with a different extension. These are intended to be shared with anyone else working in this
workspace, so the annotation file should be checked into source control.

•

Project - Used to record information about files in a specific project. The annotation file is stored in
the same directory as your project file (.vpj) and uses the same base file name but with a different
extension These are intended to be shared with anyone else working on this project.

•

User-Defined - These annotations are stored in a file of your choice. These annotations cannot be
readily shared since they store a full path to the referenced file. Unless two users have the same
directory structure on their machines, the annotations will not be able to locate the referenced
source files.
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Workspace and Project annotations are very similar. If you don’t create too many annotations, you could
save all of your annotations as Workspace annotations. However, if you have projects that are shared
between workspaces, you should use Project annotations so that the information is available regardless of
which workspace you are using. If you create a lot of annotations, you may wish to use Project instead of
Workspace so that you can view the list of annotations for a single project, providing a way to view a more
manageable subset of annotations.
See Managing Annotation Files for more information.

Private and Shared Annotations
Code annotations can be private or shared. Annotations are shared by sharing the annotation file with
other users. Like source files, annotation files are most easily shared using a version control system.
Only Workspace and Project annotations can be shared effectively. Because they refer to files in the
workspace or project, the path to those files is stored relative to the workspace or project. Even if users
have the same workspace in different directories, SlickEdit® will be able to locate the source files
referenced by annotations. Personal annotations and User-Defined annotations are not sharable. They
store a fully qualified path to the referenced file. Unless two people have the same directory hierarchy on
their machines, SlickEdit will not be able to located the referenced source files.

Relocatable Code Marker
Code Annotations use a relocatable code marker to store the location within the source code. This allows
SlickEdit® to find the new location if someone makes edits to the file externally, like editing the file with a
different editor. The next time you open the file, SlickEdit checks the location of each code marker and
verifies that it is still correct. If necessary, SlickEdit uses stored information to locate the correct line of
code for this annotation. If the code has changed too much, SlickEdit may not be able to find the new
location, and you will be prompted to find the new location yourself. This will only happen when the code
near the code marker has been heavily edited.

Annotations Tool Window and File Manager
SlickEdit® provides a Code Annotations tool window that lists all of the currently visible annotations. This
tool window allows you to filter the set of visible annotations. The primary filter is by type. If annotations of
more than one type are displayed, only the default fields common to all annotations are displayed in the
annotation list. You can use the tool window to create, edit, and delete code annotations as well. See
Managing Annotations for more information.
Code Annotations are stored in files, and they become visible when the annotation file is opened. SlickEdit
automatically opens the annotations from your personal annotations file along with those from the
workspace and project annotation files. You can use the Annotation File Manager to open any other
annotation files you like. See Managing Annotation Files for more information.

Managing Annotations
The Code Annotations tool window provides a detailed view of annotations that you have created as well
as operations for adding, modifying, copying, moving, and removing annotations. From this window, you
can also manage annotation files and create your own annotation types.
To display the tool window, from the main menu click View > Toolbars > Code Annotations, or use the
annotations_browser command on the SlickEdit® command line.
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Creating Annotations
Creating a code annotation is similar to setting a bookmark or breakpoint. To create a new annotation:
1. From within the editor window, position the cursor on the desired line of code.
2. There are three methods for initiating a new annotation, after which the New Annotation dialog is
displayed:
o

Right-click and select Create Code Annotation.

o

Click the Add

o

Use the new_annotation command on the SlickEdit® command line.

button on the Code Annotations tool window.

3. On the New Annotation dialog, select an Annotation Type from the drop-down list.
4. Select where the annotation is to be stored from the Annotation File drop-down list (see
Managing Annotation Files), then click OK.
5. SlickEdit displays a dialog with fields matching the selected annotation type. Some of the fields are
common to all annotation types, while others are specific to the chosen annotation type. Some of
the values, like author, creation date and time, and source file where the annotation marker is
located, are presented read-only, since they cannot be changed. Each dialog also contains
specific fields applicable to the annotation type:
o

Comment - The Comment Annotation dialog provides a box for typing a text comment.

o

Task - The Task Annotation dialog provides boxes for typing the name of the person this task
is assigned to, the due date, and a description. Note that the Due Date field allows any text
input.

o

Review Comment - The Review Comment Annotation dialog provides boxes for typing an
issue, a resolution, and a status.
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6. After entering the annotation details, click OK.

Viewing and Filtering Annotations
Annotations in your source code are indicated with a yellow Annotation bitmap
in the left margin of the
editor window. Hover the mouse over a bitmap to see a preview of the annotations on that line.
The Code Annotations tool window is used to view and work with a list of your annotations and displays
them in a table format, by default, in the order of last operation. Click on any column header to sort by that
column. When you sort, an arrow on the column header shows the ascending or descending order. Drag
the column size bars to resize columns to your desired width.
The Show Types area lets you choose what types of annotations to display in the tool window. Click and
drag the separator bar to resize this area.
A preview pane, located on the right side of the tool window, shows the details of the selected annotation.
This pane can also be resized by clicking and dragging the separator bar.
By default, the tool window view is set to show all annotations. To view only annotations of a specific type,
select it in the Show Types list. Click (Show All) to display all annotations again. When (Show All) is
selected, only the default fields common to all annotations are displayed in the annotation list.
To filter the list of visible annotations, use the filter boxes at the top of the tool window. Use the Filter on
Column drop-down list to select a column to filter by. When you select a column, the Filter Key drop-down
list is populated with all of the entries for that column, and you can select the item that you want displayed.
For example, to see all annotations that share the same author, select Author in the Filter on Column
drop-down, then select the author’s name from the Filter Key drop-down list.
Double-click on an annotation in the tool window to go to the location of the annotation in the source code.
You can also select Go to Annotation from the right-click context menu, or use the
show_annotation_source command on the SlickEdit® command line. Note that this command only
works from within the tool window.

Copying and Moving Annotations
Copying
You can create a new annotation by copying an existing one. This is useful if you have similar lines of code
that need to have similar annotations. From within the Code Annotations tool window, select the code
annotation to copy, then click the Copy button
. Alternatively, right-click on a selected annotation and
select Copy. When you copy an annotation, your name is assigned as the author.

Moving
Click the Relocate button
current file.

on the tool window to move the selected annotation to the current line in the

Alternatively, you can click and drag the yellow Annotation bitmap
in the editor window margin to the
desired location. If the line contains multiple annotations, the first annotation is moved.
NOTE You cannot move annotations between files. If the selected annotation is not located in the
current file, the Relocate button on the tool window is unavailable.
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Editing Annotations
SlickEdit® allows you to edit the data that was entered for existing annotations. You cannot change the
original source file, author, date, or annotation file, but the data entry fields can be edited.
To edit an existing annotation, from within the Code Annotations tool window, select the annotation to edit
then click the Edit button
. You can also right-click in the tool window and select Edit or use the
edit_annotation command on the SlickEdit command line. Note that this command will only work for an
item selected in the tool window.

Deleting Annotations
To delete an annotation, from within the Code Annotations tool window, select the annotation to delete then
click the Delete
button. You can also right-click and select Delete or use the delete_annotation
command on the SlickEdit® command line. Note that this command will only work for an item selected in
the tool window.

Managing Annotation Types
SlickEdit® provides several predefined annotation types: Comment, Task, and Review Comment. To
define your own annotation types, from the Code Annotations tool window click the Annotation Types
button
, or use the annotation_definitions command on the SlickEdit command line. The Annotation
Types dialog is displayed.

Creating a new annotation type is similar to creating a form. First you define a name, then you define the
fields. The name that you give the new type will be the title of the dialog that appears when you create a
new annotation of that type. The fields that you define will be the fields that are available on the dialog.
To create a new annotation type:
1. In the Types area, click the green Plus button.
2. Type a name for your new annotation type.
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3. In the Fields area, click the green Plus button.
4. From the Field Type drop-down list, choose the type of control you want to use, then click OK.
5. The third area on the Annotation Types dialog is now populated with the Field Type that you just
added. Click the green Plus button in this area to define values for the control.
6. Repeat Steps 3 through 5 to add more fields to your new type. Use the Up/Down arrows to control
the order in which the fields should appear on the form.
7. Repeat these steps to define additional types.
8. Click OK on the Annotation Types dialog when finished.
Now, when you create a new code annotation, you can use the newly defined type(s) that will be displayed
in the Annotation Type drop-down list on the New Annotation dialog.
To delete the selected type or a field, click the red X button next to the Types or Fields area.
NOTE In this version of Code Annotations, the Date Control field type just stores dates as text.
Columns of this type are sorted lexicographically, not by date. We plan to introduce true date
processing in a subsequent release. In the meantime, you can get the best result for dates by storing
them in this format: yyyy/mm/dd. For example, 2007/07/04. This will allow dates to sort correctly.

Handling Annotation Type Conflicts
Every annotation file contains the annotation type definitions for the annotations it contains. If a user
modifies the type definition for an annotation, it will conflict with the type definition for annotations in other
files. All annotation types by the same name must have the same definition. SlickEdit® detects any
discrepancies between types and tries to rectify them.
When two conflicting types are found, SlickEdit prompts you for which definition to use. Once you have
selected the master type, SlickEdit attempts to correct annotations that matched the other type. The
resolution depends on the category of the change:
1. Field added - The new master type contains a field not present in the other version of this
annotation type. SlickEdit will add the new field to all annotations of that type the next time they are
saved.
2. Field deleted - The new master type is missing a field that is present in the other version of this
annotation type. SlickEdit will delete that field from all annotations of that type the next time they
are saved. This will result in the data in that field being lost.
3. Field modified - The new master type contains a field by the same name as a field in the other
annotation type but the definition of the two fields differ. SlickEdit will attempt to coerce the data
from the one type to the other. Since all data is stored as text, this will work in many cases. In
some cases this will result in data loss. For example, if data is coerced from a text type to a
discrete type (like Dropdown, List, or Checkbox), data will be lost if the text value doesn’t match
one of the predefined values for this control.
This system for resolving conflicts in Annotation Types does not allow you to merge two sets of changes to
the same type. For example, if two users both add a field to the same type, one of them will be lost.
Because of this, changes to annotation types should be made in a deliberate, planned manner and rolled
out to the team in a way that avoids this issue. When a shared annotation type needs to be changed, have
one person make that change and distribute a document with that type. The rest of the team can update
their annotation files by opening that document while other documents are open. Remember, there is no
centralized repository for annotation types, so conflict resolution is only performed on the set of open
documents. To update multiple workspaces, you will have to open each workspace and then open the
document containing the changed type.
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To avoid conflicts in your personal annotation types, you may want to create your own types. Conflict
resolution is performed using the name of the annotation type to uniquely identify a type. If the types you
use in your personal annotations have their own, unique names then you can avoid conflicts with
annotation types in other documents.

Managing Annotation Files
Code annotations are stored in files with a .sca extension. There are four types of locations for these files,
based on the purpose of the annotation: Personal, Workspace, Project, and User-Defined. Each of
these are “aliases” that correspond to a path on your computer where the annotation file is stored. You
specify the location when you create new code annotations by selecting from the Annotation File dropdown list on the New Annotation dialog.

Personal Annotations
Personal annotations are for your own private use and are not specific to any workspace or project. They
are stored in the personal.sca file located in your configuration directory.

Workspace Annotations
Workspace annotations are used to record information about files in the current workspace. They are
intended to be shared with others using the same workspace, so you can check the annotation file into
source control. These annotations are stored in a .sca file located in the same directory as your
workspace file (.vpw). The base file name is the same as your workspace base file name, except it is
appended with “_workspace”. For example, if your workspace is named Diff.vpw, your Workspace
annotations are stored in Diff_workspace.sca in the same directory.

Project Annotations
Project annotations are used to record information about files in projects. They are also intended to be
shared with others using the same project, and can be checked into source control. Project annotations
are stored in a .sca file located in the same directory as your project file (.vpj). The base file name is the
same as your project base file name, except it is appended with “_project”. For example, if your project is
named Diff.vpj, your Project annotations are stored in Diff_project.sca.

User-Defined Annotations
User-defined annotations are stored in a file of your choice, and can be kept private or you can share them
if you want. You will need to specify a location path for user-defined annotations prior to creating new
annotations for this location type. This is done through the Annotation File Manager.
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Annotation File Manager
You can view annotation file information and add, open, or close user-defined annotation files by using the
Annotation File Manager. It can be accessed from the Code Annotations tool window by clicking the
Annotation Files

button.

The top of the dialog contains a list of all annotation files that are currently open, showing the alias, the
name of the file, and the location path. Click on any column header to sort by that column. An arrow in the
header indicates the ascending or descending sort order. Click and drag to resize any column. You can
also click and drag the horizontal separator bar to resize the entire Annotation Files area.
Personal, Workspace, and Project annotation files are always open and displayed. User-defined
annotation files are also displayed if you have created them and they are open.
Use the buttons on the Annotation File Manager to perform the following operations on User-defined
annotations:
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•

Click the New Annotation File button
to create a new User-Defined annotation file. The New
dialog is displayed where you can specify the name and path of the new file.

•

Click the Open Annotation File button
to open the selected User-Defined annotation file. The
Open dialog is displayed where you can specify an annotation file to open (note that annotation
files have the extension .sca).

•

Click the Close Annotation File button
to close the selected User-Defined annotation file.
Closing an annotation file removes its associated types from the list when creating new
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annotations, and also removes the margin indicators for the associated annotations. This is useful
to prevent cluttering, should the annotation file have many types or many annotations.
The bottom of the Annotation File Manager contains details about the selected file. The Annotation File
Comments area shows a tree view of the annotation types and the specific annotations that are contained
in the file. Click and drag the separator bar to resize this area. When you select a task or annotation in this
list, details are shown on the right. If a task type is selected, the dialog displays the fields and details for
that type. If an annotation is selected, the dialog displays the contents of that annotation.
The Version Info area displays the version information for the selected type or annotation, include the
original author, date of creation, version number, and the author and date of the last edit, if applicable.

Using Code Annotations to Record Tasks
Code annotations provide a convenient mechanism to record tasks associated with specific locations in
the code. You can use Personal annotations to record your own tasks, or use shared annotations to assign
tasks to another team member.
SlickEdit® includes an Annotation Type for tasks, called Task. Along with the standard fields, it adds three
additional fields: Assigned To, Due Date, and Description. Follow the instructions in Creating
Annotations to create a new task annotation, and select the Task annotation type.
If this is a personal task, select (Personal Annotations) for the location value. If this task is for another
team member or you want others to see this task, select (Workspace Annotations) or (Project
Annotations) for the location. See Managing Annotation Files for more information about annotation file
locations.

Using Code Annotations for Code Reviews
Code Reviews provide an excellent use for Code Annotations. In a typical code review process, code is
reviewed by a number of team members, who record issues and forward their comments to a review
coordinator. During the review, the comments are discussed and a resolution is recorded.
SlickEdit® includes an Annotation Type for code reviews, called Review Comment. Along with the
standard fields, it also includes Issue, Resolution, and Status. If your review process requires a different
set of fields, refer to Managing Annotation Types for information on how to create your own.
There are many ways to implement a code review using SlickEdit and Code Annotations. We will describe
one approach that should be the easiest. You may find other methods that work best with your processes.
Prior to the review, the review coordinator creates a Workspace in SlickEdit for the files to be reviewed.
Copy those files to the Workspace directory and then add the files to the Workspace. If you have modified
the stock definition of the Review Comment, you can make sure that everyone is using the same definition
by creating a Workspace Annotation using that definition. You might put one on the first line of code with
instructions for how to perform the review.
Send a copy of this workspace to each of the reviewers. This can be done by compressing the directory
into a ZIP, TAR, or other archive file. Each reviewer then reviews the code and records their comments
using the Review Comment annotation type as a Workspace annotation. When they are finished, they
send the Workspace’s .sca file back to the review coordinator.
The review coordinator will merge the .sca files together to produce a single workspace annotation file.
Since these are XML files, they are easy to read and merge using many different tools. The consolidated
annotation file is used for the review walkthrough. You can also accomplish the sharing and merging with
most source control tools. Many provide automatic merging capabilities that will add the inserted lines into
the master file. You’ll have to test your system to make sure that the merges it performs are safe. If not,
you can use SlickEdit’s DIFFzilla® to compare and merge the files.
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During the review meeting, the review coordinator opens the single, merged document and then walks
through the issues by double-clicking on each in the Code Annotation tool window. The review team
discusses the recorded comment, and appropriate resolution remarks and status are recorded for each.
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Message List
Message List is a feature that shows output messages from processes running in SlickEdit®, such as build
warnings and errors.
Messages are automatically displayed in the Message List tool window, docked in the bottom tab group of
the editor by default. The tool window shows messages in tabular format, with columns for the message
type (warning, error, etc.), source file and line number associated with the message, a description, the
message origin (Build, Java Live Errors, XML validation, etc.), and the date. Messages can be filtered and
sorted. You can clear the tool window of all messages, or clear only messages with a certain creator or
type.
Messages are associated with a location in the code. When the cursor is on a line with an error or warning
in the source code, the corresponding message in the Message List is highlighted. You can also navigate
to the message in the source code from within the Message List by double-clicking on it (or right-click on a
selected message and click Go to code location).

Processes That Use Message List
The following processes originate messages that are automatically displayed in the Message List:
•

Build operations (such as Build > Compile or Build > Build) show Warning and Error messages.
See Working with Build Errors for more information.

•

Java Live Errors, when it is enabled, shows Caution and Error messages. See Java Live Errors for
more information.

•

XML validation shows Error messages. SlickEdit® automatically validates XML files that you open
in the editor. You can force a validation check at any time with the xml_validate command.

Message List Tool Window
The Message List tool window is docked to the bottom tab group of the editor by default. Display of the tool
window can be toggled on/off by clicking View > Toolbars > Message List or by using the
toggle_messages command. To display the tool window on demand, use the activate_messages
command.

Messages are shown in tabular format with the information divided into columns. Click on a column header
to sort by that column in ascending order, or click again to sort in descending order. An arrow in the column
header indicates the ascending or descending sort order. Drag the column separators to resize columns.
The columns are:
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•

Indicator - The first column in the Message List window shows the icon that corresponds to the
message in the code. The same icon is used in editor window margins to indicate lines that contain
messages. This column can also be used as a type of “To Do” checklist. Click inside a cell in this
column to place a checkmark next to the message, and click again to clear it. This could be useful
if you just want to change the state of a message, rather than removing the message.

•

Type - This column shows the type of message, such as Error, Warning, etc.

•

Source File - Messages are associated with a location in the code. This column shows the
complete path to the source file containing the message. As you resize this column, the path is
elided to keep the file name visible.

•

Line Number - Shows the line number containing the message.

•

Description - The text of the message.

•

Creator - The Creator is the process that originated the message, such as Build, Java Live Errors,
XML validation, etc.

•

Date - This column contains the date and timestamp showing exactly when the message was
generated. This could be useful if a process is lengthy, to see the order in which messages were
generated.

As you move the mouse over messages the Message List window, a tool tip shows the message detail.
You can also see a preview of the location of the message in the source code in the Preview Tool Window,
assuming it is docked so that both are visible, by single-clicking on a message in the Message List.
When the cursor is on an error or warning in the source code, the corresponding message in the Message
List is highlighted. Double-click on a message in the Message List and the cursor moves to that message
in the source code (or select the message and choose Go to Message from the right-click context menu).
For messages originating from Build processes, the Build tool window shows Build output for a selected
message when you choose Go to Build Output from the right-click context menu.

Filtering and Removing Messages
Use the Creator and Type drop-down boxes at the top of the tool window to filter the Message List to only
show messages with the selected Creator and/or Type. The default value for both is (show all).
The Clear button is used to remove all visible messages from the Message List. Clicking Clear also resets
the filters to (show all), displaying all messages except for the ones you just cleared. The messages do
not appear again until/unless the originating operation regenerates them.
Remove selected messages in the Message List by choosing Delete from the right-click context menu.
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Commenting
SlickEdit® makes commenting your code easy. You can comment out selected text, or type the start
characters for a new doc comment and have the doc comment skeleton automatically expanded. SlickEdit
also makes your comments easier to read by automatically wrapping them as you type. Existing comments
can be “reflowed” to match current comment wrap settings.

Commenting Blocks and Lines
Existing text in your code can be commented out (or uncommented) as follows:
•

To comment out a selected code block, from the main menu, click Document > Comment Block
(or use the box command). This comments out the entire selection as a single block comment by
surrounding the block with comment characters you have specified in your comment settings.

•

To comment out selected lines, from the main menu, click Document > Comment Lines (or use
the comment command). Each line in the selection is commented out as a single line comment. If
there is no selection, the current line is commented out. If using a block selection where there are
partially selected lines, comment characters are placed at the beginning and end of the selection.
If using a character selection where there are partially selected lines, comment characters are
placed based on your settings. The comment characters that are placed to the left and right of the
text are also specified in your comment settings.

•

To uncomment lines in a selection, from the main menu, click Document > Uncomment Line (or
use the comment_erase command). Surrounding line comment characters are removed from the
line. If there is no active selection, the current line will be uncommented. Uncomment Line only
works for well-formed comments, which means that every line in the selection is commented and
that the comment characters occur in the same column.

Whether you are creating a comment block or a comment line, if the selected text already contains
comments, another set of comment characters is added. SlickEdit® attempts to preserve the indentation
level of the code and any existing comments when adding or removing comment characters.

Comment Block and Line Settings
To specify the characters and other settings used for comment blocks and lines, from the main menu, click
Document > Comment Setup (or use the comment_setup command). The Options dialog opens to the
language-specific Comments screen for the current language. You can also open this screen by clicking
Tools > Options > Languages > [LanguageCategory] > [Language] > Comments.
The Comment block group box provides eight fields to specify the characters used in your commenting
style. If you want to apply a comment with no additional decoration, fill in the upper-left and lower-right
fields with the characters to begin and end a block comment. To draw a box around the comment, fill in
additional characters in the other fields. For example, you might put an asterisk in each of the other fields
to draw a box of asterisks around the block comment.
The Comment line group box contains fields for you to specify the characters to be inserted at left and
right sides of a line comment.
For code examples and descriptions of the other available options, see Language-Specific Comment
Options.

SlickEdit® User Guide

313

COMMENTING

Doc Comments
Doc comments are specially formatted comments that are processed by tools that extract and present the
information in a formatted manner. Doc comments follow a predefined structure, based on the
programming language and the tool processing the comments.
SlickEdit® supports the most common doc comment formats (Javadoc, XMLdoc, and Doxygen). When you
type the start characters for one of these comment formats and press Enter on a line directly above a
function, class, or variable, SlickEdit can automatically insert a skeleton doc comment for that style.
NOTE In C#, you do not need to press Enter, as the skeleton comment is inserted after you type the
third slash.
To activate and configure automatic completion of doc comment skeletons, complete the following steps:
1. From the main menu, click Document > Comment Setup (or use the comment_setup
command). The Options dialog is displayed, open to the Comments option screen for the current
language. You can also open this screen by clicking Tools > Options > Languages >
[LanguageCategory] > [Language] > Comments.
2. In the Doc comments box, check the option Automatically expand doc comments.
3. In the For start characters box, select the start characters for the doc comment style you plan to
use for the selected language. These are the characters that you type that will trigger automatic
completion of the doc comment skeleton. For comments formatted in Javadoc, select /**. For
XMLdoc, select ///. For Doxygen, select /*! or //!.
4. Optionally, click the Edit expansion button to view or edit the doc comment template that is
inserted when you type the selected start characters. See Modifying Doc Comment Templates for
more information.
5. Click OK on the Options dialog.

Doc Comment Examples
Javadoc Format
To use the Javadoc commenting format for the selected language, select the start characters /** and use
style @param. Check Insert leading *. Using the following code sample:
/**[CURSOR_HERE]*/
int setDimensions(int length, int width, int height) {
...
}

Pressing Enter at the “cursor here” location results in the following automatic completion:
/**
* [CURSOR_HERE]
*
* @param length
* @param width
* @param height
*
* @return int
*/
int setDimensions(int length, int width, int height) {
...
}
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XMLdoc Format
To use the XMLdoc comment format, select the start characters /// and the <param> style. Using the
following code sample:
///[CURSOR_HERE]
int setDimensions(int length, int width, int height) {
...
}

Pressing Enter at the “cursor here” location results in the following automatic completion:
/// <summary>
/// [CURSOR_HERE]
/// </summary>
/// <param name=”length”></param>
/// <param name=”width”></param>
/// <param name=”height”></param>
/// <returns>int</returns>
int setDimensions(int length, int width, int height) {
...
}

Doxygen Format
To use a Doxygen comment format, select the start characters /*! or //! (based on your preference) and the
\param style. Using the following code sample:
/*![CURSOR_HERE]*/
int setDimensions(int length, int width, int height) {
...
}

Pressing Enter at the “cursor here” location results in the following automatic completion:
/*!
* [CURSOR_HERE]
*
* \param length
* \param width
* \param height
*
* \return int
*/
int setDimensions(int length, int width, int height) {
...
}

Modifying Doc Comment Templates
To modify a doc comment template, from the main menu, click Tools > Options > Languages, expand
your language category and language, and select Comments. In the Doc comments section, select the
type of skeleton you want to modify from the For start characters drop-down list, then click the Edit
expansion button. The Doc Comment Editor dialog for the selected language opens. The specified start
characters are already selected in the alias list so you can start editing the comment template in the edit
window.
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The box on the left contains a list of doc comment start characters. The edit window on the right contains
the expansion for the selected start characters. See Alias Escape Sequences for a list of special escape
characters you can use inside doc comment templates, for example, to insert local function param names,
types, and return types. See Doc Comment Examples for an example of each comment style.
TIP You cannot add or delete doc comment templates using the Doc Comment Editor. You can,
however, add a new doc comment expansion as a regular language-specific alias. See Creating a
Language-Specific Alias for more information. All of the doc comment escape sequences will work
as long as you expand the alias on a blank line above a function or class declaration.

String Editing
When the cursor is inside of a string, if you press Enter to split the line, SlickEdit® can automatically align
the string with the original string as well as insert the closing and opening quotes and, if necessary,
operators. To set this option, click Document > Comment Setup (comment_setup command). The
Options dialog is displayed open to the Comments screen. Select the option Split strings on Enter.
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Comment Wrapping
Comments can be set to automatically wrap to the next line as you type. This feature is available for C,
C++, C#, Java, and Slick-C® files.
To activate comment wrapping, from the main menu, click Tools > Options > Languages, expand your
language category and language, then select Comment Wrap. Select the option Enable comment wrap,
then select the type of comments you want wrapped (block comments, line comments, and/or doc
comments).
The Comment Wrap screen also provides options to control how comments are wrapped. There are three
types of width settings:
•

Fixed - Comments will be formatted to a specified width.

•

Automatic - Comments will be formatted according to the width of existing comments.

•

Fixed right margin - Lines will break before a specified number of columns has been reached.

For more details on comment wrapping configuration, see Language-Specific Comment Wrap Options.

Reflowing Comments
After configuring comment wrap settings, you can use the Reflow Comment dialog to reflow block
comments, paragraphs, or a selection of the current file. To display this dialog, click Document > Reflow
Comment. For more information on the available options, see Reflow Comment Dialog.
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Beautifying Code
Code Beautifiers
Code beautifiers, available for many languages, reformat the layout of existing text based on settings that
you specify, such as begin/end styles and indenting.
To beautify selected lines of code, or to beautify the entire buffer, from the main menu, click Tools >
Beautify (or use the gui_beautify command). A dialog box is displayed with functions specific to the type
of project that is active. If an HTML project is active, then the HTML Beautifier dialog appears with options.
If a GNU C/C++ project is active, then the C/C++ Beautifier dialog opens, and so on. Beautifying is
supported for the languages listed below. Follow the cross-reference links to learn more about working with
each beautifier.
•

Ada - See Ada Beautifier.

•

C/C++, C#, Java, JavaScript, Slick-C® - These beautifiers contain the same options and settings.
See C/C++ Beautifier.

•

CFML, HTML - These beautifiers contain the same options and settings. See HTML Beautifier.

•

Javadoc - See Javadoc Beautifier Options Dialog.

•

XML, XSD - These beautifiers contain the same options and settings. See XML Beautifier.

Reflowing Text
To reflow text in the current paragraph according to your margin settings, click Document > Format
Paragraph or use the reflow_paragraph command. Margin settings are defined on the language-specific
Word Wrap options screen (see Language-Specific Word Wrap Options).
When you reflow a paragraph, the cursor will be kept at the same location within the current paragraph
after reflow has occurred, unless the Reflow next option is changed (Tools > Options > Editing >
General). If Reflow next is set to Cursor on next paragraph, the reflow_paragraph command places
the cursor on the next paragraph after it has reformatted the current paragraph.
Comments can also be reflowed according to the comment wrap settings. See Reflowing Comments for
more information.
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Quick Refactoring
Refactoring is a code editing technique used to “clean up” and improve the understandability of source
code without affecting the code’s external behavior. Quick Refactoring is a feature set that provides several
fast and easy-to-use refactoring methods:
•

Quick Rename – Rename a symbol under the cursor or any symbol selected in the Defs or
Symbols tool windows.

•

Quick Extract Method – Create a new method using currently selected lines as the body and any
undeclared variables as parameters.

•

Quick Modify Parameter List – Use to add, delete, and re-order parameters for a selected function.

•

Quick Replace Literal with Constant – Replace a selected literal with a constant.

Quick Refactoring performs refactorings using Context Tagging® rather than a formal language parser.
Quick Refactorings are supported for C++, C#, Java, and Slick-C®.

Available Refactorings
To access Quick Refactoring, from the main menu, click Tools > Quick Refactoring. Quick Refactoring
menu can also be accessed from the right-click context menus in the Symbols and Defs tool windows.
TIP Refactoring operations can modify more than one file. You can undo all of the refactoring
modifications in one step by clicking Edit > Undo Refactoring.

Quick Rename
Quick Rename uses the Context Tagging® to rename a symbol under the cursor or any symbol selected in
the Defs or Symbols tool windows. This operation works for all tagged languages. Quick Rename does not
treat renaming classes, constructors, and destructors as a special case. Quick Rename will rename all of
the overloads of a function. Quick Rename does not rename overridden methods (in parent and child
classes).

Quick Extract Method
After selecting a set of lines, Quick Extract Method creates a new method with the selected lines as the
body. It discovers any undeclared variables and creates them as parameters to the new method. The
extracted method is created in the same scope as the original method.
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Quick Modify Parameter List
This refactoring allows you to add, delete, and re-order parameters for a selected function. The refactoring
will modify the parameter list for the selected function and all of its counterparts within the class hierarchy.

Quick Replace Literal with Constant
Replaces the selected literal with a constant, replacing use of the literal with the new constant.

Reviewing Refactoring Changes
When a refactoring finishes, the Refactoring results dialog box is displayed, allowing you to review the
changes.
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There are three panes in this window:
•

The left pane is read-only and shows the original file(s).

•

The right pane shows the refactored file(s). For convenience, this pane can be edited.

•

The bottom pane lists all files that have been modified by the refactoring. Clicking on any file in this
list brings that file into view, where it can be reviewed and edited.

Click Save All at the bottom of this window to save all the refactoring and editing changes that were made
on all files. Click Cancel to discard changes and have all files remain the way they were before the
refactoring process.
Click Next Diff or Prev Diff to advance to the next or previous change made by the refactoring. Click
File>> to restore the contents of the current selected file to its original contents.
Click Block>> to restore an entire block of changes to the original contents. Click Del Block to remove a
block of code inserted by the refactoring. Click Line>> to restore the current line to its original contents.
Some refactorings, in particular Quick Modify Parameter List, may require further user input. In this case
each input will be displayed under the file it is in, and there will be two additional buttons: Next Input and
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Prev Input. You will not be able to save the refactoring results until you have resolved all of the input
requests.
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Viewing and Displaying
SlickEdit® offers several features and options regarding viewing and displaying. See the following topics
for more information:
•
•
•
•
•
•
•

Hex/Line Hex View
Viewing Special Characters
Viewing Line Numbers
Soft Wrap
Full Screen Mode
Selective Display
Other Display Options

Hex/Line Hex View
SlickEdit® supports hex/line hex viewing and editing on a per-document or per-language basis.
Hex view displays your code using hexadecimal values to represent each character. The ASCII
representation is also shown on the right side of the editor window. When you position the cursor in one
representation, the corresponding location in the other is highlighted. You can edit by changing the hex
values or by changing the ASCII characters.
Line hex preserves your code layout, formatting, and color coding. It shows the hexadecimal value for
each character below the corresponding character. Since two hex digits are needed, the value is displayed
in a column below the corresponding character with the most significant digit at the top. This makes it
easier to read your code and still see the hex values for each character. As with regular hex view, you can
edit either the ASCII representation or the hexadecimal values.
See also Hex Mode Editing for more information.

Viewing Special Characters
By default, many important characters are not visible in the editor, like tabs, spaces, and newline
characters. When you enable view of these special characters, SlickEdit® displays a visible character to
represent the invisible characters.
You can enable view of special characters on a per-document or language-specific basis:
•

For the current document - From the main menu, click View > Special Chars, or use the
view_specialchars_toggle command. This toggles the display of all special characters (tabs,
spaces, and newline characters) on and off. The menu also provides options to toggle display of
these characters individually. See View Menu for more information.

•

For a specific language - Using the Options dialog (Tools > Options), expand the Languages
node and your language, then select View. Select the option Special Characters. This enables
the display of all special characters for the chosen language. Alternately, you can select to enable
display of the characters individually.
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To define the characters that are displayed to represent the special characters, see Defining Special
Characters. To define the colors that are used for special characters, see Changing the Color of Special
Characters.
NOTES
•

Viewing special characters is only available for ASCII files.

•

When the display of special characters is enabled along with View > Line Hex, the hex
value for the actual character (like space) will be displayed, not the value for the character
used to represent it (like a dot).

Defining Special Characters
To define the characters that are displayed to represent the special characters, from the main menu, click
Tools > Options, expand Appearance and select Special Characters. Enter the character codes that
you wish to use.
To view the differences between a DOS format text file and another format when View > New Line Chars
is active, choose something other than a space for the End-Of-Line (2) character. Under Windows, the
recommended choices are 13 for End-Of-Line (1) and 10 for End-Of-Line (2).

Changing the Color of Special Characters
To change the colors and styles of special characters, use the Color options screen (Tools > Options >
Appearance > Color). Select Special Characters from the screen element drop-down list. For more
information on color settings, see Setting Fonts and Colors.

Viewing Line Numbers
The current line number is always displayed in the editor’s status area. Click on the line number indicator
to display the Go to Line dialog. This shows the total number of lines and allows you to navigate to a
specific line.
By default, line numbers are not displayed in editor windows, but you can enable them on a per-document
or language-specific basis, so that they show up in the left margin:
•

For the current document - From the main menu, click View > Line Numbers, or use the
view_line_numbers_toggle command. This toggles the display of line numbers on and off.

•

For a specific language - Using the Options dialog (Tools > Options), expand the Languages
node and your language, then select View. Select the option Line numbers.

TIPS
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•

To display a colon with line numbers when they are enabled, use the
line_numbers_show_colon command. At the command line prompt, type Y (for yes) or N
(for no).

•

To change the amount of space used in the left margin of editor windows for line numbers,
use the line_numbers_set_width command. At the command line prompt, enter the
number of the desired width, in pixels.

•

To change the color of line numbers, open the Appearance > Colors node in the Options
dialog, and select the Line Number screen element.
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Soft Wrap
Soft Wrap makes it easy to view long lines of code without scrolling. When Soft Wrap is enabled, each line
is wrapped as though a carriage return was inserted; however, unlike Word Wrap, the file itself is not
modified.
You can enable Soft Wrap on a per-document or language-specific basis:
•

For the current document - From the main menu, click View > Soft Wrap, or use the
softwrap_toggle command. This toggles Soft Wrap on and off.

•

For a specific language - Using the Options dialog (Tools > Options), expand the Languages
node and your language, then select Word Wrap. Select the option Wrap long lines to window
width. Options are also available here to break the text at the end of a word so that words are kept
whole (Break on word boundary), and to enable Soft Wrap for all languages so you don’t have to
configure each one (Enable soft wrap).

When Soft Wrap is on, arrows in the right margin indicate lines that are wrapped. The following screen
shows Soft Wrap enabled in an XML document:

For related information, see Word Wrap, Comment Wrap, and Reflowing Text.

Full Screen Mode
SlickEdit® provides a way to expand the editor window to the full size of the screen. This is useful when
you need screen real estate for editing large files and/or when tool windows and toolbars are not needed.
To activate full screen mode, from the main menu, click View > Full Screen, or use the fullscreen
command. Or, when you are working in a file and there is no code selected, right-click and select Full
Screen (located towards the bottom of the menu).

Selective Display
Selective Display (also known as code folding) is a convenient way to display or hide regions of your code,
so that you can view those regions that are relevant to your current editing session.
Use the Selective Display dialog to activate this feature and to specify the type of regions to display or
hide. This dialog is displayed by clicking View > Selective Display, or by using the selective_display
command.
When Selective Display is active, a Plus (+) or Minus (-) bitmap is placed before hidden or expanded lines
in the editor window margin. The following screenshot shows a sample file with two function definitions
expanded and the rest collapsed.
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When Selective Display is active, you can perform the following operations:
•

Display or hide lines - Double-click on the Plus (+) or Minus (-) bitmaps. Alternatively, click View
> Expand/Collapse Block, press Ctrl+\, or use the plusminus command. See Expanding/
Collapsing Code Blocks for more details.

•

Copy visible text to the clipboard - Click View > Copy Visible or use the
copy_selective_display command. Normally when you copy a selection that spans multiple lines,
hidden lines are copied as well. This command ignores hidden lines and only copies visible text.
This operation does not work with block selections.

•

Redisplay all lines and remove the bitmaps - From the main menu click View > Show All
(show_all command).

To define the type of information to show/hide, see Selective Display Regions.

Expanding/Collapsing Code Blocks
SlickEdit® provides a more keyboard-centric way to expand and collapse code blocks. You can expand or
collapse blocks of code by using the plusminus command, whether or not Selective Display Plus or
Minus bitmaps are displayed.
The plusminus command expands or collapses code blocks under the following conditions:
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•

If the cursor is on the first line of a code block, the block is collapsed, creating a new Selective
Display region.

•

If the cursor is on a line that contains a Plus (+) bitmap, the block is expanded.
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•

If the cursor is on a line that contains a Minus (-) bitmap, the expanded block is collapsed.

NOTES
•

The definition of a “code block” is based on your language.

•

Selective Display bitmaps can be expanded or collapsed with a single click, causing
Selective Display to operate similar to Windows Explorer. Note, however, that you will not be
able to select a line by clicking to the left of a text line which contains a Selective Display
bitmap. To set this option, from the main menu, click Tools > Options > Appearance >
Advanced, then set the value of Expand/collapse to Expand on single click.

•

The plusminus command is controlled by the def_plusminus_blocks configuration
variable. The value is set to true (1) by default. For more information, see Configuration
Variables.

•

The plusminus command uses the same logic to identify code blocks as the command
cut_code_block. See Deleting Code Blocks for more information.

Selective Display Regions
Using the Selective Display dialog, you can choose the regions you want to display or hide. Specific
settings are provided for each region.
•

Search Text - Displays lines that contain the specified search string or lines that do not contain the
specified string.

•

Function Headers - Displays only function headings and optionally, function heading comments.

•

Preprocessor Directives - Displays a source file as if it were preprocessed according to the define
values specified here. If you do not remember your defines, use the Scan for Defines button.

•

Multi-Level - Select this option to set multiple levels of Selective Display based on braces or
indent.

•

Paragraphs - Displays the first line of each paragraph. A paragraph is defined by a group of lines
followed by one or more blank lines.

•

Hide Selection - Select this option to hide the lines in the current selection.

The Selective Display dialog also contains static options for expanding/collapsing sub-levels. See
Selective Display Dialog for more information and details about the available settings.

Other Display Options
This section describes other general display options that you might find useful.

Displaying a “Top of File” Line
You can specify that each buffer opened displays a line which contains the text “Top of File”. This indicator
for the location of the top of the file is displayed at line 0, which does not affect lines of code. This is useful
when you need a line inserted before the first line of a buffer when in CUA or SlickEdit® text mode
emulation. It is also useful when using Selective Display, because a Plus (+) bitmap can be displayed on
line 0.
To enable this option, from the main menu, click Tools > Options, expand Appearance and select
General, then set the Top of file line option to True.
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Rather than using this option, you can use Ctrl+Shift+Enter (Ctrl+Enter in the Visual C++ and Visual
Studio default emulations) to insert a new line above the line where the cursor is located.

Displaying a Vertical Line
You can choose to display a vertical line in all files that are open for editing. To access this setting, from the
main menu, click Tools > Options, expand Appearance and select General, then in the Vertical line
column spin box, specify the column number at which you want the vertical line displayed. A value of 0
(default) displays no vertical line. Click on the Vertical line color option to change the color of the vertical
line.

Line Highlights
Several line highlights are available both globally and on a language-specific basis:
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•

On a global basis, you can enable the Current line highlight. This feature draws a box around the
current line, and you can specify what type of box to use: a plain box, a tabs ruler, a syntax indent
ruler, or a decimal ruler. You can also control the color of the box and column markers when using
a ruler. To enable the current line highlight and specify options, open the Options dialog (Tools >
Options), expand Appearance and select General, then modify the options under the Current
line highlight category.

•

On a language-specific basis, you can enable a different background color for the current line.
Open the Options dialog (Tools > Options), expand your language category and language, then
select General. In the Color coding group box, select Current line. You can also choose to mark
lines that have been modified in the file in the current editing session by selecting Modified line.
This will display a color indicator in the left margin of editor windows for each changed line. To
change the color used for either option, open the Appearance > Colors node in the Options
dialog and select the Current Line or Modified Line screen element.
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Language-Specific Editing
This chapter contains the following topics:
•
•
•
•
•
•
•
•
•
•

Language-Specific Editing
C and C++
Java
XML and HTML
XML/HTML Formatting
Ada
COBOL
Pascal
PL/I
Python
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Language-Specific Editing
Many features in SlickEdit® are language-specific and based on the language editing mode. You can also
configure different settings for different languages. See Language-Specific Options and Language Editing
Mode below for more information.
This chapter also includes specific information about options, beautifiers, and more for the following
languages:
•
•
•
•
•
•
•
•

Ada
C and C++
COBOL
Java
Pascal
PL/I
Python
XML and HTML

Language-Specific Options
Options for language-specific features can be set through the Options dialog (Tools > Options or config
command) by using the Languages > [LanguageCategory] > [Languages] categories. A shortcut
method to access language options for the current buffer is to use the Document > [Language] Options
menu item, or the setupext command. This will open the Options dialog to the General language-specific
option screen for that language. See Language Options for more information.
NOTE The Options dialog is new in SlickEdit 2008, and consolidates all of the dialogs formerly
accessed through the Tools > Options menu.

Language Editing Mode
SlickEdit® uses the extension of the current file to determine what language you are using, thereby only
making available the options and features that are possible in that language.

Manually Setting the Language Mode
If you have a file with a non-standard extension or no extension at all, you will need to manually specify the
language editing mode. To specify a mode, from the main menu click Document > Select Mode (or use
the select_mode command). The Select Mode dialog is displayed with a list of modes from which to
select.

Managing Languages
Supported languages are listed in the Language Manager (Tools > Options > Languages > Language
Manager). You can use this tool to add languages and delete languages you have added.
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Installed languages are denoted in the list with a SlickEdit® bitmap. Use the filter box at the top of the
language list to search the list incrementally as you type. Use the Add Language and Delete Language
buttons to add and remove languages (see Adding and Removing Languages below). Click Settings to
jump to the General Language-Specific Options screen for the selected language.

Adding and Removing Languages
To add a language, complete the following steps:
1. Click Add Language on the Language Manager screen. The Add New Language dialog is
displayed.
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2. In the Mode name field, type a name for the new language (for example, C/C++, Java, etc.).
3. In the Associated extensions field, type the file extension(s) associated with this language.
Separate each extension with a space, and do not include the dot character (for example: c h cc
cp). The extensions you list here, if not already defined, are added to the File Extensions list on the
File Extension Manager. If you specify an extension that already exists and is associated with
another language, a confirmation prompt is displayed.
TIP To see a list of file extensions that are associated with a language, see the language-specific
General options page (Tools > Options > Languages > [LanguageCategory] > [Language] >
General).
4. In the Color coding lexer name field, specify the language identifier so that SlickEdit® knows
what elements to color. Use the drop-down list to select the lexer.
5. Click Add Language. The new language will be displayed in the Languages list as well as the list
of document language modes on the Select Mode dialog (Document > Select Mode).
To delete a language you have added, select it in the Language list and click Delete Language. Installed
languages cannot be deleted.

Managing File Extensions
The File Extension Manager (Tools > Options > Languages > File Extension Manager) is used to add
and work with file extensions in SlickEdit®.
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Recognized file extensions are listed in the File Extensions list. See Adding and Removing File Extensions
for more information.
The settings on the File Extension Manager screen are described as follows:
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•

Associate with language - This drop-down shows the language that is associated with the
selected file extension. Associations are created when you add a new language using the
Language Manager. You can use this field to change the language association.

•

Language Setup - Click this button to jump to the language-specific General options screen,
which shows a list of file extensions associated with the selected language and provides general
language-specific options.

•

Encoding - Each extension can have its own encoding specification. Both the language-specific
and global option settings are overridden if an encoding is previously specified in the Open dialog
box. The encoding used to override default encoding settings is recorded and this setting is used
the next time the same file is opened. This provides per-file encoding support. If the extensionspecific encoding is set to Default, then the global setting defined on the Load File Options screen
(Tools > Options > File Options > Load) is used. Note that Unicode support is required to work
with encodings. For more information about working with encodings and Unicode, see Encoding.

•

Open Application and Use file association - These options are mutually exclusive. Open
Application is used to specify the application in which to open files when you use the Projects tool
window to open them. Use the arrow to the right of this field to insert escape sequences that are
used as arguments. On Windows, if the option Use file association is selected, the association
specified in your operating system is used instead, overriding Open Application. When Use file
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association is selected, SlickEdit checks the Windows registry for the application associated with
the selected file extension and invokes that application to display the file, rather than the one
specified by Open Application. Note that Use file association is a Windows-only option. To open
a selected file from the Projects tool window, double-click on it or right-click and select Open from
the context menu.

Adding and Removing File Extensions
If SlickEdit® does not provide a file extension that you need to use, you can add it. If you have added a
new language to SlickEdit with a file extension that was not already defined, the new extension is added to
the File Extension list automatically. Or you can just add a new extension by clicking New, and the New
Extension dialog is displayed.

Enter the new file extension in the Extension box (without the dot character), then select the associated
language from the Language drop-down list and click OK. If the language does not exist, cancel this
dialog and add it using the Language Manager first (see Adding and Removing Languages).
To delete the selected extension from the File Extensions list, click Delete.
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C and C++
This section describes some of the advanced features and options that are available in SlickEdit® for C
and C++, including language-specific formatting options, the C/C++ Beautifier, compiler settings, and
preprocessing.
SlickEdit's default editing mode for C and C++ allows for programming in either language. If you are coding
to strict ANSI C standards, you should configure the value of the macro variable def_ansic_exts to contain
a space-delimited list of extensions for files you want interpreted as ANSI C. To set the macro variable,
press Esc to bring up the SlickEdit command line, then type set-var def_ansic_exts “<extensions>”,
where <extensions> is the space-delimited list of extensions.
For example:
set-var def_ansic_exts "c h"

Please note that if you also code in C++ and any of these extensions are used for C++, they will be
interpreted as ANSI C.

C/C++ Formatting Options
Options are available for C and C++ for changing Syntax Indent and Syntax Expansion styles. To access
these options, from the main menu, click Tools > Options > Languages, expand Application Languages
> C/C++, then click C/C++ Formatting Options.
NOTE Languages similar to C/C++ have similar Formatting Options screens that are not specifically
documented.
The tabs on the C/C++ Formatting Options screen are described below.

Begin-End Style Tab
Use this tab to specify the brace style used by Syntax Indent and Syntax Expansion.
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The top of the tab lets you choose the style you want to use (Style 1, Style 2, or Style 3). The hyperlink
indicates if Adaptive Formatting is on or off for this setting. The remaining options are:
•

Insert braces immediately - When this option is selected, the template is inserted with braces.

•

Insert blank line between braces - When this option is selected, a blank line is inserted between
the braces when a template expands with braces.

•

Insert function start brace on new line - When this option is selected, a function start brace is
inserted after you press Enter to start a new line.

•

Apply to function braces - When this option is selected, your begin/end style is applied to braces
for function definitions.

•

Quick brace/unbrace one line statements - Enables Quick Brace/Unbrace, features that allow
you to convert a single line statement to a brace-enclosed block, and vice versa. See Quick Brace/
Unbrace for more information.

•

Place “else” on same line as “}” - When this option is selected, SlickEdit® places the else
keyword on the same line as }. This is typical when using brace Style 1. The following is an
example of using Style 1 with an else clause:
if (i<j) {
} else {
}

Indentation Tab
The Indentation tab is used to specify indenting options.
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The following options are available:
•

Indent first level of code - When this option is selected, Syntax Indent indents the cursor after
declarations such as functions.

•

Use continuation indent on function parameters - When this option is selected, function
parameters always use the continuation indent.
By default, we format multi-line function parameters as follows:
myLongMethodName(firstarg,
secondarg,
thirdarg
);
myLongMethodName(
firstarg,
secondarg,
thirdarg
);

When this option is enabled, the format changes as follows:
myLongMethodName(firstarg,
secondarg,
thirdarg
);
myLongMethodName(
firstarg,
secondarg,
thirdarg,
);

•

Indent member access specifier - (C++ only) This option controls Syntax Indent for member
access specifiers (public:, private:, and protected: keywords) in C++ classes/structs. The value
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of this option is controlled by the def_indent_member_access_specifier configuration variable
(Macro > Set Variable). When the option is enabled, access specifiers are indented as follows:
class Foo
{
public:
private:
protected:
int value;
};

When the option is disabled, access specifiers are aligned along the class, for example:
class Foo
{
public:
private:
protected:
int value;
};

•

Indent CASE from SWITCH - When this option is selected, Syntax Expansion places the CASE
statement indented from the SWITCH statement column. The hyperlink indicates if Adaptive
Formatting is on or off for this setting.

•

No space before parenthesis - When this option is selected, no space is placed between
keywords (such as if, for, or while) and the open paren when Syntax Expansion occurs. For
example, (if( or if (). The hyperlink indicates if Adaptive Formatting is on or off for this setting.

•

Insert padding between parentheses - When this option is selected, a space is placed after the
open paren and before the close paren, providing padding for the enclosed text. For example, if ()
becomes if ( ). The hyperlink indicates if Adaptive Formatting is on or off for this setting.

•

Pointer style - Specify the pointer style you want to use.

Other Tab
The Other tab contains miscellaneous options.
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The following options are available:
•

Main style - This option specifies the main function declaration template that is inserted. Select
ANSI C/C++ if you want an old ANSI C main declaration inserted. You can define a template by
using aliases, or you can write a replacement function for c_insert_main. The command findproc c_insert_main will locate the macro source for this function.

•

C/C++ Preprocessing - Click this button to customize the global preprocessing that is used when
Context Tagging® creates tag files for C or C++. See C/C++ Preprocessing.

Extensionless C++ Files
Options are available to configure when an extensionless file should be recognized as a C++ source file.
To access these options, from the main menu, click Tools > Options > Languages, expand Application
Languages > C/C++, then click Extensionless C++ Files.
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•

Extensionless C++ file path regular expression - In order for SlickEdit to safely recognize an
extensionless C++ header file as C++ automatically, without accidently attempting to open other
extensionless files (such as executables) as if they were C++, in addition to requiring that you
specify the names of the files below, the path that the files are located in must match the regular
expression specified here.

•

Extensionless C++ files - Specifies the names of extensionless C++ header files. SlickEdit®
takes care of the standard STL headers automatically, but you can use this to add additional
compiler specific headers, such as unordered_set or regex. A file with no extension will be
recognized as C/C++ if, and only if, its name is in this list and its path matches the regular
expression specified in the field above. Click the Add button to add a file, or click the Delete button
to delete the selected file from the list.

C/C++ Beautifier
To beautify a C or C++ document, open the file you want to beautify, then from the main menu, click Tools
> Beautify (or use the gui_beautify command). The C/C++ Beautifier will be displayed, which allows you
to make settings for how the code will be beautified.
You can use the commands c_beautify or c_beautify_selection to instantly beautify the file or the
selection according to the settings on the Beautifier dialog.
Currently, this beautifier supports beautifying Slick-C® source if the statements are terminated with
semicolons like C.
NOTE The C#, Java, JavaScript, and Slick-C Beautifiers contain the same options and settings as
the C/C++ Beautifier.
The following buttons and settings are available on the Beautifier:
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•

Beautify - Beautifies current selection or buffer and closes the dialog box.

•

Reset - Restores the dialog box settings to the values that appeared when you invoked the dialog.

•

Save Settings - Saves beautify options in uformat.ini file. These settings are used by the
c_beautify command.

•

Restrict to selection - When this option is selected, only lines in the selection are beautified.

•

Sync extension options - When this option is selected, the language options are updated to
reflect any changes that these dialogs have in common. For example, changing the begin-end
style to Style 2 will update your brace style for Syntax Expansion.

The tabs on the C/C++ Beautifier are described in the sections below.

Begin-End Style Tab
The Begin-End Style tab of the C/C++ Beautifier is pictured below.

The following options and settings are available:
•

Do not change brace style - Select this option if you do not want your brace style changed. This
is useful if you are using a brace style that is not supported by SlickEdit®.

•

No space before paren - Determines whether a space is placed between a keyword such as if,
for, or while and the open paren.

•

else on same line as } - When this option is selected, the beautifier will place } else on the same
line. This is typical when using brace Style 1. The following is an example of using Style 1 with an
else clause:
if (i<j) {
} else {
}

•

Apply to function braces - When this option is selected, the beautifier will apply your begin/end
style to braces for function definition.
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Indenting Tab
The Indenting tab of the C/C++ Beautifier, pictured below, provides indenting parameters that you can use
when working with C/C++ files in SlickEdit®.

The following options and settings are available:
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•

Indent with tabs - When this option is selected, tab characters are used for the leading indent of
lines. This value defaults to the Tabs text box setting on the language-specific Indent options
screen (see Language-Specific Indent Options).

•

Indent first level of code - Do not clear this check box. When this check box is selected, the first
level of code inside a function or method definition is not indented.

•

Indent CASE from SWITCH - When this option is selected, the case and default statements found
inside switch statements are indented from the switch.

•

Indent access specifier - When this option is selected, specifiers are indented under the class.
When not selected, specifiers are aligned directly underneath the class.

•

Indent for each level (Syntax indent) - The amount to indent for each new nesting level of code.
We have put the words “Syntax indent” in parenthesis to help indicate that this field has the same
value as the Syntax indent text box on the language-specific Indent options screen (see
Language-Specific Indent Options). By default, we initialize this text box with your current
language setup setting.

•

Tab size - The value in this field specifies the output tab size. The output tab size is only used if
the option Indent with tabs is enabled on the language-specific Indent options screen (see
Language-Specific Indent Options). This value defaults to the Syntax indent text box on the
Indent options screen.

•

Original tab size - The value in this field specifies the size of the original expansion tab. SlickEdit
uses the expansion size of your original file to handle reusing indent amounts from your original
file. Currently the beautifier only reuses the original source files indenting for comments. This
option has no effect if the original file has no tab characters.

•

Continuation indent - The value in this field specifies how much to indent lines of statements that
continue to the next line. This has no effect on assignment statements or parenthesized
expressions. Lines that are a continuation of an assignment statement are indented after the first
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equal sign. Lines that are a continuation of a parenthesized expression are indented after the open
paren. Given the following example:
unsigned
int i;

The result would be:
unsigned
<Continuation Indent>int i;

•

Align on parens - When this option is selected, the text for parenthesized expressions that spans
multiple lines is aligned on the first non-blank after the parenthesis or on the parenthesis itself.

•

Align on equal - When this option is selected, the text for multi-line assignment is aligned on the
first non-blank after the equals sign (=) or on the equal sign itself.

Comments Tab
The Comments tab on the C/C++ Beautifier, pictured below, contains options for setting the parameters
that you want for the trailing comments.

The following options are available:
•

Indent stand alone comments - Indicates whether comments that appear on lines by themselves
with no statement text to the left are indented to the current statement indent level. For example:
/* stand alone
comment
*/
// another stand alone comment
i=1;
// trailing comment

•

Indent column 1 comments - Normally comments that start in column 1 are left alone. Select this
option if you want the indent for these comments to be adjusted.

•

Specific column - This text box specifies the column in which trailing comments should be
placed. Trailing comments are comments that appear at the end of lines that contain statements or
declarations. For example:
// another stand alone comment
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/* stand alone
comment
*/
i=1;
// trailing comment
if (x) {
/* trailing
comment.
*/
}

•

Original absolute column - When this option is selected, trailing comments are placed at the
same column as the original source file. Trailing comments are comments that appear at the end
of lines that contain statements or declarations.

•

Original relative column - When this option is selected, trailing comments are indented by
reusing the indent after the last character of the end of the statement or declaration of the original
source file. Trailing comments are comments that are displayed at the end of lines that contain
statements or declarations. For example, if the original code is as follows:
if () {
i=1;<four characters>//trailing comment
i=4;<four characters>/* trailing
comment.
*/
}

The resulting code would be:
if () {
i=1;<four
i=4;<four
<four
<four
}

characters>//trailing comment
characters>/* trailing
characters>
comment.
characters>*/

Other Tab
The Other tab on the C/C++ Beautifier, pictured below, contains the preprocessing and pad condition
options.
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The following options are available:
•

Indent preprocessing - When this option is selected, the indent before the # character of
preprocessing is set to indicate the preprocessing nesting level.

•

Indent inside block - When this option is selected, preprocessing inside brace block is indented
when inside preprocessing. Otherwise, preprocessing within a brace block start in column 1.

•

Indent inside special #ifndef - Many C/C++ header files starts with the following lines of code:
#ifndef myheader_h
#define myheader_h
#endif

When this option is selected, preprocessing inside this special #ifndef case is indented.
•

Eat spaces after # - When this option is selected, the spaces after a preprocessor #, but before
the keyword (if, ifdef, else, elif, endif, etc.), are removed. This is useful for fixing old C code
where the # character had to start in column 1 and spaces were used after the # to indicate the
nesting level.

•

Force parens on return - When this option is selected, parentheses are added to return
statements which do not have parentheses.

•

Pad condition - These options indicate if parenthesized conditional expressions should have their
spacing adjusted.

Schemes Tab
The Schemes tab of the C/C++ Beautifier is pictured below.

To define a new scheme, set the various beautify options, and press the Save Scheme button. User
defined schemes are stored in uformat.ini.
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C/C++ Compiler Settings
In order to correctly perform full preprocessing, parsing, symbol analysis, and cross-referencing,
SlickEdit® needs to emulate the implementation-specific parsing behavior of your compiler, including builtin functions, preset #defines, and include directories.
These properties can be specified using the C/C++ Compiler Properties option screen or the C/C++
Compiler Properties dialog. The interfaces contain the same fields and options so you can make changes
using the one you prefer:
•

From the main menu, click Tools > Options. In the tree, expand Languages > Application
Languages > C/C++, then select Compiler Properties.

•

With a C/C++ project open, from the main menu, click Project > Project Properties. Select the
Compile/Link tab, then click the Ellipsis button to the right of the Compiler combo box. The
C/C++ Properties dialog is displayed.

The interface shows the default compiler and its associated header file and include directories, known
collectively as a “configuration”. Configurations can be created and modified as needed.
In the Compiler Name drop-down list, select the compiler you wish to use. If this is to be the global default
compiler for all projects, click the Set Default button.
NOTE It is possible to select other compilers for individual projects. In those cases, the projectspecific compiler is used and overrides the global default.
SlickEdit ships with header files for each compiler, and the correct header file will appear in the Header
File field. The header file configures the parser to emulate the compiler that is chosen in the Compiler
Name field.
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Creating New Configurations
There are two ways to begin a new configuration. In both cases, a dialog box will be invoked, prompting for
the name of the new configuration.
•

Click Copy to copy the selected compiler configuration. This can be used as a template for
creating a new configuration and makes the process of creating similar configurations more
convenient.

•

Or, click Add to create a configuration from scratch or to add a newly installed compiler.

If you wish to remove the selected compiler and associated configuration from the list, click Delete. This
does not delete any files from disk.

Building the Tag File
The Build tag file button on the C/C++ Compiler Properties dialog is used to build tag files from the header
file found in the include directories for the selected compiler configuration. This is especially useful when
new configurations are created. If you do not build the tag file here manually, it will be built on demand.

C/C++ Preprocessing
Typically your source code base will include preprocessor macros that you use in your code for portability
or convenience. For performance considerations, Context Tagging® does not do full preprocessing, so
macros that interfere with normal C++ syntax can cause the parser to miss symbols. For example:
MYNAMESPACEDECL(my)
struct MYPACKEDMACRO BinaryTree {
MYTYPELESS data;
MYPOINTER(BinaryTree) next;
MYPOINTER(BinaryTree) prev;
};
MYPOINTER(BinaryTree) proot = MYNULL;
MYENDNAMESPACE

This example uses the following preprocessor macros:
#define
#define
#define
#define
#define
#define

MYNAMESPACEDECL(name)
MYPACKEDMACRO
MTYPELESS
MYPOINTER(t)
MYNULL
MYENDNAMESPACE

namespace name {
__packed
void*
t*
((void*)0)
}

Among them, the only two that are harmless are MYTYPELESS and MYNULL, because they just create
name aliases for types or constants. However, the other four are troublesome and cause the entire code
snippet to be unparsable unless you configure SlickEdit® to be aware of these preprocessor macros. To do
so, complete the following steps:
1. From the main menu, click Tools > Options > Languages and expand the Application
Languages node in the tree.
2. Depending on your language, select ANSI-C or C/C++ in the tree, then click C/C++
Preprocessing.
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3. Click New to add new preprocessing macros. Arguments are allowed; for example,
mymacro(a,b,c)
4. When finished, click OK.
5. A prompt appears asking whether to rebuild your workspace tag file. Click Yes.
Preprocessor macros are stored in usercpp.h, located in your configuration directory. Rather than using
the dialog, you can add large numbers of #defines directly to this file. You may want to make sure that your
entire development team has an up-to-date copy of this configuration file once you have added all of your
local preprocessor macros.
NOTE The usercpp.h file should only be used for #defines and #undefs—not #includes.
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Java
SlickEdit® provides a full-featured Java development environment, allowing you to edit, build, and debug
Java programs. Topics in this section:
•

Initial Setup - Read this to configure SlickEdit for your JDK and other settings needed for compiling
and debugging.

•

Java-Specific Features - Information about features designed specifically for Java programmers.

•

Java-Specific Interfaces - Detailed descriptions of dialogs, tool windows, and option screens
specific to Java programming.

Initial Setup
SlickEdit® relies on an installed Java Development Kit (JDK) for compiling and debugging. After you have
installed the JDK on your computer, the following steps will configure SlickEdit to use it. The steps are
divided into three categories:
•
•
•

Context Tagging® for Java
Setting Up a Java Workspace and Project
Configuring Java Build and Runtime Options

Context Tagging® for Java
SlickEdit® needs to tag the Java libraries to provide symbol completions and other Context Tagging
features for those classes (see Context Tagging®). When you first run SlickEdit after an installation, you
are prompted with a dialog to create these tag files. Complete the steps below if you did not create tag files
at that time or to configure additional JDKs.
1. Open the Context Tagging® - Tag Files Dialog by selecting Tools > Tag Files.
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2. Click the Auto Tag button to open the Create Tag Files for Run Time Libraries dialog. This dialog
is displayed automatically when you first run SlickEdit.

3. SlickEdit may detect that you have installed the JDK. If so, the section for Java will be filled out. If
not, you will have to configure this manually.
4. Click the Browse button to open the Java Compiler Properties Dialog. You can have multiple
JDKs installed on your computer at the same time and configure SlickEdit to use different JDKs for
each project. This dialog provides the name and location for each JDK so that you can select it for
tagging or building.
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5. Click the Add button to configure a new JDK. You will be prompted for the configuration name.
Give it a name that represents the associated JDK, like "JDK 1.6".
6. If a default JDK has not been specified, click the Set Default button to set this JDK as the default.
You will need to do this if you are adding the first JDK.
7. Next, you need to specify the root of the JDK installation. Under JRE Configuration, click the
ellipsis button to enter the root directory for the JDK installation.
8. When finished, click the OK button to return to the auto tag dialog.
9. Make sure there is a check in the Create tag file for Java run-time libraries check box.
Depending on your environment, there may be checks in the check boxes for C++ and .NET.
Leave those checked if you have not already tagged those libraries. If you just want to tag the Java
libraries, uncheck the other check boxes.
10. Click the Create tag file(s) button.
11. SlickEdit will display a progress bar while your libraries are being tagged. When finished, SlickEdit
will display the Context Tagging - Tag Files dialog. You can close this if you have no other libraries
to tag.

Setting Up a Java Workspace and Project
In SlickEdit®, files are contained in projects, and projects are contained in workspaces. Except for the most
basic editing, you should always work within a workspace and project in SlickEdit. Context Tagging® relies
on having your source files contained in a project. See Workspaces and Projects for more information.
Editing options are determined by the file extension and accessed by selecting Tools > Options from the
main menu, then selecting the corresponding language in the options hierarchy. Editing options control
how your code is formatted and key editing behaviors as you type.
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The project type determines your build environment and provides options specific to that project type. For
Java, this includes specifying which JDK to use, setting up the debugger, and configuring Java Live Errors.
To create a new Java project or to see a list of the available Java project types, select Project > New from
the main menu, then expand the Java node in the tree under Project type.
After you have created a Java project, you can set the build options by selecting Project > Project
Properties from the main menu, selecting Build in the Tool name list, then clicking the Options button.
The options displayed are specific to the project type of the active project. If you are in a Java project, you
will see Java options. If you are in a C++ project, you will see options for the C++ compiler.
NOTE The Options button is only available if you have selected Build without a makefile
(dependencies automatically checked) on the Build tab of Project Properties Dialog. If you select
either of the other two options, SlickEdit uses an external command to launch the build.
You can also change the build options for Java by selecting Build > Java Options from the main menu (or
the corresponding item for other languages).

Configuring Java Build and Runtime Options
The Java Options dialog contains settings used when you build or execute a Java project. Most of the
settings are stored for the particular Java project and configuration selected. You can set different values
for different projects and for different configurations of the same project. For example, you might have
different settings for the Debug configuration than from the Release configuration, allowing you to turn on
optimizations used for release that are incompatible with debugging. See Java Options Dialog for more
information.

Java-Specific Features
SlickEdit® provides many features that work across several languages including Java, and Java-specific
information is described throughout the documentation where applicable. The following are additional
features designed specifically for Java developers:
•
•
•
•

Javadoc Comments
Organize Imports
Java Live Errors
JUnit Testing

Javadoc Comments
Several features are available to help you enter and format Javadoc comments (as well as other doc
comment formats). See Doc Comments for more information.

Organize Imports
Organize Imports automates the management of import statements in Java files. This feature minimizes
the amount of time that it takes to compile code by only importing the classes that are used. Existing import
statements are also sorted in a readable format and are more consistent between different Java packages
in the same project. Organizing of imports is applied to an entire file.
To organize imports, from the main menu, click Tools > Imports > Organize Imports, or from the rightclick context menu, select Imports > Organize Imports. Alternately, use the jrefactor_organize_imports
command.
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Adding Imports
To add an import statement for the class name under the cursor in Java code, move the cursor to the class
name you want to import, then from the main menu, click Tools > Imports > Add Import, or from the rightclick context menu, select Imports > Add Import. Alternately, use the jrefactor_add_import command.

Import Options
Several options are available on the Options dialog to control the behavior of Organize Imports. See
Organize Java Imports Options Interface for details.

Java Live Errors
Java Live Errors is a feature that flags syntax and compilation errors as you edit your code. This feature
also provides coding “best practice” warnings, and can be configured to accommodate any source
compliance level.
To activate Live Errors, open a Java project then complete the following steps:
1. Open the Java Options dialog by selecting Build > Java Options from the main menu.
2. Select the Compiler tab and enter the Source Compliance level.
3. Select the Live Errors tab and check Enable Live Errors.
4. In the Path to JDK 6 or later field, specify the root of the JDK 6 (or compatible JDK) installation.
There is no requirement that you build your code with JDK 6, only that it is available to Live Errors.
NOTE If you have Live Errors running and wish to specify a different JDK 6 (or other compatible
JDK) root, after changing the path on the Java Options dialog, you must restart SlickEdit®.
After activating Live Errors, you can use the rte_next_error command to jump through the live errors in
the current file. Bind this command to a key sequence for more efficiency (see Creating Bindings).
See Live Errors Tab for more information about the fields and options on this tab.

JUnit Testing
JUnit tests can be run from within SlickEdit®. The results can be viewed and code that fails the testing can
be easily reconciled.
To run a JUnit test, in the Projects tool window, select the project, package or file that you want, then on the
right-click context menu, select Unit Test > Run (junit command) or Unit Test > Debug (junit_debug
command). The results are displayed in the Unit Testing tool window.
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The Unit Testing tool window displays the number of tests that ran, failed, passed, had errors, and were not
run. Double-click the items found on the Tests or Defects tab to be redirected to the code that needs to be
debugged.
A tree control displays the defect trace(s) for the currently selected test item. Buttons are available above
the tabs to rerun tests:
•

To rerun the last set of tests, click Run Current TestCases.

•

To rerun only the tests with defects from the last set of tests run, click Run Current TestCases
with Defects.

Java-Specific Interfaces
This section provides detailed information about the following dialogs, tool windows, and option screens
that are specific to Java programming:
•
358
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•
•
•
•
•
•

Java Options Dialog
Java Formatting Options Interface
Organize Java Imports Options Interface
Java Beautifier Dialog
Javadoc Editor Dialog
Javadoc Beautifier Options Dialog

Java Compiler Properties Dialog
In order to correctly perform symbol analysis and cross-referencing, SlickEdit® needs to know which JDK
you are using and where the system libraries are located.
These properties can be specified using the Java Compiler Properties option screen or the Java Compiler
Properties dialog. The interfaces contain the same fields and options so you can make changes using the
one you prefer:
•

From the main menu, click Tools > Options. In the tree, expand Languages > Application
Languages > Java, then select Compiler Properties.

•

With a Java project open, from the main menu, click Project > Project Properties. Select the
Compile/Link tab, then click the Ellipsis button to the right of the Compiler combo box. The Java
Properties dialog is displayed.

For Java, you can have multiple JDKs installed on your computer at the same time and configure SlickEdit
to use different JDKs for each project. The interface provides the name and location for each JDK so that
you can select it for tagging or building. See Language-Specific Compiler Properties for more information
about these options.
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Java Options Dialog
The Java Options dialog contains settings used when you build or execute a Java project. Most of the
settings are stored for the particular Java project and configuration selected. You can set different values
for different projects and for different configurations of the same project. For example, you might have
different settings for the Debug configuration than from the Release configuration, allowing you to turn on
optimizations used for release that are incompatible with debugging.
To access the Java Options dialog, first make sure you have a Java project or file open, then from the main
menu, click Build > Java Options (or, use the javaoptions command).

There are three settings on the dialog that apply to all tabs:
•
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Settings for - The Settings for drop-down list at the top of the dialog is used to specify the project
configuration you want to affect with the option settings. This is the same field that is on the Project
Properties dialog, where you can also create new configurations. See Project Configurations for
more information.
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•

JDK installation directory (affects all projects and configurations) - Specifies the full path to
the root of the JDK used to build and execute Java programs. This value is shared by all Java
projects and all configurations. Click the button to the right of the field to browse. Use the dropdown button to select a recently used entry.

•

Ant installation directory (affects all projects and configurations) - Specifies the full path to
the root of the Ant installation directory. Ant is a commonly used build tool for Java. It is not
shipped with SlickEdit, so you need to specify where it is installed. Click the button to the right of
the field to browse. Use the drop-down button to select a recently used entry.

The other settings and options are divided into the following tabs:
•
•
•
•
•
•
•

Compiler Tab
Javadoc Tab
Jar Tab
Classpath Tab
JRE Tab
Debugger Tab
Live Errors Tab

NOTES
•

Options that are self-explanatory are not described in the documentation.

•

Prior to making changes on the tabs of the dialog, be sure that your desired project
configuration is selected in the Settings for drop-down list at the top of the dialog.

Compiler Tab
The Compiler tab on the Java Options dialog (Build > Java Options) is shown below.
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This tab contains the following fields and options:
•

Compiler name - Specifies the name of the compiler executable without the file extension. Click
the Ellipsis button to browse for the file.

•

Output directory (-d) - Specifies the full path to a directory to save the generated class files. Click
the Ellipsis button to browse for the directory.

•

Optimize output (-O)

•

Generate no warnings (-nowarn)

•

Verbose compiler output (-verbose)

•

Notify about locations where deprecated APIs are used (-deprecation)

•

Generate debug information (-g)

•

Source Compliance level - Specifies the JDK version number to use when parsing the code. For
example, JDK 1.6 can still parse the syntax for code written using JDK 1.4. Use this field to tell the
compiler which Java syntax to use. This is the same as setting the -source option on the javac
command line.

•

Target Compliance level - Setting this value will generate code that will run on the specified
version of the Java VM. This is the same as setting the -target option on the javac command line.

•

Other options - Specify additional command line options in this text field. For example, you can
use this field to enter a value like "-sourcepath c:\dev\src\BigProject".

Javadoc Tab
The Javadoc tab on the Java Options dialog (Build > Java Options) contains options to configure the
application that processes the Javadoc comments in your code to produce project documentation. By
default, SlickEdit® uses the javah program. Many of the options are specific to that processor. If you
choose to use a different program, uncheck the command line arguments and enter your options using the
Other options field.
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This tab contains the following fields and options:
•

Javadoc app name - Specifies the name of the executable used to process the Javadoc
comments in your source code. By default, this is set to javadoc. The extension is not needed.
Click the Ellipsis button to browse for the file.

•

Output directory (-d) - Specifies the directory in which to save the generated Javadoc. You can
specify a full path or relative path. Relative paths are interpreted relative to the project location,
specified when you created the project. For example, a value of docs will create a subdirectory in
the project directory to store the output from the Javadoc processor.

•

Include @version paragraphs (-version)

•

Include @author paragraphs (-author)

•

Do not include @deprecated paragraphs (-nodeprecated)

•

Do not generate class hierarchy (-notree)

•

Do not generate index (-noindex)

•

Other options - Specify additional command line options in this text field to be passed to the
Javadoc processor.

Jar Tab
The Jar tab on the Java Options dialog (Build > Java Options) is used to configure the Jar application that
is used to package compiled Java classes.
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This tab contains the following fields and options:
•

Jar app name - Specifies the name of the Jar executable, without the extension. Click the Ellipsis
button to browse for the file.

•

Archive filename - Specifies the name of the archive to create.

•

Manifest filename - If you want to create a manifest, specify the name of the manifest file here.

•

Store only - no compression (-0)

•

Verbose output (-v)

•

Other options - Specify additional command line options to pass to the Jar application.

•

Additional class files not included in this project (-C) - Used to specify additional classes you
would like to include in the archive.
o

Add File - Click to add a new class file to the archive.

o

Add Path - Click to specify a directory. All of the classes in that directory will be added.

o

Remove - Click to remove the selected file or directory.

Classpath Tab
In Java, the classpath defines a search path for compiled Java classes. The elements are searched in the
order specified and the first matching class is used. The Classpath tab on the Java Options dialog (Build
> Java Options) allows you to configure the Java classpath used in SlickEdit® for running and debugging
programs. This does not affect the classpath set in the operating system.
If you have different classpaths for different projects, configuring the classpath inside of SlickEdit is very
useful. If you have a single classpath and use it with other external tools, it is best to configure it in the
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operating system and then put a reference to the external classpath in SlickEdit by using the Add Path
button on this tab.

This tab contains the following fields and options:
•

Add Path - Click to browse for a directory. This directory is added to the classpath.

•

Add Jar File - Click to add a JAR file to the classpath.

•

Add Class Path - Click to insert the environment variable that contains the classpath defined in
the operating system.

•

Edit - Click to edit the selected classpath element.

•

Delete - Click to delete the selected classpath element.

•

Up/Down - Use the Up and Down buttons to move the selected item up and down in the list.

•

Use Classpath settings for antmake commands - When this option is selected, the SlickEdit
classpath is passed to Ant. See Build Methods for Ant and NAnt for more information about Ant
support.

JRE Tab
The JRE tab on the Java Options dialog (Build > Java Options) is used to configure options for the Java
Runtime Environment. These are used when executing a Java program inside SlickEdit®.
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This tab contains the following fields and options:
•

JRE app name - Specifies the name of the executable for the Java interpreter, java by default.
The extension is not needed. Click the Ellipsis button to browse for the executable.

•

Main class - Specifies the name of the class to begin execution. In Java, each class can contain a
main function. This value determines where execution begins when you select Build > Execute
for this project.

•

Arguments - Specifies parameter values passed to the main function contained in the main class.

The remaining options are common configuration parameters to pass to the Java interpreter. Each
displays the command line switch used. For more information, look up the corresponding switch in the JRE
documentation. If these values are not supported by the JRE you are using, uncheck them and use Other
options to pass arguments to the JRE.

Debugger Tab
The Debugger tab on the Java Options dialog (Build > Java Options) configures the debugger to be used
when you select Debug > Start. You have two choices for debugging:
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•

Use the SlickEdit® debugger, which provides a graphical front-end for debugging.

•

Use the JDB debugger, which provides a command line interface.
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The first two options are used to select which debugger to use:
•

Use SlickEdit debugger (-Xdebug -Xrunjdwp: ...) - This option provides a graphical front-end for
debugging that displays your code and provides windows for local variables and other information
(see Debugging).]
o

•

Port - Specifies which port to use to communicate with the Java debugger.

Use JDB debugger - With this option, SlickEdit uses a command line interface to interact directly
with JDB. The options below let you specify command line arguments passed to the debugger. For
more information, look up the corresponding switch in the JDB documentation.
o

Verbose output (-verbose)

o

Run application in the Hotspot(TM) performance engine (-thotspot)

o

Launch at startup (-launch)

o

Debugger - Specifies the executable for the debugger. The extension is not needed. Click the
ellipsis button to browse for the file.

•

Run the application in the Classic VM (-classic / -tclassic) - When this option is selected, the
application is run using the Java 2 Classic VM.

•

Other options - Specifies additional command line arguments to be passed to the debugger.

Live Errors Tab
The Live Errors tab on the Java Options dialog (Build > Java Options) is used to configure the Live Errors
feature. Live Errors identifies syntax errors as you type. SlickEdit compiles your code in the background
and highlights errors directly in the editor.
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This tab provides the following fields and options:
•

Enable Live Errors - When selected, the Live Errors feature is activated. This setting is checked
by default if SlickEdit has detected a valid JDK 6, or compatible, installation on your system, the
first time a Java project is opened. For some coding, you may want to disable Live Errors since it
will point out all syntax errors, which are common in incomplete code.
After activating Live Errors, you can use the rte_next_error command to jump through the live
errors in the current file. Bind this command to a key sequence for more efficiency.

NOTES
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•

For Java Live Errors to work, you must have the full JDK downloaded and installed from
Sun, and you must specify the root of the JDK installation in the JDK installation directory
field of the Java Options dialog (Build > Java Options), unless it is automatically detected
upon startup. There is no requirement that you build your code with JDK 6, only that it is
available to Live Errors.

•

If you have Java Live Errors running and wish to specify a different JDK 6 (or compatible
JDK) root, after changing the JDK path on the Java Options dialog, you must restart
SlickEdit.

•

In order to boost performance, Java Live Errors generates .class files as you code. These
files are stored in the java_rte_classes subdirectory of your config. You can remove these
files, but they will be rebuilt the next time Java Live Errors is invoked.

•

To specify the source compliance level, use the Source Compliance level setting on the
Compiler Tab.
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•

Deprecation warnings - When this option is selected, a Warning bitmap appears when Live
Errors encounters a keyword that has been deprecated. This is useful for programmers coding to
strict Java standards.

•

No Warnings - When this option is selected, warning notices from Live Errors are not displayed.

•

Sleep Interval(ms) - Specifies the amount of time, in milliseconds, in which a Live Errors thread
sleeps before checking for errors (during times when an error check is not forced). Use this to tune
performance. A larger value will give the editor more time between builds and should reduce any
performance issues.

•

Path to JDK 6 or later - Specifies the root directory of a valid JDK 6 or compatible JDK
installation. Live Errors requires JDK 6 or a compatible JDK to run, and will not activate if this path
is not correct. SlickEdit attempts to populate this field for you the first time a Java project is
opened. Click the Ellipsis button to browse for the directory.

Java Formatting Options Interface
Options are available for Java for changing the Syntax Indent and Syntax Expansion style settings. To
access these options, from the main menu, click Tools > Options > Languages, expand Application
Languages > Java, then click Java Formatting Options.
NOTE Languages similar to Java have similar Formatting Options screens that are not specifically
documented.

The following settings are available:
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•

Begin/end style - Specify the brace style to be used for Syntax Indent and Syntax Expansion. The
hyperlink indicates if Adaptive Formatting is on or off for this setting. After specifying the brace
style, choose from the following options:
o

Insert braces immediately - Specifies whether template should be inserted with braces.

o

Insert blank line between braces - Specifies whether a blank line should be inserted
between braces when a template expands with braces.

o

Quick brace/unbrace one line statements - Enables Quick Brace/Unbrace, features that
allow you to convert a single line statement to a brace-enclosed block, and vice versa. See
Quick Brace/Unbrace for more information.

o

Place “else” on same line as “}” - When this option is selected, SlickEdit® places the else
keyword on the same line as }. This is common when using brace Style 1.

•

Indent first level of code - Specifies whether Syntax Indent should indent the cursor after
declarations such as functions.

•

Use continuation indent on function parameters - Determines whether function parameters
should always use the continuation indent.
By default, SlickEdit formats multi-line function parameters as follows:
myLongMethodName(firstarg,
secondarg,
thirdarg
);
myLongMethodName(
firstarg,
new ActionListener() {
public void actionPerformed(ActionEvent e) {
createdButtonFired(buttonIndex);
}
},
thirdarg
);
myLongMethodName(new ActionListener() {
// special case anonymous class
first argument
public void actionPerformed(ActionEvent e) {
createdButtonFired(buttonIndex);
}
},
secondarg,
thirdarg
);
myLongMethodName(
secondarg,
new ActionListener() {
public void actionPerformed(ActionEvent e) {
createdButtonFired(buttonIndex);
}
},
thirdarg
);

If Use continuation indent on function parameters is selected, the format will change as
follows:
myLongMethodName(firstarg,
secondarg,
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thirdarg
);
myLongMethodName(
firstarg,
new ActionListener() {
public void actionPerformed(ActionEvent e) {
createdButtonFired(buttonIndex);
}
},
thirdarg
);
myLongMethodName(new ActionListener() {
// special case anonymous class
first argument
public void actionPerformed(ActionEvent e) {
createdButtonFired(buttonIndex);
}
},
secondarg,
thirdarg
);

•

Indent CASE from SWITCH - When checked, Syntax Expansion places the case statement
indented from the switch statement column. The hyperlink indicates if Adaptive Formatting is on or
off for this setting.

•

No space before parenthesis - Determines whether a space is placed between a keyword such
as if, for, or while and the open paren when syntax expansion occurs. Example: (if( or if () The
hyperlink indicates if Adaptive Formatting is on or off for this setting.

•

Insert padding between parentheses - When checked, a space is placed after the open paren,
and before the close paren, providing padding for the enclosed text. For example, if () becomes
if ( ). The hyperlink indicates if Adaptive Formatting is on or off for this setting.

Java Beautifier Dialog
To beautify Java source code, from the main menu click Tools > Beautify (or use the gui_beautify
command). The Java Beautifier dialog appears, where you can specify preferences for how the code is
beautified. The Java Beautifier contains the same options and settings as the C/C++ Beautifier. See C/C++
Beautifier for more information.

Organize Java Imports Options Interface
Options are available on the Options dialog to configure the Organize Imports feature (Tools > Options >
Languages > Application Languages > Java > Organize Java Imports). A more direct route to the options
is to use one of the following methods:
•

From the main menu, click Tools > Imports > Options

•

Select Imports > Options from the right-click context menu in the editor window.

•

Use the jrefactor_organize_imports_options command.
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The following settings are available:
•

Package explicit import limit before using wildcard(.*) - If more than this number of classes are
explicitly imported from the same package in one file, the imports will be replaced with a single
wildcard import.

•

Add blank line between groups of imports - Organize Imports will group imports by package
name or top-level package name. Select this option to force Organize Imports to add a blank line
between these groups instead of having just one flat list of imports.
o
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Number of package nesting levels to group imports by - If this is set to 1, import
statements will be grouped by top-level package name only. For example, all your imports
from java. packages would be in a separate group from your imports from com. packages. If
set to 2, import statements will be grouped by second level package names. For example, all
your imports from java.util would be in a separate group from your imports from java.awt.

•

Automatically add import during code help for Java - If selected, SlickEdit® will attempt to
automatically add imports as you edit Java code.

•

Automatically add import during code help for JSP - If selected, SlickEdit will attempt to
automatically add imports as you edit Java code embedded in HTML. JSP imports are added
using the following notation: <%@ page import="java.util.Vector"%>.

•

Package sort order - This list specifies the order in which package groups are sorted. Use the
Ellipses (...) button to add a new package. Use the Up and Down arrow buttons to move items.
Use the X button to delete the currently selected package from the list.
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Javadoc Editor Dialog
Use the Javadoc Editor to generate Javadoc syntax comments for Java, C, C++, JavaScript, and Slick-C®.
To access the Javadoc Editor, right-click within the edit window and select Edit Javadoc Comments. Or,
with the cursor inside a comment, click Document > Edit Javadoc Comment.
To add a custom or unsupported tag, append the tag (with an @ prefix) and its description into the
Description text box. You can add @serial, @serialField, and @serialData fields this way.
For more information, see Sun’s Javadoc documentation at http://java.sun.com.
NOTE SlickEdit® provides powerful capabilities to create and edit Javadoc comments within the
editor. See Commenting for more information.

Javadoc Beautifier Options Dialog
To beautify Javadoc comments or set up Javadoc Beautifier options, first invoke the Javadoc Editor by
right-clicking within the edit window and selecting Edit Javadoc Comments. Then click the Options
button. The Javadoc Beautifier Options dialog is displayed. The following settings are available:
•

Align parameter comments to longest parameter name - If checked, the parameters are
aligned to the length of the longest parameter name. If the parameter name length is less than the
minimum length, the minimum length is used. If the parameter length is longer than the maximum
parameter length, the description for the parameter will start on the next line.

•

Align exception comments to longest exception name - If checked, the exceptions are aligned
to the length of the longest exception name. If the exception name length is less than the minimum
length, the minimum length is used. If the exception length is longer than the maximum exception
length, the description of the parameter will start on the next line.

•

Align return comments - Indicates whether @return comments should be aligned to the first line
of comment text. No alignment is performed if tags which are indent-sensitive such as the <pre>
tag are used.

•

Align deprecated comments - Indicates whether @return comments should be aligned to the
first line of comment text. No alignment is performed if tags which are indent-sensitive such as the
<pre> tag are used.

•

Add blank line after parameter comment - If checked, a blank line is added if a tag follows an
@param tag.

•

Add blank line after parameter comment group - If checked, a blank line is added if a tag
follows an @param group.

•

Add blank line after return comment - If checked, a blank line is added if a tag follows the
@return tag.

•

Add blank line after description - If checked, a blank line is added between the description and
the first @ tag. This option is ignored if the description contains a custom or unsupported @ tag.

•

Add blank line after example - If checked, a blank line is added if a tag follows the @example
tag.
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XML and HTML
Features for XML and HTML are described below. See also XML/HTML Formatting.

XML
XML features in SlickEdit® include Context Tagging®, validation, well-formedness checking, a beautifier,
Color Coding, URL Mapping, Syntax Expansion, and Syntax Indenting for XML, XSLT, and schemas (DTD
or XSD).
For information about working with Ant XML files for Java, see Build Methods for Ant and NAnt.

XML Toolbar
The XML toolbar is available for quickly accessing common XML operations. To display the XML toolbar,
from the main menu, click View > Toolbars > XML. By default, three buttons are available:
•

Beautify selection or entire buffer - Use this button to instantly beautify the current file according
to the Beautifier settings. See XML Beautifier for more information.

•

Validate XML document - Use this button to validate an XML file against a DTD or schema. The
results of the validation are displayed in the Output tool window. If there are errors during
validation, you can double-click on the error line and the appropriate file will be opened and moved
to the specified line.

•

Check for Well-Formedness - Use this button to check if the document is well-formed according
to XML syntax rules.

XML Formatting Options
Content in XML and HTML files may be set to automatically wrap and format as you edit, through the XML/
HTML Formatting feature. See XML/HTML Formatting for complete information.
Other miscellaneous tag and attribute options are provided through the XML Formatting Options screen.
To access these options, from the main menu, click Tools > Options > Languages, expand XML/Text
Languages > XML, then click XML Formatting Options.
TIP You can also display the XML Formatting Options screen by clicking the XML Options button on
the XML/HTML Formatting Scheme Configuration dialog (see XML/HTML Formatting Scheme
Configuration Dialog).
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The following settings are available:
•

Auto validate on open - When this option is selected, XML files are automatically validated when
they are opened. The result of the validation is displayed on the Output tool window.

•

Auto symbol translation - When selected, Auto Symbol Translation is enabled, a feature that
automatically converts a character or sequence of characters to the appropriate entity reference.
Click the Settings button to display the Symbol Translation Editor. See Auto Symbol Translation
for more information.

•

Auto formatting options - These settings are used to configure XML/HTML Formatting.
o

Default formatting scheme - Specifies the default formatting scheme to use for the selected
language. See Default Schemes for more information.

o

Enable content wrapping - When selected, content wrapping is enabled, based on the
scheme configuration for the selected formatting scheme. See Content Wrap Settings for
more information.

o

Enable tag layout - When selected, tag layout is enabled, based on the scheme configuration
for the selected formatting scheme. See Tag Layout Settings for more information.

o

Configure Schemes - Use this button to open to the XML/HTML Formatting Schemes
Configuration dialog to configure tags. See XML/HTML Formatting Scheme Configuration
Dialog.

XMLdoc Editor
Use the XMLdoc Editor to generate Microsoft XML syntax comments for C#, C, C++, Java, JavaScript, and
Slick-C®. Note that by default, when creating a new comment, the Javadoc Editor is displayed for all file
types except C#. To work around this limitation, start an XML comment with “///” and then right-click in the
edit window and select Edit XML Comments.
Unknown XML tags are left “as is” and not removed.
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XML Beautifier
To beautify XML source code, from the main menu click Tools > Beautify (or use the gui_beautify
command). The XML Beautifier dialog appears, where you can specify preferences for how the code is
beautified.
CAUTION The XML Beautifier is not affected by XML/HTML Formatting. If you run the
beautifier on documents that have been automatically formatted through XML/HTML
Formatting, you may find unexpected results.
You can use the commands xml_beautify or xml_beautify_selection to instantly beautify the file or the
selection according to the settings on the Beautifier dialog.
NOTE The XSD Beautifier contains the same options and settings as the XML Beautifier.
The following buttons and options are available on the Beautifier:
•

Beautify - Beautifies current selection or buffer and closes the dialog box.

•

Reset - Restores the dialog box settings to the values that appeared when you invoked the dialog.

•

Save Settings - Saves beautify options in uformat.ini file. These settings are used by the
xml_beautify command.

•

Restrict to selection - When on, only lines in the selection are beautified.

•

Sync extension options - When on, the language options are updated to reflect any changes that
these dialogs have in common.

The tabs on the XML Beautifier are described in the sections below.

Indent Tab
The Indent tab on the XML Beautifier is pictured below.
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The following settings are available:
•

Indent for each level (Syntax indent) - The amount to indent for each new nesting level of tags.
We have put the words “Syntax indent” in parenthesis to help indicate that this field has the same
value as the Syntax indent text box setting on the language-specific Indent options screen (see
Language-Specific Indent Options). By default, we initialize this text box with your current
language setup setting.

•

Indent with tabs - When on, tab characters are used for leading indent of lines. This value
defaults to the Tabs text box setting on the language-specific Indent options screen (see
Language-Specific Indent Options).

•

Tab size - Specifies output tab size. The output tab size is only used if the Indent with tabs check
box is on. This value defaults to the Syntax indent text box on the language-specific Indent
options screen (see Language-Specific Indent Options).

•

Original tab size - Specifies what the original file's tab expansion size was. We need to know the
tab expansion size of your original file to handle reusing indent amounts from your original file.
Currently the beautifier only reuses the original source file's indenting for comments. This option
has no effect if the original file has no tab characters.

•

Max line length - Specifies the maximum length a line can be before it is wrapped to a new line.
This max line length is relative to the current indent level. For example, if you were inside an
XHTML <td> block which was at an indent level of 30, and your max line length was set to 80, then
that line would not be wrapped until it reached a total length of 30+80=110 characters. Set this
value to 0 if you want your line breaks preserved.

•

Broken tag lines - Specify how broken tag lines are treated from the following options:
o

Indent from tag column by - Specifies the amount to indent for broken tag lines from the
starting column of the tag. Specify 0 to align broken tag lines with the starting column of the
tag.

o

Use original relative indent - Reindent broken tag lines using the original relative indent
amount from the starting column of the tag.

o

Preserve original indent - Preserve the original absolute indent amount on broken tag lines.

Tags Tab
The Tags tab on the XML Beautifier is pictured below.
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The Tags tab contains the following options and settings:
•

Tag case - Specifies how you want your tag names cased. For example, if you choose UPPER,
then <tag> would be beautified to <TAG>. Under normal circumstances you will want to preserve
the case of your XML tags, but for certain special cases (e.g. XHTML) you may want to change
this setting.

•

Tag settings - The settings in this group box apply to the tag that is selected in the list box. The
<DEFAULT TAG> tag item in the list of tags specifies settings to use when no settings exist for a
tag found during beautification.

•

o

Add - Display the Add Tag dialog. This dialog allows you to add a tag definition to the list and
specify how it will be beautified.

o

Remove - Used to remove the currently selected tag.

Content - Specify how to beautify content from the following options:
o

Reformat - When off, all white space and line breaks are preserved. However, tags are
formatted (tag case, attribute case, etc.).

o

Indent - When on, nested tags will be indented one syntax indent level. Furthermore, if
Reformat is on, the selected tag's CDATA content (i.e. plain text), bounded by the opening
and closing tag, will be indented one syntax indent level.
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o

Literal - When on, all white space and line breaks are preserved. In addition, tags within the
content are treated as literal text. If Reformat is on, then leading indent is adjusted. This
option is useful for XHTML.

TIP Some examples of content settings for specific tags are:
•

style - Literal (content is indented to the same level as the <style> open tag)

•

style - Reformat, Literal (content is indented one syntax indent level from the <style> open
tag)

•

pre - All Content check boxes off

•

blockquote - Reformat, Indent

•

End tag - When on, the selected tag has an end tag. For XML you will normally want this to remain
on.

•

End tag required - When on, the selected tag's ending tag is required. For XML you will normally
want this to remain on.

•

Preserve tag body - When on, all properties of the body of the tag selected will be preserved. This
is especially useful for processing instructions like <?xml ... ?> where you do not want the
embedded text to be beautified.

•

Preserve tag position - When on, the position of the tag within the document is preserved. This is
especially useful with JSP/ASP tags where reindenting the tag would interrupt the flow of the script
code.

•

Line breaks - Select the way lines are broken:
o

Before open tag - Specify the number of line breaks before the opening tag. For example, if
you were to set the number of line breaks before the opening tag to 3 for the XHTML <td> tag,
and the original content was:
<tr>
<td>
</td>
</tr>

The resulting content would be:
<tr>

<td>
</td>
</tr>

Please note that the number of line breaks is not the same as the number of blank lines. If you
wanted three blank lines, then you would set the number of line breaks to 4.
o

After close tag - Specify the number of line breaks after the closing tag. For example, if you
were to set the number of line breaks after the closing tag to 3 for the XHTML <td> tag, and the
original content was:
<TR>
<TD>
</TD>
</TR>

The resulting content would be:
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<TR>
<TD>
</TD>

</TR>

Please note that the number of line breaks is not the same as the number of blank lines. If you
wanted three blank lines, then you would set the number of line breaks to 4.
o

Stand-alone - When on, the selected tag will always have at least one preceding and trailing
line break on both its opening and ending tag when beautified. You can specify that there be
more than one line break by setting Line breaks for the opening and closing tags.

Attributes/Values Tab
The Attributes/Values tab of the XML Beautifier is pictured below.

The Attributes/Values tab contains the following settings:
•

Attribute case - Specifies how you want attributes cased inside the body of a tag. For example, if
you choose UPPER, then <td align=”right”> would be beautified to <td ALIGN=”right”>. Under
normal circumstances you will want to preserve the case of your XML attributes, but for certain
special cases (e.g. XHTML) you may want to change this setting.

•

Word value case - Not available for XML.

•

Hex value case - Not available for XML.

•

Quote word values - Specifies whether you want word values enclosed in double quotes after the
= of an attribute inside the body of a tag. For example, <td align=right> would be beautified to <td
align=”right”>. Select Preserve if you want word values left alone. Under normal circumstances
you will want to preserve your XML values, but for certain special cases (e.g. XHTML) you may
want to change this setting.

•

Quote number values - Specifies whether you want number values enclosed in double quotes
after the = of an attribute inside the body of a tag. For example, <td width=590> would be
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beautified to <td width=”590”>. Select Preserve if you want number values left alone. Under
normal circumstances you will want to preserve your XML values, but for certain special cases
(e.g. XHTML) you may want to change this setting.
•

Quote all values - When on, all values will be quoted after the = of an attribute inside the body of
a tag. For example, <td align=right> would be beautified to <td align=”right”>.Under normal
circumstances you will want to preserve your XML values, but for certain special cases (e.g.
XHTML) you may want to change this setting.

Comments Tab
The Comments tab of the XML Beautifier is pictured below.

The Comments tab contains the following options and settings:
•

Indent stand alone comments - When on, indicates whether comments which appear on lines by
themselves with no content to the left are indented to the current content indent level. The
following is an example of a stand-alone comment:
<!-- stand alone
comment
-->

•

Indent column 1 comments - Normally comments that start in column 1 are left alone. Turn this
on if you want the indent for these comments to be adjusted as well.

•

Define Comments - Displays the XML Comments dialog. This dialog allows you to define what
the beautifier recognizes as a comment. The sequence <!-- --> is defined as the XML comment by
default. If you delete all comment definitions then all comments will be parsed as content.

•

Trailing comments - Specify how trailing comments are treated from the following options:
o

Specific column - This text box specifies the column that “trailing comments” should be
placed at. By trailing comments, we mean comments which appear at the end of lines which
contain tags. An example of a trailing comment is:
<TD>
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o

Original absolute column - When on, “trailing comments” are placed at the same column as
the original source file. By trailing comments, we mean comments which appear at the end of
lines which contain tags.

o

Original relative column - When on, “trailing comments” are indented by reusing the indent
after the last character of the end of the statement or declaration of the original source file. By
trailing comments, we mean comments which appear at the end of lines which contain tags.
The following is an example of code before beautifying trailing comments:
<Outer>
<Inner><four characters><!-- trailing comment -->
</Inner>
</Outer>

The resulting code would be:
<Outer>
<Inner><four characters><!-- trailing comment -->
</Inner>
</Outer>

Advanced Tab
The Advanced tab of the XML Beautifier is pictured below.

The following option is available on the Advanced tab:
•

Remove blank lines - When on, blank lines are deleted.

Schemes Tab
The Schemes tab of the XML Beautifier is pictured below.
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To define a new scheme, use the Beautifier to set the various beautify options and then press the Save
Scheme button on the Schemes tab. User defined schemes are stored in uformat.ini.

DTD Caching
When you open an XML document that has a document type definition of (!DOCTYPE) that refers to a
remote external DTD, the DTD file is downloaded and cached locally. The DTD is processed to provide
Context Tagging® and better color coding. Currently, only HTTP (and not FTP) remote files are supported.
This automatic caching allows you to work offline and edit XML documents that reference remote DTDs
when you do not have an Internet connection. If you want to force re-caching of the DTD for the current
XML document, right-click to open the context menu and select Apply DTD changes. Applying DTD
changes is necessary after you create a new XML document and complete the document type definition
(!DOCTYPE).

Opening DTD Files from XML
To open the external DTD referenced by document type definition (!DOCTYPE), place the cursor
anywhere on the !DOCTYPE tag and press Alt+1 (or right-click to display the context menu and select Go
to Error/Include File).

URL Mapping
SlickEdit® provides a way to map URLs to different locations. Whenever opening a URL, the URL map is
examined to see if this URL is mapped to a different location. If the URL is mapped elsewhere, then that
mapped location is used.
This feature allows you to work offline or from a test location. For example, if you need to work with XML
documents that contain external DTDs while offline you can map the URL to the DTD to a local file.
Similarly, if you wanted to test changes to a DTD without modifying every XML document’s DTD
references, you can map the URL to the test DTD location.
Optionally, you can specify a default lookup directory that contains all of your DTDs and namespace
schemas files. Every mapping doesn't need to be explicitly configured. You can also create mappings for
namespace URIs as well as DTD files.
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To map a URL, complete the following steps.
1. From the main menu, click Tools > Options > Network & Internet Options > URL Mappings.
2. Click the Add button, and a new line opens.
3. In the From field, type in the URL that will be mapped to a different location.
4. Press Tab or click in the To field and type in the location to use for this URL.
5. Optionally, use the Search directory field to specify the default lookup directory for DTDs and
namespaces. Files in this directory are searched prior to validation.
6. Click OK to save the changes and close the Options dialog.

Toggling Between Begin and End XML Tags
Place the cursor anywhere on the begin or end tag and press Ctrl+] to find the corresponding end or begin
tag respectively.

HTML
This section describes some of the features and options that are available for HTML, including languagespecific options, the HTML Beautifier, and more.
HTML support includes Context Tagging®, a beautifier, Color Coding, Syntax Expansion, and Syntax
Indenting for HTML, JSP, and ASP. Many of the language features in SlickEdit® are supported for
languages embedded in HTML, including Context Tagging, Color Coding, SmartPaste®, Syntax
Expansion, and Syntax Indenting.
TIP When working with HTML files, you can toggle between the begin and end HTML tags by
pressing Ctrl+].

HTML Toolbar
The HTML toolbar is available for many common operations you may want to perform. To display the
HTML toolbar, from the main menu, click View > Toolbars > HTML.
To invoke a Web browser or to display the current file in a browser, use the Web Browser button on the
HTML toolbar. To configure the browser that is used, see Configuring the Web Browser below.

Exporting to HTML
To save the current open buffer as HTML file with formatting and color coding, from the main menu, click
File > Export to HTML (or use the export_html command).

Configuring the Web Browser
To specify the Web browser that is used for previewing, from the main menu click Tools > Options >
Network & Internet Options > Web Browser Setup. See Web Browser Setup Options for more
information.

HTML Formatting Options
Content in XML and HTML files may be set to automatically wrap and format as you edit, through the XML/
HTML Formatting feature. See XML/HTML Formatting for complete information.
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Other miscellaneous tag and attribute options are provided through the HTML Formatting Options screen.
To access these options, from the main menu, click Tools > Options > Languages, expand Web
Authoring Languages > HTML, then click HTML Formatting Options.
TIP You can also display the HTML Formatting Options screen by clicking the HTML Options button
on the XML/HTML Formatting Scheme Configuration dialog (see XML/HTML Formatting Scheme
Configuration Dialog).
NOTE Languages similar to HTML have similar Formatting Options screens that are not specifically
documented.

The following settings are available:
•
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Case for inserted tags - This option is where you specify if you want the tag names to be
lowercase or uppercase. For example, if you select Uppercase, then <td> becomes <TD>. The
hyperlink indicates if Adaptive Formatting is on or off for this setting.
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•

Case for inserted attributes - This option is where you specify if you want attributes to be
lowercase or uppercase inside the body of a tag. For example, if you select Uppercase, then <td
align=right> would become <td ALIGN=right>. The hyperlink indicates if Adaptive Formatting is on
or off for this setting.

•

Case for inserted single word values - This option is where you specify if you want word values
to be uppercase or lowercase when the = of an attribute is inside the body of a tag. For example, if
you select Uppercase, then <td align=right> becomes <td align=RIGHT>. The hyperlink indicates
if Adaptive Formatting is on or off for this setting.

•

Case for hex values - This option is where you specify if you want hex values to be uppercase or
lowercase after the = of an attribute inside the body of a tag. For example, if you select
Uppercase, then <body bgcolor=#ffffff> would become <body bgcolor=#FFFFFF>. The hyperlink
indicates if Adaptive Formatting is on or off for this setting.

•

Embedded ASP dialect - The language that you select here determines the default embedded
language mode for ASP files.

•

Use path for file entries - This option is used by the HTML toolbar. When this attribute is
selected, path information is included when inserting file names into the value of an attribute. For
example, creating a link with this option turned on might result in the following example.
<A HREF=file://c|/dev/html/index.htm#>sample link</A>

When this option is not selected, the result is the following example.
<A HREF= index.htm#>sample link</A>

•

Use lower case file names when inserting links - This option is used by the HTML toolbar.
When this option is selected, the lowercase file names are used when inserting links into the value
of an attribute. See the example for Use paths for file entries.

•

Use quotes for numerical values - When this option is selected, word values are enclosed in
double quotes after the = of an attribute inside the body of a tag.

•

Use quotes for single word values - When this option is selected, number values are enclosed
in double quotes after the = of an attribute inside the body of a tag.

•

Insert colors using color names (if possible) - When this option is selected, colors are inserted
by using the color names if possible. For example, instead of using #ff0000 to represent the color
red, the color name red is used.
<BODY bgcolor=#ff0000>
<!-- and -->
<BODY bgcolor=red>
<!-- are identical -->

•

Use <DIV> tags for alignment - This option is used by the HTML toolbar. When this option is
selected, the <DIV> tag is used for aligning text. For example, rather than using a <CENTER> tag
to designate alignment, use the following tagging:
<DIV ALIGN=CENTER>
</DIV>

•

Automatically insert ‘>’ when typing ‘<’ - When this option is selected, you can type the open
brace of a start tag (<), and SlickEdit automatically inserts the closing brace (>) while leaving the
cursor positioned between the braces, ready for you to type the tag.

•

Auto symbol translation - When selected, Auto Symbol Translation is enabled, a feature that
automatically converts a character or sequence of characters to the appropriate entity reference.
Click the Settings button to display the Symbol Translation Editor. See Auto Symbol Translation
for more information.

SlickEdit® User Guide

387

XML AND HTML

•

Auto formatting options - These settings are used to configure XML/HTML Formatting.
o

Default formatting scheme - Specifies the default formatting scheme to use for the selected
language. See Default Schemes for more information.

o

Enable content wrapping - When selected, content wrapping is enabled, based on the
scheme configuration for the selected formatting scheme. See Content Wrap Settings for
more information.

o

Enable tag layout - When selected, tag layout is enabled, based on the scheme configuration
for the selected formatting scheme. See Tag Layout Settings for more information.

o

Configure Schemes - Use this button to open to the XML/HTML Formatting Schemes
Configuration dialog to configure tags. See XML/HTML Formatting Scheme Configuration
Dialog.

HTML Beautifier
To beautify an HTML document, open the document you want to beautify, then from the main menu, click
Tools > Beautify (or use the gui_beautify command). The HTML Beautifier dialog will be displayed,
which allows you to make settings for how the code will be beautified.
CAUTION The HTML Beautifier is not affected by XML/HTML Formatting. If you run the
beautifier on documents that have been automatically formatted through XML/HTML
Formatting, you may find unexpected results.
You can use the commands h_beautify or h_beautify_selection to instantly beautify the file or the
selection according to the settings on the Beautifier dialog.
NOTE The CFML Beautifier contains the same options and settings as the HTML Beautifier.
The following buttons and options are available on the Beautifier:
•

Beautify - Beautifies current selection or buffer and closes the dialog box.

•

Reset - Restores the dialog box settings to the values that appeared when you invoked the dialog.

•

Save Settings - Saves beautify options in uformat.ini file. These settings are used by the
h_beautify command.

•

Restrict to selection - When on, only lines in the selection are beautified.

•

Sync extension options - When on, the language options are updated to reflect any changes that
these dialogs have in common.

The tabs on the HTML Beautifier are described in the sections below.

Indent Tab
The Indent tab on the HTML Beautifier is pictured below.

388

SlickEdit® User Guide

XML AND HTML

The following settings are available:
•

Indent for each level (Syntax indent) - The amount to indent for each new nesting level. We
have put the words “Syntax indent” in parenthesis to help indicate that this field has the same
value as the Syntax indent text box on the language-specific Indent options screen (see
Language-Specific Indent Options). By default, we initialize this text box with your current
extension setup setting.

•

Indent with tabs - When on, tab characters are used for leading indent of lines. This value
defaults to the Tabs text box on the language-specific Indent options screen (see LanguageSpecific Indent Options).

•

Tab size - Specifies output tab size. The output tab size is only used if Indent with tabs check box
is on. This value defaults to the Syntax indent text box on the language-specific Indent options
screen (see Language-Specific Indent Options).

•

Original tab size - Specifies what the original file's tab expansion size was. We need to know the
tab expansion size of your original file to handle reusing indent amounts from your original file.
Currently the beautifier only reuses the original source file's indenting for comments. This option
has no effect if the original file has no tab characters.

•

Max line length - Specifies the maximum length a line can be before it is wrapped to a new line.
This max line length is relative to the current indent level. For example, if you were inside a <TD>
block which was at an indent level of 30, and your max line length was set to 80, then that line
would not be wrapped until it reached a total length of 30+80=110 characters. Set this value to 0 if
you want your line breaks preserved.

•

Broken tag lines - Specify how broken tag lines are treated from the following options:
o

Indent from tag column by - Specifies the amount to indent for broken tag lines from the
starting column of the tag. Specify 0 to align broken tag lines with the starting column of the
tag.

o

Use original relative indent - Reindent broken tag lines using the original relative indent
amount from the starting column of the tag.

o

Preserve original indent - Preserve the original absolute indent amount on broken tag lines.
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Tags Tab
The Tags tab on the HTML Beautifier is pictured below.

The Tags tab contains the following options and settings:
•

Tag case - Specifies how you want your tag names cased. For example, if you choose UPPER,
then <td> would be beautified to <TD>.

•

Tag settings - The settings in this group box apply to the tag that is selected in the list box. The
<DEFAULT TAG> tag item in the list of tags specifies settings to use when no settings exist for a
tag found during beautification.

•

Add - Display the Add Tag dialog. This dialog allows you to add a tag definition to the list and
specify how it will be beautified.

•

Remove - Used to remove the currently selected tag.

•

Content - Specify how to beautify content from the following options:
o

Reformat - When off, all white space and line breaks are preserved. However, tags are
formatted (tag case, attribute case, etc.).

o

Indent - When on, the selected tag's content, bounded by the opening and closing tag, will be
indented one syntax indent level.

o

Literal - When on, all white space and line breaks are preserved. In addition, tags within the
content are treated as literal text. If Reformat is on, then leading indent is adjusted.

TIP Some examples of content settings for specific tags are:
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•

XMP - Literal

•

PRE - All Content check boxes off

•

BLOCKQUOTE - Reformat, Indent

•

STYLE - Reformat, Literal
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•

End tag - When on, the selected tag has an end tag. For example, the tag <TD> has a ending tag
tag that is </TD>, so End tag would be checked in this case.

•

End tag required - When on, the selected tag's ending tag is required. This means that the ending
tag is not optional. An example of a tag whose ending tag could be optional is <P>.

•

Preserve tag body - When on, all properties of the body of the tag selected will be preserved. This
is especially useful for JSP/ASP tags where you do not want the embedded Java or VBScript
inside the <% ... %> to be beautified.

•

Preserve tag position - When on, the position of the tag within the document is preserved. This is
especially useful with JSP/ASP tags where reindenting the tag would interrupt the flow of the script
code.

•

Line breaks - Select the way lines are broken:
o

Before open tag - Specify the number of line breaks before the opening tag. For example, if
you were to set the number of line breaks before the opening tag to 3 for the <TD> tag, and
the original content was:
<TR>
<TD>
</TD>
</TR>

The resulting content would be:
<TR>

<TD>
</TD>
</TR>

Please note that the number of line breaks is not the same as the number of blank lines. If you
wanted three blank lines, then you would set the number of line breaks to 4.
o

After close tag - Specify the number of line breaks after the closing tag. For example, if you
were to set the number of line breaks after the closing tag to 3 for the <TD> tag, and the
original content was:
<TR>
<TD>
</TD>
</TR>

The resulting content would be:
<TR>
<TD>
</TD>

</TR>

Please note that the number of line breaks is not the same as the number of blank lines. If you
wanted three blank lines, then you would set the number of line breaks to 4.
o

Stand-alone - When on, the selected tag will always have at least one preceding and trailing
line break on both its opening and ending tag when beautified. You can specify that there be
more than one line break by setting Line breaks for the opening and closing tags.
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Attributes/Values Tab
The Attributes/Values tab of the HTML Beautifier is pictured below.

The Attributes/Values tab contains the following settings:
•

Attribute case - Specifies how you want attributes cased inside the body of a tag. For example, if
you choose UPPER, then <td align=”right”> would be beautified to <td ALIGN=”right”>.

•

Word value case - Specifies how you want word values cased after the = of an attribute inside the
body of a tag. For example, if you choose UPPER, then <td align=”right”> would be beautified to
<td align=RIGHT>.

•

Hex value case - Specifies how you want hex values cased after the = of an attribute inside the
body of a tag. For example, if you choose UPPER, then <body bgcolor=”#ffffff”> would be
beautified to <body bgcolor=”#FFFFFF”>.

•

Quote word values - Specifies whether you want word values enclosed in double quotes after the
= of an attribute inside the body of a tag. For example, <td align=right> would be beautified to <td
align=”right”>. Select Preserve if you want word values left alone.

•

Quote number values - Specifies whether you want number values enclosed in double quotes
after the = of an attribute inside the body of a tag. For example, <td width=590> would be
beautified to <td width=”590”>. Select Preserve if you want number values left alone.

•

Quote all values - When on, all values will be quoted after the = of an attribute inside the body of
a tag. For example, <td align=right> would be beautified to <td align=”right”>.

Comments Tab
The Comments tab of the HTML Beautifier is pictured below.
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The Comments tab contains the following options and settings:
•

Indent stand alone comments - When on, indicates whether comments which appear on lines by
themselves with no content to the left are indented to the current content indent level. The
following is an example of a stand-alone comment:
<!-- stand alone
comment
-->

•

Indent column 1 comments - Normally comments that start in column 1 are left alone. Turn this
on if you want the indent for these comments to be adjusted as well.

•

Define Comments - Displays the HTML Comments dialog. This dialog allows you to define what
the beautifier recognizes as a comment. The sequence <!-- --> is defined as the HTML comment
by default. If you delete all comment definitions then all comments will be parsed as content and
possibly word-wrapped.

•

Trailing comments - Specify how trailing comments are treated from the following options:
o

Specific column - This text box specifies the column that “trailing comments” should be
placed at. By trailing comments, we mean comments which appear at the end of lines which
contain tags. An example of a trailing comment is:
<TD>

<!-- trailing comment -->

o

Original absolute column - When on, “trailing comments” are placed at the same column as
the original source file. By trailing comments, we mean comments which appear at the end of
lines which contain tags.

o

Original relative column - When on, “trailing comments” are indented by reusing the indent
after the last character of the end of the statement or declaration of the original source file. By
trailing comments, we mean comments which appear at the end of lines which contain tags.
The following is an example of code before beautifying trailing comments:
<TR>
<TD><four characters><!-- trailing comment -->
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</TD>
</TR>

The resulting code would be:
<TR>
<TD><four characters><!-- trailing comment -->
</TD>
</TR>

Advanced Tab
The Advanced tab of the HTML Beautifier is pictured below.

The following options are available on the Advanced tab:
•

End previous <P> tag when - Select from the following options:
o

Hitting another <P> tag - When on, the beautifier will interpret a <P> tag as a signal of the
end of any previous paragraphs.

o

Hitting a standalone tag - When on, the beautifier will interpret a standalone tag as a signal
of the end of any previous paragraphs. For example, in the following content, the <TABLE> tag
(assuming that the <TABLE> tag is a standalone tag) signals the end of the previous <P>
paragraph. This has the benefit of cleaning up unwanted (and unexpected) indenting. For
example:
<P>
This is a paragraph of content.
start of the table below it.

The paragraph will be ended by the

<TABLE>
<TR>
<TD>a table cell</TD>
</TR>
</TABLE>

•
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Remove blank lines - When on, blank lines are deleted.
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•

Beautify JavaScript - When on, embedded JavaScript is beautified according to your JavaScript
beautifier settings.

•

Edit JavaScript Settings - Click on this button to configure the JavaScript Beautifier settings. The
JavaScript Beautifier is the same as the C/C++ Beautifier - see C/C++ Beautifier for more
information.

Schemes Tab
To define a new scheme, set the various beautify options and press the Save Scheme button. User
defined schemes are stored in uformat.ini.

Auto Symbol Translation
Auto Symbol Translation automatically converts a character or sequence of characters to the appropriate
entity reference, saving you from having to repeatedly guess at the correct entity or look up reference
charts. This feature works automatically as you type, so you don’t need to press a special key or key
sequence to trigger the translation. For example, type >>, and SlickEdit® automatically converts the >>
sequence to &gt;, which is the entity reference for the right angle bracket (>). Typing && translates to
&amp;, the entity reference for the ampersand symbol (&).
Auto Symbol Translation uses the Alias mechanism in SlickEdit—the character or character sequence that
you type to trigger translation is actually a special kind of alias, henceforth called a “symbol alias”. SlickEdit
comes with some predefined symbol aliases. You can view these, customize them, and create your own by
using the Symbol Translation Editor dialog. The first time Auto Symbol Translation is triggered, a prompt
appears that describes the feature and lets you open the Symbol Translation Editor.

Enabling/Disabling Auto Symbol Translation
Auto Symbol Translation is enabled by default. The first time you type a symbol alias and automatic
translation occurs, a prompt is displayed that explains the feature and provides a button to access the
Symbol Translation Editor. You can also choose to prevent the prompt from appearing again in the future.

To turn off Auto Symbol Translation, from the main menu, click Tools > Options. Expand Languages and
your language category, then select your language and click [Language] Formatting Options. Clear the
Auto symbol translation option.
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Configuring Symbol Aliases
The Symbol Translation Editor dialog is used to configure symbol aliases. It can be displayed by clicking
Yes on the prompt that appears the first time a symbol translation occurs, or by clicking the Settings
button on the Formatting Options screen for your language (Tools > Options > Languages >
[LanguageCategory] > [Language] > [Language] Formatting Options).

The box on the left shows a list of symbol aliases. The edit window on the right contains the translation for
the selected alias. Click New to enter a new symbol alias, or click Delete to remove a selected alias.
Working with symbol aliases is the same as working with language-specific aliases. You can even use
escape sequences and Parameter Prompting for some interesting translation results. See Creating a
Language-Specific Alias for more information.
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XML/HTML Formatting
Content in XML and HTML files may be set to automatically wrap and format as you edit. XML/HTML
Formatting is essentially comprised of two features: Content Wrap, which wraps the content between
tags, and Tag Layout, which formats tags according to a specified layout. Both can be activated
individually for all XML and HTML files that are opened in SlickEdit®, or just for the current document.
Formatting schemes form the basis for how tags and content are formatted. A formatting scheme contains
any number of XML or HTML tags, each of which can be configured individually for indent levels, wrapping,
and tag structure. Multiple schemes can be defined—for example, you may want one scheme for HTML
files and another for XML files, or perhaps you are required to code certain files to various standards.
Schemes can be saved and imported, so they can be shared with your team. Tags for each scheme can be
entered manually or you can import tags from the current file.
CAUTION XML/HTML Formatting does not currently affect XML or HTML Beautifier settings. If
you run the beautifier on documents that have been automatically formatted through XML/
HTML Formatting, you may find unexpected results.

Enabling/Disabling XML/HTML Formatting
XML/HTML Formatting is on by default for XML and HTML files that you open in SlickEdit®. You can
activate and/or deactivate Tag Layout and/or Content Wrap for either file type on a global basis or on a per
document basis. Options to turn these features on/off are located on the Document > XML/HTML
Formatting menu.

Enabling/Disabling Globally
Automatic formatting can be enabled or disabled for every XML and/or HTML file that is created or opened
in SlickEdit®. These XML- and HTML-specific global options are toggled on/off by placing a check next to
Enable XML Formatting and/or Enable HTML Formatting. To toggle Tag Layout and/or Content Wrap
on or off for either file type, check or uncheck those items. For example, if you want both Tag Layout and
Content Wrap enabled for XML files, but you only want Content Wrap enabled for HTML files, place a
check next to Enable XML Formatting and its sub-menu items Tag Layout and Content Wrap, then
place a check next to Enable HTML Formatting and its sub-menu item Content Wrap.
The xml_formatting_toggle and html_formatting_toggle commands can also be used to toggle all
respective formatting features on/off. For use in macros, two more commands are available:
xml_formatting and html_formatting. When you use any of these commands, the command line
prompts for yes (Y) or no (N). When these commands are used to enable/disable XML/HTML Formatting,
both Tag Layout and Content Wrap are enabled/disabled for both XML and HTML files on a global basis.
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You can also turn automatic formatting on and off through the language-specific Formatting Options
screen: from the main menu, click Tools > Options, expand Languages and your language category, then
select your language and click [Language] Formatting Options. In the Auto formatting options group
box, select the default formatting scheme you want to use for this language, then enable/disable the
content wrapping or tag layout options. Click the Configure Schemes button to open the XML/HTML
Formatting Scheme Configuration dialog (see Working with Schemes).

Enabling/Disabling for the Current Document
Current document options are available so that you can turn off aspects of global formatting for just the
current document. For example, if you have both aspects of HTML formatting enabled globally, but you
need to edit an old HTML file and do not want automatic tag layout to occur, you can disable HTML Tag
Layout for that specific file. The current document settings are remembered each time you open that file.
To change XML or HTML formatting for just the current document, click Document > XML/HTML
Formatting > Current Document Options, or use the xml_html_document_options command. The
Current Document Options dialog is displayed.

Select the Formatting scheme that you want applied, then check or uncheck the Auto formatting
options that you want enabled or disabled. Click Configure Schemes if you want to modify or create a
new scheme to apply to the current document.
Global formatting must be enabled for the current file type in order for these options to be available. For
example, see the two screen shots shown previously. The menu screen shot shows that global HTML
formatting is enabled for Content Wrap only. This means that tag content for every HTML file that you
create or open in SlickEdit® will be wrapped, but no Tag Layout settings will be applied. The second
screen shot (the Current Document Options dialog) reflects that the global setting for Tag Layout is
disabled. Therefore it cannot be enabled for the current document. To enable it for the current document,
you would first need to enable the global setting by placing a check next to Document > XML/HTML
Formatting > Enable HTML Formatting > Tag Layout. Then you can use the Current Document Options
dialog to enable it for the current document.

Working with Schemes
A formatting scheme is comprised of any number of individually configurable XML or HTML tags and
controls the formatting of your text when XML/HTML Formatting is enabled. You can create different
schemes for use with either XML or HTML, and/or different schemes for use with different individual files.
For example, you may want one scheme for HTML and a different scheme for XML. Or, you may want one
scheme for creating new files and another for editing existing files.
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Schemes are stored as XML files in the format SchemeName.xml, and are located in the formatschemes/
xwschemes subdirectory of your user configuration directory. Scheme files can be shared or checked into
version control to ensure consistency in the formatting of your team’s XML/HTML files.
Use the XML/HTML Formatting Scheme Configuration dialog to work with schemes. To access this dialog,
from the main menu, click Document > XML/HTML Formatting > Current Document Options, then click
the Configure Schemes button on the Current Document Options dialog. You can also display the dialog
by using the xml_html_options command. Available schemes are listed in the Schemes column. The
tags that make up each scheme are listed in the Tags column.

Default Schemes
XML/HTML Formatting comes with two default schemes. Each time that you open an HTML file for editing,
by default, the html (default html) scheme is used. Each time an XML file is opened, the xml (default
xml) scheme is used. You can configure the settings for each default scheme or specify your own default
schemes (see Specifying a Different Default Scheme).
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The html (default html) scheme is comprised of a (default) tag as well as a list of commonly used HTML
tags, that are preconfigured with standard settings. The xml (default xml) scheme is comprised of one
(default) tag preconfigured with standard settings.
For any tag that does not appear in the Tags list, the (default) tag settings are used.

Specifying the Scheme to Use
You can specify a scheme to use for just the current document, or a default scheme to use for all HTML
and/or XML files that are created or opened in SlickEdit®.
To specify the scheme for the current document, click Document > XML/HTML Formatting > Current
Document Options, and pick the scheme to use from the drop-down list. The scheme you choose is
remembered the next time that the document is opened.

Specifying a Different Default Scheme
SlickEdit® has two predefined default schemes (see Default Schemes). You can specify your own default
scheme for new XML or HTML files by selecting a scheme, then from the right-click context menu, choose
Set as Default XML Scheme or Set as Default HTML Scheme. The name in the Scheme list will be
appended with the text “(default xml)” or “(default html)”. For example, if you have an HTML scheme
named readmes and set it as the default, the name in the Schemes list will change to
readmes (default html).

Creating Schemes
To create your own scheme, right-click in the Scheme column of the XML/HTML Formatting dialog, and
select New Scheme.

Type a name for your scheme, then select an existing scheme on which it should be based. This will “copy”
all of the tags and settings from the selected existing scheme to your new scheme. Click Create when
finished.

Saving and Deleting Schemes
In the XML/HTML Formatting Scheme Configuration dialog, modified schemes are denoted by asterisks
around the name (for example, *html*). To save a modified scheme, right-click on it and select Save
Scheme Changes. Alternatively, when you close the XML/HTML Formatting dialog, you are prompted
whether to save modified schemes.
400

SlickEdit® User Guide

XML/HTML FORMATTING

To delete a selected scheme, right-click and choose Delete Scheme.

Working with Tags
As described previously, formatting schemes are comprised of individual tags with associated formatting
settings. For example, in HTML, you may want start and end <div> tags to be on separate lines above/
below the text, while start/end style tags (such as <b> and <i>) are formatted inline with the text.
In order to configure formatting for individual tags, you must first define a scheme (see Creating Schemes),
or you can use one of the default schemes (see Default Schemes). The Tags column of the XML/HTML
Formatting dialog shows a list of tags associated with the selected scheme.

Default Tags
For all schemes, a (default) tag is included. It defines the settings that are applied to tags that are not
specifically listed in the Tags list. It can also be used as a basis for other tags when you use the Match tag
style of option on the General tab.
The default settings for the (default) tag are based on a block-style tag, in that the start and end tags are
on separate lines, content and nested tags are indented according to your extension indent style, and
content is wrapped to a fixed right margin at column 80. Use the Preview area at the bottom of the dialog to
see how tags based on the (default) tag will be formatted in your code.

Base Tags
Base tags are used to define groups of tags with similar behaviors. By creating a base tag and associating
a set of actual tags with that tag, you can configure that set of tags by changing the settings for the base
tag. The sample HTML schemes included with SlickEdit® include two base tags: (block) and (semiblock). When creating your own base tags, be sure to use unique tag names that are not used in
formatting to make it easy to spot them.
The (block) tag is useful as a base tag for tags like <div>, where you want the start and end tags on
separate lines from the content and aligned vertically. By default, this style indents nested tags and content
according to your extension indent style, and content is wrapped to a fixed right margin at column 80.
Because this is a common style in HTML, the (block) tag has the same settings as the (default) tag.
The (semi-block) tag is useful as a base tag for tags such as <h1>, where you want the start and end tags
on the same line as the content. The default settings for (semi-block) are the same as for (block), except
for the start and end tags.
Use the Preview area at the bottom of the dialog to see how tags based on these base tags will be
formatted in your code. The following are examples:
<div>
Sample text of a tag set to (block) style.
</div>
<h1>Sample text of a tag set to (semi-block) style. Notice how wrapping
occurs within this tag.</h1>
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Adding and Deleting Tags
To add individual tags to a selected scheme, right-click in the Tags column and select New Tag. Type the
name of the tag without angle brackets or attributes. Click OK and the new tag is now listed in the Tags
column.
NOTE Tag names cannot have spaces. If you create a new tag with spaces, SlickEdit converts the
spaces to underscores in the dialog.
To add all of the tags from the current file to a selected scheme, right-click in the Tags column and select
Add Tags from Current File.
To remove a tag from a selected scheme, right-click on the tag and select Delete Tag. Deleting SlickEdit®
(default) tags, or any tag that is based on another, is not recommended. If you attempt to do this, you will
be prompted whether to continue.

Formatting Settings
The tabs on the XML/HTML Formatting dialog contain settings that control how your text is formatted when
XML/HTML Formatting is enabled. For descriptions of these options, see XML/HTML Formatting Scheme
Configuration Dialog.
CAUTION XML/HTML Formatting does not currently affect XML or HTML Beautifier settings. If
you run the beautifier on documents that have been automatically formatted through XML/
HTML Formatting, you may find unexpected results.
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Ada
This section describes some of the features and options that are available for Ada, including languagespecific options and the Ada Beautifier.

Ada Formatting Options
An option to set keyword casing is available for Ada. To access it, from the main menu, click Tools >
Options > Languages, expand Application Languages > Ada, then click Ada Formatting Options.
NOTE Languages similar to Ada may have similar Formatting Options screens that are not
specifically documented.
The Keyword case option specifies the case of keywords used by Syntax Expansion. For example, when
you type the word “procedure” and the Keyword case is set to Upper case, the editor changes
“procedure” to “PROCEDURE”. The hyperlink indicates if Adaptive Formatting is on or off for this setting.

Ada Beautifier
You can beautify Ada files and change the beautify settings by using the Ada Beautifier dialog box. This
dialog box can be accessed from the main menu by clicking Tools > Beautify, or by using the
gui_beautify command.
To instantly beautify Ada code according to the settings that are selected on the Ada Beautifier dialog box,
use the ada_beautify or ada_beautify_selection commands.
The following settings and operations are available on the Ada Beautifier:
•

Restrict to selection - When checked, only lines in the selection are beautified.

•

Sync extension options - When checked, the language options are updated to reflect any
changes that these dialogs have in common.

•

Beautify - Beautifies current selection or buffer and closes the dialog box.

•

Reset - Restores the dialog box settings to the values that appeared when you invoked the dialog.

•

Save Settings - Saves beautify options in the uformat.ini file. These settings are used by the
ada_beautify command.

The tabs on the Ada Beautifier are described in the sections below.

Indent Tab
The following settings are available:
•

Indent with tabs - When checked, tab characters are used for leading indent of lines. This value
defaults to the Tabs text box on the language-specific Indent options screen (see LanguageSpecific Indent Options).

•

Indent for each level (Syntax indent) - The amount to indent for each new nesting level. The
words “Syntax indent” are in parenthesis to help indicate that this field has the same meaning as
the Syntax indent text box on the language-specific Indent options screen (see LanguageSpecific Indent Options). By default, this text box is initialized with the current language setup
setting.
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•

Tab size - Specifies output tab size. The output tab size is only used if the Indent with tabs check
box is enabled on the language-specific Indent options screen (see Language-Specific Indent
Options). This value defaults to the Syntax indent text box on the options screen.

•

Original tab size - Specifies what the original file's tab expansion size was. It is necessary to know
the tab expansion size of your original file to handle reusing indent amounts from your original file.
Currently the beautifier only reuses the original source file’s indenting for comments. This option
has no effect if the original file has no tab characters.

•

Continued Lines

•

o

Max line length - Specifies the maximum length a statement line can be before it is wrapped
to a new line. Set this value to 0 to preserve line breaks.

o

Continuation indent - Specifies how much to indent lines of statements which continue to the
next line. This has no affect on assignment statements or parenthesized expressions. Lines
which are a continuation of an assignment statement are indented after the first equal sign (=).
Lines which are a continuation of a parenthesized expression are indented after the open
paren.

Operator position - Specify where the operator should be positioned when breaking a statement
across multiple lines. For example, given the statement:
Seconds := Days * Hours_Per_Day * Minutes_Per_Hour * Seconds_Per_Minute ;

An operator position setting of End of same line would result in:
Seconds := Days *
Hours_Per_Day *
Minutes_Per_Hour *
Seconds_Per_Minute ;

An operator position setting of Beginning of next line would result in:
Seconds := Days
* Hours_Per_Day
* Minutes_Per_Hour
* Seconds_Per_Minute ;

Statements/Declarations Tab
The following options are available on the Statements/Declarations tab:
•

Reserved word case - Specifies the case for reserved words. For example, if you choose
UPPER, then the Ada reserved word “procedure” would be beautified to “PROCEDURE”.

•

One statement per line - When checked, only one statement is allowed per line of code.

•

One declaration per line - When checked, only one declaration is allowed per line of code.

•

One parameter per line - When checked, only one parameter is allowed per line of code in a
formal parameter list of a subprogram specification.

•

One enumeration per line - When checked, only one enumeration is allowed per line of code in
an enumerated type definition.

Horizontal Spacing Tab
This tab allows you to specify how certain operators and separators are padded. The following options are
available:

404

SlickEdit® User Guide

ADA

•

Item - Syntactic item to which padding settings get applied.

NOTE The “Binary operators” item includes: + - * / ** := = /= => <= >= < >
•

Padding Before - When checked, one space is placed before the item.

•

Padding After - When checked, one space is placed after the item.

•

Padding Preserve - When checked, the original padding (or lack of padding) around the item is
preserved.

Vertical Alignment Tab
The following options are available on the Vertical Alignment tab:
•

Align on declaration colon - When checked, adjacent declaration lines (including parameter
specifications) have their colons vertically aligned. For example, before beautify:
procedure foo ( A_Var : Boolean ;
Another_Var : Boolean) ;

After beautify:
procedure foo ( A_Var
: Boolean ;
Another_Var : Boolean ) ;

•

Align on declaration in-out - When checked, the modes of parameter specifications in the formal
part of a subprogram declaration are vertically aligned. For example, before beautify:
procedure foo ( A_Var : in Boolean ;
Another_Var : in out Boolean);

After beautify:
procedure foo ( A_Var
: in
Boolean ;
Another_Var : in out Boolean ) ;

Blank Lines Tab
The following options are available on the Blank Lines tab:
•

Item - Syntactic item to which blank lines settings get applied.
o

Subprogram declaration - Procedure or Function declaration.

o

Subprogram body - Procedure or Function body.

o

Type declaration - Any declaration that begins with the reserved word “TYPE”.

o

for…use - Aspect clause. For example:
for Medium'Size use 2*Byte;

o

Subunit comment header - The comment block that appears just before a subunit (e.g.
Procedure body, etc.).

o

begin/end - Any line that starts with the reserved words “begin” or “end.”

o

if/elsif/else - The if, elsif, and else parts of an if statement.

o

return - Any line that starts with the reserved word “return.”

o

Loops - Loop statements (e.g. loop, while, for).
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o

Nested paren list item - A parenthesized item that is itself enclosed in a larger parenthesized
list. For example, before beautify:
Default_Data : constant Data_Type
( A_Set => ( others => ( Item1
Item2
Item3
larger paren’d list
B_Set => ( others => ( Item1
Item2
Item3

:=
=> false ,
=> false ,
=> false ) ) , -- Paren’d item enclosed in
=> false ,
=> false ,
=> false ) ) ) ;

After beautify:
Default_Data : constant Data_Type
( A_Set => ( others => ( Item1
Item2
Item3
larger paren’d list

:=
=> false ,
=> false ,
=> false ) ) , -- Paren’d item enclosed in

B_Set => ( others => ( Item1 => false ,
Item2 => false ,
Item3 => false ) ) ) ;

•

Before - Specify how many blank lines are inserted before item.

•

After - Specify how many blank lines are inserted after item.

•

Between - Specify how many blank lines are inserted between like items.

Comments Tab
The following options are available on the Comments tab:
•

Comment lines immediately below a type declaration indented by - The amount to indent a
comment appearing immediately below a TYPE declaration.

•

Trailing comments - Trailing comments appear at the end of lines which contain statements or
declarations. For example:
A := B + C ; -- This is a trailing comment
-- This is not a trailing comment
procedure foo ( A_Var : Boolean ) ;

o

Specific column - When selected, trailing comments are placed at the specified column.

o

Indent by - When selected, trailing comments are indented by the specified number of
columns after the last character of the end of the statement or declaration.

o

Original relative indent - When selected, trailing comments are indented by reusing the
indent after the last character of the end of the statement or declaration of the original source
file.

o

Force type declaration comments to next line - When selected, trailing comments
appearing at the end of a TYPE declaration line are forced onto the next line.

Advanced Tab
The following options are available on the Advanced tab:
•
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if-then-else continued lines - Use these advanced options to customize how multi-line
conditional expressions of an if-then-else statement are indented.
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o

Force a linebreak on logical operators - A line break is forced before/after (depending on
your Operator position setting) every logical operator in the condition of an if/elseif. For
example, before beautify:
-- Indent per level = 3
-- Operator position = Beginning of next line
if A = B and C = D then
null ;
end if ;

After beautify:
if A = B
and C = D then
null ;
end if ;

o

Additional indent for logical operator - Additional indent amount for a line broken on a
logical operator. This amount is in addition to the current indent level. For example, before
beautify (Indent per level = 3; Operator position = Beginning of next line; Additional indent for
logical operator = 3):
-- Indent per level = 3
-- Operator position = Beginning of next line
-- Additional indent for logical operator = 3
if A = B and C = D then
null ;
end if ;

After beautify:
if A = B
and C = D then
null ;
end if ;

o

Additional indent for logical operator when followed by another line that begins with
logical operator - Additional indent amount for a line broken on a logical operator that is
followed by another line that also is broken on a logical operator that is different. This amount
is in addition to the current indent level, and in addition to the Additional indent for logical
operator setting.
For example, before beautify (Indent per level = 3; Additional indent for logical operator = 3;
Additional indent for logical operator when followed by another line that begins with different
logical operator = 3):
------

Indent per level = 3
Operator position = Beginning of next line
Additional indent for logical operator = 3
Additional indent for logical operator when
followed by another line that begins with different logical operator = 3

if A = B and then C = D or else E = F then
null ;
end if ;

After beautify:
if A = B
and then C = D
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or else E = F then
null ;
end if ;

Schemes Tab
To define a new scheme, set the various beautify options then click the Save Scheme button. Userdefined schemes are stored in uformat.ini.
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COBOL
This section describes some of the advanced options that are available for COBOL.

COBOL Formatting Options
Options are available for COBOL for changing Syntax Indent and Syntax Expansion styles. To access
these options, from the main menu, click Tools > Options > Languages, expand Mainframe Languages
> Cobol, then click Cobol Formatting Options.
NOTE Languages similar to COBOL may have similar Formatting Options screens that are not
specifically documented.

The following options are available:
•

Keyword case - Specifies the case of keywords used by Syntax Expansion. If Auto case
keywords is selected, the case of keywords are changed to the keyword case specified when you
type them. For example, when you type the word “procedure” and the Keyword case is set to
Upper case, the editor changes “procedure” to “PROCEDURE”. The hyperlink indicates if
Adaptive Formatting is on or off for this setting.

•

Syntax - Select the type of syntax to use. COBOL 74 and COBOL 2000 syntax are mutually
exclusive options.

•

Embedded SQL Dialect - Specifies the specific type of SQL that is embedded in your COBOL
source. This affects embedded SQL-language color coding.

•

Line Numbering - Choose the line numbering style from the following options:
o

COBOL style line numbering - When selected, expect line numbers in columns one through
six when renumbering lines.
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o
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SPF style line numbering - When selected, expect line numbers in columns 73 through 80
when renumbering lines.
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Pascal
This section describes some of the advanced options that are available for Pascal.

Pascal Formatting Options
Options are available for Pascal for changing Syntax Indent and Syntax Expansion styles. To access these
options, from the main menu, click Tools > Options > Languages, expand Application Languages >
Pascal, then click Pascal Formatting Options.
NOTE Languages similar to Pascal may have similar Formatting Options screens that are not
specifically documented.

The following options are available:
•

Begin-end style - Specify the begin/end style used by Syntax Indent and Syntax Expansion. The
hyperlink indicates if Adaptive Formatting is on or off for this setting. For each style, select from the
following options:
o

Insert begin/end pairs - Specifies whether template should be inserted with begin and end.

o

Begin/End comments - Specifies whether a comment is appended after the end keyword to
indicate the type of loop or case it terminates. In addition the begin and end for procedures
and functions are commented. No comment is appended to the begin/end pair of an if
statement.
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•

Keyword case - Specifies the case of keywords used by Syntax Expansion. The hyperlink
indicates if Adaptive Formatting is on or off for this setting.

•

Indent constant from case - Specifies whether constants of a case statement are indented or
aligned to the case keyword. The hyperlink indicates if Adaptive Formatting is on or off for this
setting.

•

Use Delphi expansions - Specify whether Delphi®-style expansions should be used.
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PL/I
This section describes some of the advanced options that are available for the PL/I language.

PL/I Formatting Options
Options are available for PL/I for changing Syntax Indent and Syntax Expansion styles. To access these
options, from the main menu, click Tools > Options > Languages, expand Mainframe Languages >
PL/I, then click PL/I Formatting Options..
NOTE Languages similar to PL/I may have similar Formatting Options screens that are not
specifically documented.

The following options are available:
•

DO/END style - Select the syntax expansion style that indicates whether syntax expansion should
place the DO on a separate line. Then select from the following options:
o

Insert DO/END immediately - Indicates whether syntax expansion should automatically add
a DO/END block.

o

Insert blank line between DO/END - Indicates whether syntax expansion should insert a
blank line when a DO/END block is inserted.
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•

Keyword case - Specifies the case of keywords used by Syntax Expansion. For example, when
you type the word “procedure” and the Keyword case is set to Upper case, the editor changes
“procedure” to “PROCEDURE”.

•

Indent WHEN from SELECT - Indicates whether the WHEN clause inside a SELECT statement
should be indented.

•

SPF style line numbering (columns 73-80) - When selected, expect line numbers in columns 73
through 80 when renumbering lines.
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Python
This section describes some of the advanced features that are available for the Python language.

Begin/End Structure Matching for Python
Begin/End Structure Matching moves the cursor from the beginning of a code structure to the end, or vice
versa.
To place the cursor on the opposite end of the structure when the cursor is on a begin or end keyword pair,
press Ctrl+] (find_matching_paren command or from the menu click Search > Go to Matching
Parenthesis). The find_matching_paren command supports matching parenthesis pairs {},[] and ().
For Python, SlickEdit® supports the matching of the colon (:) token and the end of context.
Note the cursor location in the code block below:
def function_foo(arg):| <- cursor
....
return 0| <- destination

Executing find_matching_paren will move the cursor to the end of line containing the return 0 statement.
Executing it while the cursor is at the end of the return 0 statement will bring the cursor back to the colon
(:) position of the function signature line (def function_foo(arg):).
This works on function, class, for, while, if, and try statements.
There is one limitation of this feature. Note the following code block:
for i in xrange(0, 10):| <- A
for j in xrange(0, 10):| <- B
for k in xrange(0, 10):| <- C
print i, j, k| <- D

Invoking find_matching_paren at position A, B, or C will move the cursor to D, but doing so while the
cursor is at D will only move the cursor back to C (not A nor B). This is because the Python language
doesn't have the notion of end-of-scope token (such as } in C/C++, Java, etc.), so it's impossible to
determine the correct destination when jumping from D. Therefore we pick the nearest possible destination
in this scenario.
See Begin/End Structure Matching for more information about this feature.
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Tools and Utilities
This chapter contains the following topics:
•
•
•
•
•
•
•
•
•

Find and Replace
Comparing and Merging
Version Control
Spell Checking
Sorting Text
FTP
Regular Expressions
Using the Calculator and Math Commands
OS File Browser
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Find and Replace
SlickEdit® provides several different ways to search and replace:
•

For the fastest method of searching and replacing, use Quick Search and Quick Replace (see
Quick Search and Replace below).

•

To find and replace text “on the fly,” or, as you type, use incremental searching (see Incremental
Searching below).

•

If you are more comfortable with keystrokes, you may prefer command line searching with the find
and replace commands (see Find and Replace Commands).

•

Use the Find and Replace tool window if you prefer working within an interface (see Find and
Replace Tool Window).

•

To search for symbols, use the Find Symbol tool window (see Find Symbol Tool Window).

Both the Find and Replace tool window and command line searching provide the same search and replace
options for single or multiple files, and for searching and replacing text, wildcards and regular expressions,
so you can choose which method works best for you.
This section also includes the topics Find and Replace with Regular Expressions, Undoing/Redoing
Replacements, and Match Highlighting.

Default Search Options
The behavior for all of the search mechanisms in SlickEdit® is controlled by the Search Options located in
the Options dialog (Tools > Options > Editing > Search). The options specified here are used each time
a search is performed, except for the Find and Replace Tool Window, which has controls to override these
settings.
The value of the settings in the Options dialog are used to initialize the corresponding controls in the Find
and Replace tool window. Once the value is changed in the tool window it is remembered and used the
next time the Find and Replace tool window is launched. So changing a value in the Search Options may
not have any effect on the Find and Replace tool window. Changing a setting in the Find and Replace tool
window will not change the settings in the Search Options. See Search Options for more information.

Quick Search and Replace
Quick Search
The fastest way to search is by using Quick Search. Quick Search looks through the current buffer for the
word or selection at the cursor. You can find the next occurrence of a search item by selecting a string in
an existing buffer or Search Results window, then selecting Quick Search from the right-click menu (or by
using the quick_search command). The commands find_next (Search > Next Occurrence or Ctrl+G)
and find_prev (Search > Previous Occurrence or Ctrl+Shift+G) will find the next and previous instances
of the item, respectively. Quick Search always uses the default search options (see Search Options.).

Quick Replace
Quick Replace gets the current word or selection at the cursor, prompts for replacement text on the
command line, then highlights each occurrence of the word and prompts if you want to replace the text.
Quick Replace always uses the default search options (see Search Options).
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To use Quick Replace, right-click on any word or selection and select Quick Replace (or use the
quick_replace command).
The quick_replace command has a command line alias, qr. The qr command takes the replace string as
an argument. For example, if the cursor is on the word “cat,” the command qr dog will prompt you to
replace all the instances of “cat” with “dog” in the current buffer.

Incremental Searching
During incremental searching, a string is searched for as it is typed. To start a forward incremental search
using the command line, use the i_search command (Ctrl+I). To start a reverse incremental search, use
the reverse_i_search command (Ctrl+Shift+I). Incremental Search always uses the default search
options (see Search Options).
The following key combinations (based on the default CUA emulation) take on a different definition during
an incremental search:
Keys

Function

Ctrl+R

Search in reverse for the next occurrence of the search string.

Ctrl+S

Search forward for the next occurrence of the search string.

Ctrl+T

Toggle regular expression pattern matching on/off.

Ctrl+W

Toggle word searching on and off. To change the word
characters for a specific language, use the Word chars field
on the language-specific General options screen (see General
Language-Specific Options).

Ctrl+Shift+W

Copy complete word at cursor to search string.

Ctrl+C

Toggle case sensitivity. The key bound to the Brief emulation
command case_toggle will also toggle the case sensitivity.

Ctrl+M

Toggle searching within selection.

Ctrl+O

Toggle incremental search mode.

Ctrl+Q

Quote the next character typed.

Ctrl+S or F5

(Brief emulation) Search forward for the next occurrence of the
search string.

Ctrl+R or Alt+F5

(Brief emulation) Search in reverse for the next occurrence of
the search string.

Ctrl+W

(GNU Emacs emulation) Copy complete word at cursor to
search string.

Ctrl+Shift+W

(GNU Emacs emulation) Toggle word searching on and off.

Incremental searching stops when you press a key that does not insert a character. You can press Esc to
terminate an incremental search (only during prompting). Press and hold Ctrl+Alt+Shift to terminate a
long search.
You can retrieve your previous search string by invoking the i_search or reverse_i_search command and
pressing Ctrl+S or Ctrl+R, respectively, before entering a search string.
420
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Find and Replace Commands
Find and Slash (/) Commands
The command line is available for performing searches. You can use the forward slash (/) or find
commands which provide the same functionality as the Find and Replace tool window. Press Esc to toggle
the cursor to the command line.
The syntax of the slash (/) command is:
/string[/OptionCharacters]
The syntax of the find command is:
find /string[/OptionCharacters]
OptionCharacters is one or more of the following option characters:
Option Character(s)

Description

E

Exact case.

I

Ignore case.

-

Reverse search.

M

Limit search to selection.

<

If found, place cursor at beginning of word.

>

If found, place cursor at end of word.

R

Interpret search string as a SlickEdit® regular expression.

U

Interpret search string as UNIX regular expression.

B

Interpret string as a Brief regular expression.

N

Do not interpret search string as a regular expression.

P

Wrap to beginning/end when string not found.

W

Limit search to words. Used to search for variables.

W=SlickEdit-regularexpression

Specifies the valid characters in a word. The default value is
[A-Za-z0-9_$]. To change the word characters for a specific
language, use the Word chars field on the language-specific
General options screen (see General Language-Specific
Options).

W:P

Limit search to word prefix. For example, a search for “pre”
matches “pre” and “prefix” but not “supreme” or “supre”.

W:PS

Limit search to strict word prefix. For example, a search for
“pre” matches “prefix” but not “pre,” “supreme” or “supre”.

W:S

Limit search to word suffix. For example, a search for “fix”
matches “fix” and “suffix” but not “fixit”.
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Option Character(s)

Description

W:SS

Limit search to strict word suffix. For example, a search for “fix”
matches “suffix” but not “fix” or “fixit”.

H

Allow finding search string in hidden lines.

Y

Binary search. This allows start positions in the middle of a
DBCS or UTF-8 character. This option is useful when editing
binary files (in SBCS/DBCS mode) which may contain
characters which look like DBCS but are not. For example, if
you search for the character “a”, it will not be found as the
second character of a DBCS sequence unless this option is
specified.

, (comma)

Delimiter to separate ambiguous options.

XCCLetters

Requires the first character of search string NOT be one of the
color coding elements specified. For example, XCS requires
that the first character not be in a comment or string.
CCLetters is a string of one or more of the following color
coding element letters:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
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O - Other
K - Keyword
N - Number
S - String
C - Comment
P - Preprocessing
L - Line number
1 - Symbol 1
2 - Symbol 2
3 - Symbol 3
4 - Symbol 4
F - Function color
V - No save line
A - Attribute

CCCLetters

Requires the first character of search string to be one of the
color coding elements specified. See CCLetters above.

#

Highlight matched patterns with highlight color. The buffer is
not automatically cleared when executing a new search, like it
is with the Find and Replace tool window.

*

Used with the “Search hidden text” (H) or “Highlight matches”
(#) options to find all matches and un-hide or highlight them.

&

Use Wildcard regular expression syntax (*, ?).

#

Highlight matched patterns with highlight color.
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Option Character(s)

Description

V

(Replace commands only) Preserve case. When specified,
each occurrence found is checked for all lowercase, all
uppercase, first word capitalized, or mixed case. The replace
string is converted to the same case as the occurrence found
except when the occurrence found is mixed case (possibly
multiple capitalized words). In this case, the replace string is
used without modification.

$

(Replace commands only) Replaced occurrences are
highlighted with modified color.

If you don’t specify options when using the find and (/) commands, the default search options are applied.
See Search Options for more information.
If the “*“option is not specified, you will be prompted with the message Yes/No/Last/Go/Quit/Suspend? for
each occurrence of the “Search for” string.

Replace and c Commands
The replace commands, replace and c, can be used in the command line. The syntax of these commands
is:
c/string1/string2[/options] or replace/string1/string2[/options]
The available options are the same as for the find and slash (/) commands (see Find and Slash (/)
Commands above).
You can perform one of the following actions with the replace command (c) by pressing the corresponding
key:
Key

Action

Y or Space

Make change and continue searching.

N or Backspace

No change and continue searching.

L or Dot

Make change and stop searching.

G or !

Make change and change the rest without prompting.

Q or Esc

Exit command. By default, the cursor is NOT restored to its
original position. If you want the cursor restored to its
original position, from the main menu click Tools > Options
> Editing > Search and set the Restore cursor after
replace option to True.

Ctrl+G

Exit command and restore cursor to its original position.

Ctrl+R

Search in reverse for next occurrence of search string.

Ctrl+S

Search forward for next occurrence of search string.

Ctrl+T

Toggle regular expression pattern matching on/off. The key
bound to the Brief emulation command re_toggle will also
toggle regular expression pattern matching.
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Key

Action

Ctrl+W

Toggle word searching on/off. To change the word
characters for a specific language, use the Word chars field
on the language-specific General options screen (see
General Language-Specific Options).

Ctrl+C

Toggle case-sensitivity. The key bound to the Brief
emulation command case_toggle will also toggle the casesensitivity.

Ctrl+M

Toggle searching within selection.

F1 or ?

Display Help on Find and Replace tool window.

Replace Command Search Examples
The table below provides examples of using command line replace.
Example
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Description

c $/$\$

Replace occurrences of forward slashes with back
slashes.

c/x/y/m

Replace occurrences of “x” in the selected area with
“y” using default search case sensitivity.

c $x$y$m

Replace occurrences of “x” in the selected area with
“y” using default search case sensitivity. The string
delimiter “$” has been used requiring a space
character after the “c.”

c/x/y/e*

Replace lowercase occurrences of “x” with “y” without
prompting.

c/i/something_more_meaningful/w

Replace occurrences of the variable “i” with
“something_more_meaningful.”

c/i/j/w=[A-Za-z]

Replace occurrences of the word “i” with “j” and
specify valid characters in a word to be alphabetic
characters.

replace/Test/TEMP/v

Replace occurrences of the word “test” with the word
“temp”, with the case preserved. For example:
•

Occurrences of “Test” are replaced with
“Temp”.

•

Occurrences of “test” are replaced with
“temp”.

•

Occurrences of “tesT” are replaced with
“TEMP” (because a mixed case will retain the
actual replacement that you typed).

•

Occurrences of “TEST” are replaced with
“TEMP”.
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Find and Replace Tool Window
You can use the Find and Replace tool window (Ctrl+F, Search > Find, or View > Toolbars > Find and
Replace) to specify search and replace options and conduct search and replace operations on selections,
single files, or multiple files.

Docking the Tool Window
Like other SlickEdit® tool windows, this tool window is dockable. Docking options can be accessed by
right-clicking on the tool window’s title bar. When the tool window is docked, invoking any find or replace
command will bring the window to the front focus. When it is not docked, invoking these commands will
cause the window to float display. Whether docked or floating, search and replace operations will not close
the tool window by default.

Saving Search and Replace Values
When the Find and Replace tool window is invoked, the options that were used for your last search are
displayed, providing a way to repeat the last search. Options also persist when switching between the
tabs. Pressing F7 and F8 retrieves previous and next responses, respectively.
Search and replace values can be saved as named operations. Saving preserves the values of all of the
fields in the Find and Replace tool window so that the search and/or replace operation can be repeated in
the future with the same results. To save the search/replace, right-click in the Find and Replace tool
window. Select Saved Search Expressions, then select Save Search Expression from the sub-menu.
You will be prompted to name the operation. To access a saved operation, select Saved List from the submenu, then pick the saved operation to load.
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Syntax-Driven Searching
To reduce the number of false positives in your searches, you can restrict the search based on program
syntax. Click the Color button on the Find tab of the Find and Replace tool window to specify the syntactic
elements for filtering. Each check box has three states:
•

Neutral (the default) - All check boxes start in the neutral state. These elements will be used in a
search until cleared or until one or more other elements are selected. Putting a check in any check
box essentially clears all non-checked boxes.

•

Selected - If the check box is selected, the search will be restricted to this element and any other
selected elements. There is no need to clear any other elements if any elements are selected. If
any elements are selected, only selected elements will be searched. For example, to search for
the word “result” only in comments, put a check only in the Comment check box. All other
syntactic elements will be ignored as part of this search.

•

Cleared - If the check box is clear, these elements will not be searched. For example, if you want
to find the word “result” anywhere in your code except for in comments, clear the Comment check
box.

Setting Options
Options for individual search and replace operations are located on the Find and Replace tool window.
Alternatively, you can set default options that are always used instead. To set the default options, rightclick on the background of the tool window and select Configure Options. The default search options will
always be used when the Find and Replace tool window is invoked, unless settings are changed on the
Find and Replace tool window. If you change settings on the tool window and want to use the default
options instead, right-click in the tool window and select Use Default Options. See Search Options for
more information. For information on the individual options on the Find and Replace tool window, see Find
and Replace Tool Window.

Search Results Output
You can specify that multi-file search results are displayed in a new editor window or in a new Search
Results tool window.
To send the results to a new editor window, select the Find in Files tab, click the Result options button to
expand the options, then select Output to editor window.
To send the results of a multi-file search to a specific Search Results tool window, select the Find in Files
tab, click the Results options button to expand the options, then use the Search Results Window dropdown list to select the window to be used. These are labeled starting at Search<0>. A new results tool
window can be added with the <New> option up to a pre-set limit of open Search Results windows.
If <Auto Increment> is selected from the Search Results Window drop-down list, the search results will
cycle through all of the open Search Results tabs in the Search Results tool window with each new search.
For example, if you have Search<0>, Search<1>, and Search<2> open, then for each search operation,
the results will be displayed in this order: Search<0>, Search<1>, Search<2>, Search<0>, Search<1>, and
so on. If you only have one Search Results tool window open, then all results will go into the only open
search windows. You can open and close search results windows by right-clicking on the Search Results
tab in the Search Results tool window.
Right-click in the Search Results window to access the following options:
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•

Quick Search - Finds the next occurrence of the text selected.

•

Filter Search Results - Select this option to display the Filter Search Results dialog. From here, if
a match is found, you can choose to keep or delete lines with additional searches, match case,
limit to current default regular expression syntax and/or remove matches found on the same line
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number in the same file (this can also be accomplished by selecting List matching lines only from
the Find in Files tab).
•

Open as Editor window - Opens current search results in a new editor window.

•

Go to Line - Goes to the file/line number of the current line in the Search Results window.

•

Bookmark Line - Places a bookmark at the line in the file where the result was found.

•

Clear Window - Clears all results in the current Search Results window.

•

Align Columns - Aligns the line numbers and column numbers for all search results.

•

Collapse All - Collapses all Selective Display levels. See Selective Display for more information.

•

Expand All - Expands all Selective Display levels. See Selective Display for more information.

See Find in Files Tab for more information.

Find Symbol Tool Window
The Find Symbol tool window (Search > Find Symbol or gui_push_tag command) is used to locate
symbols in your code. It allows you to search for symbols by name using either a regular expression,
substring, or fast prefix match.
Searching for a symbol is faster than a normal text search because it is executed against the Context
Tagging® database, rather than searching through your source files. Find Symbol also avoids false hits in
comments or string literals. Though Syntax-Driven Searching in the regular Find and Replace Tool Window
provides this same capability, it cannot match the speed of Find Symbol.
See Find Symbol Tool Window for information about the options that are available.

Find and Replace with Regular Expressions
SlickEdit® supports five types of regular expression syntax that you can use for finding and replacing when
regular search and replace operations are too limiting:
•
•
•
•
•

Brief
Perl
SlickEdit
UNIX
Wildcards

See Regular Expressions for more information.

Undoing/Redoing Replacements
To undo a replacement, click Edit > Undo, press Ctrl+Z, or use the undo command. To redo a
replacement, click Edit > Redo, press Ctrl+Y, or use the redo command.
To undo replacements in multiple files, click Edit > Multi-File Undo or use the mfundo command. To redo
replacements in multiple files, click Edit > Multi-File Redo or use the mfredo command.
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Match Highlighting
Cursor on Symbol Shows All Uses in File
SlickEdit® can highlight all occurrences of the current symbol under the cursor. This makes it easy to see,
at a glance, all uses of a symbol in a file. This option can be set on a language-specific basis. To enable it,
from the main menu, click Tools > Options > Languages, expand your language category and language,
then select Context Tagging®. On the options screen, select Highlight matching symbols under
cursor.
The highlight color is controlled by the Symbol Highlight screen element (Tools > Options >
Appearance > Color). To change the color, see Setting Colors for Screen Elements. See LanguageSpecific Context Tagging® Options for information about other options on the options screen.
This feature includes two advanced options that affect all languages that have Highlight matching
symbols enabled. These can be set through configuration variables (Macro > Set Macro Variable):
•

def_highlight_symbols_max_bufsize - This variable sets the maximum buffer size, in bytes, for
symbol highlighting. If the buffer size is greater than the max size, highlighting is restricted to the
visible lines.

•

def_highlight_symbols_max_matches - This variable sets the maximum number of matching
occurrences for symbol highlighting.

See Setting/Changing Configuration Variables for more information.

428

SlickEdit® User Guide

COMPARING AND MERGING

Comparing and Merging
SlickEdit® provides two powerful ways to compare and merge files: DIFFzilla® and 3-Way Merge.

DIFFzilla®
DIFFzilla provides powerful differencing capabilities that let you compare files or directories and view the
differences side-by-side. You can make edits, merge changes, and save modified files easily within the
results windows. As edits are made, the diff view is updated as you type, so you don't have to re-run the
comparison. And, switching from a directory comparison to an individual file difference is as simple as a
mouse click.
With DIFFzilla, you can:
•

View differences between two files. See Comparing Two Files.

•

View differences between symbols and parts of files. See Comparing Symbols or Parts of Files.

•

View differences between all of the symbols in two files. See Comparing All Symbols of Two Files.

•

View differences between source trees. See Comparing Two Directories.

•

See intra-line differences, color-coded as you type. See Dynamic Difference Editing.

•

Generate file lists. See Generating File Lists.

•

Specify automatic directory mapping. See Automatic Directory Mapping.

•

Save/restore multi-file results.

•

Utilize dialog box history (wild cards, paths, file specifications).

Using the DIFFzilla® Dialog
The following sections describe how to use DIFFzilla and the differencing features in SlickEdit®. For more
details on the specific options available on the DIFFzilla dialog (Tools > File Difference or diff command),
see DIFFzilla® Dialog.

Dynamic Difference Editing
DIFFzilla® allows you to diff, or compare, files, and provides the ability to view the differences side-by-side
or interleaved (one on top of the other). The output is color-coded. The side-by-side output differences can
be merged from one file to the other, and you can edit the files directly inside the DIFFzilla dialog—this is
called Dynamic Difference Editing.
Undo, copy/paste, Syntax Expansion/indenting, SmartPaste®, Auto List Members, Auto Parameter Info
and many emulation key mappings work when editing in the DIFFzilla dialog box. When you type or make
any edit, lines are re-diffed (compared again) so that you can view the new intra-line differences easily.

Comparing Two Files
To diff two source files, complete the following steps:
1. From the main menu click Tools > File Difference, or use the diff command. The DIFFzilla®
dialog appears, as pictured below.
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2. Under Diff Type, select the Text Compare option.
3. Enter the name of the first file to compare in the Path 1 text box. Enter the name of the second file
in the Path 2 text box. If the file names only differ by path, you only need to specify the path for
Path 2.
4. Click OK.

Comparing Symbols or Parts of Files
DIFFzilla® provides the ability to diff (compare) a selected range of lines from two files or the same file.
This is very useful for comparing a piece of code that has been moved into a different part of a different file.
NOTE You can only use the interactive dialog output style when diffing a selected range of lines.
Therefore, the option Instead of an interactive dialog, output one buffer with the differences
labeled, on the DIFFzilla dialog Options tab, will have no effect.
To compare symbols, select the Symbols option under Diff Type on the DIFFzilla dialog, and all symbols
from Path 1 will be diffed against all symbols from Path 2. If Multi-File is selected as the Diff Type, it
always allows you to diff all symbols. Be sure to be careful when diffing all symbols. Some symbol blocks
are not yet picked up correctly. For example, for C++, C#, and Java, variable initializations are not yet
handled correctly, as shown in the code below:
struct MYSTRUCT {
int x;
int y;
};
MYSTRUCT VariableDefinition= { // symbol definition stops here
0,1
};
// really should end here

430

SlickEdit® User Guide

COMPARING AND MERGING

To diff a selected range of lines from two source files, complete the following steps:
1. From the main menu, click Tools > File Difference.
2. Select the Multi-File diff type.
3. Type the name of the first file in the Path 1 text box.
4. Click More, and type the start and end line numbers next to Line range label.
5. Type the name of the second file in the Path 2 text box and type the start and end line numbers
next to Line range label. If the file names only differ by path, you need to specify the path for Path
2 only.
6. When differencing a symbol definition, click Symbols to enter the line number range.

Comparing All Symbols of Two Files
DIFFzilla® allows you to diff all the symbols of two different files. This feature is most useful for diffing files
with symbols that have been moved around. To diff all the symbols of two source files, complete the
following steps.
1. From the main menu, click Tools > File Difference (or use the diff command).
2. Enter the first file in the Path 1 text box.
3. Enter the second file in the Path 2 text box. If the file names only differ by path, you need to
specify the path for Path 2 only.
4. In the Diff type, select Symbols and click OK. You do not need to turn on the Diff all symbols
check box when performing a multi-file diff because mismatching files will have a plus sign (+) in
front of them so that you can diff all of the symbols.

Comparing Two Directories
You can difference two source trees to determine what files have been added or removed and generate a
list of file names. When the source tree difference is complete, click Save to generate a list file. To diff two
source trees, complete the following steps.
1. From the main menu, click Tools > File Difference, or use the diff command.
2. Mark the Recurse into subdirectories check box to compare subdirectories.
3. Enter the two directories in the Path 1 and Path 2 text boxes.
4. Fill in the Filespecs text box with the files that you want processed.
5. Click OK. The Multi-File Diff Output dialog is displayed.
If a file exists in one tree but not the other, a plus sign (+) is displayed in the one tree and a minus sign (-)
in the other. You can customize the files to view with the context menu. To display the context menu, rightclick in the left or right tree. If you move the mouse over the Plus or Minus bitmap next to the item in the
tool tree, a tool tip is displayed indicating what the bitmap means.
For descriptions of the buttons on the Multi-File Diff Output dialog, see Multi-File Diff Output Dialog.

Generating File Lists
DIFFzilla® can be used to find only the files that have been changed, and can generate file lists. The Save
button in the Multi-File Diff Output dialog can create a list of files that includes different files, matching files,
and files that do not exist in the other tree. Use the DIFFzilla dialog box to compare the new source tree
with the original source tree.
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1. From the main menu, click Tools > File Difference, or use the diff command.
2. On the Files tab, select Multi-File.
3. Enter the first file in the Path 1 text box.
4. Enter the second file in the Path 2 text box. If the file names only differ by path, you only need to
specify the path for Path 2.
5. Click OK. The Multi-File Diff Output Dialog box opens.

6. Click Save. The Save Multi-File Output dialog box opens.
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7. Select Save Path 1 Filelist, Include different files, and Include files not in Path2. All other
check boxes should be clear.
8. Click OK and select an output file for the list. The file you save will have the .lst extension
appended to the output file name.
9. Zip the files if you want.

Automatic Directory Mapping
The DIFFzilla® dialog box automatically updates the Path 2 text box with a directory, based on file paths
that you previously typed in this field. For example, if you previously typed f:\slick12\bitmaps\ into the
Path 1 text box and \\server\user\slick12\bitmaps\ into the Path 2 text box, then f:\slick12\ is mapped
to \\server\user\slick12\. The next time that you type f:\slick12\macros\ in the Path 1 text box,
\\server\user\slick12\macros\ is automatically entered into the Path 2 text box.
To turn this option off, complete the following steps.
1. From the main menu, click Tools > File Difference, or use the diff command.
2. Select the Options tab.
3. Click Dialog Setup.
4. Clear the Automatic directory mapping check box.

Diffing File History
The Backup History feature is available for viewing and comparing the differences between the current and
previous versions of an open file. It utilizes the DIFFzilla® dialog for diffs (see Using the DIFFzilla®
Dialog). For more information about this working with Backup History, see File History and Backups.

3-Way Merge
The 3-Way Merge editing feature can be used after two people make a local copy of the same source file,
and each makes modifications to their local copy. The 3-Way Merge takes both sets of changes and
creates a new source file. If there are any differences, a dialog box is displayed that lets you select the
changes that you want in the output file. The output file can be viewed side-by-side or interleaved.
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Performing a Three-Way Merge
To perform a three-way merge, complete the following steps:
1. From the main menu, click Tools > File Merge (or use the merge command). The 3-Way Merge
Setup dialog is displayed.

2. In the Filename text box, enter the baseline (original) file name. Click the Ellipses button to the
right of the text box to select files. Click the B button to select from the open buffers.
3. Enter the other names of the files to be merged in the Revision 1 and 2 text boxes.
4. In the Output file Filename text box, enter the name of the output file, or click the Ellipses button
to select from an existing file.
5. Select any Merge style or Output style that you want.
6. Click OK. The following dialog box is displayed with the results of the 3-Way Merge:

434

SlickEdit® User Guide

COMPARING AND MERGING

3-Way Merge Settings
For descriptions of the options on the 3-Way Merge Setup dialog, see 3-Way Merge Dialog.

The compare Command
The compare command compares two buffers in two tiled windows starting from the current cursor
position of each window. If the current window is not one of two tiled windows, you will be prompted for the
files/buffers you want to compare and two tiled windows will be set up for you.
TIP The functionality of the compare command has been replaced with DIFFzilla®. See DIFFzilla®
for more information.
You can perform the following steps to manually set up two tiled windows before invoking the compare
command:
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1. Open (Ctrl+O) both files you wish to compare
2. Make current one of the files you wish to compare.
3. Zoom the current window by clicking on the Maximize button.
4. Use the hsplit_window command (Ctrl+H or Window > Hsplit) to create two tiled windows.
5. Use the link_window command (Window > Link Window) to display the other buffer in the newly
created window.
After a compare mismatch, you can use the resync command to adjust the cursor in both windows to the
next reasonable match. This command will be improved in the future to handle more sophisticated
mismatches.
In ISPF emulation, this command is not called when invoked from the command line. Instead,
ispf_compare is called. Note that you cannot access the compare command when in ISPF emulation
unless you bind it to a key.

Setting Compare Options
The compare_options command displays the Compare Options dialog box to set various compare
options. The following settings are available:
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•

Binary compare - When selected, a stream compare (byte-by-byte) compare is performed.
Typically a line-by-line compare is performed.

•

Expand tabs before compare - When selected, tabs are expanded to the appropriate number of
spaces, before lines from each file are compared.

•

Ignore leading spaces - When selected, differences in leading spaces of lines are ignored.

•

Ignore trailing spaces - When selected, differences in trailing spaces at the end of lines are
ignored.

•

Ignore all spaces - When selected, differences in spacing between characters in lines are
ignored.

•

Ignore case - When selected, differences in character casing is ignored.
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Overview of Version Control
Version control is accessed from the Tools > Version Control menu, by right-clicking within a file or buffer,
or by right-clicking on an item in the Files list of the Open tool window.
The History, Difference, Lock, and Properties commands operate on the current buffer. For SCC version
control systems, the SCC provider’s function is called. For command line version control systems, the
specified command is run, and the output is displayed.
The Check In, Get, Check Out, Unlock, Add, and Remove commands show a dialog box and operate on
all files selected. This dialog will allow you to easily choose from files currently open, the files in the current
project, or files in the current workspace. Note that CVS operations are different and designed to work
especially well with CVS. Also, for SCC version control systems, you can select from files that are valid for
that command. For example, when using the Check In command, you can click Available to view all files
that can currently be checked in.
Use the Manager command to bring up the version control system’s user interface. For many command
line systems there will not be a program to call for this.
Menu items that appear grayed out for a command line version control system are blank. For SCC version
control systems, Lock is always unavailable because the SCC interface does not make allowances for a
lock command. It is possible to receive an Operation not supported message when running some
commands if an SCC version control system does not implement an interface to that operation.
The following version control systems are supported:
•
•
•
•
•
•
•
•
•
•
•
•
•

CCC/Harvest
ClearCase
ComponentSoftware RCS
CVS
MKS Source Integrity
Perforce
PVCS
RCS
SCC
StarTeam
Subversion
TLIB
Visual SourceSafe

Using Version Control
Version control operations can be accessed from the main menu by clicking Tools > Version Control, and
then choosing an operation. When you choose an operation, a dialog box for that operation is invoked. The
left side of each dialog box contains a list of files determined by the options you have selected. You can
click on individual files to select them, or you can select multiple files by using Ctrl+Click or Shift+Click.
The following options are available for each operation:
•

Workspace - When checked, all files that are in the current workspace are listed.

•

Project - When checked, all files that are in the current project are listed.

•

Buffers - When checked, all files that are currently open in the editor are listed.
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•

Available - When checked, all files that are available for the specified operation are listed. This
option is only available for SCC version control systems.

•

Advanced button - Click this button to configure the specified operation’s options. This button is
only available for SCC version control systems that support these options.

•

Check In - To check files in to the version control system, from the main menu click Tools >
Version Control > Check In, or use the vccheckin command. Select the files in the list that you
wish to check in, then click the Checkin button.
The Check In dialog provides an additional option to Save if modified. When this option is
selected, any files that are modified are saved before check-in.

•

Get Files - To retrieve files from the version control system, from the main menu click Tools >
Version Control > Get, or use the vcget command. Select the files in the list that you wish to get,
then click the Get button.

•

Check Out - To check files out of the version control system, from the main menu click Tools >
Version Control > Check Out, or use the vccheckout command. Select the files in the list that
you wish to check out, then click the Checkout button.

•

Lock - To lock files in the version control system, from the main menu click Tools > Version
Control > Lock, or use the vclock command. Select the files in the list that you wish to lock, then
click the Lock button.

•

Unlock - To unlock files in the version control system, from the main menu click Tools > Version
Control > Unlock, or use the vcunlock command. Select the files in the list that you wish to
unlock, then click the Unlock button.

•

Add files - To add files to the version control system, from the main menu click Tools > Version
Control > Add, or use the vcadd command. Select the files in the list that you wish to add, then
click the Add button.
The Add Files dialog provides two additional buttons:

•

o

The Browse button will invoke a dialog box that allows you to add other files to the list, so that
you can select them to be added to the version control system.

o

The Remove button will remove files from the list.

Remove files - To remove files from the version control system, from the main menu click Tools >
Version Control > Remove, or use the vcremove command. Select the files in the list that you
wish to remove, then click the Remove button.

Configuring Version Control
Before using Version Control, you should configure your setup. To access these options, from the main
menu, click Tools > Version Control > Setup, or use the vcsetup command. The Options dialog is
displayed open to the Version Control Setup screen. You can also access this screen by clicking Tools >
Options > Tools > Version Control Setup.
Uses these options to modify the command strings for a specific version control system. Command strings
are stored in the file vcsystem.slk (UNIX: uvcsys.slk), and uservc.slk and are the same for all projects
which use the selected version control system.
For more information, see Version Control Setup Options.
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Advanced Setup Options
Advanced setup options are available for each version control system that supports them. From the
Version Control Setup options screen (Tools > Options > Tools > Version Control Setup), select the
version control system you want to set up, then click on the Setup button. This will display the setup dialog
box for the system you have selected. Click the Advanced button on this dialog to access the advanced
options. The options are similar for each version control system. See Version Control Setup Options for a
list and descriptions of the options.

Setting Up Command Line Version Control Systems
If you are on a non-Windows platform, or are using a version control system that does not support SCC,
the version control system must have a command line interface. To configure a command line version
control system for a system that is using a command line driven operating system, complete the following
steps:
1. From the main menu, click Tools > Options, expand Tools, then select Version Control Setup
(or use the vcsetup command).
2. Select the Command line systems check box.
3. Select a Version Control System. Be sure that the executable file for each version control
command is in your file path, and that the executable files that are included with the version control
system can be found in the PATH environment variable. Depending on the system you are using,
you might need to complete information in the VCS Project text box.
4. Click Setup and verify that each command matches the options that you want. (If you are not sure
what any of the %<character> macros expand to, click on the arrow to the right of the text box to
view a list.)
5. Click OK.

Specific Version Control Support
Source Code Control (SCC)
SCC is a Source Code Control interface specification that was designed by Microsoft. This interface allows
for direct communication between a version control system and another software application. When you
are using SCC, keep in mind the following information:
•

If you are using a system that supports SCC, use the SCC support because it provides tighter
integration.

•

If your system does not have an SCC interface installed, contact the manufacturer to be sure that
an SCC interface is not available.

•

If your version control system has an SCC interface, but does not seem to behave properly,
contact SlickEdit Product Support.

Version control systems that have support for an SCC interface are supported. If you are using PVCS,
install the SCC interface support because it does not install SCC support by default. SourceSafe
automatically installs SCC support.
The following list of version control systems have SCC interfaces. If any of these systems are not
displayed in the SCC Providers list (or the SCC Providers list does not appear) dialog box, you might need
to install the support separately:
•
•

CCC/Harvest
ClearCase
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•
•
•

ComponentSoftware RCS
MKS Source Integrity
Star Team

Configuring SCC
SCC version control is available for systems that are using a Windows operating system only. To configure
an SCC version control system, complete the following steps.
1. From the main menu, click Tools > Options, expand Tools, then select Version Control Setup
(or use the vcsetup command).
2. Select the system that you want.
3. Click Initialize Provider.
4. Click Open Project and complete the Open Project dialog box.
5. Click OK. A project name is displayed in the list of SCC Version Control Systems. This version
control system and project are now bound together.

Opening an SCC Project
The SCC version control system is used to help you manage your files when you are working with projects.
SCC is available for systems that are using a Windows operating system only.
To open an SCC version control project, complete the following steps:
1. From the main menu, click Tools > Options, expand Tools, then select Version Control Setup
(or use the vcsetup command).
2. Be sure that SCC providers check box is marked. If there are no SCC providers installed, the
check box is unavailable. To activate this feature, install an SCC provider. For more information,
see Configuring SCC above.
3. Select the system that you want, and click Initialize Provider.
4. Click Open Project. The Open Project dialog box is displayed.
The following list contains additional information to assist you when using SCC with certain applications:
•

Source Integrity - For the SI Project Filename, type the entire path for the project.vpj file. For
Sandbox Path, type the path where the files are located on the local system.

•

Perforce - For Client Name, type the name of the Perforce depot (for example, “//depot”). For
Local Path, type the name of the path where the files are located on the local machine.

•

StarTeam - For StarTeam Project Name, type the name of the StarTeam project. For Local Path,
type the name of the path where the files are located on the local system. You are then prompted
for additional information by StarTeam.

After you open an SCC version control project, it is bound to the currently active project. When you restart
the project, or switch to this project from another project, this version control project is automatically
activated.

PVCS
If you are using PVCS, there is typically no need to switch version control projects since the source files
are placed in the same directory as the archive files. In some PVCS configurations, you will want to set
some environment variables when you switch projects. To set these environment variables, complete the
following steps:
1. From the main menu, click Project > Project Properties.
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2. Click the Open Command tab, and type one or more set statements to set the environment
variables.
3. Close and then reopen the project for the project macro to be executed.

CVS
A graphical interface for CVS updates is provided. Before updating a directory, a dialog box is displayed
that provides the status information for each file. You can then select the files that you want to update,
commit, or add. Use DIFFzilla® to view differences between various versions of a file (see DIFFzilla®).
Move the mouse pointer over the bitmap to the left of the file to display a tool tip which indicates what the
bitmap means. The File bitmap with a blue star means that the file is not up-to-date. A File bitmap with a
red star means that you have modified the file.
A graphical history dialog for files checked out from CVS is also provided. This includes displaying the
current state of the file, all tags for the file and a graphical display of the branches. You can also use
DIFFzilla to view differences between the current version and any past version, or any two past versions
with each other (see DIFFzilla®).
Commit sets are a way to group files checked out of CVS that need to be checked in at the same time.
For example, when fixing a defect you may want to group all of the files that you modified. Commit sets
allow you to do this, give a common comment for the group of files and then give an individual comment to
each file. When you are done, you can review the commit set, which allows you to easily compare each file
with the most up-to-date version using DIFFzilla (see DIFFzilla®). Then, you can commit all of the files at
one time.

Subversion
Subversion support provides easy convenient access to information about the files with which you are
working, and also a GUI checkout dialog. To get started, from the main menu, click Tools > Options,
expand Tools, then select Version Control Setup (or use the vcsetup command). Set the Command
line system to Subversion. After you activate this setting, you can diff any file with the current version on
its branch, view the history of the file, and update or commit the file. You can also click Tools > Version
Control > Compare Workspace with Subversion to compare your local workspace with the files in the
repository. The Subversion support mimics the existing SlickEdit® CVS support.
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Spell Checking
Spell Check Operations
You can access spell checking operations from the main menu by clicking Tools > Spell Check. Select
one of the following operations:
•

Check from Cursor - Check spelling on the open file starting at the cursor’s location. You can also
use the spell_check command to perform this operation.

•

Check Comments and Strings - Check spelling only on comments and strings within the open
file. Spell Check will start at the cursor’s location. You can also use the spell_check_source
command to perform this operation.

•

Check Selection - Check spelling only on text that is currently selected. The spell_check
command also works for this operation.

•

Check Word at Cursor - Check spelling only for the word currently under the cursor. You can also
use the spell_check_word command to perform this operation.

•

Check Files - Check spelling on multiple files. You can also use the spell_check_files command
to perform this operation. This will invoke the Spell Check Files dialog, which allows you to specify
the files for checking. See Spell Checking Multiple Files.

Running Spell Check
When Spell Check is running and a word is found that is not in the dictionary, the Spelling dialog appears,
prompting you for action.

The dialog shows the word not found and gives suggestions for a word replacement. Use the buttons on
the dialog to perform the following actions:
•

Ignore - Disregard this word and continue spell checking.

•

Ignore all - Disregard all instances of this word in the selected range and continue spell checking.

•

Change - Replace this word with the text in the Change to text box and continue spell checking.
You can use the suggested word or type your own word.
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•

Change All - Replace all instances of this word in the selected range with the text in the Change
to text box, and continue spell checking.

•

Add User 1 and 2 - Add the word not found to one of two custom dictionaries, after which spell
checking continues. The first time new words are added to these lists, SlickEdit® creates new files
in your configuration directory named userdct1.lst and userdct2.lst. See Spell Check Options
for more information on custom dictionary files.

•

Undo Last - Undo the last spell checking operation. The focus is placed on the last word not
found.

•

Options - Displays the Options dialog open to the Spell Check Options node. Options include
specifying the default dictionary, ignoring uppercase words, and detecting repeated words. You
can also access these Spell Check Options from the menu item Tools > Spell Check > Spell
Options or by using the spell_options command. See Spell Check Options for more information.

•

Skip File - When spell checking multiple files, use this button to skip checking in the current file.

Spell Checking Multiple Files
The Spell Check Files dialog is used to specify multiple files for checking, and always does a languagesensitive spell check. For HTML, markup that is not literal text is ignored. For source languages where
color coding is provided, only comments and strings are checked for spelling. To access the Spell Check
dialog box, pictured below, from the main menu click Tools > Spell Check > Check Files (or use the
spell_check_files command).

In the Files text box, enter one or more files separated by spaces. Wildcards may be used (for example,
*.html or *.c). You can use the Browse button to the right of this text box to choose a directory. There are
two file options available:
•

Recurse subdirectories - If checked, wildcard file specifications in the Files text box will process
subdirectories recursively.

•

Include project files - If checked, all project files are checked for spelling.

The Buffers list box lists the open buffers that will be spell checked in addition to the directory specified.
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Sorting Text
SlickEdit® uses a stable quicksort algorithm to sort text. It is recommended that at least half the text be in
memory for best speed results. To sort text, from the main menu, click Tools > Sort. The Sort dialog box is
displayed, as pictured below.

The following options are available:
•

Type of sort - Choose the type of sort that you prefer from the following options:
o

Sort buffer - When this option is selected, the entire contents of the buffer that you are
working in are sorted.

o

Sort on selection - When this option is selected, each line intersecting with the selection is
sorted based on the selected column. Sort on selection and Sort within selection have the
same effect except when sorting a block or column selection.

o

Sort within selection - When this option is selected, the selected text is sorted. Text outside a
block or column selection is not moved. The Sort on selection and Sort within selection
options have the same effect except when sorting a block or column selection.

•

Order - Choose Ascending or Descending. In an ascending sort, the lowest text item sorted is
placed at the top.

•

Numeric sort - When this option is selected, a numeric comparison is performed.

•

Remove duplicate lines - When this option is selected, it removes adjacent lines that are
identical. This option does not fully support column selection (it always compares complete lines).

•

Case sensitive - When this option is selected, the sort is case-sensitive.

Sort Commands
To use the command line for sorting, first activate the command line by pressing Esc. Sort command
syntax is in the form SortCommand OptionLetter(s). The following sort commands are available:
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•

sort_buffer - Sorts the current buffer.

•

sort_within_selection - Sorts text within a selected area. This command supports line and block
selections only.

•

sort_on_selection - To sort on a column field, press Ctrl+B to select an area of text, then invoke
the command sort_on_selection. This command supports line and block selections only.

The table below describes the OptionLetter(s) that you can use with each command.
Option
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Meaning

A

Sort in ascending order.

D

Sort in descending order.

I

Case insensitive sort (ignore case).

E

Case sensitive sort (exact case
which is the default).

-N

Numeric sort. C-style floating point
numbers with up to 32-digit
mantissa are supported.

-F

File name sort.

SlickEdit® User Guide

FTP

FTP
FTP support within SlickEdit® includes a complete FTP/SFTP client and the ability to easily open and edit
FTP files.

Working with FTP
Before you can access FTP files, you must create an FTP profile, then start that connection. FTP
operations can be accessed from FTP tool windows or by right-clicking on FTP files after a connection is
active.

FTP Tool Windows
There are two tool windows available for working with FTP: FTP and FTP Client.
•

The FTP tool window can be used to connect to FTP servers and open files. To access this tool
window, from the main menu, click View > Toolbars > FTP. Right-click on files to display a menu
of FTP operations.

•

The FTP Client tool window can also be used to connect to FTP servers and transfer files. As
with most FTP clients, local directories and files are displayed in the left section of the tool window,
and the FTP server directories and files are on the right. To access this tool window, from the main
menu, click View > Toolbars > FTP Client. Right-click on files to display a menu of FTP
operations.

Creating a New FTP Profile
To create a new FTP connection profile, complete the following steps:
1. From the main menu, click File > FTP > Profile Manager (ftpprofilemanager command).
Alternatively, you can display the FTP tool window (View > Toolbars > FTP) and click the button
labeled Start a New Session
below.
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2. Click Add to create a new profile. The Add FTP Profile dialog box is displayed.
3. Click Edit to Edit a profile. The Edit FTP Profile dialog box is displayed.
See Setting FTP Options for information about the options on the Add or Edit FTP Profile dialogs.

Starting a Connection
To start a new connection, use the FTP or FTP Client tool windows described above, and complete the
following steps:

1. Click the FTP button

to start a new session.

2. The FTP Profile Manager dialog box appears. From the Profiles list, select the profile name to
connect to.
3. Click Connect. The FTP tool window displays the content of the remote directory.
4. Toggle the ASCII Transfer mode button to transfer text files. When in ASCII transfer mode, line
ending characters may be translated.

5. Toggle the Binary Transfer mode button

450

to transfer images and executables.
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6. To stop the current operation, click the Stoplight button

.

Stopping a Connection
To stop a connection, use the FTP or FTP Client tool windows, and complete the following steps:
1. Select the connection that you want from the drop-down list at the top of the tool window.

2. Click the Disconnect Current Session button

.

Opening FTP Files
Before you can open FTP files, you need to start a connection. See Starting a Connection above for more
information. After your connection starts, from the FTP or FTP Client tool window, right-click on selected
files to open them, to change the directory, or to access more options.

Setting FTP Options
There are two types of settings available for working with FTP:
•

FTP connection profile options - These options are used to add or edit new FTP connection
profiles. The Add/Edit FTP Profile dialog box is used. To access this dialog, click File > FTP >
Profile Manager, then select New or Edit to edit an existing selected profile. See Add/Edit FTP
Profile Dialog for a complete list of available options.

•

Default FTP options - These are the general default FTP settings. To access these options, from
the main menu, click Tools > Options, expand Network & Internet Options and select FTP
Default Options. See FTP Default Options for more information.
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Regular Expressions
Overview
Regular expressions are patterns of text used to match and manipulate strings in your code. These
patterns are expressed with combinations of characters defined by the regular expression syntax being
used. A regular expression is sometimes referred to as a “regex”.
Use regular expressions in your search and replace operations when you find normal search/replace too
limiting. For example, with regular expressions, you can:
•
•
•
•

Find quoted strings.
Find blank lines.
Find words starting at the beginning of lines.
Find two words separated by any number of spaces or other text.

SlickEdit® supports five types of regular expression syntax:
•
•
•
•
•

Brief
Perl
SlickEdit
UNIX
Wildcards

SlickEdit also provides a Regex Evaluator that you can use to interactively create, save, and re-use tests
of regular expressions. See The Regex Evaluator for more information.
See Regular Expression Syntax for charts of the expressions in syntax. Unicode regular expression
categories and character blocks are also supported. See Unicode Categories and Character Blocks for
more information.
NOTE
•

This documentation is not meant to be an exhaustive resource on regular expressions.
Rather, we will present basic information, syntax charts, and examples. For novice users,
there are many books and Web sites that go into more detail about this topic.

•

While regular expressions in SlickEdit primarily match the syntax for that language, there
are some differences between our implementation and those elsewhere.

Using Regular Expressions in SlickEdit®
Specifying the Syntax to Use
All search and replace commands, the Find and Replace tool window, and incremental search support
regular expressions. For search and replace commands and the tool window, you can specify the regular
expression syntax to use through specific options. A global option is available to specify the default syntax
to use when you invoke these features or when you use incremental search.
For example:
•

Search and replace commands - When using the search commands / (slash) and find, or the
replace commands c and replace, you can use the following options to specify regular expression
syntax:
o

Use B to interpret the search string as Brief regular expression.
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o
o
o

Use the L option to interpret the string as a Perl regular expression.
Use R to interpret the string as a SlickEdit regular expression.
Use the U option to interpret the string as a UNIX regular expression.

•

Find and Replace tool window - When using the tool window, select Use in the Search options
box, and then pick the syntax to use from the drop-down list.

•

Incremental search - When using incremental search, press Ctrl+T to toggle regular expression
searching on and off. The syntax that will be used is based on the global syntax setting.

To set the global option, from the main menu, click Tools > Options, expand Editing and select Search.
Set the Regular expression option to True and select the syntax you want to use from the Expression
type drop-down list.

Minimal versus Maximal Matching
If you are using tagged expressions or regular expressions to perform a search and replace, it is important
to understand the difference between the minimal and maximal operators.
Take, for example, a line of text which contains a DOS file name: \path1\path2\path3\name.ext.
Based on the syntax, the following regular expressions match the string \path1\:
Syntax

Expression

Brief

<\\*\\

Perl and UNIX

^\\.*?\\

SlickEdit

^\\?*\\

The following regular expressions, which use the maximal operator, match the string \path\path2\path3\:
Syntax

Expression

Brief

<\\\:*\\

Perl and UNIX

^\\.*\\

SlickEdit

^\\?@\\

As a rule of thumb, the following minimal matching operators are generally used after a less-specific
regular expression such as ? in Brief/SlickEdit or . in UNIX:
Syntax
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Operators

Brief

@ and +

Perl and UNIX

*? and +?

SlickEdit

* and +
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Use the maximal matching operators after a regular expression which matches something more specific.
For example, to search for a string of digits and prefix each matched string with the character $, specify the
following expressions:
Syntax

Expression

Brief

Search for: {[0-9]\:+}
Replace with: $\0

Perl and UNIX

Search for: ([0-9]+)
Replace with: $\1

SlickEdit

Search for: {[0-9]#}
Replace with: $#0

If the minimal matching operator (+ in Brief/SlickEdit syntax, +? in Perl/UNIX) was used in the search string
instead of the maximal matching operator (\:@ in Brief, + in Perl/UNIX, # in SlickEdit), the above search
and replace would prefix each digit in the entire file with a $ character.

Using Tagged Expressions
When you use regular expressions to search for a string, you will often want the replace string to depend
on what was found. Use tagged expressions to insert parts of what is found into the replace string. Tagged
expressions are denoted based on the syntax:
•

Brief syntax - Use { } (curly braces) to denote a tagged expression in the search string. The
replace string specifies tagged expressions with a \ (backslash) followed by a tagged expression
number 0-9. Count the { (left braces) in the search string to determine a tagged expression
number. The first tagged expression is \0.

•

Perl and UNIX syntaxes - Use ( ) (parentheses) to denote a tagged expression in the search
string. The replace string specifies tagged expressions with a \ (backslash) followed by a tag group
number 1-9. Count the ( (left parenthesis) in the search string to determine a tagged expression
number. The first tagged expression is \1 and the last is \0.

•

SlickEdit® syntax - Use { } (curly braces) to denote a tagged expression in the search string. The
replace string specifies tagged expressions with a # (pound sign) followed by a tagged expression
number 0-9. Count the { (left braces) in the search string to determine a tagged expression
number. The first tagged expression is #0.

Examples of Tagged Expressions
Example 1: Replace Occurrences
The expressions in the table below replace occurrences of “if” and “while” with “xify” and “xwhiley.”
Unmatched groups are null. Note that the \1 in Brief syntax, \2 in Perl/UNIX, and #1 in SlickEdit syntax are
replaced with null.
Syntax
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Expression

Brief

Search for: {{if}|while}}
Replace with: x\0y\1

Perl/UNIX

Search for: (if|while)
Replace with: x\1y\2
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Syntax
SlickEdit

Expression
Search for: {if|while}
Replace with: x#0y#1

Example 2: Reverse Text on Lines Containing a Comma
The expressions in the table below reverse text on lines containing a comma. Lines with “abc,def” will be
changed to “def,abc”. Notice that the Perl/UNIX regular expression search string uses a *? minimal
matching operator, so the comma actually matches the first comma in the line and not the last.
Syntax

Expression

Brief

Search for: ^{*},{*}$
Replace with: \1,\0

Perl/UNIX

Search for: ^(.*?),(.*)$
Replace with: \2,\1

SlickEdit

Search for: ^{?*},{?*}$
Replace with: #1,#0

Replacing with Regular Expressions
When using regular expressions, some characters have a different meaning when used in the replace
string, depending on the syntax:
•

Brief - The backslash character (\) in the replace string has the same meaning as in the search
string except that \c and \:char are not supported.

•

Perl/UNIX - A backslash in the replace string has the same meaning as in the search string except
that \c and \:char are not supported.

•

SlickEdit® - The pound sign character (#) and backslash (\) have special meaning in the replace
string. A backslash in the replace string has the same meaning as in the search string except that
\c, :char, and \gd are not supported.

See the Regular Expression Syntax tables for a list of options for these characters. See Using Tagged
Expressions for information on specifying tagged expressions in the replace string.

Case Modification in Replace
When used in a replace operation, the expressions in the following table can be used to modify the
character casing of matched expressions. These work in Brief, Perl, SlickEdit, and UNIX syntaxes.
Expression
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Description

\l

Convert next character lowercase.

\u

Convert next character uppercase.

\L

Convert all characters lowercase until \E.

\U

Convert all characters uppercase until \E.

\Q

Replace all characters literally until \E.
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Expression
\E

Description
End all case modification or \Q.

Examples of Replacing with Regular Expressions
The table below contains some examples of replace operations using regular expressions.
Operation

Expression

Search for occurrences of the string
“hat” that occur at the end of a line and
replace it with “cat”.

In all syntaxes:
Search for: hat$
Replace with: cat

Delete blank lines.

Brief:
Search for: <\n
Replace with: (leave blank)
Perl/SlickEdit/UNIX:
Search for: ^\n
Replace with: (leave blank)

Replace occurrences of two
consecutive blank lines with one.

Brief:
Search for: <\n\n
Replace with: \n
Perl/SlickEdit/UNIX:
Search for: ^\n\n
Replace with: \n

Search for lines containing “a” and
replace the “a” with a formfeed
character.

Brief:
Search for: <a+$
Replace with: \d12
Perl/UNIX:
Search for: ^a+$
Replace with: \d12
SlickEdit:
Search for: ^a+$
Replace with: \12

Select occurrences of “Title:” at the
beginning of a line and capitalize the
text following “Title:”.

Brief:
Search for: <Title: {\:*}
Replace with: Title: \U\0
Perl/UNIX:
Search for: ^Title: (.*)
Replace with: Title: \U\1
SlickEdit:
Search for: ^Title\: {?@}
Replace with: Title: \U#0
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The Regex Evaluator
Regular expressions are used to express text patterns for searching. The Regex Evaluator provides the
capability to interactively create, save, and re-use tests of regular expressions.
To access the Regex Evaluator, click Tools > Regex Evaluator (or use the activate_regex_evaluator
command). Like other tool windows in SlickEdit®, this tool window is dockable. Docking options can be
accessed by right-clicking on the tool window’s title bar.
Type some samples of the text you are trying to match in the top portion of the tool window labeled Test
Cases. Enter your regular expression pattern in the bottom field. The Regex Evaluator will highlight
matched portions of your sample text and identify groups.

Entering Test Cases
Type your test cases in the Test Cases text box. These test cases will be evaluated as you type your
regular expression in the bottom field. A wavy underline will indicate the ranges of text that match the
entire expression. Matches are also marked with a yellow arrow that appears in the gutter to the left of the
test case. You can hover your mouse on this arrow to see a tool tip which displays the matched expression
details. When groups (tagged expressions) are used in your regular expression pattern, the groups will be
boxed and highlighted in yellow in the Test Cases section.

Entering a Regular Expression
Enter the regular expression to test in the text field. Use the radio buttons to select the expression syntax
that you wish to use: UNIX, SlickEdit®, Brief, or Perl. Click the arrow to the right of the regular expression
field to pick from a menu of common syntax and operators.

Regex Evaluator Options
The following options and buttons are available on the Regex Evaluator tool window:
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•

Multiline mode - If Multiline mode is selected, rather than searching through the test cases lineby-line, regular expressions will be searched on all lines at once. This is useful for test cases that
wrap to the next line. This works just as if you had entered \om on the SlickEdit® command line.

•

Case sensitive - If Case sensitive is selected, the regular expression search will be case
sensitive. This option is on by default.

•

New expression button - To clear the tool window of all entries in order to start a new evaluation,
click the button at the top of the tool window labeled New expression.

•

Open a saved expression button - To open an expression that you have already saved, click the
folder button at the top of the tool window labeled Open a saved expression.

•

Save the current expression button - To save the current expression, click the diskette button at
the top of the tool window labeled Save the current expression. Both the expression and the test
cases will be saved to a file. The default extension is .regx.

•

Save as button - To save the current expression with a different file name than what has
previously been saved, click the button at the top of the tool window labeled Save the current
expression as.

Regular Expression Syntax
This section provides charts of regular expressions for each supported syntax (Brief, Perl, SlickEdit, UNIX,
and Wildcards), including examples.
NOTE There are some differences between our implementation of these syntaxes and those
elsewhere.

Brief Regular Expressions
Brief regular expressions are defined in the following table.
Brief Regular Expression

Definition

%

Matches beginning of line.

<

Matches beginning of line.

$

Matches end of line.

>

Matches end of line.

?

Matches any character except newline.

*

Minimal match of zero or more of any character except
newline. This is the same as ?@.

X+

Minimal match of one or more occurrences of X. See Minimal
versus Maximal Matching for more information.

X\:*

Maximal match of zero or more of any character except
newline. This is the same as ?\:@.

X\:@

Maximal match of zero or more occurrences of X.

X\:+

Maximal match of one or more occurrences of X.
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Brief Regular Expression
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Definition

X\:n1

Matches exactly n1 occurrences of X. Use {} to avoid
ambiguous expressions. For example, a:9{}1 searches for
nine instances of the letter “a” followed by a “1”.

X\:n1,

Maximal match of at least n1 occurrences of X.

X\:,n2

Maximal match of at least zero occurrences but not more than
n2 occurrences of X.

X\:n1,n2

Maximal match of at least n1 occurrences but not more than
n2 occurrences of X.

X\:n1?

Match exactly n1 occurrences of X.

X\:n1,?

Minimal match of at least n1 occurrences of X.

X\:,n2?

Minimal match of at least zero occurrences but not more than
n2 occurrences of X.

X\:n1,n2?

Minimal match of at least n1 occurrences but not more than n2
occurrences of X.

\(X\)

Matches subexpression X but does not define a tagged
expression.

{X}

Matches subexpression X and specifies a new tagged
expression. See Using Tagged Expressions for more
information.

{@dX}

Matches subexpression X and specifies to use tagged
expression number d where 0<=d<=9. No more tagged
expressions are defined by the subexpression syntax {X} once
this subexpression syntax is used. This is the best way to
make sure you have enough tagged expressions.

X|Y

Matches X or Y.

~{X}

Search fails if expression X is matched.

[char-set]

Matches any one of the characters specified by char-set. A
dash (-) character may be used to specify ranges. The
expression [A-Z] matches any uppercase letter. Backslash (\)
can be used inside the square brackets to define literal
characters or define ASCII characters. For example, \specifies a literal dash character. The expression [\0-\27]
matches ASCII character codes 0..27. The expression []]
matches a right bracket. In SlickEdit® regular expressions, []
matches no characters. In both syntaxes, the expression [\]]
matches a right bracket.

[~char-set]

Matches any character not specified by char-set. A dash (-)
character may be used to specify ranges. The expression
[~A-Z] matches all characters except uppercase letters. The
expression [~] matches any character except newline.
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Brief Regular Expression

Definition

[char-set1 - [char-set2]]

Character set subtraction. Matches all characters in char-set1
except the characters in char-set2. For example, [a-z-[qw]]
matches all English lowercase letters except “q” and “w”.
[\p{L}-[qw]] matches all Unicode lowercase letters except “q”
and “w”.

[char-set1 & [char-set2]]

Character set intersection. Matches all characters in char-set1
that are also in char-set2. For example, [\x{0}-\x{7f}&[\p{L}]]
matches all letters between 0 and 127.

\x{hhhh}

Matches up to 31-bit Unicode hexadecimal character specified
by hhhh.

\p{UnicodeCategorySpec]

(Only valid in character set) Matches characters in
UnicodeCategorySpec. Where UnicodeCategorySpec uses
the standard general categories specified by the Unicode
consortium. For example, [\p{L}] matches all letters. [\p{Lu}]
matches all uppercase letters. See Unicode Category
Specifications for Regular Expressions.

\P{UnicodeCategorySpec]

(Only valid in character set) Matches characters not in
UnicodeCategorySpec. For example, [\P{L}] matches all
characters that are not letters. This is equivalent to [^\p{L}].
[\P{Lu}] matches all characters that are not uppercase letters.
See Unicode Category Specifications for Regular Expressions.

\p{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters in
UnicodeIsBlockSpec. Where UnicodeIsBlockSpec one of
the standard character blocks specified by the Unicode
consortium. For example, [\p{isGreek}] matches Unicode
characters in the Greek block. See Unicode Character Blocks
for Regular Expressions.

\P{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters not in
UnicodeIsBlockSpec. For example, [\P{isGreek}] matches
all characters that are not in the Unicode Greek block. This is
equivalent to [^\p{isGreek}]. See Unicode Character Blocks
for Regular Expressions.

\xhh

Matches hexadecimal character hh where 0<=hh<=0xff.

\dddd

Matches decimal character ddd where 0<=ddd<=255.

\d

Defines a back reference to tagged expression number d. For
example, {abc}def\0 matches the string abcdefabc. If the
tagged expression has not been set, the search fails.

\c

Specifies cursor position if match is found. If the expression
xyz\c is found, the cursor is placed after z.

\n

Matches newline character sequence. Useful for matching
multi-line search strings. What this matches depends on
whether the buffer is a DOS (ASCII 13,10 or just ASCII 10),
UNIX (ASCII 10), Macintosh (ASCII 13), or user defined ASCII
file. Use \d10 if you want to match a 10 character.
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462

Definition

\r

Matches carriage return.

\t

Matches tab character.

\b

Matches at word boundary. For example, \bre matches all
occurrences of “re” that only occur at the beginning of a word.
Note that this notation previously matched a backspace
character. It can still be used to match a backspace character
by using it in a character set (for example, [\b]).

\B

Matches all except at word boundary. For example, \Bre
matches all occurrences of “re” as long as it is not at the start
of a new word.

\Q and \E

\Q matches all characters as literals until \E. This is useful for
longer sequences of characters without the need for the
escape character. \Q does not require termination with \E, as it
will continue to match characters literally until the end of the
search string. \E returns to using special character tokens for
matching.

\f

Matches form feed character.

\od

Matches any 2-byte DBCS character. This escape is only valid
in a match set ([...\od...]). [~\od] matches any single byte
character excluding end-of-line characters. When used to
search Unicode text, this escape does nothing.

\om

Turns on multi-line matching. This enhances the match
character set, or match any character primitives to support
matching end-of-line characters. For example, \om?\@
matches the rest of the buffer.

\ol

Turns off multi-line matching (default). You can still use \n to
create regular expressions which match one or more lines.
However, expressions like ?\@ will not match multiple lines.
This is much safer and usually faster than using the \om
option.

\oi

Ignore case. Turns off case-sensitive matching in the pattern,
overriding the global case setting. This modifier is localized
inside the current grouping level, after which case matching is
restored to the previous case match setting. See also \oc.

\oc

Case-sensitive match. Turns on case-sensitive matching in the
pattern, overriding the global case setting. This modifier is
localized inside the current grouping level, after which case
matching is restored to the previous case match setting. See
also \oi.

\char

Declares character after slash to be literal. For example, \*
represents the asterisk (*) character.
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Brief Regular Expression
\:char

Definition
Matches predefined expression corresponding to char. The
predefined expressions are:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

\:a [A-Za-z0-9 - Matches an alphanumeric character.
\:b\([ \t]#\) - Matches blanks.
\:c [A-Za-z] - Matches an alphabetic character.
\:d [0-9] - Matches a digit.
\:f \([~\[\]\:\\/<>|=+;, \t”’]#\) - Matches a file name part.
\:f \([~/ \t”’]#\) - UNIX: Matches a file name part.
\:h\([0-9A-Fa-f]#\) - Matches a hex number.
\:i\([0-9]#\) - Matches an integer.
\:n\([0-9]#\(.[0-9]#|\)|.[0-9]#\)\([Ee]\(\+|-|\)[0-9]#|\)\) Matches a floating number.
\:p\(\([A-Za-z]\:|\)\(\\|/|\)\(:f\(\\|/\)\)@:f\) - Windows:
Matches a path.
\:p\(\(/|\)\(:f\(/\)\)@:f\) - UNIX: Matches a path.
\:q\(\"[~\"]@\"|'[~']@'\) - Matches a quoted string.
\:v\ ([A-Za-z_$][A-Za-z0-9_$]@\) - Matches a C
variable.
\:w\ ([A-Za-z]#\) - Matches a word.

Brief Regular Expression Examples
The table below shows examples of Brief regular expressions.
Brief Regular Expression
Example

Description

<defproc

Matches lines that begin with the word defproc.

<definit>

Matches lines that only contain the word definit.

<\*name

Matches lines that begin with the string *name. Notice that the
backslash must prefix the special character *.

[\t ]

Matches tab and space characters.

[\d9\d32]

Matches tab and space characters.

[\x9\x20]

Matches tab and space characters.

p?t

Matches any three-letter string starting with the letter p and
ending with the letter t. Two possible matches are pot and pat.

s*t

Matches the letter s followed by any number of characters
followed by the nearest letter t. Two possible matches are seat
and st.

{for}|{while}

Matches the strings for or while.

^\:p

Matches lines beginning with a file name.

xy+z

Matches x followed by one or more occurrences of y followed
by z.
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Brief Regular Expression
Example

Description

\x0d\x0a\x01\x02

Matches a sequence of hex binary characters.

\d13\d10\d1\d2

Matches a sequence of decimal binary characters.

Perl Regular Expressions
Perl regular expressions are defined in the following table.
Perl Regular Expression
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Definition

^

Matches beginning of line.

$

Matches end of line.

.

Matches any character except newline.

X+

Maximal match of one or more occurrences of X. See Minimal
versus Maximal Matching.

X*

Maximal match of zero or more occurrences of X.

X?

Maximal match of zero or one occurrences of X.

X{n1}

Match exactly n1 occurrences of X.

X{n1,}

Maximal match of at least n1 occurrences of X.

X{,n2}

Maximal match of at least zero occurrences but not more than
n2 occurrences of X.

X{n1,n2}

Maximal match of at least n1 occurrences but not more than
n2 occurrences of X.

X+?

Minimal match of one or more occurrences of X.

X*?

Minimal match of zero or more occurrences of X.

X??

Minimal match of zero or one occurrences of X.

X{n1}?

Matches exactly n1 occurrences of X.

X{n1,}?

Minimal match of at least n1 occurrences of X.

X{,n2}?

Minimal match of at least zero occurrences but not more than
n2 occurrences of X.

X{n1,n2}?

Minimal match of at least n1 occurrences but not more than n2
occurrences of X.

(?!X)

Search fails if expression X is matched. The expression ^(?!if)
matches the beginning of all lines that do not start with if.

(?=X)

Assert, positive lookahead. Searches for subexpression X, but
X is not returned as part of the match. For example, to match
words ending in “ed” while excluding “ed” as part of the match,
use \b[a-z]+(?=ed\b). See also (?!X).
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Perl Regular Expression

Definition

(?>X)

Prohibit backtracking. This expression is advanced usage. It
can be used to prevent the subexpression X from backtracking
when using maximal (greedy) matching.

(?#text)

Comment. No text is matched in this expression; it is used for
comment and documentation only.

(X)

Matches subexpression X and specifies a new tagged
expression (see Using Tagged Expressions). No more tagged
expressions are defined once an explicit tagged expression
number is specified as shown below.

(?dX)

Matches subexpression X and specifies to use tagged
expression number d where 0<=d<=9. No more tagged
expressions are defined by the subexpression syntax (X) once
this subexpression syntax is used. This is the best way to
make sure you have enough tagged expressions.

(?:X)

Matches subexpression X but does not define a tagged
expression.

X|Y

Matches X or Y.

[char-set]

Matches any one of the characters specified by char-set. A
dash (-) character may be used to specify ranges. The
expression [A-Z] matches any uppercase letter. A backslash
(\) may be used inside the square brackets to define literal
characters or define ASCII characters. For example, \specifies a literal dash character. The expression [\d0-\d27]
matches ASCII character codes 0..27. The expression []]
matches a right bracket. In SlickEdit® regular expressions, []
matches no characters. In both syntaxes, the expression [\]]
matches a right bracket. The expression [^] matches a caret
(^) character but this does not work for SlickEdit regular
expressions. In both syntaxes, [\^] matches a caret (^)
character.

[^char-set]

Matches any character not specified by char-set. A dash (-)
character may be used to specify ranges.

[char-set1 - [char-set2]]

Character set subtraction. Matches all characters in char-set1
except the characters in char-set2. The expression [^A-Z]
matches all characters except uppercase letters. For example,
[a-z-[qw]] matches all English lowercase letters except q and
w. [\p{L}-[qw]] matches all Unicode lowercase letters except q
and w.

[char-set1 & [char-set2]

Character set intersection. Matches all characters in char-set1
that are also in char-set2. For example, [\x{0}-\x{7f}&[\p{L}]]
matches all letters between 0 and 127.

\x{hhhh}

Matches up to 31-bit Unicode hexadecimal character specified
by hhhh.
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\p{UnicodeCategorySpec]

(Only valid in character set) Matches characters in
UnicodeCategorySpec. Where UnicodeCategorySpec uses
the standard general categories specified by the Unicode
consortium. For example, [\p{L}] matches all letters. [\p{Lu}]
matches all uppercase letters. See Unicode Category
Specifications for Regular Expressions.

\P{UnicodeCategorySpec]

(Only valid in character set) Matches characters not in
UnicodeCategorySpec. For example, [\P{L}] matches all
characters that are not letters. This is equivalent to [^\p{L}].
[\P{Lu}] matches all characters that are not uppercase letters.
See Unicode Category Specifications for Regular Expressions.

\p{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters in
UnicodeIsBlockSpec. Where UnicodeIsBlockSpec one of
the standard character blocks specified by the Unicode
consortium. For example, [\p{isGreek}] matches Unicode
characters in the Greek block. See Unicode Character Blocks
for Regular Expressions.

\P{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters not in
UnicodeIsBlockSpec. For example, [\P{isGreek}] matches
all characters that are not in the Unicode Greek block. This is
equivalent to [^\p{isGreek}]. See Unicode Character Blocks
for Regular Expressions.

\xhh

Matches hexadecimal character hh where 0<=hh<=0xff.

\#ddd

Matches decimal character where 0<=ddd<=255.

\d

Defines a back reference to tagged expression number d. For
example, {abc}def\0 matches the string abcdefabc. If the
tagged expression has not been set, the search fails.

\d

Equivalent to [0-9]. Can also be used inside a character class.
For example, [A-F\d] is equivalent to [A-F0-9].

\D

Equivalent to [^0-9]. Can also be used inside a character
class.

\w

Equivalent to [a-zA-Z0-9_]. Can also be used inside a
character class.

\W

Equivalent to [^a-zA-Z0-9_]. Can also be used inside a
character class.

\s

Equivalent to [ \t\n\r\f]. Can also be used inside a character
class.

\S

Equivalent to [^ \t\n\r\f]. Can also be used inside a character
class.

\ooo

Octal ASCII value.

\cx

Control character (ASCII values 0-31) '@' <=x<='_'
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\z

Specifies cursor position if match is found. If the expression
abc\z is found, the cursor is placed after the c. Note that in
UNIX, this is the same as \c. However in Perl, \c is used only
for control characters.

\n

Matches newline character sequence. Useful for matching
multi-line search strings. What this matches depends on
whether the buffer is a DOS (ASCII 13,10 or just ASCII 10),
UNIX (ASCII 10), Macintosh (ASCII 13), or user-defined ASCII
file. Use \d10 if you want to match an ASCII 10 character.

\r

Matches carriage return (ASCII 13). What this matches
depends on whether the buffer is a DOS (ASCII 13,10 or just
ASCII 10), UNIX (ASCII 10), Macintosh (ASCII 13), or user
defined ASCII file.

\t

Matches tab character.

\b

Matches at word boundary. For example, \bre matches all
occurrences of “re” that only occur at the beginning of a word.

\B

Matches all except at word boundary. For example, \Bre
matches all occurrences of “re” as long as it is not at the start
of a new word.

\Q and \E

\Q matches all characters as literals until \E. This is useful for
longer sequences of characters without the need for the
escape character. \Q does not require termination with \E, as it
will continue to match characters literally until the end of the
search string. \E returns to using special character tokens for
matching.

\f

Matches form feed character.

\od

Matches any 2-byte DBCS character. This escape is only valid
in a match set ([...\od...]). [^\od] matches any single byte
character excluding end-of-line characters. When used to
search Unicode text, this escape does nothing.

\om

Turns on multi-line matching. This enhances the match
character set, or match any character primitives to support
matching end-of-line characters. For example, \om.+ matches
the rest of the buffer.

\ol

Turns off multi-line matching (default). You can still use \n to
create regular expressions which match one or more lines.
However, expressions like .+ will not match multiple lines. This
is much safer and usually faster than using the \om option.

\oi

Ignore case. Turns off case-sensitive matching in the pattern,
overriding the global case setting. This modifier is localized
inside the current grouping level, after which case matching is
restored to the previous case match setting. Note that this is
the equivalent to the Perl syntax ?i. See also \oc.
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\oc

Case-sensitive match. Turns on case-sensitive matching in the
pattern, overriding the global case setting. This modifier is
localized inside the current grouping level, after which case
matching is restored to the previous case match setting. Note
that this is equivalent to the Perl syntax ?-i. See also \oi.

\char

Declares character after slash to be literal. For example, \*
represents the star character.

\:char

Matches predefined expression corresponding to char. The
pre-defined expressions are:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

\:a [A-Za-z0-9] - Matches an alphanumeric character.
\:c [A-Za-z] - Matches an alphabetic character.
\:b (?:[ \t]+) - Matches blanks.
\:d [0-9] - Matches a digit.
\:f (?:[^\[\]\:\\/<>|=+;, \t”’]+) - Windows: Matches a file
name part.
\:f (?:[^/ \t”’]+) - UNIX: Matches a file name part.
\:h (?:[0-9A-Fa-f]+) - Matches a hex number.
\:i (?:[0-9]+) - Matches an integer.
\:n (?:(?:[0-9]+(?:\.[0-9]+|)|\.[0-9]+)(?:[Ee](?:\+|-|)[09]+|)) - Matches a floating number.
\:p (?:(?:[A-Za-z]:|)(?:\\|/|)(?:\:f(?:\\|/))*\:f) - Windows:
Matches a path.
\:p (?:(?:/|)?:(?::f(/))*\:f) - UNIX: Matches a path.
\:q (?:\"[^\"]*\"|'[^']*') - Matches a quoted string.
\:v (?:[A-Za-z_$][A-Za-z0-9_$]*) - Matches a C
variable.
\:w (?:[A-Za-z]+) - Matches a word.

The precedence of operators, from highest to lowest, is as follows:
•
•
•

+, *, ?, {}, +?, *?, ??, {}? (These operators have the same precedence.)
concatenation
|

Perl Regular Expression Examples
The table below shows examples of UNIX regular expressions.
Perl Regular Expression
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^defproc

Matches lines that begin with the word defproc.

^definit$

Matches lines that only contain the word definit.

^\*name

Matches lines that begin with the string *name. Notice that the
backslash must prefix the special character *.

[\t ]

Matches tab and space characters.
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[\d9\d32]

Matches tab and space characters.

[\x9\x20]

Matches tab and space characters.

p.t

Matches any three-letter string starting with the letter p and
ending with the letter t. Two possible matches are pot and pat.

s.*?t

Matches the letter s followed by any number of characters
followed by the nearest letter t. Two possible matches are seat
and st.

for|while

Matches the strings for or while.

^\:p

Matches lines beginning with a file name.

xy+z

Matches x followed by one or more occurrences of y followed
by z.

[a-z-[qw]]

Character set subtraction. Matches all English lowercase
letters except q and w.

[\p{isGreek}&[\p{L}]]

Character set intersection. Matches all Unicode letters in the
Greek block.

\x{6587}

Matches Unicode character with hexadecimal value 6587.
Character set intersection. Matches all Unicode letters in the
Greek block.

[\p{L}-[qw]]

Matches all Unicode letters except q and w.

[\p{L}]

Matches all Unicode letters.

[\p{Lul}]

Matches all Unicode uppercase and lowercase letters.

[\P{L}]

Matches all Unicode characters that are not letters.

[\p{isGreek}]

Matches all Unicode characters in the Greek block.

\x0d\x0a\x01\x02

Matches a sequence of hex binary characters.

\d13\d10\d1\d2

Matches a sequence of decimal binary characters.

SlickEdit® Regular Expressions
SlickEdit regular expressions are defined in the following table.
SlickEdit Regular
Expression

Definition

^

Matches beginning of line.

$

Matches end of line.

?

Matches any character except newline.
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X+

Minimal match of one or more occurrences of X. See Minimal
versus Maximal Matching for more information.

X#

Maximal match of one or more occurrences of X.

X*

Minimal match of zero or more occurrences of X.

X@

Maximal match of zero or more occurrences of X.

X:n1

Matches exactly n1 occurrences of X. Use () to avoid
ambiguous expressions. For example a:9()1 searches for nine
instance of the letter a followed by a 1.

X:n1,

Maximal match of at least n1 occurrences of X.

X:n1,n2

Maximal match of at least n1 occurrences but not more than
n2 occurrences of X.

X:*n1,

Minimal match of at least n1 occurrences of X.

X:*n1,n2

Minimal match of at least n1 occurrences but not more than n2
occurrences of X.

~X

Search fails if expression X is matched. The expression ^~(if)
matches the beginning of all lines that do not start with if.

(X)

Matches subexpression X.

{X}

Matches subexpression X and specifies a new tagged
expression. See Using Tagged Expressions for more
information.

{#dX}

Matches subexpression X and specifies to use tagged
expression number d where 0<=d<=9.

X|Y

Matches X or Y.

[char-set]

Matches any one of the characters specified by char-set. A
dash (-) character may be used to specify ranges. The
expression [A-Z] matches any uppercase letter. Backslash (\)
may be used inside the square brackets to define literal
characters or define ASCII characters. For example, \specifies a literal dash character. The expression [\0-\27]
matches ASCII character codes 0..27. The expression []
matches no characters. In UNIX regular expressions, []]
matches a right bracket. In both syntaxes, the expression [\]]
matches a right bracket. The expression [\^] matches a caret
(^) character in both syntaxes.

[~char-set]

Matches any character not specified by char-set. A dash (-)
character may be used to specify ranges. The expression
[~A-Z] matches all characters except uppercase letters.

[^char-set]

Same as [~char-set] above.

SlickEdit® User Guide

REGULAR EXPRESSIONS

SlickEdit Regular
Expression

Definition

[char-set1 - [char-set2]]

Character set subtraction. Matches all characters in char-set1
except the characters in char-set2. For example, [a-z-[qw]]
matches all English lowercase letters except q and w.
[\p{L}-[qw]] matches all Unicode lowercase letters except q
and w.

[char-set1 & [char-set2]]

Character set intersection. Matches all characters in char-set1
that are also in char-set2. For example, [\x{0}-\x{7f}&[\p{L}]]
matches all letters between 0 and 127.

\x{hhhh}

Matches up to 31-bit Unicode hexadecimal character specified
by hhhh.

\p{UnicodeCategorySpec]

(Only valid in character set) Matches characters in
UnicodeCategorySpec. Where UnicodeCategorySpec uses
the standard general categories specified by the Unicode
consortium. For example, [\p{L}] matches all letters. [\p{Lu}]
matches all uppercase letters. See Unicode Category
Specifications for Regular Expressions.

\P{UnicodeCategorySpec]

(Only valid in character set) Matches characters not in
UnicodeCategorySpec. For example, [\P{L}] matches all
characters that are not letters. This is equivalent to [^\p{L}].
[\P{Lu}] matches all characters that are not uppercase letters.
See Unicode Category Specifications for Regular Expressions.

\p{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters in
UnicodeIsBlockSpec. Where UnicodeIsBlockSpec one of
the standard character blocks specified by the Unicode
consortium. For example, [\p{isGreek}] matches Unicode
characters in the Greek block. See Unicode Character Blocks
for Regular Expressions.

\P{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters not in
UnicodeIsBlockSpec. For example, [\P{isGreek}] matches
all characters that are not in the Unicode Greek block. This is
equivalent to [^\p{isGreek}]. See Unicode Character Blocks
for Regular Expressions.

\xhh

Matches hexadecimal character hh where 0<=hh<=0xff.

\ddd

Matches decimal character ddd where 0<=ddd<=255.

\gd

Defines a back reference to tagged expression number d. For
example, {abc}def\g0 matches the string abcdefabc. If the
tagged expression has not been set, the search fails.

\c

Specifies cursor position if match is found. If the expression
xyz\c is found, the cursor is placed after the z.
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\n

Matches newline character sequence. Useful for matching
multi-line search strings. What this matches depends on
whether the buffer is a DOS (ASCII 13,10 or just ASCII 10),
UNIX (ASCII 10), Macintosh (ASCII 13), or user-defined ASCII
file. Use \d10 if you want to match an ASCII 10 character.

\r

Matches carriage return.

\t

Matches tab character.

\b

Matches at word boundary. For example, \bre matches all
occurrences of “re” that only occur at the beginning of a word.
Note that this notation previously matched a backspace
character. It can still be used to match a backspace character
by using it in a character set (for example, [\b]).

\B

Matches all except at word boundary. For example, \Bre
matches all occurrences of “re” as long as it is not at the start
of a new word.

\Q and \E

\Q matches all characters as literals until \E. This is useful for
longer sequences of characters without the need for the
escape character. \Q does not require termination with \E, as it
will continue to match characters literally until the end of the
search string. \E returns to using special character tokens for
matching.

\f

Matches form feed character.

\od

Matches any 2-byte DBCS character. This escape is only valid
in a match set ([...\od...]). [^\od] matches any single byte
character excluding end-of-line characters. When used to
search Unicode text, this escape does nothing.

\om

Turns on multi-line matching. This enhances the match
character set, or match any character primitives to support
matching end-of-line characters. For example, \om?# matches
the rest of the buffer. NOTE: Test the regular expression on a
very small file before using it on a large file. This option may
cause the editor to use a lot of memory.

\ol

Turns off multi-line matching (default). You can still use \n to
create regular expressions which match one or more lines.
However, expressions like ?# will not match multiple lines. This
is much safer and usually faster than using the \om option.

\oi

Ignore case. Turns off case-sensitive matching in the pattern,
overriding the global case setting. This modifier is localized
inside all ( ) and { } groups, after which case matching is
restored to the previous case match setting. See also \oc.

SlickEdit® User Guide

REGULAR EXPRESSIONS

SlickEdit Regular
Expression

Definition

\oc

Case-sensitive match. Turns on case-sensitive matching in the
pattern, overriding the global case setting. This modifier is
localized inside all ( ) and { } groups, after which case
matching is restored to the previous case match setting. See
also \oi.

\char

Declares character after slash to be literal. For example, \:
represents the colon character.

:char

Matches predefined expression corresponding to char. The
predefined expressions are:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

:a [A-Za-z0-9] - Matches an alphanumeric character.
:b ([ \t]#\) - Matches blanks - note that :b is not like the
Perl/.NET \s.
:c [A-Za-z] - Matches an alphabetic character.
:d [0-9] - Matches a digit.
:f ([~\[\]\:\\/<>|=+;, \t”’]#) - Windows: Matches a file
name part.
:f ([~/ \t”’]#) - UNIX: Matches a file name part.
:h ([0-9A-Fa-f]#) - Matches a hex number.
:i ([0-9]#) - Matches an integer.
:n (([0-9]#(.[0-9]#|)|.[0-9]#)([Ee](\+|-|)[0-9]#|)) Matches a floating number.
:p (([A-Za-z]\:|)(\\|/|)(:f(\\|/))@:f) - Windows: Matches a
path.
:p ((/|)(:f(/))@:f) - UNIX: Matches a path.
:q (\"[~\"]@\"|'[~']@') - Matches a quoted string.
:v ([A-Za-z_$][A-Za-z0-9_$]@) - Matches a C
variable.
:w ([A-Za-z]#) - Matches a word.

The precedence of operators, from highest to lowest, is as follows:
•
•
•

+, #, *, @, :, :* (These operators have the same precedence.)
concatenation
|

SlickEdit® Regular Expression Examples
The table below shows examples of SlickEdit regular expressions.
SlickEdit Regular
Expression Example

Description

^defproc

Matches lines that begin with the word defproc.

^definit$

Matches lines that only contain the word definit.

^\:name

Matches lines that begin with the string :name. Notice that the
backslash must prefix the colon character (:).
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[\t ]

Matches tab and space characters.

[\9\32]

Matches tab and space characters.

[\x9\x20]

Matches tab and space characters.

p?t

Matches any three-letter string starting with the letter p and
ending with the letter t. Two possible matches are pot and pat.

s?*t

Matches the letter s followed by any number of characters
followed by the nearest letter t. Two possible matches are seat
and st.

for|while

Matches the strings for or while.

^:p

Matches lines beginning with a file name.

xy+z

Matches x followed by one or more occurrences of y followed
by z.

\x0d\x0a\x01\x02

Matches a sequence of hex binary characters.

\13\10\1\2

Matches a sequence of decimal binary characters.

UNIX Regular Expressions
UNIX regular expressions are defined in the following table.
UNIX Regular Expression
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^

Matches beginning of line.

$

Matches end of line.

.

Matches any character except newline.

X+

Maximal match of one or more occurrences of X. See Minimal
versus Maximal Matching.

X*

Maximal match of zero or more occurrences of X.

X?

Maximal match of zero or one occurrences of X.

X{n1}

Match exactly n1 occurrences of X.

X{n1,}

Maximal match of at least n1 occurrences of X.

X{,n2}

Maximal match of at least zero occurrences but not more than
n2 occurrences of X.

X{n1,n2}

Maximal match of at least n1 occurrences but not more than
n2 occurrences of X.

X+?

Minimal match of one or more occurrences of X.

X*?

Minimal match of zero or more occurrences of X.
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X??

Minimal match of zero or one occurrences of X.

X{n1}?

Matches exactly n1 occurrences of X.

X{n1,}?

Minimal match of at least n1 occurrences of X.

X{,n2}?

Minimal match of at least zero occurrences but not more than
n2 occurrences of X.

X{n1,n2}?

Minimal match of at least n1 occurrences but not more than n2
occurrences of X.

(?!X)

Search fails if expression X is matched. The expression ^(?!if)
matches the beginning of all lines that do not start with if.

(?=X)

Assert, positive lookahead. Searches for subexpression X, but
X is not returned as part of the match. For example, to match
words ending in “ed” while excluding “ed” as part of the match,
use \b[a-z]+(?=ed\b). See also (?!X).

(?>X)

Prohibit backtracking. This expression is advanced usage. It
can be used to prevent the subexpression X from backtracking
when using maximal (greedy) matching.

(?#text)

Comment. No text is matched in this expression; it is used for
comment and documentation only.

(X)

Matches subexpression X and specifies a new tagged
expression (see Using Tagged Expressions). No more tagged
expressions are defined once an explicit tagged expression
number is specified as shown below.

(?dX)

Matches subexpression X and specifies to use tagged
expression number d where 0<=d<=9. No more tagged
expressions are defined by the subexpression syntax (X) once
this subexpression syntax is used. This is the best way to
make sure you have enough tagged expressions.

(?:X)

Matches subexpression X but does not define a tagged
expression.

X|Y

Matches X or Y.
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[char-set]

Matches any one of the characters specified by char-set. A
dash (-) character may be used to specify ranges. The
expression [A-Z] matches any uppercase letter. A backslash
(\) may be used inside the square brackets to define literal
characters or define ASCII characters. For example, \specifies a literal dash character. The expression [\d0-\d27]
matches ASCII character codes 0..27. The expression []]
matches a right bracket. In SlickEdit® regular expressions, []
matches no characters. In both syntaxes, the expression [\]]
matches a right bracket. The expression [^] matches a caret
(^) character but this does not work for SlickEdit regular
expressions. In both syntaxes, [\^] matches a caret (^)
character.

[^char-set]

Matches any character not specified by char-set. A dash (-)
character may be used to specify ranges.

[char-set1 - [char-set2]]

Character set subtraction. Matches all characters in char-set1
except the characters in char-set2. The expression [^A-Z]
matches all characters except uppercase letters. For example,
[a-z-[qw]] matches all English lowercase letters except q and
w. [\p{L}-[qw]] matches all Unicode lowercase letters except q
and w.

[char-set1 & [char-set2]

Character set intersection. Matches all characters in char-set1
that are also in char-set2. For example, [\x{0}-\x{7f}&[\p{L}]]
matches all letters between 0 and 127.

\x{hhhh}

Matches up to 31-bit Unicode hexadecimal character specified
by hhhh.

\p{UnicodeCategorySpec]

(Only valid in character set) Matches characters in
UnicodeCategorySpec. Where UnicodeCategorySpec uses
the standard general categories specified by the Unicode
consortium. For example, [\p{L}] matches all letters. [\p{Lu}]
matches all uppercase letters. See Unicode Category
Specifications for Regular Expressions.

\P{UnicodeCategorySpec]

(Only valid in character set) Matches characters not in
UnicodeCategorySpec. For example, [\P{L}] matches all
characters that are not letters. This is equivalent to [^\p{L}].
[\P{Lu}] matches all characters that are not uppercase letters.
See Unicode Category Specifications for Regular Expressions.

\p{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters in
UnicodeIsBlockSpec. Where UnicodeIsBlockSpec one of
the standard character blocks specified by the Unicode
consortium. For example, [\p{isGreek}] matches Unicode
characters in the Greek block. See Unicode Character Blocks
for Regular Expressions.
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\P{UnicodeIsBlockSpec]

(Only valid in character set) Matches characters not in
UnicodeIsBlockSpec. For example, [\P{isGreek}] matches
all characters that are not in the Unicode Greek block. This is
equivalent to [^\p{isGreek}]. See Unicode Character Blocks
for Regular Expressions.

\xhh

Matches hexadecimal character hh where 0<=hh<=0xff.

\dddd

Matches decimal character ddd where 0<=ddd<=255.

\d

Defines a back reference to tagged expression number d. For
example, {abc}def\0 matches the string abcdefabc. If the
tagged expression has not been set, the search fails.

\c

Specifies cursor position if match is found. If the expression
xyz\c is found the cursor is placed after the z.

\n

Matches newline character sequence. Useful for matching
multi-line search strings. What this matches depends on
whether the buffer is a DOS (ASCII 13,10 or just ASCII 10),
UNIX (ASCII 10), Macintosh (ASCII 13), or user-defined ASCII
file. Use \d10 if you want to match an ASCII 10 character.

\r

Matches carriage return (ASCII 13). What this matches
depends on whether the buffer is a DOS (ASCII 13,10 or just
ASCII 10), UNIX (ASCII 10), Macintosh (ASCII 13), or user
defined ASCII file.

\t

Matches tab character.

\b

Matches at word boundary. For example, \bre matches all
occurrences of “re” that only occur at the beginning of a word.

\B

Matches all except at word boundary. For example, \Bre
matches all occurrences of “re” as long as it is not at the start
of a new word.

\Q and \E

\Q matches all characters as literals until \E. This is useful for
longer sequences of characters without the need for the
escape character. \Q does not require termination with \E, as it
will continue to match characters literally until the end of the
search string. \E returns to using special character tokens for
matching.

\f

Matches form feed character.

\od

Matches any 2-byte DBCS character. This escape is only valid
in a match set ([...\od...]). [^\od] matches any single byte
character excluding end-of-line characters. When used to
search Unicode text, this escape does nothing.

\om

Turns on multi-line matching. This enhances the match
character set, or match any character primitives to support
matching end-of-line characters. For example, \om.+ matches
the rest of the buffer.
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\ol

Turns off multi-line matching (default). You can still use \n to
create regular expressions which match one or more lines.
However, expressions like .+ will not match multiple lines. This
is much safer and usually faster than using the \om option.

\oi

Ignore case. Turns off case-sensitive matching in the pattern,
overriding the global case setting. This modifier is localized
inside the current grouping level, after which case matching is
restored to the previous case match setting. See also \oc.

\oc

Case-sensitive match. Turns on case-sensitive matching in the
pattern, overriding the global case setting. This modifier is
localized inside the current grouping level, after which case
matching is restored to the previous case match setting. See
also \oi.

\char

Declares character after slash to be literal. For example, \*
represents the star character.

\:char

Matches predefined expression corresponding to char. The
pre-defined expressions are:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

\:a [A-Za-z0-9] - Matches an alphanumeric character.
\:c [A-Za-z] - Matches an alphabetic character.
\:b (?:[ \t]+) - Matches blanks.
\:d [0-9] - Matches a digit.
\:f (?:[^\[\]\:\\/<>|=+;, \t”’]+) - Windows: Matches a file
name part.
\:f (?:[^/ \t”’]+) - UNIX: Matches a file name part.
\:h (?:[0-9A-Fa-f]+) - Matches a hex number.
\:i (?:[0-9]+) - Matches an integer.
\:n (?:(?:[0-9]+(?:\.[0-9]+|)|\.[0-9]+)(?:[Ee](?:\+|-|)[09]+|)) - Matches a floating number.
\:p (?:(?:[A-Za-z]:|)(?:\\|/|)(?:\:f(?:\\|/))*\:f) - Windows:
Matches a path.
\:p (?:(?:/|)?:(?::f(/))*\:f) - UNIX: Matches a path.
\:q (?:\"[^\"]*\"|'[^']*') - Matches a quoted string.
\:v (?:[A-Za-z_$][A-Za-z0-9_$]*) - Matches a C
variable.
\:w (?:[A-Za-z]+) - Matches a word.

The precedence of operators, from highest to lowest, is as follows:
•
•
•
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+, *, ?, {}, +?, *?, ??, {}? (These operators have the same precedence.)
concatenation
|
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UNIX Regular Expression Examples
The table below shows examples of UNIX regular expressions.
UNIX Regular Expression
Example

Description

^defproc

Matches lines that begin with the word defproc.

^definit$

Matches lines that only contain the word definit.

^\*name

Matches lines that begin with the string *name. Notice that the
backslash must prefix the special character *.

[\t ]

Matches tab and space characters.

[\d9\d32]

Matches tab and space characters.

[\x9\x20]

Matches tab and space characters.

p.t

Matches any three-letter string starting with the letter p and
ending with the letter t. Two possible matches are pot and pat.

s.*?t

Matches the letter s followed by any number of characters
followed by the nearest letter t. Two possible matches are seat
and st.

for|while

Matches the strings for or while.

^\:p

Matches lines beginning with a file name.

xy+z

Matches x followed by one or more occurrences of y followed
by z.

[a-z-[qw]]

Character set subtraction. Matches all English lowercase
letters except q and w.

[\p{isGreek}&[\p{L}]]

Character set intersection. Matches all Unicode letters in the
Greek block.

\x{6587}

Matches Unicode character with hexadecimal value 6587.
Character set intersection. Matches all Unicode letters in the
Greek block.

[\p{L}-[qw]]

Matches all Unicode letters except q and w.

[\p{L}]

Matches all Unicode letters.

[\p{Lul}]

Matches all Unicode uppercase and lowercase letters.

[\P{L}]

Matches all Unicode characters that are not letters.

[\p{isGreek}]

Matches all Unicode characters in the Greek block.

\x0d\x0a\x01\x02

Matches a sequence of hex binary characters.

\d13\d10\d1\d2

Matches a sequence of decimal binary characters.
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Wildcard Expressions
SlickEdit® supports *, ?, and # wildcards:
•

The asterisk (*) matches zero or more characters. For example, search for a*b to find any string
that contains a lowercase letter “a” followed by a lowercase letter “b” allowing for text in between.

•

The question mark (?) matches any single character. Use multiple question marks in succession to
represent that number of characters. For example, search for a???b to find any string that
contains a lowercase letter "a" followed by any three characters, followed by a lowercase letter “b”.

•

The pound sign (#) matches any single digit, 0-9. Use multiple pound signs in succession to
represent that number of digits. For example, use ##:## to search for four-digit time-of-day values.

Unicode Categories and Character Blocks
Unicode Category Specifications for Regular Expressions
The Unicode consortium standard regular expression categories are supported. The syntax for specifying
categories is:
\p{MainCategoryLetter Subcategories}
The above syntax matches the categories specified. The following syntax matches all characters not in the
categories specified:
\P{MainCategoryLetter Subcategories}
The \p and \P notations can only be used inside a character set specification. MainCategoryLetter can be
L, M, N, P, S, Z, or C. The valid Subcategories depend on the MainCategoryLetter specified. If no
Subcategories are specified, all are assumed. For example:
•
•
•

[\p{L}] matches all Unicode letters.
[\p{Lul}] matches all uppercase and lowercase letters.
[\P{L}] matches all characters that are not letters.

The following table lists the valid subcategories for a specific main category. These character tables were
generated using the file UnicodeData-3.1.0.txt found on the Unicode Consortium Web site
(http://unicode.org).
Subcategory
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Description

Lu

Letter, Uppercase

Ll

Letter, Lowercase

Lt

Letter, Titlecase

Lo

Letter, Other

Mn

Mark, Non-Spacing

Mc

Mark, Spacing Combining

Me

Mark, Enclosing

Nd

Number, Decimal Digit

Nl

Number, Letter
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Subcategory

Description

No

Number, Other

Pc

Punctuation, Connector

Pd

Punctuation, Dash

Ps

Punctuation, Open

Pe

Punctuation, Close

Pi

Punctuation, Initial quote (may behave like Ps or Pe
depending on usage)

Pf

Punctuation, Final quote (may behave like Ps or Pe depending
on usage)

Po

Punctuation, Other

Sm

Symbol, Math

Sc

Symbol, Currency

Sk

Symbol, Modifier

So

Symbol, Other

Zs

Separator, Space

Zl

Separator, Line

Zp

Separator, Paragraph

Cc

Other, Control

Cf

Other, Format

Cs

Other, Surrogate

Co

Other, Private Use

Cn

Other, Not Assigned (no characters in the file have this
property)

Unicode Character Blocks for Regular Expressions
The Unicode consortium standard regular expression block categories are supported. The syntax for
specifying a character block is:
\p{IsBlockName}
The above syntax matches the characters in the block specified. The following syntax matches all
characters not in the block specified:
\P{IsBlockName}
The \p and \P notations may only be used inside a character set specification. For example,
[\p{isBasicLatin}] matches all characters in the Greek block. [\P{isBasicLatin}] matches all characters
that are not in the Greek block.
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The following table lists the non-standard valid character block names. These character tables were
generated from XML standards found at the World Wide Web Consortium Web site (http://www.w3c.org).
Block Name

Description

XMLNameStartChar

All characters that are valid for the start of an XML tag name.

XMLNameChar

All characters that are valid in an XML tag name.

The following table lists the valid character block names. These character tables were generated using the
blocks.txt file found on the Unicode Consortium Web site (http://unicode.org).
Range
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Block Name

0000..007F

BasicLatin

0080..00FF

Latin-1Supplement

0100..017F

LatinExtended-A

0180..024F

LatinExtended-B

0250..02AF

IPAExtensions

02B0..02FF

SpacingModifierLetters

0300..036F

CombiningDiacriticalMarks

0370..03FF

Greek

0400..04FF

Cyrillic

0530..058F

Armenian

0590..05FF

Hebrew

0600..06FF

Arabic

0700..074F

Syriac

0780..07BF

Thaana

0900..097F

Devanagari

0980..09FF

Bengali

0A00..0A7F

Gurmukhi

0A80..0AFF

Gujarati

0B00..0B7F

Oriya

0B80..0BFF

Tamil

0C00..0C7F

Telugu

0C80..0CFF

Kannada

0D00..0D7F

Malayalam
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Range

Block Name

0D80..0DFF

Sinhala

0E00..0E7F

Thai

0E80..0EFF

Lao

0F00..0FFF

Tibetan

1000..109F

Myanmar

10A0..10FF

Georgian

1100..11FF

HangulJamo

1200..137F

Ethiopic

13A0..13FF

Cherokee

1400..167F

UnifiedCanadianAboriginalSyllabics

1680..169F

Ogham

16A0..16FF

Runic

1780..17FF

Khmer

1800..18AF

Mongolian

1E00..1EFF

LatinExtendedAdditional

1F00..1FFF

GreekExtended

2000..206F

GeneralPunctuation

2070..209F

SuperscriptsandSubscripts

20A0..20CF

CurrencySymbols

20D0..20FF

CombiningMarksforSymbols

2100..214F

LetterlikeSymbols

2150..218F

NumberForms

2190..21FF

Arrows

2200..22FF

MathematicalOperators

2300..23FF

MiscellaneousTechnical

2400..243F

ControlPictures

2440..245F

OpticalCharacterRecognition

2460..24FF

EnclosedAlphanumerics

2500..257F

BoxDrawing

2580..259F

BlockElements

25A0..25FF

GeometricShapes
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Range
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Block Name

2600..26FF

MiscellaneousSymbols

2700..27BF

Dingbats

2800..28FF

BraillePatterns

2E80..2EFF

CJKRadicalsSupplement

2F00..2FDF

KangxiRadicals

2FF0..2FFF

IdeographicDescriptionCharacters

3000..303F

CJKSymbolsandPunctuation

3040..309F

Hiragana

30A0..30FF

Katakana

3100..312F

Bopomofo

3130..318F

HangulCompatibilityJamo

3190..319F

Kanbun

31A0..31BF

BopomofoExtended

3200..32FF

EnclosedCJKLettersandMonths

3300..33FF

CJKCompatibility

3400..4DB5

CJKUnifiedIdeographsExtensionA

4E00..9FFF

CJKUnifiedIdeographs

A000..A48F

YiSyllables

A490..A4CF

YiRadicals

AC00..D7A3

HangulSyllables

D800..DB7F

HighSurrogates

DB80..DBFF

HighPrivateUseSurrogates

DC00..DFFF

LowSurrogates

E000..F8FF

PrivateUse

F900..FAFF

CJKCompatibilityIdeographs

FB00..FB4F

AlphabeticPresentationForms

FB50..FDFF

ArabicPresentationForms-A

FE20..FE2F

CombiningHalfMarks

FE30..FE4F

CJKCompatibilityForms

FE50..FE6F

SmallFormVariants

FE70..FEFE

ArabicPresentationForms-B
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Range

Block Name

FEFF..FEFF

Specials

FF00..FFEF

HalfwidthandFullwidthForms

FFF0..FFFD

Specials

10300..1032F

OldItalic

10330..1034F

Gothic

10400..1044F

Deseret

1D000..1D0FF

ByzantineMusicalSymbols

1D100..1D1FF

MusicalSymbols

1D400..1D7FF

MathematicalAlphanumericSymbols

20000..2A6D6

CJKUnifiedIdeographsExtensionB

2F800..2FA1F

CJKCompatibilityIdeographsSupplement

E0000..E007F

Tags
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Using the Calculator and Math Commands
The Calculator
To access the calculator, click Tools > Calculator, or use the calculator command.

You can use the calculator in various ways. Type in mathematical expressions from the keyboard or by
clicking buttons, including parentheses. Almost all the editing keys including undo, next word, and previous
word are supported. The calculator uses a slightly enhanced C expression syntax. The calculator supports
specifying binary numbers and allows just an x prefix when specifying hexadecimal numbers.
For example, to add the decimal numbers 135 and 288, type 135+288=. Press the = character to evaluate
the expression and place the result on the next line. To see the result in a different base, click Hex, Dec,
Oct, or Bin.

Calculating Expressions with Mixed Bases
To add hex FF with octal 77 with binary 111 with decimal 99, complete the following steps:
1. Click Hex then type or click FF.
2. Click +.
3. Click Octal, and type or click 77.
4. Click +.
5. Click Bin, and type or click 111.
6. Click +.
7. Click Dec, and type or click 99.
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8. Select the output base by clicking one of the base buttons and type or click = to compute the
result.

Math Commands
Evaluate mathematical expressions by selecting expressions in a buffer and executing the add command
or by executing one of the math commands on the command line followed by an expression.
These commands support the same expression input. The syntax of the math command is:
math expression
The math command evaluates the Slick-C® language expression given and places the results in the
message line. You can specify octal numbers by prefixing the number with a zero and specify binary
numbers by prefixing the number with the character b. If no operator is specified between two unary
expressions, addition is assumed. The characters $ and comma (,) are stripped from the expression before
it is evaluated. The mathx, matho, and mathb commands evaluate the Slick-C language expression given
and places the result in the message line in hexadecimal, octal, and binary respectively. The expression
can have the following unary operators:
•

~ bitwise complement

•

- negation

•

+ no change

The available binary operators are listed below, from lowest to highest precedence. A comma after the
operator indicates that the next operator is of the same precedence.
Operator

Meaning

&, |

bitwise AND, bitwise OR

^

xor

+, blank(s), -

addition, implied addition, subtraction

*, /, %

multiplication, division, remainder

**

power

Hexadecimal numbers are prefixed with the characters 0x or just x. Octal numbers are prefixed with the
character O or digit 0.
NOTE Not all Slick-C language operators are supported.

Math Command Examples
The following table shows some examples of math commands:
Example
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Description

math 2.5*2

Multiplies 2.5 times 2

math 5/2

Divides 5 by 2

mathx 255

Converts 255 to hexadecimal
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math xFF

Converts hexadecimal FF to decimal

math o77

Converts octal 77 to decimal

matho 255

Converts 255 to octal

math 077+0xff+10

Adds octal 77, hex FF, and 10

Overflow/Underflow
If overflow or underflow occurs, the message Numeric overflow or underflow is displayed on the message
line. Floating point numbers may have up to a 32-digit mantissa and a 9-digit exponent.

Document Math
Type mathematical expressions into a buffer and evaluate them with the add command. This feature is
called document math. The add command adds selected text and inserts the result below the last line of
the selection. If no operator exists between two adjacent numbers on the same line, addition is assumed.
The result of each adjacent line is added.

Prime Numbers
Prime numbers are often useful for sizing hash tables. The isprime command (used from the command
line) takes a decimal number as an argument and tells you if it is prime, and if not, its first divisor. The
nextprime command takes a decimal number as an argument and finds the next greater prime number.
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OS File Browser
SlickEdit® provides a way to display the operating system’s (OS) file manager/browser. For example,
Windows Explorer is displayed on Windows, Finder on Mac OS X, Konquerer on Linux KDE desktop, etc.
To display the OS file browser, click Tools > OS File Browser, or use the explore or finder command (the
finder command is the same as the explore command).
If you are editing a document, the file manager will be rooted in that file's directory, otherwise it will default
to the current working directory. Using the - option after the command (for example, explore -) will ignore
any file directory or working directory and go to the system root.
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Macros and Macro Programming
This chapter contains the following topics:
•
•

Recorded Macros
Programmable Macros
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Macros and Macro Programming
There are two types of macros in SlickEdit®:
•

Recorded Macros - A recorded macro is a series of SlickEdit operations that you can save and run
as one operation any time. Recorded macros are useful for automating repetitive tasks. Because
recording a macro generates Slick-C® code for the action being recorded, recorded macros
provide a good starting point for learning the Slick-C macro programming language.

•

Programmable Macros - Slick-C lets you take editor customization to the next level. With Slick-C,
you have more control over the editor and can even add new functionality. “Programmable
macros” is a term we use to describe Slick-C modules, Slick-C batch macros, and Slick-C
variables. In other words, Slick-C code that you write yourself.

Recorded Macros
You can automate repetitive tasks by recording a series of SlickEdit® operations in a macro. After you
create a macro, you can run it, save it, bind it to a key sequence, and/or modify the macro’s source code.
Recording a macro generates Slick-C® code for performing the action being recorded. Therefore,
recording a macro is also a useful way to discover and implement Slick-C code that controls the behavior
of SlickEdit.
Topics in this section are:
•
•
•
•
•
•
•

Common Macro Operations
Recording a Macro
Binding Recorded Macros to Keys
Running a Recorded Macro
Saving and Editing Recorded Macros
Deleting Recorded Macros
Using Macros to Discover and Control Options

Common Macro Operations
Macros can be recorded, executed, and saved from the Macro menu, or you can use commands or
predefined key bindings to perform macro operations:
•

To start or end macro recording, from the main menu, click Macro > Record Macro or Macro >
Stop Recording Macro, respectively. Alternately, you can toggle recording on and off with one of
the following methods:
o

Click the recording indicator REC, located along the bottom edge of the editor. When a macro
is being recorded, the recording indicator is active (not dimmed).

o

In CUA emulation, press Ctrl+F11 (the key binding associated with the record_macro_toggle
command).

o

On the SlickEdit command line, type record_macro_toggle.

See Recording a Macro for more information.
•

To run the last macro that you recorded, click Macro > Execute last-macro, press Ctrl+F12, or
use the record_macro_end_execute command. See Running a Recorded Macro for more
information.
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•

To display a list of your recorded macros, from which you can edit, run, delete, or bind to a key
sequence, click Macro > List Macros, or use the list_macros command.

NOTE List Macros only shows your “saved” macros, not your last recorded macro or macros created
using execute_last_macro_key.

Recording a Macro
To record a macro, simply start the recording, enter the keystrokes you want to record, then end the
recording. The instructions below outline the steps.
1. From the main menu, click Macro > Record Macro (or use one of the toggle methods to start
recording, as described under Common Macro Operations above).
2. Enter the keystrokes that you want to record. For example, to record a macro of the cursor moving
three spaces to the right, press the right arrow key three times. You can also change a
configuration option, view settings, or expand a code template during macro recording.
3. When you have finished recording the macro, end recording by clicking Macro > Stop Recording
Macro (or the same toggle you used in Step 1). The Save Macro Dialog is displayed.
TIPS
•

For recorded macros you don’t need to track, perhaps for immediate or one-time use,
SlickEdit provides a way to stop macro recording and instantly bind the macro to a key
sequence. This allows you to keep a set of recent, unnamed macro recordings instead of
having just one “last recorded macro”. See Binding Macros Using execute_last_macro_key
for more information.

•

If you’re recording the macro to discover Slick-C® code (see Using Macros to Discover and
Control Options), click Edit (or press Alt+E) at this time to view the source code. If you
choose to view/edit the source code now, you will need to save it by using Macro > Save
last-macro prior to recording a new macro or exiting the editor. See Saving and Editing
Recorded Macros for more details.

4. Specify the name for the macro in the Macro Name text box.
5. Select any desired options. Leave the default settings if you aren’t sure what to select. See Save
Macro Dialog for more information on these advanced options.
6. If you plan to use the macro frequently, we recommend creating a key binding for it. To create the
key binding, click Save and Bind to Key, then see Binding Recorded Macros to Keys for more
information.
Alternately, click Save. The List Macros Dialog is displayed, from which you can run the macro,
edit the source, delete it, or bind it to a key sequence.

Binding Recorded Macros to Keys
To use recorded macros most effectively, create key bindings for them so they can be executed quickly
when you want to use them. Macros can be bound through the Key Bindings option screen (see Binding
Macros Using the Key Bindings Option Screen), or by using the instant “stop recording and bind” method
associated with the execute_last_macro_key command (see Binding Macros Using
execute_last_macro_key).
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Binding Macros Using the Key Bindings Option Screen
To create a key binding for a recorded macro, you can either click the Save and Bind to Key button on the
Save Macro dialog that appears automatically after you end recording, or at any time you can use the Bind
to Key button on the List Macros Dialog (Macro > List Macros or list_macros command). Clicking either
button displays the Key Bindings option screen with the macro selected, so you can add a key binding.
NOTE You can also display the Key Bindings option screen by clicking Tools > Options >
Keyboard > Key Bindings, or by using the gui_keybindings command. However, if you display
the screen in this manner, it will show a list of all commands and user-recorded macros. To view your
recorded macros, click on the Recorded column header to sort and display items with a “Yes” (which
indicates these are recorded macros). A more convenient method is to use the Bind to Key button
on the List Macros dialog to only show recorded macros on the Key Bindings option screen.
Creating bindings for recorded macros works the same as creating bindings for SlickEdit commands. Click
Add to initiate the binding, then specify the key sequence or mouse event to use. See Managing Bindings
for more information about creating, editing, and removing bindings.

Binding Macros Using execute_last_macro_key
The execute_last_macro_key command provides functionality to stop macro recording and instantly bind
the macro to a key sequence. This feature is convenient for recorded macros you want to use perhaps
immediately or one-time only, and don’t need to track. It allows you to keep a set of recent, unnamed
macro recordings instead of having just one “last recorded macro”, similar to a feature provided by early
text editors that supported macro recording, such as the EVE and Edt editors on the Vax (VMS).
Unlike other SlickEdit commands that we document, execute_last_macro_key is not intended to be used
on the command line—instead, you use a key binding that is automatically assigned when you press it to
stop macro recording.
To bind a macro to a key sequence using this method, start recording the macro and enter the keystrokes
you want to record. Then press Ctrl+Shift+F12,key where key stands for keys 0 through 9, A-Z, or F1F12, to stop recording the macro and instantly bind it to the key sequence you just pressed.
NOTE The prefix key sequence Ctrl+Shift+F12 works in all emulations except SlickEdit text mode
edition. In that emulation, the prefix key sequence is Ctrl+Shift+T.
Each macro that you record and bind using this feature is saved to a new file named lastmac<key>.e,
located in your configuration directory, where <key> matches the key you used when creating the binding
(keys 0-9, A-Z, or F1-F12). These files can be helpful for determining what was recorded, because if you
use this method to bind a recorded macro, you will not have an opportunity to name the macro or see a list
of macros created with this method (they will not appear in the List Macros dialog or Key Bindings option
screen).

Running a Recorded Macro
If you have saved the macro and created a key binding for it, the easiest way to run it is to simply press the
associated key sequence. You can also run it by:
•

Typing the name of the macro in the SlickEdit® command line then pressing Enter.

•

Using the List Macros Dialog (Macro > List Macros or list_macros command)—select the macro
and click Run.

You can run the last macro that you recorded, whether it was saved or not, by clicking Macro > Execute
last-macro (Ctrl+F12 or execute_last_macro command).
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Saving and Editing Recorded Macros
When a recorded macro is saved, the source code of the macro is appended to the vusrmacs.e user
macros file located in your configuration directory.
To edit a macro that has previously been recorded and saved, from the main menu, click Macro > List
Macros (or use the list_macros command) to display the List Macros Dialog. The list box on the left
displays a list of your recorded macros. Select the macro you want to edit, then click Edit. The vusrmacs.e
file opens in the editor. Save the file when you’re done making edits.
If you are using recorded macros to discover Slick-C® code (see Using Macros to Discover and Control
Options), you can view/edit the source of a macro that you have just recorded but have not yet saved. After
creating a new recorded macro, you are prompted with the Save Macro Dialog. Instead of naming the
macro and saving it, click Edit (or press Alt+E) to view the source. A new editor window named
lastmac.e, which is the name of the file that contains the source of the last macro that was recorded, is
opened showing the macro’s source code. If you make edits, you will need to save the changes by clicking
Macros > Save last-macro. The Save Macro dialog is displayed again so you can name the macro and
then click Save, which appends the new code to the user macros file (vusrmacs.e). Or click Save and
Bind to Key to save and create a key binding for the macro (see Binding Macros Using the Key Bindings
Option Screen).
Each macro recorded and bound using execute_last_macro_key is saved in a file named
lastmac<key>.e, and the corresponding compiled byte code is saved in lastmac<key>.ex, where <key>
matches the key you used when creating the binding (keys 0-9, A-Z, or F1-F12). Both files are located in
your configuration directory. To edit a macro bound using this method, open the .e file for the macro you
want to edit, make and save the changes, then from the main menu, click Macro > Load Module (F12 or
gui_load command). Find and select the .e file you just edited and click Open. The message Module(s)
loaded appears on the message line, and SlickEdit will now honor the changes you made to the .e file
when you use the corresponding key sequence.

Deleting Recorded Macros
To delete a macro that has been recorded and saved, from the main menu, click Macro > List Macros (or
use the list_macros command). Select the macro you want to delete, and click Delete.
To delete a macro that you recorded and bound to a key sequence using execute_last_macro_key,
browse to your configuration directory and delete lastmac<key>.e and its corresponding
lastmac<key>.ex file, where <key> matches the key you used when creating the binding (keys 0-9, A-Z,
or F1-F12).

Using Macros to Discover and Control Options
Recording macros provides a good starting point for discovering variables in Slick-C® code that control the
behavior of SlickEdit®.
Since responses to dialog boxes (such as when you select/clear options) are recorded as Slick-C source,
you can use recorded macros to discover and change these variables quickly. For example, perhaps you
frequently switch line insert styles. The Line insert style option is located on the General Editing options
page. Instead of every time clicking Tools > Options > Editing > General, then selecting the option, you
can record those steps as a macro and bind it to a key sequence. Now you have an easy way to toggle a
feature on and off.
You can also view the source of a recorded macro without naming or saving it, if you just want to see the
code. See Saving and Editing Recorded Macros for more information.
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Programmable Macros
The Slick-C® macro programming language is behind most of the actions performed in SlickEdit®. Slick-C
functions are mapped to menus, buttons, and keys, and perform the action behind an event. You can use
Slick-C to extend the editor’s functionality. With Slick-C, you can manipulate buffers; parse strings;
navigate buffers and source code; and create and modify menus, dialogs, toolbars, and tool windows.
For documentation purposes, “programmable macros” is a term used to encompass Slick-C modules,
variables, and batch macros. These items are described in detail below.
This section contains the following topics:
•
•
•
•
•

Slick-C® Modules
Slick-C® Variables (Config Variables)
Slick-C® Batch Macros
State File
Slick-C® Header Files and More Resources

Slick-C® Modules
A Slick-C module is a file with the extension .e that contains Slick-C code. Slick-C modules are the most
typical use of Slick-C, used to define functionality that you want to keep loaded, such as user-defined
commands. You must compile and load a Slick-C module into the State File before it can be utilized. When
a module is compiled, the Slick-C translator converts the file into byte code, which is saved in a
corresponding file with the extension .ex. To compile and load the module, use the menu item Macro >
Load Module. See Loading and Unloading Slick-C® Modules for more information.
TIP Slick-C modules and header files that are included with SlickEdit are located in the slickedit/
macros subdirectory. You can store the macros you write in any directory you like.

Loading and Unloading Slick-C® Modules
To compile and load a Slick-C module into the State File, from the main menu, click Macro > Load
Module. You can also press F12 or use the gui_load command on the SlickEdit® command line. The
Open dialog is displayed, prompting you for the file to load.
NOTE The type of Open dialog that is displayed depends on whether the option Windows 3.1 style
open dialog is set to True or False (Tools > Options > Appearance > Advanced). See Opening
Files for more information.
To unload a Slick-C module from the State File, from the main menu, click Macro > Unload Module, or
use the gui_unload command.
CAUTION
•

Use caution when unloading modules that are shipped with SlickEdit (standard SlickEdit
modules). Unloading a standard module could cause the editor to behave unpredictably.

•

Standard modules are identified by file name. If you load a module with a name that matches
a standard SlickEdit module, it will replace the standard module, which (like unloading a
standard module), could potentially cause problems.
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Slick-C® Variables (Config Variables)
Slick-C variables are global variables that are persistently stored in the State File. Because these typically
contain user configuration settings, Slick-C variables are also called “configuration variables”. Config
variables start with the prefix def_. See Configuration Variables for more information.

Slick-C® Batch Macros
A Slick-C batch macro is a .e file that contains a defmain() function. This file cannot be loaded—you must
compile and run it from the SlickEdit® command line. Slick-C batch macros are useful for infrequent tasks
that do not involve a persistant state. They are different from recorded macros in that they usually perform
specific tasks and cannot be bound to a key. An example of a Slick-C batch macro is a file called
autotag.e. This batch macro launches the Create Tag Files for Run-Time Libraries dialog that appears
when you run SlickEdit for the first time. See Creating Tag Files for Run-Time Libraries for more
information.

State File
SlickEdit® ships with a system state file that contains default settings. The system state file is only
changed or updated when you upgrade. As you make changes to the configuration of the editor or apply
customizations, the changes are saved to a user state file, which is a copy of the system state file with user
customizations.
The user state file is located in your User Configuration Directory. On Windows, the state file is named
vslick.sta, and on UNIX, vslick.stu. The file extensions were made different to avoid any confusion
between the two, since a Windows state file is not compatible with UNIX, and vice versa.
The state file is a binary file that stores the following information:
•
•
•
•

Loadable Slick-C® Modules.
Slick-C settings such as global options, language-specific options, etc.
Slick-C resources such as event tables, dialogs, toolbars, tool windows, menus, bitmaps, and
icons.
DLL-exported function linkage.

The state file does not include DLLs themselves or Slick-C® Batch Macros.

Slick-C® Header Files and More Resources
Slick-C header files use the .sh extension. All Slick-C source files #include slick.sh.
To learn more about Slick-C functions, from the main menu, click Help > Macro Functions by Category.
This will display the Help dialog, with a list of all macro functions organized into categories.
For information about writing Slick-C, see the Slick-C Macro Programming Guide, which is included in the
SlickEdit® Help system and also available as a stand-alone PDF in the docs installation subdirectory.
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Menus, Dialogs, and Tool Windows
This chapter contains the following topics:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

File
Edit
Search
View
Project
Build
Debug
Document
Macro
Tools
Options
Window
Help
Menu Editing
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File
This section describes items on the File menu and associated dialogs and tool windows. See the chapter
Workspaces, Projects, and Files for more details about file operations.

File Menu
The table below describes items on the File menu.
File Menu Item

Description

Command

New

Displays the New dialog, which allows
you to create an empty file to edit.
This dialog also lets you create new
projects and workspaces. See New
Dialog.

new

New Item from Template

Displays the Add New Item dialog,
which allows you to create a new file
from a template. See Code
Templates.

add_item

Open

Displays the Open dialog, which
allows you to open a file for editing.
See Standard Open Dialog and
Windows 3.1-Style Open Dialog.

gui_open

Open URL

Displays the Open URL dialog,
allowing you to open an HTTP file.
See Open URL Dialog.

open_url

Close

Closes the current file.

quit

Close All

Closes all files.

close_all

Save

Saves the current file.

save

Save As

Displays the Save As dialog, which
allows you to save the current file
under a different name. See Save As
Dialog.

gui_save_as

Save All

Saves all modified files.

save_all

Revert

Revert current file to version on disk.

revert

Change Directory

Displays the Change Directory dialog,
which lets you change the current
working directory. See Change
Directory Dialog.

gui_cd

Backup History for

Displays the Backup History tool
window, where previous versions are
listed. Diffs can be run from here. See
Backup History.

activate_deltasave
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File Menu Item

Description

Command

FTP

Displays menu of FTP commands.
See File FTP Menu.

N/A

Print

Displays the Print dialog (or Text
Mode Print dialog for Mac/Linux/
UNIX), which contains options to print
the current file or selection and
provides setup options. See Print
Dialog for Windows and Print Dialog
for Mac, Linux, and UNIX.

gui_print

Insert a File

Displays the Insert File dialog, which
lets you insert a selected file at the
cursor location. See Inserting Files.

gui_insert_file

Write Selection

Displays the Write Selection dialog,
which lets you write or append
selected text to a file you choose. See
Using Write Selection.

gui_write_selection

Template Manager

Create, edit, and delete your
templates. See Code Templates.

template_manager

Export to HTML

Write file to HTML format.

export_html

File Manager

Displays menu of file manager
commands. See File Manager Menu.

N/A

Exit

Prompts you to save files if necessary
and exits the editor. See Exiting the
Program.

safe_exit

File FTP Menu
The File > FTP menu is available for performing FTP operations and changing FTP options. See FTP for
more information about working with these features.
FTP Menu Item

504

Description

Command

Start New Connection

Activates FTP tool window and starts
a new connection.

ftpOpen 1

Activate FTP

Activates FTP tool window.

activate_ftp

Upload

Uploads the current FTP file.

ftpUpload

Client

Activates FTP Client toolbar.

ftpClient

Profile Manager

Display FTP Profile Manager dialog
box. See Add/Edit FTP Profile Dialog.

ftpProfileManager

Options

Displays the default FTP options. See
FTP Default Options.

show _ftpOptions_form
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File Manager Menu
The File > File Manager menu contains options for working with the SlickEdit® File Manager, which offers
a rich set of file listing, selecting, and operating capabilities. See The SlickEdit® File Manager for detailed
information about this feature.
File Manager Menu Item

Description

Command

New File List

Displays a directory of files you
choose.

fileman

Append Files

Appends files to current list.

fileman append

Sort

Sorts file list.

fsort

Backup

Copies selected files and preserves
directory structure.

fileman_backup

Copy

Copies selected files to a directory
you choose.

fileman_copy

Move

Moves selected files to a directory you
choose.

fileman_move

Delete

Delete selected files.

fileman_delete

Edit

Edits selected files.

fileman_edit

Select

Displays menu of file manager select
commands. See File Manager Select
Menu.

N/A

Files

Displays menu of file manager listing
commands. See File Manager Files
Menu.

N/A

Attribute

Sets the Read Only, Hidden, System,
and Archive attributes of the selected
files.

fileman_attr

Repeat Command

Runs internal or external command
on selected files.

for_select

Global Replace

Performs search and replace on
selected files.

fileman_replace

Global Find

Performs search on selected files.

fileman_find

File Manager Select Menu
The File > File Manager > Select menu contains File Manager selection operations.
File Manager Select
Menu Item

Description

Command

All

Selects all files.

fileman_select_all

Deselect All

Deselects all files.

deselect_all
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File Manager Select
Menu Item

Description

Command

Invert Select

Selects files which are not selected
and deselects files which are
selected.

select_reverse

Attribute

Selects files based on file attribute.

select_attr

Extension

Selects files based on file extension.

gui_select_ext

Highlight

Selects files which are highlighted.

select_mark

Deselect Highlight

Deselects files which are highlighted.

deselect_mark

File Manager Files Menu
The File > File Manager > Files menu contains operations for working with files in the File Manager. Note
that commands in this menu do NOT delete files on disk.
File Manager Files
Menu Item

Description

Command

Unlist All

Removes all files from the list.

unlist_all

Unlist Select

Removes selected files from the list.

unlist_select

Unlist Extension

Removes files with a specific
extension from the list.

gui_unlist_ext

Unlist Attribute

Removes files with a specific attribute
from the list.

unlist_attr

Unlist Search

Removes lines which contain a
particular search string.

unlist_search

Read List

Appends a list of files contained in a
file.

read_list

Write List

Writes a file containing the currently
selected files.

write_list

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with File menu items.

New Dialog
The New dialog is used to create new files, projects, and workspaces. The dialog consists of three tabs:
•
•
•
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File Tab
Project Tab
Workspaces Tab
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File Tab
This tab on the New Dialog is used to create new files. It is displayed when you click File > New or use the
new command. See Creating Files for more information.

The fields and options on the File tab are described as follows:
•

Document Mode - Specifies the language editing mode for the new file. The language editing
mode determines the options and features that will be available for this file (see Language Editing
Mode). Double-click on a mode to instantly create an empty, untitled buffer set to that mode.
Recently used language modes appear at the top of the list. You can control the number of
recently used items that appear with the option Number of recent modes to store at the bottom
right of the tab.
When you select the Automatic mode, the language mode is picked based on the file extension of
the file you name. If your extension doesn’t match a mode, you’ll be asked if you want to create it
as plain text. Double-clicking Automatic creates an untitled plain text file.

•

Add to Project - When selected, the new file will be added to the selected project in the current
workspace. Use the drop-down list to select the project. This option is set automatically if a project
is open.

•

Filename - Specifies the name (without path) of the file to create.

•

Location - Specifies the directory in which the file should be created. By default, this is set to the
current working directory (see The Working Directory). Click the Browse button to the right of this
field to browse for a location. You can also type a path and if the directory does not exist, you will
be prompted to create it after you click OK.
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•

Encoding - The encoding indicates whether to convert a file to either SBCS/DBCS for the active
code page or Unicode (more specifically UTF-8) data. By default, XML and Unicode files with
signatures (UTF-16, UTF-32, and UTF-8) are automatically loaded as Unicode UTF-8 data, while
other more common program source files like .c, .java, and .cs source files are loaded as SBCS/
DBCS active code page data. To provide better support for editing Unicode and non-Unicode files,
two modes of editing exist: Unicode and SBCS/DBCS mode. Files that contain Unicode, XML, or
code page data not compatible with the active code page should be opened as Unicode files. See
Encoding for more information.

•

Number of recent modes to store - Specifies the number of recently used language editing
modes to display at the top of the Document Mode list.

Project Tab
The Project tab on the New Dialog is used to create new projects. It is displayed when you click Project >
New or use the workspace_new command. The fields and options on the Project tab are described below.
See Creating Projects for step-by-step instructions and Project Types more information about choosing the
correct project type.

The fields and options on the Project tab are described as follows:
•

508

Project type - Specifies the type of project that you want to create (see Project Types for more
information). Expand your language in the tree to see all types for that language. It is very
important to select the correct type of project at this stage, because it is not possible to change it
after the project has been created. Recently used project types appear at the top of the list. You
can control the number of recently used items that appear with the option Number of recent
types to store at the bottom right of the tab.
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•

Customize - Displays the Customize Project Types dialog, which allows you to create, edit, and
delete project packages from the Project type list. System-defined project types are stored in
prjtemplates.vpt. User-modified or additional project types are stored in
usrprjtemplates.vpt. See Creating Custom Project Types for more information.

•

Project name - Specifies the name of the new project.

•

Create project directory from project name - When selected, the name you specify for the
project is used as the name for the new directory in which the project will be created. The new
directory will be created as a subdirectory under the specified Location. When this option is not
selected (cleared), the project will be created inside the Location directory. The area below the
Location field shows where the project files will reside based on this option and other Project tab
settings. For example, if the project is named “TestProject”, this option is selected, and the location
is set to C:\dev\, files for this project will reside at C:\dev\TestProject. If the option is not
selected, files for the project will reside at C:\dev.

•

Location - Specifies the directory in which the project should be created. By default, this is set to
the current working directory (see The Working Directory). Click the Browse button to the right of
this field to select a different location. You can also type a path and if the directory does not exist,
you will be prompted to create it after you click OK. The area below this field shows where the
project files will reside based on this field and other Project tab settings.

•

Files will be located at - Shows the path where the project files will reside, based on the
information you have specified on the tab.

•

Executable name - Specifies the name of the executable or output file.

•

Create new workspace - Specifies that the project should be created in a new workspace. This
option and Add to current workspace are mutually exclusive.

•

Add to current workspace - Specifies that the project should be created inside the current
workspace. For example, if the current workspace is named “OrderChart” located in
C:\dev\OrderChart, the name of the new project is “TestProject”, and this option is selected, files
for the new project will reside at C:\dev\OrderChart\TestProject. This option and Create new
workspace are mutually exclusive.
o

•

Dependency of - When Add to current workspace is selected, this option specifies that the
new project should be a dependency of an existing project in the current workspace. Use the
drop-down to select the existing project on which you want the new project to depend. See
Defining Project Dependencies for more information.

Number of recent types to store - Specifies the number of recently used project types to display
at the top of the Project type list.

Workspaces Tab
This tab on the New Dialog is used to create a new workspace. To access it, click Project > New or use
the workspace_new command. See Creating Workspaces for more information.
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•

Blank Workspace - Select this only if you want to create an empty workspace to which you can
add projects.

•

Workspace name - Specify the name of the new workspace.

•

Location - Specify the directory location of the new workspace. If the directory does not exist, you
will be prompted to create it when you click OK.

The data for each workspace, solution, or project is stored in a text file with the .vpw extension.

Standard Open Dialog
On Windows, this is the default dialog that is used to open files. It is displayed when you click File > Open
or use the gui_open command.
This dialog is generally slower than the Windows 3.1-Style Open Dialog, which is displayed by default on
Mac, Linux, and UNIX platforms. To use that dialog instead, from the main menu, click Tools > Options >
Appearance > Advanced, then set the Windows 3.1 style open dialog option to True.
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•

Look in - Specify the directory for which to display files. Select multiple files with Ctrl+Click. Press
Ctrl+A to select all files.

•

File name - The name of the file you wish to edit is typed into the File name text box. Click the OK
button to open the selected files. This text box supports alias expansion. Type the alias name and
press Ctrl+Space to expand an alias. Aliases save time typing in long path names and wasting
time clicking through the Directories list box. See Directory Aliases for more information.

•

Files of type - This combo box lets you display files of particular extensions. Select a different file
filter from this combo's list box to change the file list.
You can change the file specifications that appear in the Files of type combo box at the bottom left
of the Open and Save As dialog boxes. From the main menu, click Tools > Options > File
Options, then select File Filters. The first wildcard pattern(s) specified is used to initialize the
Open dialog box. The default is to list all files. You may want an initially smaller list which displays
the source files you typically edit. See File Filter Options for more information.

•

Open as read-only - When opening a file, check this box if you wish to open a file but do not want
to accidentally modify the file. Files are automatically opened with the read-only attribute set as
read-only, regardless of the setting of this check box.

•

Encoding - The encoding specifies whether to convert a file to either SBCS/DBCS for the active
code page or Unicode (more specifically UTF-8) data. By default, XML and Unicode files with
signatures (UTF-16, UTF-32, and UTF-8) files are automatically loaded as Unicode UTF-8 data,
while other more common program source files like .c, .java, and .cs source files are loaded as
SBCS/DBCS active code page data.
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To provide better support for editing Unicode and non-Unicode files, two modes of editing exist:
Unicode and SBCS/DBCS mode. Files that contain Unicode, XML, or code page data not
compatible with the active code page should be opened as Unicode files. See Encoding for more
information on the available encodings.
•

Expand tabs - When this option is checked, tabs found in opened files are expanded to spaces in
increments of eight.

•

Preload file - This check box is used to force the entire contents of opened files to be read into
memory (may spill to disk), count the number of lines in the file, and truncate the file when an EOF
character is found.

•

Change dir - (Not always present) Check this box if you want the current directory to be changed
to the path where this file is located. To set the default value of this check box to always enabled,
from the main menu click Tools > Options > Appearance > General, and set the Change
directory option to True.

•

Line format - This option specifies the type of line ending to be used. Select DOS, UNIX, or MAC
line endings, or select Current line format to use the line endings already in the current file.

•

Line separator char (decimal) - This text box allows you to specify a decimal character which the
editor will use as a single line separator character.

•

Record width - This text box allows you to specify a decimal line width. Use this option to open
ASCII record files or binary files.

•

Find File - This button displays the Find File dialog box used to scan subdirectories for wildcard
file names. Files found may be opened. See Find File Dialog.

Windows 3.1-Style Open Dialog
On Mac, Linux, and UNIX platforms, this is the default dialog used to open files. It is displayed when you
click File > Open or use the gui_open command. This dialog is generally faster than the default Standard
Open Dialog, but you can use the Windows dialog if you prefer. To use the standard Open dialog, from the
main menu, click Tools > Options > Appearance > Advanced, and set the Windows 3.1 style open
dialog option to False.
This dialog contains the same options as the Standard Open Dialog, with the following additions/
differences:
•

File name - The name of the file you wish to edit is typed into the File name combo box. Press the
OK button to open the file. Use the Open button to open several files at once with a wildcard file
specification such as *.c.
The syntax for specifying a sequential data set is //dataset. The syntax for specifying a partitioned
data set member is //dataset/member. For example, type //SYS1.PARMLIB/BPXPRM00 into the
File name combo box and press Enter to edit the BPXPRM00 member of SYS1.PARMLIB.
The following characters have special meaning when entered as the last part of a file name:
Character
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Meaning

*

Matches zero or more characters.

?

Matches any character.
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Character
[char-set]

Meaning
Matches any one of the characters specified by char-set. A
dash (-) character may be used to specify ASCII (not
EBCIDIC) ranges. The expression [A-Z] matches any
uppercase letter. A backslash (\) may be used inside the
square brackets to define literal characters or ASCII
characters. For example, \- specifies a literal dash character.

File name wildcard examples:
Example

Meaning

//sys1.*

Match data sets starting with sys1.

//p*a.b.*

Match data sets starting with p that have a.b. in the middle.

//sys1.maclib/a*

Match all members that start with the letter a.

//dataset/vs*xy

Match all members starting with vs and ending with xy.

//dataset/a?c

Match member names that start with a, end with c, and are
exactly three characters long. For example, this matches abc
or axc.

//dataset/a[a-c]c

Matches members names aab, abc, and acc.

Like many combo boxes in SlickEdit®, the File name combo box has the following powerful
features:
o

Combo box retrieval - Press the Down arrow key to retrieve the previous file name you
entered here. The combo box list (Alt+Down) displays all the previous file names entered.
This retrieval information is saved across edit sessions.

o

Completion - Press the spacebar (Space) to automatically type the rest or more of the partial
file name for you. For example, type c:\aut and press Space. SlickEdit will attempt to expand
this to c:\autoexec.bat (or to c:\autoexec. if you have a file like c:\autoexec.bak). Press
? to list possible matches for what you have typed so far. For example, if you type a and press
?, a list will be displayed of all files which start with the letter a. See Completions for more
information.

o

Alias expansion - Type the alias name and press Ctrl+Space to expand an alias. Aliases
save you from typing long path names and wasting time clicking through the Directories list
box. Many keys from your emulation are supported here such as Ctrl+K (copy word to
clipboard), Ctrl+Backspace (cut line), and Ctrl+Shift+K (cut word). See Directory Aliases for
more information.

o

Multiple clipboards - Press Ctrl+Shift+V to view a list of all your clipboards.

NOTE (UNIX) Embed ~, ~login name, or $envvar in the File Name specification in the
same way as at a UNIX shell prompt.
•

File list - The File list is located below the File name combo box. Click in this list box to change
the file name displayed in the combo box. Multiple files may be selected with Ctrl+Click.
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•

List files of type - This combo box lets you display files of particular extensions. Select a different
file filter from this combo's list box to change the file list.

TIP You can change the file specifications that appear in the List files of type combo box at
the bottom left of the Open and Save As dialog boxes. From the main menu, click Tools >
Options > File Options, then select File Filters. The first wildcard pattern(s) specified is used
to initialize the Open dialog box. The default is to list all files. You may want an initially smaller
list which displays the source files you typically edit. See File Filter Options for more
information.
•

Directories - Double-click on files in this list box to change the directory. The File List is updated.

•

Read only - When opening a file, check this box if you wish to open a file but do not want to
accidentally modify the file. SlickEdit will automatically open files with the read-only attribute set
(UNIX: read-only permissions) as read-only, regardless of the settings of this check box. This
check box is also present when saving a file. It allows you to save a read-only file as read-only.

•

Show hidden files - Dot files (files with names beginning with a dot character) are hidden in the
Open dialog by default. To view dot files, select this option. The default state of this option is
controlled by the option Show files beginning with a dot (Tools > Options > Appearance >
General). Show files beginning with a dot can be also set using the def_filelist_show_dotfiles
configuration variable.

•

Open - To open a wildcard file specification such as *.c, type *.c in the File Name text box, and
click on the Open button.

•

Invert - Click on the Invert button to select all files in the File List that are currently not selected
and deselect all files which are selected. The Invert button appears on other dialog boxes which
have list boxes which support selection of multiple files with Ctrl+Click. Since there are no files
selected when the Open dialog box initially appears, you can click on the Invert button followed by
the OK button to open all files displayed in the File List.

•

Advanced - Expands the Open dialog box to display additional less-often used options.
You will notice that several check boxes initially appear grayed. A grayed check box indicates that
a default action will be performed. SlickEdit allows many load options to be based on the drive
from which the file you open resides. For more information, see Load File Options.

•

File locking - When on, ensures that a file handle is kept open to the file for locking purposes.
This allows SlickEdit to detect when another user is editing the same file.

•

Binary - When on, makes it safe to edit binary files by overriding some file load and save options.
If you are using the default load and save options, you do not need to turn on this check box before
editing a binary file.

•

New window - Select this option to cause the file to be opened in a new editor window.

•

File format - SlickEdit automatically detects DOS, Macintosh, and UNIX file formats by checking
the first 8096 bytes of the file. If this logic is not working for a particular file you have, force a file in
a specific format. Select the DOS, Mac, or UNIX radio button.

Find File Dialog
This dialog is used to find a file to open. It is displayed when you click File > Open, then click the Find File
button, or when you use the find_file command.
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•

File pattern - File or file pattern to search for. Subdirectories are always scanned. Press the
Search button to start the search.

•

Search - Starts searching for the file pattern specified.

•

Files found - List the files that match the last search. Use Ctrl+Click to select more than one file.

•

Read only - When checked, the selected files are opened as read-only.

•

Open - Opens the selected files in the Files Found list box.

•

Advanced - These are the same options found on the Open dialog box. See Standard Open
Dialog or Windows 3.1-Style Open Dialog.

Open URL Dialog
This dialog is used to specify an HTTP file to open. It is displayed when you click File > Open URL or use
the open_url command.
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•

URL - Enter a URL to open in this field. You may use forward or backward slashes. The prefix
“http://” is not required.

•

Use cache - If this option is selected, and the URL being opened already exists in the cache, the
cached version is opened. This option is intended to save time required to download remote files.
If the URL specified is already open, this option has no effect.

•

Include header - If this option is selected, all of the URL header data is displayed. If the URL
specified is already open, this option has no effect.

Save As Dialog
This dialog is used to save the current file under a different name. It is displayed when you click File >
Save As or use the gui_save_as command. By default, on Windows, the standard Save As dialog is
displayed. On Linux, UNIX, or Mac, a Windows 3.1-style Save As dialog is displayed. You can specify
which dialog to display by default: from the main menu, click Tools > Options > Appearance >
Advanced, and set the Windows 3.1 style open dialog option to True or False. The Standard Save As
dialog is described below.
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•

Save as type - This option filters the list of files displayed based on file extension. Changing this
value will not change the extension of the file, unless the extension is not specified in the File
name field.

•

Encoding - The encoding specifies whether to convert a file to either SBCS/DBCS for the active
code page or Unicode (more specifically UTF-8) data. By default, XML and Unicode files with
signatures (UTF-16, UTF-32, and UTF-8) files are automatically loaded as Unicode UTF-8 data,
while other more common program source files like .c, .java, and .cs source files are loaded as
SBCS/DBCS active code page data. See Encoding for more information.

•

Line format - This option specifies the type of line ending to be used. Select DOS, UNIX, or MAC
line endings, or select Current line format to use the line endings already in the current file.

•

Change dir - Check this box if you want the current directory to be changed to the path where this
file is saved. To set the default value of this check box, from the main menu, click Tools > Options
> Appearance > General, and set the Change directory option.

•

Show hidden files - (UNIX only) Dot files (files with names beginning with a dot character) are
hidden in the Save As dialog by default. To view dot files, select this option. The default state of
this option is controlled by the option Show files beginning with a dot (Tools > Options >
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Appearance > General). Show files beginning with a dot can be also set using the
def_filelist_show_dotfiles configuration variable.
•

Keep old file - When checked, the file is saved under the name you specify but the buffer name is
not changed. This check box is not always displayed.

•

Add to project - When checked, the saved file will be added to the project that is currently open in
the workspace. If no project is open, this option is unavailable. To set the default value of this
check box, from the main menu click Tools > Options > File Options > Save, and change the
option Add file to project upon Save As.

TIP This option is also available from the command line by using the option letter +P with the
save_as command. For example, save_as +P /path/to/file.cpp will add file.cpp to the
current project. Similarly, save +P will save the current file and add it to the current project.

Save Failed Dialog
This dialog appears automatically when a Save operation has failed. The following options are available:
•

Save as read only - (UNIX only) This check box is automatically selected if your file does not have
any write permissions (no “w” letter). Turn this option on to have SlickEdit® temporarily change the
permissions on the file to read/write. The resulting file will not have any write permissions (no “w”
letter).

•

Save without creating a backup - This check box is automatically selected if SlickEdit was
unable to create a backup file when trying to save your file. This can happen when you do not have
permissions to create the backup directory or when you are out of disk space. If you are editing
files on a network drive, you may not have access rights for creating a backup directory on that
drive.

•

Configure local backup directory - (Non-UNIX only) If you are editing files on a network drive,
you may not have access rights for creating a backup directory on that drive. Configuring a local
backup directory guarantees that you always have write access. If the directory you specify does
not exist, SlickEdit will create one for you.

Exiting with Modified Buffers Dialog
If files have not been saved or closed upon exit, this dialog appears so you can save or discard any
changes.
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The buffer names in the list box are buffers which have not been saved.
•

Save All - Saves all buffers. If a buffer does not have a name, you are prompted to give a file
name.

•

Save Selected - Saves only the buffers that are selected. Use Ctrl+Click to select more than one
buffer.

•

Invert - Reverses the selection status for all buffers. When no buffers are selected, this selects all
buffers.

•

Save None - Selects to save no buffers. Beware, if you are exiting the editor you will not be given
another chance to save your files.

Change Directory Dialog
This dialog is used to change the current working directory. It is displayed when you click File > Change
Directory or use the gui_cd command.
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•

Directory name - Name of directory to change to make active.

•

Expand alias - Check this box if you want to specify directory aliases in the Directory name text
box. See Directory Aliases for more information.

•

Process chdir - Check this box if you want the current directory in the Build tool window to be
changed in addition to the editor's current directory.

•

Save Settings - Save the settings of the Expand alias and Process chdir check box values. The
next time this dialog box appears, these check boxes are set to the values last saved. In addition,
these check box settings affect the cd command which is used to change directory using the
command line.

Print Dialog for Windows
On Windows, this is the default dialog used to configure print options and send text or files to a printer. It is
displayed when you click File > Print or use the gui_print command. Mac, Linux, and UNIX platforms
have a different print dialog—see Print Dialog for Mac, Linux, and UNIX for its description. See Printing for
more information about printing from within SlickEdit®.
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The general settings on the Print dialog for Windows are described below.
•

Print - Sends the selection or active buffer to the printer specified in the Print Setup dialog (print
command).

•

Font - Displays the Fonts option screen, which allows you to specify the font for the printed text.
See Font Options for more information.

•

Setup - Displays the Print Setup dialog, which allows you to specify the printer to use
(printer_setup command). The Print Setup dialog box is built into the operating system, and its
contents might vary depending on the print driver that you are using.

•

Preview - Displays a preview of what the printed file will look like (print_preview command).

•

Files - Expands the Print dialog to allow you to pick another file or multiple files for printing (as
opposed to the active file).

The remaining options are categorized into the following tabs:
•
•
•
•

General Tab
Header/Footer Tab
Margins Tab
Schemes Tab

General Tab
This tab on the Print Dialog for Windows is used to set general print options.
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•

Selection only - When this option is selected, only the selection is printed. To print the selection
immediately using the default configuration, use the print_selection command.

•

Visible lines only - When this option is selected, only visible lines are printed. This option allows
you to print selective display.

•

Print color coding - When this option is selected, language-specific color coding is printed using
the same font attributes (bold, italic, underline).

•

Print color - When this option is selected, language-specific color coding is printed using the
same colors.

•

Print hex - When this option is selected, printed output is displayed as if it were the hex display
mode.

•

Two up - When this option is selected, it specifies two columns where one page is printed in the
left column and the next page is printed in the right column. This is useful when printing in
landscape mode, especially when you are using a small font.

•

Orientation - Specifies whether text is printed top to bottom (portrait) or left to right (landscape).

•

Space between - This text specifies the width between columns, in inches. This text box is
unavailable unless the Two Up check box is marked.

•

Number lines every - When the value is not zero, lines at intervals of this value are printed with
line numbers.

•

Number of copies - This value specifies the number of copies to print.
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Header/Footer Tab
This tab on the Print Dialog for Windows is used to configure header/footer printing options.

Type directly into the text boxes to specify text for the top left, center, and right headers and bottom left,
center, and right footers. Click the arrow to the right of each text box pick from a list of escape sequences
to be inserted. Escape sequences are values that are replaced with real data, such as %f (which will be
replaced with the file name) and %d (which will be replaced with the date).

Margins Tab
This tab on the Print Dialog for Windows is used to configure print margins.
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•

After header/Before footer - Specifies the amount of spacing to come between the header and
the first line on a page, and the amount of spacing to come between the last line on a page and the
footer.

•

Margins - The Top, Bottom, Left, and Right margin fields specifies the amount of spacing in
inches to come between the outer edge of the paper and the printed text. To print the maximum
amount of text, specify “0” for all margins.

Schemes Tab
This tab on the Print Dialog for Windows lets you to save the current printer settings as a scheme. See
Print Schemes for more information.

Print Dialog for Mac, Linux, and UNIX
On Mac, Linux, and UNIX platforms, the Text Mode Print dialog is the default dialog used to configure print
options and send text or files to a printer. It is displayed when you click File > Print or use the gui_print
command. Windows uses a different print dialog—see Print Dialog for Windows for its description. See
Printing for more information about printing from within SlickEdit®.
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The Text Mode Print dialog contains the following general settings:
•

OK - Sends the selection or active buffer to the print device.

•

Save Settings - Saves the settings that are configured in the Text Mode Print dialog. The next
time a print command or this dialog is invoked, the previously saved settings are restored.

•

Files - Expands the Text Mode Print dialog to allow you to pick another file or multiple files for
printing (as opposed to the active file).

The remaining options are categorized into the following tabs:
•
•
•

General Tab
Header/Footer Tab
Advanced Tab

General Tab
This tab on the Print Dialog for Mac, Linux, and UNIX contains general print settings.
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•

Selection Only - When this option is selected, only the selection is printed. To print the selection
immediately using the default configuration, use the print_selection command.

•

Visible lines only - When this option is selected, only visible lines are printed. This option allows
you to print selective display.

•

Print hex - When this option is selected, printed output is displayed as if it were the hex display
mode.

•

Form feed after last page - Determines whether the built-in print text formatting prints a form feed
after the last page.

•

Use PostScript (Enscript) - When this option is selected, the enscript program is used to print a
source file. This allows for print formatting such as fonts, page layout, etc. To specify the options
for enscript, see Advanced Tab. Activating this option will make the following settings available:
o

Print color coding - When this option is selected, language-specific color coding is printed
using the same font attributes (bold, italic, underline).

o

Print color - When this option is selected, language-specific color coding is printed using the
same colors.

o

Two Up - When this option is selected, it specifies two columns where one page is printed in
the left column and the next page is printed in the right column.

•

Number Lines Every - When the value is not zero, lines at intervals of this value are printed with
line numbers.

•

Lines per page - Maximum number of lines that can be printed. This includes header, footer, and
blank lines.

•

Columns per line - Maximum number of columns that can be printed on a line.

Header/Footer Tab
This tab on the Print Dialog for Mac, Linux, and UNIX is the same as the Header/Footer Tab on the Print
Dialog for Windows.
526

SlickEdit® User Guide

FILE

Advanced Tab
This tab on the Print Dialog for Mac, Linux, and UNIX is used to configure advanced print options.

•

Print command - Specifies the program that will be executed to print the formatted text. If no print
command is specified, the text is written to the Print Device specified. The default print command
is lp -c -o nobanner %f. The %f specifies the file to be printed. If the print program is not found,
the command lpr %f is used instead.

•

PostScript Options - To use PostScript options, you must first select the option Use PostScript
(Enscript) on the General print settings tab. The default options are --media=Letter --no-header
--quiet. For a list of all available enscript options, see the enscript man page.

•

Print filter - Specifies an external program to format text before it is printed and overrides the builtin print text formatting. The program specified here must accept input from standard in and writes
its output to standard out. A typical print filter command is pr -1 -w76 -o0 -l50.

•

Print device - Specifies a printer device file name in which to write the formatted text. This text box
is ignored if a Print Command has been specified. The default print device is /dev/lp0.

Add/Edit FTP Profile Dialog
This dialog is used to create or edit profiles for FTP connections. It is displayed when you click File > FTP
> Profile Manager, then click Add or Edit. The title of the dialog box changes based on whether you are
adding a profile or editing an existing profile, but the interface is the same. The dialog consists of two tabs:
General Tab and Advanced Tab.

General Tab
This tab on the Add/Edit FTP Profile Dialog is used to configure general FTP profile settings.
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•

Profile name - Name displayed in connection combo box.

•

Host name - Host name of the FTP server.

•

Server type - If you are connecting to an FTP server, select FTP. If you are connecting to a Secure
Shell (SSH) server that supports the SFTP subsystem, select SFTP/SSH.

•

Host type - If the file listing is blank after connecting, select the host type from the list. Otherwise,
leave it set to Auto. If the server type is SFTP/SSH, then this type is ignored.

•

User ID - Logon user ID.

•

Password - Logon password.

•

Anonymous login - Specifies whether the FTP login uses the anonymous user ID.

•

Save password - Specifies whether to save a password.

•

Transfer type - Specifies the default file transfer method. Select ASCII if you want line breaks
translated. Otherwise, specify Binary.

•

Initial directory - Specifies the initial remote and local directories after login.

•

Filters - Specifies the initial remote and local file filters after login.

Advanced Tab
This tab on the Add/Edit FTP Profile Dialog is used to configure advanced FTP profile settings.
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•

Timeout - The value that you type in this field specifies the amount of time that the application
should wait for a reply from the FTP server.

•

Port - FTP or SFTP/SSH port. By default, this is 21 for FTP server type, and 22 for SFTP/SSH.

•

Keep alive - Keeps a connection alive even when idle. Unavailable for SFTP/SSH server type.

•

Resolve links - Resolves symbolic links on the remote host. Unavailable for SFTP/SSH server
type.

•

Auto refresh - Determines whether the host directory listing is updated after an operation. Turn
this off if the host is slow. Use the context menu (right mouse button) to temporarily turn Auto
refresh on/off or force the directory list to be updated.

•

Use firewall/proxy - This option is not available until a firewall is set up and activated.

•

Upload filename case - Indicates what file case should be used for the remote file name based
on the local file name.

•

Remote to local directory mapping - This specifies how a remote path maps to a local path and
vice versa. For example, if Remote root is /usr/ftp/www-slickedit and Local root is
c:\web\slickedit\, then the remote path /usr/ftp/www-slickedit/products/index.html is
mapped to the local path c:\web\slickedit\products\index.html. This option only affects the
FTP tool windows.
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Edit
This section describes items on the Edit menu and associated dialogs and tool windows. See Text Editing
for more details about editing operations.

Edit Menu
The table below describes items on the Edit menu.
Edit Menu Item

Description

Command

Undo

Undoes the last edit operation.

undo

Redo

Undoes an undo operation.

redo

Multi-file Undo

Undoes the last multi-file operation
(i.e.: Find and Replace in all files).

mfundo

Multi-file Redo

Undoes an multi-file undo operation.

mfredo

Cut

Deletes the selected text and copies it
to the clipboard.

cut

Copy

Copies the selected text to the
clipboard.

copy_to_clipboard

Paste

Inserts the clipboard into the current
file.

paste

List Clipboards

Displays the Clipboards tool window,
which allows you to view and insert
the selected clipboard. See
Clipboards and also Select Text to
Paste Dialog.

list_clipboards

Copy Word

Copies the current word to the
clipboard.

copy_word

Append to Clipboard

Appends the selected text to the
clipboard.

append_to_clipboard

Append Cut

Deletes the selected text and
appends it to the clipboard.

append_cut

Insert Literal

Displays the Insert Literal dialog,
which allows you to insert a specified
character code. See Inserting Literal
Characters.

insert_literal

Select

Displays menu for selecting and
deselecting text. See Edit Select
Menu.

N/A

Delete

Displays menu for deleting text. See
Edit Delete Menu.

N/A
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Edit Menu Item

Description

Command

Complete Previous
Word

Retrieves previous word or variable
matching word prefix at cursor.

complete_prev

Complete Next Word

Retrieves next word or variable
matching word prefix at cursor.

complete_next

Fill

Displays the Fill Selection dialog,
which lets you fill the selected text
with a character you choose.

gui_fill_selection

Indent

Indents the selected text based on the
tabs or indent for each level.

indent_selection

Unindent

Unindents the selected text based on
the tabs or indent for each level.

unindent_selection

Other

Displays menu containing more editrelated commands. See Edit Other
Menu.

N/A

Edit Select Menu
The Edit > Select menu contains selection operations. See Selections for more information.
Edit Select Menu Item

Description

Command

Char

Starts or ends a character/stream
selection.

select_char

Block

Starts or ends a block/column
selection.

select_block

Line

Starts or ends a line selection.

select_line

Word

Selects the word under cursor.

select_whole_word

Code Block

Selects text in current code block (if/
loop/switch block etc.).

select_code_block

Procedure

Selects text in current function
including function heading.

select_proc

Deselect

Unhighlights selected text.

deselect

All

Selects all text in current buffer.

select_all
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Edit Delete Menu
The Edit > Delete menu contains text deletion operations. See Cutting and Deleting Text for more
information.
Delete Menu Item

Description

Command

Word

Deletes text from the cursor to the
end of the current word and copies it
to the clipboard.

cut_word

Line

Deletes the current line and copies it
to the clipboard.

cut_line

To End of Line

Deletes text from the cursor to the
end of the line and copies it to the
clipboard.

cut_end_line

Selection

Deletes the selected text.

delete_selection

All

Delete all text in current buffer.

delete_all

Edit Other Menu
The Edit > Other menu contains miscellaneous editing operations.
Edit Other Menu Item

Description

Command

Lowcase

Translates the characters in the
selected text to lowercase.

lowcase_selection

Upcase

Translates the characters in the
selected text to uppercase.

upcase_selection

Capitalize

Capitalizes the first character of the
current word.

cap_selection

Shift Left

Deletes the first column of text in each
line of the selected text.

shift_selection_left

Shift Right

Inserts a space at the first column of
each line of the selected text.

shift_selection_right

Overlay Block

Overwrites selected block/column of
text at the cursor.

overlay_block_selection

Adjust Block

Overlays the selected text at the
cursor and fills the original selected
text with spaces.

adjust_block_selection

Enumerate

Displays the Enumerate dialog, which
allows you to add incrementing
numbers to a selection. See
Enumerate Dialog.

gui_enumerate
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Edit Other Menu Item

Description

Command

Filter Selection

Displays a Command dialog, which
allows you to filter selected text
through an external command. See
Filter Selection: Command Dialog.

filter_selection

Copy UCN As Unicode

Copies selected UCN to the clipboard
as Unicode. See Using Unicode.

copy_ucn_as_unicode

Copy Unicode As

Displays menu containing commands
for copying Unicode as UCN. See
Copy Unicode As Menu.

N/A

Tabs to Spaces

Converts tabs to appropriate number
of spaces. If there is no selection the
entire buffer is converted.

convert_tabs2spaces

Spaces to Tabs

Converts leading spaces to tabs. If
there is no selection the entire buffer
is converted.

convert_spaces2tabs

Remove Trailing
Whitespace

Removes trailing whitespace
characters from the ends of lines.

remove_trailing_spaces

Block Insert Mode

Allows you to insert/delete text for an
entire block/column selection.

block_insert_mode

Copy Unicode As Menu
The Edit > Other > Copy Unicode As menu contains operations for copying Unicode characters. See
Using Unicode for more information.
Copy Unicode As Menu
Item

Description

Command

C++ (UTF-16 \xHHHH)

Copies Unicode characters in
selection as C++ UTF-16 \xHHHH
notation.

copy_unicode_as_c

Regex (UTF-32
\x{HHHH})

Copies Unicode characters in
selection as Regex UTF-32 \x{HHHH}
notation.

copy_unicode_as_regex

Java/C# (UTF-16
\uHHHH)

Copies Unicode characters in
selection as Java/C# UTF-16 \uHHHH
notation.

copy_unicode_as_java

UCN (UTF-32 \uHHHH
and \UHHHHHHHH)

Copies Unicode characters in
selection as UCN UTF-32 \uHHHH
and
\UHHHHHHHH notation.

copy_unicode_as_ucn

SGML/XML
hexadecimal (UTF-32
&xHHHH;)

Copies Unicode characters in
selection as SGML/XML hexadecimal
UTF-32 &xHHHH; notation.

copy_unicode_as_xml

534

SlickEdit® User Guide

EDIT

Copy Unicode As Menu
Item
SGML/XML decimal
(UTF-32 &xDDDD;)

Description
Copies Unicode characters in
selection as SGML/XML decimal
UTF-32 &xDDDD; notation.

Command
copy_unicode_as_xmldec

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with Edit menu items.

Select Text to Paste Dialog
This is a modal dialog available for viewing and inserting recently used SlickEdit® clipboards (not the same
as the operating system clipboard). To display the dialog, you can use either the old_list_clipboards
command or the list_clipboards_modal command. These commands are identical. If there are no
clipboards, the message line states No clipboards. See Clipboards for more information.
TIP You can also use the Clipboards tool window to view and insert clipboards (Edit > List
Clipboards or list_clipboards command). It provides the same information as the Select Text to
Paste dialog, except it includes a Preview area to view color-coded clipboard contents and provides
some additional functionality. See Clipboards for more information.

The dialog shows a list of clipboards. To insert a clipboard at the current cursor location, double-click on
the clipboard to insert, or, select the clipboard to insert and press Enter or click OK.
To see the entire contents of a condensed clipboard, click the View button. The View Clipboard dialog
opens showing the color-coded contents in an edit window. From here, you can copy all or part of the
contents to the operating system clipboard.
The dialog shows the following information:
•

Clipboard name/number - This is the number of the clipboard or the name, if using Named Clipboards. Clipboards are numbered with the most recent clipboard first, which always appears at the
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top of the list. You can use this value with the paste command to insert the specified clipboard. For
example, type paste 2 on the command line to insert clipboard 2 at the cursor location.
•

Clipboard type - The clipboard type can be CHAR, LINE, or BLOCK. A CHAR type clipboard is
inserted before the current character. A LINE type clipboard is inserted after the current line by
default. If you want LINE type clipboards inserted before the current line, change the line insert
style (Tools > Options > Editing > General). A BLOCK type clipboard is inserted before the current character and pushes over all text intersecting with the block. No lines are inserted.

•

Line count - The number following the clipboard type indicates the number of complete or partial
lines of text in the clipboard.

•

Clipboard contents/summary - This area shows all or a portion of the clipboard contents. If the
contents exceed the viewing area, they are condensed.

Enumerate Dialog
This dialog contains options for adding incrementing numbers to a selection. It is displayed when you click
Edit > Other > Enumerate or use the gui_enumerate command. Alternatively, you can add incrementing
numbers to a selection using the enumerate command with options on the command line. See the Help
system for command syntax.
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•

Start - C syntax expression which evaluates to the number used for first line of selection. However,
when the Hexadecimal flags output style is selected, the start must be an integer bit position or
the first hexadecimal number with which to start.

•

Increment - C syntax expression which evaluates to the amount to increment for each line in the
selection. However, when the Hexadecimal flags output style is selected, this specifies the
number of bit positions by which to increment.

•

Pad to number of digits - Specifies the digit width for each number. Number is padded to at least
this number of digits by adding leading zeros.

•

Output - Both the Hexadecimal and Hexadecimal flags options specify hexadecimal syntax
output based on the buffers extension. We determine the hexadecimal syntax based on the color
coding which supports 0xhhhh (C syntax), &Hdddd (Basic), hhhhH (Intel assembler), and $hhhh
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(Motorola assembler). If the buffer's extension has no color coding, the hex numbers are prefixed
with 0x.

Filter Selection: Command Dialog
The Command dialog is used to specify a command to run against the selected text. It is displayed when
you click Edit > Other > Filter Selection or use the filter_selection command.

Enter the command in the Command text box. The selected text will be used as input to the command,
and the output from the command will replace the selected text. Use the drop-down arrow to the right of
the Command text box to select from a history of previously entered commands.

SlickEdit® User Guide

537

EDIT

538

SlickEdit® User Guide

SEARCH

Search
This section describes items on the Search menu and associated dialogs and tool windows. For more
information about using search and replace operations, see Find and Replace.

Search Menu
The Search menu contains items pertaining to search and replace, navigation, and bookmarks.
Search Menu Item

Description

Command

Find

Displays the Find and Replace tool
window, open to the Find tab, which
allows you to search for a specified
string. See Find and Replace Tool
Window.

gui_find

Find in Files

Displays the Find and Replace tool
window open to the Find in Files tab,
which lets you search for a string in
files. See Find in Files Tab.

find_in_files

Next Occurrence

Searches for the next occurrence of
the last string you searched for.

find_next

Previous Occurrence

Searches for the previous occurrence
of the last string you searched for.

find_prev

Replace

Displays the Find and Replace tool
window, open to the Replace tab,
which allows you to search for a string
and replace it with another string. See
Replace Tab.

gui_replace

Replace in Files

Displays the Find and Replace tool
window, open to the Replace in Files
tab, which allows you to search for a
string and replace it with another
string in files. See Replace in Files
Tab.

replace_in_files

Incremental Search

Searches for match incrementally.
See Incremental Searching.

i_search

Find File

Displays the Find File dialog, which
lets you search for files on disk.

find_file

Go to Line

Places the cursor on a line you
specify. See Navigating to a Specific
Line.

gui_goto_line

Go to Offset

Places the cursor on a byte/character
offset in the current file. See
Navigating to an Offset.

gui_seek
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Search Menu Item

Description

Command

Go to Matching
Parenthesis

Finds the matching parenthesis or
begin/end structure pair. See Begin/
End Structure Matching.

find_matching_paren

Go to Definition

Pushes a bookmark at the cursor and
places your cursor on a symbol
definition. See Find Symbol Tool
Window and Symbol Navigation.

gui_push_tag

Go to Reference

Searches for references to the symbol
under the cursor. See Symbol
Navigation.

push_ref

Find Symbol

Searches Context Tagging®
databases for a symbol you specify.
See Find Symbol Tool Window.

gui_push_tag

Push Bookmark

Pushes a bookmark at the cursor.
See Bookmarks.

push_bookmark

Pop Bookmark

Pops the last bookmark. See
Bookmarks.

pop_bookmark

Set Bookmarks

Sets a persistent bookmark on the
current line. See Bookmarks.

set_bookmark

Go to Bookmark

Displays the Go to Bookmark dialog
from which you can select a
bookmark to navigate to. See
Navigating Named Bookmarks.

gotot_bookmark

Toggle Bookmark

Toggles setting a bookmark on the
current line. See Bookmarks.

toggle_bookmark

Bookmarks

Lists bookmarks and allows you to
add and delete bookmarks. See
Bookmarks.

activate_bookmarks

Next Bookmark

Go to next bookmark. See
Bookmarks.

next_bookmark

Previous Bookmark

Go to previous bookmark. See
Bookmarks.

prev_bookmark

Last Find/Grep List

Displays list of Files/Buffers
generated by Find commands.

grep_last

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Search menu items. Note
that default search options are also available (Tools > Options > Editing > Search). See Search Options
for a description of these settings.
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Find and Replace Tool Window
This tool window is displayed when you click one of the find or replace items on the Search menu, or when
you click View > Toolbars > Find and Replace. See Find and Replace for information about searching
and replacing in SlickEdit®.

The Find and Replace tool window contains a right-click context menu and four tabs: the Find Tab, the Find
in Files Tab, the Replace Tab, and the Replace in Files Tab.

Find and Replace Tool Window: Context Menu
Right-click in the background of the Find and Replace Tool Window to access the following items:
•

Saved Search Expressions - See Saving Search and Replace Values.

•

Configure Options - Displays the Search Options screen, from which you can set the default
search options that the tool window should use.

•

Use Default Options - If selected, the options specified in the Search Options are used instead of
the options selected in the Find and Replace tool window. See Default Search Options.

•

Clear All Options - Clears all options that are selected in the Find and Replace tool window.

•

Set Current Options as Default - If selected, the options that are selected on the tool window
replace the settings in the Search Options.

•

Hide/Show Tabs - Toggles the display of the tabs on the Find and Replace tool window.

•

Clear Highlights - Removes all highlighting from text that was highlighted during a search or
replace operation.

•

Allow Docking - If selected, the Find and Replace tool window can be docked.
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Find Tab
This tab on the Find and Replace Tool Window provides fields and options for searching and finding text.

•

Search for - Enter the string you want to search for here. You can retrieve previous search strings
by clicking the drop-down list button. Strings may be text or regular expressions and can include
wildcards. Note that ISPF search expressions cannot be used here.
Click the right-pointing arrow button to the right of the Search for field to display a menu
containing specific search syntax options such as Character in Range, Beginning of Line, and
Decimal Digit.

•

Look in - This field allows you to specify a range for your search to the current selection, current
procedure, current buffer or all buffers.

•

Search options - Click this button to expand or contract the search options section of the tool
window. When contracted, the options that are selected are summarized in this area.

•

Match case - If selected, a case-sensitive search is performed.

•

Match whole word - If selected, a word search is performed. Before a search is considered
successful, the characters to the left and right of the occurrence of the search string found are
checked to be non-word characters.
The default word characters are [A-Za-z0-9_$] and can be changed. To change these, from the
main menu click Tools > Options > Languages > [Language Category] > [Language] >
General. Enter your desired characters in the Word chars field.

•
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Use - Set this option to select one of the following types of search syntax from the drop-down list:
o

Regular expression (UNIX)

o

Regular expression (Brief)

o

Regular expression (SlickEdit®)
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o

Wildcards (*,?)

See Using Regular Expressions in SlickEdit® for more information.
•

Color - Displays the Color Coding Search Options dialog. This dialog lets you pick various
syntactic elements to filter a search. These are the same elements used by the Color Coding
engine. Using these filters helps to reduce the number of false positives you find in a search. Each
check box has three states:
o

Neutral (the default) - All check boxes start in the neutral state. These elements will be used
in a search until cleared or until one or more other elements are selected. Putting a check in
any check box essentially clears all non-checked boxes.

o

Selected - If the check box is selected, the search will be restricted to this element and any
other selected elements. There is no need to clear any other elements if any elements are
selected. If any elements are selected, only selected elements will be searched. For example,
to search for the word “result” only in comments, put a check only in the Comment check box.
All other syntactic elements will be ignored as part of this search.

o

Cleared - If the check box is clear, these elements will not be searched. For example, if you
want to find the word “result” anywhere in your code except for in comments, clear the
Comment check box.

Click the Reset button to mark all items as neutral.
NOTE Not all languages have all color coding elements defined. For example, dBase and Pascal do
not have preprocessing. Only C++ and Java have function color defined. Only HTML has attributes
(i.e. <img src=.>).
•

Wrap at beginning/end - If selected, the search will always be performed on the entire buffer,
starting from the cursor.

•

Place cursor at end - If selected, the cursor is placed at the end of the occurrence found.

•

Search backward - Select this option to have the search performed from the end to the beginning.

•

Search hidden text - Select this option to search for text hidden by Selective Display. Matches
found that were set to be hidden by Selective Display will be revealed. To set Selective Display
options, from the main menu click View > Selective Display. See Selective Display for more
information.

•

List all occurrences - Select this option to see a list of all instances of the search string in the file.
The Find tab expands to show the Results options, where you can specify the output destination.
These options are similar to the Results options on the Find in Files tab. See Find in Files Tab for
more information.

•

Highlight matches - Select this option to highlight all matched patterns in the current search
range. Highlight colors for these matches are customizable. To set this color, from the main menu,
click Tools > Options > Appearance > Colors and select Highlight from the Screen element
list. Choose your desired color settings and click OK. See Colors for more information.
To clear all highlighted text in all buffers, clear the Highlight matches option or simply close the
Find and Replace tool window.

•

Bookmark matches - Select this option to bookmark lines with matching patterns and display the
Bookmarks tool window when a match is bookmarked.

•

Incremental search - Select this option to search incrementally on patterns being typed into the
Search for field, showing the location of the match at the cursor. See Incremental Searching for
more information on this method of searching.
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•

Find button - Click this button when you have entered all desired search options and are ready to
initiate a search. If no matches are found, the Search for field will turn red, and the text String not
found will be displayed in the status area of the editor.

•

Find All button - Click this button to mark all matches in the current search range which have any
of the following options selected: Search hidden text, Highlight matches, and Bookmark
matches. If no matches are found, the Search for field will turn red, and the text String not found
will be displayed in the status area of the editor.

Find in Files Tab
This tab on the Find and Replace Tool Window provides the same functionality as the Find Tab, with the
added ability to conduct multi-file searches. Additional options are described below.
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•

Look in - This field allows you to specify a range for your search to the current selection, current
procedure, current buffer or all buffers.
Click the right-pointing arrow button to the right of the Look in field to display a menu containing
more specific range options such as Directory, Project, and All Buffers. From this sub-menu,
you may also select Append and choose an item for which to have the search results appended.

•

File types - Specifies one or more file types (extensions) to search for. Type in this field or use the
drop-down list to select the extensions desired. When a file title is specified in the Look in field,
the file types wildcards are ignored.

•

Exclude - Paths, files, or file types can be excluded from a multi-file search by specifying them
with wildcards or full path names. For examples of exclude patterns, see Exclusion Examples. No
files are searched in a path that is excluded, including any files in sub-directories beneath.

•

Look in subfolders - Select this option to expand the search to sub-directories of the folder
specified in the Look in field.

•

Results options - Click this button to expand or contract the Results options section of the tool
window. When contracted, the options that are set are summarized in this area.

•

Search Results window - This field allows you to send the search results to a specific Search
Results window. The window to be used can be selected from the drop-down list, and these are
labeled starting at Search<0>. A new results window can be added with the <New> option up to a
pre-set limit of open Search Results windows. If <Auto Increment> is selected, the search results
will cycle through all of the open Search Results tabs in the Search Results tool window with each
new search. See Search Results Output for more information.
Right-click in the Search Results window to access the following options:
o

Quick Search - Finds the next occurrence of the text selected.

o

Filter Search Results - Select this option to display the Filter Search Results dialog. From
here, if a match is found, you can choose to keep or delete lines with additional searches,
match case, limit to current default regular expression syntax and/or remove matches found
on the same line number in the same file (this can also be accomplished by selecting List
matching lines only from the Find in Files tab).

o

Open as Editor window - Opens current search results in a new editor window.

o

Go to Line - Goes to the file/line number of the current line in the Search Results window.

o

Bookmark Line - Places a bookmark at the line in the file where the result was found.

o

Clear Window - Clears all results in the current Search Results window.

o

Align Columns - Aligns the line numbers and column numbers for all search results.

o

Collapse All - Collapses all Selective Display levels. See Selective Display for more
information.

o

Expand All - Expands all Selective Display levels. See Selective Display for more information.

•

Output to editor window - If selected, search results are sent to an editor window.

•

Append to output - Select this option to append search results to the search results window that
is in focus.

•

List filenames only - If selected, only file names and not occurrences are listed in the search
output.

•

List matching lines only - Selecting this option will display only one line in the search results
window for each line containing one or more matching patterns on the same line, and will highlight
all matching patterns.

SlickEdit® User Guide

545

SEARCH

•

•

Foreground search - If selected, activates the three range options listed below. This option offers
slightly better performance than a background search, but prevents you from continuing to work
while the search is being performed. The default search for SlickEdit® is background searching
unless this option is selected.
o

Prompted - When this option is selected, you are prompted whether to continue searching
when an occurrence is found.

o

Single - When this option is selected, your cursor is placed on the first occurrence found, but
the remaining files are not searched.

o

Global - When this option is selected, all files are searched for occurrences without prompting.

Stop button - Click Stop to terminate a multi-file, background search. Press Esc to terminate a
long foreground search.

Replace Tab
This tab on the Find and Replace Tool Window provides options for searching and replacing text. The
same search options from the Find Tab are provided, as well as the additional replace options described
below.

•

Replace with - Enter the text or regular expression for which to replace the item that is searched.
You can retrieve previous replacement text or regular expressions by clicking the drop-down list
button.
Click the right-pointing arrow button to the right of the Replace with field to display a menu
containing tagged expressions. See Using Tagged Expressions for more information.

•
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Preserve case - Select this option to perform a case-sensitive search and replace operation.
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•

Highlight replaced text - Select this option to highlight all instances of the text that was replaced.

•

Replace button - Click to replace the first instance of the item.

•

Replace All button - Click to replace every instance of the item.

•

Preview All button - Click to show a side-by-side comparison of the original file and the file with
replacements made. This lets you see the changes and confirm them before committing the
changes to the file.

TIP You can use the menu items Edit > Undo and Edit > Redo to undo/redo replacements.

Replace in Files Tab
This tab on the Find and Replace Tool Window provides the same functionality as the Replace Tab, with
the added ability to conduct multi-file replacements. It contains one additional option, described below.
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•

Leave modified files open - Select this option to open all of the files on which a replace has been
performed.

The Results options are the same as those on the Find in Files Tab.
TIP You can use the menu items Edit > Multi-File Undo and Edit > Multi-File Redo to undo/redo
replacements in multiple files.
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Find Symbol Tool Window
The Find Symbol tool window is used to locate symbols in your code. It allows you to search for symbols
by name using either a regular expression, substring, or fast prefix match. The tool window is displayed
when you click Search > Find Symbol or View > Toolbars > Find Symbol, or when you use the
gui_push_tag command.
See Find Symbol Tool Window under the Symbol Browsing topic for more information.

•

Search for - Enter the name of the symbol to find. If you select the option Use pattern, you can
enter regular expressions or wildcards in the search field. If you specify <Use Context Tagging®>
for the Look in field, then you can enter language-specific expressions, such as "this->get" to find
getters in your current class. SlickEdit® displays a progress bar at the top of this tool window while
a search is in progress.
Incremental matches are displayed with each character you type, and the first element in the list is
selected. Press Tab to put focus into the list of matches. Press Enter to navigate to the first match.
Press Down to select the next match. Press Escape to stop the search.

•

Symbol List - The list of search results are refreshed as you type the search string. They include
the symbol name, the file that contains it, and the line number. You can sort by any of the three
columns.
The selected match is highlighted and is displayed in the Preview tool window. Single-click or use
the arrow keys to select a match. Double-click or press Enter to navigate to that match.

•

Look in - Use this control to specify the scope of the symbol search. The options are:
o

<Use Context Tagging®> - This is the default setting. It uses Context Tagging to intelligently
determine which tag files to search.

o

<Current File> - Select this setting to only search the tags in the current file, including local
variables in the current function scope.
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•

•

o

<Current Project> - Select this setting to only search in files that are in the current project.

o

<Current Workspace> - Select this setting to only search in files that are in the current
workspace.

o

<Language Tag Files> - Select this setting to search all language-specific tag files for the
indicated extension. This may also include your workspace tag file.

o

Specific tag files - Select one of the specific tag files listed to limit search to that file.

o

<All Tag Files> - Select this setting to search all tag files for all languages.

Search Options - The search options can be expanded or collapsed to save space.
o

Match case - When selected, SlickEdit uses a case-sensitive search to find symbol matches.
When this option is not selected, SlickEdit uses a case-insensitive search. When this option is
in the neutral (mixed) state, SlickEdit first searches for case-sensitive matches, and if none are
found, attempts to perform a case-insensitive search. Note that for case-insensitive
languages, this may have no effect.

o

Match substring (slower) - When selected, SlickEdit searches for the specified string within
the available symbols. For example, finding all symbols containing the word “order,” not just
those that begin with “order.” Selecting this option causes the search to execute more slowly.

o

Use pattern (slower) - When selected, SlickEdit interprets the search string as a regular
expression or wildcard expression. This can result in slower search times, since SlickEdit must
test every symbol in the tag file against the regular expression.

o

Filters - Use filters to restrict the search to certain types of symbols. The filters are the same
the ones available on the Definitions tool window. See Defs Tool Window for more information.

Buttons - The following buttons are located at the bottom of the tool window:
o

Go to definition - Navigates to the definition of this symbol in the editor window. If the
programming language allows for separate declaration and definition, you can control which is
selected by using the language-specific Context Tagging® options screen (Tools > Options >
Languages > [Language Category] > [Language] > Context Tagging®): Select either Go
to Definition navigates to symbol definition (proc) or Go to Definition navigates to
symbol declaration (proto). See Code Navigation for more information.

o

Go to reference - Displays a list of references for the selected symbol in the References Tool
Window and, optionally, navigates to the first reference. Click Tools > Options > Editing >
Context Tagging® Options and check the option Go to Reference only lists references if
you just want to build the list of references. See Code Navigation for more information.

o

Show in symbol browser - Displays the selected symbol in the Symbols Tool Window. Note
that this feature does not work for local variables or symbols from the current file that are not in
a tag file.

o

Manage tag files - Displays the Context Tagging® - Tag Files Dialog, which can be used to
update your tag files.

Bookmarks Tool Window
The Bookmarks tool window is used to create and manage Named Bookmarks. To display the tool window,
from the main menu, click Search > Bookmarks. You can also press Ctrl+Shift+N or use the
activate_bookmarks command to display the window.
NOTE The Bookmarks tool window does not work with Pushed Bookmarks. To view a list of pushed
bookmarks, use the Bookmark Stack Dialog.
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See Toolbars and Tool Windows for information about working with tool windows. See Tabular Lists for
information about resizing columns and other layout information.
TIPS
•

Global named bookmarks are shown in the Bookmarks tool window, unless the option Use
workspace bookmarks is enabled (Tools > Options > Editing > Search). In this case,
only bookmarks for the current workspace are shown. See Using Workspace Bookmarks for
more information.

•

If you activate the Bookmarks tool window and start typing the name of a bookmark,
SlickEdit attempts to match it. This provides a fast and easy way to jump to a named
bookmark. Using the preceding screen shot as an example, you could press Ctrl+Shift+N to
activate the tool window, type “i” to select the bookmark named “inventory.css:65”, then
press Enter to quickly go to the bookmark’s location in your code.

The Bookmarks tool window can be used to perform the following operations:
•

Jump to bookmark - To go to the line in your source code that contains a bookmark, double-click
on a bookmark in the tool window. Alternately, select the bookmark to jump to, then select Go to
Bookmark from the right-click context menu or press the Enter key. See Navigating Named
Bookmarks for more navigation methods.

•

Create new bookmark - To create a new, named bookmark on the current line, click the Create
New Bookmark button, or select this operation from the window’s right-click context menu. You
can also press the Insert key (with the focus in the tool window). A dialog is displayed where you
can specify a name for the bookmark or allow automatic naming (see Setting a Bookmark With an
Automatic Name). Each new bookmark is placed at the top of the list in the Bookmarks tool
window.

•

Delete all bookmarks - To delete all named bookmarks, click the Delete All Bookmarks button,
or select this operation from the window’s right-click context menu. You can also press
Shift+Delete to delete all bookmarks. A confirmation prompt is displayed prior to deletion. See
also Deleting Named Bookmarks.

•

Delete selected bookmark - This operation is also available as a button on the tool window and
on the window’s right-click context menu. You can also press the Delete key to delete the selected
bookmark. See also Deleting Named Bookmarks.

•

Go to previous bookmark and Go to next bookmark - Use these two buttons to navigate to the
previous and next bookmark in your source code, respectively. The order of navigation matches
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the order in which the bookmarks were created, regardless of any selection in the tool window.
See Navigating Named Bookmarks for more information.

Go to Bookmark Dialog
The Go to Bookmark dialog appears automatically when you use the gb or goto_bookmark command
without arguments. It can be used to view, navigate to, and delete Named Bookmarks.
NOTE The Go to Bookmark dialog does not work with Pushed Bookmarks. To view a list of pushed
bookmarks, use the Bookmark Stack Dialog.

See Tabular Lists for information about resizing columns and other layout information.
The Go to Bookmark dialog displays the same information as the Bookmarks Tool Window, except it does
not provide a way to create bookmarks.
TIP Global named bookmarks are shown in the Go to Bookmark dialog, unless the option Use
workspace bookmarks is enabled (Tools > Options > Editing > Search). In this case, only
bookmarks for the current workspace are shown. See Using Workspace Bookmarks for more
information.
The following operations are available:
•

To go to the line in your source code that contains a bookmark, double-click on the bookmark in
the dialog. Or, select the bookmark to jump to and press the Enter key or click OK. The Go to
Bookmark dialog is dismissed after this operation.
Prior to jumping to the bookmark, SlickEdit® automatically creates a pushed bookmark at the
current location in your source code, so you can return to the current location easily by popping the
bookmark with Ctrl+Comma. See Pushed Bookmarks for more information.

•

To delete a bookmark, select it and press the Delete key or click Delete. See also Deleting Named
Bookmarks.

Bookmark Stack Dialog
The Bookmark Stack dialog can be used to view, navigate to, and delete Pushed Bookmarks. To display it,
from the main menu, click Search > Bookmark Stack, or use the bookmark_stack command.
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See Tabular Lists for information about resizing columns and other layout information.
The first column in the Bookmark Stack dialog (labeled No.), indicates the numerical order of each
bookmark in the stack, according to when the bookmark was pushed. New pushed bookmarks are always
placed at the top of the stack, so you can pop them off one by one with Ctrl+Comma as you make your
way back through the code. See Pushing and Popping Bookmarks for more information.
Popping bookmarks is the best way to navigate through your pushed bookmarks, deleting them in the
process. However, you can also use the Bookmark Stack dialog to navigate to pushed bookmarks or
delete a pushed bookmark:
•

To go to the line in your source code that contains a pushed bookmark, double-click on the
bookmark in the dialog. Or, select the bookmark to jump to and press the Enter key or click OK.
The Bookmark Stack dialog is dismissed after this operation. Prior to jumping to the bookmark,
SlickEdit® automatically creates a new pushed bookmark at the current location and places it on
top of the stack.

•

To delete a pushed bookmark, select it and press the Delete key or click Delete. The order of the
stack is still maintained, indicated by the numbers in the No. column.

Bookmarks Dialog
The Bookmarks dialog can be used to set Named Bookmarks. It appears when you click Search > Set
Bookmark from the main menu, or use the set_bookmark (or sb) command without arguments. See
Setting Named Bookmarks for more information.
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TIP Global named bookmarks are shown in the Bookmarks dialog, unless the option Use
workspace bookmarks is enabled (Tools > Options > Editing > Search). In this case, only
bookmarks for the current workspace are shown. See Using Workspace Bookmarks for more
information.
When the dialog appears, the name field is prepopulated with an automatic name (see Setting a Bookmark
With an Automatic Name). You can use the automatic name, or type over it to name the bookmark
yourself. Use the drop-down list to select a previously used name. Click Add to set the new bookmark.
The box below the bookmark name field shows a list of your current named bookmarks. It shows the
name, path and file name, line number, and the text of the bookmarked line. Use your keyboard navigation
keys to move up and down in the bookmark list. Press Enter to jump to the selected bookmark.
The buttons on the Bookmarks dialog are described as follows:
•

Add - Used to set a new bookmark. The Add button changes to a Replace button if you select a
bookmark in the list. When you click Replace, a new bookmark is set with the name of the
selected bookmark, so you can have multiple bookmarks with the same name but at different
locations in your code.

•

Close - Cancels the operation and closes the dialog.

•

Go To - Navigates to the selected bookmark in the source code.

•

Delete - Deletes the selected bookmark.

Go to Definition Dialog
The Go to Definition dialog (gui_find_proc command) was used to navigate to symbols in previous
versions. This functionality has been replaced with the Find Symbol Tool Window.
For more information about navigating between symbols, see Code Navigation.
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View
This section describes items on the View menu and associated dialogs and tool windows. For more
information, see Viewing and Displaying.

View Menu
The View menu contains options that pertain to viewing and displaying special characters, code, and
toolbars.
View Menu Item

Description

Command

Hex

Toggles hex/ASCII display. See Hex
Mode Editing.

hex

Line Hex

Toggles line hex/ASCII display. See
Hex Mode Editing.

linehex

Special Chars

Toggles viewing of tabs, spaces, and
new line character(s) on/off. See
Viewing Special Characters.

view_specialchars_toggle

New Line Chars

Toggles viewing of new line
character(s) on/off. See Viewing
Special Characters.

view_nlchars_toggle

Tab Chars

Toggles viewing of tab character(s)
on/off. See Viewing Special
Characters.

view_tabs_toggle

Spaces

Toggles viewing of space character(s)
on/off. See Viewing Special
Characters.

view_spaces_toggle

Line Numbers

Toggles the display of line numbers
on/off for the current document. See
Viewing Line Numbers.

view_line_numbers_toggle

SoftWrap

Toggles wrapping of long lines to
window width.

softwrap_toggle

Toolbars

Show, hide, or customize a toolbar or
tool window. See Toolbars and Tool
Windows.

toolbars

Fullscreen

Toggles full screen editing mode. See
Full Screen Mode.

fullscreen

Selective Display

Displays the Selective Display dialog,
which allows you to hide lines and
create an outline. See Selective
Display.

selective_display

Hide All Comments

Hides all lines that only contain a
comment.

hide_all_comments
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View Menu Item

Description

Command

Hide Code Block

Hides lines inside current code block.
See Expanding/Collapsing Code
Blocks.

hide_code_block

Hide Selection

Hides selected lines.

hide_selection

Hide #region Blocks

Hides .NET #region blocks.

hide_dotnet_regions

Function Headings

Collapses all function code blocks in
the current file. See Selective Display.

show_procs

Expand/Collapse Block

Toggles between hiding and showing
the code block under the cursor. See
Expanding/Collapsing Code Blocks.

plusminus

Copy Visible

Copies text not hidden by Selective
Display. See Selective Display.

copy_selective_display

Show All

Ends selective display. All lines are
displayed and outline bitmaps are
removed. See Selective Display.

show_all

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with View menu items.

Selective Display Dialog
The Selective Display dialog (View > Selective Display or selective_display command) allows you to
activate Selective Display and choose the regions in your code that you want to display or hide. Each
region contains settings that are specific to that region. The dialog also contains static options for
expanding. See Selective Display for more information about working with this feature.
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Search Text
Select Search text to specify a search string and display lines containing the search string specified or
lines not containing the search string specified. Click the right-pointing arrow button to the right of the field
to display a menu containing specific search syntax options such as Character in Range, Beginning of
Line, and Decimal Digit. The following settings are available:
•

Match case - When checked, a case sensitive search is performed.

•

Match whole word - When checked, a word search is performed. Before a search is considered
successful, the characters to the left and right of the occurrence of the search string found are
checked to be non-word characters. The default word characters are [A-Za-z0-9_$] and may be
changed by using the Word chars field on the language-specific General options screen (see
General Language-Specific Options).

•

Regular expression - When checked, a regular expression search is performed. See Find and
Replace with Regular Expressions for more information.

•

Reset selective display - When checked, all lines are made visible and Plus and/or Minus
bitmaps are removed before a search is performed.

•

Hide matched lines - When checked, lines containing the search pattern are hidden.

Function Headers
Select Function headers to display only function headings and optional function heading comments. The
following settings affect how comments before function headings are handled:
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•

Show comments - When checked, comments above function headings are displayed as if they
were part of the function heading.

•

Collapse comments - When checked, comments above function headings are visible but multiline comments will require that you expand them to see all comments.

When both options are off, comments will not be visible at all, making it difficult to copy or move functions
and comments.

Preprocessor Directives
Select Preprocessor directives to display a source file as if it were preprocessed according to the define
values you specify. If you do not remember your defines, use the Scan for Defines button. The following
settings are available:
•

Defines - Specifies defines and optional values used when you select the Preprocessor
Directives option on the Selective Display dialog box. The syntax is:
name1[=value1] name2[=value2]
For example:
WIN32S VERSION=4

•

Warning if Not Defined - If on when you preprocess your source, a message box is displayed for
each define found in an expression which does not have a value.

•

Scan for Defines - Searches for define variables in the current source file and lets you specify
values. Resulting values are placed in the Defines combo box.

Multi-Level
Select Multi-level to set multiple levels of selective display based on braces or indent. The following
settings are available:
•

Braces - When on, multiple levels of selective display are set to correspond to curly brace nesting
levels.

•

Indentation - When on, multiple levels of selective display are set to correspond to indentation
levels.

•

Limit levels - When too many nested levels of selective display get confusing, place a limit on the
maximum number of nested levels. Nesting deeper than this specified level is ignored.

Paragraphs
Select Paragraphs to display the first line of each paragraph. A paragraph is defined by a group of lines
followed by one or more blank lines.

Hide Selection
Select Hide selection to hide the lines in the current selection.

Expansion Options
The following expansion options can be applied for each region:
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•

Expand sub-levels - When on, expanding hidden lines expands all nested hidden lines.

•

Collapse sub-levels - When on, expanding hidden lines collapses all nesting hidden lines.

•

Remember sub-levels - When on, expanding hidden lines displays nested hidden lines the way
they were last displayed.
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Toolbar Control Properties Dialog
To change a button’s command binding, on the actual toolbar or tool window, right-click on any control and
select Properties. This will display the Toolbar Control Properties dialog, shown below. Note that the
Properties option is only available for controls that can be modified.

The following options are available:
•

Command - Specifies the command that the button is bound to. Use the drop-down arrow to pick
from a list of commands. Use the right-pointing arrow to insert special escape sequences for a file
name, line number, or word.

•

Message - Use this text box to enter the tool tip message that should appear when hovering the
mouse over the button.

•

Bitmap - Specifies the bitmap that will be used for the button. Click the drop-down arrow to display
an Open dialog in order to specify an alternate bitmap. This option is only available for graphical
controls.

•

Caption - Specifies the text that appears on the button for text-only controls (like the Sample
Button).

•

Auto Enable - Displays the Auto Enable Properties dialog, which allows you to enable/disable
predefined attributes. See Auto Enable Properties Dialog for more information.

•

Bind to Key - Displays the Key Binding Options so that you can create a key binding for this
command.
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This section describes items on the Project menu and associated dialogs and tool windows. For more
information, see Workspaces and Projects.

Project Menu
The Project menu contains operations and options for working with projects and workspaces. The table
below contains a summary of these items.
Project Menu Item

Description

Command

New

Allows you to create a workspace
and/or project.

workspace_new

Open Workspace

Opens a workspace.

workspace_open

Open Other Workspace

Displays menu for open projects,
workspaces, or makefiles from other
tools. See Open Other Workspace
Menu.

N/A

Close Workspace

Closes the current workspace.

workspace_close

Organize All
Workspaces

Allows you to organize your
workspaces which appear in the All
Workspaces menu.

workspace_organize

Workspace Properties

Displays the Workspace Properties
dialog, which allows you to add/
remove projects from the current
workspace. See Workspace
Properties Dialog.

workspace_properties

Add New Item from
Template

Adds new template file to the existing
project.

project_add_item

Open Files from Project

Allows you to open files from the
current project. See Files Tool
Window.

project_load -p

Open Files from
Workspace

Allows you to open files from the
current workspace. See Files Tool
Window.

project_load

Insert Project into
Workspace

Adds an existing project to the current
workspace. Use the Workspace
Properties dialog box to remove a
project from the current workspace.

workspace_insert

Dependencies

Displays the Project Properties dialog
open to the Dependencies tab, which
lets you set the dependencies for the
active project. See Dependencies
Tab.

workspace_dependencies
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Project Menu Item

Description

Command

Set Active Project

Allows you to set the active project

projecttbSetCurProject

Project Properties

Displays the Project Properties dialog,
which is used to edit settings for the
current project. See Project
Properties Dialog

project_edit

Open Other Workspace Menu
The Project > Open Other Workspace menu contains options for opening projects, workspaces, or
makefiles from other tools. The table below contains a summary of these items.
Open Other Workspace
Menu Item

Description

Command

Visual Studio .NET
Solution

Open a Visual Studio .NET Solution.

workspace_open_visualstu
dio

Visual C++ Workspace

Open a Visual C++ Workspace.

workspace_open_visualcp
p

Visual C++ Embedded
Workspace

Open a Visual C++ Embedded
Workspace.

workspace_open_visualcp
pembedded

Tornado Workspace

Open a Tornado Workspace.

workspace_open_tornado

Ant XML Build File

Open an Ant XML Build File.

workspace_open_ant

Makefile

Open a Makefile. See Open Makefile
as Workspace Dialog.

workspace_open_makefile

JBuilder Project

Open a JBuilder® Project.

workspace_open_jbuilder

Xcode Project

Open a Xcode Project.

workspace_open_xcode

Flash Project

Open a Flash Project.

workspace_open_flash

Workspace from CVS

Checkout and open a workspace from
CVS.

cvs_open_workspace

Convert CodeWright
Workspace

Convert a CodeWright workspace and
projects to SlickEdit workspace and
projects.

cwprojconv.e

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Project menu items.

Workspace Properties Dialog
To list projects in the current workspace, add or remove projects from the current workspace, or to set the
active project, use the Workspace Properties dialog box. The dialog, pictured below, can be accessed from
the main menu by clicking Project > Workspace Properties.
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The following options are available:
•

Properties - Displays project properties for the selected project.

•

New - Allows you to add a new project to the current workspace.

•

Add - Allows you to add an existing project to the current workspace.

•

Remove - Removes the selected project from the workspace.

•

Set Active - Sets the selected project active.

•

Environment - Displays the Workspace Environment Options dialog box, allowing you to set
environment variables. For more information on setting environment variables, see Environment
Variables.

Project Properties Dialog
The Project Properties dialog, shown below, is used to manage and edit many settings for the current
project. To access this dialog, click Project > Project Properties or use the project_edit command. You
can also right-click within the Projects tool window and select Project Properties.
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Click and drag the dialog box’s edges to resize it. Both the size and position of the dialog are remembered
between editing sessions. The buttons on the Project Properties dialog are described below (see Project
Properties Dialog - General Options). Other options are categorized into the following tabs. Click on an
item to go to that section in the documentation.
•
•
•
•
•
•
•

Files Tab
Directories Tab
Tools Tab
Build Tab
Compile/Link Tab
Dependencies Tab
Open Tab

Project Properties Dialog - General Options
The following options are available at the top of the dialog:
•
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Settings for - Allows you to select which configuration to modify. The All Configurations option
allows you to change the settings for all the configurations. All settings in the Project Properties
dialog are per configuration except the working directory, open command, and filters.
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•

Configurations - Click this button to view, add, or delete configurations. See Project
Configurations for more information.

Files Tab
The Files tab of the Project Properties dialog (Project > Project Properties) is shown below, and displays
a list of the files in the current project and also allows you to remove files from projects.

The following buttons are available:
•

Add Files - Adds one or more existing files from a single directory to the project.

•

Add Tree - Prompts for one or more wildcard file specifications separated with semicolons
(*.c;*.cpp;*.h) and searches through a directory tree adding the files that are found to the
project. To search directories recursively, select the Recursive option.

•

Add Wildcard - Adds one wildcard filespec to the project. For example, you could add a wildcard
such as *.java to your project. You will get duplicate entries if you repeat wildcards or add files
that are already included by a wildcard.

•

Invert - Inverts the selected items in the Project files list box.

•

Remove - Removes selected items from the project.
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•

Remove All - Removes all files from the project.

•

Refresh - Provides an easy way to remove files that do not exist from the project.

•

Properties - Only checked when the current file has wildcard characters. Displays various
supported options for a wildcard specification.

Directories Tab
The Directories tab of the Project Properties dialog box (Project > Project Properties), shown below,
allows you to set the working directory, references file, and include file search directories for the current
project.

The following information describes the available fields and settings:
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•

Working directory - When a project is set active, the current directory is set to the working
directory (if specified). This information is stored per project and not per configuration. Click the
button to the right of this field to browse for and specify an alternate working directory.

•

References file - You only need to complete this text box if you are using Microsoft Visual C++
and you prefer to use a Visual C++ .bsc database file instead of the Context Tagging® database
when viewing references. If you open a Visual C++ v5.0 or later workspace and you have
configured Visual C++ to generate a .bsc database file, this field is automatically configured.
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•

Includes - Specifies the directories the cursor_error (Alt+1) and next_error (Ctrl+Shift+Down)
commands will search when trying to open a file. For COBOL and High Level Assembler, this list of
directories is used to find copy books or macros. You might want to add some of your own include
directories here before the compiler’s include directories. You can specify environment variables
with the syntax %(EnvVarName) (see Environment Variables). Click the button to the right of this
field to browse for an include directory to specify. Use the up and down arrows to move the
includes up or down in the list.

Tools Tab
The Tools tab of the Project Properties dialog box (Project > Project Properties) is used to change
project commands and their properties.

The following options are available:
•

Tool name - Contains a list of the tools/commands that can be used for projects in SlickEdit®. You
can have different tools for different projects. The options on the Tools tab vary, depending on the
tool name that is selected in the Tool name text box.
Use the Up and Down arrows to move the tools up and down in the list. This order corresponds to
the order in which the tool appears on the Build menu. Click the Delete button (displayed as a red
“X”) to remove a user-defined tool (default tools cannot be deleted).
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•

New - Click the New button to add a tool.

•

Advanced - Click the Advanced button to change environment variables (see Environment
Variables).

•

Options - Displays an Options dialog box specific to the language with which you are currently
working. This button is only available for selected tools that support the language-specific options.
For more information, see Language Options.

•

Command line - Defines the command line that is set to be executed for the selected tool in the
Tool name combo box. This text box is only available (and visible) for selected tools that support a
command line execution. Click the buttons to the right of this text box to insert files and escape
sequences (such as %f which inserts the current buffer name) that you can use to build your
command line.

•

Run from dir - Specifies the directory from which to run selected tool command. By default, all of
the tools are run from the working directory that is specified using the %rw or %rp escape
sequences, which indicate the working directory or project directory, respectively. When running
programs like ant or make, this is typically set to the directory containing the makefile.

•

Capture output - Captures and processes the output of the command with SlickEdit’s built-in error
message processing facility. When the output is captured, the commands next_error
(Ctrl+Shift+Down or Build > Next Error) and prev_error (Ctrl+Shift+Up or Build > Previous
Error) are used to go to the next and previous compilation error positions respectively.

NOTE (UNIX only) Output of text mode programs that are executed using xterm cannot be
captured. To see the output, uncheck the Output options Capture output and Output to build
window, then prefix the program name in the Command line field with xterm -e or dos -w (this
waits for a key press).
•
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Output to build window - Specifies that the output of the command be run in the concurrent build
window. The concurrent build window has the following limitations:
o

You cannot run graphical applications in the concurrent build window.

o

Only programs that use standard in and standard out to read and write data can run in the
concurrent build window. This is true for most compilers.

o

Some programs which use standard in and standard out will not run properly in the concurrent
build window because they use ANSI escape sequences or do not flush standard output data
before prompting for input.

o

For Windows 2000, alternate command shells are not supported. Only cmd.exe is supported.

•

Clear build window - Clears the build window output before the command is executed. The
Output tool window displays the results of the processes that are run.

•

Save none - Saves no files before the command is executed.

•

Save current file - Saves the current file before the command is executed.

•

Save all files - Saves all files before the command is executed.

•

List modified files - Displays a selection list of modified files, which allows you to choose files to
save before the command is executed.

•

Save workspace files - Saves modified workspace files before the command is executed.

•

Always show on menu - Always shows the command on the Build menu.
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•

Hide if no command line - Hides the menu item if the command line is blank. This is useful for
saving space on the Build menu for blank command lines.

•

Never show on menu - Never shows the command on the Build menu.

•

Application type - Used to indicate the type of application as which a Java project should be
executed. This primarily affects the Execute and Debug commands for Java applets and j2me
projects.

•

Menu caption - Defines the menu item text which appears on the Build menu. Prefix the selection
character with an ampersand (&) to choose the selection character. If you have run out of selection
letters, try using numbers. For example, “&1MyTool” picks “1” as the selection character.

•

Build first - Executes the build command before the selected tool/command. If the build
completes with a non-zero return code, this command is not executed. This option requires the
use of the vsbuild utility (see Using VSBUILD to Compile) and will not work for build commands
that do not return a valid return code. If the build command returns a zero return code, the
command is executed even if the build actually failed.

NOTES
•

Windows: For commands which will not execute in the concurrent build window, prefix
the command with start (for example: start debug\myprogram.exe).

•

UNIX: If the build command is a shell script, make sure it returns a zero return code for
a successful build and a non-zero return code for an unsuccessful build. For commands
which will not execute in the concurrent build window, prefix the command with
xterm –e (for example: xterm –e debug/myprogram).

•

Command is Slick-C macro - Specifies that the command line is a Slick-C® macro as opposed to
an external program.

•

Verbose output - Specifies that the vsbuild utility is used to build the projects (see Using
VSBUILD to Compile). Detailed information about the commands that are executed will be output
during the build.

•

Beep on completion - Specifies that the vsbuild utility is used to build the projects and to sound
a status beep upon completion (see Using VSBUILD to Compile). A single beep indicates a
successful build. Two beeps indicate an error occurred.

•

Run in an X terminal - (UNIX only) Runs the command in an X terminal. This is useful for running
programs which are full screen console applications such as vi.

Build Tab
The Build tab of the Project Properties dialog (Project > Project Properties), pictured below, allows you
to run programs and/or execute commands before or after a build. You can run different programs and
commands for different projects as the information is stored per-configuration. The contents of this tab are
unavailable for extension-based projects.
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The list below describes the settings that are available. For more in-depth information, see Build System
Options.
•

Pre- and Post-Build Commands - Each line can contain a program to execute a command. For
example, the set command could be used to set environment variables. Double-click on the text
as indicated in the text boxes to add commands. Use the Up and Down arrows to the right of the
text boxes to move the commands up and down in the list. The order corresponds to the order in
which the command will be run.

•

Stop on error - When this option is checked and the current project depends on other projects,
the vsbuild utility (see Using VSBUILD to Compile) will be used to build the projects and check for
error codes. When the vsbuild program detects an error, it does not continue building other
dependencies.

NOTE (Windows only) Under Windows 95 or later, vsbuild cannot detect error codes returned from
a batch program.
•
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Build System Options - These build methods apply to GNU C/C++ projects only and affect all
configurations. With these options, you will not need to convert the current build methods to use
the GNU debugger; you can select one of these methods when you create a new GNU C/C++
Wizard project.
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o

Build without a makefile (dependencies automatically checked) - Automatically checks
dependencies and does not generate a makefile. Instead, the vsbuild utility (see Using
VSBUILD to Compile) determines what should be compiled dynamically. This option is useful
when you are not concerned with how the build gets done. Make sure the project include
directories are set up correctly (Project > Project Properties, select the Directories Tab) so
include files may be found.

o

Build with a user-maintained makefile or custom build command - Sets the build
command to make and does not generate a makefile. The build command can be changed
from the Tools tab of the Project Properties dialog box (see Tools Tab). Select this option
when you already have your own method for building the source.

o

Build with an auto-generated, auto-maintained makefile - Automatically generates a
makefile and updates when files are added to the project. This option is useful when you need
a makefile and do not want to use the built-in vsbuild utility (see Using VSBUILD to Compile).
Specify the path to the makefile in the Makefile field. Make sure the project include directories
are set up correctly (Project > Project Properties, select the Directories Tab) so include files
may be found.

To start a build from outside the application, execute the following command where make is the
name of the make program, Makefile is the name of the makefile, and ConfigName is the name of
the configuration: make -f Makefile CFG=ConfigName.

Compile/Link Tab
The Compile/Link tab of the Project Properties dialog (Project > Project Properties), shown below, is
used to specify project compilation and linking options.
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The following settings are available:
•

Compiler - By default, the compiler configuration is set to the active compiler tag file based on the
active project. To change the compiler or its configuration and properties, click the arrows to the
right of the Compiler field. See C/C++ Compiler Settings for more information.

•

Defines - Defines listed here can be used in build commands as %defs. Double-click as indicated
to add a define. Click the /D button to enter a macro. Click the /U button to undefine a macro.
Defines that set in an associated project are listed in bold and can not be modified here.

•

Libraries/Objects - Libraries and objects listed here can be used in build commands as %libs. To
add libraries and objects, click the button to the right of this field. This displays the Link Order
dialog box. The <ProjectObjects> marker indicates where all remaining object files produced by
the project will appear in the list of libraries and objects. Use the arrows to the right of the text box
to move the libraries/objects up and down in the list, or use the red X button to remove a library or
object.

Dependencies Tab
The Dependencies tab on the Project Properties dialog (Tools > Project Properties), pictured below,
allows you to define a relationship between two projects, causing the dependent project to be built after the
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projects it depends on. This ensures that elements in a depended-on project are up-to-date prior to
building the dependent project. See Defining Project Dependencies for more information.

Open Tab
The Open tab of the Project Properties dialog (Project > Project Properties) lets you enter commands
that are executed when the project is activated. This information is stored per project, not per
configuration. This tab is unavailable for extension-based projects. For instructions on entering commands
on this tab, see Specifying Open Commands.

Add Tree Dialog
The Add Tree dialog is used to add files in a directory or directory tree to a tag file or a project. It also gives
you the ability to use wildcards so that you can add only files with certain extensions.
This dialog is displayed when you click the Add Tree button on the Context Tagging® - Tag Files Dialog or
the Files Tab of the Project Properties dialog.
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The dialog contains the following elements:
•

File types - The File types combo box lets you select from predefined wildcard specifications or
you can type your own. Each file spec should be separated with semicolons (*.c;*.cpp;*.h). For
example, to include only Java files, select *.java from the predefined list. To include all files in a
directory, type the wildcard *.

•

Directory list - The directory list box lets you pick the directory from which to include files.

•

Drives - Select the disk drive to look in.

•

Exclude - Use this combo box to exclude paths, files, or file types from the specified directory
using wildcards. For examples, see Exclusion Examples below.

•

Recursive - If checked, the selected directory will be searched recursively.

Exclusion Examples
The table below shows some examples of filespec exclude patterns that you can use in various Exclude
combo boxes within SlickEdit®.
Example
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Description

*math*.cpp

Exclude any .cpp with “math” in the file name.

readme.txt

Exclude all files named readme.txt.

*.a

Exclude any file with extension .a.

*\CVS\

Exclude any files in paths named “CVS”.

/home/build/debug

Exclude all files in this path name.
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Example
*demo*

Description
Exclude any file or path with “demo” in the name.

Open Makefile as Workspace Dialog
The Open Makefile as Workspace dialog is used to import makefiles. To display it, from the main menu,
click Project > Open Other Workspace > Makefile (or use the workspace_open_makefile command).
See Importing Makefiles for more information about using this feature.

The dialog contains the following:
•

Makefile - Specifies the makefile. Use the Browse button

•

Scan for recursive makefile calls - When selected, SlickEdit scans the makefile for invocations
of make on other makefiles and includes the referenced files in the new project.
o

to browse for the makefile.

Make recursive makefile calls separate projects - When this option is selected, if Scan for
recursive makefile calls is enabled, and if the makefile contains invocations of make on other
makefiles, a new, separate project is created for each of the referenced makefiles. When this
option is cleared, SlickEdit creates only one project that includes all of the files found in all of
referenced makefiles.

•

File types - Specifies the file types to include. Use the drop-down arrow to populate this field or
type a list of file types separated with semicolons.

•

Exclude - Specifies the file types to exclude. Use the drop-down arrow to populate this field or
type a list of file types separated with semicolons.
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Build
This section describes items on the Build menu. Currently, the section Building and Compiling contains all
of the information about building and the dialogs and options that are available.

Build Menu
The Build menu is language-specific and can have alternate options depending on the language in which
the project is written.
Build Menu Item

Description

Command

Next Error

Processes the next compiler error
message.

next_error

Previous Error

Processes the previous compiler error
message.

prev_error

Go to Error or Include

Parses the error message or file
name at the cursor and places cursor
in file.

cursor_error

Clear All Error Markers

Removes all error markers in all files.

clear_all_error_markers

Configure Error Parsing

Configures regular expressions used
to search for compiler messages. See
Parsing Errors with Regular
Expressions.

configure_error_regex

Stop Build

Sends break signal to the Build tool
window.

stop_process

Show Build

Starts or activates the Build tool
window.

start_process

Build Automatically on
Save

When enabled, the project is built
each time the workspace is saved.

project_toggle_auto_build
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Debug
This section describes items on the Debug menu and associated dialogs and tool windows. For more
information about debugging, see Running and Debugging.

Debug Menu
The Debug menu contains debugging-related operations and options. The table below summarizes these
items.
Debug Menu Item

Description

Command

Windows

Displays debug window toolbars. See
Debug Windows Menu.

N/A

Start

Starts debugger.

project_debug

Suspend

Suspends execution.

debug_suspend

Stop Debugging

Stops debugging the program.

debug_stop

Restart

Restarts the program.

debug_restart

Attach Debugger

Attach debugger to a process or
remote server.

N/A

Detach

Detach from target process and allow
application to continue running.

debug_detach

Debugger Information

Displays the Debugger Information
dialog.

debug_props

Step Into

Steps into the next statement.

debug_step_into

Step Over

Steps over the next statement.

debug_step_over

Step Out

Steps out of the current function.

debug_step_out

Step Instruction

Steps one instruction at a time.

debug_step_instr

Run to Cursor

Runs the program to the line
containing the cursor.

debug_run_to_cursor

Show Next Statement

Displays the source line for the
instruction pointer.

debug_show_next_stateme
nt

Set Instruction Pointer

Set the instruction pointer to the
current line.

debug_set_instruction_poi
nter

Show Disassembly

Toggle display of disassembly.

debug_toggle_disassembly

Toggle Breakpoint

Toggles a breakpoint at the current
line.

debug_toggle_breakpoint

Delete All Breakpoints

Deletes all debugger breakpoints.

debug_clear_all_breakpoin
ts
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Debug Menu Item

Description

Command

Disable All Breakpoints

Disables all debugger breakpoints.

debug_disable_all_breakpo
ints

Add Watch

Add a watch on the variable under the
cursor.

debug_add_watch

Set Watchpoint

Set a watchpoint on the variable
under the cursor.

debug_add_watchpoint

Debugger Options

Displays the Debugger Options
dialog. See Viewing Debugger Info
and Setting Options for detailed
information.

debugger_options

Debug Windows Menu
The Debug > Windows menu items activate the debugging tool windows. The table below summarizes
these items. See also Debugger Tool Windows for more information.
Debug Windows Menu
Item

Description

Command

Call Stack

Activates the Call Stack window.

activate_call_stack

Locals

Activates the Locals window.

activate_locals

Members

Activates the window which displays
member variables.

activate_members

Autos

Activates the Autos window.

activate_autos

Watch

Activates the Watch window.

activate_watch

Threads

Activates the Threads window.

activate_threads

Breakpoints

Activates the Breakpoints window.

activate_breakpoints

Registers

Activates the Registers window.

activate_registers

Memory

Activates the Memory window.

activate_memory

Classes

Activates the Classes window.

activate_classes

Attach Debugger Menu
The Debug > Attach Debugger menu items are summarized in the table below. See Multiple Session
Debugging for more information.
Attach Debugger Menu
Item
Attach to Running
Process using GDB
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Description
Attach debugger to a running process
using GDB.

Command
debug_attach gdb
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Attach Debugger Menu
Item

Description

Command

Attach to Remote
Process using GDB

Attach debugger to a remote GDB
server or executable with GDB stub.

debug_remote gdb

Attach to Java Virtual
Machine

Attach to a Java virtual machine
executing remotely.

debug_attach jdwp

Debug Other
Executable

Step into a program using GDB.

debug_executable gdb
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Document
This section describes items on the Document menu and associated dialogs and tool windows.

Document Menu
The Document menu contains items pertaining to editor windows and the current document. The table
below lists a summary of these items.
Document Menu Item

Description

Command

Next Buffer

Switches to the next buffer. See
Buffers and Editor Windows.

next_buffer

Previous Buffer

Switches to the previous buffer. See
Buffers and Editor Windows.

prev_buffer

Close Buffer

Closes the current buffer. See Buffers
and Editor Windows.

close_buffer

List Open Files

Displays the Files tool window, which
lists all buffers and allows you to
activate one. See Files Tool Window.

list_buffers

Edit Associated File

Switch to header or source file
associated with the current file.

edit_associated_file

Select Mode

List all modes and lets you select one.
See Language Editing Mode.

select_mode

Language Options

Displays the Options dialog open to
the language-specific General options
screen for the language in the current
buffer. See Language Options.

setupext

Tabs

Sets tab stops.

gui_tabs

Margins

Sets margins.

gui_margins

Format Paragraph

Reflows the text in the current
paragraph according to the margins.

reflow_paragraph

Format Selection

Reflows the selected text according to
the margins.

reflow_selection

Format Columns

Format columns according to words.

format_columns

Edit Javadoc Comment

Edits Javadoc comments for the
current source file.

javadoc_editor

Comment Block

Converts selected text into block
comment using box comment setup
characters. See Commenting.

box
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Document Menu Item

Description

Command

Comment Lines

Converts selected lines into line
comments using the line comment
setup. See Commenting.

comment

Uncomment Lines

Uncomments any commented lines
and ignores any that isn’t commented.
See Commenting.

comment_erase

Reflow Comment

Reflows and reformats the current
block comment. See Reflow
Comment Dialog.

gui_reflow_comment

Comment Setup

Displays the language-specific
Comment options screen, which
contains settings for box and line
comments. See Language-Specific
Comment Options.

comment_setup

Comment Wrap

Toggles comment wrap on/off.

comment_wrap_toggle

XML/HTML Formatting

Displays the XML/HTML Formatting
menu. See XML/HTML Formatting
Menu.

N/A

Indent with Tabs

Toggles indenting with tabs on/off.
See Syntax Indent.

indent_with_tabs_toggle

Word Wrap

Toggles word wrap on/off.

word_wrap_toggle

Justify

Sets/displays paragraph justification
style.

gui_justify

Read Only Mode

Toggles read-only mode on/off.

read_only_mode_toggle.

Adaptive Formatting

Toggles Adaptive Formatting on/off.
See Adaptive Formatting.

adaptive_format_toggle

XML/HTML Formatting Menu
The Document > XML/HTML Formatting menu is used to activate these features in SlickEdit®. You can
enable and/or disable Tag Layout and/or Content Wrap for either file type on a global basis or on a per
document basis. See XML/HTML Formatting for more information.
XML/HTML Formatting
Menu Item
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Description

Command

Current Document
Options

Displays the Current Document
Options Dialog.

xml_html_document_optio
ns

Enable XML Formatting

Toggles XML Formatting on/off.

xml_formatting_toggle

(XML) Content Wrap

Toggles XML Content Wrap on/off.

xml_contentwrap_toggle

(XML) Tag Layout

Toggles XML Tag Layout on/off.

xml_taglayout_toggle
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XML/HTML Formatting
Menu Item

Description

Command

Enable HTML
Formatting

Toggles HTML Formatting on/off.

html_formatting_toggle

(HTML) Content Wrap

Toggles HTML Content Wrap on/off.

html_contentwrap_toggle

(HTML) Tag Layout

Toggles HTML Tag Layout on/off.

html_taglayout_toggle

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Document menu items.

Files Tool Window
The Files tool window allows you to view open files, project files, and workspace files, sortable by file name
or path. It includes a filter to narrow the list of files shown in the list, as well as shortcuts for basic file
operations (Open, Save, etc.).
NOTE For documentation purposes, the word “files” generally includes both files and buffers.

Accessing the Tool Window
There are several ways to access the Files tool window:
•

Click Document > List Open Files, press Ctrl+Shift+B, or use the list_buffers command.

•

Use the activate_files command.

•

Toggle display of the tool window by clicking View > Toolbars > Files, or by using the
toggle_files command.
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When the Files tool window is not docked, it can be dismissed by opening a file for editing or by pressing
Esc. To make this dialog behave like other tool windows, right-click inside the Files list area and uncheck
Dismiss on select.
TIP By docking this tool window, you have quick access for switching between files or opening other
files.

List Views
The Files tool window presents three available views for files. Use the View buttons or the right-click menu
to display:
•

Files open for editing - Useful for selecting the file to edit when working on multiple files.

•

Files in the active project - Useful for browsing and searching file names in the active project.

•

Files in the open workspace - Useful for browsing and searching file names in the workspace.

Working with the Files List
The bottom part of the tool window shows the Files list. The Name column displays, in alphabetical order,
a list of file names or untitled buffers based on the selected view setting. The Path column displays the
associated paths for the files listed. Click on either column header to sort by that column. When you click to
sort, an arrow on the right side of the column header shows the ascending or descending order.
The Filter text box can be used to display matching file names. Files are removed from the list that do not
contain the specified text. For example, if you type “ml,” the Files list is filtered to only show file names that
contain the letters “ml,” as they appear in that order, anywhere in the file name.
To allow Fast Prefix Matching inside the Filter text box, right-click inside the Files list area and select
Prefix match. When prefix matching is on, matching starts at the beginning of the word. For example, if
you type “d,” the Files list is filtered to only show file names that begin with the letter “d.”
When the focus is not in the Filter text box, you can incrementally search the list of file names by typing the
first few characters of the name. If you pause for a few seconds, the search is reset, and you can search
for a different file name just by typing the first few characters again. You do not need to press Backspace,
or reselect the first item in the list. Regardless of which item is selected, incremental search starts at the
top of the list. For example, if items are sorted in descending alphabetical order, the incremental search
starts at the top of the list, which would be the file that would appear last, if sorted in ascending
alphabetical order.
TIP You can collapse display of the buttons and the Filter text box by clicking the Minus button in the
top-left corner of the tool window. The collapsed area is replaced with a message that states your
current view and filter settings. To view the buttons and Filter text box again, click the Plus button.
Collapsing the buttons and filter gives your window a cleaner look and more room for file listings.

Opening Files for Editing
The name of the file that has current focus in the editor is displayed in a bold font style. The tool window
provides several ways to a file for editing:
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•

Press Enter or Alt+E.

•

Double-click on the file to be opened.

•

Click the Open a File for Editing button.
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•

Right-click and select Open.

TIP If there is no selection when you invoke an Open operation, the Open dialog is displayed from
which you can specify a file to open.

Saving Modified Files
Modified files are listed in a red font, and when selected, they have a red highlight. A Disk bitmap to the left
of the file name acts as another visual indicator for modified files and allows for a quick save.
NOTE The Project and Workspace views do not display modified file indicators.
The Files tool window provides several ways to save modified files:
•

Press Ctrl+S, Alt+S, or Alt+W.

•

Click the Disk bitmap to the left of the file name.

•

Click the Save Selected File(s) button.

•

Right-click and select Save.

TIPS
•

When you invoke a Save operation, if a file is selected, it is simply saved. If an untitled buffer
is selected, the Save As dialog is displayed from which you can save it with a specified
name. If both a file and an untitled buffer are selected, the file will be saved, and the Save As
dialog is displayed in order to save the untitled buffer.

•

The red highlight color for modified files can be changed by specifying a different
background color for the Modified Line screen element (Tools > Options > Appearance >
Colors). Note that this is the same element that specifies coloring in tree controls such as
DIFFzilla®, so change with caution. See Setting Colors for Screen Elements for more
information.

Closing Files
When you close a file, all windows displaying the buffer are closed as well (if the Files per window option
One file per window is enabled at Tools > Options > Editing > Editor Windows). You are also prompted
to save modified buffers.
The Files tool window provides several ways to close files:
•

Press Delete, Alt+C, or Alt+D.

•

Right-click and select Close.

•

Click the Close Selected File(s) button.

Files Tool Window Interface
The elements on the Files tool window are described as follows, from left to right and top to bottom:
•

Minus/Plus button - The Minus button collapses the display of the buttons and Filter text box of
the tool window. It changes to a Plus button when the area is collapsed, and a message states
your current view and filter settings.

•

View Open Files button - Displays all files and buffers that are currently open in the editor. This
view can also be specified by using the right-click menu inside the Files list.
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•

View Files in the Current Project button - Switches the view from the set of open files to the set
of all files in the current project, regardless of whether they are open or not. This view does not
show an indicator for modified files. This view can also be specified by using the right-click menu
inside the Files list. See Workspaces and Projects for more information about working with
projects.

•

View Files in the Current Workspace button - Switches the view to the set of all files in the
current workspace. This view can also be specified by using the right-click menu inside the Files
list. See Workspaces and Projects for information about workspaces.

•

Open a File for Editing button - Brings the selected file to focus in the editor. If a project or
workspace file is selected that is not currently open in the editor, that file is opened for editing. If
there is no selection, the Open dialog is displayed from which you can specify the file to open. This
operation can also be specified by using the right-click menu inside the Files list. See Opening
Files for Editing for more information.

•

Save Selected File(s) button - If a file is selected, it is simply saved. If an untitled buffer is
selected, the Save As dialog is displayed from which you can save it with a specified name. If both
a file and an untitled buffer are selected, the file will be saved, and the Save As dialog is displayed
in order to save the untitled buffer. This operation can also be specified by using the right-click
menu inside the Files list. See Saving Modified Files for more information.

•

Close Selected File(s) button - Closes the selected file(s) in the editor, which in turn, removes
the names from the Files window. If you are using the option One file per window (on by default),
all windows displaying the buffer are closed as well. You are prompted to save modified buffers.
This operation can also be specified by using the right-click menu inside the Files list. See Closing
Files for more information.

•

Filter - This text box can be used to display matching file names. Right-click inside the Files list
area to allow Prefix match inside the Filter text box. When the focus is not in the Filter text box,
you can incrementally search the list of file names by typing the first few characters of the name.
See Working with the Files List for more details about filtering and searching the Files list.

•

Files list - The Files list is divided into two columns:
o

Name column - Displays a list of file names or untitled buffers based on the selected view
setting. Items are listed in alphabetical order. Click on the Name column header to sort by this
column. When you click to sort, an arrow on the right side of the column header shows the
ascending/descending order. The name of the file that has current focus in the editor is
displayed in a bold font style. Modified files are listed in a red font, and when selected, they
have a red highlight. A Disk bitmap to the left of the file name acts as another visual indicator
for modified files and allows for a quick save.

o

Path column - Displays the corresponding paths to the files/buffers listed. Click on the Path
column header to sort by this column. When you click to sort, an arrow on the right side of the
column header shows the ascending/descending order.

Reflow Comment Dialog
The Reflow Comment dialog (Document > Reflow Comment), shown below, is used to reflow block
comments, paragraphs, or a selection of the current file.
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The following options are available:
•

Entire block comment - If selected, reflows an entire block comment based on the current width
and border settings for the block comment.

•

Match block comment border settings - If selected, forces the borders to conform to the
comment settings (Document > Comment Setup - see Language-Specific Comment Options).

•

Current paragraph - If selected, reflows the current paragraph within the block comment.

•

Selection - If selected, reflows a selection within a block comment paragraph based on current
settings.

•

Comment width - Select one of the width options to reflow a block comment to the margins or the
width that you specify in these fields. See Language-Specific Comment Wrap Options for
information.

For more information about comments, see Commenting.

Current Document Options Dialog
The Current Document Options dialog allows you to enable/disable aspects of XML or HTML Formatting
for just the current document. It can be displayed by clicking Document > XML/HTML Formatting >
Current Document Options, or by using the xml_html_document_options command.
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The dialog contains the following:
•

Formatting scheme - This drop-down specifies the formatting scheme applied to this document.
Choose from the list of available schemes.

•

Auto formatting options - These are the aspects of XML/HTML Formatting that can be enabled/
disabled for the current document.

•

Configure Schemes button - Displays the XML/HTML Formatting Scheme Configuration Dialog,
which allows you to modify or create a new scheme to apply to the current document.

For more detailed information, see Enabling/Disabling for the Current Document.

XML/HTML Formatting Scheme Configuration Dialog
This dialog is used to configure the way XML and HTML code is automatically formatted as you edit. Note
that XML/HTML Formatting must be enabled in order for these settings to work. See XML/HTML
Formatting for more information.
To access this dialog, from the main menu, click Document > XML/HTML Formatting > Current
Document Options, then click the Configure Schemes button on the Current Document Options dialog.
Or, use the xml_html_options command to display the dialog.
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The Scheme column shows a list of available schemes. The Tags column shows a list of tags associated
with the selected scheme. Right-click in this column for a menu of operations such as add, save, and more.
See Working with Schemes and Working with Tags for more details.
A Preview at the bottom of the dialog shows how the selected tag will be formatted in your code. Click the
XML Options or HTML Options button to jump to the language-specific Formatting Options page for each
language (this is the same as Tools > Options > Languages > [LanguageCategory] > [Language] >
[Language] Formatting Options).
The following sections describe the tabs and how each setting works. Before configuring settings, be sure
the scheme and tag(s) that you want to affect are selected.
CAUTION XML/HTML Formatting does not currently affect XML or HTML Beautifier settings. If
you run the beautifier on documents that have been automatically formatted through XML/
HTML Formatting, you may find unexpected results.
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General Settings
The General tab of the XML/HTML Formatting dialog is shown below.

It contains the following general settings:
•

End tags settings - These options control how the end tags for the selected tag are formatted:
o

Has end tag - This option tells SlickEdit® whether or not the specified tag is intended to be
closed with an end tag. This information is used for SlickEdit to know when to start or stop
calculating information based on the tag. For example, the <div> tag in HTML has a start and
end tag, while the <br> tag does not have an end tag.

o

Insert end tags on ‘>’ - When selected, SlickEdit automatically inserts the end tag after you
type the closing brace (>) of the start tag. For example, when you type <div>, </div> is
automatically inserted. The placement of the inserted tag depends on other settings you have
specified, such as whether or not the end tag should be on a separate line (specified on the
Tag Layout tab).

•

Match tag style of - Select this option if you want the selected tag’s settings to match the style of
another tag, then pick the tag to use from the drop-down list. This can be a time-saver when
adding a batch of new tags that should all have the same settings.

•

Scheme uses case-sensitive tag search - When this option is selected, tags in the Tags column
are displayed in the list exactly as you have typed them, with the case preserved. When you type
the tags in the editor, the case must match exactly or the tag will not be recognized (and the
(default) tag settings will be applied). This option is appropriate for XML. HTML is not casesensitive.

Content Wrap Settings
The Content Wrap tab of the XML/HTML Formatting dialog contains options for specifying how wrapping
should occur for the selected tag’s content.
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There are three main (mutually-exclusive) options:
•

Wrap tag content - When selected, content between tags is wrapped according to the settings
specified in the Tag content width group box. See Tag Content Width Settings below for details.

•

Treat as content - When selected, the tag as well as its content is wrapped according to the
parent tag content. The tag is treated as “inline” with the surrounding text. This could be useful for
style tags such as <b> or <i> that you want to appear “inline” with the content. For example:
<div>
This is a sample paragraph with the <b>bold tags</b> being treated as
content, “inline” with the rest of the text.
</div>

•

Preserve content - When selected, content between start and end tags is not wrapped, but the
tags are laid out properly with the parent tag. This could be useful for tags such as <pre>, where
the content needs to be rendered exactly as it appears in the code.

NOTES
•

When Treat as content is selected, the wrapping options in the Tag content width group
box, as well as options on the Tag Layout tab, are unavailable.

•

When Preserve content is selected, the wrapping options in the Tag content width group
box are unavailable.

Tag Content Width Settings
When Wrap tag content is selected, content between tags is wrapped according to the settings specified
in this group box. The options Fixed width, Automatic width, and Fixed right margin are mutually
exclusive.
•

Fixed width - When selected, tag content is formatted to the specified width. The original left
margin of the content is maintained, and the right margin is adjusted to meet the target width.
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If Maximum right column is used, lines will be wrapped when they reach the specified column,
even if they have not reached the specified fixed width. This is useful if coding standards mandate
that text should not exceed a specified column.
•

Automatic width - When selected, the width of the longest multi-line paragraph in the tag’s
content is used as the width. This is useful for preserving the formatting of existing content.
If Maximum right column is used, lines will be wrapped when they reach the specified column,
even if they have not reached the specified automatic width. This is useful if coding standards
mandate that text should not exceed a specified column.

•

Fixed right margin - When selected, lines will break before the specified number of columns in
the Right column field has been reached.

TIP If coding standards mandate that text should not exceed a specified column, you can still use
Fixed or Automatic width settings. Select and set the Maximum right column, and lines will be
wrapped when they reach the specified column, even if they have not reached the specified fixed or
automatic width.
•

Parent tag right margin - When selected, tag content is wrapped at the right margin to the width
of the parent tag.

•

Include tags in width calculation - When selected, the start and end tag characters are counted
in addition to the content. The number of characters and spaces (including attributes) within tags
are calculated, and the specified width is adjusted accordingly. This is useful for producing uniform
blocks of text.

•

Preserve width of existing content - When selected, SlickEdit® preserves the width of the
existing content while editing. The width is determined by the length of the longest multi-line
paragraph. If the width of the existing content cannot be determined, the formatting option
specified (Fixed, Automatic, or Fixed right) will be used instead.

Tag Layout Settings
The Tag Layout tab of the XML/HTML Formatting dialog contains options to control the location of the start
tag, end tag, and the content between them.
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•

Start tag on separate line - When selected, the start tag occurs on a separate line, and the cursor
will be placed on the line below for you to type the content. Note the cursor location (|) in the
examples below.

•

End tag on separate line - When selected, the end tag placed on a separate line below the
content.
Example of both settings checked:
<div>
|
</div>

Example of both settings unchecked:
<div>|</div>

Example of start checked and end unchecked:
<div>
|</div>

NOTE Dynamic Surround is triggered when you type a tag that has both options Start and End tag
on separate line checked. Note that Dynamic Surround cannot wrap content and only indents to
match your indent style setting (Tools > Options > Languages > [LanguageCategory] >
[Language] > Indent). See Syntax Indent for more information about indent styles.
•

Content indent - These mutually exclusive options control how content between tags is indented:
o

Match extension indent style - When selected, tag content is indented according to your
indent style setting (Tools > Options > Languages > [LanguageCategory] > [Language] >
Indent). See Syntax Indent for more information about indent styles.
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o

•

•
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Indent - When selected, indenting for the tag occurs at the column number specified in the
spin box. When Indent after start tag ’>’ is selected, indenting is relative to the close bracket.
Otherwise indenting is relative to the open bracket.

Nested tag indent - Indenting is activated after the end tag is typed (or automatically inserted if
Insert end tags on ‘>’ is checked on the General tab). These mutually exclusive settings apply to
all tags in the selected scheme:
o

Match extension indent style - When selected, SlickEdit® indents the selected tag according
to your indent style setting (Tools > Options > Languages > [LanguageCategory] >
[Language] > Indent). See Syntax Indent for more information about indent styles.

o

Match content indent - When selected, SlickEdit indents the selected tag to the same level
as its parent content.

Insert line breaks - The values for Before start tag and After end tag specify the number of line
breaks that are inserted before and after start and end tags. Note that in order to insert one or
more blank lines, the values should be set to 2 or higher.
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Macro
This section describes items on the Macro menu and associated dialogs and tool windows.

Macro Menu
The table below describes each item on the Macro menu and its corresponding command. For more
information about working with macros, see Recorded Macros, Programmable Macros, and the Slick-C®
Macro Programming Guide.
Macro Menu Item

Description

Command

Load Module

Loads a macro source module.

gui_load

Unload Module

Unloads a Slick-C macro file from the
state file.

gui_unload

List User-Loaded
Macros

Lists user-loaded Slick-C modules.
See User-Loaded Modules Dialog.

gui_list_macfiles

Record Macro

Starts recording Slick-C language
macro based on the editor features
you use.

record_macro_toggle

Execute last-macro

Runs last recorded macro.

record_macro_end_execut
e

Save last-macro

Saves the last recorded macro under
a name you specify. See Save Macro
Dialog.

gui_save_macro

List Macros

Lists saved, recorded macros. See
List Macros Dialog.

list_macros

Set Macro Variable

Allows you to set global macro
variables. See Set Variable Dialog
and Variable Editor Dialog.

gui_set_var

Start Slick-C Debugger

Activates the Slick-C debugger
window. See “Slick-C Debugger” in
the Help > Index.

slickc_debug_start

Go to Slick-C Definition

Opens a macro source file and places
your cursor on the definition of a
macro symbol.

gui_find_proc

Find Slick-C Error

Places your cursor on the macro
source line which caused the last
interpreter run-time error.

find_error

New Form

Opens a new form for editing with the
Dialog editor.

new_form

Open Form

Opens an existing or new form for
editing with the Dialog editor.

open_form
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Macro Menu Item

Description

Command

Selected Form

Displays edited form window currently
selected.

show_selected

Load and Run Form

Loads form, loads Slick-C code, and
runs the currently selected/edited
form.

run_selected

Grid

Sets form grid settings. This affects
the distance displayed between the
dots on a form that is being edited.
See Grid Settings Dialog.

gui_grid

Menus

Lists all menus and allows you to edit,
create, delete, or show menus.
Provides access to the Menu Editor
dialog box. See Menu Editor Dialog.

open_menu

Insert Form or Menu
Source

Inserts source code into current file
for a form or menu you specify.

insert_object

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Macro menu items.

User-Loaded Modules Dialog
The User-Loaded Modules dialog is used to view a list of Slick-C® modules that you have loaded. It also
lets you add, delete, and re-order modules. See Slick-C® Modules for more information.
To display the dialog, from the main menu, click Macro > List User-Loaded Modules, or, use the
gui_list_macfiles command on the SlickEdit® command line.
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To add a module to the list, double-click where indicated or click the Add button. To remove a module from
the list, select it, then click the Delete button. Use the arrow buttons to rearrange the order, moving the
selected module up and down in the list. This is the order in which modules are re-loaded when you
upgrade to a newer version of SlickEdit.
When you add a module to the list, SlickEdit prompts to load the module in the editor. When you delete a
module from the list, SlickEdit prompts to also unload the module. See Loading and Unloading Slick-C®
Modules for more information.

Save Macro Dialog
The Save Macro dialog appears automatically when you end macro recording, or when you click Macro >
Save last-macro. You can also display the dialog by using the gui_save_macro command.
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The dialog contains the following elements:
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•

Macro Name - Specifies the name for the recorded macro. If you attempt to give the macro a
name that is already taken, a message is displayed asking if you want to overwrite the existing
macro.

•

Macro list - The box under the Macro Name field shows a list of all macros you have recorded (if
any exist).

•

Requires editor control - When selected, the macro only operates if the target is an editor
control.

•

Allow in read only mode - When selected, the macro is permitted to operate even in read-only
mode. Select this option if your macro does not modify the current buffer.

•

Allow when window is iconized - When selected, the macro is permitted to operate even when
the edit window is iconized. If the macro modifies the current buffer, you may prefer to leave this
option off.

•

Allow in non-MDI editor control - When selected, the macro is permitted to operate even in a
non-MDI editor control. This is typical for commands which require an editor control but do not
open or close editor windows/buffers.

•

Save and Bind to Key - Saves the recorded macro by appending the source code of the macro to
the vusrmacs.e user macros file located in your configuration directory, then displays the Key
Bindings option screen so you can create a keyboard shortcut for the macro. See Binding
Recorded Macros to Keys for more information.

•

Save - Saves the recorded macro by appending the source code of the macro to the vusrmacs.e
user macros file located in your configuration directory.

•

Edit - (Alt+E) Displays the macro source code in a new editor window (to save it, click Macros >
Save last-macro or to bind the macro to a key, use the menu item Macro > List Macros). Note
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that this button is disabled for existing macros because with the Save Macro dialog, you can only
edit the macro you have just recorded prior to saving it. To edit a macro that has been previously
recorded and saved, use the List Macros dialog. See Saving and Editing Recorded Macros for
more information.
•

Delete - Deletes the selected macro.

List Macros Dialog
The List Macros dialog is used to view and work with a list of macros you have recorded. It is accessed by
clicking Macro > List Macros on the main menu, or by using the list_macros command on the SlickEdit®
command line.

The dialog shows a list of all macros you have recorded. Use the buttons to perform the following
operations:
•

Run - Runs the selected macro. See Running a Recorded Macro for more information.

•

Cancel - Closes the dialog.

•

Edit - Opens the macro source for editing. See Saving and Editing Recorded Macros for more
information.

•

Delete - Deletes the selected macro. See Deleting Recorded Macros for more information.

•

Bind to Key - Displays the Key Bindings option screen so you can assign a key or mouse shortcut
to the macro. See Binding Recorded Macros to Keys for more information.

Set Variable Dialog
You can set Slick-C® variables to specific values using the Set Variable dialog box (Macro > Set Macro
Variable or gui_set_var command).
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Enter the name of Slick-C variable in the Variable text field. You may use the spacebar and “?”
(completion) to assist you in entering the name. Click the drop-down arrow to select a variable from the list.
Enter the new value of the variable in the Value text box and click OK, or click Edit to display the Variable
Editor Dialog, used for editing complex variables such as arrays, hash tables, structures, and unions.

Variable Editor Dialog
The Variable Editor dialog, shown below, is used to edit complex variables for macros. For more
information about working with these programmable macros, see Programmable Macros. To access the
Variable Editor, click Macro > Set Macro Variable, or use the gui_set_var command, select a variable to
edit from the list, then click the Edit button.
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The data structure of the variable is displayed in the list box at the top of the dialog, and the value for each
entry is displayed in the Value text box.
The following buttons are available:
•

Expand Curr - Expands current item which has a Plus (+) bitmap.

•

Delete - Deletes current item.

•

Format - Allows you to change the type of the current item.

•

Insert - Inserts a new hash table or array element.

•

Expand All - Expands all items so you can see the entire data structure.

•

Collapse All - Display first level of variable with nothing expanded.

•

Update - Sets the contents of the variable to what is currently displayed in the Variable Editor.

•

Refresh - Cancels changes and displays current value of variable which is not necessarily the
same as when this dialog box was originally displayed.

•

Squish - Deletes array items which have the value _notinit.
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Grid Settings Dialog
The Grid Settings dialog (Macro > Grid or gui_grid command) is used to set the width and height of grid
dots displayed on forms when you use the Dialog Editor. These settings affect the distance between the
dots on a form that is being edited.

The width and height parameters are in twips (1440 twips equal one inch on the display).

Menu Editor Dialog
The Menu Editor dialog, shown below, contains options for editing menus. To access this dialog, click
Macro > Menus, select the menu to edit from the list, then click Open.

The following fields and settings are available:
•
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Menu name - Name of the current menu resource. You can define your own menu resource which
is used instead of our menu bar WITHOUT changing the name of our default menu bar
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_mdi_menu. Use the -m invocation option (for example, -m mymenu) or set the def_mdi_menu
macro variable to your menu name (see Setting/Changing Configuration Variables).
•

Caption - Title displayed for the menu item. For menu items, set the caption to “-” to specify a line
separator.

•

Short Cut - Key binding shortcut for the menu item.

•

Command - Macro command executed when the menu item is selected. This may be an internal
macro command or a command line for running an external program.

•

Alias - Displays the Menu Item Alias dialog box to set an alias for the menu item. See Defining
Menu Item Aliases.

•

Help Cmd - Macro command executed when F1 is pressed when the menu item is selected.
Usually it is a help or popup_imessage command. For example, if you specified gui_open as the
menu item command, specify “help open dialog box” as the Help item. If you do not know the
name of the dialog box displayed, search for Help on the command. The Help for each command
should indicate the name of the dialog box displayed. Some commands do not display dialog
boxes. For these commands, specify help command where command is name of the command
this menu item executes or help xxxx menu where xxxx is the name of the drop-down menu this
command is on.

•

Message - Message text to be displayed when selection cursor is on this menu item. This
message is currently only used when the menu is used as the SlickEdit® menu bar.

•

Submenu - Check this box if you want to create a menu which contains other menu items.

•

Auto Enable - Displays the Auto Enable Properties dialog box to set the properties for the menu
item that should be automatically enabled. See Enabling/Disabling Menu Items and Auto Enable
Properties Dialog.

•

Up - Moves the selected menu item above the previous menu item.

•

Down - Moves the selected menu item below the next menu item.

•

Next - Selects the menu item after the currently selected menu for editing. Use this button to insert
a blank menu item after the last menu item in the list.

•

Insert - Inserts a blank menu item before the selected menu item.

•

Delete - Deletes the selected menu item.

Auto Enable Properties Dialog
This dialog is used to set the auto-enable properties for a menu item. For example, the screen capture
below shows the Auto Enable Properties dialog for cut on the _textbox_menu. For more information, see
Enabling/Disabling Menu Items. To access this dialog, click the Auto Enable button on the Menu Editor
dialog.
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The following settings are available:
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•

Requires editor control - Indicates that this command should be enabled only if operating on an
editor control.

•

Allow in read only mode - Indicates that this command should be enabled if the editor control is
in strict read only mode.

•

Allow when window is iconized - Indicates that this command should be enabled if the editor
control is an editor window which is iconized.

•

Requires selection in active buffer - Indicates that this command should be disabled if there is
no selection in the active buffer.

•

Requires Context Tagging® - Indicates that this command should be disabled if Context Tagging
does not support the current buffer language type.

•

Requires fileman mode - Indicates that this command should be disabled if the current buffer is
not in Fileman mode.

•

Requires unicode buffer - Indicates that this command should be disabled if the current buffer is
not Unicode.

•

Allow in non-MDI editor control - Indicates that this command should be allowed in a non-MDI
editor control.

•

Requires block selection - Indicates that this command should be disabled if there is no
selection or the current selection is not a type of block or column.

•

Requires a clipboard - Indicates that this command should be disabled if there is no editor control
clipboard available.

•

Requires a selection - Indicates that this command should be disabled if there is no selection.
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Tools
This section describes items on the Tools menu and associated dialogs and tool windows.

Tools Menu
The table below describes each item on the Tools menu and its corresponding command.
Tools Menu Item

Description

Command

Options

Displays the Options dialog. See
Options.

config

Regex Evaluator

Shows the Regex Evaluator tool
window. See The Regex Evaluator.

activate_regex_evaluator

OS Shell

Runs operating system command
shell (DOS).

dos

OS File Browser

Runs operating system file system
browser. See OS File Browser.

explore or finder

Calculator

Displays the Calculator, which allows
you to evaluate mathematical
expressions. See Using the
Calculator and Math Commands.

calculator

Add Selected Expr

Adds the result of evaluating each line
in a selected area of text.

add

ASCII Table

Opens ASCII table file.

ascii_table

Version Control

Displays Version Control menu. See
Version Control Menu.

N/A

Quick Refactoring

Displays Quick Refactoring menu.
See Quick Refactoring Menu.

N/A

Imports

Displays Imports refactoring menu.
See Imports Menu.

N/A

Generate Debug

Generates debug code for symbol
under the cursor.

generate_debug

Sort

Sorts current buffer or selected text.
See Sorting Text.

gui_sort

Beautify

Displays a language-specific
beautifier dialog box used for setting
options and beautifying source. See
Beautifying Code.

gui_beautify
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Tools Menu Item

Description

Command

File Merge

Displays the 3-Way Merge Setup
dialog, which provides settings for
merging two sets of changes made to
a file. See 3-Way Merge and 3-Way
Merge Dialog.

merge

File Difference

Displays the DIFFzilla® dialog, which
allows you to view and edit
differences between files. See
DIFFzilla® and DIFFzilla® Dialog.

diff

Spell Check

Displays menu of spell checking
commands. See Spell Check Menu.

N/A

Tag Files

Displays a dialog which allows you to
build tag files for use by the Symbols
tool window and other Context
Tagging® features. See Creating
Language-Specific Tag Files and
Context Tagging® - Tag Files Dialog.

gui_make_tags

Version Control Menu
The table below describes each item on the Tools > Version Control menu and its corresponding
command. For more information about working with Version Control, see Version Control.
Version Control Menu
Item
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Description

Command

Check In

Checks in current file.

vccheckin

Get

Checks out current file read only.

vcget

Check Out

Checks out current file.

vccheckout

Lock

Locks the current file without checking
out the file.

vclock

Unlock

Unlocks the current file without
checking in the file.

vcunlock

Add

Adds current file to version control.

vcadd

Remove

Removes current file from version
control.

vcremove

History

Views history for current file.

vchistory

Difference

Views differences of current file.

vcdiff

Properties

Views properties of current file.

vcproperties

Manager

Executes Version Control Manager.

vcmanager
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Version Control Menu
Item
Setup

Description
Displays the Version Control Setup
options screen, which allows you to
choose and configure a Version
Control System interface. See Version
Control Setup Options.

Command
vcsetup

Quick Refactoring Menu
The Tools > Quick Refactoring menu contains the Quick Refactorings that can be used for C++, C#,
Java, and Slick-C®. These are summarized in the table below. For more information about working with
these refactorings, see Quick Refactoring.
Quick Refactoring
Menu Item

Description

Command

Rename

Rename symbol.

refactor_quick_rename

Extract Method

Extract the selected code block into a
new function.

refactor_quick_extract_met
hod

Modify Parameter List

Modify the parameter list of a method.

refactor_quick_modify_par
ams

Encapsulate Field

Encapsulate field using Context
Tagging®.

refactor_quick_encapsulate
_field

Replace Literal with
Constant

Replace literal value with a declared
constant.

refactor_quick_replace_lite
ral

Imports Menu
The Tools > Imports menu contains options for organizing Java imports. For more information, see
Organize Imports.
Imports Menu Item

Description

Command

Organize Imports

Organize import statements in a Java
file.

jrefactor_organize_imports

Add Import

Add import statement for symbol
under cursor.

jrefactor_add_import

Options

Displays the Options dialog open to
Organize Java Imports node. See
Organize Imports.

jrefactor_organize_imports
_options
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Spell Check Menu
The Tools > Spell Check menu contains spell checking operations and access to options. For more
information about working with Spell Check, see Spell Checking. The table below contains a summary of
the Spell Check menu items.
Spell Check Menu Item

Description

Command

Check from Cursor

Spell check starting from cursor.

spell_check

Check Comments and
Strings

Spell check comments and strings
starting from cursor.

spell_check_source

Check Selection

Spell check words in selection.

spell_check_selection

Check Word at Cursor

Spell check word at cursor.

spell_check_word

Check Files

Spell check multiple source files.

spell_check_files

Spell Options

Display/modify spell checker options.

spell_options

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Tools menu items.

3-Way Merge Dialog
The 3-Way Merge dialog (Tools > File Merge), shown below, is used for merging file differences.
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The Ellipses buttons to the right of the text boxes are used to select files. The B buttons to the right of the
text boxes are used to select from the open buffers.
The list below describes the remaining fields and settings:
•

Base file - Specifies the file/buffer name of the original source file before any changes are made.

•

Revision 1 and 2 - Specifies the file/buffer names of the modified versions of the base file.

•

Output file - Specifies the output file name.

•

Merge style - The following merge styles are available:

•

•

o

Auto merge - If selected, if a change does not cause a conflict, the change is automatically
applied to the output file and no indication is made that the change was already applied.

o

Show changes - If selected, if a change does not cause a conflict, the change is automatically
applied to the output file and the change IS indicated, so that using the Next Conflict button
will show you the change.

Output style - Output style has no effect if there are no conflicts. The following output styles are
available:
o

Interactive - Provides a friendly side-by-side dialog box which lets you pick the change you
want in the output file. It also lets you edit.

o

Interleaved buffer - Creates an editor buffer which you must edit to resolve conflicts.

Use smart merge - If selected, the number of conflicts found is reduced.
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•

Ignore spaces - If selected, leading and trailing spaces are ignored. The side-by-side output
allows you to easily select the change that you want.

DIFFzilla® Dialog
The DIFFzilla dialog (Tools > File Difference) is used to configure a file differencing operation and begin
the diff. The options are categorized into two tabs:
•
•

DIFFzilla® Files Tab
DIFFzilla Options Tab

DIFFzilla® Files Tab
You can compare two files or two source trees to determine which files have been added or removed and
to generate a list of file names. Use this tab to set up the comparison parameters for the files that you wish
to compare. After configuring your settings, click OK to start the diff.

Diff Types
The following Diff types are available:
•

Text Compare - Compares two files and shows the differences between them. When this option is
selected, after you click OK on this dialog to start the comparison, the interactive Diff dialog is
displayed, allowing you to preview the differences one-by-one before committing.
If the option on the Options tab, Instead of an interactive dialog, output one buffer with the
differences labeled, is checked, a buffer with the differences between the two files marked up will
be displayed instead.

•
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Symbols - Allows the selection of a symbol in order to set the Line Range line numbers. Not all
symbol ranges are identified. Ranges for multi-line variable declarations are not identified.
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•

Multi-File - Compares two directories or directory trees, and shows which files do not match.
Select Recurse into subdirectories to search subdirectories recursively. Click Previous diff to
load a diff state file (.dif), restoring the saved state of a multi-file diff session.

Path Information and Filespecs
The following list describes the path information and filespec settings that can be entered on the
DIFFzilla® dialog:
•

Path 1, Path 2 - To compare directories, set Path 1 and Path 2 to directory names. To compare
files, set Path 1 and Path 2 to file names. If the file names only differ by path, you only need to
specify a directory for Path 2. Click the Ellipses button to browse, or the B button to select an
open buffer.

•

Use file on disk - Select this option to diff the file on disk and not the file in the buffer.

•

More - Click this button to display additional file options.

•

Symbols - Click this button to select a symbol to diff. The selected symbol will appear next to the
word “Symbol” under the Line range options. All symbols from Path 1 are diffed against all
symbols from Path 2. Performing a multi-file diff always diffs all symbols. When symbols are diffed,
there is a multi-file diff on just two files which immediately diffs all symbols. Not all symbol blocks
are identified correctly. For an example, see Comparing Symbols or Parts of Files.

•

Line range - Specifies the start and end line numbers for the range of lines to compare. If you set
the start line number and leave the end line number blank, the range extends to the end of the file.
When you select a range of lines, you can compare parts of the same file.

•

Record file width - Specifies the record width to use when reading a file (optional).

•

Filespecs - Enter a space-delimited list of wildcard file specifications to difference. For example,
enter “*.c *.cpp *.h” to difference all files with .c, .cpp, and .h extensions.

•

Exclude filespecs - Enter a space-delimited list of wildcard file specifications to be excluded from
the differencing. For example, enter junk* test* to exclude all files with names beginning with the
words “junk” or “test”.

DIFFzilla Options Tab
Use this tab to set up file comparison options and options that affect the interactive Diff dialog. Click Save
to save the options and close this dialog without running DIFFzilla. There are two types of options
available: File Compare Options and Dialog Setup Options.
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File Compare Options

The file compare options, shown above, are described as follows:

614

•

Expand tabs into spaces before comparing - When selected, tabs are expanded to the
appropriate number of spaces before lines from each file that is compared.

•

Ignore leading spaces before text on each line - When selected, differences in leading spaces
of lines are ignored.

•

Ignore trailing spaces after text on each line - When selected, differences in trailing spaces at
the end of lines are ignored.

•

Ignore all spaces in file - When selected, differences in spacing between characters in lines are
ignored.

•

Compare files case insensitive - When selected, differences in character casing are ignored.

•

Do not compare newline characters - When selected, differences in end-of-line characters are
ignored. This is useful when comparing UNIX-formatted files with DOS-formatted files.

•

Skip comments at the beginning of the file - When selected, leading comments are ignored.
This is useful if you are using a version control system that automatically inserts comment file
headers.

•

Instead of an interactive dialog, output one buffer with the differences labeled - When
selected, a new buffer is created that contains color-coded difference output. You can edit the
output buffer. When this option is not selected, the Diff dialog box opens displaying the two files
side-by-side and the differences are color-coded.
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Dialog Setup Options

Setup options for the DIFFzilla® dialog are described as follows:
•

Show gauge during diff - When selected, a gauge control will show various processing statistics
while you wait for the differences output to complete.

•

Jump to next diff after copy block - When selected, the cursor is moved to the next difference
when you apply changes from one file to the other. For example, after clicking Block on the Diff
dialog box, the tab moves to the next difference. This option has no effect on interleaved output.

•

Automatic directory mapping - When selected, the Path 2 text box is automatically updated
when you type a directory in the Path 1 text box.

•

During multi-file diff, automatically close after last difference - When selected, clicking Next
Diff on the Diff dialog box when there are no more differences, triggers the Close button on that
dialog box.

•

Put buttons at top of diff dialog - When selected, the buttons that control operations such as
Next Diff, Prev Diff, and Block, are displayed at the top of the Diff dialog box.

•

Launch multi-file diffs in a separate process - When selected, source trees are diffed in a
separate process so you can continue working.

•

Starting position - Determines whether to place the cursor at the top of the file or at the first
difference when the Diff dialog box is displayed. This option has no effect on interleaved output.

•

Dialog initialization - Determines whether the DIFFzilla dialog box restores previous dialog
settings (history) or just places the current buffer name into the Path 1 text box. Press F7/ F8 to
restore the previous next dialog settings, respectively.
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Multi-File Diff Output Dialog
When using DIFFzilla® to perform a directory comparison (Multi-File diff type), the results are presented in
the Multi-File Diff Output dialog.

The Multi-File Diff Output dialog box contains the following elements:
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•

Diff - Shows current files in the difference editor when the selected files differ.

•

Del File - Deletes the selected file(s). Hold Ctrl+Click to multi-select in either tree. The X bitmap is
displayed.

•

View - Shows current files in the difference editor when the selected files match.

•

Copy File/Copy Tree - Copy File is displayed when the selected files differ or when the selected
file only exists in the current source tree. The Plus bitmap is displayed. Copy Tree is displayed
when the selected item is a directory that only exists in the current source tree. When you click
Copy Tree, you are prompted as to whether you want to copy the directory source tree recursively.

•

Next - Moves the cursor to the next set of mismatched files in both source trees.

•

Prev - Moves the cursor to the previous set of mismatched files in both source trees.

•

Save - Lets you save a diff state file (.dif) that you can load later with the Previous diff button on
the DIFFzilla® dialog box. This is especially useful when you have not completed merging files
and you want to continue at a later time. Also, you can generate a file list.

•

Refresh - Rediffs modified files or all files.

•

Options - Displays the DIFFzilla Options Tab. Options include ignoring spaces, skipping leading
comments, and expanding tabs.
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•

Report - Displays a report of the operations you performed in this dialog including file copies, file
deletes, and diffs where changes were saved. In addition, you can save the report.

Context Tagging® - Tag Files Dialog
The Context Tagging® - Tag Files dialog, shown below, is used to manage all your tag files. For more
information on tagging in general, see Context Tagging®. For more information about tag files, see
Building and Managing Tag Files. To access the Context Tagging® - Tag Files dialog, click Tools > Tag
Files.

The left section of the dialog lists all of your tag files, separated into categories. A tag file having a File
bitmap with blue arrows indicates the tag file is built with support for cross-referencing. The right section of
the dialog lists all the source files indexed by the currently selected tag file.
For descriptions of the Tag File categories, listed on the left side of the dialog, see Tag File Categories.
The following buttons are available on the Context Tagging® - Tag Files dialog:
•

Done - Saves tag file settings and closes the dialog box.

•

Add Files - Displays the Add Source Files dialog box, from which you can add a set of files to the
currently selected tag file. This button will be unavailable for read-only tag files and auto-updated
tag files. If you add files to your workspace tag file, you will be prompted if you want to also add the
files to your project.

•

Add Tree - Displays the Add Tree dialog box, from which you can recursively add a directory of
files to the currently selected tag file. This button will be unavailable for read-only tag files and
auto-updated tag files. If you add files to your workspace tag file, you will be prompted if you want
to also add the files to your project.

•

Remove Tag File - Deletes the currently selected tag file. You will be prompted whether or not to
delete the tag file from the list, and then whether or not to permanently delete the tag file from disk.
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Note that some language-specific tag files are automatically generated, and thus will be
automatically regenerated if you delete them.
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•

Remove Src. File - Removes the selected files from the currently selected tag file. If no files are
selected, you will be prompted whether or not to remove all source files from the tag file. If you
remove files from your workspace tag file, you will be prompted if you want to also remove the files
from your project.

•

Options - Displays the Context Tagging® Options screen for you to configure Context Tagging®
options. See Context Tagging® Options for more information.

•

Up - Moves the selected tag file higher in the search order. This primarily applies to languagespecific tag files (see Creating Language-Specific Tag Files).

•

Down - Moves the selected tag file lower in the search order. This primarily applies to languagespecific tag files (see Creating Language-Specific Tag Files).

•

Add Tag File - Displays the Add Tag File dialog box, which allows you to choose from a list of
languages the source type for which to insert the tag file. To automatically create tag files for C++,
Java, and .NET, you can instead use the Create Tag Files for Run-Time Libraries dialog (see
Creating Tag Files for Run-Time Libraries).

•

Retag Src. Files - Updates the Context Tagging information for the selected files in the currently
selected tag file. If no files are selected, you will be prompted whether or not to retag all source
files.

•

Rebuild Tag File - Displays the Rebuild Tag File dialog box containing options for rebuilding the
selected file. See Rebuilding Tag Files.

•

Auto Tag - Displays the Create Tag Files for Run-Time Libraries dialog box used to automatically
create run-time library tag files for C++, Java, and .NET (see Creating Tag Files for Run-Time
Libraries).
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Options
Options Dialog
The Options dialog is used to configure SlickEdit®. To display it, from the main menu, click Tools >
Options, or use the config command on the SlickEdit command line.
NOTE The Options dialog is new in SlickEdit 2008, and consolidates all of the dialogs formerly
accessed through the Tools > Options menu. If you’re looking for a particular option, use the search
field at the top of the dialog. See Option Search for more information.

The following sections describe how to use the Options dialog. For descriptions of individual options, skip
to the index located at Option Categories.
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Using the Options Dialog
The Options dialog is divided into two sections: the tree on the left, which contains category nodes (see
Option Categories), and the option panel on the right, which contains specific options. Right-click inside the
tree area to expand or collapse all nodes in the tree.
As you click on nodes, the option panel updates to show the applicable options. The layout of the option
panel can be either a property sheet in tabular format (like Tools > Options > Appearance > General), or
a form with radio buttons, check boxes, etc. (like Tools > Options > Appearance > Colors).
TIP The Options dialog supports keyboard shortcuts, so you can use the dialog and change settings
without having to touch the mouse. See Keyboard Shortcuts in the Options Dialog for more
information.
See the following sections for more information:
•
•
•
•
•

Changing and Applying Option Settings
Navigating to Previously Viewed Panels
Option Favorites
Option Search
Keyboard Shortcuts in the Options Dialog

Changing and Applying Option Settings
When options are displayed as a property sheet, the name of the option is shown in the Option column,
and the setting is shown in the Value column. The manner in which an option value is changed depends
on the type of option:
•

For options with combo boxes - Use the drop-down arrow to make a selection. Alternately, to
cycle through and select a setting, double-click on the option. If you’re using keyboard shortcuts,
you can toggle a combo box up and down using F4 or Alt+Up and Alt+Down, respectively, and
then use the Up and Down keys to make a selection.

•

For options with numeric text boxes - Click on the option and type directly in the text box to
change the value. If you’re using keyboard shortcuts, use one of the keys Right, Space, or F4 to
enable the text box.

•

For color options - Double-click on the color block or press F4, and the color picker is displayed.

•

For file and directory path options - Double-click on the value or press F4, and a directory
picker is displayed. If you have specified a file name or directory in a field and wish to change it
back to the default, press the Delete key. This clears the value and SlickEdit will use the default
setting.

For both forms and property sheets, when you change the value of an option, an asterisk appears after the
node name in the tree. If the option is in a property sheet, an asterisk also appears next to the option
name. This helps you see the options that have changed when you’ve made a lot of settings changes at
once. The asterisks remain until you click Apply or close the dialog. To see changes made in previous
dialog sessions, click the Options History node in the tree. See Options History for more information.
Click Apply to save option changes and leave the dialog open, or click OK to save the changes and close
the dialog. If you attempt to close the dialog by any other means, and if changes have been made but not
yet applied, you are prompted to save the changes. When the Options dialog is closed, the view is saved
and restored the next time the dialog is opened.
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Navigating to Previously Viewed Panels
Some options link to other option panels, like options for Adaptive Formatting. To make it easy to get back
to an option panel after clicking a link, Backward and Forward navigation buttons are available along the
top right side of the dialog. These buttons let you navigate between previously viewed panels, similar to the
Windows Explorer back/forward navigation features. Click the drop-down arrows to see lists of the
previously viewed option panels—click on an item in one of the lists to navigate to the panel directly.
TIPS
•

If your mouse has Back and Forward navigation buttons, you can use them to navigate
through previously viewed option panels.

•

If you prefer to use keyboard shortcuts, use Alt+Left and Alt+Right to navigate backward
and forward, respectively. See Keyboard Shortcuts in the Options Dialog for more
information about keyboard navigation.

Option Favorites
You can mark a frequently used options page as a favorite for quicker access. To add the current page to
your favorites list, click the Add [OptionsPage] to Favorites button located at the bottom of the tree. After
adding favorites, click the Show Favorites button located above the tree, and the tree changes to only
show a list of nodes which are favorites or parents of favorites. Favorite nodes are displayed in bold type.
To remove the selected favorite, click Remove from Favorites. To reset the tree to the default view, click
Show All. Note that initiating a search while viewing Favorites causes the tree to reset as well.

Option Search
The dialog lets you search for keywords throughout the options with an incremental search field located at
the top left of the dialog under Enter search text. As you type each character in the search box, the tree is
filtered to show only nodes that contain the search text. The node that contains a match is displayed in
bold type in the tree.
To reset the tree and clear the search box, click the Clear button or press Alt+C. Note that viewing
Favorites resets the tree and clears the search box as well.
After you have initiated a search, to see a list of search results, select the Search Results node. This node
only appears in the tree (at the bottom of the list) after you have started a search. The search results are
divided into columns showing the option name and the path to the option in the dialog. Double-click on an
option to navigate to the corresponding option page. For options in forms embedded in the Options dialog,
the results only show the name of the form. For example, if the Fixed Fonts Only option on the Fonts form
was a match, the results show “Fonts” as the option name and “Appearance” as the path.

Keyboard Shortcuts in the Options Dialog
If you prefer to keep your hands on the keyboard, invoke the Options dialog with the config command and
use keyboard shortcuts to navigate and change options.
Some quick tips:
•

Each time the dialog is displayed, the focus is in the Search box at the top left of the dialog. Use
Tab to navigate through the elements on the dialog.

•

Use the Right and Left keys to expand and collapse nodes in the tree.

•

Prefix matching is supported for tree nodes and in property sheets. For example, if the
Appearance node category is expanded and focus is in the tree, you can type “F” and the first
node beginning with that letter is selected (Fonts). Likewise, if focus is at the top of the
Appearance > General property sheet, you can type “C” and the first option beginning with “C” is
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selected (Cursor style). Note that only the current visible hierarchy of the tree is searched, and on
property sheets, property group headings are not included in the search.
•

Use Alt+O to jump from the option tree to the option panel.

•

On property sheets, use F4 to toggle combo boxes up and down, enable numeric text boxes, and
display color and directory pickers.

•

Press Enter to save changes and close the Options dialog, or Esc to prompt for changes before
closing the dialog.

The table below describes all of the available shortcuts.

Summary

Keyboard
Shortcut(s)

Description

Navigation

Alt+[letter] or
Alt+[number]

Performs the following actions:
• If neither form nor property sheet is visible,
jumps to the first Alt-prefixed shortcut on the
Options dialog proper (for example, Alt+C
corresponds to the Clear button next to the
Search field). Note that for most operating
systems, Alt-prefixed shortcuts correspond to
the underlined letters in labels on forms and
dialogs.
• If a form is visible, jumps to the first Altprefixed shortcut on the form (for example, in
the Appearance > Colors form, Alt+E
corresponds to the Screen element list).
• If a property sheet is visible, jumps to the first
option starting with that letter or number (for
example, on the Appearance > General
property sheet, Alt+T selects the first option
that starts with a “T”, which is Top of file
line).

Navigation

Tab

Moves the focus to each area/button on the Options
dialog. In a form, Tab moves between each area/
button on the form until reaching the last element and
placing focus back on the Options dialog proper. In a
property sheet, Tab jumps back to the dialog proper.

Navigation

Up and Down

In the tree, moves up and down the visible nodes. In
property sheets, moves up and down line-by-line. In
combo boxes, moves up and down through the
available settings.

Navigation (dialog to
panel)

Shift+Tab

Jumps from the OK button on the Options dialog to
the currently visible option panel.

Navigation (tree to
panel)

Alt+O

Shifts focus from the tree to the currently visible
option panel. Subsequently, if the panel is a property
sheet, use the Up and Down keys to navigate
through the options. If the panel is a form, use Tab to
navigate through the elements on the form.
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Keyboard
Shortcut(s)

Summary

Description

Navigation (between
panels)

Alt+Left and
Alt+Right

Navigates backward and forward, respectively,
between previously viewed option panels. Same as
using the Back and Forward buttons on the Options
dialog.

Navigation or exit

Enter

Saves changes and closes the Options dialog, or, if
inside a text box or combo box, shifts focus back to
the option panel. Same as pressing OK on the
Options dialog.

Navigation or exit

Esc

Prompts to save any changes and closes the Options
dialog, or, inside a text box or combo box, shifts focus
back to the option panel. Same as pressing Cancel
on the Options dialog.

Expands/collapses
tree nodes and
enables property sheet
controls

Right and Left

Expands/collapses nodes in the tree. In property
sheets, enables numeric text boxes and drops down
combo boxes (but not up).

Enables property
sheet controls

F4

Toggles combo boxes up and down, enables numeric
text boxes, and displays color and directory pickers.

Enables property
sheet controls

Alt+Up and
Alt+Down

Toggles combo boxes on property sheets up and
down, respectively.

Enables property
sheet controls

Space

In property sheets, enables a numeric text box and
drops down combo boxes (but not up). In the Option
Search results or Options History nodes, displays the
selected option in the option panel (same as doubleclicking).

Scrolling

Ctrl+Down and
Ctrl+Up

Scrolls the option tree and long property sheets one
line at a time.

Scrolling

PageUp and
PageDown

Scrolls the option tree and long property sheets one
page at a time.

Clears a directory/file
name property

Delete

Clears a directory or file name field, resetting the
default value.

Option search

Alt+C

Clears the Search box on the Options dialog. Same
as using the Clear button. See Option Search for
more information.

Option favorites

Alt+F

Adds or removes the selected node to or from your
favorites list. Same as using the Add to Favorites or
Remove from Favorites button on the Options
dialog. See Option Favorites for more information.
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Summary

Keyboard
Shortcut(s)

Description

Option favorites

Alt+S

Trims the tree to show only your favorite option
nodes (same as the Show Favorites button), or
displays all nodes again when viewing favorites
(same as the Show All button). See Option Favorites
for more information.

Save changes

Alt+A

Saves all option changes yet leaves the Options
dialog displayed. Same as using the Apply button on
the Options dialog.

Help

Alt+H

Displays the Help topic for the Options dialog.

Option Categories
The tree in the Options dialog (Tools > Options) contains the following category nodes, which are
described in subsequent sections:
•
•
•
•
•
•
•
•
•
•
•

Appearance
Keyboard
Editing
Debugger Options
Languages
File Options
Application Options
Network & Internet Options
Tools
Help Options
Options History

Appearance Options
Appearance options (Tools > Options > Appearance) allow you to customize the look of SlickEdit®. You
can change fonts and colors, specify which toolbars and tool windows to display, enable display of special
characters, and more. Appearance option categories are:
•
•
•
•
•
•
•

General
Colors
Fonts
Toolbars
Special Characters
History
Advanced

General Appearance Options
General appearance options are shown below (Tools > Options > Appearance > General).
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The options are described as follows:
•

Horizontal scroll bar - When set to True, each editor window displays a horizontal scroll bar. This
does not affect edit window controls on dialog boxes.

•

Vertical scroll bar - When set to True, each editor window displays a vertical scroll bar. This does
not affect edit window controls on dialog boxes.

•

Window left margin - Specifies the amount of space, in inches, between the left edge of the
window and the editor text. This option has no effect when there are bitmaps displayed in the left
margin, since more space may be necessary to accommodate the size of the bitmap.

•

Cursor style - Specifies the style of the cursor (block/text mode style, or vertical).

•

Hide mouse pointer - When set to True, the mouse pointer is hidden when typing, but visible
when moving the mouse or when a dialog box is displayed.

•

Vertical line column - Specifies the column in which the editor is to display a vertical line. When
the value is set to 0, the vertical line is not displayed.

•

Vertical line color - Specifies the color of the vertical line when it is displayed.

•

Top of file line - When set to True, a line 0 is inserted at the top of each buffer with the text “Top of
File”. Does not affect lines of code. Note that rather than setting this option, you can press
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Ctrl+Shift+Enter (Ctrl+Enter in the Visual C++ and Visual Studio default emulations) to insert a
new line above the line where the cursor is located.
•

List command line completions - When set to True, a pop-up list of possible commands and
argument completions is displayed for partially typed commands and arguments on the SlickEdit
command line. See Command Line Completion for more information.

•

Change directory - When set to True, the current directory is changed in the editor when the
directory is changed in the Change Directory dialog (File > Change Directory) and the Open and
Save As dialogs (File > Open and File > Save As).

•

Show files beginning with a dot - (UNIX only) When set to True, the Show hidden files option
on the UNIX Open and Save dialogs, and the Open tool window on all platforms, is checked by
default. This value is also controlled by the configuration variable def_filelist_show_dotfiles.

•

Scroll style options include:

•

•

o

Smooth horizontal scroll - When set to True, editor windows scroll column-by-column when
the cursor moves out of view. When set to False, the cursor is centered and the text is scrolled
one-fourth the width of the window when the cursor moves out of view.

o

Smooth vertical scroll - When set to True, editor windows scroll line-by-line when the cursor
moves out of view. When set to False, the cursor is centered and the text is scrolled half the
height of the window when the cursor moves out of view.

o

Scroll when - Specifies how close (in number of lines) the cursor may get to the top or bottom
of the window before scrolling occurs. Does not affect horizontal scrolling.

Current line highlight options include:
o

Current line highlight - Specifies the type of highlight to be drawn around the current line.
When None is selected, the current line is not highlighted. When Draw box only is selected, a
dotted box is drawn around the current line. When Tabs ruler is selected, a box is drawn
around the current line with tab stops marked. When Syntax indent ruler is selected, a box is
drawn around the current line with Syntax Indent levels marked. When Decimal ruler is
selected, a box is drawn around the current line with marks at multiples of five and 10.

o

Current line box color - Specifies the color of the box outline when Current line highlight is
enabled.

o

Current line column color - Specifies the color for column markers when using a current line
highlight with column indicators (Tabs, Syntax Indent, or Decimal rulers). Note that this is the
same as the margin color.

Message list colors - Select from the following options that pertain to the Message List feature:
o

Message visited color - Specifies the color of the message in the Message List tool window
after you have navigated to the associated code location.

o

Message modified color - Specifies the color of the message in the Message List tool
window after the line at the associated code location has been modified.

Color Options
Color options are shown below (Tools > Options > Appearance > Colors). These options let you specify
colors for screen elements in SlickEdit® and create and manage color schemes. See Colors for more
information.
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The options are described as follows:
•

Set embedded language color - When this option is selected, you can define the colors for
source code (for example, JavaScript embedded in an HTML file). For HTML, the syntax colorcoding recognizes the <script language="???"> tag and uses embedded language colors for the
new language. In addition, for Perl and UNIX shell scripts, you can prefix your HERE document
terminator with one of the color-coding lexer names to get embedded language color-coding. For
an example, see Setting Colors for Screen Elements

•

Screen element - Select the screen element before changing the Foreground and Background
colors. Most of the screen element items are obvious except for those in the following list:
o

Window Text - This is the color of other text which is not a specific syntax element.

o

Attribute (HTML only) - This is the color used for a recognized attribute of an HTML tag. For
example, the src attribute of the img tag gets this color.

o

Cursor - This screen element is displayed in the active edit window when the cursor is placed
on the command line. It is not the color of the blinking cursor.

o

Current Line, Current Selected Line, Selection - SlickEdit will attempt to render these
elements using your normal color settings for the Foreground color. The selected
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Foreground color will only be used if there is not enough contrast between the font colors to
be readable. It is best to specify a Background color for these elements that is as close as
possible to your normal background color, ensuring that the color-coded fonts are still easy to
read.
•

Foreground/Background - Click the color squares to change colors for the selected element. The
Color Picker dialog is displayed, allowing you to pick a color from the palette or set your own
custom color using RGB values.

•

Use system default - When this option is selected, the operating system’s default colors are
used. Currently, this check box is only available for the Status and Message fields. For UNIX, the
system default colors are selected by the editor and not the operating system.

•

Sync backgrounds - Click to apply the current Background color as the Background color for
other elements. The Select Colors to Update dialog appears, from which you can select specific
elements to affect.

•

Font Style - For color-coded elements, you may choose whether the element is normal, bolded,
italicized, or underlined. For example, keywords are bold by default.
o

Use fixed spacing for bold and italic fixed Unicode fonts - (Unicode support required)
When this option is selected, and a fixed font is selected for a Unicode source window, bold
and italic color-coding is supported. Since this requires the Unicode text to be converted to the
active code page, some characters may be displayed incorrectly. The current editor display
engine ignores bold and italic settings for proportional fonts or fixed Unicode fonts (which are
treated like proportional fonts).

•

Reset - Restores all colors to the values they were when the editor was invoked.

•

Color scheme - Specify the color scheme to use from the drop-down list. Several predefined
schemes are available or you can define your own. See Using Color Schemes for more
information.
o

Save scheme - Allows you to save the current color settings as a new color scheme with a
name you specify.

o

Delete scheme - Deletes the selected color scheme.

o

Rename scheme - Allows you to rename the selected color scheme.

Font Options
You can specify which fonts are used by the command line, status text, and other screen elements using
the options shown below (Tools > Options > Appearance > Fonts). If you want to change the font used in
editor windows, use Window > Font instead. See Fonts for more information about changing fonts and a
list of recommendations.
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The options are described as follows:
•

Element - This drop-down contains the screen elements for which fonts can be changed. When an
element is selected, the font type and size will automatically adjust to the current settings for that
element, and a preview of the font will be displayed in the Sample area. Select from the following
elements:
o

Command Line - The SlickEdit® command line displayed at the bottom of the application
window.

o

Status Line - For status messages displayed at the bottom of the application window.

o

SBCS/DBCS Source Windows - Editor windows that are displaying non-Unicode content (for
example, plain text).

o

Hex Source Windows - Editor windows that are being viewed in Hex mode (View > Hex).

o

Unicode Source Windows - Editor windows that are displaying Unicode content (for
example, XML).

o

File Manager Windows - Controls the display of the SlickEdit File Manager (File > File
Manager).

o

Diff Editor Source Windows - The editor windows used by DIFFzilla®.

o

Parameter Info - Controls the fonts used to display pop-ups with information about symbols
and parameters.

o

Parameter Info Fixed - Used when SlickEdit needs to display a fixed-width font for parameter
info, such as when displaying example code.
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o

Selection List - The font used for selection lists, like the buffer list (Document > List
Buffers).

o

Dialog - Controls the font used in SlickEdit dialogs and tool windows.

o

HTML Proportional - The default font used by HTML controls for proportional fonts. In
particular, this affects the Version Control History dialog, the About SlickEdit dialog, and the
Cool Features dialog.

o

HTML Fixed - The default font used by HTML controls for fixed-space fonts.

•

Font and Size - The Font and Size fields allow you to make typeface and point size changes to
the selected screen element. The fonts that are listed are the fonts that are installed on your
computer.

•

Style - Styles, such as bold and italic, can be set to affect the selected font.

•

Sample area - This area provides a preview of the selected font, size, and style.

•

Fixed Fonts Only - Select this option to display only fixed fonts in the Font field. By default, this
option is not selected.

•

Script (Windows only) - Choose Default unless you are editing files that have characters not in
the active code pages. Choose Western to use the typical English characters.

Toolbar Options
Toolbar options (Tools > Options > Appearance > Toolbars) let you change settings that affect toolbars
and tool windows. Note that you can also access these options from the main menu by clicking View >
Toolbars > Customize, or by right-clicking on any tool window’s title bar (or on UNIX/Mac, the tool
window’s background) and selecting Customize. See Toolbars and Tool Windows for more information.
The options are divided into three tabs:
•
•
•

Toolbar Options Toolbars Tab
Toolbar Options Categories Tab
Toolbar Options Options Tab

Toolbar Options Toolbars Tab
The Toolbars tab contains a list of the default toolbars and tool windows within SlickEdit®, and settings
made here are on a per-toolbar/tool window basis.
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The following options are available:
•

New - Creates a new, empty toolbar.

•

Rename - Renames the selected toolbar. Note that you can only rename custom toolbars.

•

Delete - Deletes the selected toolbar. Note that you can only delete custom toolbars.

•

Reset - Restores the default buttons to the selected toolbar (not applicable for custom toolbars).

•

Visible - When checked, the selected toolbar/tool window is displayed, if it is not already
displayed. When unchecked, the selected toolbar/tool window is closed.

•

Always on Top - When checked, the selected toolbar/tool window, when non-docked, will remain
on top of the editor window.

•

Allow Docking - When unchecked, the selected toolbar/tool window, when non-docked, cannot
accidentally be docked.

•

ESC dismisses floating window - When checked, pressing Esc on a floating tool window (not a
docked or auto-hide window) will dismiss the tool window as if it were a dialog. When unchecked,
pressing Esc on a floating tool window puts focus back to the active MDI child. Note that this
option applies to floating tool windows only (not toolbars).

TIP Pressing Esc on a docked tool window puts focus back to the active MDI child. Pressing Esc on
an auto-hide tool window will hide the tool window.
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•

Show tool tips - When set to True, pop-up tool tips are displayed when the mouse pointer rolls
over a button. This option is global to all toolbars/tool windows.

•

Tool tip delay (ms) - Specifies the delay, in tenths of a second, before tool tips are displayed when
Show tool tips is enabled.

•

Hide when application is inactive - When checked, non-docked toolbars/tool windows are
hidden when you switch to another application. When you switch back to SlickEdit, the toolbar/tool
window is made visible again. This option is global to all toolbars/tool windows.

Toolbar Options Categories Tab
This tab categorizes the toolbar controls (buttons) and allows you to drag and drop them onto existing
toolbars.

Select a category from the Categories list and the associated controls are displayed in the Controls box.
Click on the control you wish to add, and drag it onto a toolbar. See also Toolbar Control Properties Dialog.

Toolbar Options Options Tab
The Options tab contains settings that apply globally to toolbars and tool windows.
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The following options are available:
•

Toolbar button size and spacing - Specify the size of buttons and the amount of vertical and
horizontal spacing between buttons on a toolbar. These options affect both vertically and
horizontally docked toolbars. Click Apply to save changes.

•

Close button affects active tab only - When checked, the Close button on a tool window will
close only that tool window. When unchecked, and the tool window is tab-linked with other tool
windows, all tab-linked tool windows are closed. By default, this option is selected.

•

Auto Hide button affects active tab only - When checked, the Auto Hide button (the Pushpin
button) on a tool window will auto-hide only that tool window. When unchecked, and the tool
window is tab linked with other tool windows, all tab-linked tool windows are auto-hidden. Autohidden tool windows are displayed in the dock channel on the side of the editor where they were
auto-hidden. By default, this option is not selected.

•

Animate tool windows - When checked, auto-hide and auto-show of tool windows is animated.
When unchecked, tool windows are shown and hidden immediately. By default, this option is
selected.

•

Speed - When Animate tool windows is checked, a slider is used to adjust the speed of
animation during auto-hide and auto-show. Adjust positive (+) to increase speed and negative (-)
to decrease speed. By default, the speed is set to medium.

•

Auto Show tool window on mouse over - When checked, auto-hidden tool windows are autodisplayed when the mouse is over the item in the dock channel. Delay specifies how long to wait
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(in tenths of a second) before the mouse triggers an auto-hidden tool window to auto-display. By
default, the delay is set to 5.
•

Auto Hide delay - Specifies how long to wait (in tenths of a second) before an auto-displayed tool
window auto-hides itself. By default, this delay is set to 10.

Special Character Options
Special character options are shown below (Tools > Options > Appearance > Special Characters).
These options are used to define the characters that are displayed when the view of special characters is
enabled. Enabling special characters inserts characters into your file to show such items as tabs, spaces
and line endings that are otherwise invisible. See Viewing Special Characters for more information about
these settings.
NOTE The viewing of special characters is only available for ASCII files.

History Appearance Options
These options (Tools > Options > Appearance > History) let you view a list of recently opened files and
projects.
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You can see the history of items recently opened from the File or Project menu. These are listed in the
History type box. When you select a menu, the Items box updates to show the latest files that were
opened from that menu. Click Delete to remove selected items from the history list.

Advanced Appearance Options
Advanced appearance options are shown below (Tools > Options > Appearance > Advanced).
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The options are described as follows:
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•

Expand/collapse - Specifies how Selective Display expand/collapse bitmaps (View > Selective
Display) are clicked in order to expand/collapse areas. For more information, see Selective
Display.

•

Short key names - Specifies how keyboard shortcuts are displayed in the MDI menu bar. For
example, when Long is selected, the Edit > Undo menu item shows Ctrl+Z for the shortcut. This
is traditional for the CUA emulation. When Short is selected, C-Z is displayed, traditional in other
emulations.

•

Windows 3.1 style open dialog - (Windows only) When set to True, a Windows 3.1-style Open
dialog box is used to open and save files. This dialog does not support all the features of the
default Open dialog (for example, encoding options are not supported). For more information on
this dialog, see Windows 3.1-Style Open Dialog.

•

Windows style Browse for Folder dialog - (Windows only) When set to True, a Windows-style
Browse for Folder dialog box is used to choose directories when possible. This dialog displays the
navigation tree in a more Windows-friendly structure, letting you navigate to items such as the
Desktop, My Computer, etc. When set to False, the standard Choose Directory dialog is used at
all times. This dialog displays the navigation tree on a disk-drive basis, starting with the current
drive, and includes a text box that supports Directory Aliases that help you quickly type the
directory name.
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Keyboard Options
Keyboard options (Tools > Options > Keyboard) pertain to use of the keyboard and mouse, and include
options for setting the emulation you want to use and creating custom key bindings.
Keyboard option categories are:
•
•
•
•

Emulation
Key Bindings
Redefine Common Keys
Advanced

Emulation Options
Emulation options (Tools > Options > Keyboard > Emulation) are shown below. Use these options to
specify the editor's emulation mode and to restore default key bindings. Be sure to save your custom
bindings before switching emulations. This can be done by exporting (click Key Bindings in the Options
tree) or by using the prompt that is displayed when you switch emulations. See Emulations for more
information about these settings.

Key Binding Options
Key binding options are shown below (Tools > Options > Keyboard > Key Bindings). From here, you
can view, create, and manage key binding associations for SlickEdit® commands and user-recorded
macros. You can also import, export, or save a chart of your key bindings. See Managing Bindings for
more information.
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NOTES
•

The first time the Key Bindings option screen is invoked, the Building Tag File progress bar
may be displayed while Slick-C® macro code is tagged.

•

Bindings are based on the editor emulation mode (CUA is the default). To change the
emulation mode, click Tools > Options > Emulation. For more information, see
Emulations.

The Key Bindings option screen is described as follows:
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•

Search by command - This filter is used for searching commands in the Command column. Type
a string in the filter box, and the list of commands is filtered as you type to show only those
commands that contain the specified string. The red X button is used to clear the text box or you
can edit inside the text box manually.

•

Search by key sequence - This filter is used for searching bindings in the Key Sequence
column. It captures literal keyboard input. For example, when the focus is in this filter, press Ctrl
and C at the same time, and “Ctrl+C” is displayed. Press the Backspace key and “Backspace” is
displayed. Mouse events inside the filter are literal as well. For example, right-clicking within the
filter displays the text “RButtonDn”. Because the key sequence filter captures literal keyboard
input, you cannot edit the text or use key functions such as backspacing or tabbing in and out of
the field. You must use the red X button to clear the filter.
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•

Command - This column lists, in alphabetical order by default, the SlickEdit® commands and user
macros that are or can be bound to keys or mouse events. Click on the column label to sort
bindings by this column. An arrow in the column header indicates the sort order (ascending or
descending).
If a command/macro has more than one binding, each instance is listed on a separate row. For
example, in CUA emulation, the command gui_open is bound to F7, Command+O (on the Mac),
and Ctrl+O. Therefore, gui_open appears in the Command column three times, once for each
binding.

•

Key Sequence - This column shows the mouse event or key sequence associated with the
command or macro. If a Key Sequence cell is empty, no binding is associated with that command/
macro. Click on the column label to sort bindings by this column. An arrow in the column header
indicates the sort order (ascending or descending).

•

Mode - This column shows the language editing mode to which the key binding applies. The
default mode causes the binding to work in all language editing modes. However, the default
mode will be overridden by any language-specific mode binding to another command/macro. Click
on the column label to sort bindings by this column. An arrow in the column header indicates the
sort order (ascending or descending).

NOTE To change the mode for a command/macro that is already bound, first you should unbind the
command/macro, then recreate the binding with the mode you want to use. See Editing Bindings for
more information. For information about editing modes, see Language Editing Mode.
•

Recorded - This column indicates if the item in the Command column is a SlickEdit command
(No) or a user-recorded macro (Yes).

•

Documentation pane - The bottom pane displays the code documentation for the selected
command or macro, if it exists. Click “See Also” hyperlinks (if any exist) to display Help for that
item. For See Also links, if a Help entry does not exist, a message box notification is displayed.
The documentation pane can be resized by dragging the size bar above it. The size is
remembered the next time the screen is displayed.

•

Import and Export - These buttons allow you to import and export bindings. This is useful for
creating backups, sharing with other team members, or taking with you should you switch
computers. See Exporting and Importing Bindings for details of these features.

•

Save Chart - This button allows you to save a reference chart of all current bindings for all
language editing modes in the selected emulation. The chart is saved in HTML format with a name
and location that you specify. Commands/macros that are not bound are not included.

•

Remove - This button clears the binding for the selected command/macro. You can also press the
Delete key to clear the binding.

•

Add - This button displays the Bind Key dialog, which is used to initiate a new binding. See Bind
Key Dialog and Creating Bindings for more information.

Bind Key Dialog
This dialog is used to initiate a new key binding and is displayed when you click Add on the Key Bindings
option page.
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The dialog is described as follows:
•

Command - This field shows the command that you have selected to bind.

•

Key Sequence - This field is used to enter the key sequence or mouse event that you want bound
to the command. For example, to enter the key sequence Ctrl+W, literally press the Ctrl and W
keys together. It accepts literal keyboard/mouse input, so you cannot edit the text or use key
functions such as backspacing or tabbing in and out of the field. You must use the red X button to
clear the filter.

•

Mouse Event button - Click this button located next to the red X button to pick a mouse event to
use for the binding. If the event involves pressing a modifier key or keys, such as Ctrl, Alt, Shift,
Cmd, Ctrl+Alt, etc., in conjunction with a mouse click, for example, Ctrl+RButtonDn, press the
modifier key(s) when clicking the Mouse Event button. Then the Select Mouse Event dialog
shows a list of modifier-prefixed mouse events. After selecting the mouse event you want to look
up, click OK. The Key Sequence field updates to show the selected mouse event.

•

Bind - After entering the key sequence or mouse event, click this button to save the binding and
close the dialog. Prior to clicking Bind, you may want to assign the binding to a specific language
editing mode (see below).

•

Cancel - Click this button to cancel the binding operation and close the dialog.

•

Advanced - Click this button to expand the language editing mode settings. By default, all new
bindings are assigned to the “default” language editing mode, which means that the binding will
work in all modes. To assign the binding to a specific language editing mode, select Bind to mode
and click the language editing mode from the drop-down list.

Redefine Common Key Options
Redefine Common Key options (Tools > Options > Keyboard > Redefine Common Keys) allow you to
change the behavior of certain common keys. See also Redefining Common Keys for more information.
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The options are described as follows:
•

Cursor right/left wraps to next/previous line - When set to True, the cursor_left and
cursor_right commands wrap to the previous or next line respectively.

•

Cursor up/down places cursor in virtual space - When set to True, the cursor_up and
cursor_down commands place the cursor up or down, respectively, at either the end of the line or
at the column of the original location, whichever comes first. The cursor is never placed past the
end of the line. When set to False, cursor_up and cursor_down go to the same column of the
next or previous line, regardless of the length of the line.

•

Cursor up/down within soft wrapped lines - When set to True, if Soft Wrap is enabled (View >
Soft Wrap), the cursor_up and cursor_down commands move the cursor up to the next or
previous visible line, including line continuations. When set to False, cursor_up and
cursor_down moves the cursor to the previous or next physical line (the same position to which
the cursor would move if Soft Wrap was off).

•

Line wrap - Specifies when line wrapping occurs, either when the cursor reaches column one or
when it reaches the left margin. When language-specific Word Wrap is on (Tools > Options >
Languages > [LanguageCategory] > [Language] > Word Wrap), wrapping occurs when the left
margin is reached regardless of this setting.

•

Jump over tab characters - When set to True, moving the cursor over a tab character with the
Left or Right arrow key causes the cursor to jump across the virtual space. When set to False, the
Left and Right arrow keys move the cursor into the virtual space of tab characters. Note that this
setting also controls where the cursor is placed when clicking in a buffer or making a selection.
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•

Backspace in Replace mode - Specifies the behavior of the Backspace key when the Start mode
is set to Replace (Tools > Options > Editing > General > Start mode). When Remove previous
character only is selected, Backspace removes the previous character and moves the cursor left.
Otherwise the previous character is replaced with a space.

•

Backspace over tab - Specifies the behavior of the Backspace key when the previous character is
a tab. When Convert tab to spaces and remove 1 space is selected, the Backspace key deletes
through tab characters one column at a time.

•

Cursor left/right in leading spaces - Specifies the behavior of the cursor_left and cursor_right
commands when moving the cursor within leading space. The purpose of this option is to emulate
the “feel” of real tab characters even if you only use spaces for indentation.

•

Use Ctrl+Space for input method editor - (Linux only) When set to True, pressing Ctrl+Space
activates the Smart Common Input Method (SCIM) editor. When set to False, Ctrl+Space
executes its key binding, which performs symbol completion by default. You must enable SCIM
support for this option to have any effect. To enable SCIM support, set the VSLICK_XIM
environment variable to scim, and set the XMODIFIERS environment variable to @scim. This
feature only supports the SCIM editor on Linux.

•

Redefinable keys options are:
o

Backspace key - Specifies when the cursor is allowed to wrap to the previous line when
pressing the Backspace key at the left margin.

o

Delete key - Specifies the behavior of the Delete key when the rest of the current line is empty.
When Next line always joins is selected, the line below the current line is joined with the
current line.

o

End key - Specifies where the cursor is placed when pressing the End key. The Toggle option
is useful for trimming extra spaces from long lines, because it gives you a natural and quick
way to get to your vertical line column and the last non-blank column.

o

Enter key - Specifies whether a line is split when pressing Enter and how the cursor is aligned
on the new line. Nosplit Insert Line inserts a blank line after the current line and aligns the
cursor with the first non-blank character of the original line. The current line is not split. Split
Insert Line splits the current line at the cursor. Enough blanks are inserted at the beginning of
the new line to align it with the first non-blank character of the original line. Maybe Split Insert
Line means that if the Start mode is set to Insert (Tools > Options > Editing > General >
Start mode), the current line is split at the cursor. Enough blanks are appended to the
beginning of the new line to align it with the first non-blank character of the original line. If the
Start mode is set to Replace, the cursor is moved to column one of the next line.

NOTE When changing the key binding for the Enter key, the binding for Ctrl+Enter will automatically
switch to the opposite setting, depending on whether it is bound to Split Insert Line or Nosplit
Insert Line.
o

Home key - Specifies where the cursor is placed when pressing the Home key.

Advanced Keyboard Options
Advanced keyboard options are shown below (Tools > Options > Keyboard > Advanced).
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The options are described as follows:
•

Alt menu hotkeys - (Non-CUA emulation modes only) When set to True, “Alt”-prefixed keyboard
shortcuts display the corresponding drop-down menu. When set to False, you can be more
selective about key bindings because you are permitted to bind Alt keys you normally could not,
such as Alt+F. Set to False if you bind Alt keys that are normally menu keys; otherwise, you will
lose these key bindings.

•

Alt menu - When set to True, pressing the Alt key without following it with another key causes the
focus to shift to the menu bar, and the hotkeys in the menu names are underlined.

•

Key message delay - Specifies the maximum delay, in tenths of a second, between two key
combinations when used as a single key binding (for example, Ctrl+X,Ctrl+C). If the time limit is
exceeded between when the two key combinations are pressed, the key sequence is interpreted
as two separate bindings.

•

Command line prompting - When set to True, pressing a key binding that normally opens a
dialog box causes the SlickEdit command line to prompt for arguments instead of opening the
dialog. For example, instead of displaying the Open file dialog, Ctrl+O (bound to gui_open) opens
the command line prompting for the file to open. See Command Line Prompting for more
information.

Editing Options
Editing options (Tools > Options > Editing) directly impact your SlickEdit® coding experience. By
customizing these options so that SlickEdit works the way you prefer and to which you are accustomed,
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you can greatly improve your coding speed and efficiency. Editing options include default search/replace
values, selection styles, specifying the size of new editor windows, and more.
Editing option categories are:
•
•
•
•
•
•

General
Editor Windows
Context Tagging® Options
Selections
Search
Global Aliases

General Editing Options
General editing options are shown below (Tools > Options > Editing > General).

The options are described as follows:
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•

Start mode - Specifies the default insert/replace editing mode to use each time the editor is
invoked. The editing mode is indicated in the status line of the editor (Ins or Rep). You can also
click on the indicator to toggle the editing mode.

•

Click past end of line - When set to True, the cursor can be placed past the end of a line into
virtual space.

•

Line insert style - SlickEdit® treats line selections differently than character selections. This
option controls whether lines are inserted before or after the current line when you paste a line
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selection. This feature saves you from having to tediously position the cursor at the beginning or
end of a line prior to pasting.
•

Next word style - Specifies the cursor behavior when navigating with the next_word command
(Ctrl+Right). When Begin is selected, the cursor is placed on the beginning of the next word.
When End is selected, the cursor is placed at the end of the next word.

•

Maximum clipboards - Specifies the maximum number of clipboards saved. By default, a stack of
your last 50 clipboards are kept, any one of which can be pasted with Ctrl+Shift+V.

•

Allow drag/drop of text - When set to True, selected text can be copied or moved by dragging
and dropping the selection using the left mouse button.

•

Throw away file lists - When set to True, File Manager file lists (File > File Manager) can be
modified and closed without a save prompt.

•

Auto exit build window - When set to True, the concurrent build window is automatically exited
when the buffer is closed or when exiting the editor.

•

Reflow next - Specifies where the cursor is placed when running the reflow_paragraph
command. When Cursor on next paragraph is selected, the cursor is placed on the next
paragraph after it has reformatted the current paragraph.

•

Protect read-only mode - When set to True, read-only files cannot be modified. If you attempt to
modify a read-only file, SlickEdit displays a notification. If you attempt to save a read-only file,
SlickEdit prompts for a different output file name.

•

CUA text box - When set to True, the keys Ctrl+X, Ctrl+C, and Ctrl+V perform cut, copy, and
paste commands respectively for text boxes other than the command line, regardless of the
emulation. When False, these keys operate the same in a text box as they do in the command line
and edit windows, which could be useful if you're using a non-CUA emulation or prefer to use your
own editing key bindings.

•

Preserve column on top/bottom - When set to True, the top_of_buffer (Ctrl+Home) and
bottom_of_buffer (Ctrl+End) commands do not change the column position unless already at the
top or bottom of the buffer.

•

CR w/o LF erases line in build window - When set to True, lines of output sent to the Build tool
window that contain carriage return (CR) characters without subsequent line feed (LF) characters
are erased. When set to False, these lines are not erased.

TIP Where does this concept originate? On manual typewriters, carriage return (CR) moves the
carriage back to the first column of text, and line feed (LF) moves to the next line. Older computer
terminals, such as VT100 and its successors (Windows and UNIX shells), used this terminology as a
metaphor to redraw lines. For example, to draw a line that showed percent complete, you would
output “CR <number>%” repeatedly, then issue the line feed when it finished. In SlickEdit therefore,
due to this practice, it is possible that output sent to the Build tool window may contain carriage
return characters without subsequent line feed characters. When this happens, the line is erased in
the Build window.
•

Parenthesis matching - See Begin/End Structure Matching for more information about paren
matching. The following options available:
o

Parenthesis matching style - When Highlight is selected, after typing a closing paren,
SlickEdit temporarily block-selects the text within the paren pair. When Cursor to Begin
Paren is selected, after typing a closing paren, SlickEdit temporarily places the cursor on the
matching begin paren. When None is selected, SlickEdit just inserts the closing paren.
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o

Highlight matching blocks - When set to True, the corresponding parenthesis, brace,
bracket, or begin/end word pair under the cursor is automatically highlighted.

TIP To customize the highlight color, go to Tools > Options > Appearance > Color, and select the
Block Matching screen element. To adjust the delay in milliseconds before the highlighting is
updated, go to Macro > Set Macro Variable and modify the variable def_match_paren_idle. See
Setting Colors for Screen Elements and Setting/Changing Configuration Variables for more
information.

Editor Window Options
Editor window options are shown below (Tools > Options > Editing > Editor Windows). See also Buffers
and Editor Windows for more information.

The following options are available:
•

Files per window - Specifies whether each buffer opened in SlickEdit® is allocated in its own
editor window or in the same editor window.

•

Maximize first window - When set to True, the first editor window opened in SlickEdit is
maximized.

•

Smart next window style - Specifies preferences for navigating between editor windows. Select
from the following values:
o
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Smart next window - This is the default style. It allows you to press Ctrl+Tab (next_window
command) to switch the focus between the two most frequently used open editor windows,
rather than always going to the next window. Press Ctrl+Shift+Tab (prev_window command)
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to switch between all open editor windows. This style is similar to how Ctrl+Tab and
Ctrl+Shift+Tab work in other Windows MDI applications, like Visual Studio.

•

o

Reorder windows - If selected, activating an existing window reinserts the window after the
current window. Neither Ctrl+Tab nor Ctrl+Shift+Tab reorders the windows. This option is
very good for switching between more than two files, but it is not the Windows standard. It's
similar to the way SlickEdit reorders buffers.

o

No window reordering - If selected, newly opened windows are inserted after the current
window, like in all settings. Activating an existing window, pressing Ctrl+Tab, or pressing
Ctrl+Shift+Tab does not reorder windows. This option is best if you memorize the hot key
numbers on the Window menu (for example, Alt+W,1) because it attempts to keep the hot key
numbers the same.

New window size - These options are used to specify the width and height for new editor
windows. See Buffers and Editor Windows for more information.
o

New window width and New window height - Use the drop-down to specify one of the
following values regarding the width and height for new editor windows:
- Custom value - When this value is selected, you can specify a size in the Custom window
width and height fields.
- Default - When this value is selected, the default window size is used as determined by
SlickEdit.
- Use current window - When this value is selected, the width/height of the current window is
used for new windows.
- Use maximum available - When this value is selected, new windows are stretched to fill the
size of the editor pane. This size is dynamic, so if you change the size of the editor pane, new
windows will be created using the maximum size of the adjusted editor pane, but existing
windows will retain their size. This setting is different from Maximize first window in that new
windows are not technically maximized; they still have a border and title bar.

o

Custom window width and Custom window height - Specifies the custom width and height,
in pixels, for new editor windows. The size you have specified is used each time an editor
window is opened. This field is enabled when you select Custom as the value for the New
window width/height options.

Context Tagging® Options
Context Tagging options are shown below (Tools > Options > Editing > Context Tagging® Options).
These options let you set general parameters for the Context Tagging features. You can designate the way
Context Tagging is performed and how the references function within the application, and you can also
tune the application to maximize performance. See also Building and Managing Tag Files for more
information.
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The following options are available:
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•

Tag file on save - When set to True, files are retagged when you save a modified file.

•

Background tagging of open files - Select from the following:
o

Background tagging of open files - When set to True, all open files are retagged in the
background if they have been modified.

o

Start after seconds idle - Specifies the amount of time, in seconds, the editor remains idle
(no keyboard or mouse movements) before retagging of buffers starts, when Background
tagging of open files is enabled.

o

Update tool windows after ms idle - Specifies the amount of time, in milliseconds, the editor
waits before updating the Defs, Preview, and Current Context tool windows.

o

Max size of files to tag - Specifies the maximum size, in kilobytes, a file is allowed to have in
order to be tagged.
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o

•

•

Max number of tags per file - Specifies the maximum number of tags (including statements,
if Statement Level Tagging is enabled) that a file is allowed to have in order to appear in the
Defs and Current Context tool windows.

References - Select from the following:
o

Build workspace tag file with references - When set to True, newly created tag files are
built with support for symbol cross-references.

o

Find references incrementally (faster) - When set to True, reference queries are faster
because analysis stops when a file is found containing a valid reference. However, you may
see files which do not have any references to the symbol you are looking for listed in the
References tool window. When set to False, all files with potential references are searched
and analyzed so that the files which do not contain any references are removed.

o

Update references and call tree on single click - When set to True, references in the
References tool window are updated when you click on a new symbol in the Classes, Defs, or
Symbols tool window.

o

“Go to references” only lists references - When set to True, Go to Reference searches for
references but does not jump immediately to the first reference. When set to False, Go to
Reference searches for references and automatically jumps to the first one. Note that you can
find the next reference by using the find_next command (Search > Find Next or Ctrl+G).

o

Highlight references in editor - When set to True, each reference is highlighted within files.

Background tagging of other files - Select from the following:
o

Background tagging of other files - When set to True, tag files are updated when another
application modifies a file. Note that this causes SlickEdit to constantly perform disk I/O to
check dates of files on disk.

o

Start after minutes idle - Specifies the amount of time, in minutes, the editor remains idle (no
keyboard or mouse movements) before retagging of files on disk starts, when Background
tagging of open files is enabled.

o

Maximum number of files to tag - Specifies the maximum number of files that SlickEdit retags in one pass, when Background tagging of open files is enabled.

o

Maximum number of files to consider - Specifies the maximum number of file dates to
consider for processing when background tagging starts. Specifying a smaller maximum value
allows you to regain editor access more quickly, but re-tagging is slower. Specifying a larger
maximum value allows re-tagging to be quicker, but it will take longer to regain editor access.

o

Minutes before restarting - Specifies the number of minutes to wait for background tagging
to start again after all files have been fully tagged.

o

Workspace tag file only - When set to True, background tagging cycles through only the
workspace tag file. When set to False, background tagging cycles through all of your
language-specific tag files (listed under Tools > Tag Files) in addition to the workspace tag
file.

CAUTION We do not recommend you run a second copy of the editor to perform tag file updating
because it will cause tag file access problems. Under UNIX the editor will crash if multiple editors are
updating the same tag files.
•

Maximums (tune for performance) - You can tune Context Tagging performance and accuracy
by adjusting these values. Higher values will find more tags but increase search time. Lower
values improve performance but may cause tags to be omitted.
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o

Maximum functions found by parameter help - Specifies the maximum number of
overloaded functions to display when function parameter help (Parameter Information) is
invoked.

o

Maximum globals shown in list members - Specifies the maximum number of global
symbols to display when List Members is invoked.

o

Maximum class/struct members shown in list - Specifies the maximum number of class/
struct members to display when List Members is invoked.

o

Maximum candidates for list parameters - Specifies the maximum number of local variables
and class members that are evaluated to determine assignment compatibility when Auto List
Compatible Parameters is invoked.

o

Maximum response time to list parameters - Specifies the maximum amount of time, in
milliseconds, that SlickEdit spends finding compatible parameters. Note that this is not a hard
limit; in some cases, evaluating the assignment compatibility of a single variable can be timeconsuming, especially when templates are involved.

o

Maximum tags found in symbol search - Specifies the number of tags found when Find Tag
is invoked (right-click in the Symbols Tool Window and select Find Tag). This setting also
controls the number of duplicate tags that are tried when SlickEdit is attempting to evaluate
the type of a symbol.

o

Maximum tag file cache size - Specifies the maximum cache size, in kilobytes, for tag files.
Tagging performance can be improved by adjusting this setting to better match the size of your
tag files. Generally, a tag file cache size that matches the total size of the tag files being used
will provide the best performance. For example, if the tag files for your source code and
libraries adds up to 100 MB, you should set your cache size to 100 MB. You may have to
experiment to find the optimum value. Use the following recommendations as a guide:
* Minimum - 8 MB
* Default - 64 MB
* Ideal - Sum of tag file sizes
* Maximum - 25% of physical system memory
Note that this is the same as the Tag file cache size option under Tools > Options >
Application Options > Virtual Memory.

Selection Options
Selection options are shown below (Tools > Options > Editing > Selections). See also Selections for
more information.
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The following options are available:
•

Styles - Choose the selection style you wish to use from the following options:
o

User defined - This option is for setting your own selection preferences. Any changes that are
made to the CUA behaviors automatically select User Defined. Selecting CUA automatically
resets the select behaviors.

o

CUA - When this style is selected, selected text is deleted before a paste or character is
inserted unless the selection is locked. Pressing the Backspace or Delete keys deletes the
selection unless the selection is locked. Advanced selections (those selections not started with
the mouse or Shift+<arrow keys>) are extended as the cursor moves. Locking a selection
requires one of the emulation commands select_line, select_block, or select_char. To
access these commands from Edit pull-down menu, select this option in any emulation.

o

SlickEdit default - When this style is selected, SlickEdit® uses the default styles that are
enabled when the product is installed.

•

Extend selection as cursor moves - When checked, the selection is extended to cursor position.
This option is not available if using Brief or Emacs emulation.

•

Deselect after copy - Indicates whether copied text is selected. This is not available if using Brief
or Emacs emulation.

•

Deselect after paste - Indicates whether pasted text is selected. This is not available if using Brief
or Emacs emulation.

•

Inclusive character selection - When checked, a character selection includes the character
following the cursor. This option is not available if using Brief or Emacs emulation.

•

Delete selection before insert - Indicates whether a selection is deleted before new text is
inserted. This option is not available if using a Brief or Emacs emulation.

•

Auto deselect (i.e. when cursor moves) - Check this box to clear a selection when the cursor
moves or one of a few other editor operations occurs. This option is not available if using a Brief or
Emacs emulation.
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•

Shift+Cursor always char select - When this check box is cleared, pressing the Shift+<arrow
keys> will select line or block selections, depending upon the direction the cursor moves. This is
not available if using a Brief emulation.

•

Mouse selection creates clipboard - Select this option to use the left mouse button to create a
clipboard and to use the middle mouse button to paste.

•

Arrow keys traverse selection - If checked, the Left arrow key moves the cursor to the beginning
of the selection and the Right arrow key moves the cursor to the end of the selection.

•

Clipboard formats - (Windows only) Select the type of editing format for clipboards, allowing you
to paste formatted and color-coded text to other applications (as well as plain text). Choose from
RTF Format or HTML Format.

Search Options
Search options are shown below (Tools > Options > Editing > Search). This option screen can also be
displayed from the Find and Replace tool window (Search > Find or Ctrl+F)—right-click in the background
and select Configure Options.
These are the default search options that control the behavior of Find and Replace operations in the
following instances:
•

•

The very first time the Find and Replace tool window is displayed. After that, dialog history takes
over, unless:
o

You set the default search option Initialize with default options setting to True, then the
options are reset to default every time the tool window is invoked, or

o

You use the right-click context menu in the Find and Replace tool window to select Use
Default Options, which resets to the default state.

The default options are always applied when using:
o
o
o
o

Quick Search and Quick Replace.
Incremental Search.
Command-line searches (find and /) if you don’t specify options explicitly.
Selective Display commands when searching by text.

For more information, see Find and Replace.
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The following options are available:
•

Default search options - The following default search options apply to all command line
searches, quick searches and incremental searches, and to the Find and Replace tool window
when the option Initialize with default options is enabled.
o

Match case - When set to True, search commands default to case-sensitive searches.

o

Match whole word - When set to True, search commands default to only finding matches to
the word as a whole. When set to False, search commands default to finding all instances of
the word, ignoring characters that are to the left and right of the occurrence.

o

Regular expression - When set to True, search commands default to regular expression
searching.

o

Regular expression syntax - Specifies which regular expression syntax to use for default
regex searching, when Regular expression search is enabled.
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•

•

•
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o

Wrap at beginning/end - Specifies whether or not search commands always wrap at the
beginning or end of a buffer during a search/replace operation to complete a search.

o

Search backward - When set to True, searches are always performed from the end to the
beginning.

o

Place cursor at end - When set to True, the cursor is placed at the end of the found
occurrence.

o

Search hidden text - When set to True, text hidden by Selective Display is allowed to be
searched. To set Selective Display options, from the main menu click View > Selective
Display. See Selective Display for more information.

Tool window options - Select from the following:
o

Close after find/replace - When set to True, the Find and Replace tool window is closed after
finding text in the buffer.

o

Initialize with default options - When set to True, options on the Find and Replace tool
window are reset to the original default values each time the window is launched.

Search string initialization - The following options provide starting values for when a search and
replace operation is activated:
o

Initialize search string - Specifies the initial value to be used in the Search for fields of the
Find and Replace tool window when the window is activated. When History retrieval is
selected, the Find and Replace tool window uses the last item that was searched for as the
word used when performing a search. When Word at cursor is selected, the Find and
Replace tool window uses the word that is at the cursor when performing a search.

o

Selected text (if exists) - When set to True, the current selection is used as the initial value in
the Search for fields of the Find and Replace tool window when the window is activated. If a
selection doesn't exist, the value specified by the Initialize search string option is used.

Bookmarks - The following options pertain to bookmarks. See Bookmarks for more information.
o

Use workspace bookmarks - When set to True, bookmarks are associated with the
workspace used to create them, even if the files they are in are not part of the workspace.
When you switch workspaces, the Bookmarks tool window updates to show only the
bookmarks associated with the current workspace. See Using Workspace Bookmarks for
more information.

o

Show set bookmarks - When set to True, a green Bookmark bitmap is displayed in the left
margin of the editor window at the location of each set bookmark.

o

Show pushed bookmarks - When set to True, a blue Bookmark bitmap is displayed in the
left margin of the editor window at the location of each pushed bookmark. This helps you see
where “Pop Bookmark” will go.

o

Close deletes pushed bookmarks - When set to True, any pushed bookmarks remaining
are removed when a buffer is closed. This option is helpful for buffer management, because it
prevents buffers which were explicitly closed from coming back when you pop up out of your
bookmark stack.

o

Maximum stack depth - Specifies the maximum number of bookmarks kept in the bookmark
stack. When this number is exceeded, the oldest bookmark is removed from the stack.

o

Automatically close visited files - Specifies the closing of visited files. A file is considered
visited if it is opened as a result of a symbol navigation or search operation, not modified, and
subsequently navigated away from. Features that open files for visiting include Go to
Definition, Pop Bookmark (see Symbol Navigation), and some search operations. Select from
the following values:
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- On - When this setting selected, visited files are automatically closed when you navigate
away from them.
- Off - When this setting is selected, the option is not enabled and visited files are not closed.
- Prompt me each time - When this setting is selected, you will be prompted with a choice
each time you navigate away from a visited file.
o

•

Top/bottom buffer pushes bookmark - When set to True, a bookmark is pushed whenever
you jump to the top or bottom of the buffer (Ctrl+Home/Ctrl+End, or top_of_buffer/
bottom_of_buffer commands, respectively). This is convenient, for example, in C++: if you
jump to the top of the buffer to add a #include statement, a bookmark is pushed, so you can
use Ctrl+Comma (pop_bookmark command) to get back to your previous position. This
option corresponds to the configuration variable def_top_bottom_push_bookmark.

Additional options - Select from the following:
o

Restore cursor after replace - When set to True, the cursor is restored to its original position
after a search/replace operation completes without being cancelled.

o

Leave selected - When set to True, the last occurrence of a matching search string is left
selected when a search operation completes. This also affects whether pressing Esc during a
search and replace leaves the search string selected.

o

Incremental search highlighting - When set to True, incremental searching highlights
matching occurrences with two colors: one for the current match at the cursor and one for all
possible matches. Highlights are removed when the search terminates. These colors are
controlled by the I-Search Current Match and I-Search Highlight screen elements (Tools >
Options > Appearance > Color). See Incremental Searching for more information.

o

Maximum search results output (KB) - Specifies the maximum amount of search results, in
kilobytes, to return after a search operation.

Global Alias Options
Global alias options are shown below (Tools > Options > Editing > Global Aliases). After using this
screen to create an alias, use the alias in the editor by typing the identifier and pressing Ctrl+Space.
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Note that the Global Aliases options page uses the same form that is used to create and manage
Language-Specific Aliases. See Global Aliases for more information about this feature.

Debugger Options
Debugger options (Tools > Options > Debugger) are used for tuning the run-time performance of the
integrated debugger, examining the properties of the underlying debugger system, setting class filters, and
controlling the directories searched for source files.
You can also access these options by clicking the Debug > Debugger Options from the main menu (or by
using the debugger_options command).
NOTE To see information about the underlying debugger system, including a general description
retrieved from the debugger, version number, run-time version, and debugger name, make sure
you’re in debug mode, then click Debug > Debugger Information (or use the debug_props
command). See Viewing Debugger Info and Setting Options for more information.
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Debugger option categories are:
•
•
•
•
•

Settings
Numbers
Runtime Filters
Directories
Configurations

Debugger Option Settings
The Debugger Options Settings screen is shown below (Tools > Options > Debugger > Settings). Use
these options to increase debugger performance.

The options are described as follows:
•

Number of lines to scan for Autos - Specifies the number of lines, starting with the current line,
to scan for symbols to evaluate and display in the Autos tab of the Debug Variables tool window.

•

Response timeout(s) - Specifies the number of seconds to wait for a connection or response from
the underlying debugger system before giving up.

•

Minimum running update time(ms) - Specifices the minimum amount of time in milliseconds to
spend polling for asynchronous events coming from the underlying debugger system. This value is
also used to determine the frequency with which to poll for events when the application is running.

•

Maximum suspended update time(ms) - Specifies the maximum amount of time in milliseconds
to spend polling for asynchronous events coming from the underlying debugger system. This value

SlickEdit® User Guide

657

OPTIONS

is also used to determine the frequency with which to poll for events when the application is
suspended.
TIP Decreasing the minimum and maximum update times will make the editor more responsive in
some cases during debugging, however, increasing these times can improve overall performance.
•

Toolbar update delay(ms) - Specifies the amount of time to wait in milliseconds before updating
the debugger toolbars. This is done to improve debugger performance and decrease overhead
and redraws when single stepping through code. Set this value to 0 to force an immediate update.

•

Asynchronous message duration(s) - Specifies the amount of time in seconds to display certain
informative messages caused by asynchronous events (such as loading classes in Java) before
they are erased.

•

vsdebugio connection port - Specifies the TCP/IP port to connect to vsdebugio running locally
on the same machine.

•

Allow edit and continue (hot swap) where available - (Edit and continue - Java only) When set
to True, you can edit a file during a Java debugging session, compile or rebuild, and then continue
to debug. Keep in mind that when using this feature, there are certain feature limitations that you
might encounter that are defined by the Java Virtual Machine.

•

Allow editing of source files during debugging - When set to True, you can edit files during
debugging sessions.

•

Show value of symbol under mouse - When set to True, as the mouse cursor floats over a
symbol, the information about the symbol, including its value for variables, are displayed.

•

Automatically correct breakpoint scope - When a breakpoint is set in the debugger, the name
of the function and the class it is in is recorded. If the class name or function name subsequently
changes between debugging sessions, having this option enabled will allow the debugger to
correct this information stored with the breakpoint.

Debugger Number Options
The Debugger Options Numbers screen is shown below (Tools > Options > Debugger > Numbers). Use
these options to configure settings for viewing numbers in multiple bases (hex, octal, and binary views).
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These settings allow you to specify how different numeric types are formatted by the debugger by default.
You can specify settings for integer numbers, floating point numbers, and characters. Each option contains
the same values for you to pick from. The table below shows examples of each type of configuration.
Option Value

Base

Example

Binary

2

0b01000001

Char

N/A

'A'

Decimal

10

65

Hexadecimal

16

0x41

Octal

8

0101

These settings can be overridden by using the right-click context menu in any of the debugger variables
tool windows. They may also be overridden on a per-variable basis, again by using the right-click context
menu in the debugger variables tool windows (Autos, Locals, Members, Watches). See Debug Toolbars
and Tool Windows for more information.

Debugger Runtime Filter Options
The Debugger Options Runtime Filters screen is shown below (Tools > Options > Debugger > Runtime
Filters). Use this screen to configure the Step Into command (Debug > Step Into, debug_step_into) to
skip certain runtime functions and methods.
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For GNU C/C++, click Add to specify a function, or class and method patterns (ex. strcpy, str*,
MyClass::*, MyClass::Insert*) for the debugger to consider as run-time functions. This will affect the
behavior of Step Into. Step Into will step over statements that call into run-time functions. The Reset button
will reset the filters back to the defaults.
For Java, click Add to specify packages or specific classes or class patterns for the debugger to consider
as run-time classes. This will affect the behavior of Step Into and the Debug Loaded Classes tool window.
Step Into will step over statements that call into run-time classes. The Reset button will reset the filters
back to the defaults, which are java.*, javax.*, com.sun.*, and sun.*, which correspond to the defaults
used by Sun's JDB debugger.

Debugger Directory Options
The Debugger Options Directories screen is shown below (Tools > Options > Debugger > Directories).
Here, you can tune the search path used to find source files while debugging.
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When debugging, if a source file path cannot be resolved using the current directory or the class path, you
will be prompted for the source file. The debugger then saves the path in which the source file was found,
so you will not be prompted again when that file or another in that directory is needed during a debugging
session. The Reset button clears all stored source paths.

Debugger Configuration Options
The Debugger Options Configurations screen is shown below (Tools > Options > Debugger >
Configurations). Valid only for projects utilizing the GDB debugger, these settings provide the ability to
define multiple GDB debuggers, specify arguments to be passed to each debugger in the list, and define
one of the debuggers in the list as the default to be used when debugging local, native executables.
These settings are especially useful for development teams who use cross-compiler platforms for
applications such as embedded systems. They are also useful for adding newer versions of the GDB
debugger, when they become available, for use in the debugging processes.
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The debuggers in this list also appear on the Remote Options tab of the Debug > Attach Debugger >
Attach to Remote Process dialog box.

Language Options
SlickEdit® provides many options that can only be configured on a language-specific basis, such as
indenting and word wrap. For example, features and settings for coding in C/C++ may be different than
those used for Java. SlickEdit uses the extension of the current file to determine what language you are
using, thereby only making available the features that are possible in that language and applying the
associated settings.
Use the Languages section of the Options dialog (Tools > Options > Languages) to control the behavior
of SlickEdit for specific languages. Each supported language is categorized by its language type. Expand
the applicable category node to find your language. For example, C/C++ and Java are located under the
Application Languages node.
The options available for each language are further categorized by type. In general, the option categories
are the same for each language (General, Indent, View, etc.), although if a particular language does not
support a particular set of options, that options category is not included. Conversely, some languages
include additional options that are not available in other languages. While most of the options are common
among all languages, the default settings for these options vary.
TIP A shortcut method to access language options for the current buffer is to use the Document >
[Language] Options menu item. This will open the Options dialog to the General language-specific
option screen for that language.
The Language Manager and Extension Manager nodes are used to add and remove languages and
manage language extension associations. See Managing Languages and Managing File Extensions for
more information on these screens.
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The common categories for each language (when supported) are:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

General
Indent
View
Adaptive Formatting
[Language] Formatting Options
[Language] Compiler Properties
Word Wrap
Aliases
Comments
Comment Wrap
Auto-Complete
Context Tagging®
Color Coding
File Options

General Language-Specific Options
This option screen shows the mode name and associated file extensions for the selected language, and
provides other general options. The settings on this page depend on the selected language. As an
example, the C/C++ General options are shown below (Tools > Options > Languages > Application
Languages > C/C++ > General).

The options are described as follows:
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•

Mode name - Allows you to enter a more meaningful name for this extension setup. Define a
mode name here for the Document > Select Mode menu item to work well. See Language Editing
Mode for more information.

•

File Extensions - This area displays a list of file extensions associated with the selected
language. See Managing File Extensions for more information.

•

Edit These Extensions - Allows you to add or remove file extensions for the language mode. The
language-specific File Extensions dialog is displayed. Click the green Plus button to add a new
extension and use the red X button to delete the selected extension. You can also add an
extension by double-clicking where indicated.

•

Truncation - When On or Auto is selected, all editor operations prevent the data from the right of
the truncation line length to be moved or to be modified. For example, search and replace
operations do not find data to the right of the truncating line length. In addition, when a replace
occurs, the data to the right of the truncation line length will not move.
Set this to Auto for the editor to determine the truncation line length based on the record format of
the file. For files that do not have a record format, the truncation length is turned off. For example,
when Auto is on and the record width of the file is 80, 72 is used as the truncation line length (the
record length minus eight).

•

Auto CAPS - If selected, and a file is opened that does not contain any lowercase characters,
caps mode is turned on (not the same as caps lock). When caps mode is on, all text is inserted in
uppercase. This feature is intended to emulate ISPF.

•

Color coding - The options below affect Color Coding. For more information about working with
this feature, see Color Coding.
o
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Lexer name - This area shows the active lexer name associated with this language for Color
Coding. The lexer name is predefined for installed languages. For languages that you add to
SlickEdit®, the lexer name can be specified on the Add New Language dialog that is displayed
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when you click Add Language on the Language Manager (Tools > Options > Languages >
Language Manager).
o

Color Coding - Click this button to display the language-specific Color Coding options for the
current language. See Language-Specific Color Coding Options.

o

Modified lines - If selected, lines that have been modified are color coded.

o

Current line - Check on Current line to color code the current line.

•

Language-Specific Project - Click this button to set project properties specific to the selected
language. See Defining Language-Specific Projects for more information.

•

Context menus - These options specify which context menu to display in the editor window based
on whether a text selection is made in the editor window.
o

Menu if no selection - This specifies the menu that is displayed when right-clicking in an edit
window that does not have a selection.

o

Menu if selection - This specifies the menu that is displayed when right-clicking in an edit
window that has a selection.

o

Select first (Affects all extensions) - When checked (default), a selection can be made with
the right mouse button instead of displaying the language-specific menu. When this is not
checked, select menu items by clicking and dragging the mouse.

•

Begin/end pairs - Specify the begin/end pairs to use for the selected extension in a format similar
to a regular expression. This text box is unavailable for languages that have special begin/end
matching built-in. See Begin/End Structure Matching for more information about begin/end pairs
and using this option.

•

Word chars - These are the characters that SlickEdit uses to recognize a string of text as a word.
The word characters affect the operation of all word-oriented commands, including word
searching. You can use a dash (-) character to specify a range, such as “A-Z”, which specifies
uppercase letters. To specify the dash (-) character as a valid word character, place a dash at the
beginning or end of the word character string.

NOTE Word chars are not used for tagging operations. To adjust the identifier characters used by
Context Tagging®, use the Identifiers options on the Tokens tab of the Color Coding options page
(Tools > Options > Languages > [LanguageCategory] > [Language] > Color Coding).

Language-Specific Indent Options
These options lets you set the indenting style you like on a language-specific basis. You can also specify
whether code is indented with spaces or tabs and set the behavior of the Tab key. The features Syntax
Indent, SmartPaste®, Dynamic Surround, and Syntax Expansion are also enabled through this page.
The settings on this page depend on the selected language. As an example, the C/C++ Indent options are
shown below (Tools > Options > Languages > Application Languages > C/C++ > Indent).
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The options are described as follows:
•

•

•
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Indent style - Select from the following indent styles:
o

None - When this option is selected, the Enter key will put the cursor at the beginning of the
line.

o

Auto - When this option is selected, the Enter key indents according to the previous line.

o

Syntax indent - When this option is selected, the Enter key indents according to language
syntax. The value in the text box specifies the amount to indent for each level. The hyperlink
indicates if Adaptive Formatting is on or off for this setting. See Syntax Indent for more
information.

When tab key reindents the line - These options specify that the Tab key be used to beautify or
reindent the current line. Select from the following settings:
o

Never - When this option is selected, pressing Tab will never reindent the line. It will indent to
the next tab stop.

o

Always - Pressing the Tab key in any column will reindent the current line.

o

In leading blanks - Pressing the Tab key will reindent the line if the cursor is positioned within
the leading white space of the line. Otherwise it will indent to the next tab stop. This option is
further controlled by the Strict check box.

o

Strict - Strict only applies to the In leading blanks option. When this option is selected, it
reindents the line only if the cursor position is before the intended indent location; otherwise, it
will insert an additional tab stop. When this option is cleared, it reindents the line when the
cursor is located on the leading whitespace, regardless of whether the column is before or
after the intended indent location.

Tabs - Set tabs in increments of a specific value or at specific column positions. To specify an
increment of three, enter 3 in the text box. To specify columns, for example, enter 1 8 27 44, to
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specify tab stops that are not an increment of a specific value. The hyperlink indicates if Adaptive
Formatting is on or off for this setting.
•

Indent with tabs - Determines whether Tab key, Enter key, and paragraph reformat commands
indent with spaces or tabs. The hyperlink indicates if Adaptive Formatting is on or off for this
setting. See Indenting with Tabs for more information.

•

Insert real indent (affects all extensions) - When this option is selected, the Enter key inserts
real spaces or tabs representing the indent instead of virtual spaces. This check box affects all
extensions when it is selected. This option allows the function for the End key on the keyboard to
place the cursor after blank text where new text can be typed.

•

Indent selection when text selected (affects all extensions) - When this option is selected, it
affects all of the extensions, and pressing Tab or Shift+Tab indents or unindents the selected text.

•

Backspace at beginning of line un-indents - When this option is selected and the cursor is
located before the first non-blank character, pressing the Backspace key unindents the current line
by one indent level. See also Setting the Backspace Unindent Style.

•

Use SmartPaste® - Specifies whether copied or pasted text should be reindented according to
what the editor thinks is the correct indent level. See SmartPaste® for more information.

•

Use Dynamic Surround - Provides the ability to surround a group of statements with a block
statement, indented to the correct levels according to your indent settings on this tab. In order for
Dynamic Surround to work, the option Syntax Expansion must also be selected (see below). See
Dynamic Surround for more information on how to use this feature.

•

Syntax expansion - Activates the Syntax Expansion feature. When this option is selected,
pressing the spacebar after typing a keyword such as if or for will cause that syntax element to be
expanded, inserting the rest of the if or for statement. Alternately, you can bind a space command
to a key other than the spacebar. See Syntax Expansion for more information on using this feature.
o

Minimum expandable keyword length - Sets the minimum length for a keyword that will
trigger Syntax Expansion. For example, if this is set to 3, then two-letter keywords such as if
will not be expanded.

Language-Specific View Options
These options control the display of special characters, line numbers, and more. C/C++ View options are
shown below (Tools > Options > Languages > Application Languages > C/C++ > View).
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The options are described as follows:
•

Special Characters - When this option is selected, view of all types of special characters is
enabled for the language. This includes Tabs, Spaces, and Newline characters as well as all of
the other special characters listed on the Appearance > Special Characters option screen.
Alternately, select the individual options to enable display of the special characters you want to
see. Note that you can also toggle display of special characters on a per-document basis with the
menu item View > Special Chars (or use the view_specialchars_toggle command). Viewing of
special characters is only available for ASCII files. See Viewing Special Characters for more
information.

•

Configure Special Characters - Jumps to the Appearance > Special Characters node in the
Options dialog, where you can define the visible characters that represent each type of special
character. See Special Character Options for more information.

•

Line numbers - When this option is selected, display of line numbers is enabled for the selected
language. Note that you can also toggle display of line numbers on a per-document basis with the
menu item View > Line Numbers (or the view_line_numbers_toggle command). See Viewing
Line Numbers for more information.

•

Hex view - This option is used to enable Hex mode editing (choose Hex or Line hex). You can
also enable Hex mode on a per-document basis with the menu items View > Hex and View > Line
Hex (or use the commands hex and linehex). See Hex Mode Editing for more information.

Language-Specific Adaptive Formatting Options
Adaptive Formatting scans a file for the formatting styles in use and automatically matches those settings
for the current editing session. The options on this screen are used to enable/disable Adaptive Formatting
and configure the styles that SlickEdit® should recognize for the language. The C/C++ Adaptive
Formatting options are shown below (Tools > Options > Languages > Application Languages > C/C++
> Adaptive Formatting).
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Select or clear the Use Adaptive Formatting option to enable or disable the feature for the selected
language. When Adaptive Formatting is enabled, use the subsequent check boxes to select the individual
style settings for which SlickEdit should scan. The individual style settings that appear on the Options
screen will vary depending on the language. See Adaptive Formatting for more information.

Language-Specific Formatting Options
These options let you configure the way SlickEdit® formats code as you type. Depending on the language,
you can specify the code formatting templates, how various syntactical elements are treated, when and
what code elements are automatically inserted, and more. The formatting options that are available
depend on the selected language. For more information, see the following section for your language (or
the one that most closely relates to your language):
•
•
•
•
•
•
•
•
•

C/C++ Formatting Options
Java Formatting Options Interface
XML Formatting Options
HTML Formatting Options
XML/HTML Formatting (the feature)
Ada Formatting Options
COBOL Formatting Options
Pascal Formatting Options
PL/I Formatting Options

Language-Specific Compiler Properties
These settings are used to configure your compiler so that SlickEdit® can correctly perform full
preprocessing, parsing, symbol analysis, and cross-referencing. The fields and options on this page
depend on the selected language.
NOTE These language-specific compiler settings are also available in a dialog interface. The fields
and options are identical, so you can use the interface you prefer. To access the dialog, from the
main menu, click Project > Project Properties. Select the Compile/Link tab, then click the Ellipsis
button to the right of the Compiler combo box.
The following fields and options are common to all languages on the Compiler Properties interface:
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•

Compiler Name - Contains a list of compilers. Names in this list are the names specified when
you click Add.

•

Add - Used to add a new compiler name to the list. After adding the name, you will need to
configure the compiler using the configuration settings on the lower-half of the interface.

•

Delete - Deletes the selected compiler and its associated configuration. Does not delete files from
disk.

•

Copy - Used to add a new compiler configuration by copying the selected compiler’s configuration.
You will be prompted for a new compiler name.

•

Set Default - Specifies that the selected compiler should be used as the default. The current
default is displayed under the Compiler Name field.

•

Build Tag File - Used to build tag files for the selected compiler configuration. This is especially
useful when new configurations are created. If you do not build the tag file here manually, it will be
built on demand.

•

Compiler Configuration - The lower half of the Compiler Properties interface is used to configure
the selected compiler. In C/C++, you specify the header file and include directories. In Java, you
specify the root JDK installation and system libraries.

For more information, see C/C++ Compiler Settings or Java Compiler Properties Dialog.

Language-Specific Word Wrap Options
These language-specific options let you set margins and the justification style and configure Word Wrap,
which keeps the cursor within the specified margins when entering text, moving the cursor, and deleting
characters. Note that Word Wrap is intended for plain text only.
The settings on this page depend on the selected language. As an example, the C/C++ Word Wrap
options are shown below (Tools > Options > Languages > Application Languages > C/C++ > Word
Wrap).

The options are described as follows:
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•

Margins - Sets the left, right, and new paragraph margins. Specify the column number at which
each margin should begin. Click the colored box next to the Indicator Color label to set the color
of the margin indicator. The margin indicator will only appear if the Word wrap option is selected,
which activates word wrapping.

•

Justify style - Select from the following justification styles:
o

Left and respace - Left justification with space character reformatting. One space is placed
between words except after the punctuation characters period, ?, and !, which get two spaces.
To have only one space after the period, question mark, and exclamation point punctuation
characters, turn on 1 space after period.

o

Left - Left justification with respect for space characters between words. This setting requires
the Save options to be set such that trailing spaces are not stripped when a buffer is saved.
See Save File Options for more information.

o

Justified - Full justification. Left and right edges of text will align exactly at margins.

•

Word wrap - This option activates/deactivates Word Wrap. When selected, the editor keeps the
cursor within the margins when entering text, moving the cursor, and deleting characters. Note that
Word Wrap is intended for plain text only.

•

Soft wrap - Soft Wrap makes it easy to view long lines of code without scrolling. Each line is
wrapped as though a carriage return was inserted, however, the file itself is not modified. The
options are as follows:
o

Wrap long lines to window width - This option activates Soft Wrap. A curved arrow is
displayed at the end of each line, along the right-hand border of the edit pane, indicating that
the text continues on the next line. The horizontal scrollbar disappears as it is no longer
needed.

o

Break on word boundary - Breaks the text at the end of the line so that words are kept
whole. This makes for easier reading, especially in text files.

o

Affects all extensions - When selected, this option applies the Soft Wrap configuration that
you want on all extensions without having to manually set up each one. For example, if you
want Soft Wrap turned on for all extension types, complete the following steps:
1. Mark Wrap long lines to window width.
2. Mark Break on word boundary.
3. Then mark Affects all extensions and click either Update or OK. Each time that you open
a file, Soft Wrap is automatically turned on.
To make this feature unavailable for all extensions, clear the Wrap long lines to window
width check box.

Language-Specific Alias Options
Aliases are identifiers that you can quickly type, which are then expanded into snippets of text. Languagespecific aliases are useful for inserting comment headers, statement and function templates, or any other
text that you frequently use. This option screen is used to manage language-specific aliases. As an
example, the C/C++ Aliases options are shown below. See also Language-Specific Aliases for more
information.
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The name of the file that contains the aliases is displayed next to the label Alias file.
The left side of the options screen contains the alias list. The box on top of the alias list allows you to
search the alias list incrementally as you type, so you can find the alias you want to edit or remove.
The Surround With check box is used to specify that you are working with aliases for Surround With.
Surround With is a feature that lets you surround existing code with text or predefined structures. When
this option is selected, the alias list changes to show only Surround With aliases. When this option is not
selected, the alias list shows only normal aliases. See Surround With for more information about creating
and working with Surround With aliases.
The large box on the right is the alias edit window. When an alias is selected in the alias list, you can type
directly inside this window to define or edit the alias expansion.
Use the Insert Escape Sequence button to insert escape sequences into your alias expansion. See Alias
Escape Sequences for a list of available sequences.
The following buttons appear under the alias list and alias edit window:
•

New - Click this button to create a new alias name to be added to the alias list. After doing this,
define the expansion by typing in the alias edit window.

•

Delete - Deletes the alias that is currently selected in the alias list.

The bottom of the Aliases options page is used to create and manage parameter prompts in aliases.
Parameter Prompting is a feature that lets you insert a parameter inside an alias so that when the alias is
expanded, a dialog is displayed, prompting you to input the values.
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The parameter list contains a list of the parameters you have created. It is divided into sections that
correspond to the fields on the Enter Alias Parameter dialog, which is used to add a new parameter:
•

Param Name - The name that is used in the alias to identify this parameter.

•

Prompt String - This string appears as a label on the dialog that prompts for values when the alias
is expanded.

•

Initial Value - (Optional) This text is automatically entered as the initial value for the parameter on
the dialog that prompts for values when the alias is expanded.

The Parameters section of the Aliases options page provides the following buttons:
•

Add - Displays the Enter Alias Parameter dialog, used to add a new parameter for the alias that is
currently selected in the alias list. See Parameter Prompting for more information.

•

Remove - Deletes the parameter that is selected in the parameter list.

•

Edit - Displays the Edit Alias Parameter dialog, used to edit the parameter that is selected in the
parameter list. See Parameter Prompting for more information.

•

Up and Down - Use these buttons to change the order of the parameters, moving the selected
parameter up or down in the parameter list.

Language-Specific Comment Options
Comment options let you control how block and line comments are created.
To comment out selected lines, select text in the editor and then click Document > Comment Block or
Document > Comment Lines (box and comment commands, respectively). These operations use the
matching comment style to comment out all text on the lines containing the selection. Comment Block
surrounds multiple lines with a single block comment. Comment Lines comments out each line in the
selection with a line comment. See Commenting for more information.
The settings on the Comments screen depend on the selected language. As an example, the C/C++
options for comments are shown below (Tools > Options > Languages > Application Languages > C/
C++ > Comments).
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Comment block
These settings are used when you comment out a selected block of text (Document > Comment Block or
box command). SlickEdit® provides eight fields to specify the characters used in your commenting style. If
you want to apply a comment with no additional decoration, fill in the upper-left and lower-right fields with
the characters to begin and end a block comment. To draw a box around the comment, fill in additional
characters in the other fields. For example, you might put an asterisk in each of the other fields to draw a
box of asterisks around the block comment.
SlickEdit interprets the contents of these fields literally. If you want the asterisks on the left-hand side to line
up, you need to put a space before the asterisk in the left, middle field. Likewise you would put a space
before the asterisk and slash in the field containing the end of comment characters. Trailing spaces are
ignored on the right-hand fields.
To illustrate, the following code sample is a selection:
if (!enabled) {
tabState = TIS_DISABLED;
}

From the main menu, click Document > Comment Block, and the selection is commented out as follows:
/*
if (!enabled) {
tabState = TIS_DISABLED;
}
*/

Select from the following comment block options:
•

First line is top - When this option is selected, the first line of the text selection is used as the first
line of the comment. The top border is not drawn. Otherwise the open comment characters will
appear on their own line.
If this option is selected for the preceding code sample, the comment will instead be formatted as
follows:
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/*

if (!enabled) {
tabState = TIS_DISABLED;
}

*/

•

Last line is bottom - When this option is selected, the last line of the text selection is used as the
last line of the comment. The bottom border is not drawn. Otherwise the open comment characters
appear on their own line.
Using the same example, if this option is selected, the comment will be formatted as follows:
/*
if (!enabled) {
tabState = TIS_DISABLED;
}
*/

Comment line
These settings are used when you comment out selected lines (Document > Comment Lines or
comment command).
•

Left and Right - Characters that you specify in these boxes are literally inserted to the left and
right of the text on each line of the selection when you use SlickEdit® to create a line comment.
The placement of the Left characters can be controlled through the Location options below.
Characters specified in the Right box are placed and aligned vertically at the end of the longest
line of text in the selection. For example, if the Left and Right boxes both contain the
characters //, clicking Document > Comment Line comments out the example code as follows:
//
//
//

•

if (!enabled) {
//
tabState = TIS_DISABLED;//
}
//

Location - Mutually exclusive location options control where characters specified in the Left box
are placed:
o

At left margin - Places characters flush against the left margin of the editor window, as shown
in the previous example. The indent levels are not changed. This provides better visibility for
your comments and a way to clearly see the indent level relative to lines that are not
commented out.

o

At level of indent - Places and aligns characters vertically at the current indent level. For
example:
//if (!enabled) {
//
tabState = TIS_DISABLED;
//}

o

Start in column - Specifies in which column to start the comment for a line selection. This is
useful for column-oriented languages such as COBOL. Type or use the spin box to select the
desired column number. The left comment characters are placed at the specified column.

Doc comments
Select from the following options:
•

Automatically expand doc comments - When this option is selected, SlickEdit® automatically
inserts a skeleton doc comment when you type comment start characters and then press Enter on
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a line directly above a function, class, or variable. The type of skeleton that is inserted is based on
your start characters and style settings (specified in the For start characters box).
NOTE In C#, you do not need to press Enter, as the skeleton comment is inserted after you type the
third slash.
•

For start characters - Use this box to specify the comment start characters that will trigger the
style of reference tags that are automatically inserted as part of the doc comment skeleton. The
characters selected here use the reference tag style specified in the Use style box. For comments
formatted in Javadoc, select /**. For XMLdoc, select ///. For Doxygen, select /*! or //!. See Doc
Comment Examples for more information.

•

Edit <startchars> expansion - Click this button to open the Doc Comment Editor, where you can
define and edit the templates that are inserted when doc comments are expanded. See Modifying
Doc Comment Templates for more information.

Comment editing
The following options control comment editing behaviors. These options will be unavailable for nonapplicable extensions.
•

Split line comments - If selected, when you press Enter in the middle of a line comment, a new
line comment will automatically be started on the new line. For example:
// The quick brown fox [CURSOR_HERE]jumped over the lazy dog.

Pressing Enter will result in:
// The quick brown fox
// [CURSOR_HERE]jumped over the lazy dog.

•

Extend line comments - If selected, when you press Enter at the end of a line containing a line
comment, and there is also an aligned line comment on the line before or after the current line, a
new line comment will automatically be started on the new line. For example:
// The quick brown fox
// jumped over the lazy dog.[CURSOR_HERE]

Pressing Enter will result in:
// The quick brown fox
// jumped over the lazy dog.
// [CURSOR_HERE]

•

Join comments when joining lines - If selected, when you press Delete at the end of a line
containing a line comment to join the current line with the next line, and the next line is also a line
comment, the line comment characters will automatically be deleted. For example:
// The quick brown fox [CURSOR_HERE]
// jumped over the lazy dog.

Pressing Delete will result in:
// The quick brown fox[CURSOR_HERE] jumped over the lazy dog.

String editing
If Split strings on Enter is selected, when you press Enter to split a line when the cursor is inside of a
string, the closing and opening quotes and, if necessary, operators, will automatically be inserted, and the
string will be aligned with the original string. For example:
String x = "The quick brown fox [CURSOR_HERE]jumped over the lazy dog.";
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Pressing Enter will result in:
String x = "The quick brown fox "+
"[CURSOR_HERE]jumped over the lazy dog.";

Language-Specific Comment Wrap Options
Comment Wrap options let you activate wrapping and configure the way block, line, and doc comments are
wrapped. See Comment Wrapping for more information.
The settings on this page depend on the selected language. As an example, the C/C++ Comment Wrap
options are shown below (Tools > Options > Languages > Application Languages > C/C++ >
Comment Wrap).

The options are described as follows:
•

Enable comment wrap - When selected, comments are allowed to be wrapped. You must still
specify the type of comments that you want wrapped by selecting one or more of the Enable
options for block, line, and doc comments.
o

•

Start wrapping on line - This setting pertains to line comments only. Make sure line comment
wrapping is turned on, then type or select the number of consecutive line comments that must
be present before wrapping is activated. If your code contains many one line descriptive
comments, you may want to set this to 2 or more so that comment wrapping will not affect
these short line comments.

Comment width - There are three types of width settings for comments:
o

Fixed width - If selected, comments are formatted to the specified width. This is useful since
comments are typically indented with the corresponding code. This option maintains the
original left margin of the comment and adjusts the right margin to meet the target width.
If Maximum right column is used, comment lines will be wrapped when they reach the
specified column, even if they have not reached the specified fixed width. This is useful if
coding standards mandate that text should not exceed a specified column.
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o

Automatic width - If selected, the width of the longest multi-line paragraph in the comment
block is used as the width for block comments. This is useful for preserving the formatting of
existing comments.
If Maximum right column is used, comment lines will be wrapped when they reach the
specified column, even if they have not reached the specified fixed width. This is useful if
coding standards mandate that text should not exceed a specified column.

o

Fixed right margin - If selected, lines will break before the specified number of columns in the
Right column field has been reached.

o

Preserve width on existing comments - If selected, when editing an existing comment,
SlickEdit® preserves the width of the existing comment. The width is determined by the length
of the longest multi-line paragraph. If the width of the existing comment cannot be determined,
the formatting option specified under Comment width will be used instead.

o

Continue bullet list on Enter - If selected, when Enter is pressed inside a bulleted paragraph,
a new bullet will be inserted and the cursor will be placed at the text starting position.

•

Javadoc - If Use hanging indent on block tag comments is selected, the second line of a block
tag comment will be automatically aligned to the first non-whitespace character after the first word
after the tag.

•

Sync vertical line column - This button will make visible and move the vertical line column to
match the hard margin column (if using fixed right column margins) or the maximum right column
(if using fixed width).

Language-Specific Auto-Complete Options
These options let you configure the behavior of the Auto-Complete feature. The settings on this page
depend on the selected language. As an example, the C/C++ Auto-Complete options are shown below
(Tools > Options > Languages > Application Languages > C/C++ > Auto-Complete).

The options are described as follows:
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•

Enable auto-completion - If selected, activates the Auto-Complete feature. See Auto-Complete
for more information.

•

Syntax expansion - If selected, Auto-Complete will show Syntax Expansion choices for the word
prefix under the cursor. Syntax Expansion completes syntactic elements of the language, like if or
for statements, putting in the parentheses and braces matching your specified coding style
settings. See Syntax Expansion for more information.

•

Keywords - If selected, Auto-Complete will show keyword choices for the word prefix under the
cursor, if it matches one or more keywords in the current language.

•

Alias expansion - If selected, Auto-Complete will show the matching alias for the word under the
cursor. Aliases names require an exact word match, not just a prefix match. For more information
on using aliases, see Aliases.

•

Symbols - If selected, symbols will be displayed as completion options if the word prefix at the
cursor matches one or more symbols using a strict, context-sensitive and language-specific tag
search.
o

•

Maximums (Symbols) - For performance tuning, you can limit the maximum number of
symbols displayed by Auto-Complete. This setting affects all file extensions.

Word completion - If selected, word completions will be displayed if the word prefix under the
cursor matches one or more words in the current file. The strength of this option is that it ties into
the word and line completion features of SlickEdit®. After you select a word completion, you can
press Ctrl+Shift+Space to complete the rest of the line from which the original word came. See
Word Completion for more information.
o

Maximums (Word completion) - For performance tuning, you can limit the maximum number
of word completions displayed by Word Completion. This setting affects all file extensions.
This is especially useful when editing large files.

•

Argument completion - If selected, turns Auto-Complete on in the Build tool window for
completing file names and paths.

•

Options - More options are available:
o

Auto-select unique items - If this option is selected and Auto-Complete finds exactly one
word match, it will automatically select that match for completion. If this option is turned off,
you must select a word to complete using the Tab key or the Up or Down arrow keys.

o

Tab inserts longest unique prefix - If selected, pressing Tab will cause Auto-Complete to
attempt to insert the longest unique prefix match of all its completions. If the word prefix cannot
be extended, Tab will cycle to the next completion choices.

o

Tab cycles through choices - Select this option if you want to use Tab and Shift+Tab to
cycle through completion choices, as is done in some command shells. If cleared, Tab will
attempt to insert the longest unique prefix (if selected), or insert the selected completion, or
cancel Auto-Complete and behave normally if there is no completion selected.

o

Insert selected - If selected, when cycling through completion choices and a choice is
selected, the selected choice will replace the current text. This modifies the file as you work.

o

Minimum prefix length - The minimum number of characters the word prefix must contain
before auto-completions will be displayed automatically.

o

Display after (ms) idle - The number of milliseconds the editor must be idle before autocompletion suggestions will be displayed. This setting affects all extensions.

o

Update after (ms) idle - The number of milliseconds the editor must be idle before autocompletion suggestions will be refreshed. This setting affects all extensions.
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•

Details - Detailed options include:
o

Show light bulb - If selected, displays the light bulb as a reminder when Auto-Complete
suggestions are available for the current word prefix.

o

Show expanded text - If selected, shows the rest of the word or statement being completed.

o

Show list of matches - If selected, shows the list of matches underneath the word prefix.

o

Show icons - If selected, displays symbol icons and folder icons. Turn this feature off to get a
more compact list containing only completions.

o

Show categories - If selected, shows completions in a categorized list for each type. If
cleared, all completions will be shown in one flat, sorted list.

o

Show symbol declaration - If selected, for symbol completions, this will show the symbol
declaration as a comment to the right of the symbol completion.

o

Show comments - If selected, for symbol completions, this will display the symbol’s
comments to the right of the symbol completion.

Language-Specific Context Tagging® Options
These options let you configure language-specific settings for Context Tagging (see Context Tagging®).
Note that global Context Tagging options are located at Tools > Options > Editing > Context Tagging®
Options (see Context Tagging® Options).
The settings on this page depend on the selected language. As an example, the C/C++ Context Tagging
options are shown below (Tools > Options > Languages > Application Languages > C/C++ > Context
Tagging®).

List Members
The following options apply to List Members. See List Members for more information.
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•

Auto-list members - If selected, typing a member access operator (for example, “.” or “->” in C++)
will trigger SlickEdit® to display a list of the members for the corresponding type. To access this
feature on demand, press Alt+Dot. If you use this feature on demand, and you are not in a
member expression, this feature will display a list of locals, global variables, current class
members, etc.

•

Show comments - If selected, the comments are displayed for the currently selected symbol in
the list displayed by List Members. When a symbol has multiple definitions or overloads, and
multiple sets of comments, the comments will indicate that you are looking at item “< 1 of n >”.
Click on the arrows or use Ctrl+PgUp and Ctrl+PgDn to cycle through the comment sets.

•

Completion on space - If selected, pressing the spacebar when List Members is displayed will
insert the longest unique matching prefix from the symbols in the list. For example, if the list
contains FLAG_CHAR and FLAG_LONG, then typing FL<Alt+Dot><spacebar> completes the
line of code up to FLAG_. If this option is not selected, use Ctrl+Space when List Members is
displayed to perform completion.

•

Space always inserts space - If selected, pressing the spacebar when List Members is displayed
will insert the current item and a space in the list after the current item. If this option is not selected,
pressing the spacebar will only insert the current item with no extra space.

•

Insert open parenthesis - If selected, selecting an item in the list inserts the current item in the list
and any extra characters that are required by the symbol. For example, an open parenthesis is
inserted after a function name for languages that require an open parenthesis after a function
name. For C++, the less-than symbol (<) is inserted after a template class name.

•

Preserve identifier to right of cursor - If selected, only the identifier characters before the cursor
are replaced with an item selected from a List Members dialog. Identifier characters after the
cursor are preserved. When this option is not selected, identifier characters following the cursor
are replaced with the item selected from a list members dialog. When this option is in the mixed
state, trailing identifier characters are preserved for auto list members but not when listing
members on demand by pressing Alt+Dot.
For example, if List Members is active and the current line is as follows:
this->foo<cursor_here>Bar

Then if this option is selected and you choose a symbol named “foodForThought” from the List
Members list, the line will be changed to:
this->foodForThought<cursor here>Bar

If this option is not selected, doing the same would result in:
this->foodForThoughtBar<cursor here>

•

Auto-list compatible values - If selected, compatible variables are automatically listed after you
press the spacebar after assignment operators and return statements. Global (non-module)
variables are not listed. This only affects C, C++, and Java. To access this feature on demand,
press Alt+Comma.

Parameter Information
The following options apply to parameters. See Parameter Information for more details.
•

Auto-display parameter information - If selected, the prototype and comments for a function are
automatically displayed when a function operator such as the open parenthesis is typed, and the
current argument is highlighted within the displayed prototype. To access this feature on demand,
press Alt+Comma.
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•

Show comments - If selected, comments are displayed when Parameter Info is displayed. When
a symbol has multiple definitions, and multiple sets of comments, the comments will indicate that
you are looking at item “< 1 of n >”. Click on the arrows or use Ctrl+PgUp and Ctrl+PgDn to cycle
through the comment sets.

•

Auto-insert matching parameter - If selected, when Parameter Info is displayed and the name of
the current formal parameter matches the name of a symbol in the current scope of the
appropriate type or class, the name is automatically inserted. When the name is inserted, it is also
selected so that you can type over it, or you can type Comma, Space, Tab, or a closing parenthesis
to use the automatically inserted parameter.

•

Auto-list compatible parameters - If selected, compatible variables are automatically listed when
parameter info is active and typing the arguments to a function call. Global (non-module) variables
are not listed. This only affects C, C++, and Java. To access this feature on demand, press
Alt+Comma. See Auto List Compatible Parameters for more information.

•

Pad parentheses - If selected, a space is inserted after the open parenthesis when a parameter
name is automatically inserted. In addition, if you type a close parenthesis after an automatically
inserted parameter, it will insert a space before the close parenthesis.

•

Insert space after comma - If selected, a space is inserted after the comma when a parameter
name is automatically inserted, such as myfun(a, b, c).

Miscellaneous Options
The following options appear at the bottom of the Context Tagging® option screen:
•

Go to Definition navigates to symbol definition (proc) or declaration (proto) - These options
are mutually exclusive. If neither option is selected, the Select Symbol Dialog is displayed,
prompting you for both definitions and declarations. In any case, if you use Ctrl+Dot to jump to a
symbol, you can cycle through the alternate symbols by pressing Ctrl+Dot repeatedly. You can
step backwards through the list of matches by pressing Ctrl+Comma. However, once you reach
the first match, Ctrl+Comma will then pop you back to your original location, where you were
before you pressed Ctrl+Dot.
Independent of the settings for these options, in the following circumstances, SlickEdit® will jump
directly to the definition or declaration.
o

If the cursor is on the first line of a symbol's declaration, it will jump directly to the definition,
provided it is unique.

o

If the cursor is on the first line of a symbol's definition, it will jump directly to the declaration,
provided it is unique.

This behavior is particularly convenient for C++ programmers to navigate from a function to its
prototype and vice-versa. See Symbol Navigation for more information about navigating through
your code.
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•

Go to Definition ignores forward class declarations - When this option is enabled, Go to
Definition filters out forward class declarations, and only shows the actual class definitions and
declarations.

•

Show info for symbol under mouse - When selected, as the mouse cursor floats over a symbol,
the information and comments for that symbol are displayed.

•

Highlight matching symbols under cursor - When selected, all occurrences of the current
symbol under the cursor in the buffer are highlighted. The highlight color is controlled by the
Symbol Highlight screen element (Tools > Options > Appearance > Color). Advanced
configuration options are available. See Cursor on Symbol Shows All Uses in File for more
information.
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•

Update after (ms) idle - The value that you type in this field contains the idle time in milliseconds
before the List Members feature displays the list. To prevent the List Members list from being
displayed when you are typing fast, set the idle time to 300 milliseconds.

Language-Specific Color Coding Options
Color Coding is a feature that displays various portions of code in color for identification purposes. Colors
used for Color Coding are set through these options. See also Color Coding for more information.
The settings on the Color Coding options page depend on the selected language. The C/C++ Color Coding
options (Tools > Options > Languages > Application Languages > C/C++ > Color Coding) are used in
the screen shots for this section.
The Color Coding options page contains the following general options:
•

Lexer name - Select the language lexer to use from the Lexer name drop-down list. This sets the
active lexer for that language.

•

New - Click this button, located next to Lexer name, to prompt for a lexer name to start a new
language-specific color coding definition (see Creating Color Coding for a New Language).

•

Delete - Click this button, located next to Lexer name, to remove a lexer name from the list. You
can only delete user-created lexers.

•

Import - Click this button to import lexer definitions from a VLX file.

•

Colors - Click this button to jump to the Tools > Options > Appearance > Colors option screen
where you can specify the colors used. Click the Back button on the Options dialog to return to the
Color Coding Language tab. See Setting Colors for Screen Elements for more information.

Other options are categorized into the following tabs:
•
•
•
•
•
•

Tokens
Numbers
Strings
Language
Comments
Tags

Color Coding Tokens Tab
The Tokens tab provides the capability to specify unique tokens to help you when working with your code.
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The following options are available:
•

•

Token type - Select from the following token types:
o

Keywords - When this option is selected, the list box displays the words that have keyword
color.

o

CS keywords - When this option is selected, the list box to the right displays case-sensitive
words that have keyword color. These words are always case-sensitive even if the Case
Sensitive check box is not selected.

o

Preprocessor - When this option is selected, the list box to the right displays preprocessor
keywords in preprocessor color. All preprocessor keywords must start with the same
character.

o

Punctuation, Lib Symbols, Operators, User Defined - When one of these options is
selected, the list boxes to the right display the words associated with each.

Identifiers - All Context Tagging® operations use this set of characters to find identifiers in the
code that is being analyzed. Therefore, it is important to set the start and follow characters in a
manner that is consistent with the language specification. In most languages, identifiers can
contain digits, but they cannot start with them. For example, in C/C++, start characters are “a-zAZ_$” and follow characters are “0-9”.
o
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Case-sensitive - Indicates whether identifiers are case-sensitive.
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o

ID start characters - Specifies characters which are valid for the start of an identifier or any
part of an identifier.

o

ID follow characters - Specifies additional characters which are valid after the first character
of an identifier.

•

New - Click this button on the Tokens tab to add one or more words. Separate each word with a
space.

•

Delete - Deletes selected items in a list box.

•

Get - Click this button to add words by selecting the file that contains the keywords that you want
to add.

Color Coding Numbers Tab
The Numbers tab provides options for color coding numerical values when working with SlickEdit®.

This tab contains the following:
•

Hex numbers
o

0x#### (C-Style) - When this option is selected, text such as 0x123ABC is color coded in
number color.
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•

•

o

####h (Intel assembler) - When this option is selected, text such as 123ABCh is color coded
in number color.

o

$#### (Motorola) - When this option is selected, text such as $123ABC is color coded in
number color.

o

&H#### (Basic) - When this option is selected, text such as &H123ABC is color coded in
number color.

o

“####”X (Rexx) - When this option is selected, strings such as “123ABC”X are color coded in
number color.

o

Z“####” (Fortran) - When this option is selected, strings such as Z“123ABC” are color coded
in number color.

o

No Hex (COBOL) - When this option is selected, text such as 123ABC is not color coded in
number color. By default (for most languages set in Language tab) 123ABC is color coded in
number color.

Octal and binary numbers
o

####O (Intel assembler) - When this option is selected, octal numbers such as 17723O are
color coded in number color.

o

####Q (Intel assembler) - When this option is selected, octal numbers such as 17723Q are
color coded in number color.

o

####B (Intel assembler) - When this option is selected, octal numbers such as 17723B are
color coded in number color.

o

&O#### (Basic) - When this option is selected, octal numbers such as &017723 are color
coded in number color.

o

O#### (C) - When this option is selected, octal numbers with a leading zero, such as 017723
are color coded in number color.

o

####B (Binary numbers) - When this option is selected, binary numbers such as 110100B
are color coded in number color.

Floating point numbers
o

#base#number#exponent float (Ada) - When this option is selected, text such as
#23#56#67 is color coded in number color.

o

Floating point with “E” exponent - When this option is selected, text such as 123.4E24 is
color coded in number color.

o

Floating point with “D” exponent - When this option is selected, text such as 123.4D24 is
color coded in number color.

o

No exponents (COBOL) - When this option is selected, it specifies that the language does not
allow floating point exponents of any kind.

•

Do not color code numbers (HTML) - When this option is selected, text such as 123.4E24 and
123ABC is not color coded in number color. By default (for most languages set in the Language
tab), 123.4E24 and 123ABC is color coded in number color.

•

Allow underscores in integers (Ada) - When this option is selected, text such as 12_34 is color
coded in number color.

Color Coding Strings Tab
The Strings tab contains options for color coding strings.
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This tab contains the following:
•

Double quoted strings
o

Two consecutive quotes represent one (REXX) - """" for REXX represents a string of
length one which is a double quote character.

o

\" represents a double quote (C) - "\"" for C represents a string of length one which is a
double quote character.

o

Double quoted strings are always 1 char long - When this option is selected, this means
that a double quote character is followed by an additional character and then the terminating
double quote character. There is never more than one character between the start and end
double quote.

o

Trailing backslash continues string across lines (C) - When this option is selected, it
indicates that searching for the terminating quote continues to the next line if the lines end with
a backslash character.

o

Search for end quote across multiple lines - When this option is selected, it indicates that
the string does not have to be terminated on the same line as the start quote character.

o

Delay color coding until end quote - When this option is selected, a string is not color coded
unless an end quote is seen on the same line. This does not support multi-line strings.
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•

•

Single quotes
o

Two consecutive quotes represent one (Pascal) - '''' (four consecutive single quote
characters) for Pascal represents a string of length one which is a single quote character.

o

\' represents a single quote (C) - '\'' represents a string of length one which is a single quote
character.

o

Single quoted strings are always 1 char long - When this option is selected, a single quote
character is followed by an additional character and then the terminating single quote
character. There is never more than one character between the start and end single quote.

o

Trailing backslashes continues string across lines (C) - When this option is selected, it
indicates that searching for the terminating quote continues to the next line if the lines end with
a backslash character.

o

Search for end quote across multiple lines - When this option is selected, it indicates that
the string does not have to be terminated on the same line as the start quote character.

o

Delay color coding until end quote - When this option is selected, a string is not color coded
unless an end quote is seen on the same line. This does not support multi-line strings.

Backquoted strings (Perl, Bourne shell, C shell) - When this option is selected, backquoted
shell expansion strings such as `ls -d /home/` are color coded in string color.

Color Coding Language Tab
The Language tab is used to set more language-specific color coding options.
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This tab contains the following:
•

Language specific - To avoid requiring complicated BNF for defining color-coding, some
hardware language-specific adjustments have been added. You may be able to use one of these
language-specific settings for another language, but there's no guarantee it will work.

•

Color Code Line Numbers (Basic/COBOL) - When this option is selected, indicates that leading
line numbers should be color-coded in line number color.

•

Backslash escapes next character (Bourne Shell) - Backslash escapes the character that
follows. This is useful for UNIX shell scripts which use \" to indicate that the double quote is not the
start a string.

•

Here Document (UNIX Shells/Perl) - Activates support for HERE documents. Note that if you
prefix your terminator with one of our lexer names, you will get embedded language color-coding.
Example of a HERE document in Perl, where HTMLEOF is used as the terminator to get HTML
embedded language color-coding:
print <<HTMLEOF;
<HTML><HEAD><TITLE>...</TITLE></HEAD>
<BODY>
...
</BODY>
</HTML>
HTMLEOF
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Unknown languages are color-coded in string color. Embedded language colors are userdefinable.
•

Color identifiers followed by ‘(’ as a function - For language such as C++, Java, and Slick-C®,
an identifier followed by a parenthesis always indicates a function.

•

Special coloring for ‘package’ and ‘import’ statements (Java) - When this option is selected,
the Java syntax package and import statements are supported. This option is forced on for the
lexer name Java. You must add the package and/or import keywords to your keyword list in order
for this option to have any effect.

•

Preprocessing keywords can appear anywhere - When this option is selected, preprocessing
keywords are color-coded even if they are not only preceded by white space.

•

Identifiers may start with a number (COBOL) - When this option is selected, identifiers may start
with one or more decimal digits. By default, leading decimal digits indicate a number.

•

@####'' Unicode strings (C#) - When this option is selected, text in the form of @"any text" is
coded as a string.

Color Coding Comments Tab
The Comments tab is used to set comment options for Color Coding.

This tab contains the following:
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•

New Line comment - Click this button to define new single-line comments.

•

New Multi-line comment - Click this button to define new multi-line comments.

•

Delete - Click this button to remove the selected comment definition from the list.

•

Multi-line comment

- The following line comment options apply to multi-line comments:

o

Start delimiter - Delimiter which starts the multi-line comment. Currently, the first character of
this string cannot be a valid identifier character.

o

End delimiter - Delimiter which ends the multi-line comment. Currently, the first character of
this string cannot be a valid identifier character.

o

Nesting allowed - When this option is selected, this multi-line comment may have this multiline comment inside it.

o

Only if first non-blank character in line - Indicates the start delimiter must be the first nonblank character in the line in order to be considered the start of a comment. This check box is
available only when the Only when start delimiter is in column text box is completed.

o

Check for start delimiter first - When this option is selected, the lexer checks for the start
delimiter before looking for other items. When this option is specified, the start delimiter is
limited to one character in length.

o

End delimiter must be the last character on the line - When this option is selected, the end
delimiter text must occur at the end of a line to terminate the comment.

o

Only when start delimiter is in column - Indicates that the start delimiter text starts a
comment only when found in the column specified.

o

Color as - Specifies color used for this comment. This color is not used when the start
delimiter is immediately followed by one of the Comment Keywords. When the start delimiter is
immediately followed by one of the Comment Keywords, keyword color is used.

Color Coding Tags Tab
The Tags tab is used to set color-coding attributes when working with tagged-based languages such as
HTML and XML. The following screen shot shows the Color Coding Tags tab for HTML:
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It contains the following options:
•

Tag names - List box containing tags for HTML or XML. To add or delete tags, use the New and
Delete buttons below this list box.

•

>>Attributes - List box containing attributes that belong to the tag selected in the Tag names list
box. To add or delete attributes, use the New Attr and Delete buttons below this list box.

•

Attribute values - List box contains the values for the specified tag and attribute. To add or delete
a value, use the New Value and Delete buttons below this list box.

•

For all tags - When this option is selected, the values in the Attribute value list box are applied to
all tags that have the specified attribute.

Language-Specific File Options
These options are used to specify load and save options for files on a language-specific basis. As an
example, the C/C++ file options are shown below (Tools > Options > Languages > Application
Languages > C/C++ > File Options).
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The options are described as follows:
•

•

Load Options - Select from the following:
o

Load as Binary - When set to True, files are loaded without any translations (like changing
tabs to spaces). This setting has precedence over all global options, as well as all languagespecific options.

o

Expand tabs to spaces - When set to Default, SlickEdit® uses the setting for the global file
load option, Expand tabs to spaces (Tools > Options > File Options > Load). When set to
True, SlickEdit always loads files with tabs expanded to spaces. When set to False, tabs are
always left unexpanded.

Save Options - Select from the following:
o

Save as Binary - When set to True, files are saved without any translations, exactly byte-forbyte as they appear in the buffer. This setting has precedence over all global options, as well
as all language-specific options.

o

Expand tabs to spaces - When set to Default, SlickEdit uses the setting for the global file
save option, Expand tabs to spaces (Tools > Options > File Options > Save). When set to
True, SlickEdit always saves files with tabs expanded to spaces. When set to False, tabs are
always left unexpanded.

o

Strip trailing spaces - When set to Default, SlickEdit uses the setting for the global file save
option, Strip trailing spaces (Tools > Options > File Options > Save). When set to True,
trailing spaces at the end of lines are stripped. When set to False, spaces at the end of lines
are always left.
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File Options
These global file options (Tools > Options > File Options) are used to make settings regarding file
operations such as loading and saving. For more information about working with files, see the chapter
Workspaces, Projects, and Files.
File option categories are:
•
•
•
•
•
•

Load
Save
Backup
AutoSave
File Filters
Associate File Types

Load File Options
Load file options are shown below (Tools > Options > File Options > Load). For more information about
loading and opening files, see Opening Files.
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The options are described as follows:
•

Edit 'A B C' start on file A - When set to True, the first file opened becomes the active buffer.

•

Fast line count on partial load - When set to True, SlickEdit® counts the number of lines when
files are opened. The line number is always displayed in the line indicator area of the editor. This
option is much faster than the Count number of lines option when editing files larger than the
cache size (2 MB by default), because very little data is written to the spill file. The Auto Reload
feature does not work until the file is saved. If you are using the edit command to open files, use
the switch +LF to control this option (see Command Line Switches).

•

Show EOF character - When set to True, the EOF character is not removed when a file is loaded.
If you are using the edit command to open files, use the switch +LE to control this option (see
Command Line Switches).

•

Expand tabs to spaces - When set to True, the entire contents of files are read into memory and
tabs are expanded into spaces. If your tab settings for the file being loaded are of the form
+<increment> (e.g. “+4”), then tabs are expanded in increments of the specified increment.
Otherwise, tabs are expanded in increments of eight. To set tabs in a form +<increment>, select
Tools > Options > Languages > [LanguageCategory] > [Language] > Indent, and enter your
values in the Tabs text box. For languages such as REXX and Linux containing shell scripts that
require the contents of the file be analyzed before the file type is known, the Fundamental mode
tab settings are used. If you are using the edit command to open files, use the switch +E to specify
this option (see Command Line Switches).

•

File locking - When set to True, a file handle is kept open to the file for locking purposes. This
detects when another user is editing the same file. If you are using the edit command to open files,
use the switch +N to specify this option (see Command Line Switches).

•

Reinsert after current - When set to True, SlickEdit switches back to the previous buffer with the
prev_buffer command. If you are using the edit command to open files, use the switch +BP to
specify this option (see Command Line Switches).

•

Wrap line length - Specifies the number of characters at which long lines should be wrapped
when a file is opened. This option improves editing performance and is particularly useful for
editing very large, single-line XML files.

•

Use undo - When set to True, modifications to buffers may be undone (Ctrl+Z or Edit > Undo).

•

Max undo steps - Specifies the maximum number of steps that are stored for undo operations
when Use undo is enabled. Cursor motion can be undone but is not counted as a step. If you are
using the edit command to open files, use the switch +U to specify this option (see Command Line
Switches). For example, +U:32000 turns on undo and specifies a 32,000-step max.

•

Save/restore file position - When set to True, the cursor position in files is preserved on close
and restored on open.

•

Max files - Specifies the maximum number of recently closed cursor positions to save when Save/
restore file position is enabled.

•

Encoding - Unicode support required. Specifies the global (non-extension specific) file encoding.
This setting is overridden if a extension-specific encoding is defined on the File Extension
Manager for the selected language (see Managing File Extensions). Both the extension-specific
and global setting are overridden if you specify an encoding in the Open dialog. SlickEdit records
the encoding used to override default encoding settings and reuses this setting the next time you
open the same file. This provides you with per-file encoding support. Encoding is also supported
for Microsoft project files (vcproj, csproj, vbproj) that are XML files but that default to active
code page encoding and not UTF-8, like XML. See Encoding for more information.

•

Load entire file - The following options are available:
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•

o

Load entire file - When set to True, the entire contents of opened files are read into memory,
however, the line indicator (located at the bottom right section of the editor) might become
blank if the file does not fit in the editor’s cache (defaults to 2 MB). When False, Auto Reload
does not work until the file is saved. If you are using the edit command to open files, use the
switch +L to specify this option (see Command Line Switches).

o

Count number of lines - When set to True, the entire contents of opened files are read into
memory and the number of lines in the file are counted. The line number is always displayed in
the line indicator area of the editor. The Load entire file setting will have the same affect as
this setting when the entire file fits within the cache of the editor (defaults to 2 MB) and does
not have to be spilled. If you are using the edit command to open files, use the switch +LC to
specify this option (see Command Line Switches).

o

Truncate file at EOF - When set to True, the entire contents of the opened files are read into
memory and the number of lines are counted. In addition, DOS format files are truncated when
an EOF (End of File) character is found. The line number is always displayed in the line
indicator area of the editor. This option is useful for REXX .cmd files which can have p-code
appended to them after the EOF character. If you are using the edit command to open files,
use the switch +LZ to specify this option (see Command Line Switches).

o

Load partially for large files - When set to True, the editor only partially loads files larger
than the size specified in Load partially when files are larger than, in order to conserve
memory. Since the file handle remains open to your file, Auto Reload does not work until the
file is saved. The line indicator might be blank unless the Fast line count on partial load
option is enabled.

o

Load partially when files are larger than - Specifies the size limit for files to be opened
completely in the editor. If the size of the file being loaded is greater than this value, only a
portion of the file is read into memory.

Auto reload - The following options are available:
o

Auto reload - When set to True, SlickEdit detects when files being edited have been modified
by other applications and prompts to replace the file with the new copy on disk.

o

Suppress prompt unless modified - When set to True, files that have been changed on disk
are automatically reloaded unless the file has been modified in SlickEdit.

o

Auto read only - When set to True, SlickEdit detects when other applications change the
read-only attribute of a file, and automatically changes the permissions of the file being edited
to match.

o

Fast auto read only - (Windows only) When set to True, this option speeds up the Auto read
only feature by only checking the attribute on disk (not opening every file). This option is
controlled by the configuration variable def_fast_auto_readonly (see Setting/Changing
Configuration Variables).

o

Reload on switch buffer - When set to True, SlickEdit detects if a file has been modified by
another application when you switch buffers to view the file in the active editor window. When
False, the default check is still performed when you switch from another application.

Save File Options
Save file options are shown below (Tools > Options > File Options > Save).
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The options are described as follows:
•

Append EOF character - When set to True, an EOF (End of File) character is appended to the
end of DOS files when the buffer is saved. Has no effect on UNIX, Mac, or binary files. If you are
using the save command to save files, use the switch +Z to specify this option (see Command
Line Switches).

•

Remove EOF character - When set to True, the EOF (End of File) character is removed from the
end of DOS files when the buffer is saved. Has no effect on UNIX, Mac, or binary files. If you are
using the save command to save files, use the switch +ZR to specify this option (see Command
Line Switches).

•

Expand tabs to spaces - When set to True, tabs are expanded to spaces according to the tab
stops when the buffer is saved. If you are using the save command to save files, use the switch +E
to specify this option (see Command Line Switches).

•

Strip trailing spaces - When set to True, trailing spaces at the end lines are stripped when the
buffer is saved. If you are using the save command to save files, use the switch +S to specify this
option (see Command Line Switches).

•

Save files on loss of focus - When set to True, all modified files are saved when you switch to
another application.

•

Reset line modify - When set to True, line modify flags are reset when the buffer is saved. If you
are using the save command to save files, use the switch +L to specify this option (see Command
Line Switches).
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•

Add file to project upon Save As - This option controls the default value of the Add to project
option on the Save As dialog. If you are using the save command to save files, use the switch +P
to specify this option (see Command Line Switches).

•

Line format - Specifies how end of line characters are translated when a file is saved. When
Automatic is set, the line breaks are saved automatically in the file format appropriate to the
context in which you are working with no changes to the end of line characters. However, you can
designate a file type for the line breaks. For example, if you are working in Windows and using
CVS, using UNIX line breaks will make using CVS easier. Therefore, set the file format to UNIX.

NOTES
•

The Save As dialog also allows the translation of the line end characters for the
current file. See Save As Dialog.

•

Classic Mac line endings are a single carriage return (ASCII 13).

Backup File Options
Backup file options are shown below (Tools > Options > File Options > Backup). For more information
about backing up files, see File History and Backups.

The options are described as follows:
•
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Make backup files - When set to True, Backup is enabled and a backup is created when files are
saved. Use the Backup directory option to select the type and location of backups. If you are
using the save command to save files, use the switch +O to specify this option (see Command
Line Switches).
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•

Backup directory option - Specifies the type of backup history to make. Select from the following:
o

Create backup history on save - This option just creates a backup history entry of the file
when it is saved (recommended).

o

Global directory - This option places backup files in a single directory. The default backup
directory is \vslick\backup\ (UNIX: $HOME/.vslick/backup). The backup file gets the
same name as the destination file. For example, given the destination file c:\project\test.c
(UNIX: /project/test.c), the backup file will be c:\vslick\backup\test.c (UNIX: $HOME/
.vslick/backup/test.c). If you are using the save command to save files, use the switch
+D to specify this option (see Command Line Switches). Note that for a network, you might
need to create the backup directory with appropriate access rights manually before saving a
file. See Backing Up Network Files.

o

Global nested directories - This option places backup files into a directory derived from
concatenating a backup directory with the path and name of the destination file. The default
backup directory is \vslick\backup\ (UNIX: $HOME/.vslick/backup). For example, given
the destination file c:\project\test.c, the backup file will be
c:\vslick\backup\project\test.c (UNIX: $HOME/.vslick/backup/project/test.c). If
you are using the save command to save files, use the switch -D to specify this option (see
Command Line Switches). Note that for a network, you might need to create the backup
directory with appropriate access rights manually before saving a file. See Backing Up
Network Files.

o

Same directory as *.BAK - This option places backup files in the same directory as the
destination file but the extension is changed to .bak. This option is useful on networks. If you
are using the save command to save files, use the switch +DB to specify this option (see
Command Line Switches).

o

Use child directory - This option places backup files in a directory off the same directory as
the destination file. For example, given the destination file c:\project\test.c (UNIX:
/project/test.c), the backup file will be c:\project\backup\test.c (UNIX: /project/
backup/test.c). This option is most convenient on networks because of file permission
issues. If you are using the save command to save files, use the switch +DK to specify this
option (see Command Line Switches).

•

Backup directory path - Specifies the path to the directory (including the drive, if you wish) in
which to place backup files when Make backup files is enabled and one of the “Global” Backup
directory options is selected. Sets the VSLICKBACKUP environment variable. Press Delete to
clear this field, specifying the default.

•

Number of backups to keep for each file - Specifies the number of backups to store for each file.

•

Limit size of backup - When set to True, SlickEdit® limits backups to the size specified in the
option Maximum size to backup.

•

Maximum size to backup - Specifies the maximum size, in kilobytes, for files in order to be
backed up when Limit size of backup is enabled.

AutoSave File Options
AutoSave file options are shown below (Tools > Options > File Options > AutoSave). For more
information, see Saving Files.
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The options are described as follows:
•

AutoSave activated - When set to True, AutoSave is enabled, which prevents you from losing
data when an abnormal editor exit occurs (possibly from a power loss). AutoSave creates
temporary files in the specified AutoSave directory. Temporary files are only created for modified
files and are replaced when AutoSave runs subsequently. AutoSave files are deleted when you
manually save the file, close the file, or exit SlickEdit normally.
AutoSave does not save buffers that are not named. In addition, AutoRestore does not restore
files that do not exist on the disk drive of your system. Save your file at least one time to ensure
that the file has a file name and exists on the disk drive.

•

Save after period of inactivity - Specifies the amount of idle time, in seconds, after which
modified files are saved. Set this value to 0 if you do not want this option ignored.

•

Exit SlickEdit on AutoSave - When set to True, the SlickEdit® application closes after an
AutoSave, if AutoSave is enabled.

•

Save after period of time - Specifies the amount of time, in seconds, after which modified files
should be saved. Set this value to 0 if you want this option ignored.

•

Save to - Specifies save options for AutoSave temporary files. Select from:
o

Save to different directory - This option places AutoSave files in the directory specified by
the AutoSave directory field. Use this option to clean up or find all of the AutoSave files if an
abnormal editor exit occurs.

NOTE When editing two files with the same name but in different directories, one AutoSave
temporary file is overwritten by the other.
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o

Same name, different extension - This option places the AutoSave file in the same directory
as the file that is being auto-saved, but with a different extension. The third character of the
extension is replaced with a ~ (tilde) character. The length of the extension is padded with
underscores if the length of the extension is less than three characters. For example, the
AutoSave file for test.c is test.c_~. The AutoSave file for test.prg is test.pr~. If you are
editing two files in the same directory which differ only by the third character, one AutoSave
temporary file will be overwritten by the other.

o

Same name - This option automatically saves the modified files and no AutoSave temporary
files are created.

•

AutoSave directory - Specifies a different directory to use for AutoSave temporary files when
Save to different directory is selected in the Save to options. If this field is blank,
<configuration_directory>\autosave is used. To find the location of your configuration
directory, see Help > About. Press Delete to clear this field, specifying the default.

•

Largest file to AutoSave - Specifies the maximum size, in kilobytes, a file is allowed to have in
order to be automatically saved. To have all files auto-saved, set this value to 0.

File Filter Options
File filter options are shown below (Tools > Options > File Options > File Filters). They are used to
specify the default file filters for the Open and Save As dialogs.

The order of the filters specifies the order they will appear in the Open and Save As dialogs. The first file
filter is used to initialize the file list. Use the Up and Down arrow buttons to change the order. Click the
Delete button to delete a selected filter from the list.
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To add a new filter, click the Add button and enter the new filter name. Then set the value using the Filter
value box on the options screen. Separate each filter with a comma. Place file patterns in parentheses and
separate them with a semicolon. Some example filters are:
•

Basic Files (*.bas), All Files (*.*)

•

C/C++ Files (*.cpp;*.cxx;*.c;*.h), All Files (*.*)

Associate File Types Options
Use these options (Tools > Options > File Options > Associate File Types) to set up file associations.
Files that are associated run in SlickEdit® when you open them from Windows Explorer. The options,
shown below, can also be displayed with the assocft command. See Setting File Associations for more
information.
NOTE This feature is available for Windows platforms only.

Application Options
Application options (Tools > Options > Application Options) pertain to the SlickEdit® application. You
can specify what parts of SlickEdit should be restored on startup, the amount of virtual memory to use, and
more.
Application option categories are:
•
702

Auto Restore
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•
•

Virtual Memory
Exit

Auto Restore Options
Auto Restore options are shown below (Tools > Options > Application Options > Auto Restore). They
let you specify the elements of your SlickEdit® environment that are restored when you switch workspaces
or close and re-open SlickEdit. See Restoring Settings on Startup for more information about these
options.

The options are described as follows:
•

Auto restore files - When set to True, files and editor windows that were open in your last edit
session are restored when you start SlickEdit.

•

Auto restore clipboards - When set to True, clipboards are preserved and restored across
editing sessions.

•

Auto restore working directory - When set to True, the working directory is preserved and
restored across editing sessions.

•

Auto restore build window - When set to True, the concurrent process buffer is preserved and
restored across editing sessions.

•

Auto restore workspace files - When set to True, files and windows that were open in the
workspace previously are restored when you switch between workspaces. See Workspaces and
Projects for more information.

•

Auto restore line modify - When set to True, line modification flags are saved and restored when
you save and open files, respectively. Line modification flags for the last 200 files are saved. This
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option works best when the language-specific Color Coding option Modified lines is enabled
(Tools > Options > Languages > [LanguageCategory] > [Language] > General).
•

Auto restore selective display - When set to True, Selective Display is saved and restored when
saving and opening files, respectively. Selective Display for the last 200 files is saved.

•

Auto restore symbol browser tree - When set to True, the symbol browser tree in the Symbols
Tool Window is restored across edit sessions. The currently selected position is always restored
regardless of this setting.

Virtual Memory Options
Virtual memory options are shown below (Tools > Options > Application Options > Virtual Memory).
NOTE You must restart SlickEdit® for these settings to take effect.

The options are described as follows:
•
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Spill file path - Specifies the directory for spill and temporary files. On Windows, this defaults to
the directory specified the TEMP environment variable. If it does not exist, the directory specified
by the TMP environment variable is used. On UNIX, this defaults to the directory specified by the
TMP environment variable. Press Delete to clear this field, specifying the default.
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•

Buffer cache size (KB) - Specifies the maximum amount of memory, in kilobytes, used to store
text buffer data. A value that is less than zero specifies all available memory.

CAUTION If the operating system starts the swapping process before the cache is full,
performance might be degraded. The cache size must be smaller than the amount of actual
memory available.
•

Tag file cache size (KB) - Specifies the maximum cache size, in kilobytes, for tag files. Tagging
performance can be improved by adjusting this setting to better match the size of your tag files.
Generally, a tag file cache size that matches the total size of the tag files being used will provide
the best performance. For example, if the tag files for your source code and libraries adds up to
100 MB, you should set your cache size to 100 MB. You may have to experiment to find the
optimum value. Use the recommendations below as a guide. Note that this is the same as the
Maximum tag file cache size option under Tools > Options > Editing > Context Tagging®
Options. For more information about tagging, see Building and Managing Tag Files.
Tagging Performance

Recommended Setting

Minimum

8 MB

Default

64 MB

Ideal

Sum of tag file sizes

Maximum

25% of physical system memory

Exit Options
Exit options are shown below (Tools > Options > Application Options > Exit). For more information
about exiting the editor, see also Exiting the Program.
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The options are described as follows:
•

Save configuration - Specifies whether or not configuration changes are made immediately, or
upon exit, and whether or not a confirmation prompt is displayed. If set to Save configuration
immediately, configuration changes will be saved immediately after changes are detected.

•

Exit confirmation prompt - When set to True, SlickEdit always displays a confirmation prompt
prior to exiting the application.

Network & Internet Options
Network and Internet options (Tools > Options > Network & Internet Options) are used to configure the
IP setting, FTP connection profiles and options, proxy settings, and more.
Network and Internet option categories are:
•
•
•
•
•

Network Settings
FTP Default Options
URL Mappings
Proxy Settings
Web Browser Setup

Network Settings
Network settings are shown below (Tools > Options > Network & Internet Options > Network
Settings). These options are used to set the Internet Protocol (IP) version. The IP setting affects how
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addresses are chosen when connecting to a host. Features that use this setting include FTP, SFTP, and
Opening URLs.

The options are mutually exclusive: Select IPv6 and IPv4 (the default) to automatically select the address
when connecting to a host. Select IPv4 only to force IPv4 address connections or IPv6 only to force IPv6
address connections.

FTP Default Options
Default FTP options are shown below (Tools > Options > Network & Internet Options > FTP Default
Options). This Options screen is also displayed when you click File > FTP > Default Options or when you
click the Default Options button on the FTP Profile Manager. Options include the ability to set the default
local directory, specify preferences such as the default time-out and port information, enable firewall/proxy
support, and configure SSH information. See FTP for more information.
The options are categorized into the following tabs:
•
•
•
•
•

General
Advanced
Firewall/Proxy
SSH/SFTP
Debug
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FTP Default Options General Tab

The General tab contains the following:
•

Anonymous e-mail address - Default password used for anonymous logins.

•

Default local directory - Default used when adding a new connection profile. Specifies the initial
local directory after login. The local directory only applies to the FTP Client toolbar.

•

Upload on save - Select from the following:

•
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o

Do not upload - When on, saving an FTP file will not upload the file.

o

Prompt - When on, a prompt appears to upload when an FTP file is saved to specify ASCII or
Binary transfer type.

o

Upload without prompting - When on, saving an FTP file will upload the file. The same
transfer type used to open the file is used to upload the file.

Resolve links - Default for adding a new connection profile. Resolves symbolic links on remote
host.
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FTP Default Options Advanced Tab

The Advanced tab contains the following:
•

Timeout (sec) - Default used when adding a new connection profile. Specifies the wait time for a
reply from the FTP server.

•

Port - Default used when adding a new connection profile.

•

Keep alive - Default used when adding a new connection profile. Keeps a connection alive even
when idle.

•

Upload filename case - Default used when adding a new connection profile. Indicates what file
case should be used for the remote file name based on the local file name.
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FTP Default Options Firewall/Proxy Tab

The Firewall/Proxy tab contains the following:
•

Enable firewall/proxy - When on, indicates you have a firewall or proxy. You need to turn this on
to add a connection profile that uses a firewall.

•

Host name - Host name of firewall.

•

Port - Port number of firewall.

•

User ID - User ID used when logging into firewall.

•

Password - Password used when logging into firewall.

•

Type - Select from the following:

•
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o

USER user@site - When this option is selected, host and port are required. User id and
password are ignored. USER @remote_host is sent to the firewall when connecting.

o

OPEN site - When this option is selected, host and port are required. User ID and password
are ignored. OPEN remote_host is sent to the firewall when connecting.

o

USER user@site after logon - When this option is selected, host, port, user id, and password
are required. USER remote_userid@remote_host is sent to the firewall after logon.

o

Router - When this option is selected, host, port, user id, and password are ignored. Router
based firewalls are transparent with the exception that connections can only be established
one way (out through the firewall). Because incoming connections are not allowed, PASV is
turned on automatically.

Passive transfers (PASV) - When this option is selected, transfers are initiated by SlickEdit®.
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FTP Default Options SSH/SFTP Tab

The SSH/SFTP tab contains the following options:
•

SSH executable - The location of the SSH client program that is used to establish the secure
connection with the SSH server.
SFTP support requires the OpenSSH client program to operate. Windows users can obtain the
SSH client by downloading and installing the Cygwin package (www.cygwin.com) and making sure
to choose the openssh package during install.

•

Subsystem/Service name - The name of the SFTP service being run by the SSH server. Defaults
to sftp.

FTP Default Options Debug Tab
This tab is used by SlickEdit® Product Support to debug customer FTP/SFTP issues.

URL Mapping Options
URL Mapping options are shown below (Tools > Options > Network & Internet Options > URL
Mappings). These options let you map a URL path or file to a local or remote path or file, so you can work
offline or from a test location that contains DTDs referenced by your XML files. See URL Mapping for
information.
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To add a new URL mapping, click the Add button (or click <add> in the From column) and type the URL
that will be mapped to a different location. Then in the corresponding field in the To column, type the
location to use for this URL. To delete the selected mapping, click Delete.

URI Scheme Options
URI Scheme options are shown below (Tools > Options > Network & Internet Options > URI
Schemes). These options let you specify URL types that SlickEdit should recognize as hyperlinks in the
editor. See Navigating to URLs for information.
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To add a new URI scheme, click Add, and type the scheme you want to add. Do not include the “://”. For
example, if you want to be able to click on e-mail addresses in the editor, you could add a mailto scheme.
After adding a scheme, newly recognized URLs are underlined in the edit window as soon as it regains
focus.
To delete the selected scheme, so that those URLs are not hyperlinked, click Delete.

Proxy Setting Options
Proxy options are shown below (Tools > Options > Network & Internet Options > Proxy Settings).
These options allow you to configure a proxy server to use when SlickEdit® needs to use an Internet
connection. Internet Explorer settings are used by default.
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The following options are mutually exclusive:
•

None - Specifies that no proxy server is used.

•

Use Internet Explorer settings - If selected, Internet Explorer settings will be used, and the
remaining options and fields on the page are inapplicable and therefore dimmed.

•

Use proxy server - If selected, the remaining options and fields are applicable and available.
o

Servers - Indicates the proxy address and port to use.

o

Exceptions - Indicates the Web site addresses that the proxy server should disregard.
Separate entries with semicolons (;).

Web Browser Setup Options
Web browser setup options are shown below (Tools > Options > Network & Internet Options > Web
Browser Setup). Use these options to specify the browser to use when SlickEdit® needs to launch one.
Selecting a preferred browser automatically sets the defaults for the other options on this form.
NOTE This configuration does not apply to the Help system. See Supported Help Web Browsers for
more information.
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The following options are available:
•

Browsers - Select which Web browser you want to use. Selecting a preferred browser
automatically sets the defaults for the other items in the Web Browser Setup dialog box. Note the
following:
o

Windows platforms - Your Web browser is automatically detected.

o

UNIX and Mac OS X platforms - You need to specify which Web browser you are using. In
addition, you need to give the full path to the program executable.

•

Program - Indicates the program to run. You may specify a %F in this text box or any of the other
text boxes on this dialog box to have the HTML file name inserted into the command that is
executed.

•

DDE - The Application, Topic, and Item text boxes specify DDE XTYP_REQUEST parameters
and are used only if the Use DDE option is selected.

Tool Options
Options for tools (Tools > Options > Tools) pertain to tools such as Spell Check, and utilities supported by
SlickEdit®, such as version control (CVS, Subversion, etc.).
Tools option categories are:
•
•

Spell Check Options
Version Control Setup
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•

Configure Error Parsing

Spell Check Options
Spell Check options are shown below (Tools > Options > Tools > Spell Check Options). These settings
control the behavior of Spell Check in the editor (Tools > Spell Check). You can also access these options
from the main menu item Tools > Spell Check > Spell Options, or by using the spell_options command.

The Spell Check Options screen contains the following:
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•

Common list - Specifies the default dictionary list. Dictionary lists are text files that have the
extension .lst. Words that are frequently misspelled are spelled correctly in these files for
matching during spell checking. Each line of a dictionary list can contain only one word. The
default dictionary list is named scommon.lst and is located in the SlickEdit® installation directory.

•

User lists - You can have up to two custom dictionaries. When a word is not found during a spell
check and you add the word to User list 1 or 2, the word is added to the associated file specified
in these fields. By default, the first time words are added, SlickEdit will create files named
userdct1.lst and userdct2.lst in your configuration directory, so these file names are filled in
for you. If you choose to create your own files, be sure to place them in the default configuration
directory and add the file names here.

•

Ignore all UPPERCASE words - When set to True, all words in uppercase are ignored during a
spell check operation. This applies to all spell check operations.

•

Detect repeated words - When set to True, words that are repeated twice in a row are detected
during a spell check operation. This applies to all spell check operations.
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Version Control Setup Options
Version Control setup options are shown below (Tools > Options > Tools > Version Control Setup). Use
these options to enable version control support and to specify configuration information and preferences.
For more information, see Version Control.

This screen contains the following:
•

Command line systems - This is a list of command line version control systems that have built-in
support. To select a version control system, first select this option and then select the system.

•

Setup button - To change the individual commands that will be run for the selected system, click
on the Setup button. You may need to fill in the VCS Project text box depending on your
advanced version control setup.
This Setup button invokes the setup dialog for the version control system you have selected. The
following items appear on this setup dialog:

•

o

VC Command - This is a list of commands that can be run from the editor.

o

Command - This is the command that is run by the operating system when the corresponding
version control command is run. Click on the arrow to the right of the text box for a list of
variables to be parsed in.

o

Advanced button - This button invokes the Advanced Setup dialog box for the selected
version control system. See Version Control Advanced Setup Dialog for information on this
dialog box.

Add button - To add a new command line version control system, click the Add button and you
will be prompted to fill in a name for the new version control system. Then the Version Control
Command Setup dialog box will be launched.
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•

SCC providers - This section is for SCC version control systems that are registered.

•

Auto check-out on edit - When selected, a prompt appears to check out a file when you open a
file that does not exist or is read-only. This option is global and not local to the current project.

•

Set files to read only on check in - When selected, after a file is checked in, the buffer in memory
is set to read-only mode if the file is read-only. This option is global and not local to the current
project.

•

Prompt for files - When selected, the Checkin or Checkout Files dialog is displayed when
checking a file in or out, respectively. This option is not available for CVS or Subversion. See
Checkin/Checkout Files Dialog for more information.

Version Control Advanced Setup Dialog
You can access advanced setup options for each version control system that supports them. From the
Version Control Setup options (Tools > Options > Tools > Version Control Setup), select the version
control system you wish to set up. Click the Setup button. This will display the setup dialog box for the
system you have selected. Click the Advanced button on this dialog to access the advanced options. The
options are similar for each version control system. For example, below is a screen capture of the SCCS
Advanced Setup dialog. For more information about working with Version Control, see Version Control.

The following options are available:
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•

Capture errors from stdout and stderr - If the version control executable returns non-zero
(indicating an error), display output from both stdout and stderr. Most command line version control
systems will behave this way.

•

Capture errors from stdout (TLIB only) - Capture errors from stdout only. Displays output from
version control system if the return code from the version control executable is non-zero.

•

Retrieve errors from file (SS only) - This option is for the command line version of Source Safe.
It will open the error file and search for exit code. The error file name used is the default file name
for directing errors into, and can be specified in the command line as %t. It also displays output
from the version control system if the value after the colon is non-zero.

•

Internal command lookup - Check to see if the command specified is a Slick-C® command,
otherwise run as an OS command.

•

Simulate return code (Search output for “Error”)(Delta) - Searches for Error or Warning.
Displays output from the version control system if either are found.

•

Write comment to file - Write comment to a temp file, the name of which can be parsed into the
command line by putting in %c. If this option is not selected, and %c is in the command line, the
comment can only be one line, and %c will be replaced with the comment itself.
o

UNIX comment file - Writes comment file with UNIX end-of-line characters. This option is for
Windows only.

•

Run ‘dosrc’ to get error code - Used to help get the return code, especially from 16-bit
applications. Has no adverse affect, so it is best to leave this on under Windows.

•

Add *.??v to File Type list (PVCS) - Select this option for PVCS.

•

Require VCS Project box to be filled in - Requires the VCS Project text box on the Version
Control Setup dialog to be filled in.

•

Always show output - Show output from the version control system regardless of return code.

•

CD to file’s directory before running VCS command - Temporarily change the current directory
to the path of the file being operated on while running the VCS command. The directory is
changed back after the command is run.

•

CD to this directory before running VCS command - Temporarily change the current directory
to the path specified in the VCS Project text box on the Version Control Setup dialog while running
the VCS command. The directory is changed back after the command is run.

•

This directory contains the archive files (RCS) - For command line versions of RCS, specify the
directory that has the archive files for the VCS Project text box on the Version Control Setup
dialog.

•

Source Safe Tree Style - Use this style to map Source Safe projects to your actual disk hierarchy.
In the VCS Project text box on the Version Control Setup dialog, enter the Source Safe project
name in square brackets followed by the root directory for files in the project. For example:
[ $/vslick15 ] c:\vslick15

When using this style, the Source Project tree looks like the directory tree. If the name of the file
you check in or check out is c:\vslick15\clib\test.c, this file will placed in the project
$/vslick15/clib/test.c. Only files at or below c:\vslick15 directory may be checked in or
out.
•

Source Safe One Dir - When using this style, all source files are checked into or out of the Source
Safe project directory specified in square brackets. Enter the project name in square brackets in
the VCS Project text box on the Version Control Setup dialog. For example:
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[ $/vslick15 ]

•

Source Safe Locate File - When using this file, the VCS Project text box may be blank (even if
the vcp_required style is present). However, a Source Safe base project directory may be
specified in square brackets. When using this style, the Source Safe project is dynamically
determined by using Source Safe's locate command. If the file exists in the base project (VCS
Project not blank), only projects at or below this project are used. This mode of operation is slower
than sstree and ssonedir because it requires the locate command to execute for each file.

NOTE If you are using Source Safe for Windows, use the SCC interface.

Checkin/Checkout Files Dialog
When the option Prompt for files is checked in the Version Control Setup options, the Checkin Files or
Checkout Files dialog is displayed when checking files in or out, respectively. This allows you to see a list
of files in the current workspace or project, or a list of open files (buffers), and select the files to check in or
out.
NOTE This dialog is not available for CVS and Subversion.

The Checkin Files and Checkout Files dialogs share a similar interface and contain the following elements:
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•

Workspace - When this option is selected, all files in the workspace are added to the list.

•

Project - When this option is selected, all files in the current project are added to the list.

•

Buffers - When this option is selected, all open files are added to the list.

•

Available - When this option is selected, all files available for the check-in or check-out operation
are displayed in the list. For example, if you are performing a check-in, all files that have been
checked out will be added to the list. This option is only available for SCC systems.
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•

Save if modified - When this option is selected, any unsaved files are saved before check-in.

•

Checkin or Checkout - Click these buttons to perform the check-in or check-out operation on the
selected files.

•

Advanced - This button displays the options dialog specific to the version control system you are
using. This option is only available for SCC systems.

Configure Error Parsing
Options used to configure error parsing are shown below (Tools > Options > Tools > Configure Error
Parsing). They can also be accessed by clicking Build > Configure Error Parsing from the main menu,
or by using the configure_error_regex command. See Parsing Errors with Regular Expressions for
information about these features.

Help Options
Help options (Tools > Options > Help Options) pertain to the SlickEdit® Help system. Help option
categories are:
•
•
•

General
F1 Index File
F1 MSDN Help

General Help Options
General Help options are shown below (Tools > Options > Help Options > General).
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•

Word help filename(s) - Specifies the Word Help files (.idx or .mvb) used by the wh command
(Ctrl+F1), wh2 command (Ctrl+F2), and wh3 command. Separate each file with a plus sign. You
can only specify one IDX or MVB file per command. See Changing the Default Word Help File(s)
for more information about this setting.

F1 Index File Options
F1 Index File options are shown below (Tools > Options > Help Options > F1 Index File). They are used
to build and manage the Help files for Help searches and look-up. You can also display this Options screen
by selecting Help > Configure F1 Index File from the main menu, or by using the configure_index_file
command. See F1 Index Help for more information.
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The following options are available:
•

Help files - This list box displays Help files that you have added. Use the Up and Down buttons to
move the selected files up and down in the list. Use the Remove button to remove selected files.

•

Add - The Add icon, located above the Up and Down buttons, lets you to browse for another Help
file on your system to add.

•

Edit - Use this button to change the description of the selected Help file.

•

Export - Use this button to save the list of keywords for the selected Help file in Help List Text File
format (*.hlt).

•

Help file path - Type a list of directories, separated with semicolons, in this text field. These
directories are used when searching for Help files. These directories are required because .idx
files contain the Help file names without path information.

•

Load - Allows you to browse for a Help Index File in .idx format to load. If the file doesn’t exist, it
will be created.

•

Scan - Scans for Help files which contain a prefix match or exact match of the keyword selected.

•

Default - Displays the Default Help dialog. See Default Help Dialog below.

•

Show keywords - Displays a list of keywords that are in the selected Help file.

Default Help Dialog
To access this dialog, click the Default button on the F1 Index File options screen (Tools > Options >
Help Options > F1 Index File). See F1 Index Help for more information.
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The Default Help dialog is typically used to interface with Microsoft Visual C++ MVB files. However, you
could turn off the Use DDE option and configure the Program text box to run a program like Microsoft
Quick Help (qh) and pass the word at the cursor (%k). However, you may prefer to bind the qh command
to a key to separate Quick Help Word Help access.
•

Program - Indicates the program and arguments to run. The Help program is only executed if no
other Help file contains information on the word at the cursor or if using DDE requires a program to
be started before the DDE request can be made.

•

DDE - The Application, Topic, and Command text boxes specify DDE XTYP_REQUEST
parameters and are used only if the Use DDE option is selected.

F1 MSDN Help Options
F1 MSDN Help options (Tools > Options > Help Options > F1 MSDN Help) are used to enable and
specify which MSDN Help collections to use as the default Help. This Options screen can also be
displayed by selecting Help > Configure F1 MSDN Help from the main menu, or by using the
msdn_configure_collection command. See Configuring F1 MSDN Help for information.
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Options History
The Options History node in the Options dialog (Tools > Options > Options History) is used to see
changed options. From the drop-down, select Anytime to see all options that have been changed from the
default values since the editor was installed, or, choose to see only those options that were changed today,
yesterday, or within the last week or month. Only the most recent date is shown for options that have been
changed more than once.
NOTE Options History only shows changes that were made through the Options dialog. Changes
made by setting configuration variables, in macro code, or in other dialogs are not viewable in the
Options History.
The results are displayed in the Options dialog in the results window, as shown in the following screen.
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The number of results returned is displayed at the top right of the results window. The results are divided
into columns showing the name of the option, the path to the option in the option tree, and the date it was
last changed. Click on the column header to sort by any column. Double-click on an option to display that
option panel in the dialog. For options changed on forms embedded in the Options dialog, the results show
only the name of the form. For example, if you made a change to a color under Appearance > Colors on
the Options dialog, the Options History results show “Colors” as the name of the option and “Appearance”
as the path.

Select Symbol Dialog
The Select Symbol dialog is automatically displayed when you use the Go to Definition feature (by
pressing Ctrl+Dot, clicking Search > Go to Definition from the main menu, or using the push_tag
command), when multiple code locations match the selected symbol. See Symbol Navigation for more
information about this feature.
NOTE The “Select a Tag” dialog has been renamed as the “Select Symbol” dialog in SlickEdit® 2008
(v13.0.1).
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See Tabular Lists for information about resizing columns and other layout information.
The dialog displays all tagged instances of the symbol in your project, including definitions and
declarations. The name of the symbol and the file path and line number are shown.
To go to a symbol, select it and click OK or double-click on it. Like other selection dialogs, you can also
start to type the name of the symbol and as you type, SlickEdit auto-selects the matched item in the list.
The options on this dialog set the behavior of Go to Definition going forward. The first three options match
the Go to Definition options found at Tools > Options > Languages > [LanguageCategory] >
[Language] > Context Tagging® (see Language-Specific Context Tagging® Options). When you make a
setting on the Select Symbol dialog, the settings on the Options dialog are updated to match, and this
dialog does not appear again unless there is more than one unique definition or declaration.
When the option Do not show these options again is selected, the Select Symbol dialog does not show
these options when/if it is displayed in the future. This option is automatically checked when you select one
of the Always navigate to options.
To reset the default behavior so this dialog with options appears again when applicable, go to the language-specific Go to Definition options and uncheck both of the Go to Definition navigates to options.
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Window
This section describes items on the Window menu and associated dialogs and tool windows. For more
information about working with editor windows, see Buffers and Editor Windows.

Window Menu
The table below describes each item on the Window menu and its corresponding command.
Window Menu Item

Description

Command

Cascade

Cascades editor windows.

cascade_windows

Tile

Tiles editor windows.

tile_windows

Tile Horizontal

Tiles editor windows horizontally
when there are three or less windows.

tile_windows h

Arrange Icons

Rearranges iconized windows.

arrange_icons

Next

Switches to next window.

next_window

Previous

Switches to previous window.

prev_window

Close

Closes the current window.

close_window

Font

Displays the Window Font dialog,
which allows you to set/view fonts for
the current editor window or all
windows. See Window Font Dialog.

wfont

Split Horizontally

Splits the current window horizontally
in half.

hsplit_window

Split Vertically

Splits the current window vertically in
half.

vsplit_window

Zoom Toggle

Zooms or unzooms the current
window.

zoom_window

One Window

Zooms the current window and
deletes all other windows.

one_window

Duplicate

Creates another window linked to the
current buffer.

duplicate_window

Link Window

Displays the Link Window dialog,
which allows you to select a buffer to
display in the current editor window.
See Link Window Dialog.

link_window

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Window menu items.
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Window Font Dialog
The Window Font dialog is used to set the font and font style of editor windows. For more information
about setting fonts, see Setting Fonts and Colors.
To access the Window Font dialog, click Window > Font, or use the wfont command.

The following options and settings are available:
•
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Scope - Specifies the editor windows to affect.
o

Current window - Affects the current editor window only.

o

All windows and Default - Affects all open editor windows and all newly-created editor
windows.

•

Font - Displays a selection list of the fonts installed on your computer.

•

Size - Displays a selection list of the sizes that are available for the selected font.

•

Style - Displays a selection list of common font style options such as bold, italic, etc.

•

Fixed Fonts Only - If selected, only fixed fonts that are installed on your computer are displayed in
the Font list box.

•

Script - (Windows only) Displays a selection list of character language settings. Choose Default
unless you are editing files that have characters not in the active code pages. Choose Western to
use the typical English characters.

•

Sample - Displays a preview of the selected font and settings.
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Link Window Dialog
The Link Window dialog is used to link files to editor windows, so that you can view more than one file in
one editor window. For more information about working with editor windows, see Buffers and Editor
Windows.
To access the Link Window dialog, click Window > Link Window, or use the link_window command.

The buttons are described as follows:
•

Link to Window - Changes the file that is displayed in the current window to be the selected file/
buffer in the list box. Modifications made to the buffer that was previously displayed will not be lost.

•

Open File - Opens a file and displays it in the current window. No additional window is created.

•

Start Process - Starts a process buffer and displays it in the current window. If a process buffer
has already been started, it is linked to the current window.
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Help
This section describes items on the Help menu and associated dialogs and tool windows. For more
information about how to use the Help system and how to obtain product support, see The Help System
and Product Support. For advanced Help configuration topics, such as accessing multiple Help files and
configuring F1 MSDN Help, see Advanced Help Configuration.

Help Menu
The table below describes each item on the Help menu and its corresponding command.
Help Menu Item

Description

Command

Contents

Displays the Help system open to the
Table of Contents. See The Help
System.

help -contents

Index

Displays the Help system open to the
Index, where you can search for index
items. See The Help System.

help -index

Search

Displays the Help system open to the
Search tab, where you can search for
any item. See The Help System.

help -search

Cool Features

Displays the Cool Features dialog,
which shows SlickEdit® feature tips.
See Cool Features Dialog.

cool_features

Quick Start

Displays the SlickEdit Quick Start
documentation. See Quick Start.

help Quick Start

Keys Help

Displays the Help system open to the
emulation key binding reference
tables for the current emulation. See
Emulation Tables.

help key bindings

What Is Key

Used to discover the command
associated with a key binding. Opens
the command line, prompting with the
text What is key. See Determining the
Command of a Key Binding.

what_is

Where Is Command

Used to discover the key binding
associated with a command. Opens
the command line, prompting with the
text Where is command. See
Determining the Key Binding of a
Command.

where_is

Macro Functions by
Category

Displays the Help system open to this
topic, which shows a categorized list
of macro functions.

help macro functions by
category

SlickEdit® User Guide

733

HELP

Help Menu Item

Description

Command

Frequently Asked
Questions

Invokes a Web browser which opens
to the FAQs section of the SlickEdit
Web site, which contains answers to
common user questions.

goto_faq

F1 Index Help

Displays the Help Index dialog, where
you can search the F1 index file for
Help on a word. See Help Index
Dialog.

help_index

Configure F1 Index File

Lets you view or modify the index file
used by F1 Word Help. See F1 Index
File Options.

configure_index_file

Configure F1 MSDN
Help

Lets you activate and configure
MSDN Library F1 Word Help. See
Configuring F1 MSDN Help.

msdn_configure_collection

License Manager

Displays the SlickEdit License
Manager for managing licenses. See
Licensing.

lmw 1

Product Updates

Displays the Product Updates menu,
from which you can install updates
and hot fixes. See Product Updates
Menu.

N/A

Register Product

Displays the Register dialog, from
which you can begin the SlickEdit online registration process.

online_registration

SlickEdit Support Web
Site

Invokes a Web browser which opens
to the SlickEdit Support Web site. See
Product Support.

goto_slickedit

Contact Product
Support

Used to invoke a Web browser which
opens to a form on the SlickEdit Web
site that you can use to contact
Product Support. See Product
Support.

do_webmail_support

Check Maintenance

Invokes a Web browser which opens
to a SlickEdit Web page that shows
the status of your Maintenance and
Support Agreement.

check_maintenance

About SlickEdit

Displays a property sheet containing
information about your product, such
as serial and version numbers, as well
as release notes and the license
agreement.

version
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Product Updates Menu
The table below describes each item on the Help > Product Updates menu and its corresponding
command.
Product Updates Menu
Item

Description

Command

New Updates

Checks for new updates to the
product.

upcheck_display

Options

Displays the Update Manager Options
dialog, used to set the frequency of
automatic checking of new updates.
See Update Manager Options Dialog.

upcheck_options

Load Hot Fix

Displays an Open-style dialog, to
begin the process of installing a hot
fix. See Applying Hot Fixes.

load_hotfix

List Installed Fixes

Displays a summary sheet of hot fixes
that are installed on your computer.
See Applying Hot Fixes.

list_hotfixes

Dialogs and Tool Windows
This section describes the dialogs and tool windows that are associated with the Help menu items.

Cool Features Dialog
The Cool Features dialog appears automatically after the product installation has completed, and by
default, each time the editor is started. To access the dialog at any time, from the main menu, click Help >
Cool Features, or use the cool_features command on the SlickEdit® command line.
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The following options and buttons are available:
•

Options for Feature - Displays the dialog from which you can make settings for the selected
feature.

•

Help on Feature - Displays the Help system open to the documentation for the selected feature.

•

View Demonstration - Invokes a Web browser which navigates to a SlickEdit Web page
containing an audio/visual demonstration of the feature in action.

•

Topics - Displays a table of contents from which you can select a Cool Feature to learn more
about. The previously viewed topic is remembered and displayed the next time the dialog is
invoked.

•

Prev - Scrolls to the previous Cool Feature.

•

Next - Scrolls to the next Cool Feature.

•

Show on startup - If selected, prevents the Cool Features dialog from appearing each time the
editor is started.

Help Index Dialog
The Help Index dialog scans a Help .idx file for Help files that contain a prefix match or exact match of the
keyword under the cursor. To display this dialog, press F1 when the cursor is under a keyword, or click
Help > F1 Index Help. The following options and buttons are available:
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•

Help Keyword - Specifies the keyword to search for. Type directly into this field, or, if you are
seeking Help for a keyword under the cursor, the keyword will be automatically filled in.

•

Help Files list box - Displays a list of the Help files in which the keyword was found. Select the
Help file to use.

•

Close on choose - If selected, the dialog is closed when you click OK.

•

Exact match - If selected, only Help files which contain an exact match of the keyword specified
are displayed.

•

Use default - If selected, no search is performed for a valid Help item. A DDE or shell command is
performed to get help on the Help Keyword specified. The exact action here depends on the
Default Help dialog (see Default Help Dialog). Visual C++ Help usually works without selecting this
option.

•

Configure Index - Displays the F1 Index File options screen, which lets you specify the Help files
to be used when searching for help. See F1 Index File Options for more information.

Update Manager Options Dialog
The Update Manager checks for new product updates. To set the frequency of automatic updates, use the
Update Manager Options dialog (Help > Product Updates > Options). Click Proxy Settings to display
the Proxy Setting Options.
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Menu Editing
For information about accessing menus in SlickEdit® and associated options, see Accessing Menus.

Creating and Editing Menus
Menus in SlickEdit® are controlled by Slick-C® macro files. You can customize menus by editing these
files.
If you plan to customize your menu items, be sure to back up your configuration directory before installing
any updates or new versions of SlickEdit, as they will overwrite your changes.
Menus can be managed using the Open Menu dialog. From this dialog, you can pick a menu to edit, create
a new menu, run a menu as a pop-up. To access the dialog, from the main menu, click Macro > Menus (or
use the open_menu command). The following buttons are available:
•

Open - Opens the menu specified in the combo box for editing with the Menu Editor. If the menu
specified does not already exist, it is created.

•

New - Creates a new menu with a unique name for editing with the Menu Editor. The Menu Editor
allows you to change the name of the menu.

•

Delete - Deletes the specified menu from the combo box.

•

Show - Runs the menu by displaying it as a pop-up. Use this button during macro recording to
create a command which runs a menu by displaying it as a pop-up. If you bind the command to a
left or right button mouse event, the menu will be displayed at the cursor position.

You can use the Menu Editor to create a new menu, or modify the SlickEdit menu bar or an existing menu
resource, which can be displayed as a pop-up or menu bar.

Creating a New Menu Resource
Use the Menu Editor to create a new menu resource. From the main menu, click Macro > Menus (or use
the open_menu command), then click New on the Open Menu dialog. The Menu Editor is displayed. See
Menu Editor Dialog for more information.
To create a command which runs a menu by displaying it as a pop-up, after creating a menu, while macro
recording, click the Show button on the Open Menu dialog box. If you bind the recorded command to a left
or right mouse button event, the menu will be displayed at the cursor position. You DO NOT need to
specify key bindings for menu items because the Menu Editor automatically determines the key bindings
for you. To choose between short and long key names, from the main menu click Tools > Options >
Appearance > Advanced, then change the option Short key names.
See the Slick-C® Macro Programming Guide for information on creating forms with menu bars or
advanced information.

Editing Menus
To select a menu for editing, from the main menu click Macro > Menus (or use the open_menu
command). Select the menu to edit from the list, then click Open. The Menu Editor will be displayed. See
Menu Editor Dialog for a list of the available options.

Defining Menu Item Aliases
The Menu Item Alias dialog box allows you to define aliases (which are similar commands) for the
command that is being executed. This dialog box can be accessed by clicking the Alias button on the
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Menu Editor. Enter each alias command on a separate line. If one of the alias commands are bound to a
key, that key name will be displayed to the right of the menu item. For example, the e and edit commands
are absolutely identically in function except that the e command requires fewer characters to type. The
gui_open command is identical to the edit command except that it prompts the user with a dialog box,
whereas the edit command prompts for files on the command line. These two examples illustrate the best
reasons for using aliases.

Enabling/Disabling Menu Items
SlickEdit® has some enable or disable attributes for predefines which you can specify for any command.
When these predefined auto-enabling attributes are not enough, you need to implement a callback which
determines the enable or disable state of the command. See the Slick-C® Macro Programming Guide for
information on enabling and disabling menu items with your own callback.
The Auto Enable Properties dialog box is used for these settings, and can be accessed from the main
menu by clicking Macro > Menus. When the Open Menu dialog box is displayed, click New to display the
Menu Editor. Click the Auto Enable button, and the Auto Enable Properties dialog is displayed.
For descriptions of the options on this dialog, see Auto Enable Properties Dialog.
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Appendix
This chapter contains the following topics:
•
•
•
•
•
•
•
•
•
•
•
•

Tutorials
Encoding
Invocation Options
Environment Variables
Configuration Variables
Configuration Directories and Files
File Search Order
Advanced Help Configuration
VLX File and Color Coding
Editing the Key Binding Source
Using the ISPF and XEDIT Emulations
Emulation Tables
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Tutorials
Tutorials in this section:
•
•
•
•
•

Hello World Tutorial (C/C++)
Hello World Tutorial (C#)
Hello World Tutorial (Java)
Vim Tutorial
Creating and Distributing Custom Toolbars

Hello World Tutorial (C/C++)
This tutorial outlines the steps to create, build, and run a sample Hello World program using the auto-build
system for GNU C/C++ projects.
The sample C++ program prints the text hello world to the standard output on the Console view. Follow
these steps to create a Hello World program using the GNU C/C++ wizard.

Create the Project Using the GNU C/C++ Wizard
1. From the main menu, click Project > New.
2. On the Project tab, click to expand C/C++, then click GNU C/C++ Wizard.
3. Specify the Project name as HelloWorld. Change the location if you want.
4. Click OK on New project dialog.
5. Select the Project Type as Executable and the Source Type as C++.
6. Click Next.
7. For the Application Type, select A “Hello World” application.
8. Click Next.
9. Select Build without a makefile.
10. Click Finish. A dialog is displayed, containing information about the new project. Click OK. The
wizard constructs a workspace by the name of HelloWorld.vpw, a project called
HelloWorld.vpj, and a program file called HelloWorld.cpp.

Build the Project
To build this project, from the main menu, select Build.

Run the Program
To run the program, from the main menu, click Build > Execute. The application displays Hello World in
the output window.

Comments
When creating a new project in a new workspace, a new workspace does not have to be explicitly created.
The workspace is created automatically when the project is created. The workspace will be given the same
name as the project.
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For large projects, multiple projects most likely will be created and the workspace name should be distinct
from the project names for easier organization.

Hello World Tutorial (C#)
This tutorial describes how to build a simple C# console application with SlickEdit—no Visual Studio
required. It assumes you have the .NET Framework 2.0 and the C# compiler (Csc.exe) installed under
%WINDIR%\Microsoft.NET\Framework\v2.0.50727. The Windows SDK (v6.0 or later) or the full .NET
Framework SDK is required if you want to interact with the managed code debugger (mdbg.exe).

Creating the Starter Project
Project Setup
Use the following steps to set up the starter project:
1. From the main menu, click Project > New.
2. Select the (Generic) project type.
3. In the Project name box, type SeHello.
4. Select the Create project directory from project name option.
5. Change the Location to the path where you want to store the project.
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6. Click OK.
7. Close the Project Properties dialog that automatically appears.

Create and Add a File to the Project
Next, use the following steps to create and add a file to the project:
1. From the main menu, click File > New Item from Template.
2. In the Categories list, under Installed Templates, select CSharp.
3. In the Templates list, select C# Main Entry Point.
4. In the Name box, select the default or change the name based on your preference.
5. Select the Add to current project option.

6. Click Add.
7. Click OK on the Parameter Entry dialog.
8. The new file opens in the editor and also appears in the Source Files project folder. Use the
Projects tool window to see project folders and their contents.

SlickEdit® User Guide

745

TUTORIALS

9. Add the following code inside Main():
#if DEBUG
Console.WriteLine("Hello World - Debug");
#else
Console.WriteLine("Hello World - Release");
#endif

10. Save and close the file.

Set Environment Variables
Use the steps below to set variables for the workspace. A SlickEdit workspace (.vpw) is equivalent to a
solution (.sln) in Visual Studio.
1. From the main menu, click Project > Workspace Properties.
2. Click the Environment button.
3. Click Set Environment Variable.
4. In the Name box, type DOTNETDIR.
5. In the Value box, specify your .NET framework that you want to use for the C# compiler, for
example, C:\Windows\Microsoft.NET\Framework\v2.0.50727. To use an existing environment
variable in the definition of the workspace environment, use the %(VARIABLE) syntax—not the
%VARIABLE% syntax—for example, %(WINDIR)\Microsoft.NET\Framework\v2.0.50727. Be
sure to select environment variable names that do not already exist.
6. Optionally, create another variable named WINSDKDIR, and point it to the Windows SDK or .NET
Framework SDK, for example, C:\Program Files\Microsoft SDKs\Windows\v6.0. This should
be a directory where the mdbg.exe managed code debugger can be found.
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7. Click OK.
8. Close and reopen the workspace to set the environment variables.

Setting Up the Release Build
Once you’ve set the environment variables, complete the following steps to configure the commands for
building a release version:
1. From the main menu, click Project > Properties.
2. In the Settings for box, select Release.
3. Click to display the Tools tab.
4. In the Tool name box, remove both Compile and Rebuild by selecting them and clicking the red
X button. The remaining tools are Build, Debug, and Execute.
5. In the Tool name box, select the Build tool.
6. In the Command line box, type the following, replacing SeHello.exe with your own executable
name:
%(DOTNETDIR)\csc.exe /warn:3 /target:exe /define:TRACE /debug- /
out:%bdSeHello.exe %{*.cs}

The %bd in the above command line is a variable that represents the build output directory, in this
case Release\. The %{*.cs} construct specifies all project files that end with the .cs extension.
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7. Make sure the Run from dir box contains %rw, which specifies the build should run from the
project’s working directory.
8. Make sure the Capture output and Output to build window options are selected, so the output
is captured and displayed in the Build tool window.

9. Back in the Tool name box, select the Execute tool.
10. Change the command line to “SeHello.exe” (including quotes), replacing SeHello.exe with the
name of the executable specified in Step 6 above.
11. In the Run from dir box, change the option to %bd (which represents the build output directory).
12. Make sure the Capture output and Output to build window options are selected.
13. Click OK to save your settings and close the Project Properties dialog.
You can now execute a build and see the output of the C# compiler by clicking Build > Build from the main
menu. Once successful, you can run the console program and display the “Hello World-Release” results by
clicking Project > Execute from the main menu.

Setting Up the Debug Build
To configure commands for a debug build, complete the following steps:
748

SlickEdit® User Guide

TUTORIALS

1. From the main menu, click Project > Project Properties.
2. Click the Configurations button.
3. Click New.
4. In the New config name box, type Debug.
5. In the Copy settings from box, make sure Release is selected.
6. Click OK to create the Debug config, and dismiss all of the dialogs.
7. On the Project Properties dialog, click to display the Tools tab.
8. In the Settings for box, select Debug.
9. In the Tool name box, select the Build tool.
10. In the Command line box, type the following, replacing SeHello.exe with your own executable
name:
%(DOTNETDIR)\csc.exe /warn:3 /target:exe /define:DEBUG;TRACE /debug+ /
out:%bdSeHello.exe %{*.cs}

Adding the DEBUG define and changing /debug- to /debug+ are the only changes between the
Release and Debug configuration command lines.
11. In the Tool name box, select the Execute tool.
12. Set up the Execute tool the same as you did in Step 9 for the Release configuration (see Setting
Up the Release Build).
13. Click OK to save your settings and close the Project Properties dialog.
14. From the main menu, click Build > Set Active Configuration and select Debug.
You can now execute the build by clicking Build > Build from the main menu. Once successful, click Build
> Execute to see the “Hello World - Debug” output in the Build tool window.

Handling Complex Build Commands
A small console application like this one doesn’t have any extensive dependencies, and most of the default
options for the C# compiler are fine. However, more complex projects will require many more options to be
passed on the command line. For these cases, it can be useful to create an options file for all of the
command line switches. To do this:
1. From the main menu, click File > New to create a new text file and add it to the project. For this
example, we are creating the command line options for the Debug build in a file called
Debug.opts.
2. Insert the following into the new file. This should match your first few options on the Debug build
command line:
/warn:3 /target:exe /define:DEBUG;TRACE /debug+

3. From the main menu, click Project > Project Properties.
4. Click to display the Tools tab.
5. In the Settings for box, select the Debug configuration.
6. In the Tool name box, select the Build tool.
7. In the Command line box, type the following, where SeHello.exe is your own executable name:
%(DOTNETDIR)\csc.exe @Debug.opts /out:%bdSeHello.exe %{*.cs}

SlickEdit® User Guide

749

TUTORIALS

8. Close the Project Properties dialog.
9. From the main menu, click Build > Build to make sure the options file was correctly read.

Setting Up the Console Debugger
Optionally, to set up the console debugger, complete the following steps. This demonstrates how to hook
up an external tool, and how it can be used interactively inside the Build tool window.
1. From the main menu, click Project > Project Properties.
2. Click to display the Tools tab.
3. In the Settings for box, select Debug.
4. In the Tool name box, select the Debug tool.
5. In the Command line box, type the following, where SeHello.exe is the name of your own
executable:
%(WINSDKDIR)\Bin\mdbg.exe SeHello.exe

6. Make sure Run from dir is set to %bd.
7. Make sure the Capture output and Output to build window options are selected.
8. Click OK to save your settings and close the Project Properties dialog.
9. From the main menu, click Build > Debug. The Build tool window now has focus with a blinking
cursor just after the first mdbg> prompt.
10. In the Build window, type the following commands in order, pressing Enter after each one:
o
o
o
o

print args - To show the value of the args variable.
next - To do a step over.
go - To continue execution.
quit - To quit the debugger. The debugger must be stopped in order for SlickEdit to regain
control of the Build window.

The entire debug session output should look similar to the following:
C:\Dev\Lab\TestProjects\SeHello\Debug
> C:\WinSDK\Bin\mdbg.exe SeHello.exe
MDbg (Managed debugger) v2.0.50727.312 (rtmLHS.050727-3100) started.
Copyright (C) Microsoft Corporation. All rights reserved.
For information about commands type “help”;
to exit program type “quit”.
run SeHello.exe
STOP: Breakpoint Hit
16: static void Main(string[] args) {
[p#:0, t#:0] mdbg> print args
args=array [0]
[p#:0, t#:0] mdbg> next
19: Console.WriteLine(”Hello World - Debug”);
[p#:0, t#:0] mdbg> go
Hello World - Debug
STOP: Process Exited
mdbg> quit
C:\Dev\Lab\TestProjects\SeHello\Debug
>
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Hello World Tutorial (Java)
This tutorial outlines the steps to create, build, and run a sample Hello World program for Java projects.
The sample Java program prints the text Hello World to the standard output.

Create the Project
1. From the main menu, click Project > New.
2. On the Project tab, click to expand Java, then select Java - Empty Project.
3. Type the Project name, HelloWorld. If you already completed the C/C++ tutorial you will need to
enter a different name, like HelloWorldJava.
This creates a workspace and project by the name HelloWorld at C:\HelloWorld.

Create the File
1. From the main menu, click Project > New.
2. Select the File tab.
3. Select Java from the list and enter a Filename, HelloWorld.java. Be sure to type the file
extension.
4. Check the Add to Project check box or the file will be created but will not be able to be built.
By default the file is created in the directory created in the previous step.

Edit the File
Edit the file to enter a Hello World program, as shown in the following example:
public class HelloWorld {
public static void main (String args[]) {
System.out.println("hello world");
}
}

Build the Project
From the main menu, select Build.

Run the Program
From the main menu, click Run > Execute. The words Hello World are displayed in the window.

Vim Tutorial
SlickEdit® provides an emulation mode for the Vim text editor. If you want to learn Vim, you can use the
vimtutor command. Most Vim installations come with this command, which displays a special “learn-bydoing” practice file in the editor that you can can actually edit as you learn how to use the Vim commands.
This file has been customized for SlickEdit users.
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To use the command, open the SlickEdit command line, then type the command and press Enter. The
practice file is displayed in the editor. Each time you use the vimtutor command, SlickEdit creates a fresh
copy of this file.
TIPS
•

You will be prompted to switch to the Vim emulation when you invoke the command if the
editor is set to a different emulation. See Changing Emulations for more information.

•

When in the Vim emulation, you can open the SlickEdit command line with Ctrl+A, or in any
emulation, by clicking in the message area with the mouse. See Activating the Command
Line for more information.

Creating and Distributing Custom Toolbars
Use the following steps to write a macro which will load a custom toolbar that you can easily distribute to
other users:
1. Create a new form by clicking Macro > New Form.
2. Change the form's name by editing the name property. For this example, we will name the form
“mytoolbar1”. You will need to remember the name of the form.
3. Save the new form by pressing Ctrl+S, or, right-click on the form and select Save Form.
4. Close the form and its properties.
5. Create a new toolbar. To do this, click View > Toolbars > Customize, then make sure the
Toolbars tab is selected and click New. Enter a new toolbar name in the Tool Bar Name field. This
is the caption that will be used on the title bar of your toolbar when it is floating (i.e. not docked).
For this example, we will use “My Toolbar 1”. Next, expand the dialog by clicking the Advanced
button. In the Form Name box, enter the form name that you just created in Step 1, then click OK.
The new toolbar is displayed as floating.
6. Add buttons to the new toolbar by dragging and dropping them onto the new toolbar from the
Categories tab of the Toolbars options page (Tools > Options > Appearance > Toolbars).
7. Activate the SlickEdit® command line (see Activating the Command Line) and run the
save_config command.
8. Open the file vusrobjs.e (this file resides in your SlickEdit config directory, which can be found by
going to Help > About SlickEdit). An example of this file is located in the docs/samples
installation subdirectory.
9. Copy all of the code which is related to your new toolbar as well as the defmain() function at the
bottom of the file, and paste it into a new file with a .e extension. An example of this file is
newToolbar.e, located in the docs/samples installation subdirectory.
10. Add the following include statements to the very top of the file:
#include 'slick.sh'
#include 'toolbar.sh'

Be sure that slick.sh is included first.
11. At the end of the defmain() method, add the following line directly below the call to
_config_modify_flags (as seen in newToolbar.e):
_tbAddForm("mytoolbar1", TBFLAG_NEW_TOOLBAR,false,0,true);
// Where mytoolbar1 is the name of your new form and _not_ the name of your
toolbar.
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This will actually add the toolbar to SlickEdit and update the SlickEdit state file.
12. Save the file.
13. This macro (remember that it ends in .e) will not compile like standard macros because of the
defmain() call. Therefore, activate the SlickEdit command line and enter the full path to the newly
created macro file (in this case, newToolbar.e). This will load the macro and the new toolbar.
In order to share this toolbar, distribute the new macro file that you created in Step 10, and have each user
run it on the SlickEdit command line as described in Step 14. The new toolbar can be displayed by clicking
View > Toolbars > My Toolbar 1.
Your final macro should look very similar to newToolbar.e. Of course you can add more than one toolbar
to the macro file using the same steps.
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Encoding
Encodings are used to convert a file to either SBCS/DBCS for the active code page or Unicode (more
specifically UTF-8) data. By default, XML and Unicode files with signatures (UTF-8, UTF-16 and UTF-32)
files are automatically loaded as Unicode UTF-8 data, while other more common program source files like
.c, .java, and .cs source files are loaded as SBCS/DBCS active code page data.
All file data can be configured to Unicode UTF-8 data, but this would cause some problems. Loading files
containing SBCS/DBCS data would take significantly longer, slowing down parsing by Context Tagging®
and any other multi-file operations. In addition, Unicode editors cannot support all the features supported
by SBCS/DBCS editors due to font limitations. For more information, see Unicode Limitations.
To provide better support for editing Unicode and non-Unicode files, two modes of editing exist: Unicode
and SBCS/DBCS mode. Files that contain Unicode, XML, or code page data not compatible with the active
code page should be opened as Unicode files.
The following are non-Unicode encodings and put the editor in SBCS/DBCS editing mode: Default, Text,
SBCS/DBCS mode, Binary, SBCS/DBCS mode, and EBCDIC, SBCS/DBCS mode. In addition, the
Auto Unicode, Auto Unicode2, Auto EBCDIC and Unicode, and Auto EBCDIC and Unicode2
encodings put the editor into SBCS/DBCS editing mode when the file is determined not to be Unicode. All
other encodings put the editor in Unicode mode and require that the file data be converted to UTF-8.
There are many encodings available, including:
•

Auto XML - This encoding specifies that the file encoding be determined based on XML standards
and that the file be loaded as Unicode data. The encoding is determined based on the encoding
specified by the ?xml tag. If the encoding is not specified by the ?xml, the file data is assumed to
be UTF-8 data which is consistent with XML standards. We applied some modifications to the
standard XML encoding determination to allow for some user error. If the file has a standard
Unicode signature, the Unicode signature is assumed to be correct and the encoding defined by
the ?xml tag is ignored.

•

Auto Unicode - When this encoding is chosen and the file has a standard Unicode signature, the
file is loaded as Unicode data. Otherwise the file is loaded as SBCS/DBCS data.

•

Auto Unicode2 - When this encoding is chosen and the file has a standard Unicode signature or
looks like a Unicode file, the file is loaded as Unicode data. Otherwise the file is loaded as SBCS/
DBCS data. This option is NOT fool-proof and may give incorrect results.

•

Auto EBCDIC - When this encoding is chosen and the file looks like an EBCDIC file, the file is
loaded as Unicode data. Otherwise, the file is loaded as SBCS/DBCS data. This option is NOT
fool-proof and may give incorrect results. The option does attempt to support binary EBCDIC files.

•

Auto EBCDIC and Unicode2 - This encoding is a combination of the Auto EBCDIC and Auto
Unicode2 encodings described above.

Using Unicode
To use encodings in SlickEdit®, Unicode support is required (OEMs typically turn this feature off). Unicode
is supported for the following list of features:
•

All Context Tagging® features.

•

Color Coding.

•

Level 1 regular expressions as defined by the Unicode consortium.

•

Multi-file search and replace.
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•

Support for many encodings including UTF-8, UTF-16, UTF-32, and many code pages. Automatic
encoding recognition for XML files. Configure encoding recognition per extension or globally.
Optionally store signatures and specify little endian or big endian. Use the Save As or Write
Selection dialog to convert data to a particular file encoding.

•

Support for converting Unicode to UNC data and visa versa. Supported UCN formats include
\xHHHH, \x{HHHH}, \uHHHH, &xHHHH;, and &xDDDD;. This is useful for specifying Unicode
character strings in SBCS/DBCS active code page source files. See Converting Unicode to UCN.

•

Multiple clipboards.

•

Sorting.

•

3-Way Merge.

•

Support for composite and surrogate characters.

•

Support for storing up to 31-bit Unicode characters.

•

SmartPaste®.

•

Syntax Expansion and Syntax Indenting.

•

Code beautifiers.

•

Support for almost all of SlickEdit’s SBCS/DBCS active code page features.

Unicode File Recognition
By default, XML and Unicode files with signatures (UTF-8, UTF-16 and UTF-32) files are automatically
loaded as Unicode. If you have Unicode files that are not XML and do not have signatures, configure
default options to get the best recognition possible. This is important because some features such as drag/
drop files and DIFFzilla® do not prompt you for the file encoding.
Each extension may have its own encoding specification. If the extension-specific encoding is set to
Default, then the global setting defined at Tools > Options > Languages > File Extension Manager is
used. Both the extension-specific and global setting are overridden if you previously specified an encoding
in the Open dialog. The encoding used to override default encoding settings is recorded. The setting is
then reused the next time you open the same file. This provides you with per-file encoding support.
If you have non-XML UTF-16 files that have signatures, then try selecting Auto Unicode2 as an
extension-specific or global encoding. Since there is no option for recognizing UTF-8 or UTF-32 files (other
than Auto XML) by looking at the file contents, you will either need to set an extension-specific encoding,
or specify the encoding in the Open dialog the first time you open the file.
Some compilers (such as Visual C++) let you specify the code page in the source file (in fact, more than
one code page can be used in the file). This is not supported, so the assumption is that the file is SBCS/
DBCS active code page data.

Opening Unicode Files
To open a Unicode file, complete the following steps:
1. Use the Open dialog (File > Open).
2. Specify the encoding if necessary.
3. Press Enter.
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Surrogate Support
Unicode data is stored as UTF-8 and not UTF-16. Since the Windows Win32 calls are used to implement
some Unicode features there are some issues. By default, Windows does not support surrogates. You
must use the regedit program to turn on surrogate support.
To turn on surrogate support, run the regedit program and go to the following key location:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\LanguagePack

Set the value for SURROGATE to 0x00000002.
Casing features (uppercase, lowercase, ignore case) do not support surrogates. Windows is used for
casing support and Windows casing features do not support surrogates.

Converting Unicode to UCN
You can convert a selection from Unicode to UCN or vice-versa. SlickEdit® conversion features are
located on the Edit > Other menu. The Unicode to UCN conversion feature is most useful for specifying
Unicode character strings in SBCS/DBCS active code page source files. For example, here are the steps
to store some UCN in a Java source file:
1. Open the Unicode file containing the Unicode characters or create a new Unicode file and enter
the characters you want to convert.
2. Select the Unicode characters you want to convert.
3. Execute the Java/C# (UTF-16 \uHHHH) menu item (Edit > Other > Copy Unicode As).
4. Open the Java source file and paste (Edit > Paste) the UCN data into the file.

Unicode Limitations
The following is a list of Unicode limitations:
•

Bold and italics color-coding is not supported. Support for this will be added in a future version.

•

Tab character operations are not fully supported. Tab display, the Expand tabs to spaces save
option (Tools > Options > File Options > Save), and save with tabs (save +t) only work correctly
if all the characters are below 128. The Expand tabs to spaces load option (Tools > Options >
File Options > Load) is ignored.

•

Column selections do not fully support Unicode. If all the characters are below 128 and the font is
fixed then it works. Support for this will be added in a future version.

•

Word Wrap does not fully support Unicode. If all the characters are below 128 and the font is fixed,
then it works. Support for this will be added in a future version.

•

The Unicode line end character 0x2048 is not supported.

•

Hex editing is not supported. The current character (Composite character) is displayed on the
status line. Also, use the Open dialog with the Binary, SBCS/DBCS mode encoding to view a
Unicode file in hexadecimal.

•

Casing features (uppercase, lowercase, ignore case) do not support surrogates. Windows is relied
upon for casing support, and Windows casing features do not support surrogates. See Surrogate
Support.

•

Vertical line column (Tools > Options > Appearance > General) is not supported.

•

Truncation line length is not supported.

•

Record width on the File Open dialog is not supported.
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•

DDE is not supported. Unicode DDE does not work with Internet Explorer or Netscape®. You can
view files with Unicode data in Internet Explorer; however, this feature will fail if the file name
contains characters not in the active code page.

•

Version control supports files containing Unicode data but does not support file names that contain
characters not in the active code page.

•

Special character display is not supported for Unicode buffers.

•

The grew program does not support Unicode and can only be used on SBCS/DBCS active code
page text.

•

If you load the same source file in Unicode and SBCS/DBCS mode, the Context Tagging®
database will have incorrect seek positions. It is important to use the default load options and to
always load source files in the same encoding so that the Context Tagging seek positions match
the editor seek positions.

•

The install (setup.exe), unionist (uninstall.exe), and update (update.exe) programs are not
Unicode applications so the installation directory must contain characters in the active code page.

Unicode Implementation
Native Unicode and SBCS/DBCS editing modes are supported. When you edit a SBCS/DBCS (active
code page) file such as a .c, .h, or .java file, the data is loaded as SBCS/DBCS data and is not converted
to Unicode. When you edit a Unicode file, such as an XML file, the data is converted to UTF-8 that is one
of the standard formats for supporting Unicode files. There are several advantages to this implementation:
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•

Since almost all source files for programming are stored as SBCS/DBCS, loading these files is
significantly faster. This is very important to our customers who expect superior performance from
SlickEdit®.

•

Unicode editing modes cannot support all the features you were used to when editing SBCS/
DBCS files (see Unicode Limitations).

•

Macros can be written once to support both editing modes. This was very important to us because
we wanted to reduce development time.

•

Since Unicode is stored as UTF-8, only one set of binaries is required. Most products that support
SBCS/DBCS and Unicode (UTF-16), use preprocessing. This requires two sets of binaries.
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Invocation Options
SlickEdit® can be invoked with different options to control certain system settings. The command line
syntax for invoking SlickEdit is as follows:
vs {options} file1 {options} file2
The vs executable is stored in the win subdirectory on Windows and the bin directory on Linux/UNIX/Mac.
On Windows, to invoke SlickEdit, you can simply double-click on the SlickEdit icon created by the install
program. However, the command line syntax for invoking SlickEdit is often useful. For example, you might
want to set up multiple icons that open different SlickEdit projects, or start the editor from a shell prompt.
When SlickEdit is invoked, it concatenates the value of the environment variable VSLICK before the
command line that you specify. This environment variable specifies additional command line arguments to
the editor as if you were typing them in when invoking the editor. See Environment Variables for a list of
variables you can use with SlickEdit.
The table below shows a list of available invocation options.
Invocation Option

Description

+ or -new

Indicates whether a new instance of the editor should be
created or if the existing instance should process the
command line parameters. +new creates a new instance.
Default is -new.

-sc config_path

Specifies the configuration directory. This directory will be
used to find and save configuration files. Sets the
SLICKEDITCONFIG environment variable to config_path.

-supf kbdfile

(UNIX only) Specifies a keyboard file for mapping the
keyboard at the X (modmap) level. Some UNIX systems
have keyboard mappings that need to be modified so that
keys like Backspace and Delete (and sometimes others)
function properly. Use the xmapkeys program to generate
the keyboard file.

-sr restore_path

Specifies the directory containing auto-restore files. Sets the
VSLICKRESTORE environment variable to restore_path.

-si kmax_var_space
max_Nofvars

kmax_var_space specifies the amount of memory in
kilobytes allocated for storing the contents of interpreter
variables (default is 1000 kilobits). max_Nofvars specifies
the maximum number of local, static, and global variables
there may be (default is 10000).

-st state_ksize

Specifies the maximum amount of swappable state file data
in vslick.sta (UNIX: vslick.stu) to be kept in memory, in
kilobytes. -1 specifies no limit. 0 specifies that the editor
preload all state file data. The default is 200 K.

-sm max_file_size

Specifies the maximum amount of buffer text (in megabytes)
that may be edited at one time. Additional memory will
automatically be allocated to allow for the editing of up to 2
GB of files. Choosing this option will provide you with better
performance.
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Invocation Option

Description

-suxft

(Linux only) Disables Xft font support. Use this option only if
you have problems with fonts under Linux and would like to
use non-Xft fonts, like previous versions of SlickEdit. See
note below.

-summ “[x_1 y_1] width_1
height_1,
[x_2 y_2] width_2 height_2”

(UNIX only) Specifies multiple monitor configuration. You
must specify at least two monitors. By default, SlickEdit tries
to automatically detect if you have two monitors. However,
this only works if your monitors have the same width, height,
and y values. In a left-to-right monitor configuration, x and y
are not necessary. The following two examples are
equivalent because the monitors are in a left-to-right
configuration:
•
•

-summ “1024 768,1024 768”
-summ “0 0 1024 768,1024 0 1024 768”

Specifying the -summ option in the previous example would
not be necessary because it would be automatically
detected correctly. However, the following monitor
configurations would not be detected correctly:
•
•
•

-summ “1600 1200,1024 768”
-summ “0 0 1024 768,0 768 1024 768”
-summ “1024 768,1024 768,1024 768”

The above examples represent the following configurations:
left-to-right, 2 monitors; top-to-bottom, 2 monitors; left-toright, 3 monitors.
Note that you can specify this option in the VSLICK
environment variable and set it in your vslick.ini file so
you don’t need to specify this for every invocation. For more
information, see Setting Environment Variables in vslick.ini.
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-sul

Disables the byte-range file locking that SlickEdit normally
performs. Enable this option when receiving an “access
denied” error with remote files.

-x pcode_name

Alternate state file (.sta) or pcode file (.ex).

-m menu_file

Name of menu resource to use for the SlickEdit menu bar.

-p cmdline

Execute command with arguments given and exit. No other
options or file names can be specified after this option since
the rest of the command line is assumed to be the program
name and space-delimited arguments for this option.

-r cmdline

Execute command with arguments given and remain
resident. No other options or file names can be specified
after this option since the rest of the command line is
assumed to be the program name and space-delimited
arguments for this option.
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Invocation Option

Description

file1 file2

Files to edit. File names may contain wildcard characters (*
and ?).

-#command

Execute command on active buffer. For example,
vs test.c -#bottom-of-buffer places the cursor at the end of
test.c. Use double quotes if the command has spaces
(vs test.c “-#goto-col 50“).

+ or -L[C]

Turn on/off load entire file switch. The optional C suffix
specifies counting the number of lines in the file.

+nnn

Load binary file(s) that follow with a record width nnn.

+T [buf_name]

Start a default operating system format temporary buffer
with name buf_name.

+TU [buf_name]

Start a UNIX format temporary buffer with name buf_name.

+TM [buf_name]

Start a Macintosh format temporary buffer with name
buf_name. Classic Mac line endings are a single carriage
return (ASCII 13).

+TD [buf_name]

Start a DOS format temporary buffer with name buf_name.

+ or -E

Turn on/off expand tabs to spaces when loading file. Default
is off.
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Environment Variables
Below is a list of environment variables that can be used within SlickEdit®. Configuration environment
variables are set in vslick.ini.
You can also use the set command to temporarily change one of the configuration environment variables
or any other environment variable. See Using the set Command for more information.
CAUTION Do not set the SLICKEDITCONFIG environment variable in vslick.ini.
SLICKEDITCONFIG determines where the editor looks for vslick.ini. When the editor starts up, it
sets the value of environment variables specified in vslick.ini. For more information, see Setting
Environment Variables in vslick.ini.
Environment Variable

Description

VSLICKRESTORE

Directory to store Auto Restore files.

SLICKEDITCONFIG

Directory where user's local configuration files are stored.
Used in multi-user environments. Defaults to:
•

(Windows) .../My Documents/My SlickEdit

•

(Linux, UNIX, Mac) $HOME/.slickedit/

Config/Editor_Version/
editor_version/

Note that VSLICKCONFIG and VSLICKCLASSICCONFIG
are no longer supported. VSLICKCONFIG has been
replaced with a new variable, SLICKEDITCONFIG.
VSLICK

Specifies additional command line arguments to editor as if
you were typing them in when invoking the editor. See also
Invocation Options.

VSLICKPATH

One or more directories separated with a semicolon (;) (or a
colon [:] on UNIX) where batch macros or executable files are
searched.

VSLICKMACROS

One or more directories separated with a semicolon (;) (or a
colon [:] on UNIX) that contain macro files (*.e). VSLICKPATH
must also contain the directories listed here.

VSLICKBIN

One or more directories separated with a semicolon (;) (or a
colon [:] on UNIX) that contain binary files. VSLICKPATH must
also contain the directories listed here.

VSLICKBITMAPS

One or more directories separated with a semicolon (;) (or a
colon [:] on UNIX) that contain bitmap files (*.bmp).
VSLICKPATH must also contain the directories listed here.
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Environment Variable

Description

VSLICKMISC

One or more directories separated with a semicolon (;) (or a
colon [:] on UNIX) that contain miscellaneous files including
*.vlx, *.slk, *.api, *.idx, vslick.sta (UNIX:
vslick.stu), *.hlp, scommon.lst, main.dct, *.pif, *.ini
(except for vslick.ini), and *.lst. VSLICKPATH must also
contain the directories listed here.

VSLICKALIAS

One or more file names separated with a semicolon (;) (or a
colon [:] on UNIX) that contain alias definitions.

VSLICKTAGS

Specifies global tag files. One or more file names separated
with a semicolon (;) (or a colon [:] on UNIX) that contain tags.
Do not put this environment variable in vslick.ini.

VSLICKBACKUP

Directory to place backup files. Affects +D (default) and -D
backup configurations only.

VSLICKSAVE

Allows save options to be specified per drive.

VSLICKLOAD

Allows load options to be specified per drive.

VSLICK_XIM

Set this to VSLICK_XIM=scim to activate the Smart Common
Input Method (SCIM) editor. XMODIFIERS
(XMODIFIERS=@scim) is set by your operating system and
you must enable SCIM support for this option to have any
effect. (This may cause keyboard input instability.)

VSLICKXTERM

(UNIX only) Allows you to specify the default xterm program
and arguments used by the dos command and shell function.
The complete path to the xterm program must be specified.
You may not specify the -e option in the command string. For
example, setting VSLICKXTERM to:
/usr/X11/bin/xterm -geometry 80x40
will create xterm windows with a width of 80 characters and a
height of 40 characters.

VSUSER

The License Manager handles system crashes better if each
user sets the VSUSER environment variable to a unique
name.

VST

Specifies additional command line arguments to the macro
compiler as if you typed them in when invoking the compiler.

VSLICKXNOBLINK

Suppresses the blinking cursor.

VSLICKXNOPLUSNEWMSG

Suppresses a message when starting a second instance of
SlickEdit.

Setting Environment Variables in vslick.ini
Place configuration environment settings in the file vslick.ini. This file is located in the following default
directory based on your platform (if it does not exist, it can be created manually):
•
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Windows: .../My Documents/My SlickEdit Config/Editor_Version/
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•

Linux, UNIX, Mac: $HOME/.slickedit/editor_version/

Below is text from a sample vslick.ini file with an environment section.
[Environment]
VSLICKPATH=c:\vslick\win;c:\vslick\macros;c:\vslick\bitmaps;c:\vmacros
VSLICKALIAS=c:\vmacros\alias.slk
VSLICKINCLUDE=c:\vslick\macros;c:\vmacros
VSLICKLOAD=a: +l b: +l
VSLICKSAVE=a: +o b: +o
MYPROJECTVERSION=c:\myprog4.2

When the editor starts, the following environment variables are created by the editor:
•

VSDRIVE - Drive letter followed by a colon (:) where editor executable resides.

•

VSDIR - Directory of editor executable with a trailing backslash (UNIX: slash).

Environment variables can be embedded in any line within a section by placing % characters around the
environment variable.

Using the set Command
Change or view the environment while running through the set command. The operation of the built-in set
command is almost identical to the DOS SET command. Use the set command to temporarily change one
of the configuration environment variables or any other environment variable. For a complete listing of
configuration environment variables, see Environment Variables. The syntax of the set command is:
set [envvar_name [=value]]
When you invoke the set command with no parameters, a new buffer is created and the current
environment variable settings are inserted. The current value of an individual environment variable may be
retrieved by executing the set command followed by the name of the environment variable. Specify the
name of the environment variable followed by an equal sign and the new value will replace the value of an
existing environment variable or assign a value to a new environment variable.
To remove an environment variable, specify the name of the environment variable followed by an equal
sign, but omit the value parameter (ex. set classpath=). The DOS command shell removes environment
variables in this way also.
The following steps are a convenient way to change the PATH environment variable:
1. Press Esc to toggle the cursor to the command line.
2. Type set path and press Enter. This will place the current value of the PATH variable on the
command line.
3. Edit the current value and press Enter.
You can use the above steps to change the value of any other environment variable by specifying a
different environment variable name in the second step. The set command supports completion on the
environment variable name. Typing set ? on the command line will give you a selection list of all of the
environment variable names.
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Configuration Variables
SlickEdit® has many behaviors that are controlled through properties not exposed in the options dialogs.
They are set through global configuration macro variables in Slick-C®, using the set_var command. The
most commonly used of these variables are listed in the table below.

Viewing Configuration Variables
To view the complete list of configuration variables, bring up the SlickEdit® command line and type
set_var def-? (note the hyphen). The completion list will provide the full list of available variables. Use the
Help system to look up information on a variable by typing the name of the variable into the Index search
field. You can also see a list of variables in the Help under Macro Functions by Category >
Configuration Variables.
Alternatively, you can use the Symbols Tool Window to find where the variable is defined in the Slick-C®
code. Expand the Slick-C folder and then expand the Global Variables folder. If Slick-C hasn't already
been tagged, type fp into the SlickEdit command line. This is an abbreviation of the find_proc command,
which will trigger tagging if it hasn't already been done.

Setting/Changing Configuration Variables
There are two ways to set/change these macro variables:
•

From the SlickEdit® menu, click Macro > Set Macro Variable (or use the gui_set_var command)
and enter the macro variable in the Variable field. The current value of the variable will be shown
in the Value text box. Click Edit to edit this variable, then click OK to accept the change.

•

From the SlickEdit command line, invoke the set_var command with the macro variable name (for
example, set_var def_auto_linecomment), then press Enter to view the current value. You can
edit this value, then press Enter to accept the change.

See Programmable Macros for more information on loading macros and setting variables.

Table of Configuration Variables
The table below provides a list of the most commonly used configuration variables.
Configuration Variable

Description

def_auto_linecomment

Change to 0 to turn off automatic line comment insertion.

def_binary_ext

This variable is used by the editflst.e macro for the
Brief emulation. When the editflst.e macro is loaded,
the space-delimited extensions listed by this variable are
filtered out by the edit command's completion. The default
is .ex .obj .exe .lib.
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Configuration Variable
def_buflist

Description
Change this variable to find the initial file in Buffer List. The
default is 3. This macro variable determines how the
list_buffers commands displays the buffer list. By default,
the buffer list is sorted and path information is in a
separate column to the right of the name. This macro
variable is composed with the following flags:
•
•

SORT_BUFLIST_FLAG - 1
SEPARATE_PATH_FLAG - 2

Add the flags together to select a configuration. Leaving
out a flag removes the features. If the buffer list is not
sorted, the list will be in the order of the buffer ring.
If you set this variable to 1, it will show the full path, which
you can order according to path. The default (3) will show
an alphabetical list of the files in the left column and the
directories in the right column.
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def_ctags_flags

This variable is a safeguard against parsing past the end
of a proc when the braces mismatch. To have SlickEdit®
recognize the second dd, set the value of this variable to
10.

def_debug_logging

If you change this value to 1, then run the integrated
debugger and let it time out, a vs.log file will be created in
your config directory.

def_deselect_copy

Set to 1 in Brief emulation to deselect after a copy.

def_do_block_mode_key

Set this variable’s value equal to 0 to stop SlickEdit from
inserting characters on every line of a block selection.

def_error_re2

Edit this variable to change from the SlickEdit regular
expression used for compile/build errors.

def_fast_auto_readonly

When set to 1, this option speeds up the Auto read only
feature by only checking the attribute on disk (not opening
every file). See Load File Options for more information.

def_filelist_show_dotfiles

Controls the global Show files beginning with a dot
option (Tools > Options > Appearance > General). On
Windows, the default value of this variable is 1; change to
0 to view Dot files. On UNIX platforms, the default value is
0; change to 1 to hide Dot files. (Dot files are files with
names beginning with a dot character.)

def_from_cursor

Default is 0. If non-zero, the commands upcase_word,
lowcase_word, and cap_word will start case change
from the cursor position instead of the beginning of the
current word.
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Configuration Variable

Description

def_linewrap

Default is set to 1. If you are at the end of a line that has
whitespace only on the line below it (spaces or tabs) and
you press Delete, this will bring the whitespace below it up
to the end of the line that you are on. When the value is set
to 0, if you press Delete while at the end of a line that has
whitespace only on the line below it (spaces or tabs), the
whitespace is removed entirely–acting as a line delete.

def_linux1_shell

To use an alternate shell, set this variable to the shell that
you want to run (for example, /bin/bash -i). This will cause
the editor to use your process shell.

def_max_filehist

Increases the number of files displayed in the file history of
the File menu. Enter the number of files you want to see in
the history.

def_max_mffind_output

This variable is set for performance reasons. You can
increase the amount of information displayed in the Output
tool window during a multi-file search by changing this to
your desired setting.

def_max_workspace_hist

Increases the length of the Workspace history list in the
Project menu. Enter the number of files you want to see in
the history.

def_modal_paste

Default is 0. If non-zero, commands that insert a BLOCKtype clipboard will overwrite the destination text if the
cursor is in Replace mode.

def_plusminus_blocks

When the value is set to 1, the plusminus command will
try to find code blocks to expand or collapse if the cursor is
on a line that does not have a Plus or Minus bitmap on it.
The default is 1.

def_preplace

Default is 1. If the value is set to 0, the save command will
NOT prompt you if you are inadvertently overwriting a file.
For example, if you invoke the command save xyz, and an
xyz file already exists, and xyz is not the name of the
current buffer, you are prompted by default whether you
wish to overwrite the file.

def_rwprompt

Default is 1. Change this to 0 to suppress the pop-up that
asks: Do you want to update the read-only attribute of the

file on disk?
def_save_macro

Default is 1. Set this variable to 0 if you do not want to be
prompted with the Save Macro dialog box after ending
macro recording.

def_shift_updown_line_select

Set this value to 1 for Shift+Up or Shift+Down to select
the current line.
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Configuration Variable
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Description

def_show_makefile_target_menu

This variable can be set to decrease the time that it takes
for menus to open. Set to 0 to disable all makefile
submenus (such as the Build menu and the Projects tool
window). Set to 1 to enable all makefile submenus (this is
the default). Set to 2 to enable makefile submenus only in
the Projects tool window (the Build menu makefile targets
are disabled).

def_switchbuf_cd

Set this variable equal to 1 to change the current working
directory to the file that currently has focus in the editor.
This variable is on by default in the GNU Emacs
emulation, and off in all other emulations.

def_top_bottom_push_bookmark

Set this variable to 1 to push a bookmark whenever you
jump to the top or bottom of the buffer. Note that even
when this variable is set, no bookmarks are pushed when
using the current buffer as a build window (.process
buffer). The default value is 0.

def_undo_with_cursor

Set this value to 1 to enable the undo of each cursor
movement.

def_update_context_max_file_size

This variable increases the array size in bytes of a file that
is too large. The default size of files that can be processed
by Context Tagging® is 4 MB. The size can be lowered by
changing this variable and setting it to equal the size that
you want (in bytes).

def_vc_advanced_options

Set to this variable to 0 to remove advanced options that
decrease performance when using ClearCase version
control.

def_vtg_tornado

Set this variable value to 0 to prevent Context Tagging of
Tornado files.

def_xml_no_schema_list

To prevent SlickEdit from accessing the Internet to validate
and get color coding information from DTDs, add your
XML extension to this variable. Set the value to a list of
space-delimited extensions that you want excluded for
actual schema validation. For example: .xml .xsl .xsd.
This will prevent SlickEdit from attempting to connect to
the Internet for these extensions.
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Configuration Directories and Files
User Configuration Directory
Your SlickEdit® configuration directory contains configuration files representing the changes you have
made through setting editor options, and it preserves the state of SlickEdit by using the state file,
vslick.sta.
You should make periodic backups of your SlickEdit configuration directory. If you experience a problem in
the editor, you can often solve it by using a saved config directory.
Configuration changes are saved when you exit the editor. Note that SlickEdit cannot save configuration
changes when another instance is running. If you attempt to close an instance that contains configuration
changes, while another instance is running, a Save failed message is displayed, then a prompt asks
whether or not to exit anyway.

Configuration Directory Location
By default, the user configuration directory is located in My Documents/My SlickEdit Config on
Windows, and $HOME/.slickedit on UNIX, Linux, and Mac. SlickEdit® creates a versioned config
subdirectory for each version of SlickEdit you run.
You can view the path to the config directory by clicking Help > About SlickEdit. When SlickEdit displays
the config directory, it includes the versioned subdirectory. For example: C:\Documents and
Settings\SlickEditUser\My Documents\My SlickEdit Config\13.0.0\.
If you want to use a different directory for your config files, set the SLICKEDITCONFIG environment
variable (see Environment Variables), or specify the location by using the -sc invocation option on the
command line (see Invocation Options). In both cases, SlickEdit will create a versioned subdirectory below
the specified directory.

Resetting the Configuration Directory
For troubleshooting purposes, it is sometimes helpful to reset the configuration directory to the defaults.
SlickEdit Product Support may also ask you to use a default configuration to help debug problems. To
reset to the default configuration:
1. Exit any instances of SlickEdit® that are running.
2. Make a backup of the user config directory and store the backup in a safe location.
3. Delete the contents of the versioned config directory (i.e. 13.0.0) but NOT the directory itself.
4. Start SlickEdit.
After completing these steps, SlickEdit opens with the default configuration settings. Note that you will be
prompted for all of the initial setup information just as if you were running SlickEdit for the first time (see
Running SlickEdit® for the First Time).
NOTE If, instead of deleting the contents of the directory, you delete the directory itself, SlickEdit will
attempt to migrate your settings from a previous version.
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Table of User Configuration Files
The table below provides a list of the user configuration files.
User Config File

772

Description

*.als

A text file that contains user-defined language-specific aliases.

alias.slk

A text file that contains user-defined global aliases (directory
aliases).

ftp.ini
(UNIX: uftp.ini)

A text file that contains user-defined FTP configurations.

project.vpe
(UNIX: uproject.vpe)

A text file that contains user-defined language-specific
projects.

ubox.ini

A text file that contains user-defined box and line comment
styles.

uformat.ini

A text file that contains user-defined beautifier schemes.

uprint.ini

A text file that contains user-defined printing schemes.

uscheme.ini

A text file that contains user-defined color schemes.

user.vlx

A text file that contains color coding changes (keywords, etc.).
This file is updated when you close the Color Coding dialog
box.

usercpp.h

A text file that contains defines (default preprocessing) for
Context Tagging® of C++ and C code.

uservc.slk

A text file that contains user-defined version control systems.

usrprjtemplates.vpt

A text file that contains user-defined project packages.

vrestore.slk

A text file that contains auto-restore information. The
workspace files also contain auto-restore information, but only
for the files/windows previously open.

vslick.ini

A text file that contains a few miscellaneous options. The userconfigured backup directory is stored here. In addition, some
customizable environment variables for path searching for
macros, bitmaps, and binary files are stored here as well.

vslick.sta
(UNIX: vslick.stu)

A binary file that contains dialog boxes, menus, macro pcode,
key bindings, and all other configuration data not stored in one
of the other configuration files. Both user and system
configuration information is stored here.

vusrdefs.e
(UNIX: vunxdefs.e)

A Slick-C® text file that contains the emulation setting, key
bindings, color settings, language setup information, and some
other miscellaneous options.

vusrobjs.e
(UNIX: vunxobjs.e)

A text file that contains user-defined dialog boxes and menus
in Slick-C syntax.
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User Config File
vusrs*.e
(UNIX: vunxs*.e)

Description
A text file that contains system modified dialog boxes and
menus. These changes are NOT automatically transferred
unless the version encoding matches. For example,
vusrs10e.e.

System Configuration Files
System configuration files are located in the SlickEdit® installation directory.
Typically, these files are only modified by SlickEdit Inc. or OEM customers. OEM customers might want to
modify one of these files to ship a customized version of SlickEdit.

Table of System Configuration Files
The table below provides a list of the system configuration files.
System Config File

Description

alias.slk

A text file that contains default global aliases (for example,
directory aliases).

box.ini

A text file that contains default box and line comment styles.
This file is NOT modified by the dialogs and is not preserved
when a new editor is installed.

format.ini

A text file that contains default beautifier schemes.

print.ini

A text file that contains default printing schemes. This file is
NOT modified by the dialogs and is not preserved when a new
editor is installed.

prjtemplates.vpt

A text file that contains default project packages. This file is
NOT modified by the dialogs and is not preserved when a new
editor is installed.

syscpp.h
(UNIX: usyscpp.h)

A text file that contains system-defined default preprocessing
for Context Tagging® of C++ and C code.

vcsystem.slk

A text file that contains default version control systems. This
file is NOT modified by the dialogs and is not preserved when
a new editor is installed.

(UNIX: uvcsys.slk)
vslick.ini

A text file that contains a few miscellaneous options. Some
customizable environment variables for path searching for
macros, bitmaps, and binary files are stored here as well. This
file is NOT modified by the dialogs and is not preserved when
a new editor is installed.

vslick.sta
(UNIX: vslick.stu)

A binary file that contains default dialog boxes, menus, macro
pcode, key bindings, and all other configuration data not stored
in one of the other configuration files.

vslick.vlx

A text file that contains default color coding lexer definitions.
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System Config File
vsscheme.ini

774

Description
A text file that contains default color schemes. This file is NOT
modified by the dialogs and is not preserved when a new
editor is installed.
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File Search Order
Search Order for Configuration Files
Several files are automatically searched for, either immediately when the editor is invoked or during the
course of operation. The search order for configuration files such as vslick.ini, vslick.sta, and
vrestore.slk is:
1. Configuration directory.
2. Current directory.
3. Paths specified in VSLICKPATH environment variable.
4. Paths specified in PATH environment variable.

Search Order for Executable Files
The search order for executable files, batch macro programs, and miscellaneous files is:
1. Current directory.
2. Configuration directory.
3. Paths specified in VSLICKPATH environment variable.
4. Paths specified in PATH environment variable.
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Advanced Help Configuration
This section outlines the ways that alternative and multiple Help file access can be configured.

F1 Index Help
F1 Help, also known as Word Help or SDK Help, searches external Help files for information about a
symbol. For C++ compiler packages, this includes help on the Windows API, Standard C library, and
Microsoft C Foundation Classes (if you have Microsoft Visual C++).
To use F1 Help, first configure the Help files to be used. You can also configure access to multiple Help
files (such as MSDN Help). See Configuring Help Files.
After configuration, to search the Help files for the keyword at the cursor, use one of the following methods:
•

Press F1

•

Or, from the main menu, click Help > F1 Index Help

•

Or, on the SlickEdit command line, use the help_index command

•

Or, in any emulation, click the Question Mark button (

) located on the SlickEdit toolbar.

This will invoke the Help Index dialog box which scans a help .idx file for Help files that contain a prefix
match or exact match of the Help keyword specified. You can specify other keywords by directly typing
them into the Help Keyword field on this dialog.

UNIX, Linux, and Mac OS X F1 Help
UNIX, Linux, and Mac OS X users can get man page Help on the word at the cursor by pressing F1
(executes the wh command). When you are editing a Slick-C® macro, pressing F1 brings up macro
language Help for the word at the cursor. You will find this especially useful for getting help on macro
source generated during macro recordings. F1 works for the default CUA emulation and most other
emulations as well.

Help Index Options
The options on the Help Index dialog are described in the topic Help Index Dialog.

Configuring Help Files
The Help system uses Help files to determine the Help information that is displayed. To add or remove
Help files from SlickEdit®, from the main menu click Tools > Options > Help Options > F1 Index File.
These options let you add an IDX file, which is typically used for providing Word Help on multiple Help files
that may have duplicate Help index entries. If you want your IDX file to be used when you press Ctrl+F1
(wh command), make sure the Word help filename(s) box on the General Help options screen (Tools >
Options > Help Options > General) specifies this file name.

Building the Help Index File vslick.idx
1. From the main menu, click Tools > Options > Help Options > F1 Index File.
2. Click Scan to automatically add Help files (.hlp) on the PATH. This should also find Microsoft
Visual C++, C++ Builder, and Delphi Help files.
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3. If scanning did not pick up some Help files you want, add the other Help directories manually to the
Help file path text box. Click Scan again.
4. Click OK to build the vslick.idx file.
Usually, you only need one Help index file for all the compiler packages. However, you may prefer to
separate the Help files into groups that you can access on different keys.

Changing the Default Word Help File(s)
To change the default Word Help file name(s) for Ctrl+F1 and Ctrl+F2 (wh and wh2 commands), complete
the following steps:
1. To set the Word Help file name, from the main menu, click Tools > Options > Help Options >
General.
2. In the Word help filename(s) box, specify the Help files for the wh command (Ctrl+F1), each
separated with a plus sign. You can only specify one IDX or MVB file per command.
3. Use a semicolon to indicate the start of the Help files for the wh2 command (Ctrl+F2) and specify
its Help files separated with a plus sign.
4. You can use another semicolon to indicate the start of the Help files for the wh3 command;
however, this command is not bound to a key.
Help files have the extension .mvb, .hlp, or .idx. Do not use a plus sign to specify more than one IDX or
MVB file. For example:
•

CtrlF1a.hlp + CtrlF1b.hlp; CtrlF2.hlp

•

vslick.idx; win31wh.hlp+mscxx.hlp+errors.hlp+vslick.hlp

•

CtrlF1.idx; CtrlF2.idx

•

vslick.idx; c:\msdev\help\vcbks40.mvb

Environment variables may be embedded in the Word Help file name(s) string by the following notation:
%(envvar-name)

Configuring F1 MSDN Help
You can configure F1 Help to display information from Microsoft’s MSDN Help system when searching for
help in a Microsoft solution or project. Any MSDN library that is installed with Visual Studio 2003 and later
installs this Help viewer. To set this configuration, from the main menu, click Tools > Options > Help
Options > F1 MSDN Help, then select Use MSDN help for F1 help to enable the feature. Installed
Collections is a list of the Help collections that are installed on your computer. By default, Help searches
the collections with the word “combined” in the name, first. It searches in the index list as well as the
keywords.
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VLX File and Color Coding
For more basic information about using Color Coding, see Color Coding.
To modify the color coding for VLX files, use one of the following methods:
•
•
•

Use the language-specific Color Coding options screen (see Language-Specific Color Coding
Options).
Modify the vslick.vlx file.
Create a new VLX file.

The vslick.vlx file defines language-specific coloring support for the following languages:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Ada
Assembler
AWK
C
C++
CFScript
CICS
COBOL
dBASE
Delphi
Fortran
HTML
Java
Modula-2
Pascal
Perl
Python
REXX
Slick-C®
VHDL
Visual Basic .NET

Modifying the VLX File to Change a Color Definition
To modify an existing language-specific coloring definition, complete the following steps:
1. Open vslick.vlx for editing.
2. Search for one of the section names: CPP, Java, Delphi, Pascal, AWK, REXX, Perl, HTML,
Modula-2, AWK, COBOL, Python, CICS, Fortran, Visual Basic .NET, Ada, or Slick-C®.
3. Modify the definition. See below for information on the syntax of definitions.
4. Invoke the cload command from the command line. If the current buffer has a .vlx extension, it
will be loaded. Otherwise you will be prompted to specify a file name. Specify vslick.vlx
including path as the file name.

Creating a Lexer Name and a New VLX File
To create a new lexer name (and thus a new section in the VLX file), first complete all of the preceding
steps under Modifying the VLX File to Change a Color Definition, then complete the steps below.
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1. From the main menu, click Tools > Options > Languages, expand your language category and
language, then select General.
2. If this lexer definition is for a new extension, create the extension with the New button. Otherwise,
choose the appropriate extension.
3. Set the Lexer Name for the new lexer definition you created.
4. Turn on the Language Specific check box.
5. Click Update to commit the changes.
Files with a .vlx extension are text files that have a syntax similar to a .ini file. If the first non-blank
character in a line is a semicolon, the line is considered a comment. Each definition of a language starts
with a section name (the lexer name) enclosed in square brackets. Within each section are statements that
look like name=value.
The table below shows the statements that can be used.
Statement

Description

case-sensitive= [Y | N]

Defines the case sensitivity for the language. This
statement must be the first or second statement
within the section.

idchars=start_id_chars after_id_chars

Defines the characters that are the start of a valid
identifier and additional valid characters that may
follow. This statement must be the first or second
statement within the section. You may use a dash
(-) character to specify a range, for example, A-Z
specifies uppercase letters. To specify a dash or
backslash (\) character as a valid word character,
place a backslash before the character.

styles= style

Defines zero or more styles. See Table of style
Values below for a list of available styles.
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Statement

Description

mlcomment= start_symbol end_symbol
[nesting] [followedby idchars] [colorname]

Defines a multi-line comment. start_symbol and
end_symbol define strings which start and end
the comment. Specify nesting if the lexer should
look for another occurrence of start_symbol
when looking for the end comment symbol. The
followedby idchars is used to require certain
characters to follow start_symbol. You can use a
dash (-) character to specify a range, such as A-Z,
which specifies uppercase letters. To specify a
dash (-) or backslash (\) character as a valid word
character, place a backslash before the character.
followedby is ignored when the html style is
specified. Currently, start_symbol and
end_symbol may not be valid identifiers. No more
than four multi-line comments may be defined.
colorname can be used to indicate that a different
color such as keyword color be used instead of
comment color when a match is found.
colorname may be keywordcolor, numbercolor,
stringcolor, commentcolor, ppkeywordcolor,
linenumcolor, symbol1color, symbol2color,
symbol3color, or symbol4color.

mlcomment= start_symbol start_col
[checkfirst|leading] end_symbol [lastchar]

Defines a multi-line comment. This construct was
designed to handle comments for the ATLAS
language. start_symbol and end_symbol define
strings which start and end the comment.
start_symbol is only considered the start of a
comment if it appears in column start_col.
checkfirst specifies that the lexer should check if
the line is a comment before determining the color
coding of symbols in the line. When the checkfirst
option is specified, start_symbol is limited to one
character in length. leading specifies that symbol
is considered a line comment only if it appears as
the first non-blank character. Space or tab
characters are considered blanks. Currently,
end_symbol may not be a valid identifier.
lastchar specifies that end_symbol must appear
as the last character on a line to terminate the
comment. No more than two multi-line comments
may be defined.

mlckeywords= [keyword ] [keyword ] ...

Defines keywords for the last mlcomment
statement. When one of these keywords follows
the start_symbol defined for the last mlcomment
statement, the keyword color is used to color the
comment instead of comment color. Keywords do
not have to be valid identifiers. This statement is
useful for tag languages like HTML. See the
HTML definition in the file vslick.vlx for an
example.
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Statement

Description

keywordattrs= [mlckeyword] [attribute ]
[attribute ] ...

Defines attributes for the mlckeyword specified
which belongs to the last mlcomment statement.
Currently this statement only supports HTML
syntax attributes and requires that the HTML style
be specified. For example,
keywordattrs=SCRIPT LANGUAGE SRC

linecomment= [symbol ] [col | col+ |
start_col - end_col] [checkfirst|leading]

Defines a line comment. symbol defines the
character(s) which start this line comment. If no
column limits are specified, the remainder of the
line is considered a comment regardless of where
symbol appears. A plus sign (+) after a column
specifies an unlimited end_col. checkfirst
specifies that the lexer should check if the line is a
comment before determining the color coding of
symbols in the line. When the checkfirst option is
specified, symbol is limited to one character in
length. If symbol is not specified, all characters
will be ignored at or after the column specified (ex.
linecoment=73+). This is useful for Fortran which
requires that all characters at or after column 73
be ignored. leading specifies that symbol is
considered a line comment only if it appears as
the first non-blank character. Space or tab
characters are considered blanks.

keywords= [keyword ] [keyword ] ...

Defines words that should be displayed in
keyword color. Keywords do not have to be valid
identifiers.

cskeywords= [keyword ] [keyword ] ...

(Case-sensitive keywords) Defines words that
should be displayed in keyword color only if found
in the case specified. This statement should only
be used for languages such as HTML which are
case insensitive except for a few words. For other
languages, use the case-sensitive and
keywords statements. Keywords do not have to
be valid identifiers.

ppkeywords= [keyword ] [keyword ] ...

Defines words that should be displayed in
preprocessor color. The first character of a
preprocessor keyword must not be a valid
identifier. Preprocessing keywords must appear as
the first non-blank symbol in the line.

symbol1= [ keyword ] [ keyword ] ...

Defines words that should be displayed in
symbol1 color. Keywords do not have to be valid
identifiers.

symbol2= [keyword ] [keyword ] ...

Defines words that should be displayed in
symbol2 color. Keywords do not have to be valid
identifiers.
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Statement

Description

symbol3= [keyword ] [keyword ] ...

Defines words that should be displayed in
symbol3 color. Keywords do not have to be valid
identifiers.

symbol4= [keyword ] [keyword ] ...

Defines words that should be displayed in
symbol4 color. Keywords do not have to be valid
identifiers.

Table of style Values
The table below describes the style values that can be used:
Value of style

Description

linenum

Line numbers may be found as the first non-blank
symbol of a line like BASIC.

dqbackslash

Color double-quoted strings. Characters following
a backslash in a double-quoted string are included
in the string (like C).

dqbackslashml

Color double-quoted strings. If a double-quoted
string ends in a backslash, it continues the string
to the next line (like C).

dqmultiline

Color double-quoted strings. String may span
multiple lines.

dqdoubles

Color double-quoted strings. Two double quotes
represent one double quote.

dqterminate

Do not color-code a double-quoted string until the
string is terminated. This style does not support
dqmultiline or dqbackslashml.

dqlen1

Color double-quoted strings. Double-quoted
strings contain exactly one character.

sqbackslash

Color single-quoted strings. Characters following a
backslash in a single-quoted string are included in
the string (like C).

sqbackslashml

Color single-quoted strings. If a double-quoted
string ends in a backslash, it continues the string
to the next line.

sqmultiline

Color single-quoted strings. String may span
multiple lines.

sqdoubles

Color single-quoted strings. Two consecutive
single quotes represent one single quote (like
Pascal).
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Description

sqterminate

Do not color-code a single-quoted string until the
string is terminated. This style does not support
sqmultiline or sqbackslashml.

sqlen1

Single-quoted strings contain exactly one
character (like Ada).

amphhex

Hexadecimal numbers are of the form &Hdddd
(like BASIC).

ampooct

Octal numbers are of the form &Odddd (like
BASIC).

hexh

Hexadecimal numbers are of the form ddddH (like
Intel Assembler).

octo

Octal numbers are of the form ddddO (like Intel
Assembler).

octq

Octal numbers are of the form ddddQ (like Intel
Assembler).

poundbase

Based numbers are of the form
#base#number#exponent (like Ada).

underlineint

Numbers may have underlines between the
numbers (like Ada).

xhex

Hexadecimal numbers are of the form 0xhhhh
(like C).

nonumbers

Do not color-code numbers. This style is useful for
tag languages like HTML. Using this style with
other number color-coding styles will produce
unpredictable results.

rexxhex

Hexadecimal strings are followed by an upper or
lowercase letter X. For example, '414141'X or
414141X are REXX-style hexadecimal strings that
are both equivalent to the string AAA.

packageimport

Language has Java syntax package and import
statement where non-quoted file name follows
package and import keyword.

idparenfunction

An identifier followed by an open parenthesis
indicates a function (like C++ and Java).

html

Enables HTML syntax embedded languages and
attribute coloring.

backslashescapechars

Backslash escapes the character that follows.
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Value of style

Description

heredocument

Enables support for Here documents. Note that if
you prefix the terminator with one of the lexer
names, you will get embedded language colorcoding.

perl

Adds support for Perl format statement and some
other Perl-specific changes.

tcl

Special support for TCL language color-coding.

bquote

Perl- and Linux Shell-style backquote (subshell).

model204

Special support for Model 204 language.

cics

Special support for CICS embedded in COBOL.

python

Special support for Python.
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Editing the Key Binding Source
If you are creating a new emulation or if you change many key bindings, you might want to edit your key
binding source instead of using the Key Binding Options screen. To create a Slick-C® batch macro
containing your current key bindings, enter the command list_source on the command line. One of the
files generated by this command is vusrdefs.e. It is placed in your configuration directory. If you open this
file (Ctrl+O), the first part of the source code is your key binding, which looks like the following:
defeventtab default_keys
def 'A-a'-'A-z'=
def 'A-F6'=
def 'F10'=
def 'C-A'= select all
def 'C-B'= select_block
def 'C-C'= copy_to_clipboard
def 'C-D'= gui_cd

The default_keys are the key bindings that are active in Fundamental mode. The other event tables
defined by the defeventtab primitive are mode event tables containing key bindings which override the
Fundamental mode key bindings. Make changes to this buffer by adding or modifying the def keyname=
command lines and then save the buffer by pressing Ctrl+S. The valid key names are listed in the Help
system under Event Names. You can also list the key names of the keys through the Help by invoking the
command help Event Names. To run this batch program, type the name vusrdefs without the extension
on the command line. The path is not necessary if it is included in your VSLICKPATH or PATH
environment variable.
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Using the ISPF and XEDIT Emulations
This section describes the features of the ISPF editor emulation and outlines some XEDIT line commands.

ISPF Options
The ISPF Emulation options screen is used to tune various ISPF emulation behaviors. To access these
options, SlickEdit must be in ISPF emulation mode. Then, from the main menu, click Tools > Options,
expand Keyboard, and select ISPF Emulation.

The following settings are available:
•

Prefix area width - The number of characters to display in the prefix area (default is 6). Note that
some line commands require four characters (e.g. BNDS, TABS, COLS, MASK). To completely
remove the prefix area, set the prefix area width to 0.
Only the following line commands are allowed in read-only mode:
Command

Description

ISPF Line Labels

Define a label.

ISPF Line Command BNDS

Insert a column boundary ruler line.

ISPF Line Command COLS

Insert a column ruler line.
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ISPF Line Command First

Expose one or more lines at the beginning of a block of
excluded lines.

ISPF Line Command Last

Expose one or more lines at the beginning of a block of
excluded lines.

ISPF Line Command Show

Expose one or more lines having the leftmost indentation
level in a block of excluded lines.

ISPF Line Command TABS

Displays the tab definition line.

ISPF Line Command Exclude

Specifies one or more lines to be hidden (excluded).

ISPF Line Command Select

Select a block of lines.

•

Enter places cursor in prefix area - When this check box is selected, the Enter key places the
cursor in the prefix area of the next line. When this check box is cleared, the Enter key places the
cursor in column 1 of the next line.

•

Right CTRL = Enter/Send - When this check box is selected, the Enter key places the cursor at
the beginning of the next line, and the Right Ctrl key is used to execute line commands. When this
check box is cleared, the Right Ctrl key acts like a normal control key and the Enter key is used to
execute line commands.

•

Cursor page up/down - When this check box is selected, the display is scrolled up/down until the
line the cursor is on becomes the last/first line displayed, respectively. If the cursor is already on
the top/bottom display line, the display is scrolled one page. When this check box is cleared, page
up/down always scrolls one page.

•

END command saves the file - When this check box is selected, changes to the buffer are saved
automatically when the ispf_end (F3) command is performed. Otherwise, you will be prompted if
you want to save changes before closing the file.

•

XEDIT line commands - When this check box is selected, the prefix area will support XEDIT-style
line commands.

•

Home places cursor on command line - When this check box is selected, the Home key places
the cursor on the command line. By default, this option is off, and the Home key simply moves the
cursor to the beginning of the line.

More ISPF-related options are available on the language-specific General options screen (Tools >
Options > Languages > [LanguageCategory] > [Language] > General). These options include Auto
CAPS mode and editing of boundaries and the truncation column. The Bounds setting is unique to ISPF.
It controls column bounds for specific ISPF commands that operate on column ranges. See General
Language-Specific Options for more information.

ISPF Primary Commands
The following table of standard ISPF primary commands are supported in the ISPF emulation mode.
Primary commands are entered by placing the cursor on the command line (see ISPF Command Line and
Text Box Editing for details about command line editing features).
To place the cursor on the command line, either press the Esc key, click on the message line, or use
ispf_retrieve (F12). If configured to do so, the Home key will also place the cursor on the command line.
Once on the command line, you may use the cursor Up/Down keys to retrieve the previous/last command
entered, respectively.

790

SlickEdit® User Guide

USING THE ISPF AND XEDIT EMULATIONS

Though primary commands may be typed at the command line explicitly, for convenience you can simply
type the last part of the command name in the command line and it will automatically be mapped to the
ISPF-specific command. For example, to execute the ISPF reset command, simply type reset at the
command line instead of ispf_reset.
NOTE Some standard built-in commands conflict with ISPF emulation commands. These conflicts
include copy, cut, delete, find, hex, move, and paste. To access the built-in command, you may
be able to use a menu option or consult the Help for that command for specific instructions.
Command

Description

ispf_autosave

Turn on or off prompting to save changes.

ispf_bounds

Set or reset the left and right edit boundaries.

ispf_bnds

Set or reset the left and right edit boundaries

ispf_browse

Browse a data set or member.

ispf_cancel

Closes the current file or PDS member without saving
changes.

ispf_caps

Turn on or off automatic capitalization mode.

ispf_change

Replace one string with another within the current buffer.

ispf_chg

Replace one string with another within the current buffer.

ispf_compare

Compare the file you are editing with another file.

ispf_copy

Insert the contents of a file or PDS member into the buffer.

ispf_create

Create a new file or PDS member containing the contents of
the buffer.

ispf_cut

Cut lines out of the current buffer and place them in the
clipboard.

ispf_delete

Delete lines in the given line range, or the entire buffer.

ispf_edit

This command is identical to the built-in edit command.

ispf_end

Close the current file.

ispf_exclude

Hide (exclude) lines that match the given search string.

ispf_find

Find occurrences of the given search string in the current
buffer.

ispf_flip

Reverse the exclude status of lines.

ispf_hex

Toggle display of the document in Hexadecimal mode.

ispf_hilite

Specify the use of color-coding in the editor.

ispf_locate

Find lines with a specific line prefix.

ispf_move

Move the contents of a file or PDS member into the buffer.

ispf_nonumber

Turn off numbering mode.
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ispf_number

Controls line numbering mode. Unlike ISPF, this command
does affect how lines are inserted.

ispf_paste

Copy lines from the clipboard to the buffer.

ispf_preserve

Controls saving of trailing blanks.

ispf_rchange

Repeat the change requested by the most recent change
command.

ispf_renumber

Immediately update the line numbers in a file.

ispf_replace

Save the contents of the current buffer to an existing file.

ispf_reset

Reset the contents of the line prefix area.

ispf_return

Close the current file.

ispf_rfind

Repeat the last find operation requested.

ispf_save

This command is identical to the built-in save command.

ispf_sort

Sort lines of data in a specified order.

ispf_submit

Submit the contents of the current buffer for batch processing.

ispf_swap

Switch to the next buffer.

ispf_tabs

Define logical tab positions.

ispf_unnumber

Blank out the line numbers in a file.

ispf_undo

This command is identical to the undo command.

ISPF Line Commands
The table below shows ISPF edit line commands that are supported in the ISPF emulation mode.
Enter line commands by typing over the prefix area (on the left-hand side of the editor control) which
contains either ====== or the line number. To place the cursor in the prefix area, click there, or move the
cursor left or backspace until the cursor in is in the prefix area. In addition, Enter will place the cursor in the
prefix area of the next line, unless an insert or text entry command is executed.
Edit line commands operate on either a single line or a block of lines. The commands that operate on
blocks require you to place the command on both the first and last lines of the block.
Line commands are processed using the ispf_do_lc command when you press Enter, Ctrl+Enter or the
Right Control key, depending on your preferences. Several commands or line labels can be entered and
then processed at one time. The ispf_reset command is used to clear the prefix area.
Command
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Description

ISPF Line Labels

Define a label.

ISPF Line Command Shift

Shift data left or right.

ISPF Line Command A

Identify a line after which lines are to be inserted.

ISPF Line Command B

Identify a line before which lines are to be inserted.
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ISPF Line Command BNDS

Insert a column boundary ruler line.

ISPF Line Command Copy S

Specify lines to be copied to another location.

ISPF Line Command COL

Insert a column ruler line.

ISPF Line Command Delete

Delete one or more lines.

ISPF Line Command First

Expose one or more lines at the beginning of a block
of excluded lines.

ISPF Line CommandI

Insert one or more blank data entry lines.

ISPF Line Command Lowercase

Convert all uppercase letter alphabetic characters in
one or more lines to lowercase.

ISPF Line Command Last

Expose one or more lines at the beginning of a block
of excluded lines.

ISPF Line Command Move

Specify lines to be moved to another location.

ISPF Line Command MASK

Display the contents of the mask used with the insert
(I) and text entry (TE) line commands.

ISPF Line Command Make Data

Convert one or more no-save lines to data so that they
may be saved when the buffer is saved.

ISPF Line Command Overlay

Identify one or more lines over which the copy or move
block is to be overlaid.

ISPF Line Command Repeat

Specify lines to be repeated immediately following this
line or block.

ISPF Line Command Show

Expose one or more lines having the left-most
indentation level in a block of excluded lines.

ISPF Line Command TABS

Display the tab definition line.

ISPF Line Command TE

Insert one or more blank lines to allow power typing for
text entry.

ISPF Line Command TF

Reflow paragraphs according to the current column
boundary settings.

ISPF Line Command TJ

Join this line with the next line.

ISPF Line Command TS

Divide a line so that data can be added.

ISPF Line Command Uppercase

Convert all lowercase letter alphabetic characters in
one or more lines to uppercase.

ISPF Line Command Exclude

Specify one or more lines to be hidden (excluded).

ISPF Line Command Select

Select a block of lines.
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ISPF Line Command Documentation
ISPF Line Labels .label
Usage
.label, where label does not start with a z
Remarks
Define a label to be used as a marker to identify the given line. Labels are used to specify a particular line,
such as in the ispf_locate command, or to specify a range of lines for an primary command to operate on.
The following labels are built in to the ISPF emulation:
•

.zfirst - The first line in the buffer (abbreviated .zf).

•

.zlast - The last line in the buffer (abbreviated .zl).

•

.zcsr - The current line the cursor is on (abbreviated .zc).

See Also
ispf_change, ispf_copy, ispf_delete, ispf_exclude, ispf_find, ispf_flip, ispf_locate, ispf_paste,
ispf_reset, ispf_sort

ISPF Shift Lines Left or Right
Usage
•

( [n] - Shift the current line n columns left, default 2

•

(( [n] - Shift the block of lines n columns left, default 2

•

) [n] - Shift the current line n columns right, default 2

•

)) [n] - Shift the block of lines n columns right, default 2

•

< [n] - Data shift the current line n columns left, default 2

•

<< [n] - Data shift the block of lines n columns left, default 2

•

> [n] - Data shift the current line n columns right, default 2

•

>> [n] - Data shift the block of lines n columns right, default 2

Remarks
This set of commands is used for shifting data left or right. The versions using parenthesis shift text
literally, while the other versions attempt to intelligently shift text without disturbing line numbers or
comments. In all cases, the default number of columns that the text is shifted is two.
There are two forms to these commands. The single character forms (, ), <, or > specifies that the line and
the subsequent n-1 lines are to be shifted. The two-character block forms are placed on the first and last
lines of the block to be shifted.
Data is shifted only within the columns defined by the current bounds, or if bounds is turned off, but there is
a truncation column, between column 1 and the truncation column. If the shift operation results in data
moving beyond the right or left margins, it is truncated and there is no warning message.
See Also
ispf_bounds
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ISPF Insert After A
Usage
A [n]
Remarks
Identifies a line after which copied or moved lines are to be inserted n times. You are allowed to specify
multiple A, B, or O line commands to have the same copy or move block inserted in multiple places.
See Also
ispf_copy, ispf_paste, ISPF Line Command B, ISPF Line Command Copy, ISPF Line Command
Move, ISPF Line Command Overlay

ISPF Insert Before B
Usage
B [n]
Remarks
Identifies a line before which copied or moved lines are to be inserted n times. You are allowed to specify
multiple A, B, or O line commands to have the same copy or move block inserted in multiple places.
See Also
ispf_copy, ispf_paste, ISPF Line Command B, ISPF Line Command Copy, ISPF Line Command
Move, ISPF Line Command Overlay

ISPF Insert Bounds Ruler BNDS
Usage
BNDS
Remarks
Insert a column boundary ruler line. After this line is inserted, the < and > marks may be moved in order to
adjust the column boundaries. Note that if you have multiple bounds lines, and you change one, the
subsequent bounds lines will also be changed.
A column boundary line with one < sign indicates a left boundary and no right boundary (unbounded). A
column boundary with one > sign indicates a single column boundary (left and right bounds are same).
See Also
ispf_bounds, ISPF Line Command Shift, ISPF Line Command Overlay

ISPF Copy Lines C and CC for blocks
Usage
•

C [n] - Copy n lines starting with the line with the command.

•

CC - Copy a block of lines, must match another CC.

Remarks
Specify lines to be copied to another location. There are two forms to this command. The first form (C [n])
specifies that the line and the subsequent n-1 lines are to be copied. The second (block) form (CC) is

SlickEdit® User Guide

795

USING THE ISPF AND XEDIT EMULATIONS

placed on the first and last lines of the block to be copied. There can be only one copy block specified.
Furthermore, you can not have both a move block and a copy block specified at the same time.
See Also
ISPF Line Command A, ISPF Line Command B, ISPF Line Command Move, ISPF Line Command
Overlay

ISPF Insert Columns Ruler COLS or SCALE
Usage
COLS
SCALE
Remarks
Insert a column ruler line. The column ruler line is read-only.
See Also
ispf_bounds, ispf_tabs, ISPF Line Command BNDS, ISPF Line Command TABS

ISPF Delete Lines D and DD for blocks
Usage
•

D [n] - Delete n lines starting with the line with the command.

•

DD - Delete a block of lines, must match another DD.

Remarks
Deletes one or more lines. There are two forms to this command. The first form (D [n]) specifies that the
line and the subsequent n-1 lines are to be deleted. The second (block) form (DD) is placed on the first and
last lines of the block to be deleted.
See Also
ispf_delete

ISPF Expose First Lines F and FF
Usage
•

F [n] - Unexclude (expose) the first n lines of an excluded block.

•

FF - Unexclude (expose) an entire excluded block.

Remarks
Expose one or more lines at the beginning of a block of excluded lines. The FF line command exposes the
entire block of lines and is to F[m] where m is the number of lines in the block of excluded lines.
See Also
ispf_exclude, ispf_reset, ISPF Line Command Last, ISPF Line Command Show, ISPF Line
Command Exclude
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ISPF Insert Lines
Usage
I [n]
Remarks
Insert one or more blank data entry lines.
See Also
ispf_enter, ISPF Line Command TE

ISPF Lowercase Lines LC, LCC and LCLC for blocks
Usage
•

LC [n] - Lowercase n lines starting with the line with the command.

•

LCC - Lowercase a block of lines, must match another LCC or LCLC.

•

LCLC - Lowercase a block of lines, must match another LCC or LCLC.

Remarks
Converts all uppercase letter alphabetic characters in one or more lines to lowercase. This command only
operates on text within the edit boundary columns. There are two forms to this command. The first form
(LC [n]) specifies that the line and the subsequent n-1 lines are to be converted. The second (block) form
(LCLC or LCC) is placed on the first and last lines of the block to be converted.
See Also
ispf_caps, ISPF Line Command Uppercase, lowcase, upcase

ISPF Expose Last Lines L and LL
Usage
•

L [n] - Unexclude (expose) the last n lines of an excluded block.

•

LL - Unexclude (expose) an entire excluded block (identical to FF).

Remarks
Expose one or more lines at the end of a block of excluded lines. The LL line command exposes the entire
block of lines and is to L[m] where m is the number of lines in the block of excluded lines.
See Also
ispf_exclude, ispf_reset, ISPF Line Command First, ISPF Line Command Show, ISPF Line
Command Exclude

ISPF Move Lines M and MM for blocks
Usage
•

M [n] - Move n lines starting with the line with the command.

•

MM - Move a block of lines, must match another MM.

Remarks
Specify lines to be moved to another location. There are two forms to this command. The first form (M [n])
specifies that the line and the subsequent n-1 lines are to be moved. The second (block) form (MM) is
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placed on the first and last lines of the block to be moved. There can be only one move block specified.
Furthermore, you cannot have both a move block and a copy block specified at the same time.
See Also
ISPF Line Command A, ISPF Line Command B, ISPF Line Command Copy, ISPF Line Command
Overlay

ISPF Insert Mask Line MASK
Usage
MASK
Remarks
Displays the contents of the mask used with the insert (I) and text entry (TE) line commands. Normally,
when a line is inserted, the line is initially blank. By specifying an insert mask, you can insert a block of
lines with a particular template. The MASK line is editable. Note that if you specify multiple masks in one
file, only the first mask is used.
See Also
ISPF Line Command I, ISPF Line Command TE, ISPF Line Command TS

ISPF Make Data Lines MD, MDD and MDMD for blocks
Usage
•

MD [n] - Make n data lines starting with the line with the command.

•

MDD - Make a block of lines data, must match another MDD or MDMD.

•

MDMD - Make a block of lines data, must match another MDD or MDMD.

Remarks
Converts one or more no-save lines to data so that they may be saved when the buffer is saved. There are
two forms to this command. The first form (MD [n]) specifies that the line and the subsequent n-1 lines are
to be converted. The second (block) form (MDMD or MDD) is placed on the first and last lines of the block
to be converted.
See Also
ISPF Line Commands, ISPF Line Command COLS, ISPF Line Command BNDS, ISPF Line
Command MASK, ISPF Line Command TABS

ISPF Overlay Lines O and OO for blocks
Usage
•

O [n] - Overlay n lines starting with the line with the command.

•

OO - Overlay a block of lines, must match another OO.

Remarks
Identifies one or more lines over which the copy or move block is to be overlaid. Text is only overlaid within
the column boundaries. If the copy or move block has less lines than the overlay, it is repeated until it fills
the entire overlay block.
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There are two forms to this command. The first form (O [n]) specifies that the line and the subsequent n-1
lines are to be overlaid. The second (block) form (OO) is placed on the first and last lines of the block to be
overlaid.
You are allowed to specify multiple A, B, or O line commands to have the same copy or move block
inserted or overlaid in multiple places.
See Also
ispf_copy, ispf_paste, ISPF Line Command A, ISPF Line Command B, ISPF Line Command Copy,
ISPF Line Command Move, ISPF Line Command Overlay

ISPF Repeat Lines
Usage
•

R [n] - Repeat the line with the command n times.

•

RR [n] - Repeat the block n times, must match another RR.

Remarks
Specify lines to be repeated immediately following this line or block. There are two forms to this command.
The first form (R[n]) specifies that the line is to be repeated n times. The second (block) form (RR[n]) is
placed on the first and last lines of the block to be repeated n times.
See Also
ISPF Line Command A, ISPF Line Command B, ISPF Line Command Copy

ISPF Expose Next Level of Code S and SS
Usage
•

S [n] - Unexclude (expose) the first n lines of an excluded block.

•

SS - Unexclude (expose) an entire excluded block.

Remarks
Expose one or more lines having the leftmost indentation level in a block of excluded lines. The SS line
command exposes the entire block of lines and is to S[m] where m is the number of lines in the block of
excluded lines.
See Also
ispf_exclude, ispf_reset, ISPF Line Command First, ISPF Line Command Last, ISPF Line Command
Exclude

ISPF Insert Tabs Ruler TABS or TABL
Usage
TABS
TABL
Remarks
Displays the tab definition line. After this line is inserted, the * marks may be moved in order to adjust the
tab positions. Note that if you have multiple tabs lines, and you change one, the subsequent tabs lines will
also be changed.
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See Also
ispf_tabs, tabs

ISPF Insert Text TE
Usage
TE [n]
Remarks
Inserts one or more blank lines to allow power typing for text entry. This command is identical to the insert
(I) command, except that it switches the mode to wrap lines.
See Also
ispf_enter, ISPF Line Command I, ISPF Line Command MASK

ISPF Insert Lines TF
Usage
TF
Remarks
Reflows paragraphs according to the current column boundary settings.
See Also
reflow_paragraph

ISPF Join Lines TJ
Usage
TJ
Remarks
Join this line with the next line.
See Also
ISPF Line Command TS, join_line

ISPF Split Line TS
Usage
TS
Remarks
Divides a line so that data can be added. The line is split at the column in which the cursor is in when you
press Enter. This command does not support multiple lines.
See Also
ISPF Line Command TJ, split_insert_line
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ISPF Uppercase Lines UC, UCC and UCUC for blocks
Usage
•

UC [n] - Uppercase n lines starting with the line with the command.

•

UCC - Uppercase a block of lines, must match another UCC or UCC.

•

UCUC - Uppercase a block of lines, must match another UCC or UCUC.

Remarks
Converts all lowercase letter alphabetic characters in one or more lines to uppercase. This command only
operates on text within the edit boundary columns. There are two forms to this command. The first form
(UC [n]) specifies that the line and the subsequent n-1 lines are to be converted. The second (block) form
(UCUC or UCC) is placed on the first and last lines of the block to be converted.
See Also
ispf_caps, ISPF Line Command Lowercase, lowcase, upcase

ISPF Exclude Lines X and XX for blocks
Usage
•

X [n] - Exclude n lines starting with the line with the command.

•

XX - Exclude a block of lines, must match another XX.

Remarks
Specifies one or more lines to be hidden (excluded). There are two forms to this command. The first form
(X [n]) specifies that the line and the subsequent n-1 lines are to be excluded. The second (block) form
(XX) is placed on the first and last lines of the block to be excluded.
See Also
ispf_exclude, ispf_reset, ISPF Line Command First, ISPF Line Command Last, ISPF Line Command
Show

ISPF Select Lines Z and ZZ for blocks
Usage
•

Z [n] - Select n lines starting with the line with the command.

•

ZZ - Select a block of lines, must match another ZZ.

Remarks
Select a block of lines. There are two forms to this command. The first form (Z [n]) specifies that the line
and the subsequent n-1 lines are to be selected. The second (block) form (ZZ) is placed on the first and
last lines of the block to be selected.
See Also
ispf_cut, ispf_paste
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XEDIT Line Commands
The following XEDIT line commands are supported and override the like-named ISPF commands when
there is a conflict. XEDIT commands can be enabled using the ISPF Options dialog box (Tools > Options
> ISPF Options).
XEDIT

ISPF

Description

/

R

Repeat the marked line.

F

A

Paste text following line.

A

I

Add (insert) line(s).

P

B

Paste text before line.

L

LC

Make line lowercase.

LL

LCC

Make block lowercase.

U

UC

Make line uppercase.

UU

UCC

Make block uppercase.

Note the following conflicts with standard ISPF edit line commands:
•

F conflicts with unexclude first (F).

•

A conflicts with paste after (A).

•

L conflicts with unexclude last (L).

•

LL conflicts with unexclude block (LL).

ISPF Unsupported Primary Commands
The table below shows ISPF primary commands that are not supported in the ISPF emulation mode. The
unsupported commands fall into two categories. First, some ISPF commands are made obsolete by more
powerful features, such as recovery, profile, and setundo. Second, some commands reflect features that
we chose not to implement for the emulation, such as ISPF macros, PDF statistics, model, and pack.
Unsupported Command
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Description

autolist

Control the automatic printing of data to the ISPF list data set.

builtin

Process a built-in command, even if overloaded by a macro.

define

Define a name as an alias or macro.

imacro

Save the name of an initial macro in the edit profile.

level

Set the modification level number in PDF library statistics.

model

Copy a model into the buffer or defines a model class.

notes

Control whether the MODEL command display notes or not.

nulls

Control null spaces.
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pack

Control whether data is to be stored compressed or not.

profile

Display edit profile.

recovery

Specify edit recovery options.

rmacro

Save a recovery macro in the edit profile.

setundo

Control the UNDO mode.

stats

Generate library statistics.

version

Set the version number in the PDF library statistics.

view

Save as browse command but prompts on save.

The following commands are supported in ISPF emulation mode.
Supported Command

Description

ispf_bottom

Move cursor to the end of the buffer.

ispf_down

Move cursor to next page of text.

ispf_enter

Handle the Enter key or Right Control key in ISPF emulation.

ispf_home

Place the focus on the command line in ISPF emulation.

ispf_retrieve

Does command line retrieval, getting the next command line
from the list.

ispf_retrieve_back

Identical to the ispf_retrieve back command.

ispf_top

Move cursor up to the top of the buffer.

ispf_up

Move cursor up to the previous page of text.

ispf_do_lc

Immediately process all commands found in the line prefix
area.
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Glossary
3-Way Merge
Typically used after two people make a local copy of the same source file and make some modifications
to their local copy. The 3-way merge takes both sets of changes and creates a new source file. A wizard
lets you select the change desired in the output file. The output can be viewed side-by-side or
interleaved.
API
Application Programming Interface. A functional interface that allows an application program written in
a high-level language to use specific data or functions of the operating system or another program. An
API is the set of programming language constructs or statements that can be coded in an application
program to obtain the specific functions and services provided by an underlying operating system or
service program.
Binding
The attachment of a command to a key.
Bookmark stack
An internal list of pushed bookmarks.
Breakpoint
A point designated in the code to break or stop during a debug. View a list of all breakpoints in the Task
view.
Buffer
A file that has been loaded into the application. When a file is loaded, you can safely perform
modifications to the buffer without modifying the file on disk until you save the buffer.
Class
A compiled Java source file.
Clipboard
A temporary storage area used to transfer text or dialog box controls from one place to another. Multiple
text clipboards are available to store multiple instances of copied material.
Code block
A syntactical set of code that is delimited by a specific begin and end. These include if, for, function
defines, areas between braces, etc.
Context Tagging®
A feature set that performs expression type, scope, and inheritance analysis as well as symbol look-up
within the current context to help you navigate and write code. Context Tagging uses an engine that
parses your code and builds a database of symbol definitions and declarations—commonly referred to
as tags. Context Tagging features work with your source code, not just standard APIs (application
program interfaces), and the features are dynamic, in the sense that symbols are updated immediately
or in the background as you edit your source code.
CVS
An open-source, network-transparent version control system.
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DIFFzilla®
Allows you to view and merge changes from one version of a file to another. Difference two files, two
directories or two source trees. Provides the ability to view and merge differences for specific symbols
such as functions or classes, or a specified range of lines, from two files or the same file.
Edit window
A rectangular viewing area used to display and edit buffers.
Emulation
The ability of a program or device to imitate another program or device. Change the keyboard bindings
or shortcuts to emulate favorite shortcuts. Thirteen emulations available.
Enscript
Enscript is an external, command line program that prints a text file to a printer using PostScript, which
allows for print formatting such as font, page layout, margins, colors, etc. Enscript is included in most
Linux distributions. However, it is also shipped with SlickEdit® to ensure availability of the program.
FLEXnet™ Publisher
Licensing option for multiple users on a server.
Function heading
A term that refers to both the function signature and the comment above it. A function signature is the
first line (typically) of a function that contains the function name and the parameters. This can spread
across multiple lines, but is still considered one Line of Code (LOC).
Hotkey
A keyboard shortcut that is bound to a menu item.
IDE
Integrated development environment. A set of software development tools such as editors, compilers,
and debuggers, that are accessible from a single user interface.
Incremental search
Allows searching as letters are typed.
Key binding
A key or combination of keys that a user can press to perform an action that is available from a menu.
Also known as a shortcut key.
List Members
A SlickEdit Context Tagging feature that automatically lists members when you type a member access
operator. Also access this feature by pressing Alt+Dot.
List Parameters
A SlickEdit Context Tagging feature that displays a list of compatible variables and expressions for the
current argument when you type a function operator. For performance reasons, not all possible
variables and expressions are listed. Press Alt+Dot if the symbol you want is not listed. To access Auto
List Parameters on demand, press Alt+Comma.
Parameter Info
Automatically displays the prototype for a function when you type a function operator, and highlights the
current argument within the displayed prototype.
pcode
The binary result of a translation of Slick-C® source code. The translation is done to speed up the
interpretation of source code.
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Project
A group of folders, files, classes or packages.
Refactoring
A comprehensive code editing feature to help improve, stabilize, and maintain code. It allows a systemwide coding change without affecting the semantic behavior of the system.
Run–time
The time period that a computer program is executing. A run-time environment is an execution
environment.
Schema
In database programming, the representation of a database that will be mapped.
Selection
A highlighted region of text typically operated by a command which affects only the region. In the dialog
editor, the selection is indicated by eight square handles which surround the control.
Selective Display
A SlickEdit feature that allows you to select which lines are visible or hidden based on the content of the
lines. Also known as code folding.
Slick–C®
The SlickEdit macro programming language.
SmartPaste®
Pasted or dropped source code is automatically re-indented to the correct indentation level.
Source folder
A folder that contains packages, classes, and files.
State file
A file that stores configuration information and allows quick state restoration in subsequent edit
sessions.
Window
A rectangular viewing area. We also use this term in the more advanced sections of this manual to refer
to the operating system resource known as a window.
Workspace
A workspace defines a set of projects and retains the settings for an editing session.
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Index
A
Abbreviate similar files 76
About SlickEdit 55
ActionScript Formatting Options 369
active project 135
Ada Beautifier dialog box 403
Ada Formatting Options 403
Adaptive Formatting 263
Adaptive Formatting Options (Language-Specific) 668
Adaptive Formatting Results dialog 266
Adaptive Formatting Statistics dialog 268
Add Dialog Box 438
Add File dialog box (Code Templates) 246
Add file to project upon Save As 698
Add FTP Profile Advanced Tab 528
Add FTP Profile General Tab 527
Add import 357
Add New Filter dialog 701
Add New Item dialog box (Code Templates) 246
Add New Language dialog 334
Add Parameter dialog box (Code Templates) 246
Add Tag dialog 379
Add Tag File dialog 166
Add to current workspace 509
Add to Project 507
Add Tree dialog box 573
Add (Code Templates Add New Item dialog box) 247
adding files to a project 140
Advanced Appearance Options 635
Advanced Keyboard Options 642
Advanced tab (FTP Options) 709
after header 96
Alias Options (Language-Specific) 671
aliases 275
creating from selection 281
directory aliases 275
escape sequences 278
expansion option 679
language-specific aliases 276
parameter prompting 280
align on equal 347
align on parens 347
Allow drag/drop of text 645
Allow edit and continue (hot swap) where available 658
Allow editing of source files during debugging 658
Alt menu 643
Alt menu hotkeys 643
Annotation Editor dialog 303
Annotation File Manager dialog 308
Annotation Types dialog 305
anonymous e-mail address 708
anonymous login 528
ANSI C Formatting Options 369
Ant targets 178

SlickEdit® User Guide

Apache Ant 178
Appearance Options 624
Append EOF character 697
Application Options 702
argument completion 273
options for 679
Associate File Types dialog 123
Associate File Types Options 702
Associate with language 336
associating workspaces 123
Asynchronous message duration(s) 658
At left margin 675
At level of indent 675
attach debugger 186
core file 187
GDB 187
Java 187
running process 186
Attach Debugger Menu 580
attach debugger (GDB) 187
attach debugger (Java) 187
auto 666
auto caps mode 664
auto deselect 651
Auto Enable Properties dialog box 605
Auto exit build window 645
auto hide toolbar 67
auto increment search results window 545
Auto List Compatible Parameters 163
auto list members 161
auto merge 611
auto parameter information 162
Auto read only 696
auto refresh 529
Auto reload 696
Auto restore build window 703
Auto restore clipboards 703
Auto restore files 703
Auto restore line modify 703
Auto Restore Options 703
Auto restore selective display 704
Auto restore symbol browser tree 704
Auto restore working directory 703
Auto restore workspace files 703
Auto Symbol Translation 395
Auto symbol translation (option) 376
auto validate on open 376
Auto-Complete 271
Auto-Complete Options (Language-Specific) 678
Auto-display parameter 681
Auto-insert matching param 682
Auto-list compatible params 682
Auto-list members 681
Auto-list values 681
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automatic directory mapping 433
Automatic mode 507
automatic width (comment wrapping) 678
Automatically close visited files 654
Automatically correct breakpoint scope 658
Automatically expand doc comments 675
auto-restore 121
Autos tool window 73
AutoSave activated 700
AutoSave directory 701
AutoSave File Options 699
Auto-select unique items 679
auto-updated tag files 168
AWK Formatting Options 369

B
Background tagging of open files 648
Background tagging of other files 649
backing up network files 156
Backspace in replace mode 642
Backspace key 642
Backspace over tab 642
backup 155
history 155
network files 156
options 156
Backup dialog box 154
Backup directory option 699
Backup directory path 699
Backup File Options 698
backup files 698
Backup History 155
setting options for 156
Backup History tool window 68
backward 543
Base Classes dialog box 212
base file 434
beautifier 319
beautify 345
Beautifying code 319
before footer 96
begin end structure matching 194
setting match style 195
viewing/defining 194
Begin-End Style tab (C/C++ Formatting) 339
binary character searching 464
binary files (editing) 145
Bind Key dialog 639
bind macro to key 496
block cursor option 625
Block insert mode 235
block selections 220
blog 39
Bookmark Stack dialog 552
bookmarks 295
named 295
pushed 298
Bookmarks dialog box 553
Bookmarks tool window 550

810

Bounds 790
breadcrumbs 298
breakpoints 187
conditional 187
exceptions 188
breakpoints tab 187
Breakpoints tool window 68
Brief regular expressions 459
examples 463
Buffer cache size 705
Buffer tabs (visibility) 69
buffers 75
closing 81
listing open 79
switching between 78
build and compile 175
auto-build on save 176
build errors 179
build methods 177
build on save 176
commands 177
GNU C/C++ 177
makefiles 177
operations 175
parsing errors 179
projects 176
setting shortcuts for Ant targets 178
Xcode 177
build errors 179
listing 179
parsing with reg expressions 179
viewing and navigating 179
Build Menu 577
build methods 177
GNU C/C++ 177
Xcode 177
build options 139
build settings (projects) 138
Build tab (Project Properties) 569
Build tag file (C++ Compiler) 351
Build tool window 68
build window (auto exit) 645
build window (erased lines) 645
Build workspace tag file with references 649
building tag files 166
byte offset navigation 197

C
cache size (for buffers) 705
cache size (for tagging) 705
calculating (see mathematics)
calculator dialog box 487
Call Stack tool window 73
call tree 211
case for hex values 387
case sensitive 447
Categories (Code Templates Add New Item dialog box)
247
Categories (Template Manager dialog box) 244
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CFML Formatting Options 385
CFScript Formatting Options 369
Ch Formatting Options 369
Change directory 626
Change Directory dialog box 519
changing emulations 104
changing fonts and colors 117
character count indicator 64
character selection 219
inclusive option 651
characters (identifiers) 684
characters (inserting literal) 231
Check In Dialog Box 438
Check Out Dialog Box 438
Checkin/Checkout Files dialog 720
CICS Formatting Options 409
Class Exclusion Manager dialog 201
class properties 73
Class tool window 199
exclusion manager 201
filtering hierarchy pane 201
filtering/sorting members pane 201
clear bookmark 297
clear modified lines 259
Click past end of line 644
Clipboards tool window 69
clipboards (how to use) 231
Close after find/replace 654
Close deletes pushed bookmarks 654
close workspace 130
closing files 152
automatically 153
closing SlickEdit (see exiting SlickEdit)
clr debugger 188
COBOL Formatting Options 409
Code Annotations 301
code annotations
code marker 302
copying 304
creating 303
deleting 305
editing 305
for code reviews 309
for recording tasks 309
go to annotation 304
handling type conflicts 306
locations 301
managing files 307
moving 304
private and shared 302
types 301
user-defined 308
view and filter 304
Code Annotations tool window 302
code folding 327
code navigation 193
code reviews with annotations 309
Code Templates 239
Add File dialog box 246
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Add New Item dialog box 246
Add Parameter dialog box 246
Creating 241
Creating a multi-file template 248
Global substitution parameters 245
Locating Templates 247
Manually creating a template 247
Metadata file reference 249
Organizing templates 243
Pre-defined substitution parameters 242
Substitution parameters 242
Template Manager dialog box 244
Template Options dialog box 245
collapse code block 328
color
see colors
color coding 259
adding keywords 259
advanced configuration 260
clear modified line color 259
configuration 260
creating support for a new language 259
Color Coding Comments Tab 690
Color Coding Language Tab 688
Color Coding Numbers Tab 685
Color Coding Options (Language-Specific) 683
Color Coding Search Options dialog box 543
Color Coding Strings Tab 686
Color Coding Tags Tab 691
Color Coding Tokens Tab 683
Color Options 626
Color Picker dialog 119
Color Settings dialog box 626
colors 118
customizing 118
for embedded languages 120
of special characters 326
schemes 120
sync backgrounds 628
column indicators 64
Columns per Line 526
Command line prompting 643
Command Line Switches 87
command line (see SlickEdit command line) 85
commands 88
binding to keys 110
viewing associated key bindings 86
see also SlickEdit command line
Comment Options (Language-Specific) 673
Comment width 589
Comment Wrap Options (Language-Specific) 677
comment wrapping 317
enable 677
reflowing comments 317
sync vertical line 678
width settings 677
comments 313
block comments 313
commenting lines 313
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configuration 313
configuring block comments 674
configuring doc comments 675
configuring line comments 675
creating doc comments 314
doc comment examples 314
Doxygen 315
editing options 676
Javadoc 314
line comments 313
reflowing 317
removing 313
string editing 316
wrapping 317
XMLdoc 315
Comments tab (Beautifier) 347
Comments tab (Color Coding Setup) 690
common keys (redefining) 94
Compare Options dialog box 436
comparing directories 431
comparing files 429
comparing parts of files 430
comparing symbols in one file 430
comparing symbols of two files 431
compile 175
projects 176
Visual C++ 176
vsbuild 176
Compiler Properties (Language-Specific) 669
Compile/Link tab (Project Properties) 571
completion 271
word/variable 272
Completion on space 681
Completion (Context Tagging) 163
Completions in dialogs 273
concurrent process buffer (Build window) 68
conditional breakpoints 187
confidence level 268
config (see configuration)
configuration 771
changes not on menu 764
configuration variables 767
environment variables 763
F1 index file 777
F1 MSDN help 778
help files 777
of project directories 136
of project tools 137
of projects 135
options for saving 706
set command 765
system config files 773
table of sys config files 773
table of user config files 772
user config directory 771
vslick.ini 764
Configurations (Debugger Options) 661
configuraton
of build settings 138
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Configure Error Parsing 180, 721
Configure F1 MSDN help 778
Configure Special Characters 668
contact support 55
context menus 83, 665
Context Tagging 161
Auto List Compatible Parameters 163
building tag files 165
Completions 163
configuring for COBOL 168
for a new extension 166
List Members 161
managing tag files 168
options for 170
Parameter Information 162
Statement Level Tagging 164
Symbol Browsing 164
Tag-Driven Navigation 161
Context Tagging - Tag Files dialog 617
Context Tagging Options 647
Context Tagging Options (Language-Specific) 680
Context Tagging toolbar 72
continuation indent 346
Continue bullet list on Enter (comment wrapping) 678
control characters (inserting) 97
conventions 39
code syntax 41
menus and dialogs 40
convert HTML symbols 395
convert Unicode to UCN 757
Cool Features 735
Copy dialog box 154
Copy source to template directory (Code Templates Add
File dialog box) 246
Copy Unicode As Menu 534
copying code annotations 304
core file 187
Count number of lines 696
count selected characters 221
count selected lines 221
CR w/o LF erases line in build window 645
Create backup history on save 699
Create New Configuration dialog 135
Create new workspace 509
Create project directory from project name 509
Create Tag Files for Run-Time Libraries dialog 165
create workspace 130
creating a file from a selection 147
Creating a multi-file template 248
Creating a new category (Template Manager dialog box)
244
Creating a new template (Template Manager dialog box)
244
creating code annotations 303
creating custom project types 134
creating directory aliases 275
creating extension-specific aliases 277
creating files 147
Creating new configurations (compiler) 351
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creating project files 142
creating projects 134
Creating templates 241
Ctrl+Comma (pop bookmark) 193
Ctrl+Dot (go to definition) 193
Ctrl+Shift+V 232
Ctrl+/ (go to reference) 193
Ctr+Shift+V 645
CUA text box 645
CUA (default emulation) 39
current character 64
Current Context tool window 202
Current Document Options dialog 589
Current line 665
Current line box color 626
Current line column color 626
Current line highlight 626
Current paragraph 589
Cursor left/right in leading spaces 642
cursor navigation 196
Cursor page up/down 790
Cursor right/left wraps to next/prev line 641
Cursor style 625
Cursor up/down places cursor in virtual space 641
Cursor up/down within soft-wrapped lines 641
Custom Parameters tab (Template Manager dialog box)
245
custom project types 134
custom window size 77
Custom window width 647
Customize 509
Customize Project Types dialog 134
CVS 441
C# Formatting Options 369
C# tutorial 744
c/c++ beautifier 344
C/C++ Compiler Properties 350
C/C++ Formatting Options 339
C/C++ preprocessing 351

D
dBASE Formatting Options 413
Debug 579
debug key bindings 185
Debug Menu 579
Debug Sessions tool window 73
debug tab (FTP Options) 711
Debug toolbar 71
Debug Windows Menu 580
debug (see also debugging) 185
Debugger Configuration Options 661
Debugger Directory Options 660
Debugger Number Options 658
Debugger Option Settings 657
Debugger Options 656
Debugger Options dialog box 188
Debugger Runtime Filter Options 659
debugger (see also debugging) 185
debugging 185
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attach to core file 187
attach to remote process 187
attach to remote VM 187
attach to running process 186
GDB 187
generate debug 188
hot-swap debugger 658
mixed mode view 185
multiple sessions 186
named sessions 186
setting breakpoints 187
setting options for 188
tool windows 189
Decimal ruler 626
default emulation 39
Default Help dialog box 723
default key binding mode 39
default local directory 708
DefaultName element (Code Templates metadata file reference) 250
defining project dependencies 135
Defs tool window 203
options 203
delete bookmark 297
Delete Code Block dialog 294
Delete key 642
Delete Menu 533
delete selection 651
Deleting a template (Template Manager dialog box) 244
deleting code annotations 305
deleting code blocks 294
Dependencies tab (Project Properties) 572
dependencies (defining for projects) 135
Dependency of 509
Derived Classes dialog 212
Description element (Code Templates metadata file reference) 251
deselect after paste 651
Details tab (Template Manager dialog box) 245
Diff dialog box 429
diff options tab 615
Diff Setup dialog box 615
diffing (see DIFFzilla) 429
DIFFzilla 429
backup history 433
comparing directories 431
comparing symbols in two files 431
comparing symbols/parts of files 430
comparing two files 429
directory mapping 433
dynamic difference editing 429
generating file lists 431
options 613
path info and filespecs 613
types 612
DIFFzilla dialog box 612
Directories tab (Project Properties) 566
directories (comparing) 431
Directories (Debugger Options) 660
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directories (for projects) 136
directory aliases 275
creating 275
embedding env variables 276
using 275
directory mapping 433
directory (auto-change) 626
Display after idle 679
display line numbers 668
display symbol info under mouse 682
display tool tips 115
do not upload 708
Doc Comment Editor dialog 315
doc comments 314
configuration 675
docking toolbars 67
document math 489
Document Menu 583
Document Mode 507
documentation 39
documentation conventions 39
documentation feedback 39
Doxygen comments 315
drag and drop text 230
drag/drop 645
Draw box only 626
DTD caching 384
dual monitors 91
dynamic difference editing 429
Dynamic Surround 287
dynamic tagging 161
dynamic-language projects 134

E
eat spaces after 349
Edit Alias Parameter dialog 673
Edit Help File Description dialog 723
Edit Menu 531
edit other copy unicode as ucn menu 757
Edit Other Menu 533
Edit Select Menu 532
Edit toolbar 72
Edit 'A B C' start on file A 695
Edit (File Manager) 154
Editing an existing template (Template Manager dialog
box) 244
editing code annotations 305
Editing Options 643
editing recorded macros 498
Editor Window Options 646
editor windows 75
cascading and tiling 77
closing 81
duplicating 76
left margin width 76
linking 80
splitting 76
Elements (Code Templates metadata file reference) 250
else on same line as } 345

814

embedded asp dialect 387
embedded language color 120
embedded languages 44
HTML 45
Perl 45
UNIX 45
embedding env variables in aliases 276
Emulation Options 637
emulations 103
changing 104
default (CUA) 39
determining keys/functions 105
supported 103
Emulations (list) 103
Enable auto-completion 679
enable comment wrap 677
encoding 755
SBCS/DBCS 755
Unicode 755
UTF-8 755
Encoding (global option) 695
END command saves the file 790
End key 642
end of line 326
Enter Alias Parameter dialog 280, 673
Enter key 642
Enter New Alias Name dialog 277
Enter New Lexer Name dialog 259
Enter New Tag Name dialog 402
Enter places cursor in prefix area 790
Entire block comment (Comment Wrap tab) 589
entity reference translation 395
Enumerate dialog box 536
Enumeration 222
environment variables 763
set command 765
setting in vslick.ini 764
Error File dialog box 179
error parsing 179
configuration 180
exclusions 182
sample expression 182
testing expressions 183
Error Regular Expressions dialog box 180
ESC dismisses floating window 631
escape sequences 278
evaluating regular expressions 458
examples of Brief reg expressions 463
examples of Perl reg expressions 468
examples of SlickEdit reg expressions 473
examples of UNIX reg expressions 479
exception breakpoints 188
Exceptions tool window 69
exclusions (error parsing) 182
Executable name 509
execute Ant target 178
execute NAnt target 178
Exit confirmation prompt 706
Exit Options 705
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exit process 68, 645
Exit SlickEdit on AutoSave 700
exiting SlickEdit 54
default options 54
with modified buffers 54
expand code block 328
Expand tabs 512
Expand tabs to spaces 693, 695, 697
Expand/collapse 636
Explorer Open dialog box 148
export key bindings 112
export to HTML 385
extend file history 769
Extend line comments 676
extend workspace history 769
Extensioness C++ File options 343
Extensionless 343
extension-specific aliases
creating 277
escape sequences 278
parameter prompting 280
Extract method (Quick Refactoring) 321

F
f command 194
failed saves 151
Fast auto read only 696
Fast line count on partial load 695
features (new) 33
file associations 123
File element (Code Templates metadata file reference)
251
File Extension Manager 335
File Extensions dialog 664
File Filter Options 701
file format 514
file history (File menu) 769
file history (Project menu) 769
file lists 153, 645
file lists (generating) 431
File locking 695
File Manager Files Menu 506
File Manager Menu 505
File Manager Select Menu 505
File Manager (Using) 153
File Menu 503
File Open dialog box 510
File Options 694
File Options dialog box 150
File Options (Language-Specific) 692
file search order 775
File Sort dialog box 154
File tab (New dialog) 507
File Tabs tool window 69
File tabs (visibility) 69
file types 123
fileman select menu 154
files 145
auto-close 153
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autosave options 152
closing 152
comparing parts of 430
comparing symbols in two files 431
comparing two files 429
configuration files and directories 771
creating from selections 147
diffing file history 433
encoding 755
failed saves 151
finding files to open 149
FTP 451
generating lists 431
history and backups 155
inserting into buffers 149
listing open files/buffers 79
merging 433
navigating between 196
opening 148
quick create/open 147
save as 151
saving 151
setting associations 123
Files element (Code Templates metadata file reference)
252
files menu 503
Files tab (DIFFzilla) 612
Files tab (Project Properties) 565
Files tab (Template Manager dialog box) 245
Files tool window 70
filters 528
find
see also searching
Find and Replace tool window 541
Find File dialog box 149
Find in Files tab (Find and Replace) 544
Find references incrementally (faster) 649
Find Symbol tool window 549
Find tab (Find and Replace) 542
finding files 149
firewall proxy tab 710
First line is top 674
first time running SlickEdit 53
fixed right margin (comment wrapping) 678
fixed width (comment wrapping) 677
float toolbar 67
follow characters 685
Font Configuration dialog box 628
Font dialog box 118
Font Options 628
fonts 117
changing 117
in editor windows 118
recommended 117
UNIX 117
footer (printing) 96
For start characters 676
force parens on return 349
foreground search 546
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form feed after last page 526
format file 698
Formatting Options (Language-Specific) 669
Fortran Formatting Options 409
forums 39
fp command 194
FTP 449
configuration options 451
connecting 450
create connection profile 449
disconnecting 451
opening files 451
tool windows 449
ftp connection profile 449
FTP Default Options 707
FTP Default Options Advanced Tab 709
FTP Default Options Debug Tab 711
FTP Default Options Firewall/Proxy Tab 710
FTP Default Options SSH/SFTP Tab 711
FTP Menu 504
FTP Options Advanced Tab 709
ftp options firewall/proxy tab 710
ftp options general tab 527
ftp options ssh/sftp tab 711
FTP tool windows 449
full screen mode 327
function braces 345
F1 Index File 722
F1 Index Help 777
F1 MSDN Help 724

G
GDB projects 133
GDB (attaching to remote process) 187
GDB (multiple session debugging) 186
GDB (newer version) 661
GDB (setting configurations) 661
General Appearance Options 624
General Editing Options 644
General Help Options 721
General Options (Language-Specific) 663
Generate debug 188
generate file list 431
generate references 208
Generic Project type 132
Get Dialog Box 438
Global Alias Options 655
global aliases 275
Global directory 699
Global Find dialog 155
Global nested directories 699
Global Replace dialog box 155
Global Substitution Parameters (Code Templates) 245
glossary 805
GNU C/C++ build methods 177
GNU C/C++ projects 132
go to annotation 304
Go to Bookmark dialog box 552
Go to Bookmark feature 297
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go to definition 193
navigation option 682
Go To Definition dialog box 554
Go to Definition ignores forward class declarations 682
go to reference 193
Go to references only lists references 649
Grid Settings dialog 604

H
hash tables editing 602
header (printing) 96
help
F1 777
UNIX, Linux, Mac OS X 777
Help Index dialog box 736
help key shortcuts 42
Help Menu 733
Help Options 721
help resources 39
help system 41
Hex view 668
hexadecimal display 236
Hide mouse pointer 625
hide toolbar 67
Highlight matches 543
Highlight matching blocks 646
Highlight matching symbols under cursor 682
Highlight references in editor 649
highlight symbols 428
history 155
backup 155
network files 156
of opened items 156
History Appearance Options 634
History dialog box 156
History retrieval 654
history (increase File menu) 769
history (increase Project menu) 769
Home key 642
HOME Key Configurations 94
Home places cursor on command line 790
Horizontal scroll bar 625
host name of firewall 710
host name of FTP server 528
host type 528
hot fixes 51
installing 51
list of installed 51
unloading 51
hot key 84
hotkeys 643
hot-swap debugger 658
HTML 385
beautifying 388
browser configuration 385
exporting current file 385
HTML Beautifier Advanced tab 394
HTML Beautifier Attributes Values tab 392
HTML Beautifier Comments tab 392
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HTML Beautifier dialog box 388
HTML Beautifier Indent tab 388
HTML Beautifier Schemes tab 395
HTML Beautifier Tags tab 390
HTML Comments dialog 393
HTML Formatting Options 385
HTML symbol translation 395
HTML toolbar 385

I
iconized windows 600
Identifiers 684
ignore spaces 612
Import File List dialog 142
import key bindings 112
Import options 357
importing files to projects 142
importing makefiles 142
Imports 356
Imports Menu 609
increase file history (File menu) 769
increase workspace history (Project menu) 769
Incremental search highlighting 655
incremental searching 420
Indent access specifier 346
indent case 346
indent first level of code 346
indent for each level 346
indent inside block 349
Indent Options (Language-Specific) 665
indent preprocessing 349
indent stand alone comments 347
indent style 666
indent with tabs 346
Indentation tab (C/C++ Formatting) 340
indenting tab 346
indicator (line/char count) 64
indicator (macro recording) 64
indicator (named bookmark) 295
indicator (pushed bookmark) 298
initial directory 528
Initialize search string 654
Initialize with default options 654
Insert File dialog box 149
Insert Literal dialog box 231
insert mode 644
Insert open paren 681
insert real indent 667
Insert selected 679
Insert space after comma 682
insert toggle 64
inserted attribute (casing) 387
inserted tag (casing) 386
Inserting characters 231
Inserting control characters 97
inserting files into buffers 149
Installed templates (Locating) 247
installing SlickEdit 47
installing X11 for Mac OS X 48
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InstallScript Formatting Options 369
invocation options 759
invoking Ant targets 178
invoking NAnt targets 178
ISPF Copy Lines 795
ISPF Delete Lines 796
ISPF Emulation 789
ISPF Emulation Options 789
ISPF Exclude Lines 801
ISPF Expose First Lines 796
ISPF Expose Last Line 797
ISPF Expose Next Level of Code 799
ISPF Insert After 795
ISPF Insert Before 795
ISPF Insert Bounds Ruler 795
ISPF Insert Columns Ruler 796
ISPF Insert Lines 797, 800
ISPF Insert Mask Line 798
ISPF Insert Tabs Ruler 799
ISPF Insert Text 800
ISPF Join Lines 800
ISPF Line Command A 792
ISPF Line Command B 792
ISPF Line Command Delete 793
ISPF Line Command Exclude 793
ISPF Line Command First 793
ISPF Line Command Uppercase 793
ISPF Line Commands 793
ISPF Line Labels 794
ISPF Lowercase Lines 797
ISPF Make Data Lines 798
ISPF Move Lines 797
ISPF Overlay Lines 798
ISPF Repeat Lines 799
ISPF Select Lines 801
ISPF Shift Lines Left or Right 794
ISPF Split Line 800
ISPF Unsupported Primary Commands 802
ISPF Uppercase Lines 801

J
Java 353
Java Beautifier dialog 371
Java compiler 357
Java Compiler Properties 359
Java Formatting Options 369
Java Live Errors 357
Java Options Appletviewer tab 357
Java Options Classpath tab 357
Java Options Compiler tab 357
Java Options Debugger tab 357
Java Options dialog 357
Java Options Jar tab 357
Java Options Javadoc tab 357
Java Options JRE tab 357
Java Options J2ME tab 357
Java Options Live Errors tab 357
Java Organize Imports 356
Java Organize imports options 357
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Java projects 133
Javadoc Beautifier dialog box 373
Javadoc comments 314
Javadoc Editor dialog box 373
JavaScript Formatting Options 369
JAWS screen reader 91
configuration 91
JCL Formatting Options 409
Join comments 676
JSP TagLib Formatting Options 385
Jump over tab characters 641
jumping to a tag 193
justification dialog box 671
justified 671
justify style 671
J# Formatting Options 369

K
keep alive default FTP 709
keep alive FTP connection 529
Key Binding Options 637
key bindings 107
binding macros 496
creating 110
definitions of terms 107
emulations 103
export/import 112
key message delay 113
unbinding 111
used in debugging 185
viewing associated commands 86
key definition 86
Key message delay 643
key names 84
key names (option) 636
key shortcuts in text boxes 93
Keyboard Options 637
Keys Help 105
Keyword case 403
Keywords 679

L
664
Language Manager 333
Language Options 662
Language Setup 336
language support 43
Language tab (Color Coding Setup) 688
language-specific aliases 276
creating from selection 281
language-specific projects 140
Largest file to AutoSave 701
Last line is bottom 675
lcase 230
Leave selected 655
left and respace 671
Left and Right 675
Lexer name 664
lexer name 335
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lexer name (creating in VLX file) 779
libraries 130
license agreement tab (about slickedit) 53
licensing 49
Limit size of backup 699
Line Comment Options 691
line count indicator 64
Line format 698
line indicators 64
Line insert style 644
line navigation 197
Line numbers 668
line numbers 326
line selections 220
Line separator char 512
Line wrap 641
lines
clearing modified line coloring 259
line numbers 326
Lines per Page 526
Link Window dialog box 80
Linking to a window 80
Linux (printing on) 97
List all occurrences 543
list clipboards 231
list clipboards dialog box 231
List command line completions 626
List errors 179
List Files dialog box 153
List files of type 511
list hot fixes 51
List Members 161
List members 680
list open files/buffers 79
list project files 585
list workspace files 585
literal characters (inserting) 231
live errors 357
Load as Binary 693
Load entire file 696
Load File Options 694
Load Module dialog box 499
load partial if larger than 150
Load partially for large files 696
Load partially when files are larger than 696
load (for different drives) 151
Loaded Classes tool window 73
loading project files 143
Locals tool window 73
Locating templates 247
Installed templates 247
User templates 247
Location 675
Location (Code Templates Add New Item dialog box) 247
locations for code annotations 301
locked files 150
look in 542
lower case file names 387
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M
Mac OS X 40
format buffer 761
printing 97
special features 44
Macro Menu 597
macros
programmable 499
recorded 495
macros (batch) 500
Maintenance and Support 32
Make backup files 698
makefile import 142
makefile (build with auto) 177
makefile (building without) 177
makefile (custom build command) 177
makefiles 135
managing code annotation files 307
managing project source files 140
managing projects 132
managing projects in workspace 131
managing workspaces 130
Manually creating a template 247
margins tab 96
margins (setting) 671
Match block comment setting 589
Match case 542
Match case (default) 653
match highlighting 428
Match whole word 542
Match whole word (default) 653
math (see mathematics)
mathematics 487
document math 489
expressions with mixed bases 487
math commands 488
math commands (examples) 488
overflow/underflow 489
prime numbers 489
using the Calculator 487
Max files 695
Max number of tags per file 649
Max size of files to tag 648
Max undo steps 695
Maximize first window 646
maximizing and minimizing windows 77
Maximum candidates for list parameters 650
Maximum class/struct members shown in list 650
Maximum clipboards 645
Maximum functions found by parameter help 650
Maximum globals shown in list members 650
Maximum number of files to consider 649
Maximum number of files to tag 649
Maximum response time to list parameters 650
Maximum search results output (KB) 655
Maximum size to backup 699
Maximum stack depth 654
Maximum suspended update time(ms) 657
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Maximum Symbols 679
Maximum tag file cache size 650
Maximum tags found in symbol search 650
Maximum Word completion 679
Members tool window 73
Memory tool window 73
Menu Editor dialog box 604
menu if no selection 83, 665
menu if selection 83, 665
Menu Item Alias dialog box 739
Merge dialog box 433
merging files 433
Message line 64
Message List 311
Message list colors 626
Message List tool window 311
Message modified color 626
Message visited color 626
Metadata file reference (Code Templates) 249
minimizing and maximizing windows 77
Minimum prefix 679
Minimum running update time(ms) 657
Minutes before restarting 649
mixed mode view (debugging) 185
mode name 664
Modified Buffers dialog box 54
Modified lines 665
Modify parameter list (Quick Refactoring) 322
modify (reset line) 697
modifying doc comment templates 315
modifying selected text 222
modifying Surround With templates 291
modules (Slick-C) 499
mouse pointer option 625
mouse selection 652
mouseover symbol info 682
Move dialog box 154
moving code annotations 304
multi-file diff output dialog box 431
multi-file undo/redo 427
Multi-line Comment dialog box 691
multiple file search and replace 544
multiple help file access 777
multiple instances 53
multiple monitors 91
multiple monitors (configuring) 760

N
Name element (Code Templates metadata file reference)
253
Name (Code Templates Add New Item dialog box) 247
Name (Code Templates Add Parameter dialog box) 246
named bookmarks 295
Bookmarks tool window 550
deleting/clearing 297
indicator 295
navigating (go to) 297
setting 295
toggle 296
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workspace bookmarks 297
named sessions (debugging) 186
namespaces 351
NAnt 178
NAnt targets 178
navigate to named bookmark 297
navigate to pushed bookmark (popping) 298
navigation 193
between buffers/windows 78
between symbols 193
between words 196
cursor movements 196
go to definition 193
go to offset 197
go to reference 193
in pages and files 196
in statements and tags 195
pop bookmark 193
symbol browsing 199
to a specific line 197
URLs 197
Network and Internet Options 706
network backup 156
Network Settings 706
never 666
New Annotation dialog 303
new configurations 351
New Extension dialog 337
new features 33
New Field dialog 305
New File Tab 147
New Folder Name dialog 130
New Formatting Scheme dialog 400
New Project dialog 134
New Project Tab 508
New window size 647
New window width 647
New Workspace Tab 509
New (File) dialog box 147
Newline characters 668
next word 196
Next word style 645
no space before paren 345
no window reordering 647
none 666
non-mdi editor control 600
number lines every 522
Number of backups to keep for each file 699
number of copies 522
Number of lines to scan for Autos 657
Number of recent modes to store 508
Number of recent types to store 509
numeric overflow or underflow 489
numeric sort 447
numerical values 387

O
Objective-C Formatting Options 369
offset navigation 197
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OMG IDL Formatting Options 369
one file per window 646
Open Application 336
Open dialog box 148
Open Makefile as Workspace dialog 575
Open Menu dialog box 739
Open Other Workspace Menu 562
open site 710
Open tab (Project Properties) 573
Open tool window 70
Open URL dialog box 149
open workspace 130
opening files 148
quick open 147
UNIX, Linux, Mac OS X 148
Windows 148
opening Unicode files 756
opening URLs 149
options
auto-restore 121
Options dialog 619
Options dialog shortcuts 621
options for common keyboard keys 94
options for pushed bookmarks 299
Options History 725
Options menu 607
Options Search 621
Options tab (DIFFzilla) 613
options (using macros to discover/control) 498
order 447
Organize All Workspaces dialog 130
Organize Imports Options 357
Organize Java Imports 356
organize_imports_options 356
organizing projects 127
Organizing templates 243
orginal absolute column 348
orientation 522
original relative column 348
original tab size 346
OS prompt 87
OS/390 Assembler Formatting Options 409
Other menu 533
other tab 348
Other tab (C/C++ Formatting) 342
output file 611
output style 611
Output tool window 70

P
pad condition 349
Pad parens 682
Parameter element (Code Templates metadata file reference) 254
Parameter info 681
Parameter Information 162
parameter prompting 280
Parameters element (Code Templates metadata file reference) 255
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paren style 195
Parenthesis matching style 645
partial load (fast line count) 695
Pascal Formatting Options 411
passive transfers 710
password 528, 710
paste 229
Perl Formatting Options 369
Perl regular expressions 464
examples 468
PHP Formatting Options 385
Place cursor at end 654
platform support 40
PL/I Formatting Options 413
PL/SQL Formatting Options 413
pop bookmark 298
port 529, 709, 710
Pre-defined substitution parameters (Code Templates)
242
Prefix area width 789
Prefix matching (Options dialog) 621
preprocessing for C/C++ 351
Preserve column on top/bottom 645
Preserve trailing 681
preserve width on existing (comment wrapping) 678
Preview tool window 205
what is displayed 206
Preview (Code Templates Add File dialog box) 246
prime numbers 489
print color 522
print color coding 522
Print Command 527
Print Device 527
Print dialog box 520
print dialog (text mode) 524
Print Filter 527
print hex 522
print schemes 96
print (see also printing) 95
printing 95
insert formfeed 97
on UNIX, Linux, Mac OS X 97
on Windows 95
schemes 96
process buffer 68, 645
procs and prototypes 193
product registration 32
Product Updates 737
Product Updates Menu 735
profile name 528
program info tab (about slickedit) 53
programmable macros 499
loading 499
Progress 4GL Formatting Options 369
Project Build Commands tab 569
Project Configuration Settings dialog 135
project directories tab 566
project files 140
adding and removing 140
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creating 142
importing 142
listing 585
loading 143
makefiles 135
Project Files Tab 565
Project Menu 561
Project name 509
Project Properties dialog 563
Project properties (Tools) 567
Project tab (New dialog) 508
Project Tools Tab 567
Project Tools toolbar 72
Project type 508
project types 132
dynamic languages 134
GNU C/C++ 132
Java 133
other compilers 133
Visual Studio 133
projects 127
build settings 138
build system options 139
command line execution 138
configurations 135
configuring directories 136
configuring tools 137
creating 134
creating custom types 134
defining dependencies 135
defining language-specific 140
importing files 142
libraries 130
loading files 143
makefiles 135
managing 132
managing source files 140
managing within a workspace 131
organizing 127
project types 132
setting active 135
sharing between workspaces 131
specifying command directory 138
version control 129
wildcards 130
with one file 140
Projects tool window 71
Prompt for value (Code Templates Add Parameter dialog
box) 246
prompt replace dialog box 546
Prompt string (Code Templates Add Parameter dialog
box) 246
protect read-only 645
Protect read-only mode 645
Proxy Settings 713
pushed bookmarks 298
bookmark stack 298
indicator 298
options 299
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popping 298
pushing 298
viewing 298
PVCS 440
Python Formatting Options 369

Q
Quick Brace 285
Quick brace/unbrace one line statements 340, 370
quick create 147
quick extract method 321
quick modify parameter list 322
quick open 147
quick refactoring 321
undo/redo 321
Quick Refactoring Menu 609
quick rename 321
quick replace 419
quick replace literal with constant 322
quick search 419
Quick Start 57
quotes 387
quotes (numerical values) 387
quotes (single values) 387
quote_key command 97

R
Read List dialog box 154
read only indicator 64
read only mode (macros) 600
read only mode (protect) 645
read only (open as) 514
rebuild 178
recognizing Unicode files 756
Record width 512
recorded macros 495
binding to keys 496
deleting 498
execute_last_macro_key 497
operations 495
recording a new macro 496
running 497
saving and editing 498
using to discover/control options 498
recording tasks with annotations 309
Redefine Common Key Options 640
redo replacement 427
redo (multi-file) 427
refactoring 321
Refactoring results 322
References tool window 207
options 208
References view 207
references (options) 649
reflow comment dialog box 588
Reflow next 645
reflowing comments 317
Regex Evaluator 458
Regex Evaluator tool window 458
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entering expressions 458
entering test cases 458
options 458
Registers tool window 73
registration 32
Regular expression syntax 653
regular expressions 459
Brief 459
Brief examples 463
evaluating 458
minimal versus maximal matching 454
Perl 464
Perl examples 468
search and replace with 427
SlickEdit 469
SlickEdit examples 473
tagged search expressions 455
Unicode category specifications 480
Unicode character blocks 481
UNIX 474
UNIX examples 479
Reinsert after current 695
release notes tab (about slickedit) 53
Reload on switch buffer 696
reload prompt 696
remote process (debugging) 187
remote to local directory mapping 529
remote VM 187
Remove Dialog Box 438
remove duplicate lines 447
Remove EOF character 697
removing files from a project 140
removing SlickEdit 51
Rename (Quick Refactoring) 321
reorder windows 647
repeat command on selected dialog box 505
replace
see also replacing
Replace in Files tab (Find and Replace) 547
Replace literal with constant (Quick Refactoring) 322
replace mode 644
Replace params in target file (Code Templates Add File
dialog box) 246
Replace tab (Find and Replace) 546
replace toggle 64
replacing 419
Find and Replace tool window 425
minimal vs maximal matching 454
quick replace 419
replace and c commands 423
undo/redo 427
using regular expressions 427
see also searching
reset 345
Reset line modify 697
resolve links 529
Response timeout(s) 657
Restore cursor after replace 655
revision one 611
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revision two 611
REXX Formatting Options 413
Right CTRL = Enter/Send 790
router 710
Ruby Formatting Options 369
running a program 185
running multiple instances 53
running recorded macros 497
runtime functions 659
run-time libraries 167

S
safe exit 54
Same directory as *.BAK 699
Same name 701
Same name different extension 701
Save after period of inactivity 700
Save after period of time 700
Save and Bind to Key 600
Save As dialog box 151
save as (using) 151
Save configuration 706
Save Failed dialog box 151
Save File Options 696
Save files on loss of focus 697
save macro dialog box 599
Save Multi-File Diff Output dialog box 432
save password 528
save settings 345, 525
Save to 700
Save to different directory 700
Save/restore file position 695
saving files 151
saving recorded macros 498
SBCS/DBCS 755
SCC 439
configuration 440
opening a project 440
schemes tab 349
Schemes (Beautify) 349
schemes (colors) 120
schemes (printing) 96
SCIM 642
screen layout 63
screen management 91
scroll bars 115
Scroll style 626
Scroll when 626
search
see also searching 419
Search backward 654
search for 542
Search hidden text 654
Search Menu 539
Search Options 652
Search Options dialog box 542
search order 775
configuration files 775
executable files 775
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Search Results node 621
Search results output 426
Search Results tool window 71
search (go to offset) 197
searching 419
classes 69
Find and Replace tool window 425
find and slash commands 421
Find Symbol tool window 427
finding all symbols in file 428
history retrieval 654
incrementally 420
initialization options 654
members 69
minimal vs maximal matching 454
multiple files 544
quick search 419
syntax-driven 426
tagged search expressions 455
undo/redo 427
using regular expression syntax 653
using regular expressions 427
See F1 Index Help for more information. 619
Seek dialog 197
seek offset position 197
Select a Buffer dialog box 80
Select Colors to Update dialog 119
Select Files With Attribute dialog 154
select first 83, 665
Select Mode dialog box 333
Select Mouse Event dialog 109
Select Symbol dialog 726
Select Text to Paste dialog 535
Selected text (if exists) 654
selecting a code block 291
Selecting a mode 333
selecting text 218
block insert mode 235
blocks (columns) 220
characters 219
commands 222
counting lines/characters 221
drag-and-drop 230
enumeration 222
keyboard shortcuts 219
lines 220
modifying a selection 222
selection color 218
selection only 522
Selection Options 650
selection restriction 345
selection styles 650
Selection (Comments) 589
selection (creating alias from) 281
Selective Display 327
Selective Display dialog box 556
Selective Display Function headers 557
Selective Display Multi-level 558
Selective Display Preprocessor directives 558
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Selective Display Search Text 557
Selective Display toolbar 72
server type 528
service name 711
Set Attributes dialog 155
set command 765
set named bookmark 295
set pushed bookmark 298
set scroll style 115
Set Variable dialog box 601
SETemplate element (Code Templates metadata file reference) 255
setting active project 135
setting fonts and colors 117
SFTP 449
sftp tab 711
sharing code annotations 302
sharing projects 131
shell prompt 87
shell scripts 44
shelling 87
Short key names 636
shortcuts for build and rebuild 178
shortcuts in Options dialog 621
shortcuts in text boxes 93
Show categories 680
show changes 611
Show comments 680, 681, 682
Show EOF character 695
Show expanded text 680
Show files beginning with a dot 626
show hidden files (Open dialog) 514
show hidden files (Save As dialog) 517
Show icons 680
Show info for symbol under mouse 682
Show light bulb 680
Show list of matches 680
Show pictures 76
Show pushed bookmarks 654
Show set bookmarks 654
Show symbol declaration 680
Show symbol info 682
Show tool tips 632
Show value of symbol under mouse 658
single line statements 285
single word values 387
sizing windows 77
Slick-C Formatting Options 369
Slick-C headers 500
Slick-C module 499
Slick-C Stack 71
Slick-C Stack tool window 71
Slick-C variable 500
SlickEdit book 39
SlickEdit command line 85
activating 85
common commands 88
history 85
keyboard shortcuts 86, 93
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prompting 87
prompting (option) 643
shelling 87
SlickEdit dialog 53
SlickEdit File Manager 153
SlickEdit regular expressions 469
examples 473
SLICKEDITCONFIG 763
smart next window 78
Smart next window style 646
SmartPaste 262
Smooth horizontal scroll 626
Smooth vertical scroll 626
snippets 275
soft wrap 671
Sort buffer 447
sort commands 447
sort dialog box 447
Sort on selection 447
Sort within selection 447
sort (selection) 447
sorting text 447
commands 447
SortOrder element (Code Templates metadata file reference) 256
sort_on_selection command 448
Source file name (Code Templates Add File dialog box)
246
space between 522
Space inserts space 681
Special Character Options 634
Special Characters 668
special characters tab 634
specifying tabs for a file extension 262
spell check 443
in multiple files 444
operations 443
running 443
Spell Check Files dialog box 444
Spell Check Menu 610
Spell Check Options 716
spelling dialog box 443
Spill file path 704
spill file (and buffer cache) 150
Split line comments 676
Split strings 676
SQL Server Formatting Options 413
ssh executable 711
ssh tab 711
stack class 162
stand alone comments 347
Standard Open dialog box 148
Standard toolbar 72
Start after minutes idle 649
Start after seconds idle 648
start characters 685
Start in column 675
Start mode 644
start on file 695
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Start wrapping on line 677
starting FTP connection 450
starting SlickEdit 53
for the first time 53
multiple instances 53
state file 500
state file (alternate) 760
Statement Level Tagging 164
statement navigation 195
status line 64
stopping FTP connection 451
String editing 676
string editing (comments) 316
Strip trailing spaces 697
structure matching 194
setting match style 195
viewing/defining 194
submenus 83
Substitution parameters (Code Templates) 242
subsystem 711
Subversion 441
summary of keys 103
support (for SlickEdit) 55
supported browsers 42
Suppress prompt unless modified 696
surrogate support 757
surround selection 290
Surround With 290
commands 292
modifying templates 291
surround with block statement 287
Surround With dialog 290
surrounding text 287
Symbol Browser Filter Options dialog box 212
symbol browsing 199
base/derived classes 212
Class tool window 199
Current Context tool window 202
Defs tool window 203
Find Symbol tool window 204
Preview tool window 205
References tool window 207
symbol uses/call tree 211
Symbols tool window 208
Tag Properties tool window 215
symbol highlighting 428
symbol info (show under mouse) 682
symbol navigation 193
between multiple instances 194
browsing symbols 199
Find Symbol tool window 194
more methods 194
Symbol Properties tool window 215
Symbol Translation Editor 396
symbol use 211
Symbol Uses/Calling tree dialog box 211
Symbol view 208
Symbols 679
symbols
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comparing in one file 430
comparing in two files 431
Symbols tool window 208
base/derived classes 212
filter options 212
filtering symbols 209
options 210
uses/calling tree 211
sync backgrounds (colors) 628
sync extension 345
sync vertical line (comment wrapping) 678
Syntax expansion 679
syntax expansion 283
Syntax expansion (Overview) 283
syntax indent 261, 346, 666
Syntax indent ruler 626
syntax-driven search 426
system command line invocation options 759
system configuration files 773
system state file 500

T
Tab cycles choices 679
tab groups 67
Tab inserts longest 679
Tab key 261
tab size 346
Tabs 666
tabs dialog box 262
Tabs ruler 626
tabular lists 65
Tag file cache size 705
Tag file on save 648
tag files 351
auto-create 165
auto-updated 168
building 165
categories 168
for libraries 166
rebuilding 169
search order 169
tag navigation 195
tagging 161
tagging cache 705
tagging libraries 166
tagging (identifiers) 684
tagging (minutes before retagging) 649
Tags tab (Color Coding Setup) 691
Target file name (Code Templates Add File dialog box)
246
Tcl Formatting Options 369
Template file (Template Manager dialog box) 245
Template Manager dialog box (Code Templates) 244
Template Options dialog box (Code Templates) 245
TemplateContent element (Code Templates metadata
file reference) 257
TemplateDetails element (Code Templates metadata file
reference) 257
Templates list (Code Templates Add New Item dialog
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box) 247
Templates list (Template Manager dialog box) 245
testing regular expressions 458
text box editing keys 93
text compare 429
text editing 217
block insert mode 235
cut, copy, move 227
inserting characters 231
selections 218
sorting 447
Text Mode Print dialog box 524
text selection 667
third-party workspaces 132
Threads tool window 73
three way merge editing 433
Throw away file lists 645
timeout 529, 709
toggle 64
toggle bookmark 296
Tool Options 715
Tool tip delay (ms) 632
tool tips (global option) 632
tool windows (overview) 67
Toolbar Control Properties dialog 559
Toolbar Customization Categories Tab 632
Toolbar Customization dialog 630
Toolbar Customization Options Tab 632
Toolbar Customization Toolbars Tab 630
Toolbar Options 630
Toolbar Options Categories Tab 632
Toolbar Options Options Tab 632
Toolbar Options Toolbars Tab 630
Toolbar update delay(ms) 658
toolbars 67
displaying 67
docking 67
Toolbars (Customizing) 67
Tools Menu 607
Tools tab (Project Properties) 567
Tools toolbar 72
tools (for project configuration) 137
Top of file line 625
Tornado workspaces 132
transfer type 528
Truncate file at EOF 696
truncation 664, 696
tutorials 743
C# 744
C/C++ 743
Java 751
two up 522
types of code annotations 301
types of projects 132

U
ucase 230
UCN 757
unattended installation 48
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unbinding a key 111
Unbrace 285
uncommenting 313
undo replacement 427
undo (multi-file) 427
Unicode 755
category specs for reg expressions 480
character blocks for reg expressions 481
converting to UCN 757
file recognition 756
implementation 758
limitations 757
opening files 756
surrogate support 757
uninstalling SlickEdit 51
Unit testing 357
Unit Testing tool window 71
UNIX regular expressions 474
examples 479
UNIX temp environment 704
UNIX (printing on) 97
UNIX (recommended fonts) 117
Unlist Search dialog box 154
unload hot fix 51
unload module 499
Unlock Dialog Box 438
Unsurround Block 293
Update after idle 679, 683
update manager 50
Update Manager Options dialog 737
Update tool windows after ms idle 648
updates (to SlickEdit) 50
upgrading SlickEdit 50
upload filename case 529, 709
URI Scheme Options 712
URL Mapping Options 711
url mappings 384
URL navigation 197
URL (opening) 149
Use child directory 699
Use Ctrl+Space for input method editor 642
Use file association 336
use firewall/proxy 529
use hanging indent (comment wrapping) 678
use smart merge 611
Use undo 695
Use workspace bookmarks 654
user configuration files 771
user id 528, 710
User interface 63
tabular lists 65
user preferences 101
user state file 500
User templates (Locating) 247
User-Loaded Modules dialog 598
Using Version Control 437
UTF-8 755
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V
Value (Code Templates Add Parameter dialog box) 246
Variable editor 602
Variable Editor dialog box 602
variable (Slick-C) 500
VBScript Formatting Options 411
version control 437
advanced settings 439
configuration 438
CVS 441
overview 437
PVCS 440
SCC 439
setting up command line systems 439
Subversion 441
using 437
workspaces and projects 129
Version Control Advanced Setup Dialog Box 718
version control command setup dialog box 439
Version Control Menu 608
Version Control Setup dialog box 438
Version Control Setup Options 717
Vertical line color 625
Vertical line column 625
Vertical scroll bar 625
VHDL Formatting Options 411
view and filter code annotations 304
View Menu 555
View Options (Language-Specific) 667
view special characters 325
view text symbols 325
View text symbols (Special Characters tab) 634
viewing accessible members 213
viewing symbol properties 210
viewing symbol references 207
viewing symbol uses 211
Vim tutorial 751
Virtual Memory Options 704
visible lines only 522
Visual Basic Formatting Options 411
Visual C++ Setup dialog box 176
Visual Studio projects 133
Visual Studio workspaces 132
VLX file 779
creating a lexer name 779
modifying to change color definitions 779
VPW extension 123
vsbuild to compile files 176
vsdebugio connection port 658
VSLICK 763
VSLICKALIAS 764
VSLICKBACKUP 764
VSLICKBIN 763
VSLICKBITMAPS 763
VSLICKLOAD 764
VSLICKMACROS 763
VSLICKMISC 764
VSLICKPATH 763
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VSLICKRESTORE 763
VSLICKTAGS 764
VSLICKXNOBLINK 764
VSLICKXNOPLUSNEWMSG 764
VSLICKXTERM 764
vslick.sta 759
vslick.stu 759
VSLICK_XIM 764
vsmktags 168
VST 764

W
Watch tool window 74
Web Browser Setup 385
Web Browser Setup Options 714
web development 375
welcome 31
what is key 86
When tab key reindents 666
where is command 86
wildcards 130
window font dialog box 730
Window left margin 625
Window Menu 729
window ordering 646
windows 75
maximize/minimize 77
setting new window size 77
Windows style Browse for Folder dialog 636
Windows temp environment 704
Windows (printing on) 95
Windows 3.1 style open dialog 636
word boundary 671
word chars 665
Word completion 679
word help 777
word help file name 777
word navigation 196
word wrap 671
Word Wrap Options (Language-Specific) 670
workspace bookmarks 297
workspace files (listing) 585
workspace history list 769
Workspace Properties dialog 562
Workspace tag file only 649
workspaces 127
creating 130
managing 130
managing projects 131
opening and closing 130
sharing projects 131
third-party 132
workspaces and projects 127
wrap 543
Wrap at beginning/end 654
Wrap line length 695
wrap long lines 671
wrapping (comments) 317
Write List dialog box 147
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Write Selection dialog box 147

X
Xcode build methods 177
Xcode workspaces 132
XEDIT Line Commands 802
XEDIT line commands 790
Xft font support (disable) 760
XML 375
beautifying 377
DTD caching 384
toggle between begin/end tags 385
turn off auto-validate 770
XMLdoc Editor 376
XML Beautifier Advanced tab 383
XML Beautifier Attributes Values tab 381
XML Beautifier Comments tab 382
XML Beautifier dialog box 377
XML Beautifier Indent tab 377
XML Beautifier Schemes tab 383
XML Beautifier Tags tab 378
XML encoding 755
XML Formatting Options 375
XML symbol translation 395
XML toolbar 375
XMLdoc comments 315
XMLDOC Editor dialog box 376
XML/HTML Formatting 397
xml/html formatting
content wrap 592
enabling 397
enabling for current document 398
schemes 398
settings 402
tag layout 594
tags 401
XML/HTML Formatting dialog 397
XML/HTML formatting menu 397
XML/HTML Formatting Scheme Configuration dialog 590
XOR operator 488
X11 installation 48

Z
zooming windows 77

Symbols
.bak 699

Numerics
3 Way Merge Setup dialog box 610
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